Altium Wiki

Information and resources for electronic product designers

Skip to end of metadata
Go to start of metadata

Summer 08 Highlights

Altium Designer Summer 08 brings significant new and enhanced features to unify the design process, make project management easier, expand access to FPGAs and improve design productivity - helping you create a return on your innovation and stay ahead of today's complexity with the latest technology.

Design Insight, for example, makes project navigation through complicated design projects faster, easier and more intuitive. Automatic previews and context-sensitive navigation allows you to preview documents and trace nets without having to physically open multiple schematic, PCB, or text documents - a real convenience and timesaver! More flexible generation of output files and documentation allows better data management and design collaboration for your projects with Multiple Output Publishing.

Physical platform design has been upgraded to better support increased board densities and high-speed signaling common in electronics designs. Interactive Routing features incredibly powerful and new capabilities such as Push and Shove, Walkaround, Hugging and Auto-Complete modes, giving you more control over the routing process. Intelligent automatic completion lets you rapidly finish off complex multi-trace routing tasks. Internal plane views have been significantly improved for a more accurate representation and reduced potential for downstream manufacturing errors as well.

Having the ability to visualize a board in 3D gives a highly realistic, real-time view of the bare or assembled board - and the best part is that it's not a static model. Fully navigable and rendered on-the-fly, you can now make changes to the design and instantly see the result. PCB 3D Visualization has been further enhanced with more Display options that allow for easier configuration of multiple views, system level settings and improved support for 3D highlighting.

Support for direct linking to external STEP models enabling electronics designers to interactively adjust board layout, component placement and even component package choice to suit the proposed enclosure design is also possible - before the board is sent for prototype or manufacture! All ground breaking technology within the industry that reduces design iterations necessary to close the ECAD-MCAD loop and help you focus on true innovation and not just saving time-to-market.

Programmable device support makes it easier for customers to develop their own Wishbone peripherals without having any knowledge of the internals of the Wishbone bus. Virtual instrumentation rises to a whole new level of control with Custom Instrument, a fully customizable instrument that allows you to monitor and control signals within your FPGA design.

These are just a few of the new features in what we believe to be an exciting new major release of Altium Designer. Based directly on feedback from you, the engineers and designers developing designs, Altium Designer Summer 08 helps you keep pace with the speed of today's development. We're excited about the new features and technologies we're developing for this release and the reaction they are receiving, and we're sure that you'll be excited too!

Seeing is believing - read more and watch demos of Altium Designer

Altium's DEMOcenter gives you the opportunity to walk through the extensive design capabilities of Altium Designer featured as individual demos, each only taking a couple of minutes, making this a quick and easy way for you to browse the areas of most importance to you.
If you'd like to read more about updates in Altium Designer, as well as watch short videos about some of the exciting new features, then visit the What's New in Altium Designer page on the website and enjoy the action. Click the link below to read more and watch the videos.

Unified Design Management

New - Design Insight

Design projects have quickly become complicated, involving a large number of varied design documents each with potentially massive amounts of data. Faster, easier and more intuitive project navigation is on the way with new Design Insight. Design Insight provides a number of exciting features to help you navigate at the project, document and even connectivity level, allowing automatic preview without having to physically open multiple sheets.

Project Insight


Figure 1. Hover over your project icon in the Projects panel to see your project preview.

Project Insight provides you with a preview of all of the documents within your project. Clicking a document in the preview will make that document the active document. Project Insight is provided for Schematic, PCB and text documents.

Document Insight


Figure 2. Hover over your project icon and selected document in the Projects panel or Document Bar to see your document preview.

Document Insight provides you with a preview of your documents from both the Projects Panel and the Documents Bar. Clicking the Document Preview from either of these locations will make that document the active document. Document Insight is provided for Schematic, PCB and text documents.

Connectivity Insight

Connectivity Insight provides you with a list and preview of all documents in your project that are connected to the selected net object. Hover over or Alt +Double-click on a net object such as a port, sheet symbol, bus, power port, component or a harness to see Connectivity Insight in action.


Figure 3. Click on one of the documents in the hierarchy tree to navigate to that document.

A list of documents is displayed with the current document highlighted and in preview mode, with the selected net highlighted. Hover over the other documents in the list to see the selected net highlighted. Your selected net will remain highlighted on alternate sheets for ease of navigation. Compiling your project is necessary for Design Insight to work.

New - Cadence Allegro® PCB Importer

Altium Designer allows designers to unlock the potential of large-scale programmable devices as a system development and deployment platform, creating programmed device intelligence that can be used across multiple hardware domains. Because of this, it's important to be able to easily move to Altium Designer from older style legacy point tools to stay competitive.
Importing Allegro ASCII PCB (*.alg) designs can be directly translated into Altium Designer using the Import Wizard (File » Import Wizard). Options for layer mapping and configuring a report log are also available. Files are converted to Altium Designer PCB document format (*.PCBDoc) and are added to a PCB project (*.PrjPcb).
To translate your binary PCB designs (*.brd), you need to have Version 15.2 or 16 Allegro installed. Alternatively, you can use the Batch File included in your installation to translate your binary designs (*.brd) to ASCII format. In this way, you only need Allegro installed to convert all of your files to ASCII, which can then be directly translated in Altium Designer.


Figure 4. Tailored for Allegro users, you can easily drag and drop your designs from project folders directly from Windows Explorer into the Projects panel page.

Programmable Devices

New - Custom Wishbone Interface Component


In order to provide an easy, modular way to rapidly build FPGA-based system designs, Altium uses a non-proprietary Wishbone bus interface to connect together the various FPGA-based peripheral component blocks available for system construction. Until now, designers have not been able to easily create or import their own custom peripheral components to connect to a Wishbone-based system. But now designers can easily extend the functionality that is supplied with Altium Designer and create or import custom functionality through the new Custom Wishbone Interface component (WB_INTERFACE).

The Custom Wishbone Interface component enables you to build a custom Wishbone peripheral in a design, extending your 32-bit FPGA systems through the creation of custom FPGA logic and, what's more, you can build custom Wishbone peripherals without needing to know any details of the Wishbone bus. The end result is that this greatly increases the scope of applications that can be developed in Altium Designer and opens up the system for designers to build their own custom peripheral libraries, or to develop custom peripherals that can be used by others.

The Custom Wishbone Interface component has a fully configurable interface for transferring data to/from connected logic, and a Wishbone bus to interface with a host processor. The individual units of this configurable interface are referred to as 'items'. The interface can include a combination of one or more of the following items:

  • Internal Registers - which allow values to be read from, and/or written to, connected logic.
  • Command Sets - which allow operations to be enabled on connected logic.
  • External Address Ranges - which allow access to blocks of addresses on connected logic.

Customization is performed through configuration dialogs associated with the component, after placement on the OpenBus System or Schematic document.
Figure 5. Configure the Wishbone Interface to communicate with your custom logic as required and extend the capabilities of your design.
In addition to making the task of building custom Wishbone peripherals far easier, the Custom Wishbone Interface component also provides the ability to generate C code based on the items specified in the interface - simplifying interaction with the component from the embedded code running on the host processor.

New - Custom FPGA Logic Development in C

Altium Designer comes standard with a large selection of custom FPGA-based functionality available as royalty-free FPGA-based components. Components range from basic logic blocks right through to sophisticated peripherals and processor cores. These components can be used to rapidly construct FPGA-hosted systems.
To extend this supplied functionality, Altium Designer supports the design of custom logic blocks. Previously this involved using the FPGA library components to create custom logic functions at the schematic level, or defining custom logic using the Verilog or VHDL Hardware Description Languages - or a combination of all three. But now a new type of sheet symbol - a C Code Symbol - has been added to the system to allow blocks of C code to be added within the schematic design hierarchy.
Simply write the functionality required in Altium's code-aware C Editor and then sit back as Altium Designer's C-to-Hardware Compiler converts your code into VHDL or Verilog (depending on your defined netlisting preference). From the schematic sheet, the underlying C source file is referenced in much the same way as a schematic or HDL file. Instead of a sheet symbol however, the new C Code Symbol primitive is used. Each C Code Symbol represents one top-level exported function, resident in the referenced C source file.
Access to the parameters of the function is made using C Code Entries - placed on the symbol and functionally similar to sheet entries on a sheet symbol. These entries can be wired to other components on the schematic, allowing for transfer of data. The top-level function may call other C functions, which themselves may be distributed among several source files.
Depending on your preferred method of working, there are two ways to create the interface to your custom logic:

  • Place a C Code Symbol and add the required parameters - either by manually placing C Code Entries or by defining the parameters directly in the properties dialog for the symbol. Once done you can then use a command to generate a shell C source file for addition to your project.
  • Write your C code first and then use a command to generate the C Code Symbol and related C Code Entries automatically. If your source file contains multiple functions, you will be able to choose which function you wish to export.


Figure 6. Use a C Code Symbol to interface to your C-coded custom FPGA logic.

New - Custom Instrument

Moving hardware functionality inside devices such as FPGAs means that traditional circuit test methods using physical connections to signals traveling between components are no longer viable. In traditional FPGA design flows simulation has often been seen as a replacement for direct testing. But simulation is extremely difficult and time consuming when applied at the system level. This is overcome with virtual instrumentation.
Virtual instrumentation rises to a whole new level of control with Custom Instrument, a fully customizable instrument that allows you to monitor and control signals within your FPGA design.


Figure 7. Monitor and control signals in your design with your own, fully customized instrument.

Similar in look and feel to the existing DIGITAL_IO instrument, the interface is fairly intuitive. As part of the instrument's configuration you are able to create your own GUI - this interface is seen once the design is programmed into the target device and the instrument is accessed. A palette of standard components and instrument controls enable you to quickly whip up a useable panel. Use the various properties associated with a control to customize it further, even the title of the instrument.


Figure 8. Define the look, feel and operation of the instrument exactly how you want it.

Defined IO signals can be hooked up directly to the various controls in your custom GUI. However, for the passionate scripter configuration of the instrument is writing your own DelphiScript code to process IO as required. Scripts are fired whenever the instrument polls, and in relation to specified events.


Figure 9. Use scripting to provide even greater control when processing signal IO.

At the click of a button you can switch to editing your code within the more familiar scripting editor, complete with its syntax highlighting and code-related display benefits.
The configuration information itself is stored within a separate file (*.Instrument), allowing for portability of customized instruments between projects and installations - why use someone else's instrument, when you can take your favorite with you.

When an FPGA design is processed and a custom instrument is detected on the Soft Devices JTAG chain, Altium Designer needs to essentially retrieve this configuration information. There are two methods by which it does this, selectable by the user as part of the configuration:

  • From the project - the configuration information is retrieved from the corresponding .Instrument file for the instrument, which resides alongside the project file. The project must be open in order to show the instrument from the Devices view.
  • From the FPGA device - the configuration information is downloaded with the design to the physical device, and stored in Block RAM. It is retrieved directly from here and the project need not be open.
    The level of flexibility and customization enabled by the new custom instrument opens a new range of possibilities to designers working with soft device intelligence programmed into a target platform.

Enhanced - Configurable Logic Analyzer

Altium Designer Summer 08 brings with it a number of improvements to make the configurable Logic Analyzer instrument and Digital Waveform Viewer more intuitive and easier to use during debugging sessions.
Configuration and ease of use improvements for the instrument includes automatic selection of capture width, indication of memory required, ease of external memory selection and indication of used width for a signal set just to name a few.

Enhanced - Digital Waveform Viewer

More control over how captured signal information is presented in the Digital Waveform Viewer is now possible with this release. Support is enhanced for Wave Styles - the viewer will display signals using the applicable styles assigned to them as part of the Logic Analyzer's configuration. Styles are defined on the Wave - General page of the Preferences dialog (DXP » Preferences).

When defining a style, you can determine the color used for waveform display at both the individual signal (Color) and bussed signal (Group Color) level. You can also define the Extend Type (application of dotted extension lines) as Positive Edge, Negative Edge, Both or None.
Two default styles are provided: Clock and Default. The latter will be used for all signals unless you expressly assign a custom style during configuration of the LAX. These two styles, although editable in their graphical attributes, cannot be removed or renamed.

  • Signal Highlighting - right-click on a signal and use the new Highlight command to make the signal text bold and its corresponding waveform appear thicker.
  • Bus Order Reversal
    - right-click on a group (bussed) signal and use the new Reverse Bus Order command to reverse the bit order accordingly.
  • Optional Grid Lines - both vertical and horizontal grid lines can now be toggled ON or OFF. Controls are available from the Wave - General page of the Preferences dialog.

Enhanced - FPGA Tool Feedback


With Altium Designer Summer 08, feedback messaging from the Build stage of the Process Flow has been streamlined and made easier to interrogate.
Build (Vendor Tool) related messages are kept to a minimum in the Messages panel, with the ability to cross-probe from errors and warnings to the corresponding message in the Output panel. The latter becomes the focal point for more detailed build information.
The detail contained within the Output panel can be very extensive. To aid in finding the information you need in a fast efficient manner, search functionality has been added to the panel - simply hit Ctrl+F and away you go!

Board Level Design

Improved - Version Control

One of the traditional problems of extending version control to the electronics design process has been that at the board level, designs are largely graphical in nature. Even comparing different versions of the same files is not as simple to do as text-based files. The ability to compare graphical files is crucial to effective version control support within an electronics design context. Of equal importance is the ease with which designers can access and use their chosen version control system. Altium Designer solves these problems by building integration control directly into the product interface and providing a powerful differencing engine for the direct comparison of graphical files.
The Version Control System (VCS) in Altium Designer Summer 08 has been enhanced so that it fetches and updates revisions in the background, a great time saver with larger projects allowing you to carry on with your work with less interruption. In addition, you can also update the working copy of all of the files in the focused project with changes from the VCS repository. This command can be launched through Project » Version Control » Update Whole Project.

Improved - Internal Plane Representation


In Altium Designer Summer 08 plane support has been significantly upgraded and enhanced. Previously, internal planes did not accurately model the interaction of primitives (primarily pads and vias) within the plane leading to unexpected discrepancies in CAM output and resulting in significantly lower standards of analysis for internal planes compared with signal layers. Internal planes are now modeled and displayed in 2D and 3D with 100% accuracy in the PCB editor. DRC also includes live connectivity checking of planes and will detect net breaks caused by inadvertent plane splits, isolated pads and vias, and starved thermal relief connections.
Matched representation of the plane in both PCB and CAM is now ensured so that you can confidently model internal planes without worrying about the CAM output. This includes additional filtering options such as positive or negative CAM outputs for planes.
Internal planes have also been improved so that there is now true connectivity - where connectivity follows copper - on a plane with live connectivity checking. Design Rules Checking (DRC) will also detect breaks in a net on the plane layer caused by plane regions split into multiples, isolated pads or vias and starved thermal relief connections. 3D Visualization has also been improved to support improved internal plane representation. Plane connections, relief or direct can be seen on the individual plane layers when viewing the PCB in 3D.

New and Improved - Interactive Routing

When design speed is important, routing is a major factor in custom board design. Board densities are on the increase, as is are layer stacks and the prevalence of dense packaging technologies, making your routing job even trickier. The biggest improvements in routing - and therefore saving design time - are made by introducing interactive routing technologies, which that aid rather than than take control over the routing process.
Interactive routing tools in Altium Designer Summer 08 have been redesigned to do just that - for more power, ease of use and speed in features that are very intuitive to use and fast. Basic operation modes include fast and robust Push and Shove of tracks and vias, guided routing for rapid trace placement, automatic hugging of existing traces when routing, and improved route auto-completion. Modes can be used independently or in combination to provide excellent control in all routing situations.
Altium Designer offers, as standard, interactive length tuning for single nets and differential pairs, full differential pair support system wide, impedance-controlled routing, multi-trace routing, pin and part swapping, automatic FPGA pin optimization for routing all within an easy-to-use interface that is very intuitive.
Available from Place » Interactive Routing, the new interactive routing supersedes or extends functionality from previous versions while still feeling familiar in operation (Legacy 3D View and other older interactive routing tools have all been moved to Tools » Legacy Tools). Easy to use interactive routing shortcuts are found by hitting the tilde (~) shortcut key when routing. During routing, you can control the ability to route dynamically, guiding the routing path with the mouse, adding segments and rolling back unwanted segments. As with previous versions, left-click anchors the path up to the cursor position and you are still able to switch between modes on-the-fly, giving you complete control over the current route.

Push and Shove

Powerful and fast Push and Shove technology allows you plough through existing objects with ease, and under full rules-based control. It can push and shove tracks and vias, and can even shove objects with a via hanging off of the trace end. This is a real time-saving feature when you're routing through high-density and complex board areas.

Walkaround

A standard push dynamically updates and you can force walkaround an obstacle. Walkaround mode traces around obstacles and includes the option to Hug existing objects, such as traces. Walkaround mode, which traces around obstacles automatically, also has a force push option as well as a hugging mode which can be toggled on/off.
Guided routing makes short work of even the most complicated routing designs. A new powerful path-finding engine efficiently gets a trace from Point A to Point B by following your cursor path. You can still decide to continue on in the traditional fashion simply by clicking and continuing on as per previous behavior. If you change your mind on the current path, move the cursor back over the route and the trace automatically unwinds. Guided routing can be combined with Auto-Complete for maximum routing efficiency.

Hugging Mode

Trace hugging automatically follows the contour of adjacent objects so you don't have to manually do it. Hugging assists with refining the routed path by smoothing corners upon terminating the routing of the net. You can also swap to opposite route point, and switch leader trace to give you control over where to start or continue routing from. Just guide the cursor and you'll have perfect parallel trace groupings every time, in no time.

Auto-Complete

Auto-Complete can save quite a bit of time and repetitive actions by completing traces and routing an entire connection automatically with a simple CTRL
+ Click. Especially helpful for finishing off complex multi-trace routing tasks, this intelligent feature is available in any routing mode provided that the router can find a suitable path.

Improved - MCAD Support


Altium Designer's 3D capabilities have been enhanced to allow for direct linking to external STEP models, an intelligent 3D file format supported all major MCAD software - ground breaking technology within the industry that reduces design iterations necessary to close the ECAD-MCAD loop.
This means that electronics designers can bring mechanical assemblies or case designs done in MCAD software into Altium Designer and work directly with the case design as it is being done to ensure that the PCB will fit into the final enclosure. Interactively adjusting board layout, component placement and full interference/clearance checking between design objects and the case that surrounds them provides the real-time link between the electronic and the mechanical domains. Getting your designs to fit in the case can now be done by good management rather than luck!

Create board outline from STEP model

Create board outline from STEP model adds a powerful way to define the PCB board outline using a 3D model originating from an MCAD application, allowing a dynamic ability to define the board in 3D.
Launched from Design » Board Shape » Define from 3D body, this feature prompts the user to select a planar face within the 3D model which is used to create the board outline. Holes in the face are imported as either holes or board cutouts.
Figure 15. Once you have brought in a STEP model, you can pick a surface and create a board shape based on the model. Any holes are created automatically as cutouts

Cylindrical and Spherical 3D bodies

Designers can now directly link to the mechanical CAD world and unify ECAD and MCAD, effectively breaking down the barriers between design of the electronics and the case or physical housing that they reside in with improved STEP models support in 3D. When placing a 3D body onto a footprint in an open library, the shape can be configured as either a sphere or a cylinder by using Place » Place 3D Body and then opening the Properties dialog box for that 3D body (double-clicking on it).


The body is then generated and treated as a STEP model that can be placed at any angle or orientation by editing the XYZ and Z height properties. In this way, you can now create a host of objects not available through extruded modelling - lowering the need to exit Altium Designer in order to achieve complex 3D shapes.

Figure 16. Here a 3D body is generated into a STEP model with transparent coloring.
There is also the ability to assign a 3D body object to an external STEP model. The models can be embedded so that is becomes part of the PCB document, or linked to it. Linked models will always remain up-to-date in Altium Designer even if the source files change. You can also import STEP models such as housings and enclosures to visualize complete assemblies in the 3D workspace.

Visualization Control


New controls for visualization allow you to make changes such as opacity settings, to 3D bodies through a panel rather than individually selecting them in the workspace. Presentations of modeled boards can be manipulated to ease navigation and visual checking of dense modeling. There are also added benefits of adding transparent enclosures to commercial product packaging.
When viewing the PCB panel for an open PCB document, the panel now has an extra category - 3D Models. When selected, the user can then select All Components and the window will display all models used along with a sub-listing of any model currently highlighted. When highlighting the model from a listing, the properties of this component model can be altered from the Highlighted models drop-down menu. The sub-panel will allow the individual elements to be altered in the same manner.

Interference/Clearance Checking

Real-time interference and clearance checking can be done as you work, giving you immediate feedback while placing 3D bodies. Conflicts between models or assemblies can be seen and resolved before your board leaves the virtual world, saving valuable time.


Figure 18. Determine physical constraints on your board layout based on feedback from the model's clearance.
Clearance checking between 3D bodies is incorporated into Altium Designer's rules-based design checking system.

Design to Manufacture

Improved - Multiple Output Publishing

More flexible generation of different output files and documentation provides better data management and design collaboration for your projects with new Multiple Output Publishing. Designers can now consolidate multiple outputs into a single media type. For example, schematics, PCB, and BOM can all go into a single PDF output through the OutputJob editor.
The OutputJob editor has been enhanced to include a new Output Media column. Output Media view allows different sets of outputs to be created and configured independently. This can include configuring a number of Print Jobs, PDF jobs and File Generation jobs.
To create a new Output medium, copy and paste a set of compatible outputs into the Output Media column, then select the desired format. Alternatively, you can drag individual or multiple outputs into the Output Media column or select Add New Output Medium. Choose from either a Print Job (prints the outputs to your chosen printer) or a Publishing Job (creates a PDF).

You can also create an Output Media job for Output Generators that require file generation - Netlists, Reports and Pick and Place files. As you select each output medium, green arrows link up the selected outputs to the output medium. This displays what will be included in the output whenever you publish your project. You can easily add additional output generators to existing Output Media by dragging or copying and pasting the output generator onto the existing Output Media Job.

Support for Bill of Materials

The Bill of Materials can now be either printed directly or published into the same PDF file as the schematic and PCB through the OutputJob editor. This effectively makes it possible to consolidate all of the outputs into a single source document that can be shared throughout an organization. In addition, you will notice the option to export to PDF in the Bill of Materials dialog (Reports » Bill of Materials) as seen here.

Labels