Altium Wiki

Information and resources for electronic product designers

Skip to end of metadata
Go to start of metadata

より詳細な PCB 製造用のファイルを出力するために、Altium Designer では、基板製造に関するグラフィカルなドキュメントを作成できます。専用のファイルフォーマット、図面ツールに基づいた、新しい Altium Draftsman 図面システムにより、カスタムテンプレート、注釈、コールアウト、メモを含む製造、実装図を作成できます。

新しいDraftsman PCB 図面機能は、Altium Designer の拡張機能で利用できます。この拡張機能は、Altium Designer の Extension & Updates ページ (DXP » Extensions and Updates) から手動でインストール/削除、または更新できます。Installed タブ下に Draftsman の拡張機能が表示されます。更新を利用できる時は、Updates タブ下に表示されます。

主な特徴

Draftsman の図面アプリケーションは、従来の PCB 製造資料出力の付属機能として、またはその代わりに、よりグラフィカルな PCB 製造資料を作成するために利用できます。そして、要求に応じて、実装、製造図を自動で配置できます。また、手動で重要な詳細情報を追加したり、複数ページをハイライト表示できます。

この機能の主な特徴は、以下です:

  • ソース PCB ドキュメントから図面データを自動で抽出。
  • 複数ページのドキュメントを作成。
  • ドキュメントの各ページにテンプレートを適用。
  • カスタマイズしたテンプレートから自動で図面を生成。
  • 一般的な drawing view (実装ビュー、製造ビュー、断面ビュー、ドリルドローイング ビュー) に対応。
  • 3D モデル(特定の PCB レイヤに関する要件はありません)から生成したグラフィックを含む実装ビュー。
  • 詳細なレイヤ情報を追加したり、カスタマイズできる Layer Stack Legend。
  • 全ての基板の item、または選択した実装ビューの item のみ表示できる部品表。
  • コールアウトを配置して、BOM item の位置、または Notes リストの item を参照。
  • 実装バリアントの対応。
  • 図面オブジェクトや機能に関するユーザプリファレンス設定 (DXP » Preferences)。
  • PDF の印刷やエクスポート。
  • 出力ジョブで、Draftsman PCB 図面ファイルを新しいドキュメント出力として追加できます。


1ページ、または複数ページの Draftsman ドキュメントに、drawing view、オブジェクト、注釈を配置。

ドキュメントとテンプレートでの作業

Altium Draftsman アプリケーションでは、PCB 図面ファイル (*.PCBDwf) を作成、保存できます。また、シート(ページ)プロパティ (*.DwsDot) やドキュメント content (*.DwfDot) を定義するための、特定のテンプレートフォーマットを使用できます。指定した PCB drawing view やテキストが配置されたドキュメントを自動で反映するために、ドキュメントテンプレートを設定できます。最初に作成したドキュメントテンプレートでは、現在のシートテンプレートを使用してページプロパティ(サイズ、様式、余白等)を定義できます。

新しいドキュメントの作成

新しいDraftsmanドキュメントは、File » New » Draftsman Document コマンドを使用して、作成できます(New Draftsman Document ダイアログが表示されます)。

ダイアログでは、事前に定義してあるドキュメントテンプレート(インストール時には、3 種類用意されています)、または Default オプション(ブランクのA4 ドキュメントが作成されます)を選択できます。新しいドキュメントを作成する時、Sheet Template を適用できることに注意してください。 ボタンをクリックすると、Draftman Preferences ダイアログの Templates ページが表示されます(テンプレートディレクティブの場所が定義されています)。


指定したプロジェクトや PCB から、ブランク、またはテンプレートベースの Draftsman ドキュメントを作成。

Altium Designer で複数のファイルを開いている場合、Draftsman テンプレートの他に、特定の Project や 基板の Source Document を選択できます。その新しいドキュメントは、指定したプロジェクト(アクティブプロジェクトになります)の図面データと関連します。新しく作成したドキュメントは、指定したプロジェクトへ追加されます。

 

ダイアログの Layers チェックボックスは、Fabrication document template を使用した時、どのレイヤ(レイヤ構成で定義した)を使用して、Fabrication 図面を生成するか決めるためのものです。Drawing レイヤは、常に含まれます。

ドキュメント シート

PCB Draftsman ファイルは、複数シートのフォーマットです(個々のページ(シート)を設定して、それらに特定のタイプの製造情報を割り当てることができます)。シートは、Tools » Add sheetTools » Remove sheet コマンド、または右クリックメニューによるコマンドを実行して、追加、削除できます。

現在、アクティブなシート番号や、シートの合計数は、ワークスペース下部にあるステータスバーに表示されます。

シートプロパティ

Draftsman ドキュメントのページプロパティは、Sheet Properties ダイアログ(Tools » Sheet Properties を選択、または右クリックメニューから Sheet Properties を選択)から定義できます。

Sheet Properties ダイアログの設定では、ドキュメントの現在のページ、または全てのページの基本的な構造(サイズ、ボーダ設定等)を決めます。あるいは、ページフォーマットは、(カスタム)シートテンプレート ドキュメントを読み込んで、定義できます。


シート様式プロパティは、標準、またはカスタム設定を使用できます。または、シートテンプレートから割り当てできます。

フォーマットとサイズ

ダイアログの Format & Size タブを選択して、ドキュメントのサイズ/内容を手動で、またはテンプレートベースで設定します。そのオプションは以下です:

  • Custom template – 事前に定義されているシートテンプレートのページ設定が適用されます。テンプレートで定義したグラフィックや、シートサイズ、ゾーン、ボーダの余白定義を含むテンプレートデータは、そのページへ読み込まれます。PCB Draftsman の拡張機能では、標準のテンプレートが反映されます。カスタムシート テンプレートは、*.DwsDot フォーマットで既存のドキュメントを保存して作成できます(以下をご覧ください)。

     

    他の場所から別のシートテンプレートを直接、開くには、 ボタンを使用します。

  • Standard Sheet Size – ドロップダウンから選択した標準のシートサイズが適用されます。
  • Custom Size sheet – 入力したカスタムシートサイズが適用されます。

Apply to で、シート設定をアクティブページ(現在のページ)、または全てのページ(ドキュメント全体)に反映するか選択します。

余白とゾーン

ボーダと区分けを設定するには、ダイアログの Margins & Zone タブを選択します。そのオプションは以下です:

  • Margins – そのページの端から各ボーダラインまでの距離を定義します。
  • Zones – ボーダ内の横、縦のリファレンス分割数を入力します。

Apply to で、シート設定をアクティブページ(現在のページ)、または全てのページ(ドキュメント全体)に反映するか選択します。

テンプレートの作成

Altium Draftsman ドキュメントでは、ページプロパティを定義したり(シートテンプレート)や、新しいドキュメント用に、事前に決めた内容を定義する(ドキュメントテンプレート)ためにテンプレートを使用できます。双方のテンプレート共、現在、開いている PCB 図面ファイル(PCBDwf)をテンプレートタイプ(DwsDot、または DwfDot)として保存して作成できます。テンプレートドキュメントは、再度、開いてその内容やプロパティを変更できます。

シートテンプレート

シート(ページ)テンプレートには、シートサイズ、パラメータ、ゾーン、ボーダ設定を含むグラフィック情報があります。このエディタのグラフィックツールで作成したオブジェクト(ライン、四角形、円、テキスト)も含まれます(例えば、タイトルブロックやその内容)。シートテンプレートは、新しい、または既存の図面ドキュメントのグラフィックフォーマットを定義するために使用できます。また、Document Template の一部として保存されます。

シートテンプレートとして図面ドキュメントフォーマットを保存するには、File » Save Copy As (または、Save As) コマンドを選択して、save ダイアログの ファイルの種類Altium Draftsman Sheet Templates (*.DwsDot) を選択します。シートテンプレートと互換性が無い要素(例えば、配置した図面、または追加ページ)は、削除されます。互換性が無い要素がある場合、保存する前に、警告ダイアログが表示されます。

 

その他の Altium Designer のドキュメント(回路図、PCB 等)と同様に、Save As コマンドで、既存のソースファイル(Draftsman 図面ドキュメント)と別にシートテンプレートドキュメントとして保存されます。ソースドキュメント (*.PCBDwf) は、プロジェクトフォルダから削除されません。

より良い方法は、Save Copy As オプションを使用することです(ソースドキュメントを残したままで、新しいテンプレートが指定したディレクトリへ保存されます)。

保存したシートテンプレートは、Sheet Properties ダイアログから Draftsman ドキュメントページへ適用できる(ダイアログの ボタンを選択し、特定のシートテンプレートを指定して読み込みます)ことに注意してください。

ドキュメントテンプレート
ドキュメントテンプレートでは、Draftsman ドキュメントの内容や、その様式(任意)を定義します。このテンプレートでは、複数ページのドキュメント、ドキュメント属性に関するデータ(テーブル、リスト、図面タイプ等)、PCB の設計内容に依存しない図面エディタで作成した要素を対応しています。

図面ドキュメントフォーマットをドキュメントテンプレートとして保存するには、File » Save Copy As (または、Save As) コマンドを選択し、save ダイアログの ファイルの種類 Altium Draftsman Document Templates (*.DwfDot) を選択します。既存の図面ドキュメントの内容や属性(PCB デザインから抽出されたデータを除く)は、ドキュメントテンプレートとして保存されます。ソース図面ドキュメントに、特定のページ様式(シートテンプレートを適用している場合等)がある場合、それらのグラフィカル要素や属性は、新しいドキュメントテンプレートに保存されます。

ドキュメントテンプレート フォーマットと互換性が無い要素は、削除されます。互換性が無い要素がある場合、保存する前に、警告ダイアログが表示されます。

 

ドキュメントテンプレートでは、1 つの 製造ビュー のみ保存できます。これは、テンプレートを使用して新しい Draftsman 図面ドキュメントを作成する時、生成された製造図面(シートごとに 1 つ)のレイヤや内容は、特定の PCB デザインに依存するためです。

複数ページの Draftsman ドキュメントには、通常、実装図、ドリルテーブル、ドリルドローイング、レイヤ構成、部品表、製造図を含めます。ドキュメントテンプレートとして保存した時、PCB のデータは保持され、図面内容を反映できます。

その後に、新しい図面ドキュメントのテンプレートとして使用した時、プロジェクトの現在の PCB データが、テンプレート PCB データの代わりに読み込まれます。これにより、ドキュメントフォーマットやその内容が再現されます。

テンプレートの編集

シートとドキュメントテンプレートは、free document として開いて編集できます。File » Open を選択して、ブラウザのフィルタオプションから Altium Draftsman Sheet Templates (*.DwsDot)、または Altium Draftsman Document Templates (*.DwfDot) を選択し、テンプレートを開きます。

開いたドキュメントテンプレートには、テンプレートを作成した時に適用した PCB 設計データや、シートテンプレート プロパティが含まれています。ドキュメントテンプレートで、シートテンプレートのページプロパティを定義していて、シートテンプレートを変更した場合、再適用する必要があります。

ドキュメントオプション

PCB Draftsman ドキュメントに関するオプション設定は、Draftsman Document Options ダイアログ(Tools » Document Options メニューコマンドから表示)で定義できます。ドキュメントオプションは、図面ドキュメント全体に適用されますが、シートプロパティ 設定は、個々のドキュメントシート(ページ)に適用されることに注意してください。ドキュメントオプションとシートプロパティは、Draftsman ドキュメントに保存されます。


Draftsman ドキュメントプロパティは、図面ドキュメントの全てのページへ適用されます。

Draftsman Document Options ダイアログでは、Draftsman ドキュメントに関する以下の設定があります:

  • General タブ。全般的な設定:
    • Source – 同期する図面の PCB ファイルソースデータ。
      PCB Document メニューでは、現在のプロジェクトで利用できる基板を選択できます。選択した基板に基づいて、図面ドキュメントと PCB 間のリンクが再定義されます。
      Top/Bottom Assembly Layer メニューでは、コンポーネント Geometry のソースや RefDes の位置として基板のメカニカルレイヤを選択できます。このコンポーネントデータは、Component Display Properties ダイアログの Geometry Source、または Location ソースで、AssemblyDrawing オプションを選択した時に適用されます。
    • Grids – グリッド色や、グリッド間隔(サイズ)、細かいラインと粗いライン(乗算)の間隔を設定。
    • Variants – 選択したバリアントで実装しないコンポーネントを示す方法(非表示、またはメッシュ形状)。Board Assembly View モードの Properties パネルにある Variation メニュー(View の項目内)でバリアントを選択します。
    • Zones – ドキュメントボーダ内にあるゾーンのアルファベットと数字に適用するルール。
    • Scale 等 – これから配置するドキュメント表示の倍率や、現在のドキュメントの全てのシートに関するフォント、シート/ボーダ色を設定。
  • Parameters タブ。パラメータを表示、追加/削除。パラメータは、図面ドキュメント(例えば、タイトル、またはテーブル内)で使用できます。
    • パラメータの追加/削除 – カスタムパラメータを作成、または削除するには、 ボタンを使用します。
    • パラメータのフィルタ表示 – リストでフィルタ表示するには(カスタムパラメータは、常に表示されます)、System/Project/PCB Parameter オプションにチェックを入れます。カスタムパラメータ以外は、読み取り専用で、アスタリスクのサフィックス (*) が表示されることに注意してください。
  • Snapping タブ。 スナップオプション。全体的に無効にしたり (Shift+E)、以下について個々に選択できます;
    • Vertices – 四角形の角、ライン、または断面の端等。
    • Line centers – ラインの中心点。
    • Circle centers – 円の中心点。
    • GridGeneral タブの Grids 設定で定義したグリッド。
    • Boundaries – オブジェクトの端、または中心の延長線。
    • Snapping Distance – スナップする距離を定義(カーソルを近づけた時にスナップが効く範囲)。
  • Line Styles タブ。ドキュメントに配置するラインの太さや破線形状を定義。
    • Dash Patterns – 0.2mm(メートル系モードの時)単位で、破線ラインのライン/間隔を定義。例えば、Value に 20,10,20 と定義した場合、4mm、2mm、4mm の破線が繰り返されます(10mm の周期)。カスタムの破線は、 ボタンから作成できます。
    • Line Thickness – ラインの太さ。デフォルト値 .xxxx に戻すには、 ボタンを使用します。
  • Units タブ。ドキュメントに使用する単位と精度を設定。
    • Measurement Unit – 測定単位をインチ系、またはメートル系に設定。
    • Precision – 図面ドキュメント用に、基準の測定精度や許容差(少数点以下の桁数と最後の桁の丸め)を設定。測定用の許容差は、Properties パネルのTolerance の項目にあるTolerance Type オプションを選択して、表示できます。

drawing view での作業

Altium Draftsman アプリケーションでは、自動化した製造図を Draftsman 図面ドキュメントへ直接、配置できます。配置する図面タイプは、Drawing Views アイコン、またはPlace メニューから選択します。

Draftsman Properties パネル

ドキュメントに配置したら、図面のプロパティは、Properties パネルから編集できます。パネルを開いていない場合、配置した drawing view をダブルクリック、または drawing view を選択して右クリックメニューから Properties を選択、または作業領域の下にある  ボタンをクリックして表示できます。


パネルは、選択した drawing view、またはオブジェクトのモードや内容に自動で変わります。

パネルでは、図面ドキュメントに配置したオブジェクトのプロパティを表示して編集できます。パネルでプロパティを表示するには、オブジェクト、または view を選択します。

view モード(図面オブジェクトを選択して表示したように)で、いくつかの項目は、共通です。これらは、以下です:

  • Position – オブジェクトの回転角度(90º ステップ)を設定。
  • Scale – オブジェクトの表示サイズを Scale メニューから設定。または、1 に対する特定の数値を設定。0.9 は、90%(Use Custom Scale オプション)を表します。
  • Title – view のタイトル名、タイトル名のフォント/色を設定。システム、またはカスタム パラメータ は、タイトルに使用できます。Use Document Font チェックボックスにチェックを入れると、Draftsman Document Options ダイアログ(上記 をご覧ください)で定義したフォントスタイルが、配置した view に強制的に反映されます。

実装ビュー

指定したプロジェクト PCB の実装ビューは、Place » Board Assembly View コマンド、または Drawing Views オプションの アイコンをクリックして配置します。


配置した実装ビューは、移動、倍率変更、異なる面から表示できます。

この図では、カットアウト、穴、注釈を含むコンポーネントグラフィックや、基板外形が表示されます。コンポーネントグラフィックは、自動で生成され、以下の様々なデータが優先度に基づいて反映されます:

  1. コンポーネントの 3 次元モデル(3D モデル)(デフォルトで使用)。
  2. Top/Bottom Overlay レイヤによるコンポーネントのシルク(3D モデルを利用できない時に使用)。
  3. コンポーネントの範囲に関するグラフィック(その領域ボックス)(3Dモデルとシルクを利用できない時に使用)。

グラフィックを形成するために使用したコンポーネントの表示、デジグネータ属性、幾何学ソース(上記の1、2、3)は、Component Display Properties ダイアログ(Properties パネル(以下をご覧ください)から開きます)で変更できます。

 

The automatic generation of the drawing view does not rely on the availability of an additional board layer (for example, Top/Bottom Assembly).

実装ビューのプロパティ

Board Assembly View モードの Properties パネルでは、以下の設定があります(オプショングループを展開/折りたたむには、 ボタンを使用します):

  • Position – シート上の実装ビューの角度。
  • Scale – 図面倍率(ズーム)、ドロップダウンから比率を選択、またはカスタム値で設定。
  • Title – 図のタイトル名、フォント/色設定。
  • Styles – 基板やコンポーネントの外形に関する色、線幅/形状を設定。
  • Font – コンポーネントデジグネータのフォント設定。コンポーネントのグラフィックに合うよう、自動で縮尺するための最小、最大サイズも定義できます。Component Display Properties ダイアログの個々のコンポーネントに関するフォントスタイルは、無効になります。
  • View– 以下の表示設定;
    • View – 図の方向(上、下、側面から等)。
    • Display holes – 穴の表示に関するフィルタ。全ての穴 (All)、construction 穴のみ (Pads Only)、大きい穴のみ (Minimum diameter Only) を表示したり、または穴を非表示 (None) にできます。
    • Minimum Diameter – Minimum Diameter の穴を表示(上記)する時の、最小サイズ。
    • Variation – 利用できる場合、バリアントを選択します。実装しないコンポーネントは、表示されないか、または(緑の)メッシュ(Document Options 設定で決めた)で示されます。
    • Component Caption – コンポーネントの表題に関するパラメータソースを選択(Designator、または BOM Item reference)。
    • Show SMD Pads – チェックを入れると、表面実装部品のパッドが表示されます。表示する色を選択するには、ドロップダウンメニューを使用します。
    • Show Through-Hole Pads – チェックを入れると、スルーホールタイプのパッドが表示されます。表示する色を選択するには、ドロップダウンメニューを使用します。
    • Components ボタン – コンポーネントの表示オプションを設定するための Component Display Properties ダイアログが表示されます。コンポーネントのパッドを表示するには、Show Component Pads にチェックを入れます。

Component Display Properties

実装ビューでコンポーネントをどのように表示するか、Component Display Properties ダイアログ(Board Assembly View Properties パネルにある ボタンから利用できます)で設定します。

Component Display Properties ダイアログの Show メニューを使用して、様々なフォーマット(コンポーネント、クラス、フットプリント、BOM の項目)でコンポーネントプロパティを表示できます(フットプリントは、下図のように表示されます)。このダイアログでは、個々のコンポーネントの表示方法をコントロールできます。以下のオプションがあります:

  • Visible – コンポーネントの表示、非表示を切り換えます。
  • Geometry Source– コンポーネントを表示するために使用したデータソース:
    • Default – コンポーネント グラフィックは、3 つのオプション(3D モデル、シルク、領域ボックス)の優先度に従って、いずれかで表示されます。
    • Body projection – 利用できる場合、コンポーネントの 3D モデル。
    • Silk screen – シルク印刷レイヤ。
    • Bounding box – コンポーネントのパッドを含む領域。
    • AssemblyDrawing – メカニカルレイヤ(Document Options ダイアログで指定した)にあるコンポーネントのグラフィックデータ。
  • Color – コンポーネントグラフィックの色。
  • Reference marker display – コンポーネントの参照マーカーを表示/非表示(通常、コンポーネントの 1 番ピンにドットを表示)。
  • Show Designator – コンポーネント デジグネータの表示、非表示を切り換えます。
  • Location – コンポーネント デジグネータの位置設定。
    • CenterFit (デフォルト) – デジグネータは、コンポーネント グラフィックの中央に配置され、その中に収まるように自動でサイズが調整されます。
    • Center, TopLeft, Left, Right, 等 – デジグネータは、コンポーネント外形の近く(指定した位置)に配置されます。
    • AssemblyDrawing – デジグネータの位置とサイズは、指定したメカニカルレイヤ(Document OptionsTop/Bottom Assembly Layer 設定をご覧ください)に配置したコンポーネント デジグネータのプロパティ(通常、 .Designator の スペシャルストリング を使用)で定義します。
  • Font – コンポーネント デジグネータのフォント(Center/Fit オプションでは利用できません)。メカニカルレイヤのデジグネータ(Assembly View Location オプション)の場合、フォント スタイル は、Font オプションで決定しますが、フォント サイズ は、メカニカルレイヤのデジグネータで定義したサイズが反映されることに注意してください。
  • Hatching Pattern – コンポーネントの側面を表示するためのパターンと色(例えば、断面ビューで表示する時等)。


実装ビューで表示するコンポーネントのグラフィックと注釈を設定。

Component Display Properties ダイアログでは、フィルタ機能を使用して(各項目で アイコンを使用します)、複数の項目を容易に検索、変更できます。フィルタのドロップダウンから目的の項目を選択し、選択した属性でフィルタ表示できます。複数のフィルタオプションを適用できます。また、ダイアログの下部にあるチェックボックスを使用して、フィルタを無効、または削除できます。


特定のテキストクエリでフィルタが実行され コンポーネントを分類。または、カスタムフィルタでクエリを指定(下図)。

より高度な、または複合のフィルタを作成するには、フィルタのドロップダウンリストから Custom オプションを選択します。

製造ビュー

指定したプロジェクト PCB の製造ビューは、Place » Board Fabrication View コマンド、または Drawing Views オプションの アイコンをクリックして配置します。


Draftsman 実装ビューは、両側から(または、反転)表示できます。また、ポリゴンを塗り潰し、または外形で表示できます。

製造ビューのプロパティ

Board Fabrication View モードの Properties パネルでは、以下の設定があります:

  • Position – シート上の製造ビューの角度。
  • Scale – 図面倍率(ズーム)。
  • Title – 図のタイトル名、フォント/色設定。システム、またはカスタムパラメータは、テキストプロパティ欄(例えば、下図の Title にある Layer Name と Scale パラメータ)で使用する場合があることに注意してください。
  • View– 以下の表示設定;
    • Layer – この図で表示するレイヤ。
    • View – 図の方向(上、または下)。
    • Drawing Mode – 基板の導体を表示する方法: 塗り潰し (Full)、またはライン (Simplified)。
    • Polygon Fill Mode – ポリゴンを表示する方法: 塗り潰し (Filled)、斜めの平行線 (Hatched)、外形 (Outline)。
    • Board Line Style – 基板外形のラインの種類、色、幅。

Drill Drawing ビュー

選択した PCB の Drill Drawing ビューは、Place » Drill Drawing View コマンド、または Drawing Views オプションの アイコンをクリックして配置します。


配置した Drill Drawing では、特定のドリルペアに関する穴を、定義したシンボルで表示できます。

Drill Drawing ビューのプロパティ

Drill Drawing View モードの Properties パネルでは、標準のdrawing view設定(例えば、Position、Title、View 等)があります。そのパネルでのその他のプロパティ設定は以下です: 

  • Layer Pairs (View の下) – drawing view に表示するためのドリルレイヤペアをリストから選択します。
  • Configurations (Drill Symbols の下) – Drill Symbol Configurations ダイアログ(以下をご覧ください)を使用して、ドリルシンボルのグラフィックやサイズを設定します。

ドリルシンボルの設定

選択したパラメータ(項目)ごとにシンボルが分類された穴データの表が、Drill Symbol Configuration ダイアログに表示されます。このダイアログは、Drill Drawing View モード(上記の通り)の時、Properties パネルの ボタンをクリックして表示します。


指定した属性で分類された、穴シンボルのグラフィックを設定。

ダイアログの穴データの表では、シンボルのグラフィックやサイズを設定できます。Grouping ドロップダウンメニューにあるパラメータを使用して、選択した基準で穴を分類し、シンボルが割り当てられます。

例えば、上図の基準では、サイズ、Plated、許容差で穴が分類されます。そのため、共通してこれらのパラメータ値がある穴は、1 つのドリルシンボル下に集約されます。それに反して、分類基準を 'Drill Layer Pair' に設定した場合、全ての 穴が 1 つのシンボルにまとめられます。この PCB では、そのパラメータ値が、全ての穴に相当するためです(この PCB デザインでは、1 つのドリルレイヤペアのみ使用されています)。

Drill Drawing ビューや、配置した Drill Table でのドリルシンボルは、Drill Symbol Configurations ダイアログの Symbol Graphics メニューから選択します。シンボルは、グラフィック形状や文字を対応しています。

詳細図

Draftsman ドキュメントの詳細図の機能では、指定した領域の詳細な拡大図を配置できます。詳細図の拡大倍率、ラベル、ライン属性は、Board Detail View モードの Properties パネルで設定できます。

詳細図を配置するには、Place » Board Detail View コマンドを選択するか、または Drawing Views ツールオプションの アイコンをクリックします。配置手順は以下になります:

  • drawing 上で、詳細図を表示したい箇所の中心をクリックします。
  • 詳細図を表示したい箇所の半径の位置までマウスを移動し、クリックします(詳細図のソース)。
  • 詳細図の拡大図を配置する箇所でクリックします。
  • 詳細図をソース領域と関連付ける設定を行うには、Properties パネル(Board Detail View モード)の ViewStyle オプションを使用します。

詳細ビューは、全ての基板図(実装ビュー、製造ビュー、断面ビュー、ドリルドローイング ビューを含む)で追加する場合があります。

断面ビュー

断面ビューでは、PCB 実装ビューで指定した箇所をカットして断面を表示できます。PCB の 3D データを取得し、指定したカット位置で断面を作成します。断面ビューは、実装ビューで作成できます。そして、断面ビューを配置後、断面パラメータを変更する場合があります。

断面ビューを作成するには、Place » Board Sectional View コマンドを使用するか、または Drawing Views ツールバーの アイコンを選択します。下図の B-B の断面を作成するには、以下の手順を実行します:

  1. 実装ビュー上にカーソルを置きます。最初に配置してある横のカットライン(A-A)は、クリックして移動できます – カットラインの方向(縦、横)を切り換えるには、スペースバーを使用します。
  2. カットラインの位置を設定するために、クリックします。
  3. 表示方向(カットラインの矢印で示された)を設定するために、カーソルを移動しクリックします。
  4. 新しい断面ビューをドラッグして配置します。

 

断面ビューは、配置した後、新しい位置へドラッグ移動できます。または、実装ビュー上のカットラインを移動できます。後者を行うには、実装ビュー上でカットラインを選択してからドラッグ移動します。断面ビューのグラフィックは、それに応じて更新されます。

Board Section View モードのProperties パネルでは、断面ビューに関するその他のオプションがあります(例えば、その倍率、ラベル、形状、方向等)。

  • 既存の断面ビューのサイズと角度(90º ステップで)を定義するには、PositionScale オプションを使用します。
  • カットや断面の表示を設定するには、以下の View オプションを使用します:
    • Positional Mode では、カット方向(横、縦)を設定します。また、Flip View Direction オプションでは、カットした断面の表示方向を設定します。カットライン方向の矢印は、それに応じて、変わります。
    • Slice Section オプションでは、カットラインの後ろにあるオブジェクトを非表示にできます。断面ビューの '背景' にあるオブジェクトを削除します。
    • Board Cut Fill Style オプションでは、カットした基板断面の表示形式を設定します。
    • Display Mode オプションでは、カットライン端の矢印形状を設定します。Show Connector Line では、カット矢印間にあるラインの表示、非表示を切り換えできます。
  • 実装ビュー上に配置したカットラインの表示形状を決めるには、以下の Styles オプションを使用します:
    • Cutting Line Style オプションでは、ライン幅、形状、色を定義します。Connector Line Style では、カット矢印間にあるラインのプロパティを設定します。
    • Arrow Style オプションでは、カット矢印先端の形状と幅を設定します。

レイヤスタック レジェンド

Draftsman ドキュメントのレイヤスタック レジェンド図では、拡大した断面ビューとして基板の内部構造を表示できます。それには、各層に関する内容説明や情報(各層に関連するガーバーファイルを含む)があります。

デフォルトで、各層の情報は、Layer Stack Manager ダイアログ(PCB エディタでの Design » Layer Stack Manager)で定義した Board Layer Stack の属性から読み込まれます。しかし、層の属性は、Layer Stack Legend モードの Properties パネルで編集できます – 以下をご覧ください。

レイヤスタック レジェンド図を配置するには、Place » Layer Stack Legend コマンドを使用するか、または Drawing Views ツールバーの アイコンを選択します。


配置したレイヤスタック レジェンドには、指定した PCB に関するレイヤ構成のデータが読み込まれ、それらの情報(層の厚さやドリルペアを含む)が表示され ます。

レイヤスタック レジェンドのプロパティ

レイヤスタック図に表示する方法を設定するには、Layer Stack Legend モードの Properties パネル(配置した図をダブルクリックするか、または右クリックオプションからProperties を選択して表示します)を使用します。パネルには、配置したレイヤスタック レジェンド図の詳細な微調整ができる属性設定があります。パネルオプションのグループを展開/折りたたむには、 ボタンを使用します。

このパネルでの、より重要な設定は以下です:

  • View WidthLayer Heights (View Styles 欄) – レイヤスタック図の表示方法を決めます。Heights オプションでは、標準の一次元の図を選択します(層の深さ(高さ)が、実際の層の厚さと比例した図や、層の高さを表に合わせた図)。
  • Show Drill Pairs (View Styles 欄) – 基板に割り当てられているドリルレイヤペア(PCB デザインの Layer Stack で定義した)のドリル穴を表示します。
  • Scale (View Styles 欄) – 実際の層の厚さと比較して、層の倍率を設定します(Layer Heights オプションが、'Real Width' モードである必要があります)。min/max Layer Height 設定では、層高さの倍率の範囲を決めます。
  • Source (Data 欄) – 図に含めたデータのソース。リジッドフレキシブル基板のような、異なる構造の基板を扱う時、様々な構成を選択できます。
  • Configurations (Settings 欄) – ボタンをクリックすると、Layer Information ダイアログが表示されます。ここでは、層のデータや情報を編集できます。
  • パネル内のその他のオプションは、明確ですが、値を変更したり、オプションを切り換えて設定します。

レイヤスタック レジェンドの情報

Layer Information ダイアログでは、Layer Stack Legend 図の表に表示する層情報をコントロールできます。このダイアログを開くには、Layer Stack Legend モードの Properties パネルの Settings 欄にある ボタンをクリックします。

Layer Information ダイアログには、以下の編集オプションがあります:

  • 外側にある層(Paste、Solder Mask、Silkscreen overlay)の表示を切り換え。
  • 各層の表示色を定義。
  • 表の項目を非表示、移動、名称変更。また、表の項目を追加、削除できます。
  • 表内にあるセルの内容を編集。セルの内容は、最初に基板のレイヤ構成データから読み込まれます。しかし、一度、手動で編集すると、基板データから更新できません(Tools » Update Board)。
  • Total の情報(表の下部に表示)を定義。ここには、デフォルトで基板厚の合計が表示されますが、名称変更、またはカスタムの値に設定できます – この下部の表示は、Properties パネルの Table Styles 欄にある Show Footer オプションで切り換えできることに注意してください。

 

Layer Stack Legend 図には、レイヤ構成や情報オプションが定義され、PCBエディタで定義されている Board Layer Stack 設定に影響を及ぼさないことに注意してください。

注釈と図面ツール

Altium Draftsman では、重要な情報を追加するための図面、注釈機能があります。これらには、自動化されたメモやハイライト表示するシステム、図面機能が含まれています。寸法線機能は、実装図 ビューで利用できます(Place メニュー、または Drawing Annotations ツールバーのアイコンを使用)。

寸法線

寸法線は、オブジェクト外形の長さ、サイズ、角度、または指定したオブジェクト間の距離を表示するために、実装図ビューに配置します – また、寸法線は、実装図の 断面ビュー に追加する場合もあります。寸法線を配置するには、Place メニューから種類を選択、またはツールバーの Dimension ドロップダウンメニュー () から選択します。

Linear Dimension(線指定)

linear dimension は、オブジェクト外形の端、またはオブジェクトの 2 点間に配置できます。これを配置するには、以下を行います:

  1. Linear Dimension ツール:  を選択します。
  2. オブジェクトの端から寸法線を配置するには、カーソルをオブジェクトの端へ移動し、ハイライト表示した箇所でクリックします。そして、カーソルを移動し、クリックして寸法線を配置します。
  3. 2 点間から寸法線を配置するには、カーソルを最初の位置へ移動し、ハイライト表示(ドット)した箇所でクリックします。同様に、2 番目の箇所でクリックします。そして、カーソルを移動し、クリックして寸法線を配置します。
     

寸法線は、配置した後、移動できますが、その角度の平面内(横、縦等)でのみです。配置した寸法線の属性は、dimension モードの Properties パネルで編集できます。

Dimension モードのパネルで利用できる主なオプションは、以下です:

  • Value – ドキュメントで設定されている単位で、測定した寸法線が表示されます。尚、Override Value With オプションを使用して、別の値を表示できます。
  • Units – このオブジェクトの単位を設定します(詳細については、以下の Measurement units をご覧ください)。
  • Tolerance – 許容差 +/- 値の表示方法を設定します。
  • View – 寸法線に対する、寸法線の文字や矢印の位置を設定します。
  • Appearance – 矢印の形状や、ライン幅、形状、色を設定します。
  • Text prefix/suffix – 寸法線の文字へプリフィックスと/またはサフィックス文字を追加します。例えば、~ と  nom をそれぞれ設定し、寸法線の値が 10.5 の場合、~10.5nom となります。パネルの Units の項目で単位名の表示が有効な場合、単位名のサフィックス(例えば、mm)が表示されます。

 

測定単位:

Draftsman ドキュメントへ適用する単位(メートル系、またはインチ系)は、Draftsman Document Options ダイアログ (Tools » Document Options) のMeasurement Unit 設定で定義することに注意してください。しかし、寸法線/半径、ドリル/部品表、Layer Stack Legend のようなオブジェクトに関するデフォルトの単位は、Preferences ダイアログ (DXP » Preferences) の Draftsman – Primitive Defaults ページで設定できます。そのタイプの新しいオブジェクトを配置する時、これらの設定は、ドキュメントのベースの単位より優先されます。

配置したオブジェクトの単位は、Draftsman Properties パネルの Units オプションで変更できます。

Radial Dimension(半径)

radial dimension は、実装図で円形の穴に追加できます。これを配置するには、以下を行います:

  1. Radial Dimension ツール:  を選択します。
  2. 目的の穴の上にカーソルを置き、ハイライト表示します。それから、クリックします。
  3. 寸法線のグラフィックを、クリックして配置します。

Radial dimension は、Linear Dimension と同様の方法で、移動(選択してドラッグ)、または編集できます。また、配置した寸法線は、Radial Dimension モードのProperties パネル(配置した radial dimension をダブルクリックします)で編集できます。

 

Altium Designer は、単位(mm、または mil)を含む、手動で入力した寸法線を自動で検出(必要であれば、変換)することに注意してください。入力した寸法線の単位が適切でない時、ドキュメント、またはオブジェクトで設定した単位が数値に反映されます。

Angular Dimension(角度)

angular dimension は、実装図で 2 つのオブジェクト間の端に追加できます。これを配置するには、以下を行います:

  1. Angular Dimension ツール:  を選択します。
  2. 最初のオブジェクトの端にカーソルを置き、ラインをハイライト表示してからクリックします。2 番目のラインを同様にクリックします。
  3. 寸法線のグラフィックをクリックして配置します。グラフィックは、2 つのラインが交差する内側、または外側に配置できることに注意してください。

Angular dimension は、Linear Dimension と同様の方法で、移動(選択してドラッグ)、または編集できます。また、配置した寸法線は、Angular Dimension モードのProperties パネル(配置した angular dimension をダブルクリックします)で編集できます。

Callout

Draftsman ドキュメントの Callout では、コンポーネント、一般的なオブジェクト、実装図ビュー、部品表に同期した表示、Note items に関する詳細情報を配置できます。Callout のソーステキストは、カスタムで入力したり、指定した注釈へリンクできます。または、自動で BOM item を参照できます。

Callout を配置するには、以下を行います:

  1. Callout ツール:  を選択します。
  2. Callout をカスタムテキストで配置するには、図面要素がハイライトされない箇所をクリックし、Callout のポインタを配置します。そして、再度、クリックし Callout を配置します。Properties パネルで、Callout テキストを編集します。既存の Callout は、パネルの Source グループ内にある Source Type リストで Custom Text を選択して、Custom Text 形式に変更できます(下図をご覧ください)。
  3. BOM のコンポーネントと自動でリンクするには、コンポーネントの外形にカーソルを移動してハイライト表示し、クリックします。そして、再度、クリックしCallout を配置します。BOM が図面上に配置されている場合、そのコンポーネントに相当する BOM の項目の番号が、Callout に表示されます。
  4. Note へ参照するには、Callout を配置し、Properties ダイアログの Source グループ内にある Source Type で Note Item を選択します(下図をご覧ください)。Note Item のドロップダウンリストから、Note の番号を選択します(Note のリストに、あらかじめ入力してある必要があります)。

Callout テキストを配置して、そのコンポーネントに相当する BOM の項目とリンクしたり、Note Item を参照、またはカスタムテキストを表示できます。

Callout を配置する時、type は、以下のように、選択したソースオブジェクトに基づいて自動で選択されます:

  • 何もない箇所を選択する(ハイライト表示されません)と、Custom Text callout が作成されます(上記のステップ 2 をご覧ください)。
  • コンポーネントの外形を選択すると、BOM Item callout が作成されます(上記のステップ 3 をご覧ください)。

Note Item を参照させる、または既存の Callout を他のタイプへ変更するには、Callout モードの Properties パネルにある Source の項目で Source Type を選択します。

Note

Draftsman ドキュメントの Note Item のリストには、文字を配置できます。これは、Callout で参照でき(上記をご覧ください)、Note モードの Properties パネルで設定、編集できます。

Note Item を配置するには、Insert Note ツール を選択してから、図面領域でクリックします。文字や番号アイコンの形式は、Properties パネル内で編集できます。Add/Delete ボタンを使用して、テキストを追加、削除できます。また、Up/Down ボタンを使用して、テキストの順番を設定できます。


Properties ダイアログの Note Item リスト内を選択して、その内容を編集。

事前に設定してあるドキュメントパラメータを新しい Note へ追加するには、以下の手順を行います:

  1. Note Item を選択します。それから、Properties パネルで ボタンを選択します。
  2. 文字を入力してから、 ボタンを選択し、Document Parameters ダイアログを表示します。
  3. リストから既存の(システム)パラメータ、またはカスタムパラメータを選択します。カスタムパラメータは、Draftsman Document Options ダイアログ (Tools » Document Options) のParameters タブで追加できることに注意してください。
  4. OK をクリックします。新しい Note へ参照パラメータを追加できます(下図の note 4)。

BOM とドリルテーブル

PCB Draftsman ドキュメントでは、Bill Of Materials (BOM) とドリルシンボル/データテーブルを配置して、Properties パネルで設定できます。PCB ファイルから直接、表形式データが反映され、PCB の製造、実装プロセスに関する重要な情報を容易に伝達できます。

BOM/Drill 配置オプションは、Place メニュー、または Drawing Annotations ツールバーのアイコンから利用できます。

BOM テーブル

BOM テーブルを配置するには、BOM テーブル配置ツール を選択し、図面ドキュメント上でクリックします。

配置したテーブルをダブルクリックし、Bill of Materials モードの Properties ダイアログ(BOM テーブルの表示属性やデータ内容を含む設定オプションがあります)を表示します。Data Filtering オプションでは、選択した PCB のバリアント(バリエーション)、と/または、ドキュメント上に配置されている 実装ビュー を選択して(デフォルトは、'All' です)、その情報を BOM へ反映できます。

 

新しく配置する BOM テーブルのプロパティは、Draftsman のプリファレンス (DXP » Preferences – Draftsman) で定義できることに注意してください。

テーブルのデータ欄を管理するには、パネルの Columns の項目を使用します。しかし、その欄の分類や内容は、以下で説明している通り、BOM 自体がどのように設定されているかに依存します。


配置した BOM テーブルの欄を、Properties パネルの Columns の項目で編集。

Bill Of Materials Configuration ダイアログ(Properties パネルの Configurations の項目にある ボタンをクリックします)で、BOM テーブルの内容や分類するデータを設定します。このダイアログでは、以下の BOM 設定オプションがあります:

  • Data Source – どの PCB プロジェクトデータファイルを BOM item リストに使用するか定義(デフォルトで、これは現在の Board デザインです)。Project オプションでは、指定した PCB プロジェクトの全てのデザインファイルから BOM データが抽出されます。
  • Grouping Key – どのコンポーネント属性で、BOM item を分類するか(一行で)定義。これは、同じタイプのコンポーネントが一緒になるように、一般的に Comment(また、Footprint も)に設定します。

 

回路図ドキュメントのカスタム コンポーネントパラメータを含む、全てのプロジェクトデータを反映するには、Data Source メニューから Project オプションを選択します。

Properties パネルの Columns の項目では、Up/Down ボタンを使用して、欄の順番を変更できます。また、欄を削除、追加できます。テーブルで新しい欄を追加するには、 ボタンを使用します。リストの欄をリセットするには、 ボタンを使用します。

ドリルテーブル

ドリルテーブルを配置するには、ドリルテーブル配置ツール を選択し、図面ドキュメント上でクリックします。

配置したテーブルをダブルクリックし、Drill Table モードの Properties ダイアログ(ドリルテーブルの表示属性やデータ内容(Data Filtering や Column の設定による)を含む設定オプションがあります)を表示します。パネルの Units の項目では、寸法の項目(例えば、穴サイズ欄等)に 1 つ、または両方の単位(mm、または mil)を設定できることに注意してください。

テーブルデータのソート順、欄の表示を管理するには、パネルの Columns の項目を使用します。ソート順ボタン () で、昇順、降順に切り換えでき、ソートは、複数の欄へ適用できます。


ドリルテーブル欄の表示、ソート順を設定。ドリル穴のシンボルは、配置した Drill Drawing ビューConfiguration ボタンの通りに定義されます。

ドリルテーブルのシンボル形状や、ドリル穴タイプの分類は、Drill Symbol Configurations ダイアログ(パネルの Drill Symbols 下にある ボタンをクリック)で設定します。これは、Drill Drawing View モードのパネルから表示したダイアログと同じですが、Drill Table で有効にした(visible にした)欄のみ表示されます。この 2 つの Drill Symbol Configuration ダイアログは、同じソースから読み込まれており、連動していることに注意してください。

グラフィカルツール

Draftsman では、基本的なグラフィカル要素を配置できます。これは、Place メニュー、または Drawing Annotations ツールバーにあるグラフィカルツールのドロップダウンメニュー () から実行します。

クリックして、グラフィック要素の最初のノードを配置します。再度、クリックして、2 番目のノードを配置します。これにより、そのサイズが決まります。つまり、ラインの長さ、円の半径、四角形、またはテキストボックスの対角の頂点間の距離、配置した画像の寸法です。

配置したグラフィカル要素は、選択からドラッグして、または、複数の要素を選択(Ctrl-shift + クリック、またはマウスの領域で囲って)してからまとめて移動できます。個々のノードも、選択して移動できます。詳細なオプションは、配置したグラフィカル要素をダブルクリックし、Properties パネルで設定できます。テキストボックスの内容は、パネルで定義し、ドキュメントパラメータを含めることができることに注意してください。

DXF インポート

Draftsman では、その他のグラフィカルオプションがあり、File » Import from DXF メニューコマンドを使用して標準の DXF ファイルをインポートできます。Windows のファイルブラウザで *.DXF、または *.DWG ファイルを選択してから、DXF Import Settings ダイアログの以下のインポートオプションを設定します:

  • Units – ソースファイルと一致する、メートル系、またはインチ系の単位を選択します。
  • Default Line Width – インポートするグラフィックファイル内のオブジェクトに関するデフォルトのライン幅を選択します。Draftsman での 'normal' のライン幅は、0.2mm に設定されています。
  • Default Font Family – ソースファイル内のテキストを表現するためのデフォルトのフォントを選択します。

 

DXF ソースファイルのグラフィックは、Draftsman の標準のグラフィカル オブジェクト(ライン、円、四角形、テキスト)に変換されることに注意してください。そのため、個々のオブジェクトは、Properties パネルで編集できます。

Documentation Outputs

Draftsman ドキュメントは、Altium Designer のその他のグラフィックベースのドキュメント(回路図、PCB 等)と同じ方法で、印刷、出力ファイルとして生成できます。

印刷、または PDF へエクスポート

図面ドキュメントを印刷するには、メインメニュー(または、Ctrl+P)から File » Print を選択します。そして、通常の方法で print options を選択します。print ダイアログでページ選択や、プリントプレビューのサイズを変更できます。

図面ドキュメントを単一、または複数ページの PDF ファイル(ドキュメント構造で決めた通り)でエクスポートするには、メインメニューから File » Export to PDF を選択します。

出力ジョブへ追加

Draftsman 図面ドキュメントは、既存の出力ジョブファイルを開いて、または新しい出力ドキュメントを作成(File » New » Output Job File)して、出力ジョブへ追加できます。

Draftsman ドキュメントを出力ジョブへ追加するには、Documentation Outputs の項目の Add New Documentation オプションを選択し、Draftsman >> 新しく追加した出力ファイル (*.PCBDwF) を選択します。container オプションで PDF を選択し、Draftsman ドキュメントに関連する Enable オプションをクリックします。

インストールとプリファレンス

Draftsman PCB 図面機能は、Altium Designer の Draftsman software extension で利用できます。これは、Vault Explorer のようなその他の software extension と同様に、Altium Designer インストール時に自動でインストールされます。

この拡張機能を手動でインストールするには、Extension Manager (DXP » Extensions and Updates) で Purchased タブを選択し、Draftsman extension の アイコンをクリックします。そして、Altium Designer を再起動します。


インストールした後、新しいバージョンをダウンロードできる場合、Draftsman アイコンは Updates タブ(Extensions & Updates 下)にも表示されます。

インストールしたら、この拡張機能が、Extension Manager の Installed タブ下に表示されます。新しい Draftsman ドキュメントファイルを作成する機能を含む Draftsman 図面機能は、回路図、または PCB プロジェクトドキュメントを開いている時、利用できます。

 

Altium Designer の更新で、Draftsman 拡張機能を自動でインストールしたくない場合、Extension Manager の Configure Platform ページ – DXP » Extension and Updates, Installed タブ, Configure リンクにある Draftsman extension オプションのチェックを外します。 をクリックし、変更を適用します。これを実行すると、Draftsman 拡張機能はアンインストールされることに注意してください。

プリファレンス

この拡張機能のプリファレンスは、Preferences ダイアログ (DXP » Preferences) の Draftsman の項目で利用できます。

Draftsman プリファレンスの Primitives Defaults ページでは、Draftsman ドキュメントで配置する図面やオブジェクトのデフォルト値を設定できます。オブジェクト、または図面をドキュメントに配置したら、デフォルト値に関係なく Draftsman Properties パネルで自由に設定できます。

Templates プリファレンスページは、Draftsman シートやドキュメントテンプレートの場所を定義するために使用します。


Draftsman プリファレンス設定では、PCB ドキュメントに配置する図面やオブジェクトのデフォルト設定を定義します。図面やオブジェクトを配置したら、デフォルト設定に関係なく、Draftsman Properties パネルで 自由に設定できます。

Labels
  • None