Altium Wiki

Information and resources for electronic product designers

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Image Added

...

回路図編集の要点

...

概要

...

Image Removed

Column
width25%

English

Column
width5%

Image Removed

Column
width25%

中国

Column
width5%

Image Removed

Column
width25%

日本語

Section
Column
width5%

Image Removed

Column
width25%

Deutsch

Column
width5%

Image Removed

Column
width25%

Français

Column
width5%

Image Removed

Column
width25%

한국어


...

width5%

...

width25%
Column
width5%

Image Removed

Column
width25%

Русский

...

width5%

...

width25%

このアプリケーションノートでは、Altium Designerでの回路図オブジェクトの配置や編集方法を紹介します。

Application Note AP0109 (v2.3) March 14, 2008

 

 

 


このアプリケーションノートでは、回路図エディタで使用される一般的なデザインオブジェクトの配置と編集方法の概要を紹介しています。ワイヤやパーツなど、複雑なオブジェクトに関しては、より詳細な説明が記載されています。

オブジェクト配置の基本

グリッドとカーソル

回路図エディタでオブジェクトを配置する前に、容易に配置を行えるよう、グリッドを設定します。Altium Designerでは、表示用のビジブルグリッド、配置用のスナップグリッド、接続箇所の作成を補助するエレクトリカルグリッドの3種類のグリッドが用意されています。グリッドは、ドキュメントオプションになり、個別のデザインファイルに保存されます。このため、グリッドの設定は各デザインドキュメントで異なっている可能性があります。最初にDocument Optionsダイアログ(Design » Document Options)でグリッドを設定してください。
Image Added ビジブルグリッドは、ズームレベルに応じて表示できるスペースがあれば、ラインかドットで表示されます。スナップグリッドは、回路図のデザインオブジェクトを配置、移動する場合にカーソルがロックされるグリッドです。エレクトリカルグリッドは、オフグリッドパーツがあった場合、接続を行うため、スナップグリッドを無視します。接続を行うため、ワークスペースで電気的なオブジェクトを移動した場合、他の電気的なオブジェクトのエレクトリカルグリッドの範囲内に近づけると、カーソルがオブジェクトに引き込まれ、「ホットスポット」(赤い十字)が表示されます。エレクトリカルグリッドは、現在のスナップグリッドの値より大きな値に設定すると、電気的なオブジェクトを1格子分離して配置するのが難しくなるので、スナップグリッドより若干小さく設定すべきです。
グリッドは、キーボードやマウスによるショートカットで簡単に値や有効・無効の切り替えが行えます。例えば、G キーでスナップグリッドが 1、5、10と切り替わります。Preferences ダイアログ(Tools » Schematic Preferences あるいは、ショートカット T, P)のSchematic – Gridsページを使って、Imperial(インチ)とMetric(ミリ)のグリッドのプリセットができます。
また、必要に応じてPreferencesダイアログのSchematic – Graphical Editingページの Cursor セクションでカーソルタイプの設定を変更することが可能です。例えば、カーソルタイプの設定で Large Cursor 90 のオプションを選択すると、デザインオブジェクトの配置や移動を行う場合、カーソルがデザインウィンドウの端まで表示されます。

デザインオブジェクトの配置

回路図のデザインオブジェクトの配置方法の基本的な手順を以下に示します。
1. 配置したいオブジェクトのタイプを選択します。オブジェクトタイプの選択は、Place(配置)メニューから項目を選択(例えば、Place » Wire)するか、Placementツールバーのどれかをクリックします。配置のためのショートカットキーも用意されています。(例えば P, W でワイヤが配置されます。)コンポーネント(パーツ)を配置するには、Library パネルのPlaceボタンをクリックするか、Library パネルに表示されているコンポーネント名を選択し、ドキュメント上にドラッグします。
2. 配置のためにオブジェクトが選択されると、カーソルは十字に変わり、編集モードであることを示します。そしてオブジェクトがカーソルのところにフローティングの状態で表示されます。
3. 配置中にオブジェクトの属性を編集するには、TABキーを押します。これによって、オブジェクトのPropertiesダイアログが表示され、様々なオプションの変更が可能となります。
Image Added
属性の設定が終了すれば、OKボタンをクリックし、配置モードへ戻ります。
配置中にオブジェクトの編集を行うと、デジグネータのように数字を含んだ識別子が自動的にインクリメントされていきます。また、配置中に行った変更は、そのオブジェクトタイプのデフォルト値になります。Preferencesダイアログ(T, P)のSchematic– Default Primitives ページにある Permanentオプションが有効でなければ、配置中に行ったオブジェクト属性の変更によってオブジェクト属性のデフォルト値が更新されます。
4. オブジェクトを配置するにはカーソルを適切な位置に移動し、左クリックかENTERキーを押します。ワイヤやポリゴンなどの複雑なオブジェクトでは、カーソルの移動とクリックを繰り返して、オブジェクトの頂点をすべて配置します。
注記 :オートパンの機能が有効であれば、編集ウィンドウの端を越えてカーソルを移動させるとドキュメントの表示エリアを移動することができます。オートパンのスタイルとスピードは、Preferencesダイアログの Schematic – Graphical Editingページで設定が可能です。
PreferencesダイアログのSchematic – AutoFocusページにあるオートフォーカスオプションで、接続されているオブジェクトを配置または編集するときに回路図画面を自動的にズームしたり、現在配置しているワイヤに関係のないワイヤをすべて薄暗く表示するなどのコントロールができます。
その他、ズーミングやパンニングオプションは、ショートカットキーやマウスホイールで行えます。配置時に Ctrl+マウスホイールで、ズームイン、ズームアウトが行えます。また、ホイールボタンを押して上に移動するとズームインし、下に移動するとズームアウトします。PreferencesダイアログのSchematic – Mouse Configurationページで、マウスの動作の設定が可能です。
5. オブジェクトを配置した後も、配置モードが継続され(カーソルが十字のマークのまま)、同じタイプの別のオブジェクトがすぐに配置できます。
6. 配置モードを終了するには、右クリックかESCキーを押します。ポリゴンの配置の様に、いくつかのケースでは、これを2回行う必要があります。1回でオブジェクトの配置を終了し、更にもう1回実行することで配置モードを終了します。配置モードを終了すると、カーソルはデフォルトの形状に戻ります。
Image Added 特定のデザインオブジェクトに関する詳細は、回路図エディタでオブジェクト上にカーソルを移動させ、F1キーを押してください。Knowledge Centerパネルに該当するオブジェクトの詳細が表示されます。

リエントラントな編集

回路図エディタには、リエントラント(再帰可能)編集と呼ばれる強力な機能が用意されています。これは、ある操作を実行中に、その操作を中止することなく、ショートカットキーで別の操作を実行する機能です。例えば、パーツを配置中、SPACEBARで回転させることができ、配置の作業がキャンセルされることはありません。パーツの配置が済めば、次のパーツが現れ、回転させることができます。
再帰編集が有効に使える例としては、ポートにワイヤを接続する場合で、先にワイヤの配置を始めてから、まだ、配置していないポートに接続をする場合です。ワイヤの配置モードを終了する必要はなく、単にポートを配置するショートカットキー(P, R)を使ってポートを配置し、Escキーでポートの配置を終了し、ワイヤをポートに接続します。

回路図ドキュメント上の距離の測定

回路図エディタには、距離ツールが Reports メニューにあります(Reports » Measure Distance または Ctrl+M ショートカットキー)。このツールを使用して、回路図ドキュメント上の2つの点の間の距離を測定することができます。
このコマンドを実行すると、回路図ドキュメント上の 2 つの点をクリックするよう求められ、2 つの点を選択すると、Information ダイアログに、全体の Distance 値、X DistanceY Distance の値が、小数点以下 2 桁で表示されます。
測定単位は、回路図ドキュメントで選択したシステム単位で決まります(Design » Document Options)。ダイアログに測定単位が含まれていない場合、そのドキュメントはデフォルト単位 DXP(1 単位は 10 ミル)を使用するように設定されていることを意味します。システム単位を切り替えることで、ImperialMetric の単位を切り替えることができます(View » Toggle Units)。

グラフィカルオブジェクトの配置

回路図オブジェクトは、グラフィカルと電気的なオブジェクトの2つのグループに分けられます。
Image Added ラインや円弧、文字などのグラフィカルオブジェクトを配置するには、Utilities ツールバー(View » Toolbars » Utilities)から利用可能な、Drawing Tools ツールバーを使用します。Paste Array(Edit » Paste Array)を除く、Drawingツールバーの機能はPlace » Drawing Toolsメニューからアクセスすることができます。

電気的なオブジェクトの配置

回路図の電気的なデザインオブジェクトは、実際の回路を作画するために用いられます。電気的オブジェクトには、コンポーネント(パーツ)とワイヤや、バス、ポートのように接続するためのオブジェクトが用意されています。電気的オブジェクトを配置するには、PlaceメニューかWiringツールバー(View » Toolbars » Wiring)を使用します。
Image Added
次のセクションではパーツ(コンポーネント)とワイヤの2つのオブジェクトタイプの配置方法を紹介します。

パーツの配置

Place » Part (P, P)を選択するか、ワイヤリングツールバーの Image Added ボタンをクリックします。Place Part ダイアログが表示されます。Lib Refフィールドにコンポーネントの名称を入力するか、ブラウズボタン (…)をクリックし、ライブラリからパートを検索するか、適切なライブラリを追加します。Historyボタンをクリックすると以前配置したパーツを検索することができます。
Image Added
また、パーツは、Library パネルのPlace ボタンや回路図のライブラリエディタからでも配置できます。あるいはLibraries パネルでコンポーネント名をリストから選択し、ドキュメント上にドラッグすると、カーソル上にフローティングの状態で現れ、配置が可能となります。クリックで配置が確定します。
パーツの配置には、スナップグリッドをお使いください。ピンエンドをグリッドポイント、例えば、10に固定することができます。G キーでスナップグリッドが 1、5、10と切り替わります。

ワイヤの配置

Image Added ワイヤは、ポイント間の電気的な接続を示すために使用されます。ワイヤを配置するときには、誤ってラインコマンドを使用せずに、必ず、Place » Wire コマンド Image Added を使用してください。また、ワイヤの配置コマンドは回路図ドキュメント上で右クリックか、Wiring ツールバーからも実行できます。
ワイヤの終端は、電気的なオブジェクトの接続ポイントと接続する必要があります。例えば、ワイヤをピンに接続するには、ワイヤの終端をピンのホットエンドに接続します。ワイヤを配置するときには、エレクトリカルグリッドの範囲内にある別の電気的なオブジェクトに近づけると、カーソルがオブジェクトに引き込まれ、「ホットスポット」(赤い十字)が表示されます。このホットスポットによって有効な接続ポイントが示され、カーソルはエレクトリカル接続ポイントに自動的に引き込まれます。ワイヤはホットスポット上で終了すると、自動的に切断されます。
エレクトリカルグッドをスナップグリッドより大きな値を設定すると、電気的なオブジェクトを1格子分離して配置するのが難しくなるので、スナップグリッドより少し小さな値に設定することをお勧めします。
配置したワイヤが電気的なオブジェクトに接続していない状態で、配線を中断するには右クリック(あるいはESCキー)を実行します。更に、右クリック(あるいはESCキー)を実行すると、配置モードを終了します。
ワイヤの配置中、BACKSPACEキーで直前に配置した頂点を削除することができます。

ワイヤの配置モード

ワイヤを配置するときには、SHIFT+SPACEBARでワイヤの配置モードが切り替わります。用意されている配置モードは以下のとおりです:

  • 90度
  • 45度
  • フリーアングル
  • オートワイヤ

Anchor
_Hlt61071291
モードは、ワイヤを配置する際のコーナーの作成方法と、配置角度がどのように作成されるかを指定します。SPACEBAR を押すと開始と終了のサブモードが切り替わるか(90°モードまたは45°モードの場合)、フリーアングルとオートワイヤモード間で切り替わります(これらのモードのいずれかがアクティブな場合)。
オートワイヤモードは特別なモードで、指定した回路図上の2点を自動的に接続します。オートワイヤ機能が自動的に障害物を避けて接続します。このモードでTABキーを押すと、オートワイヤのオプション設定を行う、Point to Point Router Optionsダイアログが表示されます。

ジャンクション

Image Added ワイヤには、オートジャンクション機能が用意されています。ワイヤの始点か終点が別のワイヤやピンに接続するとジャンクションオブジェクト(ドット)が自動的に挿入されます。オートジャンクションとマニュアルジャンクションの表示、ジャンクションサイズと色は、PreferencesダイアログのSchematic - Compilerページでコントロールすることができます。また、ワイヤの交差を設定し、既存のワイヤを交差に変換するためのオプションが、Preferences ダイアログのSchematic – Generalページに用意されています。

Anchor
_Hlt176253277
Anchor
_Hlt176253278
配置したワイヤの編集方法はこのアプリケーションノート後半にある[ 配置し
Anchor
_Hlt212368826
たワイ
Anchor
_Hlt212368866
ヤの編集 |#_配置されたワイヤの編集]を参照してください。

回路デザインオブジェクトの編集

回路図上に配置したオブジェクトには、様々な編集方法が用意されています。オブジェクトはドキュメント内での移動や、ドキュメント内およびドキュメント間での切り取り、コピー、貼り付けなどの操作が可能です。また、オブジェクトの色、デジグネータ、ネット割り付けなど属性の変更も可能です。
ポリライン形状(バス、ワイヤ、ポリゴン、ラインなど)などのいくつかのオブジェクトでは、配置後にグラフィカルに形状を変更することができます。
Image Added 一つのオブジェクトを編集することも、クエリなどの強力な編集機能を使ってデザイン全体のオブジェクトを編集することも可能です。Find Similar ObjectsダイアログやSCH Listパネル、SCH Inspectorパネルなどの強力なツールで、グループ化したオブジェクを一度に編集することができます。
詳細は、チュートリアルTU011

Anchor
_Hlt212368966
5 複数オ
Anchor
_Hlt212368978
Anchor
_Hlt212368979
ブジ
Anchor
_Hlt212375381
ェクトの編集 TU0115%20Editing%20Multiple%20Objects.PDFを参照してください。
配置されたコンポーネント(パーツ)とフットプリントは、それらの属性ダイアログで変更が可能です。あるいはライブラリエディタで変更し、更新することができます。ピンは、回路図のComponent Propertiesダイアログ(のEdit Pins ボタン)からComponent Pin Editor を使って編集することができます。
Image Added ライブラリエディタを使用してのパーツやフットプリントの作成や編集方法の詳細は、チュートリアル TU0103
Anchor
_Hlt212369072
Anchor
_Hlt212369073
ライブラリ
Anchor
_Hlt212375421
・コンポーネントの作成 TU0103%20Creating%20Library%20Components.PDFを参照してください。

配置されたオブジェクトのグラフィカルな編集

ワークスペースに表示されているオブジェクトをグラフィカルに編集するのは簡単です。これを行うには、まず、オブジェクトを選択する必要があります。

Anchor
_Editing_placed_wires
Image Added オブジェクトが選択されると、オブジェクトの移動やグラフィカルな属性が変更できます。オブジェクトを選択するためにクリックすると、「ハンドル」や頂点が表示されます。 選択されたオブジェクトをグラフィカルに編集するには、ハンドル上でクリックし、ボタンを押さえ続けます。オブジェクトのそのポイントがカーソルとともに移動しますので、新しい位置にマウスを移動させ、サイズを変更しボタンを放します。オブジェクトを移動するには、オブジェクト上でマウスボタンを押さえ続け、ドラッグします。また、削除するには、Deleteキーを押します。

Anchor
_配置されたワイヤの編集
配置されたワイヤの編集

Anchor
_Hlt176253280
頂点の移動、セグメントの移動、ワイヤ全体の移動、ワイヤを伸ばすなど、配置されたワイヤの編集方法はいくつか用意されています。また、ワイヤのPropertiesダイアログにあるVerticesタブから頂点の追加や削除が可能です。詳細は、Properties
Anchor
_Hlt212368806
Anchor
_Hlt212368807
ダイアログから頂点の編集 _Propertiesダイアログから頂点の編集を参照してください。

ワイヤの頂点移動による編集

Image Added ワイヤの頂点を移動するには、ワイヤをクリックして選択します。移動したい頂点上にカーソルを移動すると、カーソルが2方向の矢印に変わります。図のようにマウスボタンをクリックしたまま、頂点を新しい位置にドラッグします。

ワイヤセグメントの移動

ワイヤのセグメントを移動することも可能です。ワイヤを選択し、カーソルをセグメントの上に移動すると、カーソルが4方向の矢印に変わります。下の図のようにマウスボタンをクリックしたまま、セグメントを新しい位置にドラッグします
Image Added

ワイヤ全体の移動

形状を変えずにワイヤ全体を移動するには、選択をしないで単にドラッグをします。
Image Added

ワイヤの延長

Image Added 配置されたワイヤは伸ばしたり、頂点を追加することができます。ワイヤを選択し、カーソルをワイヤの終端に移動すると2方向の矢印に変化します。ワイヤの終端をクリックしてドラッグすると、「ルックアヘッド」セグメントが表示され、新しい位置でクリックすると配置されます。カーソルを移動中、SHIFT + SPACEBARで配置モードを変更することができます。 同じ方向に伸ばしたい場合は、選択した終端をドラッグする際にALTキーを押してください。

ワイヤの切断

Image Added Edit » Break Wireコマンドでワイヤセグメントを2つに切断することができます。このコマンドは、カーソルがワイヤ上にあるときに右ボタンクリックを実行することでも利用できます。(デフォルトでは)表示される「カッターボックス」をワイヤセグメント上に配置することで、カットします。カットされる部分は、図のようにマスク表示されます。カットされる長さは、2つセグメントの距離になります。コマンドを実行中、SPACEBARを押すと、カットする長さが(セグメントにスナップ、グリッドサイズにスナップ、固定長の)3つのモードで切り替わります。TAB キーを押すと、固定長の長さやその他のカッターオプションが設定できます。ワイヤをカットするにはクリックします。右クリックか、ESCキーを押すとワイヤ切断モードが終了します。ワイヤ切断のオプションはPreferenceダイアログのSchematic – Break Wire ページでも設定が可能です。
PreferenceダイアログのSchematic – General ページのComponents Cut Wiresオプションも設定することができます。このオプションとOptimize Wires and Busesオプションが有効であれば、コンポーネントをワイヤ上に配置すると、ワイヤが2つに分割され、その終端がコンポーネントの2つのピンと自動的に接続されます。

Image Added

_Drag and release one vertex and all aligned vertices will move to remain aligned._マルチワイヤ
回路図エディタのマルチワイヤ編集モードでは、複数のワイヤを同時に延長することができます。平行した複数のワイヤで、終端座標が同じになっているものの一つのワイヤをドラッグすると、選択されているその他のワイヤも移動し、終端の位置が揃います。

回路図オブジェクトの移動とドラッグ

Altium Designerでのオブジェクトの移動は、それに接続されているオブジェクトに関係なく、移動が行われます。例えば、コンポーネントを移動する場合、そこに接続されているワイヤは移動しません。逆に、コンポーネントのドラッグでは、移動後、ワイヤとの接続が維持されます。選択したオブジェクトを移動する際、常に電気的な接続を維持したい場合は、PreferencesはダイアログのSchematic – Graphical EditingページのAlways Drag オプションを有効にします。

オブジェクトの移動

単独の選択されていないオブジェクトあるいは、選択されている複数のオブジェクトをマウスのドラッグで移動することができます。また、特に配置されているオブジェクトの前後にオブジェクトを移動したい場合、Edit » Moveコマンドを使用することができます。
シート内でオブジェクトを移動する場合には、あらかじめオブジェクトを選択する必要はありません。単に電気的なホットスポットマークが表示されるまでマウスボタンを押さえ続け、コンポーネント/オブジェクトを新しい位置へドラッグします。カーソルが一番近い電気的なホットスポットに移動します。例えば、オブジェクトをクリックしたとき、カーソルはピンに最も近ければそこに移動します。これはPreferencesダイアログのSchematic – Graphical EditingページのObject's Electrical Hot Spot オプション(デフォルト)、またはCenter of Objectオプションによって移動やドラッグする際の動作が決まります。
オブジェクトの移動中:

  • SPACEBAR を押すと、オブジェクトは回転します。回転は、反時計回りで90°ステップで回転します。SHIFT+SPACEBAR を押すと、オブジェクトは時計回りで回転します。
  • Xキー、Y キーを押すとX軸、Y軸に沿って、それぞれオブジェクトが反転します。
  • ALTキーを押すと、移動方向が垂直、水平方向のいずれかに制限されます。

オブジェクトの移動

選択したオブジェクトを移動するには、回路図ドキュメント上で Ctrl キーと矢印キーの組み合わせを使用するか(垂直または水平)、Ctrl キーと Shift キーと矢印キーの組み合わせを使用します。
選択したオブジェクトの移動は、Document Options ダイアログ(Document » Options またはショートカット D, O)の現在の Snap Grid 設定に応じて設定されます。このダイアログでスナップグリッド値を変更します。このグリッド値は、Altium Designer のステータスバーにも表示されます。Preferences ダイアログの Schematic - Grids ページを使用して Imperial(インチ)と Metric(ミリ)のグリッドのプリセットを設定することもできます。スナップグリッド設定値を切り替えるには、ショートカット G を使用します。あるいは、View » Gridsのサブメニューや右クリックメニューから Grids を選択します。

  • Ctrl キーを押しながら矢印キーを押すと、選択したオブジェクトは、現在のスナップグリッド値に応じて少し移動します。
  • Ctrl キーと Shift キーを押したまま矢印キーを押すと、選択したオブジェクトは、スナップグリッド値に 10 を掛けた分だけ大きく移動します。

オブジェクトのドラッグ

Edit » Move » Drag コマンドで 、コンポーネント(パーツ)やポート、ワイヤ、バスなど、ワイヤが接続されているオブジェクトの接続を維持した状態での移動が可能です。カーソルが十字に変化し、ドラッグしたいオブジェクトの上でクリックするか、ENTERキーを押します。オブジェクトを移動し、適切な位置でクリックするか、ENTERキーを押します。引き続き、他のオブジェクトが移動するか、あるいは、右クリックかESCキーでドラッグモードを終了します。
選択した複数のオブジェクトを、接続を維持したままドラッグするには、Edit » Move » Drag Selectionコマンドを使用します。
あるいは、ショートカットキーを使用してオブジェクトをドラッグすることも可能です。クリックするときに CTRL キーを押さえ続け、マウスを移動します。ドラッグを始めた後、CTRLキーを放しても構いません。これはオブジェクトを複数選択した場合も動作します。CTRLキーを使用すると、PreferencesダイアログのAlways Dragオプションの設定が一時的に切り替わりますので、注意してください。
オブジェクトをドラッグしている間は:

  • ドラッグ中に SPACEBARか、SHIFT+SPACEBARを押すと、ワイヤの配置モードが変化します。
  • 移動中、CTRL+SPACEBARでオブジェクトが回転します。回転は、反時計回りで90°ステップで回転します。
  • 移動中、XYキーを押すと、X軸、Y軸に沿って反転します。
  • 移動中、SPACEBARを押すと、オブジェクトに接続されているワイヤのモードが変化します。
  • 移動中、ALT キーを押すと、移動方向が最初に移動した方向によって、垂直、水平方向のいずれかに制限されます。

オブジェクトの移動をロックする

回路図オブジェクトが誤って移動されるのを防ぐために、これらのオブジェクトの Locked 属性を有効にして、グラフィカルに編集できないようにすることができます。ロックされたデザインオブジェクトを編集しようとすると、Confirm ダイアログが表示され、動作を続行するかどうかを質問されます。
Preferences ダイアログの Schematic - General ページで Protect Locked Objects オプションが有効になっており、このデザインオブジェクトの Locked オプションが有効になっている場合、このオブジェクトは移動できず、メッセージも表示されません。ロックされたオブジェクトを含むオブジェクトグループを選択しようとしても、ロックされたオブジェクトは選択されません。

コピー&ペーストの使用法

回路図エディタでは、回路図ドキュメント内やドキュメント間でオブジェクトのコピー、ペーストができます。例えばコンポーネントをあるドキュメントから別のドキュメントへコピーすることができます。オブジェクトをウィンドウズのクリップボードへコピーし、別のドキュメントへ貼り付けることができます。テキストはウィンドウズのクリップボードから回路図のテキストフレームへコピーすることができます。また、Microsoft Excel などの他のアプリケーションやAltium Designer内のグリッドスタイルコントロールから、テーブルタイプのセレクションを直接コピー/ペーストすることができます。更に、高度なコピー/ペーストの操作は、スマートペースト機能を使って行えます。
コピーしたいオブジェクトを選択し、Edit » Copy (Ctrl+C) を選択してコピーするオブジェクトの原点でクリックします。これは、貼り付けする際、正確な位置にオブジェクトを配置するためです。尚、この機能を利用するには、Preferences ダイアログのSchematic – Graphical Editing ページのClipboard Reference オプションが有効である必要があります。

スマートペーストの使用

回路図エディタのスマートペースト機能により、選択したオブジェクトを他のオブジェクトに変換して、ペーストすることができます。例えば、選択したネットラベルをコピーし、スマートペーストにより一回の操作で、ポートとしてペーストしたり、選択したシートエントリをネットラベル+ワイヤとしてペーストすることができます。
Image Added
スマートペーストを使用して、コピーしたシートエントリをネットラベル+ワイヤに変更
スマートペーストする時に、特定のオブジェクトをコントロールすることもできます。チェックボックスを無効にして、特定オブジェクトのスマートペーストを行わせません。
その他の便利な機能は、選択した回路をグラフィックとして貼り付ける機能です。これを使用して、他のシートにある回路のグラフィックな箇所を簡単に含めることができ、必要に応じてそのサイズを設定します。Edit » Smart Paste を選択して、貼り付ける時に、クリップボードにコピーされたオブジェクトを変更します。

シート上でのテキスト編集

テキストストリングは、回路図エディタ上で直接編集することができます。クリックしてテキストストリング、テキストフレーム、ノートのいずれかを選択し、再度クリックする(あるいはショートカットキーF2を押す)と、回路図シート上で直接テキストが編集できます。この動作は、PreferencesダイアログのSchematic – GeneralページにあるEnable In-place Editingオプションをオフにすることで無効にできます。

アノテーションとリ・アノテーション

Altium Designerには、3種類のアプローチが用意されています。回路図レベルのアノテーション、ボードレベルのアノテーション、PCBアノテーションです。
回路図のアノテーション機能では、パラメータによりコンポーネントを一致させることができ、すべてのデジグネータまたは重複するデジグネータのリセット、PCB ドキュメントから回路図へのバックアノテート、回路図シート毎のデジグネータインデックスコントロール、サフィックスオプションが用意されています。
回路図エディタで、Tools » Annotate Schematics コマンドを使用してAnnotate ダイアログを開きます。そこで、カレントプロジェクトの選択したシート内のすべてまたは選択した部品のデジグネータを、固有に連続した順番で再割り当てできます。
Image Added
AnnotateダイアログがオープンされているときF1キーを押すと、このプロセスの詳細情報が表示されます。
また、Annotate ダイアログを実行せず、現在、デジグネータが割り当てられていない部品へ固有のデジグネータを割り当てるにはTools » Annotate Schematics Quietly コマンドを使用します。このコマンドは、以前 Annotate ダイアログで設定した回路図アノテーション設定に従います。Annotate Schematics Quietly は、重複に対して固有のデジグネータを割り当てません。
アクティブプロジェクトのすべてのコンポーネント デジグネータをリセットする場合、必要に応じて、Tools » Reset Schematic Designators コマンドを使用できます。または、重複しているデジグネータをリセットする場合はTools » Reset Duplicate Schematic Designators コマンドを使用します。
Annotate ダイアログで定義した回路図アノテーション設定に従って、すべてのコンポーネント デジグネータをリ-アノテートするには、Tools » Force Annotate All Schematics コマンドを使用します。
PCBドキュメントでデジグネータをリ-アノテートする時、生成されたWAS-ISファイルを使用して、バックアノテート(Tools » Back Annotate Schematics)により、アクティブプロジェクトのソース回路図シート内のコンポーネントのデジグネータを更新できます。
ボードレベルアノテーションは、回路図エディタを通じて、コンパイルしたコンポーネント(コンポーネントの物理的なビュー)をアノテートすることです。Tools » Board Level Annotate コマンドを使用して Board Level Annotate ダイアログを開きます。このダイアログで、命名方式に基づきコンパイルしたコンポーネントの命名規則の計算、PCBドキュメントからコンパイルしたドキュメントへのバックアノテート、カスタム名の指定、すべてのデジグネータのリセットを行うことができます。
Image Added
Board Level Annotation ダイアログでは、アノテートオブションを通じた命名方式のカスタマイズ、すべてのデジグネータのリセット、コンポーネントに対するカスタム名の作成を行うことができます。
PCB エディタで、Tools » Re-Annotate コマンドを使用してPositional Re-Annotate ダイアログを開き、デジグネータを前後関係に依存して再割り当てすることができます。リ・アノテーション操作によって、ファイル名に日付と時刻を含む固有の *.WAS ファイルが生成されます。このファイルは、回路図のアノテーションまたはボードのアノテーション中にバックアノテーションを実行するときに使用されます。
Image Added
Image Added デザインのアノテーションの詳細については、アプリケーションノートAP0140 設計

Anchor
_Hlt212375557
のア
Anchor
_Hlt212375545
ノテーションについて AP0140%20Understanding%20Design%20Annotation.PDFを参照してください。

オブジェクトの属性編集

オブジェクトの属性を表示、編集するには、次のいずれかの方法で、Propertiesダイアログをオープンします:

  • 配置中などオブジェクトがカーソルで移動できるフローティング状態の時、TABキーを押し、Propertiesダイアログをオープンします。
  • 配置されているオブジェクトをダブルクリックし、直接オープンします。
  • メニューから Edit » Change を実行し、編集モードに入ります。編集したいオブジェクトをクリックします。編集モードを終了するには、右クリックかESC キーをクリックします。
  • 配置されたオブジェクトを選択するためにクリックし、次に紹介するSCH InspectorSCH Listパネルを使って編集します。

Anchor
_Propertiesダイアログから頂点の編集
Propertiesダイアログから頂点の編集

バス、ワイヤ、ポリライン、ポリゴンオブジェクトの Properties ダイアログにあるVertices タブで、頂点の座標を編集できます。例えば、Wire properties ダイアログにはVertices タブがあります。そこで必要に応じて選択したワイヤオブジェクトの個々の頂点を編集できます。
Image Added
タブには、ワイヤの現在のすべての頂点がリスト表示されます。ワイヤに新しい頂点を追加、既存の頂点の座標を編集、選択した頂点全体を削除できます。
Menu ボタンをクリック、またはメインリスト領域内で右クリックし、表示されたポップアップメニューから希望の設定(頂点の編集、追加、削除、またはセルのコピー、貼り付け、選択、移動)を選択します。Move Wire By XY コマンドは、全体のワイヤオブジェクトを移動します。Move Wire By ダイアログで、各頂点のX、Y座標に適用する値を入力できます。

Image Added

SCH Inspectorパネルでのオブジェクト編集
SCH Inspector パネルでは、現在アクティブな、または開いているドキュメントの1つ、または複数のデザインオブジェクトの属性を表示および編集できます。SCH Filter パネル(F12)、またはFind Similar Objects コマンド(Shift+F、または選択したオブジェクトを右クリックし、Find Similar Objects を選択)と併用して使用すると、同じ種類の複数のオブジェクトを変更できます。
1つ、または複数のオブジェクトを選択して、F11 を押すか、またはSCH Inspector タブをクリックしてSCH Inspector パネルを表示します。もし、パネルが表示されない場合、ステータスバーにあるSCH ボタンをクリックしSCH Inspectorを選択するか、またはView » Workspace Panels » SCH » SCH Inspectorを選択します。また、デザインオブジェクトをダブルクリックした時、オブジェクトのProperties ダイアログを表示する代わりにSCH Inspector パネルを表示するには、Preferences ダイアログのSchematic – Graphical Editing ページのDouble Click Runs Inspector オプションで設定できます。
SCH Inspector パネルは、選択したオブジェクトに共通な属性を表示するだけであることに注意してください。リスト表示された属性はSCH Inspector パネルで修正できます。新しい属性を入力しチェックボックスをクリック、またはドロップダウンリストから選択します。Enter を押すか、またはパネルの他のセルをクリックして変更を実行します。
Image Added 複数のオブジェクトを編集するには、チュートリアルTU0115 複

Anchor
_Hlt212369178
Anchor
_Hlt212369179
Anchor
_Hlt212375600
オブジェクトの編集 TU0115%20Editing%20Multiple%20Objects.PDF を参照してください。

SCH Listパネルでのオブジェクト編集

オブジェクト(または、複数のオブジェクト)を選択して、Shift+F12 を押してSCH List パネルを表示します。SCH Filter パネル (F12) 、またはFind Similar Objects コマンド(Shift+F) と併用して使用する時、複数のデザインオブジェクトをターゲットとし編集できます。SCH Listパネル上部のView/Edit ドロップダウンメニューからEditを選択して、SCH Listパネルからオブジェクトの属性を変更できます。
Image Added
SCH ListパネルのObject Kindのリストからオブジェクトをダブルクリックすると、そのオブジェクトのPropertiesダイアログが表示されます。

更新履歴

Date

Version No.

Revision

05-Jan-2004

1.0

New product release

24-Mar-2005

2.0

Renamed from Object Placement and Editing. Concentrates on Schematic Editor objects only in Altium SP3.

29-Nov-2005

2.1

Updated for Altium Designer 6

3-Oct-2007

2.2

Updated for Altium Designer 6.8

14-Mar-2008

2.3

Updated Page Size to A4.

ソフトウェア、ハードウェア、文書、および関連資料
Copyright © 2004 Altium Limited.
All rights reserved.この文書の印刷は、(1) 個人的使用に限定し、ネットワークコンピュータやあらゆる種類の媒体にコピーや送信を行わない、かつ (2) 文書の変更をまったく行わない、という条件でのみ行うことができます。Altium Limited の事前の書面による許可なく、本書の全体または一部を問わず、機械的または電子的な複製、他言語への翻訳を禁じます。ただし、公表するレビュー目的での抜粋を除きます。本書の無許可の複製は、各国の法律でも禁止されています。違反者は、罰金や実刑を含む刑事罰と民事罰両方の対象となることがあります。
Altium、Altium Designer、Board Insight、CAMtastic、CircuitStudio、Design Explorer、DXP、LiveDesign、NanoBoard、Desktop NanoBoard、NanoTalk、Nexar、nVisage、PCAD、Protel、SimCode、Situs、TASKING、Topological Autorouting、およびそれぞれに対応するロゴは、Altium Limited またはその子会社の商標または登録商標です。本書に記載されているそれ以外の登録商標や商標はそれぞれの所有者の財産であり、商標権を主張するものではありません。