Altium Wiki

Information and resources for electronic product designers

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Mate を対応した新しい 3D グラフィックエンジン

このバージョンでは、効果的な新しい 3D エンジンが搭載されています。このエンジンには、マルチボード設計を含む、ソフトウェアの多くの分野の大幅な改善点が含まれています。

新しい 3D エンジンがもたらす利点の 1 つは、マルチボード アセンブリ エディタでのより多くの MCAD のような設計機能です。導入されている第一の機能は、Mateです。オブジェクトは、整列と配置を行わなくても、結合されます。

メカニカル CAD ソフトウェアで空間内の 2 つのオブジェクトを関連付ける概念は、設計プロセスの基本的な部分です(2 つのオブジェクトを結合するプロセス)。2 つのオブジェクトが結合された時、1 つのオブジェクトとして操作できます。結合されたオブジェクトは他のオブジェクトと結合でき、このプロセスを介して、個別のオブジェクトはアセンブリへ形成されます(機構設計の本質)。

Altium Designer 18 で作成したマルチボード アセンブリを開く

新しい 3D エンジンと改良された機能を対応するためにファイルフォーマットを変更したため、Altium Designer 18 で作成したマルチボード アセンブリは、インポートする必要があります。

古いフォーマットの MbaDoc を開く時、Legacy document import ダイアログが表示されます:

マルチボード アセンブリ エディタで Design » Import コマンドを選択して、子モジュールを再読み込みする ECO を生成します。改善したマルチボード アセンブリ エディタでは、全体の PCB ファイルデータが読み込まれるので、このプロセスは、時間がかかる場合があります。

 

Note

改善した機能と新しい 3D エンジンを対応するためにファイルフォーマットを変更したため、このバージョンの Altium Designer で保存したマルチボード アセンブリは、古いバージョンの Altium Designer で開けません(これが実行された場合、空のドキュメントとして開きます)。

マルチボード アセンブリ エディタの UI の変更

回路図と PCB エディタと同様に、マルチボード アセンブリ エディタに Active Bar が含まれました。

モードのコントロールは Active Bar にあり、Mating モード、測定モード、断面プレーン機能が含まれています。

クリックすると Mating モードになります。カーソルが表面上を移動すると、各面の mate 位置がハイライト表示されます。異なるオブジェクトの 2 つの mating 位置を指定する必要があります。これらは、2 番目を選択した後、結合されます。Esc を押して、Mating モードを終了します。
クリックすると測定モードになります。1 つのオブジェクトをクリックしてから、2 つ目のオブジェクトをクリックします。最も近い端/表面間の距離が表示されます。測定モードのままにすると、更に測定できます。Ctrl+M を押すと測定モードは維持されますが、既存の測定は削除されます。Esc を押すと測定モードは終了し、全ての測定表示は削除されます。
クリックすると断面ビューモードになります。基板は、断面プレーンに沿って分割されます(その面の前にあるオブジェクトは非表示になります)。ボタンを再度クリックすると断面ビューは終了します。
クリックすると断面プレーンが表示されます。断面プレーン Gizmo を使用して、プレーンの方向を変更できます。Gizmo のライン上にカーソルを置き、オレンジ色から黄色に変更してからクリックします。そして、クリックしたままドラッグして断面プレーンの方向をコントロールできます。ボタンを再度クリックすると、断面プレーンは非表示になります。

Mate での作業

 

Tip

Mate: 2 つの別々のオブジェクト間に形成される接続。その接続は、各オブジェクトの表面上で選択した点になり、mate されたらオブジェクトの方向は決まります。そのため、それらの表面や垂直の軸は、整列されます。

  • Source - Mate 位置として指定した最初の位置。
  • Target - 2 番目に指定した位置。このオブジェクトは、ソースと結合するために移動します。
  • Mating 軸 - Mate の中心からの垂直軸。

 

  • Mate は、Mating モードにしてから、Source と Target mating 位置を指定して定義します。
  • mate は、Multi-board Assembly パネルの Mates の項目で選択し、Properties パネルの Mates モードでそのプロパティを編集して変更できます。

パネルで Mate を選択して、Properties パネルでその設定を編集。ワークスペースで、白色の円は Mating の位置を示し、紫色のラインは mating の軸を示します。

 

Info

編集操作のほとんど(例えば、回転、または距離の変更)は、ホットキー(これらは、Properties パネルの Mates モードで詳細を確認できます)を使用して実行できます。

Mate の定義

Mate を定義するには以下を行います:

  1. Active Bar ボタンをクリックして Mating モードに切り換えます。mating プロセスは、1 回クリックして各 mate 位置を定義する必要がありますが、必要に応じて、更にクリックできます(下の緑のハイライトボックスで説明しているように)。
  2. mating モード中、結合するオブジェクト上にカーソルを置きます。オブジェクトの表面上にカーソルを置くと、その表面はグレーに変わり、mate 位置 (glyph) が表示されます。
    • 平面上で、境界となっている四角形の中心、コーナー、中間点にある 9 つの glyph から選択します。
    • 円筒面上で、円筒の各端の軸に沿った 2 つの glyph から選択します。
  3. 各 glyph は可能性のある mate 位置であり、現在、カーソルに最も近い glyph が大きな緑色のドットでハイライト表示されます。表面上の任意の場所をクリックし、ハイライト表示された glyph を最初の mate 位置(Source)として確定します。選択したら、Source は紫色のドットでマークされます。
  4. カーソルが表面の外に移動すると、緑色になります(Source がその表面にあることを示します)。
  5. 2 番目のオブジェクトでこのプロセスを繰り返し、2 番目の mate 位置(Target)を定義します。この時、mate 位置は茶色のドットでハイライト表示されます。
  6. Target を定義するとすぐに、Target オブジェクトは、Source 位置とTarget 位置の垂直軸と表面が合って、それらが結合される(同じ位置に配置される)ように移動します。Mate 位置は、他のオブジェクトから見える状態で円弧で表示されます(Mate を選択した時)。そして、mate 位置の垂直軸は、紫色の破線で表示されます。
  7. オブジェクトを結合した時、それらはロックされ、1 つのオブジェクトとして移動します。
  8. 既存の Mate を変更するには、Multiboard Assembly パネルでそれを選択してから Properties パネルでその値を編集します。

 

Tip

ヒント:

  • glyph を選択することが難しい場合(例えば、オブジェクトの穴の中心を選択する場合(以下の動画で説明している)、または間違った glyph を選択した場合)、Target glyphを定義する前に Source glyph を変更できます。
  • Source に定義した平面上でカーソルを移動すると、カーソルに最も近づいた glyph が緑色でハイライト表示されます。現在の Source は、紫色でハイライト表示されたままになります。別の glyph が必要な場合、glyph 上にカーソルを置き、緑色にハイライト表示してからクリックして、それを指定します。
  • 取り付けネジで Mate を定義できない場合、ネジを非表示にして(Multi-board Assembly パネルでオブジェクトを右クリック)、代わりにネジ穴を使用します。
  • 2 番目の mate 位置は、最初の mate 位置と別のオブジェクトで指定する必要があります。2 番目の面を、最初の mate 位置と同じオブジェクトで選択した場合、新しい最初のmate位置を選択する様、促されます。
  • 結合したオブジェクトは、3 番目のオブジェクトへ結合できます。
  • ワークスペース画面は、Mate を定義している時、変更できます:


    • Ctrl+右クリックしたままドラッグし、ズームイン/アウトできます。
    • Shift+右クリックしたままドラッグし、ワークスペース画面でクリック位置の周りを旋回できます。
  • Esc を押して、mating プロセスを中止し Mating モードを終了できます。

 

ナットとネジ間で Mate を定義する簡単なデモンストレーション。mate の定義モード、または mate の編集モードの時、ステータスバーに表示されます。

Mate の変更

Mateを変更するには、Multi-board Assembly パネルで Mate を選択してから、Properties パネルを使用してその設定を調整します。mate が編集モードの時、ステータスバーに表示されることに注意してください。

Mate を変更するには、Multi-board Assembly パネルの Mates の項目で最初に Mate を選択してから、Properties パネルで編集します。

  • 新しい Mate は、デフォルトで Auto になります。
  • 以下のように、Mate を設定できる 3 つのモードがあります:
    • Auto - Mate は全ての方向でロックされ、いずれかのオブジェクトをドラッグすると両方が移動します。パネル内の編集欄を使用して、Target は、Source mating 平面を横切って X & Y 方向に Offset できます。また、Distance も mating 軸に沿って調整できます。
    • Plane-to-Plane - Mate は mating 軸に沿ってロックされますが、X/Y 平面を横切ってインタラクティブにドラッグできます。編集欄を使用して Distance を調整し、mating 軸に沿って Target を移動できます。
    • Axis-to-Axis - Mate は X/Y 平面でロックされますが、mating 軸に沿ってインタラクティブにドラッグできます。パネル内の編集欄を使用して、Target は、mating 平面の X & Y 方向に Offset できます。Source は、静止したままです。
  • ホットキー(パネルの Help の項目に表示されている)は、ロックした mate を調整するための効率的な方法になります。ホットキーは維持でき、何度もキーを押す必要はありません。
  • オブジェクトを正しく配置したら、モードを Auto に設定して、ワークスペース内のオブジェクトをドラッグして位置関係が不注意で変更されないようにできます。

断面プレーンの表示と定義

断面プレーン Gizmo は、プレーンを移動するために使用します。ハイライト表示された Gizmo のラインは、クリックしてドラッグした時、プレーンをどの方向に移動するかを示します。

  • 断面ビューで作業する 2 つの機能があります。最初に断面プレーンの位置と方向を決め、それから断面ビューモードを有効にします。
  • ボタンをクリックして、断面プレーンのオン/オフを切り換えます。
  • 上図に示すように、Section Plane Gizmo を使用して、Gizmo のライン、またはアークをクリックしてドラッグし、断面プレーンを移動、または方向付けできます。必要に応じて、断面ビューモードがオンの時、プレーンは移動できます。
  • ボタンをクリックして、断面ビューモードをオンに切り換えます。プレーンの前にあるオブジェクトは非表示になります。断面ビューモードをオフに切り換えるには、再度、クリックします。

 

強化した衝突テスト

新しい 3D エンジンを利用して、衝突テストの時間は大幅に減少しました。

  • 衝突をチェックするには、Tools » Check Collisions を選択します。全ての衝突の詳細は、Messages パネルに表示されます。
  • 必要に応じて、衝突違反マーカーは、Tools » Clear Violations コマンドを選択して削除できます。

リジッドフレキシブルの対応

マルチボード アセンブリ エディタでは、リジッドフレキシブル基板を対応しました。マルチボード アセンブリ エディタでは、PCB エディタで定義したように、最後に折り曲げた状態の PCB が表示されます。

MCAD へエクスポート

アセンブリ全体を STEP 3D、または Parasolid フォーマットでエクスポートするには、メニューから File » Export » STEP 3D、または File » Export » Parasolid を選択します。

Rhinoceros MCAD エディタで開いたマルチボードアセンブリの STEP ファイル。