Altium Wiki

Information and resources for electronic product designers

Skip to end of metadata
Go to start of metadata
Language

これは、回路図エディタで使用するデザインオブジェクトの配置や編集方法の一般的な概要です。ワイヤと部品のような複合のオブジェクトの配置や編集の詳細な説明も含まれます。 

オブジェクト配置の基本

グリッドとカーソル

回路図エディタでオブジェクトを配置する前に、容易に配置できるようグリッドを設定します。  Altium Designerでは、3種類のグリッドが用意されています。: 表示用のビジブルグリッド、配置用のスナップグリッド、接続箇所の作成を補助するエレクトリカルグリッド。グリッドは、ドキュメントオプションになり、個別のデザインファイルに保存されます。このため、グリッドの設定は各デザインドキュメントで異なっている可能性があります。最初に Document Options ダイアログ (Design » Document Options) でグリッドを設定してください。

ビジブルグリッドは、ズームレベルに応じて表示できるスペースがあれば、ラインかドットで表示されます。スナップグリッドは、回路図のデザインオブジェクトを配置、移動する場合にカーソルがロックされるグリッドです。エレクトリカルグリッドは、オフグリッドパーツがあった場合、接続を行うため、スナップグリッドを無視します。接続を行うため、ワークスペースで電気的なオブジェクトを移動した場合、他の電気的なオブジェクトのエレクトリカルグリッドの範囲内に近づけると、カーソルがオブジェクトに引き込まれ、「ホットスポット」(赤い十字)が表示されます。エレクトリカルグリッドは、現在のスナップグリッドの値より大きな値に設定すると、電気的なオブジェクトを1格子分離して配置するのが難しくなるので、スナップグリッドより若干小さく設定すべきです。 
グリッドは、キーボードやマウスによるショートカットで簡単に値や有効・無効の切り替えが行えます。例えば、G キーでスナップグリッドが 1、5、10と切り替わります。また、View » Grids サブメニュー、または 右クリックメニューの Grids を使用できます。Preferences ダイアログ(Tools » Schematic Preferences あるいは、ショートカット T, P)の Schematic フォルダ下の Grids タブを使用して、Imperial(インチ)とMetric(ミリ)のグリッドのプリセットができます。
また、必要に応じて Preferences ダイアログの Schematic フォルダ下の Graphical Editing タブの Cursor セクションでカーソルタイプの設定を変更することが可能です。例えば、カーソルタイプの設定で Large Cursor 90 のオプションを選択すると、デザインオブジェクトの配置や移動を行う場合、カーソルがデザインウィンドウの端まで表示されます。

デザインオブジェクトの配置

回路図のデザインオブジェクトの配置方法の基本的な手順を以下に示します。
1. 配置したいオブジェクトのタイプを選択します。オブジェクトタイプの選択は、Place(配置)メニューから項目を選択(例えば、Place » Wire)するか、Placement ツールバーのアイコンをクリックします。配置のためのショートカットキーも用意されています(例えば P, W でワイヤが配置されます。)。コンポーネント(パーツ)を配置するには、Library パネルの Place ボタンをクリックするか、Library パネルに表示されているコンポーネント名を選択し、ドキュメント上にドラッグします。
2. 配置のためにオブジェクトが選択されると、カーソルは十字に変わり、編集モードであることを示します。そしてオブジェクトがカーソルのところに "フローティング" の状態で表示されます。
3. 配置する前にオブジェクトの属性を編集するには、TABキーを押します。これによって、オブジェクトの Properties ダイアログが表示され、様々なオプションの変更が可能となります。

属性の設定が終了すれば、OKボタンをクリックし、配置モードへ戻ります。
配置中にオブジェクトの編集を行うと、デジグネータのように数字を含んだ識別子が自動的にインクリメントされていきます。また、配置中に行った変更は、そのオブジェクトタイプのデフォルト値になります。Preferences ダイアログ(T, P)の Schematic フォルダ下の Default Primitives タブにある Permanent オプションが有効でなければ、配置中に行ったオブジェクト属性の変更によってオブジェクト属性のデフォルト値が更新されます。
4. オブジェクトを配置するにはカーソルを適切な位置に移動し、左クリックか ENTER キーを押します。ワイヤやポリゴンなどの複雑なオブジェクトでは、カーソルの移動とクリックを繰り返して、オブジェクトの頂点をすべて配置します。
注記: オートパンの機能が有効であれば、編集ウィンドウの端を越えてカーソルを移動させるとドキュメントの表示エリアを移動することができます。オートパンのスタイルとスピードは、Preferences ダイアログの Schematic フォルダ下の Graphical Editing タブで設定が可能です。
Preferences ダイアログの Schematic フォルダ下の AutoFocus タブにある AutoFocus オプションで、接続されているオブジェクトを配置、または編集するときに回路図画面を自動的にズームしたり、現在配置しているワイヤに関係のないワイヤをすべて薄暗く表示するなどのコントロールができます。
その他、ズーミングやパンニングオプションは、ショートカットキーやマウスホイールで行えます。 配置時に Ctrl+マウスホイールで、ズームイン、ズームアウトが行えます。また、ホイールボタンを押してマウスを上に移動するとズームインし、下に移動するとズームアウトします。Preferences ダイアログの Schematic フォルダ下の Mouse Configuration タブで、マウスの動作の設定が可能です。
5. オブジェクトを配置した後も、配置モードが継続され(カーソルが十字のマークのまま)、同じタイプの別のオブジェクトがすぐに配置できます。
6. 配置モードを終了するには、右クリックかESCキーを押します。ポリゴンの配置の様に、いくつかのケースでは、これを2回行う必要があります。1回でオブジェクトの配置を終了し、更にもう1回実行することで配置モードを終了します。配置モードを終了すると、カーソルはデフォルトの形状に戻ります。

リエントラント(再帰可能)な編集

回路図エディタには、リエントラント編集と呼ばれる強力な機能が用意されています。これは、ある操作を実行中に、その操作を中止することなく、ショートカットキーで別の操作を実行する機能です。例えば、パーツを配置中、スペースキーで回転させることができ、配置の作業がキャンセルされることはありません。パーツの配置が済めば、次のパーツが現れ、回転させることができます。
リエントラント編集が有効に使える例としては、ポートにワイヤを接続する場合で、先にワイヤの配置を始めてから、まだ、配置していないポートに接続をする場合です。ワイヤの配置モードを終了する必要はなく、単にポートを配置するショートカットキー(P, R)を使ってポートを配置し、Escキーでポートの配置を終了し、ワイヤをポートに接続します。

回路図ドキュメント上の距離の測定

回路図エディタには、距離ツールが Reports メニューにあります(Reports » Measure Distance または Ctrl+M ショートカットキー)。このツールを使用して、回路図ドキュメント上の2点間の距離を測定することができます。
このコマンドを実行すると、回路図ドキュメント上の 2 つの点をクリックするよう求められ、2 つの点を選択すると、Information ダイアログに、全体の Distance 値、X Distance と Y Distance の値が、小数点以下 2 桁で表示されます。
測定単位は、回路図ドキュメントで選択したシステム単位で決まります(Design » Document Options)。ダイアログに測定単位が含まれていない場合、そのドキュメントはデフォルト単位 DXP(1 単位は 10 ミル)を使用するように設定されていることを意味します。システム単位を切り替えることで、Imperial と Metric の単位を切り替えることができます(View » Toggle Units)。

グラフィカルオブジェクトの配置

回路図オブジェクトは、グラフィカルと電気的なオブジェクトの2つのグループに分けられます。

ラインや円弧、文字などのグラフィカルオブジェクトを配置するには、Utilities ツールバー(View » Toolbars » Utilities)から利用可能な、Drawing Tools ツールバーを使用します。Paste Array(Edit » Paste Array)を除く、Drawingツールバーの機能は*Place* » Drawing Tools メニューからアクセスすることができます。

電気的なオブジェクトの配置

回路図の電気的なデザインオブジェクトは、実際の回路を作画するために用いられます。電気的オブジェクトには、コンポーネント(パーツ)や、ワイヤ、バス、ポートのように接続するためのオブジェクトが用意されています。電気的オブジェクトを配置するには、Place メニューか Wiring ツールバー(View » Toolbars » Wiring)を使用します。

次のセクションではパーツ(コンポーネント)とワイヤの2つのオブジェクトタイプの共通の配置方法を紹介します。

パーツの配置

Place » Part (P, P)を選択するか、Wiring ツールバーの ボタンをクリックします。Place Part ダイアログが表示されます。Lib Ref フィールドにコンポーネントの名称を入力するか、ブラウズボタン (...)をクリックし、ライブラリからパートを検索するか、適切なライブラリを追加します。History ボタンをクリックすると以前配置したパーツを検索することができます。

また、パーツは、Library パネルの Place ボタンや回路図のライブラリエディタからでも配置できます。あるいは Libraries パネルでコンポーネント名をリストから選択し、ドキュメント上にドラッグすると、カーソル上にフローティングの状態で現れ、配置が可能となります。クリックで配置が確定します。
パーツの配置には、スナップグリッドをお使いください。ピンエンドをグリッドポイント、例えば、10 に固定することができます。G キーでスナップグリッドが 1、5、10 と切り替わります。

ワイヤの配置


ワイヤは、ポイント間の電気的な接続を示すために使用されます。ワイヤを配置するときには、誤ってラインコマンドを使用せずに、必ず、Place » Wire コマンド を使用してください。また、ワイヤの配置コマンドは回路図ドキュメント上で右クリックか、Wiring ツールバーからも実行できます。
ワイヤの終端は、電気的なオブジェクトの接続ポイントと接続する必要があります。例えば、ワイヤをピンに接続するには、ワイヤの終端をピンのホットエンドに接続します。ワイヤを配置するときには、エレクトリカルグリッドの範囲内にある別の電気的なオブジェクトに近づけると、カーソルがオブジェクトに引き込まれ、「ホットスポット」(赤い十字)が表示されます。このホットスポットによって有効な接続ポイントが示され、カーソルはエレクトリカル接続ポイントに自動的に引き込まれます。ワイヤはホットスポット上で終了すると、自動的に切断されます。
エレクトリカルグッドをスナップグリッドより大きな値を設定すると、電気的なオブジェクトを1格子分離して配置するのが難しくなるので、スナップグリッドより少し小さな値に設定することをお勧めします。
配置したワイヤが電気的なオブジェクトに接続していない状態で、配線を中断するには右クリック(あるいは ESC キー)を実行します。更に、右クリック(あるいは ESC キー)を実行すると、配置モードを終了します。
ワイヤの配置中、BACKSPACE キーで直前に配置した頂点を削除することができます。

ワイヤの配置モード

ワイヤを配置するときには、SHIFT+SPACEBAR でワイヤの配置モードが切り替わります。用意されている配置モードは以下のとおりです:

  • 90 度
  • 45 度
  • フリーアングル
  • オートワイヤ
    モードは、ワイヤを配置する際のコーナーの作成方法と、配置角度がどのように作成されるかを指定します。SPACEBAR を押すと開始と終了のサブモードが切り替わるか(90°モードまたは45°モードの場合)、フリーアングルとオートワイヤモード間で切り替わります(これらのモードのいずれかがアクティブな場合)。
    オートワイヤモードは特別なモードで、指定した回路図上の2点を自動的に接続します。オートワイヤ機能が自動的に障害物を避けて接続します。このモードで TAB キーを押すと、オートワイヤのオプション設定を行う、Point to Point Router Options ダイアログが表示されます。

ジャンクション


ワイヤには、オートジャンクション機能が用意されています。ワイヤの始点か終点が別のワイヤやピンに接続するとジャンクションオブジェクト(ドット)が自動的に挿入されます。オートジャンクションとマニュアルジャンクションの表示、ジャンクションサイズと色は、Preferences ダイアログの Schematic フォルダ下の Compiler タブでコントロールすることができます。また、ワイヤの交差を設定し、既存のワイヤを交差に変換するためのオプションが、Preferences ダイアログのSchematic フォルダ下の General タブに用意されています。
配置したワイヤの編集方法はこのアプリケーションノート後半にある Editing Placed Wires を参照してください。

回路デザインオブジェクトの編集

回路図上に配置したオブジェクトには、様々な編集方法が用意されています。オブジェクトはドキュメント内での移動や、ドキュメント内およびドキュメント間での切り取り、コピー、貼り付けなどの操作が可能です。また、オブジェクトの色、デジグネータ、ネット割り付けなど属性の変更も可能です。ポリライン形状(バス、ワイヤ、ポリゴン、ラインなど)などのいくつかのオブジェクトでは、配置後にグラフィカルに形状を変更することができます。
一つのオブジェクトを編集することも、クエリなどの強力な編集機能を使ってデザイン全体のオブジェクトを編集することも可能です。Find Similar Objects ダイアログや SCH List パネル、SCH Inspector パネルなどの強力なツールで、グループ化したオブジェクを一度に編集することができます。

配置されたコンポーネント(パーツ)とフットプリントは、それらの属性ダイアログで変更が可能です。あるいはライブラリエディタで変更し、更新することができます。ピンは、回路図の Component Properties ダイアログ(Edit Pins ボタン)から Component Pin Editor を使って編集することができます。

配置されたオブジェクトのグラフィカルな編集

ワークスペースに表示されているオブジェクトをグラフィカルに編集するのは簡単です。これを行うには、まず、オブジェクトを選択する必要があります。

オブジェクトが選択されると、オブジェクトの移動やグラフィカルな属性が変更できます。オブジェクトを選択するためにクリックすると、「ハンドル」や頂点が表示されます。選択されたオブジェクトをグラフィカルに編集するには、ハンドル上でクリックし、ボタンを押さえ続けます。オブジェクトのそのポイントがカーソルとともに移動しますので、新しい位置にマウスを移動させ、サイズを変更しボタンを放します。オブジェクトを移動するには、オブジェクト上でマウスボタンを押さえ続け、ドラッグします。また、削除するには、Delete キーを押します。

配置されたワイヤの編集

頂点の移動、セグメントの移動、ワイヤ全体の移動、ワイヤを伸ばすなど、配置されたワイヤの編集方法はいくつか用意されています。また、ワイヤの Properties ダイアログにある Vertices タブから頂点の編集、追加、削除が可能です。詳細は、Properties ダイアログから Editing Vertices を参照してください。

ワイヤの頂点移動による編集

ワイヤの頂点を移動するには、ワイヤをクリックして選択します。移動したい頂点上にカーソルを移動すると、カーソルが2方向の矢印に変わります。図のようにマウスボタンをクリックしたまま、頂点を新しい位置にドラッグします。

ワイヤセグメントの移動

ワイヤのセグメントを移動することも可能です。ワイヤを選択し、カーソルをセグメントの上に移動すると、カーソルが 4 方向の矢印に変わります。下図のようにマウスボタンをクリックしたまま、セグメントを新しい位置にドラッグします。

ワイヤ全体の移動

形状を変えずにワイヤ全体を移動するには、選択をしないで単にドラッグをします。

ワイヤの延長

配置されたワイヤは伸ばしたり、頂点を追加することができます。ワイヤを選択し、カーソルをワイヤの終端に移動すると2方向の矢印に変化します。ワイヤの終端をクリックしてドラッグすると、「ルックアヘッド」セグメントが表示され、新しい位置でクリックすると配置されます。カーソルを移動中、SHIFT + SPACEBARで配置モードを変更することができます。
同じ方向に伸ばしたい場合は、選択した終端をドラッグする際に ALT キーを押してください。

ワイヤの切断

Edit » Break Wire コマンドでワイヤセグメントを2つに切断することができます。このコマンドは、カーソルがワイヤ上にあるときに右ボタンクリックを実行することでも利用できます。(デフォルトでは)表示される「カッターボックス」をワイヤセグメント上に配置することで、カットします。カットされる部分は、図のようにマスク表示されます。カットされる長さは、2つのセグメント間の領域になります。コマンドを実行中、SPACEBAR を押すと、カットする長さが(セグメントにスナップ、グリッドサイズにスナップ、固定長の)3つのモードで切り替わります。TAB キーを押すと、固定長の長さやその他のカッターオプションが設定できます。ワイヤをカットするにはクリックします。右クリックか、ESC キーを押すとワイヤ切断モードが終了します。ワイヤ切断のオプションは Preference ダイアログの Schematic フォルダ下の Break Wire タブでも設定が可能です。
Preference ダイアログの Schematic フォルダ下の General タブの Components Cut Wires オプションも設定することができます。このオプションと Optimize Wires and Buses オプションが有効であれば、コンポーネントをワイヤ上に配置すると、ワイヤが2つに分割され、その終端がコンポーネントの2つの 'ホット' ピンと自動的に接続されます。

マルチワイヤ

回路図エディタのマルチワイヤ編集モードでは、複数のワイヤを同時に延長することができます。平行した複数のワイヤで、終端座標が同じになっているものの1つのワイヤをドラッグすると、選択されているその他のワイヤも移動し、終端の位置が揃います。

1つの頂点、また全ての整列された頂点をドラッグ、開放することで整列したまま移動できます。

回路図オブジェクトの移動とドラッグ

Altium Designer でのオブジェクトの移動は、それに接続されているオブジェクトに関係なく、移動が行われます。例えば、コンポーネントを移動する場合、そこに接続されているワイヤは移動しません。逆に、コンポーネントのドラッグでは、移動後、ワイヤとの接続が維持されます。選択したオブジェクトを移動する際、常に電気的な接続を維持したい場合は、Preferences ダイアログのSchematic フォルダ下の Graphical Editing タブの Always Drag オプションを有効にします。

オブジェクトの移動

単独の選択されていないオブジェクトあるいは、選択されている複数のオブジェクトをマウスのドラッグで移動することができます。また、特に配置されているオブジェクトの前後にオブジェクトを移動したい場合、Edit » Move コマンドを使用することができます。 
シート内でオブジェクトを移動する場合には、あらかじめオブジェクトを選択する必要はありません。単に電気的なホットスポットマークが表示されるまでマウスボタンを押さえ続け、コンポーネント/オブジェクトを新しい位置へドラッグします。カーソルが一番近い電気的なホットスポットに移動します。例えば、オブジェクトをクリックしたとき、カーソルはピンに最も近ければそこに移動します。これは Preferences ダイアログの Schematic フォルダ下の Graphical Editing タブのObject's Electrical Hot Spot オプション(デフォルト)、または Center of Object オプションによって、移動やドラッグする際の動作が決まります。
オブジェクトの移動中に:

  • SPACEBAR を押すと、オブジェクトは回転します。回転は、反時計回りで90°ステップで回転します。SHIFT+SPACEBAR を押すと、オブジェクトは時計回りで回転します。
  • X キー、Y キーを押すとX軸、Y軸に沿って、それぞれオブジェクトが反転します。
  • ALT キーを押すと、移動方向が垂直、水平方向のいずれかに制限されます。

選択したオブジェクトの移動

選択したオブジェクトを移動するには、回路図ドキュメント上で Ctrl キーと矢印キーの組み合わせを使用するか(垂直または水平)、Ctrl キーと Shift キーと矢印キーの組み合わせを使用します。
選択したオブジェクトの移動は、Document Options ダイアログ(Document » Options またはショートカット D, O)の現在の Snap Grid 設定に応じて設定されます。このダイアログでスナップグリッド値を変更します。このグリッド値は、Altium Designer のステータスバーにも表示されます。Preferences ダイアログの Schematic フォルダ下の Grids タブを使用して Imperial(インチ)と Metric(ミリ)のグリッドのプリセットを設定することもできます。  スナップグリッド設定値を切り替えるには、ショートカット G を使用します。あるいは、View » Grids のサブメニューや右クリックメニューから Grids を選択します。

  • Ctrl キーを押しながら矢印キーを押すと、選択したオブジェクトは、現在のスナップグリッド値に応じて少し移動します。
  • Ctrl キーと Shift キーを押したまま矢印キーを押すと、選択したオブジェクトは、スナップグリッド値に 10 を掛けた分だけ大きく移動します。

オブジェクトのドラッグ

Edit » Move » Drag コマンドで、例えば、コンポーネント(パーツ)やポート、ワイヤ、バスなど、ワイヤが接続されているオブジェクトの接続を維持した状態での移動が可能です。カーソルが十字に変化し、ドラッグしたいオブジェクトの上でクリックするか、ENTERキーを押します。オブジェクトを移動し、適切な位置でクリックするか、ENTER キーを押します。引き続き、他のオブジェクトが移動するか、あるいは、右クリックか ESC キーでドラッグモードを終了します。
選択した複数のオブジェクトを、接続を維持したままドラッグするには、Edit » Move » Drag Selection コマンドを使用します。
あるいは、ショートカットキーを使用してオブジェクトをドラッグすることも可能です。クリックするときに CTRL キーを押さえ続け、マウスを移動します。ドラッグを始めた後、CTRL キーを放しても構いません。これはオブジェクトを複数選択した場合も動作します。CTRL キーを使用すると、Preferences ダイアログの Always Drag オプションの設定が一時的に切り替わりますので、注意してください。
オブジェクトをドラッグしている間は:

  • ドラッグ中に SPACEBAR か、SHIFT+SPACEBAR を押すと、ワイヤの配置モードが変化します。
  • 移動中、CTRL+SPACEBAR でオブジェクトが回転します。回転は、反時計回りで90°ステップで回転します。
  • 移動中、X か Y キーを押すと、X 軸、Y 軸に沿ってそれぞれ反転します。
  • 移動中、SPACEBAR を押すと、オブジェクトに接続されているワイヤのモードが変化します。
  • 移動中、ALT キーを押すと、移動方向が最初に移動した方向によって、垂直、水平方向のいずれかに制限されます。

オブジェクトの移動をロックする

回路図オブジェクトが誤って移動されるのを防ぐために、これらのオブジェクトの Locked 属性を有効にして、グラフィカルに編集できないようにすることができます。ロックされたデザインオブジェクトを編集しようとすると、Confirm ダイアログが表示され、動作を続行するかどうか尋ねてきます。
Preferences ダイアログの Schematic フォルダ下の General タブで Protect Locked Objects オプションが有効になっており、このデザインオブジェクトの Locked オプションが有効になっている場合、このオブジェクトは移動できず、メッセージも表示されないことに注意してください。ロックされたオブジェクトを含むオブジェクトグループを選択しようとしても、ロックされたオブジェクトは選択されません。

コピー&ペーストの使用法

回路図エディタでは、回路図ドキュメント内やドキュメント間でオブジェクトのコピー、ペーストができます。例えばコンポーネントをある回路図から別の回路図ドキュメントへコピーすることができます。オブジェクトをウィンドウズのクリップボードへコピーし、別のドキュメントへ貼り付けることができます。テキストはウィンドウズのクリップボードから回路図のテキストフレームへコピーすることができます。また、Microsoft Excel などの他のアプリケーションや Altium Designer 内のグリッドスタイルコントロールから、テーブルタイプのセレクションを直接コピー/ペーストすることができます。更に、高度なコピー/ペーストの操作は、スマートペースト機能を使って行えます。
コピーしたいオブジェクトを選択し、Edit » Copy (Ctrl+C) を選択してコピーするオブジェクトの原点でクリックします。これは、貼り付けする際、正確な位置にオブジェクトを配置するためです。尚、この機能を利用するには、Preferences ダイアログの Schematic フォルダ下の Graphical Editing タブの Clipboard Reference オプションが有効である必要があります。

スマートペーストの使用

回路図エディタのスマートペースト機能により、選択したオブジェクトを他のオブジェクトに変換して、ペーストすることができます。例えば、選択したネットラベルをコピーし、スマートペーストにより一回の操作で、ポートとしてペーストしたり、下図のように選択したシートエントリをネットラベル+ワイヤとしてペーストすることができます。

シートエントリは、コピーして Smart Paste 機能を使用してコピーしてネットラベルやワイヤに変換できます。  
また、スマートペーストしたいセレクションのオブジェクトをコントロールできます。セレクションをスマートペーストする時、チェックボックスを無効にして特定のオブジェクトを無視できます。その他の便利な機能は、選択した回路をグラフィックとして貼り付ける機能です。これを使用して、他のシートにある回路のグラフィックな箇所を簡単に含めることができ、必要に応じてそのサイズを設定します。Edit » Smart Paste を選択して、貼り付ける時に、クリップボードにコピーされたオブジェクトを変更します。

シート上でのテキスト編集

テキストストリングは、回路図エディタ上で直接編集することができます。クリックしてテキストストリング、テキストフレーム、注釈のいずれかを選択し、再度クリックする(あるいはショートカットキー F2 を押す)と、回路図シート上で直接テキストが編集できます。この動作は、Preferencesダイアログの Schematic フォルダ下の General タブにある Enable In-place Editing オプションをオフにすることで無効にできます。

アノテーションとリ・アノテーション

Altium Designer には、デザインをアノテートするために3種類のアプローチが用意されています。回路図レベルのアノテーション、ボードレベルのアノテーション、PCBアノテーションです。
回路図レベルのアノテーション機能では、パラメータによりコンポーネントを一致させることができ、全てのデジグネータまたは重複するデジグネータのリセット、PCB ドキュメントから回路図へのバックアノテート、回路図シート毎のデジグネータインデックスコントロール、サフィックスオプションが用意されています。
回路図エディタで、Tools » Annotate Schematics コマンドを使用して Annotate ダイアログを開きます。そこで、カレントプロジェクトの選択したシート内の全てまたは選択した部品のデジグネータを、固有に連続した順番で再割り当てできます。 

Annotate ダイアログが開いている時に F1 キーを押すと、このプロセスの詳細情報が表示されます。
また、Annotate ダイアログを実行せず、現在、デジグネータが割り当てられていない部品へ固有のデジグネータを割り当てるには Tools » Annotate Schematics Quietly コマンドを使用します。このコマンドは、以前 Annotate ダイアログで設定した回路図アノテーション設定に従います。Annotate Schematics Quietly は、重複に対して固有のデジグネータを割り当てません。
アクティブプロジェクトの全てのコンポーネント デジグネータをリセットする場合、必要に応じて、Tools » Reset Schematic Designators コマンドを使用できます。または、重複しているデジグネータをリセットする場合は Tools » Reset Duplicate Schematic Designators コマンドを使用します。
Annotate ダイアログで定義した回路図アノテーション設定に従って、全てのコンポーネント デジグネータをリ-アノテートするには、Tools » Force Annotate All Schematics コマンドを使用します。
PCBドキュメントでデジグネータをリ-アノテートする時、生成されたWAS-ISファイルを使用して、バックアノテート(Tools » Back Annotate Schematics)により、アクティブプロジェクトのソース回路図シート内のコンポーネントのデジグネータを更新できます。
ボードレベルアノテーションは、回路図エディタを通じて、コンパイルしたコンポーネント(コンポーネントの物理的な表示)をアノテートすることです。Tools » Board Level Annotate コマンドを使用して Board Level Annotate ダイアログを開きます。このダイアログで、割り付け方針に基づきコンパイルしたコンポーネントの割り付け方法の計算、PCB ドキュメントからコンパイルしたドキュメントへのバックアノテート、カスタム名の指定、全てのデジグネータのリセットを行うことができます。

Board Level Annotation ダイアログでは、アノテートオプションを通じた割り付け方針のカスタマイズ、全てのデジグネータのリセット、コンポーネントに対するカスタム名の作成を行うことができます。
PCB エディタで、Tools » Re-Annotate コマンドを使用して Positional Re-Annotate ダイアログを開き、デジグネータを前後関係に依存して再割り当てすることができます。リ・アノテーション操作によって、ファイル名に日付と時刻を含む固有の *.WAS ファイルが生成されます。このファイルは、回路図レベル、またはボードレベルのアノテーション中にバックアノテーションを実行する時に使用されます。

オブジェクトの属性編集

オブジェクトの属性を表示、編集するには、次のいずれかの方法で、Properties ダイアログを開きます: 

  • 配置中などオブジェクトがカーソルで移動できる 'フローティング状態' の時、TABキーを押し、Properties ダイアログを開きます。
  • 配置されているオブジェクトをダブルクリックし、直接、properties ダイアログを開きます。
  • メニューから Edit » Change を実行し、編集モードに入ります。編集したいオブジェクトをクリックします。編集モードを終了するには、右クリックか ESC キーをクリックします。
  • 配置されたオブジェクトを選択するためにクリックし、次に紹介する SCH Inspector や SCH List パネルを使って属性を編集します。

Properties ダイアログから頂点の編集

バス、ワイヤ、ポリライン、ポリゴンオブジェクトの Properties ダイアログにある Vertices タブで、頂点の座標を編集できます。例えば、Wire properties ダイアログには Vertices タブがあります。そこで必要に応じて選択したワイヤオブジェクトの個々の頂点を編集できます。

タブには、ワイヤの現在の全ての頂点がリスト表示されます。ワイヤに新しい頂点を追加、既存の頂点の座標を編集、選択した頂点全体を削除できます。
Menu ボタンをクリック、またはメインリスト領域内で右クリックし、表示されたポップアップメニューから希望の設定(頂点の編集、追加、削除、またはセルのコピー、貼り付け、選択、移動)を選択します。Move Wire By XY コマンドは、全体のワイヤオブジェクトを移動します。Move Wire By ダイアログで、各頂点の X、Y 座標に適用する値を入力できます

SCH Inspector パネルでのオブジェクト編集

SCH Inspector パネルでは、現在アクティブな、または開いているドキュメントの1つ、または複数のデザインオブジェクトの属性を表示および編集できます。SCH Filter パネル(F12)、または Find Similar Objects コマンド(Shift+F、または選択したオブジェクトを右クリックし、Find Similar Objects を選択)と併用して使用すると、同じ種類の複数のオブジェクトを変更できます。

1つ、または複数のオブジェクトを選択して、F11 を押すか、または SCH Inspector タブをクリックして SCH Inspector パネルを表示します。もし、パネルが表示されない場合、ステータスバーにある SCH ボタンをクリックし SCH Inspector を選択するか、または View » Workspace Panels » SCH » SCH Inspector を選択します。また、デザインオブジェクトをダブルクリックした時、オブジェクトの Properties ダイアログを表示する代わりに SCH Inspector パネルを表示するには、Preferences ダイアログの Schematic フォルダ下の Graphical Editing タブの Double Click Runs Inspector オプションで設定できます。 
SCH Inspector パネルは、選択したオブジェクトに共通な属性を表示するだけであることに注意してください。リスト表示された属性は SCH Inspector パネルで修正できます。新しい属性を入力しチェックボックスをクリック、またはドロップダウンリストから選択します。Enter を押すか、またはパネルの他のセルをクリックして変更を実行します

SCH List パネルでのオブジェクト編集

オブジェクト(または、複数のオブジェクト)を選択して、Shift+F12 を押して SCH List パネルを表示します。SCH Filter パネル (F12) 、または Find Similar Objects コマンド(Shift+F) と併用して使用する時、複数のデザインオブジェクトをターゲットとし編集できます。SCH List パネル上部の View/Edit ドロップダウンメニューから Edit を選択して、SCH List パネルからオブジェクトの属性を変更できます。

SCH List パネルの Object Kind のリストからオブジェクトをダブルクリックすると、そのオブジェクトの Properties ダイアログが表示されます。

Labels
  • None