Altium Wiki

Information and resources for electronic product designers

Skip to end of metadata
Go to start of metadata

ガーバーファイルを出力するには、生成に先立ち、Gerber Setupダイアログで出力のオプションを設定します。

Output GeneratorOG0101 (v1.3) March 26, 2008

ガーバー設定ダイアログ

Gerber Setupダイアログでは、いくつかのツールを使用してガーバーファイルの出力オプションを設定します。 このダイアログは、次のように、いくつかのタブに分かれています:

General(全般)タブ

このタブでは、出力するガーバーファイルの単位系とフォーマットを指定します。 単位系は、インチかミリのどちらかを指定します。
フォーマットは、座標値データの精度を指定します。 これは、PCBワークスペースのオブジェクト配置精度に適したものを選択する必要があります。 例えば、2:3フォーマットでは、解像度は1 mil(=1/1000インチ)になります。 デザイン上のオブジェクトが1milより細かいグリッドを使用してに配置されている場合、このフォーマットは適していません。 逆に、精度の高いフォーマットは、フォトプロットや製造時に支障をきたしたり、高価になったりするかもしれません。

Layers(レイヤ)タブ

Layers _tab は、エンベデッドボードアレイ(面付け)に対するレイヤの相互干渉を表示します。 ここで、いくつかの干渉違反が赤色で表示されていることに注意してください。_このタブでは、どのレイヤをガーバーファイルに生成するか選択します。 また、各レイヤに対し、鏡面反転のガーバーファイルを作成するように指定できます。
どのメカニカルレイヤをすべてのガーバープロットに追加するか、についても指定できます。
ガーバー出力をPCBデザインから生成する際に、エンベデッドボードアレイや面付け(図 1参照)が含まれていると、レイヤの相互干渉について、デザインが自動的に解析されます。

  • Flipped(反転している)エンベデッドボードは、レイヤスタックが反転して表示されます。
  • 異なる中間信号レイヤと内部プレーンは、まだ同じ中間レイヤのパネルに表示されています。
  • 中間信号レイヤと内部プレーンは、再度、それぞれ、反転されます

Drill Drawing(ドリルドローイング)タブ

このタブで、どのレイヤペアにドリルドローイングが必要か指定します(鏡面反射のファイルも出力できます)。 また、ドリルのサイズを示すドローイングシンボルのタイプとサイズの指定もできます。
このタブではまた、どのレイヤペアにドリルガイド・ファイルが必要か指定できます(鏡面反射のファイルも出力できます)。 ドリルガイドはPCB上の各ドリルの位置をあらわすプロットで、小さな十字でマークされています。

Apertures(アパーチャ)タブ

このタブで、デザインに必要なアパーチャ情報の設定などを行います。
Embedded apertures (RS274X) オプションが有効のときは、ガーバーファイルを作成するたび、自動的にアパーチャリストが作成されます。 アパーチャは、RS274X(拡張ガーバー形式)の標準規格に従って、ガーバーファイルに埋め込まれます。 この機能を使えば、必要なアパーチャが最新のアパーチャリストにすべて含まれているかどうか、気にする必要がありません。
このオプションを無効にした場合、タブのメインアパーチャ領域が有効になり、アパーチャテーブルのロード、作成、編集、保存が自由にできます。

新しいアパーチャを作成すると、DCodeダイアログが表示されます。 最大1000個のドラフトコードが、範囲D00-D9999で定義できます。ただし、これらのコードのうち、いくつかは(通常、D00-D09)はプロッタ用に"予約済み"ですので、これらのコードの使用はお勧めできません。 新規のドラフトコードを入力する際は "D" を含めないでください。

新しいコードを入力すると編集モードになります。Aperture ダイアログが表示され、ここで必要なアパーチャの属性を編集することができます。

変更は、その時点でメモリにロードされているアパーチャファイルにすべて適用されます。 これらの変更をちゃんと保存するには、Save ボタン(Gerber Setup ダイアログの Apertures タブ)を使ってください。

Advanced(詳細設定)タブ

このタブでは、ガーバーを作成する場合に適用される仮想のフィルムサイズや、アパーチャの許容差、ゼロ省略の使用などのオプションを指定します。
Center on film オプションを有効にすると、ガーバーデータは、指定したフィルムの中心に自動的にプロットされます。
このタブではまた、出力するプロッタのタイプをベクタかラスタのどちらかで指定できます。

ガーバーファイルの生成

次の表はPCBドキュメントから出力できるガーバーファイルのリストです。 各ケースにおいて、ガーバーファイルは、PCBドキュメントと同じ名前(例えば、PCBDesignName.GerberExtension)で生成されます。

ガーバー拡張子

内容

G1, G2, etc

Mid-layer 1, 2, etc

GBL

Bottom Layer

GBO

Bottom Overlay

GBP

Bottom Paste Mask

GBS

Bottom Solder Mask

GD1, GD2, etc

Drill Drawing(Drill-Pair Manager ダイアログに表示されるドリルペアの順序に基づいて生成)

GG1, GG2, etc

Drill Guide(Drill-Pair Manager ダイアログに表示されるドリルペアの順序に基づいて生成)

GKO

Keep Out Layer

GM1, GM2, etc

Mechanical Layer 1, 2, etc

GP1, GP2, etc

Internal Plane Layer 1, 2, etc

GPB

Pad Master Bottom

GPT

Pad Master Top

GTL

Top Layer

GTO

Top Overlay

GTP

Top Paste Mask

GTS

Top Solder Mask

P01, P02, etc

Gerber Panels

APR

アパーチャファイル(エンベデッドアパーチャ(RS274X)で作成された場合)

APT

アパーチャファイル(エンベデッドアパーチャ(RS274X)を使用しない で作成された場合)

さらに次のファイルも作成されます:

  • PCBDesignName.rul - このファイルには、ガーバーファイルを作成する際、元のPCBドキュメントで定義されているすべてのデザインルールが含まれています。 このファイルは、Gerber SetupダイアログのAdvancedタブにあるGenerate DRC Rules export file (.RUL)オプションが有効になっている場合に作成されます。
  • PCBDesignName.rep - このファイルは生成レポートです。どのガーバーファイルが作成されたかを示します。

エンベデッドアパーチャ(RS274X)が使用されていない場合は、生成される各ガーバーのレイヤに対応したテキストベースのアパーチャファイルが別に作成されます。例えば、GBLでは、対応したアパーチャファイル、拡張子ABLのファイルが生成されます。 これらそれぞれのファイルの内容は同じです。 このケースでは、本当のガーバーのアパーチャファイルは、拡張子 .aptとして区別されます。

注記

使用できる各オプションの詳細情報を表示するには、ダイアログの What's This Help 機能を使用します。 ダイアログの右上にある疑問符( )のボタンをクリックしてから、フィールドまたはオプションをクリックすると、そのフィールドまたはオプションの情報がポップアップ表示されます。

ガーバー出力は、次の2つのどちらかの方法で生成することができます:

  • Output Job Configurationファイル(*.OutJob)で適切な設定を行ったアウトプットジェネレーターを使用します。 出力は、設定したアウトプットジェネレーターを実行することで生成されます
  • アクティブなPCBドキュメントで、メニューコマンドFile » Fabrication Outputs » Gerber Filesを直接実行します。 Gerber SetupダイアログのOKボタンをクリックすると、すぐに出力が生成されます。

注 : 出力がPCBから直接生成された場合にGerber Setup ダイアログで行われた設定は、Output Job Configurationファイルの同じ出力タイプの設定とは区別されています。 前者の場合、設定はプロジェクトファイルに保存され、後者の場合は、Output Job Configurationファイルに保存されます

ガーバー出力を生成するときは、出力が新規のCAMドキュメントで自動的に開くように指定できます。 この方法は、どのように出力を生成したかによって設定箇所が異なります:

  • Output Job Configurationファイルからの場合 - Gerber Outputのオートロードオプションを、Output Job Options ダイアログ(OutputJobエディタからTools » Output Job Options)で有効にします。
  • PCBから直接の場合 - Open outputs after compileオプションを、Options For Project ダイアログ(Project » Project Options)の Optionsタブで有効にします。


PCBの製造サイドがエンベデッドアパーチャをサポートしていない場合でも、Embedded apertures (RS274X) オプションを使って出力することを強くお勧めします。 現在、一般的なほとんどのフォトプロッタは、ラスタプロッタです。どんなサイズのアパーチャにも対応しています。 通常、それらのプロッタはエンベデッドアパーチャ付のガーバーファイルを読み込むことができます。

製造サイドがエンベデッドアパーチャを使用しない場合は、別のアパーチャファイル(*.apt)をガーバーファイルに含める必要があります。

PCBファイルで、パッドやビアの穴を定義した場合のファイルには、特別なアパーチャを提供する必要があります。 これはPCBエディタが、ドリルドローイングのシンボルや文字を作画するために特別なアパーチャの提供を必要とするからです。 ドリルドローイングプロットを生成しない場合でも、アパーチャが必要になります。 ファイルに穴が無い場合(例えば、ビアがなく、全パッドの穴径が0)は、アパーチャは必要ではありません。

既存のアパーチャファイルを使用する場合は、PCBエディタは、PCBドキュメントで使用されているプリミティブ(トラック、パッドなど)をスキャンし、読み込んだ .aptファイルのアパーチャの内容と照合します。 プリミティブに正確にマッチするアパーチャが存在しない場合は、PCBエディタは、より細いアパーチャで、そのプリミティブを自動的に「塗り潰し」ます。 「塗り潰し」に適したアパーチャが存在しない場合は、.MAT(マッチ)ファイルが欠落アパーチャのリストを作成し、ガーバーファイルの生成は中断されます。

アパーチャの自動生成機能を使用すると、ドリルドローイングのシンボルとその他の文字に必要なアパーチャが、文字の高さに比例する幅で、自動的に提供されます。 例えば、デフォルト50mil のドリルドローイングのシンボルサイズは、7milのアパーチャでシンボルが作画されます。 高さが60milの文字は、8milの描画幅になります。 シルクスクリーン(または、オーバーレイ)レイヤに使用する文字のサイズを設定する場合には注意が必要です。つまり、細い線幅にすると基板にうまく印刷できない可能性があります。

ガーバーファイルの拡張子の命名規則は、一般的な業界の慣習に従っています。

基板の製造サイドには、PCBファイルを直接受け入れられるか確認してください。 多くの製造業者が、バイナリのPCBファイルから、直接PCBを作成することが可能になっています。

フォトプロット用のデータを生成する前に、フォトプロット出力センターに連絡を取ってください。 ガーバーフォトツールを生成するときに、利用可能なプロットオプションを編集レベルで一致させておくと、かなりの時間と費用を節約することができます。

生成するファイルの出力パスは、Options for ProjectダイアログのOptions タブで設定します。 デフォルトでは、出力パスは、プロジェクトファイルが存在しているフォルダ下のサブフォルダに設定されます。名称は、Project Outputs for ProjectName です。 出力パスは必要に応じて変更することができます。 別々の出力タイプに、別々のフォルダを使用するオプションは、Options タブでを有効になります。ガーバーファイルは、さらにその下の、Gerber Output というサブフォルダに書き込まれます。

生成された出力はプロジェクトに追加され、Projectsパネルに表示されます。場所は、Generatedフォルダ内の適切なサブフォルダです。 出力タイプでフォルダを分けた場合は、それぞれに対応したGenerated フォルダが、Projects パネルに追加されます(例えば: Generated (Gerber Output))。

Labels
  • None