Altium Wiki

Information and resources for electronic product designers

Skip to end of metadata
Go to start of metadata

このチュートリアルでは、Altium Designerの回路図とPCBのライブラリ・エディタを使用して、回路図コンポーネントとPCBフットプリントを作成する方法を説明します。 このチュートリアルで使用されている用語の説明が用語集として最後にまとめられています。

Tutorial TU0103 (v2.2) May 22, 2008

このチュートリアルでは以下の内容を説明します。

  • ライブラリの新規作成
  • シングル、または複合の回路図シンボルの新規作成
  • 回路図ライブラリ・エディタのレポートを使用したコンポーネントのチェック
  • マニュアル、またはPCB Component Wizard を利用したPCBフットプリントの新規作成
  • 異型パッド形状を含む、その他の特別なフットプリントの作成
  • 3次元コンポーネントの詳細(3Dボディ)
  • PCBライブラリ・エディタのレポートを使用したコンポーネント・フットプリントをチェック
  • 新しいコンポーネントとモデルを使用した統合ライブラリの新規作成

このチュートリアルは、回路図とPCBエディタの操作環境についての理解、また、コンポーネントの配置や編集について慣れている方を対象としています。 このチュートリアルで使用したコンポーネントやライブラリは、Altium Designerがインストールされているフォルダ内のCreating Componentsに収められています。

回路図ライブラリ、モデルと統合ライブラリ

回路図コンポーネントシンボルは、回路図ライブラリ(.SchLib)で作成されます。 これらのライブラリのコンポーネントは、個別のフットプリント・ライブラリやモデル・ファイルで定義されたフットプリントやその他のモデルを参照します。 これらの個別のコンポーネント・ライブラリからコンポーネントを配置できます。 または、シンボル・ライブラリ、フットプリント・ライブラリ、モデル・ファイルを統合ライブラリ(.IntLib)へコンパイルできます。
統合ライブラリの長所は、持ち運びやすさ(1つのファイルにまとめられています)と、内部のコンポーネントやモデルを編集できないようになっている点です。 Altium Designerのコンポーネントの多くは(ISO に対応した約70,000のコンポーネント)統合ライブラリとなっており、Altium DesignerがインストールされているフォルダのLibraryに保存されています。 統合ライブラリからは、ソース・ライブラリを抽出することができます。統合ライブラリを開いてExtract Sourcesを選択してください。編集可能なコンポーネントとして開かれます。 詳細については、TU0111 統合ライブラリの作成 TU0111%20Building%20an%20Integrated%20Library.PDFを参照してください。
更に、Design » Make Project Libraryコマンドを使用して、アクティブなプロジェクトの回路図ドキュメントに配置されているすべてのコンポーネントの回路図ライブラリを作成できます。

回路図コンポーネントの作成

回路図ライブラリ・エディタは、回路図コンポーネントを作成、修正し、コンポーネント・ライブラリを管理するために使用します。 これは、回路図エディタに似ており、ピン・ツールが付加された同じグラフィック・デザイン・オブジェクトを共有します。
コンポーネントは、回路図ライブラリ・エディタ内のデザイン・オブジェクトを使用して作成します。 または、ある回路図ライブラリから他の回路図ライブラリへ、あるいは回路図エディタから回路図ライブラリ・エディタへコピー、ペーストできます。

新規のライブラリ・パッケージと回路図ライブラリの作成

コンポーネントを作成する前に、それらを保存する新規回路図ライブラリを作成しておくことが必要です。 このライブラリは、個別のファイルでモデルを参照して独立したライブラリとして作成することができます。 コンポーネントを作成するには、回路図ライブラリと参照したモデルを統合ライブラリ・パッケージでコンパイルすることです。 これはライブラリを作成する前に、新規のライブラリ・パッケージを作成する必要があることを意味します。 ライブラリ・パッケージ(.LibPkg)は、統合ライブラリの基本で、コンパイルして個々の回路図ライブラリ、フットプリント・ライブラリ、モデル・ファイルを1つの統合ライブラリ・ファイルに結び付けます。

_図1 新規のライブラリ(デフォルトのComponent_1という名称で作成されます)
新規の統合ライブラリ・パッケージと空の回路図ライブラリを作成するには、次のステップを実行してください。
1. File » New » Project » Integrated Libraryを選択します。 新しいライブラリ・パッケージ、Integrated_Library1.LibPkgが作成されます。 これは、Projectsパネルに表示されます。
2. Projectsパネル内のライブラリ・パッケージ名を右クリックし、表示されるメニューからSave Project Asを選択します。 New Library.LibPkgを入力し、適切な場所を指定してSave ボタンをクリックします。 拡張子を入力しない場合、拡張子は自動で追加されることに注意してください。
3. File » New » Library » Schematic Libraryを選択し、空の回路図ライブラリを追加します。 Schlib1.SchLibという名称で新規のライブラリが作成され、デザイン・ウィンドウにComponent_1という空のコンポーネント・シートが表示されます。
4. File » Save As を選択し、Schematic Components.SchLibという名称でライブラリを保存します。
5. SCH Libraryタブをクリックし、SCH Libraryパネルを開きます。

新規の回路図コンポーネントの作成


_図2 NPNトランジスタのシンボル_既存のライブラリで新規の回路図コンポーネントを作成するには、通常、Tools » New Componentを選択します。しかし、新規のライブラリは常に空のコンポーネントシートが含まれる為、Component_1と言う名称を変更して最初のコンポーネント(NPNトランジスタ)を作成します。
1. SCH LibraryパネルのComponentsリストから、Component_1を選択し、Tools » Rename Componentを選択します。 Rename Componentダイアログで新しいコンポーネント名(例えば、NPN)を入力し、OKをクリックします。
2.必要ならば、Edit » Jump » Origin [ショートカットJ, O]を選択して、デザイン・ウィンドウの中央(シートの原点)にカーソルを移動します。 原点にカーソルが移動しているかどうかは、画面の左下のステータスを確認してください。 Altiumで用意されているコンポーネントは、シートの中央にある縦と横の線が交差する位置を原点として作成されています。 常に、この原点の近くでコンポーネントを作成する必要があります。 回路図上にコンポーネントを配置する時、この原点に一番近い電気的なホットスポット(ピンの端)でコンポーネントを、 ''つかみ' ます。

図3 Library Editor Workspaceダイアログで単位やその他のシート属性を設定

3.単位やスナップ、表示グリッドは、Library Editor Workspaceダイアログ(Tools » Document Options, ショートカット T, D)で設定できます。
Always Show Comment/DesignatorオプションをLibrary Editor Workspaceダイアログから有効にして、ライブラリドキュメント内の現在のコンポーネント用にComment/Designatorのストリングを表示させることができます。グリッドを変更する必要がある時は、Library Editor Workspaceダイアログを開かなくても、キーボードのGを押して、簡単にスナップグリッドを1, 5, 10と切り換えることができます。
これらの3つの設定は、PreferencesダイアログのSchematic - Gridsページで設定できます。図3に従って、Library Editor Workspaceオプションを設定しますFigure 3。 それから、UnitsタブをクリックしImperial Unitsを有効にしてDXP Defaultsを指定します。 OKボタンをクリックし、ダイアログを閉じます。 もし、ダイアログを閉じた時に回路図ライブラリ・エディタの表示グリッドが見えない場合、表示するまでPage Upキーで拡大します。 ズームは、カーソルの周りで動作するので、原点の近くにカーソルを置いておくことに注意してください。


図4 NPNのボディ
4.NPNトランジスタを作成するため、初めにコンポーネントのボディを定義します。 Place » Line[ショートカット P, L],を選択します。または、Place Line ツールバーボタンを (Utilities ツールバーの中にあります)クリックします。 必要ならば、TABキーを押して、PolyLineダイアログでラインの属性を設定します。 Figure 4をガイドにして(グリッドラインを使用すると簡単に配置できます)、垂直にラインを配置します。
一度クリックして最初のラインの最初の端を決め、もう一方の端までマウスを移動してクリックし、確定させます。右クリックかESCを押してラインの配置を終了します。 カーソルに十字マークが表示されている場合は、まだラインの配置モードになっていることに注意してください。
5.その他の2つのラインを作成します。 このトランジスタでは、不規則な角度にラインを配置します。 ラインを配置する時、水平/垂直、または45度に限定されることに気づくでしょう。 配置モードを切り換えるには、ラインを配置中にShift + Spacebarを押します。 モードの1つにフリーの角度の配置モードがあります。 このモードにより、正確にラインを定義することができます。 これらの2つのラインを定義した後、配置モードを解除するには、ESCを押します。

グラフィカルなラインの正確な位置は、重要ではありません。 コンポーネントデザインで重要なことは、ピンの場所か、ピンのホットスポットと呼ばれる特別な場所です。 これは、電気的な接続を構築する場所で、ピンは常に配線に適するグリッドで配置すべきです。
6.矢印の先は、閉じたポリゴンで作成します。 Place » Polygon[ショートカット P, Y],を選択します。または、Place Polygon ツールバー ボタン (Utilities ツールバー)をクリックします。 ポリゴンを配置する前に、TAB キーを押してPolygonダイアログで属性を設定します。 Border WidthSmallestに設定し、Draw Solidを有効にします。 そして、fillとborder色を同じ色(基準色 229)に設定してOKをクリック、しダイアログを閉じます。 三角形の各頂点を定義し、右クリックして終了します。 右クリックか、ESCを押してポリゴンの配置モードを終了します。 Figure 5は、ポリゴンの頂点の座標を示します。

Utilities toolbar

図5 矢印の先端の座標が正しいか確認するには、座標情報を使用してください。

7.コンポーネントを保存します[ショートカット Ctrl + S]。

回路図コンポーネントにピンを追加


{_}図6 ピン名称と番号が表示されたNPNシンボル_コンポーネントのピンは、コンポーネントに電気的な属性を割り当てて、接続箇所を定義します。 また、グラフィカルな属性も割り当てられます。
コンポーネントにピンを配置するには:
1. Place » Pin [ショートカット P, P]を選択するか、 ツールバーボタンをクリックします。 ピンがカーソルに表示されます。 カーソル側が電気的にホットな端子になり、コンポーネントのボディ側と逆の位置に配置します。
2.ピンを配置する前、配置中にTABキーを押してピンの属性を編集します。 Pin Propertiesダイアログ(Figure 8)が表示されます。 ピンを配置する前にピン属性を定義した場合、定義した設定がデフォルトになります。 そして、ピン番号と数値のピン名称は配置するごとに自動的にインクリメント(+1)されていきます。
3. Pin Propertiesダイアログで、Display Name欄にピン名称(最初のNPNのピン番号である1)を、Designator欄にピン番号(同じく1)を入力します。 もし、回路図シート上にコンポーネントを配置した時にピン名称と番号を表示したい場合は、Visibleのチェックボックスにチェックを入れます。
4.ドロップダウン・リストからピンのElectrical Typeを設定します。 このタイプは、回路図シートの電気的な接続エラーを検知するために、プロジェクトをコンパイルする時、または回路図ドキュメントを分析する時に使用します。 このコンポーネントの例では、すべてのピンのElectrical TypePassiveで設定されています。
5.このピンの長さを設定し、OKをクリックします。 (このコンポーネントの全てのピンを20に設定します。
6.カーソルにピンが表示されている時にSPACEBAR を押すと、ピンを90ºごとに回転できます。 ピンの一端だけが電気的な接続ポイント(ホットスポット)であり、この端子は、コンポーネントのボディ側と逆側に配置する必要があることを覚えておいてください。 ピンの非電気的な接続ポイントの先に、ピン名称があります。
7.コンポーネントを完成させるのに必要なピンを更に追加し、ピン名称、番号、シンボル、電気的なタイプがに示されたNPNシンボルFigure 6と同様になっているか確認します。

図7 3つすべてのピンのピン名称と番号の表示を編集

図8 ピンを配置する前にピン属性を設定
ピン名称、または番号とコンポーネントのボディ間の距離を(1インチの100分の1の単位で)変更したい場合は、Tools » Schematic Preferencesを選択し、Schematic — General ページのPin Margin オプションを変更します。
8.もし、ピン名称と番号をすべて表示して配置した場合、容易に一回の操作ですべての表示状態を変更できます。 これを実行するには、3つのピンだけを選択(Shift + クリックで各ピンを選択)し、F11 を押してInspectorパネルを表示させます。そして、Figure 7のようにShow NameShow Designatorのオプションを無効にします。
9.これでコンポーネントの作画は終了しました。File » Save を選択してファイルを保存します。

ピン追加時の注意点

  • ピン配置後にピン属性をセットするには、そのピンをダブルクリックするか、SCH LibraryパネルのPinsリストをダブルクリックしPin Propertiesダイアログを開きます。 あるいは、上記のようにInspectorで複数のピンを編集します。
  • ピンの名前の上にバーを表示したい場合は、その文字の後ろにバックスラッシュ()を使用します。 例えば、M\C\L\R\/VPP と記入すれば表示は となります。
  • 電源やGNDピンなど回路図では表示させない(ヒドゥン)ピンは、Hide オプションを有効にします。 ヒドゥン・ピンはConnect Toフィールドに記入されている電源やGNDネットに接続されます。 例えば、VCC用のピンは、コンポーネントの配置時、自動的にVCCネットに接続されます。
  • ヒドゥン・ピン、またはヒドゥン・ピンのピン名称/番号を表示させるには、View » Show Hidden Pinsを選択します。
  • Component Pin Editor ダイアログを使用すると、ピンの属性がピン個別のPin Propertiesダイアログを経由しないで直接編集できます。 Library Component Propertiesダイアログ(このダイアログを開くには、SCH Library パネルのコンポーネント名をダブルクリック)で、Edit Pinsをクリックすると、Component Pin Editorダイアログが表示されます(Figure 9)。


図9 Component Pin Editorダイアログですべてのピンの表示、編集が可能

  • 複数のパートがあるコンポーネントでは、選択されたパートに関連したピンがComponent Pin Editorダイアログで白地のバックグランドにハイライト表示されます。 その他の選択されていないパートのピンはグレーです 選択されていないパートでも、同様にピンの編集を行うことはできます。 ピンを選択してEditボタンをクリックすると、Pin Propertiesダイアログが表示されます。

回路図コンポーネントの属性設定

各コンポーネントには、Default Designator、PCB footprint、Models、コンポーネントに定義されているParameterなどの属性があります。 コンポーネントの属性を設定するには:
1. SCH LibraryパネルのComponentsリストからコンポーネントを選択し、Editボタンをクリックするかコンポーネント名をダブルクリックします。 Library Component Propertiesダイアログ(Figure 10)が表示されます。

図10 基本的なコンポーネント属性は、Library Component ダイアログで定義します。
2. Default Designator(例えば、Q?)を入力します。 ?マークを入力すると、コンポーネントの配置時に、デジグネータ名が自動的にインクリメント(この場合ではQ1, Q2)されるようになります。コンポーネントの配置前にデジグネータを定義しておくこと(配置前にオブジェクトを編集するには、配置中にTABを押します。 )が必要です。
3. Commentを入力すると、コンポーネントの配置時に表示させることができます(例えば、NPNなど)。 DesignatorCommentフィールドのVisibleオプションが有効であることを確認します。 Comment フィールドがブランクのままの場合、コンポーネントを配置する時に自動でLibrary Referenceの名称が割り当てられます。
4. Descriptionフィールドにトランジスタの詳細な説明(例えば、Transistor, NPN Generic)を入力します。 ここで入力した文字はライブラリ検索で検索され、Librariesパネルに表示されます。
5.その他の欄はデフォルト値のままにし、必要に応じてモデルやパラメータを追加してください。

回路図コンポーネントにモデルを追加


図11 Sch Libraryパネルを利用してモデルを追加
回路シミュレーションやシグナルインティグリティ解析に使用されるモデル・ファイルと同様、回路図コンポーネントに関連したPCBフットプリントのモデルも複数登録しておくことができます。 コンポーネントに複数のモデル(例えば、複数のフットプリント)が割り当てられている場合、回路図にコンポーネントを配置する時、Component Propertiesダイアログで適切なモデルを選択できます。
モデルの調達は、既存のAltiumライブラリからモデルを使用するか、Webからベンダのモデル・ファイルをダウンロードするかして、自分自身で作成することができます。
PCBフットプリント・モデルは、C:\Program Files\Altium Designer\Library\Pcbフォルダに、PCB libraries (.PcbLib)という形で提供されています。 PCBライブラリには、多くのPCBフットプリントを含めることが可能です。

回路シミュレーションに使用されるSPICEモデル(.cktや.mdlファイル)は、Altium DesignerがインストールされたフォルダのLibrary内にある統合ライブラリに保存されます。 新規のコンポーネントを作成する場合、デバイス・ベンダのウェブサイトからSpiceモデルを入手するのが一般的です。 また、XSpice Model Wizard(Tools » XSpice Model Wizard)を使用して、Spiceモデルタイプを作成してコンポーネントに追加することができます。
回路図ライブラリ・エディタのModel Managerでは、コンポーネントモデルの概要を確認でき編集することができます。 例えば、同じモデルを、複数の選択したコンポーネントに追加することができます。 Model Managerを実行するには、Tools » Model Managerを選択します。
あるいは、モデルを既存のコンポーネントに追加することもできます。SCH LibraryパネルのModelリストの下にあるAddボタンをクリックするか、回路図ライブラリ・エディタ・ワークスペースのModels領域を使ってください。 Models画面を表示するには、の様にワークスペースの右下にある 矢印をクリックします。

図12 Models画面を表示するには、ワークスペース下部の矢印をクリックします。 それから、Addボタンを使用してモデルの種類を選択し、新規モデルを追加します。
1.回路図ライブラリ・エディタ・ワークスペースでModels画面を表示させます。上下の矢印シンボル をクリックしてください。

モデル・ファイルの保存場所を検索

回路図ライブラリ・エディタでコンポーネントにモデルを追加した時、モデルはリンクされますが、モデル・データは回路図コンポーネントにコピー、保存されません。 これは、ライブラリ作成中や、コンポーネントを回路図シートに配置する時に、リンクしたモデルを利用できる必要があることを意味します。
ライブラリ・エディタで作業している時、コンポーネントからモデル情報へのリンクは、以下の検索場所を使用して決められます。
1.最初に既存のライブラリ・パッケージ・プロジェクトに含まれるライブラリが検索されます。
2.次に、Librariesリストに登録されているPCB libraries(統合ライブラリではありません)が検索されます。 注 : ライブラリのリストが指定できます。
3.最後に、Project検索パスに表示されているモデル・ライブラリが検索されます。 サーチパスは、Options for Projectダイアログ(Project » Project Options)で定義されます。 注 : 検索パスにあるライブラリ内にあるモデルは表示できませんが、コンパイラは検索時にモデルが含まれています。
回路図ライブラリ・エディタや回路図エディタでモデルを検索する方法の詳細な情報については、AR0104 コンポーネント、モデル、ライブラリの概要 AR0104%20Component,%20Model%20and%20Library%20Concepts.pdf を参照してください。
このチュートリアルでは、コンポーネントやそのモデル・ファイルをリンクするために、別の方法を使用します。 ライブラリ・パッケージをコンパイルして統合ライブラリを作成する際は、モデルが保存されているさまざまな場所から統合ライブラリにコピーされます。

回路図コンポーネントへのフットプリント・モデルの追加

最初にPCBエディタでのコンポーネントを表すフットプリント(他のデザインツールでは、パターン、またはデカルとして知られています)のモデルを追加します。 回路図コンポーネントに必要なフットプリントは、BCY-W3と言うフットプリントです。

図13 フットプリント・モデルをコンポーネントに追加{*}
注 :* 回路図ライブラリ・エディタの回路図コンポーネントにPCBフットプリント・モデルをリンクする時、モデルは統合ライブラリでは無く、PCBライブラリに存在する必要があります。
1. Library Component PropertiesダイアログのModelsの項目でAdd ボタンの右側にある小さい矢印をクリックします。 そして、の様にリストからFootprintを選択します。Figure 13
2. PCB Modelダイアログが表示されます(Figure 16)。
3. Browseボタンをクリックし、Browse Librariesダイアログを開きます。 このダイアログでは、ライブラリ・プロジェクト、またはInstalledライブラリ・リストに追加されているフットプリント・ライブラリを検索することができます。
4. 既存のライブラリで目的のフットプリントが無い場合、ライブラリを検索する必要があります。 これを実行するには、Browse LibrariesダイアログでFindボタンをクリックします。 Libraries Searchダイアログが表示されます。

図15 フットプリント・ライブラリの検索


図16 BCY-W3のフットプリントの検索結果

5. ScopeをLibraries on Pathに、PathAltium DesignerがインストールされているフォルダのLibrary\Pcbに設定します。Include Subdirectoriesオプションが有効になっていることを確認します。
6.ダイアログの上部のクエリ欄にBCY-W3と入力し、Searchをクリックします。
7. Browse Librariesダイアログに、PCBライブラリ(Cylinder with Flat Index.PcbLib)に保存されているフットプリントがリスト表示されます。Figure 15 このライブラリからBCY-W3を選択し、OKをクリックしてPCB Modelダイアログに戻ります。
8.このライブラリを使用するのは初めてなので、このライブラリを登録するかの確認のダイアログが表示されます。 Confirm ダイアログのYes をクリックします。 フットプリント・モデル情報が更新され、PCB Modelダイアログにそのライブラリが追加されます。
9. OKをクリックしてモデルを追加します。 ワークスペース下部にModel画面が表示されます。


{_}図17 フットプリント・モデルがコンポーネントに追加されます。

_
図18 PCBモデルを回路図コンポーネントにアサイン

回路シミュレーションモデルの追加



図19 現在の作業フォルダでのサーチパス
{_}
すべてのSpiceモデルの種類の指定や設定は、Sim Modelダイアログで行います。_
SPICEモデルは、回路シミュレーション(.cktや.mdlファイル)で使用します。一般的にデバイス・ベンダのウェブサイトから供給されています。 使用しようとしているデバイスが既存のライブラリで利用できる場合、それにはSpiceモデルが含まれています。 このチュートリアルの手順を実行する為に、 C:\Program Files\Altium Designer\Examples\Tutorials\Creating Componentsフォルダで適切な一般的なNPNモデルを検索し、ライブラリを保存したフォルダにこのモデルをコピーします。
1.Spiceモデルがどのように参照されているかは、プロジェクトによります(モデルはリンクされることを思い出してください)。 その他のソース・ファイルとしてそれをプロジェクトに追加できます(Projectsパネルでプロジェクト・ファイル名を右クリックして、Add Existing to Projectを選択します)。 しかし、もし、簡単に編集できない参照するソース・ファイルとしてモデル・ファイルを表示する場合、普通のプロジェクト・ファイルとしてそれを含めません。 この場合、それを参照する最も適切な方法は、シミュレーション・モデル・ファイルを含むフォルダにSearch Pathを定義することになります。 これを実行するには、メニューからProject » Project Optionsを選択し、Search Pathsタブをクリックします。
2. Addをクリックして新規の検索パスを定義します。Edit Search Pathダイアログが表示されます。
3.特に必要でない限りInclude sub-folders in searchオプションは、常に無効にしてください。検索プロセスが非常に遅くなります。
4.デフォルトの検索パスは、現在のフォルダです。 作業フォルダにモデルをコピーしてからOKをクリックします。 モデルが検索されたか確認するには、OptionsダイアログのRefresh Listボタンをクリックします(Figure 19)。 検索パスが定義され、作業フォルダに保存されたモデルが自動で検索されます。

図20 NPNモデルの設定

5.今、モデルを作成しているプロジェクト(ライブラリ・パッケージNew Library.LibPkg)で利用できます。 これで、NPNコンポーネントにシミュレーション・モデルを追加できるようになります。 これを実行するには、フットプリント・モデルを追加する方法と同じ方法を実行します(Simulationモデルを選択する方法を除く)。 SIM Model - General / Generic Editorダイアログが表示されます(Figure 19)。
6.NPNはトランジスタですので、Model Kindのドロップダウン・リストからTransistorを選択します。 ダイアログは、Sim Model - Transistor/BJTダイアログになります。
7. BJTModel Sub-Kindとして選択されていることを確認します。
8.このチュートリアルでは、Model Nameの欄にNPN(モデル・ファイルNPN.mdl用)というモデル・ファイルの名称を入力します。 名称を入力するとすぐにモデルが検知されます。 モデルが見つかった場合、ダイアログにパス/名称が、そしてFound Inと表示されます。
Model Nameは、SIMモデルファイルへリンクさせるのに重要ですので、適切なモデル名(拡張子なし)であるか確認してください。
注記 : ダイアログのFound In region - 正しいモデルが見つかるとリスト表示されます。

9.適切なDescription(例えば、Generic NPN)を入力します。
モデル・ファイル(.mdl)が無い場合、Createボタンをクリックして、簡単にシミュレーション・モデル・ファイルを作成してコンポーネントに割り当てることができるSpice Model Wizardを実行します。
10. OKをクリックして、モデルNPNがModelsリストに追加されたLibrary Component Propertiesダイアログに戻ります。Figure 21

図21 Models画面にリストされたNPNのフットプリントとシミュレーション・モデル


図22 NPNトランジスタについて設定したシグナル・インテグリティ・モデル・エディタ
シグナルインテグリティ・モデルの追加
シグナル・インテグリティ・シミュレータは、コンポーネントモデルではなく、ピンモデルを使用します。 シグナル・インテグリティ・シミュレーションのコンポーネントを設定するには、Typeと Technologyオプション(デフォルトで用意されているピン・モデルを使用する)を設定するか、IBIS モデル(基本的に一組のピンモデル)をインポートします。
1.シグナル・インテグリティ・モデルを追加するには、Signal Integrityを選択し、それ以外はフットプリントを追加した方法と同じ作業を実行します。 Signal Integrity Modelダイアログが表示されます。
2.IBISファイルをインポートしたい場合、Import IBISボタンをクリックして必要な.ibsファイルを指定します。 このチュートリアルでは、デフォルトで用意されたピン・モデルを使用します。 TypeBJT に設定し、 適切な Model NameDescription を入力します (たとえば、 NPN)。Figure 22をご覧ください。
3. OKをクリックして、モデルがModelsリストに追加されたLibrary Component Propertiesダイアログに戻ります。Figure 23

図23 シミュレーションとシグナル・インテグリティ・モデルが、トランジスタに追加されます。
シグナル・インテグリティ・モデルの追加、編集についての詳細は、TU0113 シグナルインティグリティ解析の実行を参照してください。
ライブラリ内の全コンポーネントのパラメータの編集と管理には、パラメータマネージャ (Tools メニュー)を使用します。

コンポーネントパラメータの追加

コンポーネント・パラメータでは、コンポーネントについての追加情報を定義することができます。 これは、BOM、製造データ、コンポーネント・データシートへの参照、デザインルール、またはPCBクラスへの割り当ての様な設計指示情報、Spiceシミュレーション・パラメータなどで必要なデータを含みます。パラメータには、コンポーネントに必要な情報を追加することができます。

図24 パラメータは、Parameter Propertiesダイアログで設定します
回路図コンポーネントにパラメータを追加するには:
1.パラメータは、Library Component Propertiesダイアログでコンポーネントに追加します。 ダイアログを開くには、Sch Libraryパネルのリストでコンポーネント名をダブルクリックします。
2.新規のパラメータを追加するには、Library Component Properties ダイアログのParameters for... セクション内のAdd ボタンをクリックしParameter Propertiesダイアログを表示させます( Figure 24 )。
3.パラメータの名称と値を入力します。 テキスト・ストリングが必要な場合は、StringがパラメータType として選択されていることを確認してください。また、コンポーネントが回路図シートに配置された時に値を表示したい場合は、値のVisible オプションが有効になっていることを確認してください。 OKをクリックします。 パラメータは、Library Component PropertiesダイアログのParametersリストに追加されます。

コンポーネントからデータシートへのリンク用パラメータ

パラメータは、コンポーネントからデータシートの様な参考資料へリンクさせることができます。 リンクは、特定のコンポーネント・パラメータを追加することにより構築されます。 参照ドキュメントにアクセスするにはF1ボタンを使用します。 複数のドキュメントを参照するには、右クリック・メニューを使用します。

HelpURL

コンポーネントに予約されたパラメータ名(HelpURL)が含まれている場合、カーソルがコンポーネント上にある時にF1ボタンを押すと、URLが表示されます。 URLには実際のウェブアドレス、テキストファイル、PDFファイルが指定できます。

コンポーネントリンク

2つ目の手法は、複数のリンク、各リンクの名称をサポートしています。 ここでは、パラメータ(リンクされたドキュメント、またはURLを示すもの)を追加し、次に、このリンクのラベルを定義します。 パラメータは、次のように定義します。

 

パラメータ名

パラメータ値の例

1番目のパラメータ

ComponentLink1URL

C:\MyDatasheets\XYZDatasheet.pdf

2番目のパラメータ

ComponentLink1Description

Datasheet for XYZ

1番目のパラメータ

ComponentLink2URL

C:\MyDatasheets\AlternateXYZDatasheet.pdf

2番目のパラメータ

ComponentLink2Description

Datasheet for Alternate XYZ


図25 右クリックしてデータシート・リンクを実行
同じパラメータのペアを使って、リンクはいくつでも定義できます。ただし、インクリメンタルな指定はできません。 データシートリンクを使ったコンポーネント上で右クリックすると、Context メニューの中に、Reference メニューのエントリが表示されます。メニューから各コンポーネントリンク用のエントリを見つけてください(Figure 25)。
Libraries パネルでコンポーネントを閲覧するときにも、コンポーネントとデータシートのリンクが使用できます。 - F1キーまたは、パネルのコンポーネント名の上で右クリックすると、リンク先ドキュメント/URLにアクセスします。

間接的に参照する文字

後で何らかの文字を入力するため、場所を確保しておく定義が必要になることがあります。 例えば、回路図のテンプレートで、DesignedByというパラメータを使用したいとします。 この場合、その値はテンプレートを適用した新規回路図において定義します。 Altium Designerでは、間接的に文字を参照する手法で、この要求をサポートします。 回路図シートレベルで、ドキュメント・パラメータとして、例えばDesignedByというパラメータを追加し、その値をブランクにします。 実際のドキュメントには通常の文字として、=DesignedByを配置します。 = は、間接参照を行っている文字であることを示し、文字を表示する代わりに、ドキュメント・パラメータDesignedByの現在の値を表示します。
注 : デフォルトでは、間接的な文字は解析されず、最終的な値が表示されます。これを有効にするには、Preferences ダイアログの Schematic - Graphical Editing ページで、Convert Special Stringsオプションを有効にします。 パラメータのValue がブランクの場合、何も表示されません。Convert Special Strings オプションがデフォルトで無効になっているからです。
間接的に参照する文字は、コンポーネントにも使用できます。Visibleオプションを有効にしてコンポーネントに追加されているパラメータを表示するのと同様に、コンポーネントのComment フィールドの文字を間接的に表示することもできます。
間接的に参照する文字が役に立つ状況は、コンポーネントをPCBデザインや回路シミュレーションの双方で使用している場合です。 回路図からPCBデザインへデータを移行する際、回路図のComment欄がPCBコンポーネントのComment 欄にマップされます。 しかし、回路シミュレーションではComment 欄は使用されません。 シミュレータは、コンポーネントの多くの属性を必要とするからです。例えば、BJTには5つのシミュレーション属性があります。 これらの5つの属性は、パラメータとして定義されます。 この場合、回路シミュレーション・パラメータは、パラメータの名称を = 記号の後に入力することにより、間接的に参照する文字を使用してComment欄にマップできます。 例えば、抵抗には1つのシミュレーション・パラメータ(Value)が割り当てられています。 もし、抵抗のComment欄が=Valueに設定されていれば、Valueパラメータの内容がComment として表示されます。 もし、シミュレーション中に抵抗値を調整している場合、PCBレイアウトにデザインを移行する時に正しい抵抗値が使用されます。

シミュレーションパラメータ

上記に記載した様に、間接的に参照する文字の機能は、コンポーネントのComment欄にパラメータをマップするのに使用できます。 注 : シミュレーション・パラメータは、シミュレーション・モデルに構築され、手動でコンポーネントにそれらを追加する必要が無いことに注意してください。 作成しているトランジスタのシミュレーション・モデルを編集する場合、BJTモデルがの様な5つのシミュレーション・パラメータを持っていることがわかるでしょう。


図26 シミュレーション・パラメータは、Sim Modelダイアログで定義します。
シミュレーション・パラメータに簡単にアクセスしたい、または回路図にそれらを表示したい、または出力ドキュメントにそれらを含めたい場合など、各パラメータの隣のComponent parameter のチェックボックスを有効にして、コンポーネント・パラメータにすることができます。

コンポーネントをチェックし、レポートを作成

新規のコンポーネントが正しく作成されているか確認するには、3つのレポートを作成します。 ライブラリ・ファイルが、レポートが作成される前に保存されているか確認してください。 レポート・ファイルを閉じて、回路図ライブラリ・エディタに戻ります。
コンポーネント・ピンからモデルへのリンクは、コンポーネント・ルール・チェッカでチェックされません。
このリンクのレベルは、統合ライブラリにライブラリ・パッケージをコンパイルする時にチェックされます。 コンパイルされた統合ライブラリを使用するつもりでなくても、ライブラリ・パッケージを使用してライブラリを作成し管理する際には便利になります。コンパイルすることで、より包括的なコンポーネントの検証ができます。

コンポーネント・ルール・チェッカ

コンポーネント・ルール・チェッカでは、ピンのダブリやミスなどのエラーをチェックします。
1. Reports » Component Rule Check [ショートカット R, R]を選択します。 Library Component Rule Check ダイアログが表示されます(Figure 27)。

図27 既存のコンポーネントをテストするためにComponent Rule Checkダイアログを設定
2.確認したい属性を設定します。 OKをクリックします。 libraryname.errという名のレポートが、テキストエディタに表れ、ルール・チェックに違反したコンポーネントがリスト表示されます。
3.必要な修正をライブラリに行い、ルールチェックを再度、実行します。
4.回路図ライブラリを保存します。

コンポーネント・レポート

アクティブなコンポーネントのすべての情報をリスト表示するレポートを作成するには:
1. Reports » Component [ショートカット R, C]を選択します。
2. 'libraryname.cmp'という名のレポートがテキストエディタに表れ、コンポーネントの各パートの数やピン情報が表示されます。

ライブラリレポート

ライブラリの各コンポーネントのレポートを作成するには:
1. Reports » Library Report [ショートカット R, L]を選択します。
2. Library Report Settingsダイアログで必要なレポートを設定します。
レポートは、選択した形式によりMicrosoft Word、またはウェブブラウザで開きます。

コンポーネントをその他のライブラリからコピー

その他の開いている回路図ライブラリからも回路図ライブラリへコンポーネントをコピーし、必要な属性を編集することができます。 コンポーネントが統合ライブラリの一部である場合、.IntLibファイルを開き(File » Open)、Yes を選んでソースライブラリを抽出する必要があります。 生成されたソースライブラリ(.SchLib)は、Projectsパネルから開きます。
1. SCH LibraryパネルのComponentsリストで、コピーしたいコンポーネントを選択すると、そのコンポーネントがデザインウィンドウに表示されます。
2. Tools » Copy Componentを選択して、既存のライブラリ・コンポーネントからその他の開いているライブラリ・ドキュメントへコンポーネントをコピーします。 Destination Libraryダイアログが表示され、開いているすべての回路図ライブラリ・ドキュメントがリスト表示されます。
3.コンポーネントをコピーしたいドキュメントを選択します。 OKをクリックすると、コピーしたコンポーネントが目的のライブラリに追加され、必要なら編集もできます。


図28 既存のライブラリから選択したコンポーネントをコピー

複数のコンポーネントのコピー

SCH Libraryパネルを利用して1つ、または複数のコンポーネントもコピーできます。 コンポーネントをパネルの名称リストから選択します。標準的な CTRL + クリック、や SHIFT + クリック機能が使用できます。次に、選択したコンポーネント上で 右クリックして、Copy をポップアップメニューから選びます。 Figure 28 を参照してください
Components リストで右クリックすると :

  • 同じライブラリにコンポーネントを貼り付けることができます。
  • その他の開いているライブラリにコンポーネントを貼り付けることができます
  • 同じ手法を使用して、回路図のコンポーネントを開いているライブラリへのコピー、貼り付けができます

複数のパートを持つ新規の回路図コンポーネントの作成

作成したトランジスタのシンボルは、コンポーネント全体(デバイス・メーカーによって供給された物理的なパッケージを表す1つのシンボル)を表します。
1つの物理的なコンポーネントは、パートの集まりとして表される場合があります。 例えば、8つの抵抗を含む抵抗アレイがあります。 各抵抗は、その他の抵抗と独立して使用できます。 その他の例では、2入力ANDゲートの74F08があります(このデバイスには、4つの独立した2入力AND ゲートがあります。 )。 コンポーネントは、各4つのゲートを1つのシンボルとして描画でき、もし、回路図で、各ゲートを4つの分割したゲートとして描画する場合、より役に立ちます。 このような一組の分割したパートとして配置するコンポーネントを、マルチ・パート・コンポーネントと呼びます。

図29 新規コンポーネントの名称を入力
チュートリアルのこの項では、74F08SJX Quad 2-IN AND を作成する方法を説明します。 また、交互に別の形状のモデルを表示できるコンポーネント(デバイスのIEEE規格を表現)を作成します。
1.回路図ライブラリ・エディタで、Tools » New Component [ショートカット T, C]を選択します。 New Component Nameダイアログが表示されます(Figure 29)。
2.新規コンポーネントの名称を入力し(例えば、74F08SJX)、OKをクリックします。 新規コンポーネントの名称がSCH LibraryパネルのComponentsリストに表示され、シートの中央に十字の線(原点)のある空のコンポーネントシートが、表示されます。
3.これで、新規コンポーネントの最初のピンを作成できるようになります。上図のように、ピンが含まれています。詳細は、以下のセクションで説明します。 最初のパートは、その他のパートの基準として使用されます。ピン番号だけは、各パートで変更する必要があります。

コンポーネントのボディを作成

このコンポーネントのボディは、複数のセグメントと円弧で構成されています。 コンポーネント・シートの原点がワークスペースの中央にあることを確認してください。Edit » Jump » Origin [ショートカット J, O]を選択します。 グリッドについても表示されていることを確認してください[ショートカット Page Up]。

図30 最初のパートのボディを定義するためにPolylineを配置します

ラインの配置

1.現在のグリッド設定がAltium Designerのステータスバー(左下)に表示されることに注意してください。 いつでも3種のグリッド設定を切り換えることができます。Gキーを押してください。ここでは、グリッドを5に設定しています。
2. Place » Line [ショートカット P, L]を選択するか、 ツールバーボタンをクリックします。 カーソルが、十字に変わり、複数セグメントのラインを配置するモードになります。
3. TABキーを押して、ラインの属性を設定します。 Polylineダイアログで、線幅をSmallに設定します。
4.ステータスバーの左端に表示されるX, Y座標を参照し、25, -5 になるところへカーソルを移動します。 クリックするかENTER を押し、線を引き始めます。 マウスを移動し、ラインのセグメントを定義する頂点(0,-5; 0,-35; 25,-35)で左クリックします。
5.ラインの配置が完了したら、右クリック、またはESCを押します。
6.完成したポリラインは、Figure 30の様になります。 コンポーネントを保存します。

図31 アークの属性は、ダイアログ、またはマウスを使用して定義できます。

アークの配置

アークは、アークの中心点、半径、開始点、終了点の4ステップで配置します。 注 : アークの配置では、クリックの代わりにEnterを押すことができます。
1. Place » Arc (Center) [ショートカット P, A]を選択します。 アークがカーソルの上に現れ、アークの配置モードになります。
2. TABキーを押して、アークの属性を設定します。 Arcダイアログが表示されます。 半径を15、開始点を270、終了点を90、ライン幅をSmallに設定します(Figure 31)。
3.アークの中心点を決めるため、25, -20の位置にカーソルを移動してEnterを押すか左クリックします。 マウスを移動する必要はありません。 カーソルは、Arcダイアログで設定した様に15の半径を定義する正確な位置にジャンプします。 Enterを押します。
4.それから、カーソルは、ダイアログで設定した様にアークの開始点にジャンプします。 マウスを移動しないでEnter を押し、開始点を受け入れます。カーソルが終了点までジャンプするので、そこで再び、Enterを押します。
5.右クリックするか、ESCを押して、アークの配置モードを抜けます。

図34 コンポーネント74F08SJXのパートA。 input/outputを示す三角形は表示上の機能です。PreferencesダイアログのSchematic - GeneralページのPin Directionオプションで設定します。


図34 Part Bが追加されます


図34 74F08SJXのPart B

信号ピンの追加

最初のパートにピンを追加します。このチュートリアルの最初の方にある回路図コンポーネントにピンを追加 AddingPins の項目で説明したのと同じ手法を使用します。 1、2番ピンにInput、3番ピンにOutputの電気的属性を割り当てます。 ピンの長さを20に設定します。 完成したパートは、Figure 34のようになります。

パート2、3、4の作成

1. Edit » Select » All [ショートカット Ctrl + A]を使用してコンポーネントを選択します。
2. Edit » Copy [ショートカット Ctrl + C]を選択し、このパートをクリップボードにコピーします。
3. Tools » New Partを選択します。 空白のコンポーネントシートが表示されます。 SCH Libraryパネル内のパートカウンターが更新され、Part AとPart B が含められます。SCH Library パネル内の Componentsのリストでコンポーネント名の左にある + をクリックすると、図34の様になります。
4. Edit » Paste [ショートカット Ctrl + V]を選択します。 コンポーネントパートの外形がカーソルの上に現れるので、シートの原点に対して相対的に同様な場所に、Part Aとして配置します(シートの中央の黒い十字の部分が原点です)。 必要ならば、元のパートと同じ位置になるまでコピーしたパートを選択し移動します。
5.新しいパート、Part Bのピン情報を更新します。各ピンをダブルクリックして、Pin Propertiesダイアログでピン名称、番号を変更します。 完成すると、Part Bは Figure 34 のようになります。
6.上記の3から5のステップを繰り返し、 Figure 35 のように、残りの2つのパート、Part CとPart Dを作成します。 ライブラリを保存します。

図35 74F08SJXのPart C と Part D

パワーピンの追加

パワー・ピンを定義するには、2つの方法があります。 5番目のパートをコンポーネントに作成することができ、そのパートにVCCやGNDピンを配置します。 この方法を使用する場合、再アノテーション中にどのゲートもスワップされないようにするには、Component PropertiesダイアログのLocked オプション( )を有効にする必要があります。
2つ目の方法は、パワー・ピンをHiddenピン として定義することです。 この場合、それらは特別なネットに自動的に接続されます。
Hiddenパワーピンは、マルチパート・コンポーネントの特定のパートに属さず、すべてのパートに属します(どのパートが配置されているかに関らず、回路図に存在するそのコンポーネントのパートすべて)。 この要件を満たすには、ピンをPart 0に割り当てます。つまり、コンポーネントの各パートに追加したいピンを保存するために使用する特別なパートです。
1.コンポーネントにGND (ピン番号 7)とVCC (ピン番号 14)のピンを追加します。Part Number 属性を 0に、Electrical Type をPower に、Hide ステータスHiddenに、Connect toのネット属性をGNDとVCCにそれぞれ設定します。

図36 hiddenパワーピンと一緒に表示されたPart A
2.Hiddenオブジェクトを表示するには、メニューからView » Show Hidden Pinsを選択します。 完成したパートは、 Figure 36 のように表示されます。 パワーピンが各パートに現れることを確認します。

コンポーネントの属性設定

1.コンポーネントがComponentsリストで選択されているときに、SCH LibraryパネルのEditボタンをクリックして、コンポーネント属性を設定します。 Library Component Properties ダイアログを設定します。Default Designator で U? を指定し、Description を Quad 2-Input AND Gate に指定、フットプリント名 DIP14 を Models リストに追加します。 このチュートリアルの後半では、PCB Component Wizardを使用してDIP14のフットプリントを作成します。
2. File » Saveを選択して、ライブラリのコンポーネントを保存します。

パートにおけるAlternate表示モードの作成

255種類のAlternate表示モード をコンポーネントパートに追加できます。 これらの表示モードは、DeMorgan、またはIEEEの表現のように、異なる形状のコンポーネントを作成することができます。 IEEE シンボルの選択は、Sch Lib IEEEツールバー(View » Toolbars » Utilities)、またはPlace » IEEE Symbols から有効にすることができます。 各Alternate表示モデルは、ノーマルモードと同じピンのセットを持つ必要があります。
パートのAlternate表示が追加されている場合、Figure 37の様にModeツールバーのModeツールからAlternate モードを選択すると、そのモードがSchematic Libraryエディタに表示され編集することができます。
Schematic Libraryエディタのデザインウィンドウに表示されるコンポーネント・パートにAlternate表示モードを追加するには:
1. Tools » Mode » Addを選択するか、 ボタンをクリックします。Alternate 1のブランクシートが表示されます。
2.一般的には、Normalモードで作成されたパートをコピーし、新規のAlternateモードにそれを貼り付けします。 この方法で正しいピンのセットが作成され、必要ならば形状やピンの位置を修正できます。
3.ライブラリを保存します。
一度、コンポーネントを回路図シートに配置したら、表示モードは、Component Properties ダイアログのGraphical の項目のMode リストから選択することができます。

図37 ANDゲートのIEEEを表すために使用した表示モード Alternate 1

PCBコンポーネントのフットプリントの作成

フットプリントは、それらを配置した基板の最終的なサイドに関係なく、常にトップ面から作成されます。 レイヤに独特の属性、たとえば表面実装のパッドやソルダマスクの定義などは、コンポーネントの配置中にフットプリントを基板の反対側に反転させたとき、自動的に適切な下層レイヤに移行されます。チュートリアルのこの項目では、次の内容について説明します:

  • 新規PCBライブラリの作成
  • PCB Component Wizardを使用した、回路図コンポーネントに関するフットプリントの作成
  • 手動によるフットプリントの作成
  • 異型パッド形状を含む、特別なフットプリントの条件
  • 3次元コンポーネントボディについての詳細(3Dボディ)

フットプリントは、PCBエディタからPCBライブラリへコピーしたり、PCBライブラリ間でコピーできます。 または、PCBライブラリエディタのPCB Component Wizard、または描画ツールを使用してゼロから作成できます。 PCBデザインにすべてのフットプリントが配置されている場合、PCBエディタでDesign » Make PCB Libraryコマンドを使って、それらのフットプリントだけが含まれたPCBライブラリを作成することができます。
Altium Designerには、定義済みのスルーホールやSMDコンポーネントフットプリントなど、PCBデザインで使用するための包括的なライブラリが含まれています。 フットプリント・ライブラリ(.PcbLib files)は、Altium DesignerがインストールされたディレクトリのLibrary\Pcbフォルダに保存されています。
チュートリアルのこのパートで、手動で作成するフットプリントは、必要な手順を説明するだけです。寸法は正確ではありません。 新規のフットプリントを作成する場合、メーカーのデータシートに対して一致しているか、常に確認してください。

新規PCBライブラリの作成


図38 フットプリントライブラリ追加後のライブラリパッケージ 新規のPCBライブラリを作成するには:
1. File » New » Library » PCB Libraryを選択します。 新規のPCBライブラリドキュメント、PcbLib1.PcbLibが作成され、空のコンポーネントシート、PCBComponent_1 が表示されます。
2.新規のPCBライブラリ・ドキュメントの名称を、たとえば、PCB Footprints.PcbLibに変更します。File » Save Asを選択してください。 新規のPCBフットプリントライブラリは、ライブラリパッケージ内に入れる必要があります(Figure 38)。
3. PCB Libraryタブをクリックして、PCB Libraryパネルを開きます。
4.PCB Library Editor ワークスペースのグレー領域をクリックして、 Figure 39 のようなグリッドが表示されるまで PageUpキーを数回押します。
PCB Library Editor コマンドを使用して、新規のPCBライブラリのフットプリントコンポーネントを追加、削除、編集する準備ができました。

図39 フットプリントを作成する準備ができた新規のPCBライブラリ

PCBコンポーネントウィザードの使用

PCB ライブラリエディタには、PCB Component Wizard が含まれていて、ユーザのリクエストに応じたコンポーネントフットプリントが作成できます。 DIP14のフットプリントを作成するために、ウィザードを使用します。

図40 PCB Component Wizard を利用して、DIP14のフットプリントを作成

図41 DIP14のフットプリントを作成するウィザードの作業
Component Wizard を使用して、新規のコンポーネントフットプリント(DIP14)を作成するには:
1. Tools » Component Wizard [ショートカット T, C]を選択します。 PCB Component Wizardが自動的に立ち上がります。 Next >をクリックしてウィザードを進めます。
2.有効なオプションからの質問に選択で答えていきます。 DIP14を作成するには、Dual in-line Package (DIP)をPatternとして選択し、単位をImperial 、ラウンドパッド60mil、穴サイズを32mil (寸法線の値を選択、入力)、 パッド間の距離を300mil(水平方向)、100mil(垂直方向)に設定、パッド数を設定する画面まではデフォルト設定を適用します。 パッド数を設定する画面では、14と入力します。
3.ウィザードの最後のページまでNext >をクリックし、最後のページでFinishをクリックします。 新規のフットプリントのファイル名、DIP14がPCB LibraryパネルのComponentsリストに表示され、その新規のフットプリントがデザインウィンドウに表示されます(Figure 40)。 必要なら更にコンポーネントを編集できます。
4. File » Save [ショートカット Ctrl + S]を選択して、その新規のフットプリント・コンポーネントがあるライブラリを保存します。

IPCフットプリントウィザードの使用


図42 IPC® Compliant Footprint Wizard は、コンポーネントの大きさに基づいて、フットプリントを作成します
PCB Component Wizard と同様に、IPC® Compliant Footprint Wizard でコンポーネントフットプリントを作成できます。 フットプリントを定義するパッドやトラックの属性を入力するように求めるのではなく、IPC Compliant Footprint Wizard は、実際のコンポーネントの大きさを入力として採用します。 IPC-7351 標準用に開発された方式に基づいて、ウィザードはフットプリントを生成します。パッドやトラックなど、Altium Designer の標準オブジェクトが使用されます。 ウィザードは PCB Library Editor の Tools メニューから起動できます。

手動によるフットプリントの作成

フットプリントは、PCBライブラリエディタ内で作成され、修正されます。PCBエディタで利用できるツールとデザインオブジェクトのセットを使用します。 どんなものでも、PCBフットプリントとして保存できます。コーナーマーカー、フォトツールのターゲット、機構的な定義が含まれます。 注 : 一度、フットプリントがPCBに配置されると、形状や機構の要求に応じて、Type 属性が設定できます。 これらの設定の詳細な情報を確認するには、ComponentダイアログのWhat's This helpを使用してください。

_図43 Board Options ダイアログで単位とグリッドを設定_コンポーネント・フットプリントは、コンポーネント・ピンの接続を構成するためのパッドを配置し、トラックやアークで外形を定義して作成します。 デザインオブジェクトは、どんなレイヤにも配置できます。 しかし、通常、外形はTop Overlay(シルク・スクリーン)レイヤに、パッドはマルチレイヤ(スルーホール・コンポーネント・ピン用)、または部品面の信号レイヤ(表面実装コンポーネント・ピン用)に作成します。 PCBドキュメントにフットプリントを配置する時、フットプリントを構成するすべてのオブジェクトは定義されたレイヤに割り当てられます。

NPNトランジスタのフットプリントをマニュアルで作成するには:
1.フットプリントを作成する前に、単位とグリッドが適切であることを確認してください。 Tools » Library Options [ショートカット D, O] を選択して、Board Options ダイアログを表示します。UnitsImperialSnap Grid が XY方向に10milであることを確認します。 作成するフットプリントのパッド間隔を目的の間隔にするため、Gridを設定する必要があります。 Visible Grid 1を10milに、Visible Grid 2を100mil に設定します。
2. Tools » New Blank Component [ショートカット T, W]を選択すると、空のコンポーネント・フットプリントのワークスペースが作成されます。 ここで、新規のライブラリに空のフットプリントが作成されるのでそれを使用します。
作業中にスナップグリッドを変更するには、Ctrl+Gを押します。
Visibleグリッドを表示、または非表示にするには、Lキーを押してView Configurations ダイアログを表示します。
原点マーカーが表示されない場合は、View Configurations ダイアログを開き、View Configurations ページのOrigin Marker オプションを有効にします。
3.デフォルトの空フットプリントの名称を変更するには、PCB Libraryパネルのリストでその名称(たとえば、PCBComponent_1)をダブルクリックします。 ここでは、チュートリアルの最初の方で使用した名称、BCY-W3を入力しましょう。新しいフットプリント名をPCB Library Component ダイアログに入力します。
4.原点マーカーで表示されたワークスペースの参照ポイント(0, 0)の周りにフットプリントを作成することをお薦めします。 作業中に原点にカーソルをジャンプさせるには、ショートカットJ, Rを使用します。
参照ポイントとは、コンポーネントを配置するときに、コンポーネントを ''つかんだ' カーソルの位置のことです。 一般的に、参照ポイントはコンポーネントのパッド1の中心、または幾何学的なオブジェクトの中心になります。 参照ポイントは、いつでもこれらのどちらかに設定できます。Edit » Set Referenceのサブメニューのオプションを使用してください。

新規のフットプリントにパッドを配置

Pad 属性ダイアログにはビューアがあり、定義されているレイヤ上のパッド形状を検討することができます。 パッド用の通常の円形、楕円形(スロット)、四角形のホールを定義して、それらの箔付け属性(箔付けする、しない)の切り替えルことができます。また、サーマルレリーフの生成、クリアランス計算、ガーバー出力、ODB++、NCドリルなどをサポートするのに必要なすべての作業を自動的に扱うことができます。 NCドリル出力(NC Drill Excellon format 2)では、3種の異なるホール用と箔付けする、しないの別によって、6個の異なるNCファイルが生成されます。
新規のコンポーネント・フットプリントを作成するのに最も重要な手順の一つは、コンポーネントをPCBに半田付けするために使用するパッドを配置することです。 これらは、物理的なデバイス上のピンに対して、正しい位置に正確に配置する必要があります。

パッドを配置するには:
1. Place » Pad [ショートカット P, P]を選択するか、 ツールバーボタンをクリックします。 パッドがカーソル上に表示されます。 最初のパッドを配置する前に、TABキーを押してパッド属性を定義します。 Padダイアログが表示されます(Figure 45)。
2.ダイアログの各領域を編集します(Figure 45)。 これで、伸びたパッドが作成されました。
3.ステータス・バーに表示される座標を目安にして、最初のパッドをX:0, Y:-50に位置決めし、クリック(または、ENTERを押)します。
4.最初のパッドを配置後、カーソル上に次のパッドが表示されます。 カーソルをX:0, Y:0に合わせてクリックし、2番目のパッドを配置します。 注 : パッドの部品番号は自動的にインクリメントされます(出現順に数字が振られます)。
5.X:0, Y:50にカーソルを移動し、クリックして3つ目のパッドを配置します。
6.右クリックするか、ESCを押して、パッドの配置モードを抜けます。 3つのパッドは Figure 44 の様に配置されます。
7.フットプリントを保存します。 File » Save [ショートカット CTRL + S]を選択してください。


図44 段階1, パッドを配置_表面実装用のパッドは、Layer属性をTop Layer に設定します
各レイヤで異なったサイズが必要なスルーホールパッドについては、Size and Shape属性を使用します。

図45 最初のパッドを配置する前にパッド属性を設定

カーソル上に浮かんでいるパッドをマウスを使わずに配置するには、J, L ショートカットを使用して、Jump to Location ダイアログを表示させます。 TAB を押して、XとY の欄を行き来させ、ENTER で変更を受け入れます。ENTER をもう一度押すと、パッドがワークスペースに配置されます。

パッドのデジグネータ(部品番号)

パッドにはデジグネータ(通常、コンポーネントのピン番号)でラベルをつけることができます。20までの英数字が使用できます。 デジグネータは、必要ならブランクのままにすることができます。
数字で始まる、または数字で終わるデジグネータを繰り返し配置すると、番号が自動的にインクリメントされます。 アルファベットでインクリメント機能を利用する場合は(例えば、1A, 1B)、Paste Array機能を使用します。

ペースト・アレイ機能

パッドをクリップボードにコピーする前にパッドのデジグネータを設定することで、ペーストアレイ機能を使用した自動的な配置シーケンスをパッドのデジグネータに適用できます。 Paste ArrayダイアログのText Incrementの項目を設定すると、以下のようなパッドのデジグネータシーケンスで配置できます:

  • 数字(1, 3, 5)

  • 図46 複数のパッドを一度にペースト_アルファベット(A, B, C)
  • アルファベットと数字の組み合わせ(A1 A2、または1A 1B、またはA1 B1、または1A 2Aなど)
  • 数字順にインクリメントさせるには、Text Incrementの項目をインクリメントしたい値に設定します。
  • アルファベット順にインクリメントするには、Text Incrementの項目をスキップしたいアルファベットに設定します。 例えば、もし最初のパッドのデジグネータが1Aの場合、A(アルファベットの最初の文字)をインクリメント1のデジグネータに設定します。 項目にC(アルファベットの3番目の文字)を設定すると、デジグネータは1A, 1D(Aの3つ後の文字), 1Gなどになります。

ペーストアレイの機能を利用するには:

  • 最初のパッドを作成し必要なデジグネータを設定します(例えば、1A)。 Edit » Copy [ショートカット Ctrl + C]を使用して、クリップボードにこのパッドをコピーします。
  • Edit » Paste Special [ショートカット E, A]を選択します。 Paste Specialダイアログが表示されます(図46)。
  • Paste ArrayボタンをクリックしSetup Paste Arrayダイアログを表示させます。 必要に応じて各項目を設定します。

PCBシルク層(コンポーネントオーバーレイ)に外形を描画

インチ(mil)からミリ(mm)に座標単位を切り換えるには、Qを押します。PCBシルク層に表示される外形は、Top Overlayに定義します。 配置中にコンポーネントをボードの下層に反転させた場合、シルク層は自動的にBottom Overlay レイヤに変更されます。
1. アーク、またはライン(トラック)などのシルクのオブジェクトを配置する前に、メイン編集ウィンドウの下のTop Overlayレイヤタブをクリックします。
2.最初に、Figure 47 の様にアークを配置します。 アークを配置するには、メニューからPlace » Arc (Center)を選択します。 カーソルをX:0, Y:0に移動してクリックし、アークの中心を定義します。 アークの半径や開始、終了角度がわかっている場合は、対話的な定義による設定を経ることなく、ずっと簡単にアークを配置することができます。配置したアークはArcダイアログで編集します。
3.アークの半径を定義するためにどこかをクリックし、再度クリックしてアークの開始角度を定義します。 必要なら、Spacebarを押して、終了角度を定義する前にアークの方向を切り換えることができます。Figure 47 の様に方向を設定し、再度クリックしてアークの終了角度を定義します。 右クリックしアークの配置モードを抜けます。
ラインの配置中に間違えた場合は、BACKSPACE で最後に配置したトラックを消してください。配置したアークをダブルクリックし、Arcダイアログを表示させます。 次のように属性を設定します: Width=6mil、Radius=105mil、Start Angle=55、 End Angle=305。
4.次に、ラインを配置します。 Place » Line [ショートカット P, L]を選択するか、 ボタンをクリックします。 アークの端の近くにカーソルを移動し、Figure 47 のようにPageUp を押してズームインします。 アークの端にカーソルを近づけると、カーソルがアークの端の中心に引き込まれます。 これは、オブジェクトの端にカーソルを引き込む電気的なグリッドを表します。 クリックしてラインセグメントを始めます。
5. TABを押して、線幅(6mil)を設定し、Line Constraintsダイアログでレイヤを確認します。
6.アークのもう一方の端へマウスを移動し、クリックしてラインを配置します。 注 : ラインを配置中、Shift + Spacebarキーを押すと、配置角度の切り換えができます。
7. ラインの配置モードを抜けるには、右クリック、またはESCを押します。

図47 配置されたアーク。ライン配置の開始時に電気的なグリッドを使用してアークにカーソルを引き込み、完成したシルク


図48 複数のオブジェクトを配置して不規則な形状のパッドを作成

異型パッド形状のフットプリントを作成

異型形状のパッドを持つフットプリントを作成する必要がある場合があります。 この場合、ライブラリエディタで利用できるデザインオブジェクトを使用して作成しますが、覚えておく必要がある重要な要因があります。
ソフトウェアでは、パッド形状に基づいてソルダ、ペーストマスクが自動で作成されます。 もし、不規則な形状を構築する為にパッドを使用すれば、そのパッドと一致する不規則なマスクが正しく作成されますが、ライン(トラック)、フィル、カッパーエリア、またはアークなど、その他のオブジェクトから異型の形状を作成する場合、ソルダマスクとペーストマスクのレイヤに適切な大きさのオブジェクトを配置してソルダ、またはペーストマスクを定義する必要があります。

図48 は、異なる設計者によって作成されたSOT-89のフットプリントの2つのバージョンです。 左の図は、中央に大きな異型形状のパッドを配置して2つのパッドを使用しています。 右の図は、パッドとライン(トラック)を使用しています。 後者では、手動でソルダとペーストマスクを作成する必要があります。

フットプリントにプリミティブを含むコンポーネントの管理

デザインを移行する時、各コンポーネントで指定したフットプリントがライブラリから抽出されボードに配置されます。 フットプリント内の各パッドには、回路図のコンポーネントのピンに接続されたネット名と同じネット属性が割り当てられます。 もし、フットプリントのパッドが銅箔のプリミティブに接触している場合、これらのプリミティブには自動でネット名が割り当てられず、デザインルール違反になります。 この場合、ネット名を割り当てる更新過程を実行する必要があります。
PCBエディタには、広範囲のネット管理ツールが含まれています。実行するには、メニューからDesign » Netlist » Configure Physical Nets * を選択します。 図49 は、Configure Physical Nets ダイアログです。図51 に示すスイッチのフットプリントで見つかった余分なプリミティブを更新するのに使用します。 *Menu ボタンをクリックしてオプションのメニューを表示させ、New Net Name 領域をクリックして、ネットを選択。割り当てのないプリミティブへネットを割り当てます。

図49 Configure Physical Netsダイアログで、ネットが無いフットプリントのプリミティブにネット名を更新

図50 2つのパッドに、同じネットの3のデジグネータが割り当てられたTO-3のフットプリント

複数のパッドが同じピンに接続されたフットプリント

図50 に示すフットプリント(TO-3のトランジスタ)は、そのフットプリントに相当する回路図コンポーネントのピンにリンクされた複数のパッドを持っています。 このコンポーネントについては、2つの実装穴のパッド共、同じ''3'のデジグネータが割り当てられています。
回路図エディタでDesign » Update PCBコマンドを使用して、PCBへデザイン情報を移行すると、PCBエディタで両方のパッドに接続線が表示されます(それらは、Figure 50 の様に同じネット上にあります)。 これらの両方共、配線できます。

特別なソルダマスクの取り扱いで必要なこと


図51 パッド、ライン、アークを配置して作成された押しボタンのフットプリント
図51 に示すフットプリントは、PCBの表面レイヤの銅箔に直接、接触させる押しボタンスイッチの接触箇所です。
導電性があるゴムのスイッチパッドをPCB上に配置し、ボタンを押すと、フットプリントの両方の指状パターンと接触し、導通が生まれます。
導通させるには、両方のパターンがソルダマスクで覆われている必要はありません。 円状のソルダマスクの開口は、アークの幅が半径と同じ、または半径より大きいアークを配置することにより作成できます。 これは、2つの指状パターンのところに円で作成されます。
指状のパターンは、アーク、水平のライン、パッドで定義されています。 パッドは、接続箇所の定義に必要です。
注 : ボードの半田面にコンポーネントを配置する時、手動で配置したソルダ・マスクは自動で半田面に移動します。

その他のフットプリント属性

ソルダ、ペースト、マスク

ソルダ、ペーストマスクは、Solder MaskとPaste Maskレイヤそれぞれの各パッドの箇所に自動で作成されます。 Maskレイヤの形状は、PCBエディタで設定されたソルダ・マスクとペースト・マスクのデザインルール、またはPadダイアログで指定されたパッドの端からの拡張、または縮小されたパッド形状になります。

図52 ソルダ・マスクが表示されたパッド
パッド属性には、ソルダ・マスク、ペースト・マスクの拡張度の設定があります。 ここでは、部分的にパッドの拡張度を設定できますが、通常、ここでの設定は行いません。 一般的には、PCBエディタのペーストマスクとソルダ・マスクのデザインルールで適切な拡張度を設定します。 一つのルールを定義すれば、ボード上の全てのコンポーネントの拡張度を設定できます。 もし必要ならば、ボード上の特定のフットプリント、または特定のコンポーネントの特定のパッドなどの様な特定の条件を割り当てたその他のルールを追加することができます。

マスクの表示

PCBライブラリ・エディタで、自動で定義されているソルダ・マスク/ペースト・マスクを確認するには、Maskレイヤを表示します。
1.マスクレイヤを表示させるには、View Configurationsダイアログ(Tools » Board Layers & Colors [ショートカット L])を開いて、Show オプションを各マスクレイヤについて有効にし、OKをクリックします。
2.デザインウィンドウ下部のレイヤタブ(例えば、Top Solder)をクリックして、ソルダマスクを表示します(Figure 52)。 注 : 各パッドの端の周りに、Top Solder Maskレイヤの色で表示されるリングは、ソルダマスクの拡張の度合いにより、マルチレイヤパッドから突き出したソルダマスク形状の端を表します。これは、multilayer が描画順序のトップのレイヤだからです。 レイヤの描画順序は、PreferencesダイアログのPCB Editor - Display ページで設定されています。

マスクのエクスパンション(開口サイズ)をデザインルールで設定

デザインルールでマスクのエクスパンション(開口サイズ)を設定するには:
1. Expansion value from rules オプションが、Pad ダイアログのPaste Mask Expansion、または、Solder Mask Expansion のセクションで有効になっていること確認します。
2.PCBファイルを開いて(PCBファイルが開いてなくても、簡単に仮の新規PCBを作成できます)、PCBエディタのメニューからDesign » Rules を選択し、MaskカテゴリのデザインルールをPCB Rules and Constraints Editorダイアログで確認します。 これらのルールは、フットプリントをPCBに配置した時に反映されます。 注 : ルールシステムは階層構造になっており、必要ならば、ボード全体に適用させる通常のルールを無視して、より高い優先度を持つルールを定義できます。

マスクのエクスパンションを手動で指定

デザインルールのエクスパンジョンを無効にするには、パッド属性のマスクエクスパンジョンを指定します:
1. PadダイアログのPaste Mask Expansion またはSolder Mask Expansion セクションのSpecify expansion value を選択します。
2.値を入力しOKをクリックします。 フットプリントを保存します。

デジグネータとコメント文字

デフォルトのデジグネータとコメント文字

今、ライブラリで作成しているのはフットプリントです。 基板にフットプリントを配置すると、デジグネータとコメントが割り当てられます。これを、コンポーネントと呼びます。 フットプリントを作成する時、デジグネータとコメント文字を手動で定義する必要はありません。 これらは、フットプリントを基板に配置する時、自動で追加されます。 これらの文字の位置は、Componentダイアログのデジグネータとコメント文字のAutopositionオプションで決まります。 PreferencesダイアログのPCB Editor - Defaultsページで文字の位置(サイズ)を事前に定義できます。

デジグネータとコメント文字の追加

デジグネータ、またはコメント文字を追加したい状況があるかもしれません。 例えば、設計者はレイヤ別に出力する図面でコンポーネントが配置される位置にデジグネータのシルクが必要である一方、基板製造業者は、デジグネータを含む各コンポーネントの詳細な製造図面が必要です。 このようなデジグネータを追加したい場合、フットプリントに.Designatorのスペシャル・ストリング(.Commentのスペシャル・ストリングもあります。 )を含めることで対応できます。 基板製造業者に渡す図面を作成するには、ライブラリ・エディタでメカニカルレイヤに.Designator のスペシャル・ストリングを配置します。 それから、このレイヤの図面を印刷します。
この機能が必要な場合、以下の方法を実行します:
1.必要なメカニカルレイヤを表示します。各メカニカルレイヤの ShowEnable オプションを、View Configurations ダイアログ(Tools » Board Layers & Colors)で有効にします。
2.このレイヤをアクティブにするには、デザイン・ウィンドウの下部のMechanicalレイヤタブをクリックします。 タブがハイライト表示され、すべての新しいテキストはこのレイヤに配置されます。
3. Place » String [ショートカット P, S]を選択するか、Place String ボタンをクリックします。
4. テキストストリングを入力しその属性(例えば、フォント、サイズ、レイヤ)を定義するには、テキストを配置する前に、TAB キーを押します。 Stringダイアログが表示されます。 Textのドロップダウン・リストから.Designatorを選択します。 テキストのHeight(高さ)を40milに、Width(幅)を6mil に設定してOKを押します。 デジグネータの左下には、.Designatorのストリングのドットがあります。
5.これでテキスト・ストリングを配置できます。 テキストストリングを回転させるにはSpacebarを押します。 必要な場所に移動し、クリックして配置します。 右クリック、またはESCを押して、ストリング配置モードを抜けます。
6.必要であれば、同じ手順を実行して.Commentのスペシャル・ストリングを配置します。
7.特別なストリングをテストするには、PCBにフットプリントを配置します。 PCB Libraryパネルでフットプリント名を右クリックしPlaceを選択して、フットプリントを配置できます(PCBファイルが開いているとき)。 フットプリントをPCBドキュメントに配置してもデジグネータが表示されない場合は、PCBエディタのView Configurationsダイアログ、View Optionsページで、Convert Special Strings オプションが選択されているか確認してください。

特別なレイヤ指定要求の取り扱い


図53 PCBエディタでのレイヤペア定義
グルードット、またはソルダー・マスクの様なPCBコンポーネントに割り当てる特別な必要条件があります。 これらの特別な必要条件の多くは、コンポーネントを実装する配置面に関連しており、コンポーネントを反転する時、コンポーネントに関連するオブジェクトもボードの反対面に反転する必要があります。

Altium DesignerのPCBエディタでは、滅多に使用しない特別な目的のレイヤを含めるのではなく、"レイヤペア"という機能を利用してこの要求をサポートします。 レイヤペアとは、ペアとして定義された2つのメカニカルレイヤです。 コンポーネントをボードのある面から反対面に反転する時はいつでも、ペアとなったメカニカルレイヤのオブジェクトは、そのペアの反対面のメカニカルレイヤに反転します。
この方法を使用して、グルードット(または、その他の特別な条件)を含めるのに適切なメカニカルレイヤを選択します。 そして、オブジェクトを使用してその形状を定義します。 ボードにフットプリントを配置する時、レイヤペアを設定する必要があります。 これにより、このコンポーネントをボードの反対側に反転する時にそのオブジェクトを移行するレイヤが指定されます。
注 : レイヤペアはPCBライブラリエディタでは定義できません。PCBエディタで定義します。

3次元コンポーネントの詳細機能3D

今日のエレクトロニクス製品はより精密で複雑になっており、PCB設計者はコンポーネントの水平方向のクリアランスの条件以上のことを考慮する必要があります。 また、高さ制限やコンポーネントの下にコンポーネントを配置するオプションを考慮する必要があります。 さらに、最終的なPCBファイルを機構CADツールへ移行し、開発中の製品を仮想的に組み立て、パッケージの完成度を確認する必要があります。 Altium Designerには、これらの異なる状況に対応する機能が多数、搭載されており、もちろん、その中にはリアル3Dビジュアライゼーションが含まれています。

PCBフットプリントへ高さ情報を追加

最も簡単なレベルでフットプリントに高さ属性を追加できます。 これを実行するには、PCB LibraryパネルのComponentsリストのフットプリント名をダブルクリックし、PCB Library Componentsダイアログを表示させます。 そして、Heightの項目にコンポーネントの高さを入力します。
Height デザインルールは、ボード設計中に定義できます(PCBエディタでDesign » Rules を選択します)。 一般的には、コンポーネントのクラス、またはルームを定義して最大のコンポーネントの高さについてテストします。

フットプリントに3Dボディを追加

よりリアルなコンポーネントレンダリングのため、3Dビューモード[ショートカット 2 (2D), 3 (3D)] がPCB ライブラリエディタに用意されています。3Dボディのオブジェクトはフットプリントに追加できます。3Dボディは有効なメカニカルレイヤ上でのみ、フットプリントに追加できます。 押出成型のようなシンプルな3Dボディは、2Dポリゴンタイプのオブジェクトです。表面カラーと高さの属性を持っており、3Dのレンダリング時には、引っ張ったような、あるいは型で押し出したような形をしています。 3Dボディは球体や円筒形も作成できます。
複数のの3Dボディは、コンポーネントの物理的なサイズと形状を全方向にわたって定義するために結合させることができ、コンポーネントクリアランスのデザインルールで使用されます。 高精度の3Dモデルはコンポーネントクリアランスのチェックの精度を向上させ、視覚的な訴求力と完成したPCBアセンブリのリアリティを向上させます。
Altium Designerは、PCBフットプリントへダイレクトに3D STEPモデル(*.step or *.stp files)をインポートし、3Dモデルをレンダリングする機能をサポートしています。 この機能的な拡張は、STEPモデルをAltium Designerのドキュメントに組込むか、リンクすることができるようにします。ただし、リンクされたSTEPモデルは、PCBライブラリエディタでは扱えません。
注 : コンポーネントを反転させると、3Dボディもボードの反対側に反転します。 3Dボディデータ(メカニカルレイヤ内)を別のメカニカルレイヤに反転させたい場合は、PCBドキュメントにレイヤペアを定義する必要があります。詳細は、特別なレイヤ指定要求の取り扱い GlueDotsをご覧ください。

図54 - DIP-14 コンポーネントの詳細

3Dボディを手動で配置

3Dボディは、手動でPCBライブラリエディタ内に配置することができます(Place » 3D Body) それらは、PCBライブラリエディタのフットプリント(および、PCBエディタに配置されたフットプリント)にも自動的に追加されます。 3D Body Manager ダイアログ (Tools » Manage 3D Bodies for Library/Current Component)を使用してください。
注 : 3Dボディは、2Dモデル、3Dモデルの両方に配置できます。

図55 - DIP-14 3Dのフットプリント

ここで、このチュートリアルで以前に作成したフットプリントDIP14に3Dボディを追加してみましょう。 PCB ライブラリエディタで3Dボディを手動で配置するには:
1. PCB Library パネルで、DIP-14 エントリをダブルクリックすると、PCB Library Component ダイアログが開きます(Figure 54)。名称、高さ意、記述がわかります。 コンポーネントの高さが、ここでは重要です。実際に高さのある3Dボディを作る必要があるからです。
注 : コンポーネントの諸元について製造元のデータが利用できる場合は、それをお使いください。

図56 3D Bodyダイアログで3Dボディ属性を定義
2. Place » 3D Bodyを選択します。 コマンドの起動後、3D Body ダイアログが表示されます (Figure 56) 。 Extruded オプションを 3D Model Type 領域から選びます。
3. Properties 領域で、3Dボディオブジェクトに特定の名前(Identifier)を付けます。Body Side (基板のどちらの側で3Dボディプロジェクトを垂直にするか) は、Top Side のままにしておいてください。
注 : コンポーネントには、ピンのように、PCBから突き出しているネガティブスタンドオフの高さを入力できます。 スタンドオフの高さはデザインルールチェッカではチェックされません。
4. Overall Height を 200mil に、Standoff Height(ボードから3Dボディ下部までの距離)を 0mil に設定。3D Color の色を適当に設定します。
5. OK をクリックして、3D Body ダイアログを閉じます。配置モードになります。 2Dでは十字形、3Dでは青色の円錐にカーソルが変化します。
6.カーソルを移動させ、クリックして、ボディの開始点を固定します。続いて、一連の頂点ポイントを固定して、ボディのポリゴン形状を定義します。
7.最後の頂点ポイントを配した後、右クリック、またはESC を押してボディの配置を完成させます。 Altium Designerでは、最初に配置したポイントから最後に配置したポイントを自動的に結び、形を作成するので、完全に閉じたポリゴンを作成する必要はありません。

形状の定義中に SHIFT + SPACEBAR を使って、いくつかのコーナーモードを切り替えることができます。 切り替え可能なモードは次のとおり: 自由アングル、45°、アークつき45°、90°アークつき90° アークの半径は自由に増減できます。SHIFT + . (ピリオド)、または、SHIFT + , (コンマ)をそれぞれ使用します。 SPACEBAR で、コーナーの向きを切り替えることができます。
押出 3Dボディオブジェクトが選択されているときは、編集ハンドルが各頂点に表示されます。 カーソルが変化して、 ハンドルを捉えたら、クリック&ドラッグで頂点を動かすことができます。 このカーソルが縁の中間に表示されたら、クリック&ドラッグで頂点をその縁に追加し、動かすことができます。
カーソルが変化して、 オブジェクトの縁を捉えたら、クリック&ドラッグで縁を動かすことができます。
カーソルが変化して、 オブジェクトを捉えたら、クリック&ドラッグで3Dボディを動かすことができます。 3Dボディはドラッグして、回転させたり、反転させたりできます。 編集コントロールを使って、3Dボディの形状を調整してください。

図57 DIP14 の 3D の例 このモデルには16の3Dボディ - メインボディ、足、円筒によるピン1参照マーカ - が使われています。

配置モードのときにBACKSPACE キーを使うと、最後に配置した頂点を削除できます。 キーを繰り返し使うと、ポリゴンの外形を '崩す' ことができ、最初にはじめたところに戻ることができます。
この形状は、Component Clearance 設計ルールに適合しています。しかし、3Dビジュアライゼーション用としては、不十分かもしれません。 さらに 3Dボディを設計して、コンポーネントの詳細を追加することもできます。
3D ボディを完成させると、3D Body ダイアログが表示されます。 3D ボディの配置を続けるか、Cancel をクリック、または ESC を押してダイアログを閉じます。 Figure 57 は Altium Designerが作成した DIP14 3Dです。
3D ボディを 3D で見たいときは、3 を押して、3D ビューモードに入ります。 3D ボディが見れないときは L を押して、View Configurations ダイアログを開きます。Physical Materials ページの Show Simple 3D Bodies オプションを有効にするか、あるいは、3D Bodeis Display Options コントロールを PCB パネル上で使用してください。,3D モデルモードになります。 2D モードに戻るには、2を押します。
PCBライブラリを保存します。

3D Body をインタラクティブに作成

3D ボディオブジェクトをフットプリントから対話的に作成するのは、手動のやり方とよく似ています。 基本的な違いは、フットプリントの詳細を含む既存のオブジェクトから、3D ボディとして"押し出す"ことのできる閉じた形状を検出するのに、Altium Designerを使うことです。 これは、3D Body Manager ダイアログで行います。
注 : "閉じている" ポリゴンだけが 3D ボディオブジェクトを作成できます。
3D Body Manager ダイアログを使用して、トランジスタパッケージ用の3D ボディ、TO-39 を定義しましょう。 パッケージボディのカーブ形状や位置づけタブのおかげで、このアプローチは形状を手動で定義しようとするよりも簡単です。

3D Body Manager ダイアログを使用するには:

図58 3D ボディが追加されたTO-39 2D フットプリント

1.ライブラリで、TO-39 フットプリントをアクティブにします
2. Tools » Manage 3D Bodies for Current Component を選択します。 3D Body Manager ダイアログが表示されます。

図59 TO-39 3D モデル


図60 3D Body Manager ダイアログを使って、既存のプリミティブから3D ボディオブジェクトをクイック作成

3.コンポーネントのシルク外形に基づいた形状を作成するには、リストに表示される2番目のオプション、Polygonal shape created from primitives on TopOverlayを使用します。 ダイアログのこの行で、Action 行の Add to (component_name)をクリックし、Registration Layer をボディオブジェクトが配置されるメカニカルレイヤに設定します(この場合は Mechanical1)。Overall Height に適当な値、たとえば 180milに設定。Body 3D Color は適当な色に設定します。 図60 をご覧ください。 リストをスクロールして、コンポーネントモデルを定義するのに使いたい、いずれかの閉じたポリゴンを選択します。
4. Closeをクリックすると、3Dボディの形状は 図58 のようにコンポーネント上に表示されます。 ライブラリを保存します。
図59 は、TO-39 用に完成された 3D モデルです。 このモデルは、5つの 3Dボディオブジェクトから構成されています。

  • ひとつはベースで、フットプリント外形(全体の高さ 50mil、スタンドオフの高さ 0mil、ボディ 3D の色は灰色)から作成されます。

    図61 3D ボディの詳細が表示されるPCBLib List パネル
  • ひとつは、ケーシングのボディで、配置された円形から作成され、閉じたポリゴンをそこから選び出します。その際、3D Body Manager ダイアログによって検出され、次のような属性 - 全体の高さは 180mil、スタンドオフの高さは 0mil、色は灰色 - を付与されます。
  • ひとつはピンで、これも配置された円形 (全体の高さ 0mil、スタンドオフの高さ -450mil、色は金色)から作成されます。 これはコピーされ、ペーストされ、残りのピンを作成するのに、2回、位置決めされています。

3D ボディを編集するには、右クリックして、ポップアップメニューからProperties を選んで、3D Body ダイアログを開きます(図56)。 PCBLib List パネル(図61)を使って、3D ボディをリストし、直接、編集することもできます。
3D Body の詳細については、TR0112 PCBエディタとオブジェクトのリファレンス TR0112%20PCB%20Editor%20and%20Object%20Reference.PDF ドキュメントの3D ボディのセクションを参照してください。

3DボディとしてSTEPモデルをインポート

多くのコンポーネントベンダが詳細な3Dモデルを提供して、一般的なメカニカルCADパッケージで使用されています。 Altium Designerは3D STEP モデル(*.step or *.stp)を直接、コンポーネントフットプリントにインポートすることができます。 モデルを自作するより、時間が節約され、さらに洗練されたモデルにすることもできます。
STEP ファイルでは、AP214、AP203 フォーマットがサポートされています。 AP203 フォーマットでは彩色がサポートされていません。インポートされたモデルは、グレイスケールで表示されます。

リンクされたSTEPモデル

リンクされたSTEP モデルは、PCB ライブラリエディタではサポートされていません。 組込み STEP モデルはサポートされていません。

STEPモデルのインポート

STEP モデルのインポート手順は、以下のとおりです。
1. Place » 3D Body [ショートカット P, B]を選択します。 3D Body ダイアログが表示されます。
2. Generic STEP Model オプションを3D Model Type 領域で選択します。
3. Embed STEP Model ボタンをクリックします。 Choose Model ダイアログが表示されます。そこで *.step や *.stp ファイルを確認することができます。
4.目的のSTEP を選択し、 Open ボタンを押して Choose Model ダイアログを閉じます。
5. 3D Body ダイアログに戻り、OK をクリックして閉じます。 3D ボディがカーソルの上に表示されます。
6.ワークスペース内でクリックして、ロードされた選択モデルとともに、3D ボディオブジェクトを配置します。

STEP モデルの位置決めと向き

STEP モデルがインポートされると、プレースホルダ 3D ボディがモデルを収納するためにリサイズされます。 生成アプリケーション内で使用されている原点のせいで、PCBドキュメントの座標軸に対して、STEP モデルを正確に方向付けるのは難しいかもしれません。 STEPモデルのグラフィカルな位置決めを行うには、いくつかの方法があります。モデルを扱うために配置されている参照ポイント(snap pointsでわかります)を使用するか、ボードに対するモデルの表面または表層を使用します。 非グラフィカルな位置決めは、 3D Body ダイアログのGeneric STEP Model 領域の設定で実行できます
STEPモデルの位置決めと向きについての詳細は、TU0132 MCADオブジェクトとPCBデザインの統合 TU0132%20Integrating%20MCAD%20Objects%20and%20PCB%20Designs.pdf を参照してください。

その他のソースからフットプリントを追加

PCBライブラリに既存のフットプリントをコピーできます。 コピーしたフットプリントは名称を変更したり編集を行うことができます。
もし、既存のフットプリントをPCBライブラリにコピーしたい場合、以下のことができます:

  • PCBドキュメントで配置したフットプリントを選択し、コピーして(Edit » Copy)、開いているPCBライブラリにEdit » Paste Component を使用してペーストします。
  • Edit » Copy Component を選択して、PCBライブラリエディタにコピーするフットプリントをアクティブにします。コピー先のPCBライブラリを開き、Edit » Paste Component を選択します。
  • 一つ、または複数のフットプリントをPCBライブラリパネルのリストで選択します。標準的な操作、Shift + クリック、または、Ctrl + クリックしたまま、右クリックで、Copyを選択します。コピー先のライブラリに切り替えて、フットプリント名のリストで右クリックしPasteを選択します。


図62 デザインで使用する前に、ライブラリ内のフットプリントを検証

コンポーネントのフットプリントの確認

回路図ライブラリエディタには一連のレポート機能があり、フットプリントが正しく作成されているか確認し、どのコンポーネントが既存のPCBライブラリにあるか特定できます。 既存のPCBライブラリのすべてのコンポーネントを確認するには、Component Rule Checkのレポート機能を実行します。 Component Rule Checkerは、複数のプリミティブ、パッドのデジグネータの誤り、未接続の銅箔、不適当なコンポーネントについてチェックします。
1.レポートを実行する前にライブラリ・ファイルを保存します。
2. Reports » Component Rule Check [ショートカット R, R]を選択して、Component Rule Checkダイアログを表示させます。
3.すべてのチェックボックス有効にして、OKをクリックします。 PCBlibraryfilename.err と言うレポートが作成され、テキストエディタに表示されます。 どんなエラーもチェックされます。
4.レポートを閉じてPCBライブラリ・エディタに戻ります。

統合ライブラリの作成


図63コンパイル時にエラーチェックが実行されます

ここまでで、以下のような操作を行ってきました:

  • 統合されたライブラリパッケージ(コンパイルされた統合ライブラリのソースプロジェクト)を作成しました。
  • 新規の回路図ライブラリをライブラリパッケージに追加し、回路図コンポーネントを作成しました。
  • コンポーネントがその他の領域で使われる際に使用するモデルを特定しました。ボードデザイン、または回路シミュレーションなどです。
  • 新規のPCBフットプリントライブラリをライブラリパッケージに追加し、フットプリントを作成しました。
  • 特別なフットプリントを扱う方法について説明しました。

このチュートリアルの最後の手順では、ライブラリパッケージをコンパイルして統合ライブラリを作成し、コンポーネントやすべての参照モデルを含む一つのファイルを作成します。 たとえ、統合ライブラリを使用しないでソースライブラリとモデルファイルから直接、作業する方を好んだとしても、ライブラリパッケージをコンパイルする強力な動機があります。 これにより、広範囲なコンポーネントやコンポーネントに関連するモデルをチェックすることができます(図63)。

ライブラリパッケージをコンパイルするには:
1. Project » Compile Integrated Libraryを選択して、統合ライブラリのライブラリパッケージ内のソースライブラリやモデルファイルをコンパイルします。 コンパイル中に見つかったエラー、またはワーニングは、Messagesパネル(View » Workspace Panels » System » Messages)に表示されます。 Messagesパネルでエラーをダブルクリックすると、詳細情報を表示して、コンポーネントにジャンプします。 この方法でソースライブラリのエラー箇所を修正し、統合ライブラリを再コンパイルします。
2.新規のIntegrated Libraryname.INTLIB が作成され、Project OptionsダイアログのOptionsタブで指定した出力フォルダに保存されます。 新規の統合ライブラリは自動でInstalled Librariesのリストに追加され、Librariesパネルに表示されます。

Design » Make Integrated Libraryコマンドを使用して、完成したプロジェクトから統合ライブラリを作成できることに注意してください。 これは最初にソースライブラリを作成し、それから統合ライブラリを作成する方法です。
統合ライブラリの詳細については、TU0111 統合ライブラリの作成 TU0111%20Building%20an%20Integrated%20Library.PDFを参照してください。

用語

以下の用語がこのチュートリアルで使用されています。

コンポーネント

コンポーネントは、ボードに配置される物理的なデバイスです。集積回路、抵抗など。 これらのコンポーネントには、一つのパート、または複数のパートで構成されているものがあります。

3Dボディ

3Dボディはポリゴンで形成されたオブジェクトで、有効なメカニカルレイヤ上のフットプリントに追加できます。 水平方向、垂直方向のプレーンで、コンポーネントの物理的なサイズと形状を定義するために使用できます。きちんとコントロールされたクリアランスチェックや、3Dビジュアライゼーションを可能にしています。 3D ボディオブジェクトは、コンポーネントフットプリントにおけるSTEPモデルのプレースホルダとして、また、PCBに実装されない自由部品オブジェクト、ハウジングやアセンブリなどとして活用できます。

デジグネータ(部品番号、識別子)

固有の識別子。PCBで、特定のコンポーネントをその他のコンポーネントから見分けるために使用します。 デジグネータは、アルファベット、数値、またはその組み合わせで表すことができます。 パッドでは、さらに、コンポーネントのピン番号に一致する固有のデジグネータが割り当てられます。

フットプリント

フットプリントは、PCB上に実装されるコンポーネントに必要なスペースを定義(または、モデル化)します。 コンポーネントのフットプリントモデルは、PCBライブラリに保存されます。 フットプリントには、デバイスのピンへ接続するためのパッドと、シルク(オーバーレイ)レイヤ上にトラックまたはアークセグメントで作成されたパッケージの物理的な外形が含まれています。 さらに、デバイスの実装する機能が含まれています。
PCBライブラリ内のフットプリントには、デジグネータ、またはコメントはありません。 PCBシート上に配置され、デジグネータやコメントが割り当てられた時に、それらはコンポーネントになります。

ヒドゥンピン

コンポーネントには存在するが、表示する必要が無いピンです。 一般的には、パワーピンです。指定したネットに自動的に接続されます。

ライブラリ

回路図ライブラリは、個々のシートに保存されたコンポーネントやそのパーツの一式です。 PCBライブラリは、コンポーネントフットプリントを含みます。 各ライブラリタイプには、それ自身のエディタがあります。 統合ライブラリは、回路図ライブラリを関連したモデルと結合させます。ライブラリエディタでは直接、編集できません。

オブジェクト

ライブラリエディタのワークスペースに配置できる個々のアイテムです。

パッド

パッドオブジェクトは、通常、フットプリントに使用され、コンポーネントピンの接続パッドを生成します。

パート

グラフィカルオブジェクトの集まりで、複数のデバイスを持つコンポーネントの一つを表します。 パートは、回路図コンポーネントライブラリのコンポーネント内で個別のシートに保存されます。

ピン

コンポーネントのピンは、コンポーネントに電気的な属性を割り当てて、接続箇所を定義します。

Labels
  • None