Altium Wiki

Information and resources for electronic product designers

Skip to end of metadata
Go to start of metadata

このチュートリアルでは、アナログフィルタデザインの回路図を作成して、回路シミュレーションをセットアップします。設定、解析の実行、を回路図上で行い、結果を波形アナライザで表示するまでをカバーします。

Tutorial TU0106 (v1.6) April 20, 2008

このチュートリアルでは、回路シミュレーション解析を実行するために回路図を作成することから始めます。最初に新規プロジェクトファイルを作成してからブランクの新規回路図シートを追加します。

新規プロジェクトの作成


チュートリアルを開始するには、新規PCBプロジェクトを作成します:
1. メニューから File » New » Project » PCB Project を選択するか、またはFilesパネルのNewの項目にあるBlank Project (PCB)をクリックします。もし、このパネルが表示されていない場合は、ワークスペースパネルの下部のFilesタブをクリックします。
あるいは、Altium Designer Home Page (View » Home) のPick a Task の項目のPrinted Circuit Board Designを選択してからNew Blank PCB Projectをクリックします。
2. Projectsパネルが表示されます。新規のプロジェクトファイル(PCB Project1.PrjPCB)がここにNo Documents Addedとしてリスト表示されます。
3. File » Save Project As を選択して、新規のプロジェクトファイル(拡張子.PrjPCB)の名称を変更します。ファイル名をFilter.PrjPCBと入力し、プロジェクトの保存先を指定し、Saveをクリックします。
次に空のプロジェクトファイルに追加する回路図を作成します。この回路図は、フィルタ回路になります。もし、回路図を作成する時間が無い場合は、Altium Designerがインストールされている場所のExamples\Circuit Simulation\Filterフォルダに保存されている類似のプロジェクト(Filter.PrjPCB)を開きます。

新規回路図シートの作成

新規の回路図シートを作成するには、次のステップを実行します:
1. File » New » Schematic を選択します。回路図エディタのデザインウィンドウにSheet1.SchDoc というブランクの回路図シートが表示され、Projectsパネル内のプロジェクト名が表示されている下のSource Documentsに回路図シートのアイコンが表示されます。
2. File » Save As を選択して、新規の回路図ファイル(拡張子.SchDoc)の名称を変更します。ハードディスク上で回路図を保存したい場所を指定し、ファイル名の項目でFilter.SchDocと入力してSaveをクリックします。

回路図の作成

図1 に示すフィルタ回路を作成します。シミュレーションを実行する前に、回路図に付属のSIMモデルを持つコンポーネントやフィルタに供給する電源ソース、入力ソース、グランドシンボル、そして波形を表示したい場所にネットラベルを配置する必要があります。
チュートリアルのこの項目では、コンポーネントを配置し、それらの属性を設定してからワイヤを接続します。

1.Filter.SchDoc

コンポーネント配置とライブラリの読み込み

最初にLF411CN というオペアンプのコンポーネントを検索します。
1. LibrariesタブをクリックしてLibrariesワークスペースパネルを表示させます。
2. LibrariesパネルのSearchボタンを押すか、Tools » Find Componentを選択します。Libraries Searchsダイアログが開きます。
3. ScopeをLibraries on Pathに設定し、Pathの欄でこれから検索するパスが指定されているか確認します。インストールの際、デフォルトディレクトリを適用した場合、パスは、C:\Program Files\Altium Designer\Library\になるはずです。必要ならば、フォルダアイコンをクリックし、ライブラリフォルダを確認します。Include Subdirectoriesオプションが有効(チェック)になっていることを確認します。

4. LF411に関連するすべての部品を検索する為に、Libraries Searchダイアログの上部のテキスト入力欄に*LF411* と入力します。*(アスタリスク)は、メーカーごとに異なる接頭辞や接尾辞が挿入されていることを考慮して使用するワイルドカードです。
5. Searchボタンをクリックすると検索が開始され、検索結果がLibrariesパネルに表示されます。必要なコンポーネントは、NSC Operational Amplifier.IntLibライブラリに保存されています。

シミュレーション用コンポーネントの配置

最初にオペアンプU1のコンポーネントを回路図に配置します。回路の一般的なレイアウトに関しては、図1に示した回路図を参照してください。
1. LibrariesパネルのComponentsリストでLF411CNを選択し、Place LF411CNボタンをクリックします。あるいは、コンポーネント名をダブルクリックします。
2. ライブラリが登録されていない場合、Confirmダイアログが表示されます。

3. ライブラリを登録するには、Yesをクリックします。オペアンプのシンボルがカーソル上に現れます。今は、部品の配置モードになっています。
4. 回路図に部品を配置する前に、まず、その属性を編集します。オペアンプがカーソルにある時にTAB キーを押してComponent Propertiesダイアログを表示させます。

5. ダイアログのPropertiesセクションに、最初のコンポーネントデジグネータの値を設定します。Designatorの項目にU1と入力してください。
6. 次に、シミュレーションを実行する時に使用する SIM  モデルを確認します。このチュートリアルでは、回路シミュレーション用の推奨モデルが既に含まれている統合ライブラリを使用します。Component PropertiesダイアログのModelsリストのLF411_NSC を選択します。 そして、Edit をクリックしSIM Model - General / Generic Editorダイアログを表示します。

7. モデルファイルパス名が、NSC Operational Amplifier.IntLib 統合ライブラリで検索され、設定されていることに注目してください。
Model Fileタブをクリックし、モデルファイルの内容を表示させます。もし、モデルファイルが見つからない場合は、エラーメッセージがこのタブに表示されます。
Altium Designer のシミュレータ サポートは、Spice 3F5 モデルとPSpice モデルの大半です。

8. (Netlist Templateタブをクリックして表示される)Netlist Templateにモデルファイルからのデータが表示され、その内容をNetlist Previewタブをクリックして確認することができます。

OKをクリックして、すべてのダイアログを閉じます。
これで回路図シートにオペアンプを配置する準備ができました。
9. もし、図1の回路図を参照する場合、U1がカーソル上にフローティングの状態であるシンボルを反転して配置されていることに注意してください。オペアンプの方向を垂直に反転するには、配置する前にYキーを押します。シート上でコンポーネントを配置する場所に移動し、左クリックするかENTERを押して回路図に配置します。
10. 右クリックまたはESCキーを押して、部品配置モードを解除します。

新規SIMモデルファイルの追加

回路シミュレーション(.cktや.mdlファイル)で使用するSPICEモデルは、Altium Designerがインストールされている場所のLibraryフォルダの統合ライブラリ内に保存されます。正しい拡張子をそれぞれのモデルタイプに使用してください。例えば、SPICE .subcktは*.cktファイルでないと見つけられなくなり、SPICE .model は*.mdlファイルでないと見つけられなくなります。
Model Nameは、SIMモデルファイルへリンクさせるのに重要ですので、適切なモデル名であることを確認してください。
Altium Designerの統合ライブラリ内の既存のモデルファイル名を検索するには:
1. LibrariesパネルのSearchボタンをクリックします。Libraries Searchダイアログが表示されます。
2. 供給されたライブラリで利用できるすべてのシミュレーションモデルを検索するには、次のクエリを入力します:
HasModel('SIM','',False)と入力し、Search{*}ボタンをクリックします。
更に、クエリにより詳細な情報を追加することにより、検索範囲を狭くすることができます。 例えば、LF411に関するモデルだけを検索するには、次のクエリを使用します:
HasModel('SIM','LF411',False)

クエリの詳細については、Query Helper(Libraries SearchダイアログのHelperボタンをクリック)を使用するか、TR0110 クエリ言語リファレンス TR0110%20Query%20Language%20Reference.pdfを参照してください。

3. 検索結果がLibrariesパネルに表示されます。

既に統合ライブラリのコンポーネントに供給されているモデルではなく、その他のモデルをデザインで使用したい場合があるかもしれません。この場合、メーカーから入手したモデルファイルをデザインのプロジェクトファイルにコピーすることをお薦めします。

その他の統合ライブラリに属するシミュレーションモデルを使用したい場合:
1. 必要なモデルを含む.Intlibファイルを開きます(File » Open を選択し、ソースライブラリを抽出します)。
2. 出力フォルダ(統合ライブラリを開いた時に作成されたフォルダ)からプロジェクトを含むフォルダに、モデルファイルをコピーします。それから、このモデルを追加し、必要ならばSimエディタを使用して修正することができます。

試しに、Altium Designerがインストールされている場所のExamples\Circuit Simulation\Filterフォルダに保存されている他のSPICEモデル(LF411C.ckt)を追加してみましょう。
1. LF411C.cktをコピーし、Windowsエクスプローラを使用して、作成したプロジェクトファイルが存在するフォルダにこのファイルを貼り付けます。
2. Projectsパネル内のプロジェクト名(Filter.PrjPCB)を選択して、右クリックしAdd Existing to Projectを選択して、プロジェクトにモデルファイルを追加します。モデルファイルを選択しOpenをクリックします。SPICEモデルファイル(LF411C.ckt)が、Projectsパネル内のLibraries\AdvancedSim Sub-Circuitsフォルダ下のプロジェクトに追加されます。
これで回路図内のコンポーネントへモデルを追加することができます。もし、必要ならば回路図ライブラリのこのコンポーネントへモデルを追加することもできます。

3. オペアンプ(U1)をダブルクリックして、Component Propertiesダイアログを開きます。Modelsの項目で設定されているSIMモデルを削除します。 削除するには、SIMモデルを選択してRemoveをクリックし、ConfirmダイアログでYesをクリックします。
4. Models Listの項目のAdd をクリックしてAdd New Modelダイアログを表示させます。
5. Model TypeのドロップダウンリストからSimulationを選択し、OKをクリックします。SIM Model - General / Generic Editorダイアログが表示されます。

6. Model Sub-KindリストからSpice Subcircuitを選択してSpice PrefixをXに設定し、Model Locationの項目を表示します。ダイアログ名は、Model Sub-Kindに変更されます。
7. Model Nameの項目にLF411Cと入力します(拡張子は必要ありません)。 一致するモデルをすべての有効なライブラリから検索する為、Model LocationはAnyに設定します。
Altium Designerは、一致するモデルが見つかるとすぐにモデルの検索を停止します。統合ライブラリに関連付けられていないモデルについては、プロジェクトに追加したモデルファイルを検索します。 更に、Options for Projectダイアログ (Project » Project Options)のSearch Pathsタブ内で設定されているSearch Pathsで見つかったモデルファイルを検索します。この例では、projectフォルダに保存されているモデルファイル(LF411C.ckt)を検索します。
モデル検索で一致するモデルが見つからない時は、Model Fileタブにエラーが表示されます。プロジェクトをコンパイルすると、エラーはMessagesパネルに表示されます。
8. 最後の段階は、新しいモデルが回路図コンポーネントのピン番号と一致しているかピンマッピングを確認することです。SIM Model - General / Spice SubcircuitダイアログのPort Mapタブをクリックします。

9. Model Pinドロップダウンリスト(上図のダイアログ参照)から一致するピンを選択して、元のSIMモデル(LF411_NSC)に使用されているピン番号と同じになる様、ピンマッピングを修正します。
ピン番号の順番は、Netlist Templateタブで確認します。このモデルの指示は、1, 2, 3, 4, 5であることに注意してください。

これらは、Model Fileタブに表示される.SUBCKTヘッダーと対応します。 これらの番号は、このモデルファイルでの設定で、他のモデルでは同じように一致するとは限りません。

ピンマッピングの変更
Original pin mapping

Port MapタブのModel Pin 欄で、1(1), 2(2), 3(3), 4(4), 5(5), とリスト表示されます。 最初の番号が、モデルピン番号で(Netlist Templateの%1, %2, など)、サブサーキットヘッダーに対応するノード名/番号は、括弧で囲まれます。
サブサーキットヘッダ内の実際の番号は、重要ではありません。 重要なのは、Spice ネットリストに表示される接続の順番です。これらは、.SUBCKTのヘッダー内の順番 (例えば、Non-Inverting Input (IN+)、 Inverting Input (IN-)、Positive Power Supply (V+)、Negative Power Supply (V-) 、そしてOutput (OUT))と一致する必要があります。

ネットリストヘッダは、各ピンの機能について記述されています。それらを適切な回路図ピンにリンクさせる為にこの情報を使用します。例えば:
1(1)は、+ input (Non-Inverting Input)ですので、回路図ピン3(IN+)にリンクさせます。
また 5(5)は、Outputですので、回路図ピン6(OUT)にリンクさせます。

10. ピンマッピングを修正したら、OKをクリックしてすべてのダイアログを閉じます。
シミュレーションを行うために、Filter回路図の設定を続けます。

シミュレーション用の抵抗の設定

次に2つの抵抗を配置します。
1. Librariesパネルで、Miscellaneous Devices.IntLibライブラリがアクティブになっていることを確認します。
2. ライブラリ名の下のフィルタの項目にres1と入力しフィルタを設定します。
3. コンポーネントリストのRES1を選択し、Placeボタンをクリックします。カーソル上に抵抗のシンボルが表示されます。
4. TABキーを押して、抵抗の属性を編集します。ダイアログのProperties内で、最初のコンポーネント識別子の値をDesignatorフィールドにR1と入力して設定します。
5. 抵抗のパラメータの項目を設定します。設定は、回路図上に表示され、このチュートリアルの後半で回路シミュレーションを実行する時に使用します。Valueパラメータは、一般的なコンポーネント情報に使用されますが、ディスクリートコンポーネントは、シミュレーションを行う時にそれを使用します。
もし、コンポーネント属性に既存パラメータとしてValueが無い場合は、パラメータリストのAddボタンをクリックし、Parameter Propertiesダイアログを表示させます。NameにValue、Valueに100kと入力します。Stringが、パラメータタイプとして選択されていて、ValueのVisibleボックスにチェックが入っていることを確認してください。OKをクリックします。
6. ダイアログのPropertiesの項目でCommentの項目をクリックし、ドロップダウンリストから=Valueストリングを選択し、Visibleのチェックをはずします。Altium Designerでは、Comment欄をパラメータの内容で置き換える「間接的参照」をサポートしており、(パラメータのValueとCommentの項目で)値を2回入力する必要はありません。このデータは、2回入力しなくてもPCBと部品表に転送することができます。
7. ModelsリストでSIMモデル(RESISTOR )を確認します。Modelsリストでモデル名を選択し、EditをクリックしてSim Model - General/Resistorダイアログを表示させます。このタイプの抵抗は、モデルファイルは必要とせず、Valueパラメータで入力したNetlist TemplateのValueを参照します。

OKをクリックしてダイアログを閉じ、Component Propertiesダイアログに戻ります。OKをクリックします。

8. 抵抗を配置する位置を決めて(図1の回路図参照)、左クリックまたはENTERを押し、部品を配置します。
9. 次にR2の抵抗を配置します。そのまま続けて配置すると、デジグネータは自動でインクリメントされます。
10. 抵抗を配置した後に、右クリックまたはESCを押して部品配置モードを解除します。

シミュレーション用のコンデンサの設定

次に2つのコンデンサを検索し、配置します。
1. コンデンサの部品は、Librariesパネルで既に選択されているMiscellaneous Devices.IntLibライブラリにあります。Librariesパネル内のコンポーネントのフィルタ欄にcapと入力します。コンポーネントリスト内のCAPをクリックし、Placeボタンをクリックします。
2. TABキーを押して、コンデンサの属性を編集します。Component PropertiesダイアログのPropertiesのDesignator欄をC1と設定します。
3. ValueパラメータのValueの項目を112pFに変更します。Stringが、パラメータタイプとして選択されていて、ValueのVisibleボックスにチェックが入っていることを確認してください。

4. ダイアログのPropertiesの項目でCommentの項目をクリックし、ドロップダウンリストから=Valueストリングを選択し、Visibleのチェックをはずします。
5. 統合ライブラリからModelsリストに追加されているSIMモデル(CAP)を確認します。Modelsリストでモデル名を選択し、EditをクリックしてSim Model - General/Capacitorダイアログを表示させます。このコンデンサは、モデルファイルを必要とせず、ValueパラメータからのValue を参照します。
6. OKをクリックして、Component Propertiessに戻ります。OK をクリックすると配置モードに戻ります。
7. 抵抗の配置と同じ方法で、2つのコンデンサを配置する位置を決めて配置します。 C2は56pFにValueを変更し、スペースキーを押してシンボルを回転し、配置します。
8. 右クリックかESCを押して、配置モードを抜けます。

電源の追加

シミュレーション時に必要な、デザインに供給する電源を追加します。

1. 最初にVDD電源を配置します。LibrariesパネルでVSRCコンポーネントを検索し、Available LibrariesリストにSimulation Sources.IntLibライブラリを追加します。他のシミュレーションライブラリが、Altium Designerをインストールした場所のLibrary\ Simulationフォルダに保存されていることに注意してください。
電源を配置する際に、TABキーを押して属性を編集します。
2. Component PropertiesダイアログのModelsリストでSIMモデル(VSRC)をクリックし、Editをクリックします。Sim Model - Voltage Source/DC Sourceダイアログで、Model KindがVoltage Sourceに、Model Sub-KindがDC Sourceに設定されていることを確認してください。
3. Parametersタブをクリックし、必要な電圧値を設定します。Valueの項目に5Vと入力し、Component Parameterオプションをチェックします。チェックを入れると、自動でComponent Propertiesダイアログのパラメータに'Value'が作成されます。他の項目は、0に設定しておいてください。
OKをクリックし、すべてのダイアログを閉じます。回路図上でクリックし、この電源を配置します。右クリックかESCを押して、配置モードを抜けます。

4. 次にモデルファイルパラメータのValueを-5Vに設定してVSSの電源を配置します。
5. 最後にSimulation Sources.IntLibからサイン波(Sinusoidal Voltage Source:VSIN)を追加します。 配置する前にTABキーを押して、属性を編集します。この例では、1KHzから50KHzに周波数を変更します。 Component Properties ダイアログで、ModelsリストのSIMモデル(VSIN)をクリックし、Editをクリックします。

Sim Model - Voltage Source / Sinusoidal ダイアログで、Model KindがVoltage Sourceに、Model Sub-KindがSinusoidalに設定されていることを確認してください。

6. Parametersタブをクリックし、必要な電圧値を設定します。Sim Model - Voltage Source / Sinusoidalダイアログ(右図)を参照して、パラメータ値を入力してください。Netlist Templateは、この情報を使用して評価されNetlist Previewに表示されます。
OKをクリックしてすべてのダイログを閉じ、クリックして回路図にこの電源を配置します。右クリックかESCを押して、配置モードを抜けます。
7. 回路図を保存します[ショートカット Ctrl + S]。

パワーポートの追加

メニューバーからパワーポートを配置するには、 View » Toolbars » Utilities を選択して、必要なパワーポートのボタンをクリックしてください図1を参照して、Filter回路図にパワーポートを追加します。
1. Place » Power Port を選択します。TABを押して、Power Portダイアログで属性を設定します。
2. コンポーネントのピンに付けられたポートについては、対応するネット名(例えば、VSS)を入力し、StyleをBarに設定します。OKをクリックし、左クリックかENTERを押して、パワーポートを配置します。配置中にポートを回転するには、スペースバーを使用します。
3. パワーポートの配置を続けます。電源(VIN、VDDやVSS)にパワーポートを追加する際に、StyleをPower Groundに、NetをGNDに設定します。OUTポートは、NetをOUTに、StyleをCircleに設定します。
4. パワーポートを配置し終えたら、右クリックかESCを押して配置モードを解除します。

回路の配線

配線は、回路の様々なコンポーネント間の接続を作成する作業です。回路図の配線を行うには、図1を参照してください。
1. ワイヤ配置モードにするには、Place » Wire [ショートカットP, W]を選択するか、Wiring ToolsツールバーからWireツールをクリックします。

回路図の配線に関する詳細は、チュートリアルTU0117 PCB設計入門 TU0117%20Getting%20Started%20with%20PCB%20Design.PDF を参照してください。

2. ワイヤ配置モードを解除するには、右クリックするかESCを押します。

ネットとネットラベル

シミュレーションを実行する為の最後の操作は、表示したい信号を容易に確認できるように回路上の適切な場所にネットラベルを配置することです。チュートリアルの回路で注目する信号は、INとOUTネットです。OUTネット名がOUTパワーポートから読み込まれている一方、INネットは、ネットラベルで認識されます。図1のように必要なネット上にネットラベルを配置するには:

1. Place » Net Label [ショートカットP, N]を選択し、TABを押してネットラベル名を入力します。クリックしてネットラベルを配置します。
ネットラベルの配置に関する詳細は、チュートリアルTU0117 PCB設計入門 TU0117%20Getting%20Started%20with%20PCB%20Design.PDF を参照してください。
2. 右クリックか、ESCを押すと、ネットラベルの配置モードを抜けます。
3. File » Save [ショートカットF, S]を選択してボードを保存してください。Projectsパネルでプロジェクト名を選択して右クリックし、Save Projectを選択して同様にプロジェクトを保存します。

プロジェクトのコンパイル

プロジェクトのコンパイルは、デザインドキュメントの描画や電気的なルールエラーを確認します。Options for Project ダイアログ(Project » Project Options)のError CheckingConnection Matrixタブで既に設定されているデフォルトのルールを使用します。
1. Filterプロジェクトをコンパイルするには、Project » Compile PCB Projectを選択します。
2. プロジェクトがコンパイルされると、警告やエラーがMessagesパネルに表示されます。エラーがある場合は、回路を見直し、すべての配線や接続が正しいか確認してください。

解析の設定

Altium Designerでは、回路図から直接シミュレーションを実行できます。チュートリアルの次の項目では、Filter回路で作成された出力波形をシミュレートします。

シミュレーションは、Simulateメニューコマンドを使用するか、Mixed Simツールバー(View » Toolbars » Mixed Simを選択して表示される)の適切なボタンをクリックして設定し実行します。

1. 回路図エディタでFilter.SchDocを開いて、Design » Simulate » Mix Sim を選択するか、またはMixed SimツールバーのSetupアイコン をクリックしAnalyses SetupダイアログのGeneral Setupページを表示させます。回路図で警告やエラーがある場合、Messagesパネルに表示されます。Analyses Setupダイアログを閉じ、問題点を修正します。 そして、再度、Setupツールを選択する前にMessagesパネルを閉じます。
すべてのシミュレーションのオプションは、ここで設定します。 シミュレーションの範囲(ネットリストを出力するシート)やシミュレーションが完了する時に自動で表示される信号(Active Signals)、シミュレーションで実行したい解析形式を含みます。これらのオプションは、プロジェクトファイル(保存した時)に保存され、シミュレーションが実行される時に使用されるSPICEネットリスト(*.nsx)の作成に使用されます。
2. 最初に計測したい回路のノードを設定します。Collect Data Forの項目で、リストからNode Voltage, Supply Current, Device Current and Power を選択します。このオプションでは、シミュレーションを実行中に計算したいデータの形式を定義します。 すなわち、各ノードでの電圧、各電源の電流と各デバイス電流・電力のデータが保存されます。SimView SetupをShow Active Signalsに設定します。
3. Available Signalsの項目で、INOUTの信号名をダブルクリックします。各信号をダブルクリックすると、信号名がActive Signalsの項目に移動します。また、信号リスト上でクリックしマウスをドラッグするか、信号をクリックしている間SHIFTCTRLキーを使用して、Available Signalsリストから複数の信号を選択することができます。選択後、> ボタンを使用してActive Signalsリストに信号を移動します。Active Signalsのシミュレーション結果は、シミュレーションが実行された時、自動で波形解析画面に表示されます。

4. (Analyses/Optionsの項目にリスト表示された)各解析形式は、Analyses Setupダイアログの各ページで設定されます。各解析の設定ページをアクティブにするには、解析名をクリックしてください。

過渡/フーリエ解析の設定

過渡/フーリエ解析は、ユーザが指定した時間間隔で過渡出力変数(電圧, 電流または電力)を計算し、オシロスコープに表示されるような出力を作成します。
動作点解析は、Use Initial Conditionsオプションが有効で無い限り、回路のDCバイアスを定義する為に 過渡解析より先に自動で実行されます。もし、このオプションが有効ならば、DCバイアスは回路に定義した初期状態から計算されます。初期状態は、回路図内の各適切なコンポーネントに、または、回路に .IC デバイスを配置して定義することができます。
詳細なヘルプを表示させるには、各解析設定ページでF1を押します。50KHz の入力ソースを6周期表示するには、波形画面で表示が60uになるように設定します。
1. Analyses Setupダイアログ内のTransient/Fourierオプションが有効になっている(チェックが入っている)ことを確認してください。もし、Transient/Fourier Analysis Setupページが自動で表示されない場合、Analyses/Optionsリスト内のTransient/Fourier Analysisをクリックしてください。

2. Use Transient Defaultsオプションが無効になっていることを確認してください。 これで過渡解析パラメータを変更することができます。
3. シミュレーション画面を60uに指定するには、Transient Stop Timeを60uに設定します。
4. Transient Step Timeの項目を100nに設定します。 これは、シミュレーションが100nsの地点ごとに計算されることを表します。
5. シミュレーション中の実際のタイムステップは、収束と必要な精度を満たす為に自動で変更されます。Maximum Stepの項目は、タイムステップサイズの変化を制限しますので、Transient Max Step Timeを200nに設定します。

AC小信号解析の設定

AC解析は、周波数関数として小信号のAC出力変数を計算し、回路の周波数応答を示す出力を作成します。AC小信号解析で要求される出力は、通常、伝達関数(例えば、電圧利得)です。

回路図には、SIMモデルでAC Magnitudeパラメータの値が設定されたACソースが少なくとも1つ必要です。AC Magnitudeの値、周波数と振幅についてはサイン波ソース(VSIN)のパラメータで既に設定しています。詳細については、電源ソースの設定 を参照してください。
1. Analyses Setupダイアログで、AC Small Signal Analysisオプションが有効になっていることを確認してください。
2. 上図のようにパラメータ値を入力します。
3. この解析が実行されると、回路のDCバイアスを決定する為に動作点解析が先に実行されます。その後、信号ソースは振幅が固定された正弦波ジェネレーターに置き換えられ、指定した周波数範囲内で、Test PointsSweep Typeの値を元に解析されます。

シミュレーションの実行

これで設定を有効にした解析を実行する準備ができました。
今後は、毎回Analyses Setupダイアログで入力をせずに、Mixed SimツールバーのRun Mixed Signal Simulationボタン をクリックするだけでシミュレーションを実行できることに注意してください。
1. シミュレーションを実行するには、Analyses Setupダイアログの下部にあるOKボタンをクリックします。
SPICEネットリストの生成、または実際のシミュレーション過程中に作成された警告やエラーは、Messagesパネルに表示されます。次に進む前にエラーを修正してください。
2. 回路にエラーが無ければSPICEネットリスト(*.nsx)が作成されシミュレータに渡されます。ネットリストは、シミュレーションが実行される度に再生成されることに注意してください。
3. シミュレーションが開始され、シミュレーションデータファイル(*.sdf)が開きます。各解析の結果は、SimDataエディタの波形解析画面で個別のチャートとして表示されます。 動作点解析は、回路のDCバイアスを定義する為に最初に実行されます。 Waveform Analysis window:SimData Editor Circuit simulation:SimData Editor
4. シミュレーションが終了すると、以下の図のような出力を確認できるはずです。

AC小信号解析波形

動作点解析 過渡解析波形

過渡解析波形

波形アナライザとSim Dataパネルの使用方法の詳細については、TU0113 シグナルインティグリティ解析の実行 TU0113%20Performing%20Signal%20Integrity%20Analyses.pdf の内の Using the Waveform Analysis Window を参照してください。 波形表示とパネルの操作は両方のツールで同じ画面を使用します。

ボードプロットの作成


ボードプロットは、周波数の対数関数として 2つの曲線(利得と位相の対数)で構成されています。Y軸はデシベル(dB)のゲインと、位相をリニアにプロットし、X軸はLogスケールでいくつかの周期を持つチャートが作成されます。各周期は、周波数の10の因数を表します。このボードプロットは、Edit Waveformダイアログで利用できるWaveform機能を使用して作成することができます。
1. 波形解析画面のAC Analysisタブに、dB(in), dB(out), PHASE(in),PHASE(out)を表示します。
2. 波形解析画面で、ネットin をクリックします。 選択したネットを右クリックし、Edit Wave(または、Wave » Edit Wave )を選択します。Edit Waveformダイアログが表示されます。選択した波形の形式がExpressionの項目に表示されます。
3. Complex Functionsリスト(例えば、Magnitude (dB))から機能を選択します。プロット上でdB(net_name)の波形(例えば、dB(in))を見るには、Createをクリックします。
4. dB(out)を作成するには、プロット上で右クリックしAdd Wave to Plotを選択します。Edit Waveformダイアログと同じ方法で設定できるAdd Wave to Plotダイアログが表示されます。
5. 2番目のプロットにPHASE(in)とPHASE(out)を作成するには、4.の操作を繰り返してください(Add Wave to PlotダイアログのComplex Functionsの項目は、Phase (Deg)を選択します)。

6. これらの波形は必要に応じ、Edit WaveformダイアログのAdd to new Y axisを選択することで、異なるY軸を追加表示させることができます。追加したY軸を削除する場合、この軸にプロットされたすべての波形と波形に付けられた計測カーソルも削除されますので、注意してください。Undo機能はありません。新たにY軸を追加した場合、右側に表示されます。

計測カーソルの使用

計測カーソルを使用して、3dBの位置を指定してみます。
1. DB(out)のネット名をクリックして、波形解析画面の波形を選択します。
2. 右クリックし、Cursor A(または、Wave » Cursor Aを選択します)を選択します。マーカーをドラッグして、カーソルAをローパスの部分に移動します。
3. 右クリックし、Cursor B(または、Wave » Cursor Bを選択します)を選択します。Sim DataパネルのMeasurementの項目でB-A = -3と表示される位置になるようにカーソルBを移動します。

4. Sim DataパネルのMeasurement Cursorsの項目のカーソルBのX値を確認してください。 3dB point = 20kHzであることが分かります。

5. カーソルをクリアするには、カーソルマーカーを選択し、右クリックしてCursor Offを選択します。

パラメータスイープ解析の実行

いくつか解析を設定し、実行しましたが、次に周波数応答でいくつかのコンデンサ/抵抗の値を変更した結果を見るためにパラメータスイープを設定してみます。
パラメータスイープ解析は、定義した指定した範囲でデバイスの値をスイープさせます。パラメータスイープ解析を実行するには、AC, DCまたは過渡解析のどれかを有効にする必要があります。 有効にした解析は、パラメータスイープして複数回シミュレータが実行されます。
この解析は、基準のコンポーネントの値とモデルパラメータを変更することができますが、サブサーキットデータは、解析中は変更できません。
1. Filter.SchDocタブをクリックして、デザイン画面で回路図を利用できるようにします。Design » Simulate » Mixed Sim を選択します。Analyses SetupダイアログのGeneral SetupページのSIMView SetupでShow Active Signals が選択されていることを確認してください。
2. Analyses SetupダイアログのAnalyses/Optionsの項目でParameter Sweepをクリックして、この解析形式を有効(Enabledにチェックを入れます)にします。
3. Primary Sweep Variableの項目でスイープさせる為のパラメータを入力します。この例では、プライマリ スイープパラメータをドロップダウンリストから選択してC2[capacitance]にします。
4. Primary Start Valueを20pに、Primary Stop Valueを-20pに設定して、スイープの値の範囲を定義します。Primary Step Valueを-10pに設定して、増加ステップを定義します。
5. Primary Sweep TypeオプションをRelative Valuesに設定します。Primary Start Value, Primary Stop Value, Primary Step Valueの項目で入力した値は、パラメータの既存またはデフォルトの値に追加されます。
6. Enable Secondaryをクリックして、Secondary Sweep Valuesを追加します。セカンダリ パラメータを定義した場合、プライマリ パラメータは、セカンダリ パラメータの各値でスイープされます。
Secondary Start Valueを-80pに、Secondary Stop Value を80p にしてC1[capacitance]のセカンダリ スイープを設定します。Primary Step Valueを80pに設定し、増加ステップを定義します。Secondary Sweep TypeをRelative Valuesに設定します。

7. OKボタンをクリックして、シミュレーションを実行します。各プライマリ スイープは、波形解析画面のAC AnalysisTransient Analysisタブ内の新しいプロットに<net_name_p<sweep_number>の表記(例えば、out_p01)で波形として表示されます。
詳細情報を表示するには(例えば、out_p01をクリックすると、プロットの下にスイープ情報が表示されます)、スイープ パラメータ名をクリックしてください。

以下の図で、このパラメータ スイープによってカットオフ周波数の周りの周波数応答を大きく変化させることが判ります。

AC Analysisタブでのパラメータスイープ結果

Transient Analysisタブでのパラメータスイープ結果

アドバンスオプションの使用

Analyses SetupダイアログのAdvanced Optionsのページは、エラーの許容度や繰り返し制限のようなシミュレーション計算を達成する為に設定できるSPICE内部のオプションのリストになっています。

SPICEオプションの値を変更するには(例えば、ITL1の繰り返しの値):
1. 変数(例えば、ITL1)を選択します。Valueの項目に新しい値を入力するか、表示される矢印スクロールをクリックして値を選択します。
2. Enterを押すか、他の項目をクリックすると、デフォルト(Def)オプションが無効になります。
また、このページから異なる積分方法を選択することができます。 例えば、回路デザインに予期しない高周波の発振がある場合、標準的な積分法のTrapezoidal(台形法)からGear(ギヤ法)へ変更することができます。台形法は、比較的早く正確ですが、ある条件下で振動する傾向があります。理論上、高次ギヤ法の方が、結果はより正確ですがシミュレーション時間が長くなる欠点があります。

シミュレーション用のSPICEネットリストの使用

回路図からネットリスト(.nsx) を作成するには、回路図がアクティブドキュメントであることを確認してください。
Design » Netlist For Project » XSpiceを選択するか、またはMixed SimツールバーのGenerate XSpice Netlistアイコン をクリックしてください。他の回路図キャプチャツールと組み合わせてAltium Designerシミュレータが使用できるように、SPICEネットリストから直接、シミュレーションを実行することができます。

これを行うには:
1. プロジェクトファイル(.PrjPcb)にネットリストを保存します。これでシミュレーションセッション中の設定情報を保存することができます。設定情報は、回路図を含むプロジェクトと同じ方法でプロジェクトファイルに保存されます。プロジェクトファイルは、P-CADから最初にシミュレーションを実行する時に自動で追加されることに注意してください。もし、ネットリストがフリードキュメントとして開いた場合、設定情報は、Altium Designerに保存されません。
2. Altium Designerシミュレーションエンジンは、設定情報と同様にコンポーネント情報、デザイン接続、モデルデータを含んだネットリストが必要です。もし、ネットリストにシミュレーション設定情報が無い場合、Simulate » Setupを選択すると新しいネットリストが<original filename>_tmp.nsxと言う名称で作成されます。 このファイルは、元の.nsxファイルからのネットリスト情報とプロジェクトファイルからの設定情報を含みます。
もし、ネットリスト中にシミュレーション情報がある場合、シミュレーションはネットリストを変更しないで直接、実行されます。これは、ネットリストで直接、設定を変更したいユーザには役立ちます。もし、ネットリストに設定情報が既に含まれている場合、Analyses Setupダイアログを使用して、設定情報を追加または設定できないことに注意してください。
もし、ネットリストにシミュレーション設定情報が無く、プロジェクトに回路図ドキュメントがある場合、ネットリストは、回路図ドキュメントとプロジェクトの設定情報から再生成されます。これは、ネットリストから設定情報を削除してシミュレーションを行おうとした場合にのみ発生します。
3. 一度、設定情報が無いネットリストをプロジェクトに追加すれば、Simulate " Setupを選択して解析を設定することができます。
4. シミュレーションを実行するには、メニューからSimulate " Runを選択します。シミュレーション波形は、.sdfドキュメントに表示されます。
5. 次回シミュレーションを実行する時に上書きされないように、ネットリストファイルの名称を変更してください。

シミュレーションの詳細については、TR0113 シミュレーションモデルと解析のリファレンス TR0113%20Simulation%20Models%20and%20Analyses%20Reference.pdfまたは TR0117 デジタルSimCodeリファレンス TR0117%20Digital%20SimCode%20Reference.pdfを参照してください。

Labels
  • None