Altium Wiki

Information and resources for electronic product designers

Skip to end of metadata
Go to start of metadata

このチュートリアル では、回路図エディタからデザイン情報を転送する前の準備として必要に応じて行う、ボードシェープの定義や作画シートの設定、レイヤの設定、キープアウトの設定方法などを紹介します。

Tutorial TU0110 (v1.7) May 26, 2008

このチュートリアルでは、PCB設計を開始する際に必要な項目である、ボードシェープの作成や修正、シートテンプレートの設定やキープアウトの設定方法を紹介します。また、コンポーネントの配置や配線を行う前に必要なPCBのワークスペースでのグリッドやレイヤスタック、デザインルールの設定を簡単に紹介します。

ボードシェープの作成と修正

ボードシェープは、PCBエディタにおいて境界や範囲を指定します。ボードシェープは、基板外形とも呼ばれ、基本的には閉じた多角形です。新規PCBドキュメントを作成すると、デフォルトでは、グリッドが表示された黒いエリアとして表示されます。Altium Designerでは、スプリットパワープレーンを使用する際、基板端のプルバック(外形からの逃げ)の範囲を決定するため、およびデザインデータを他のツールへ出力する際に基板のサイズを計算するために使用されます。
メニューからFile » New » PCBを選択し、新規PCBファイルを作成すると、ボードシェープはデフォルトで6000 x 4000 milのサイズになります。シェープは、Design » Board Shapeのメニューにあるコマンドを使うことでサイズや形状の変更が可能です。PCBテンプレートやPCB Board Wizardを使ってPCBドキュメントを作成すると、ボードシェープは適切なサイズで作成されます。

ボードシェープのインポート

また、PCBエディタのメカニカルレイヤに設定したオブジェクトと同じ形状をボードシェープに設定することができます。この機能と機構系CADからのDWGやDXFデータをインポートする機能を組み合わせ、機構系CADからAltium Designerへ必要なボードシェープを転送することができます。
新規に作成したPCBにDXF/DWGファイルをインポートするには:
1. File » New » PCBを選択します。
2. 新規PCBファイルがオープンします。シート上の黒い領域がボードシェープを表しています。ここでは、AutoCADで.DXF (または .DWG)で作成した機構系ファイルをボードシェープとして再定義します。AutoCADの2.5から14までのすべてのバージョンをサポートしています。インポートする形状は閉じた形で、内部のカットアウトはサポートしていないので注意してください。
3. File » Import を選択します。Import File ダイアログが表示されます。
4. Files of type(ファイルの種類)を変更し、ファイルフォーマットをAutoCAD (.DXF,DWG) に変更します。
5. インポートしたいファイルがあるフォルダへ移動し、ファイルを選択し、Open(開く)をクリックします。
6. Import from AutoCAD ダイアログが表示され、AutoCADのレイヤをAltium Designer のどのレイヤにインポートするか指定することができます。例えば、(左側の)AutoCADの '0' レイヤを(ドロップダウンリストから選択し)Altium DesignerのMechanical layer 4に割り当てることができます。
7. その他のインポートオプションが正しく設定されていることを確認し、OKボタンをクリックします。ボード外形を構成するトラックセグメントが所定のレイヤに表示されます。例えば、メカニカルレイヤ4です。インポートされたデータが現在のPCBワークスペースよりも大きい場合は、自動的に縮小されます。
これで閉じた領域がメカニカルレイヤに読み込まれ、これらのオブジェクトがボードシェープを定義するために使用できます。

選択したオブジェクトからボードシェープを定義

先に記載したように、ラインやアークを使って閉じた領域をメカニカルレイヤ(あるいは、他のレイヤ)に設定することでボードシェープを定義することができます。
選択済みのオブジェクトからボードシェープを定義するには:
1. ボードシェープとして定義したい閉じた形状をメカニカルレイヤ上に作成します。形状を作成するには、Place » LinePlace » Arcなどの配置コマンドを使用します。
2. 新しいボードシェープの形状だけを選択します。カレントレイヤのすべてのオブジェクトを選択するには、Edit » Select » All on Layer コマンド[ショートカットS, Y]を実行します。.
3. Design » Board Shape » Define from Selected Objectsを実行すると、ボードシェープが選択している領域に適した形で再表示されます。

ボードシェープの修正

ボードシェープは、再定義(再作画)や頂点を移動することで変更することが可能です。ボードシェープは、その周囲に配置されているオブジェクトと一緒にあるいは、それとは別に移動することができます。
ボードシェープの色は、Design » Board Layers & Colors(ショートカットキー L)を実行し、View ConfigurationsダイアログのSystem ColorsにあるBoard Area Colorで新しい色を選択することで変更できます。.

ボードシェープの設定

既存のボードシェープとは関係なく、何も無いのと同じ状態からボードシェープを作画することができます。ボードシェープ全体を変更する場合は、次の手順を実行してください。
1. Design » Board Shape » Redefine Board Shapeを実行します。カーソルが十字に変化し、バックグランドが黒に、元のボードシェープが緑色で表示されます。
2. 頂点でクリック(あるいは、ENTERキーを押し)新しいボードシェープを作成します。ボードシェープの定義中にSPACEBARを押すと、コーナースタイルが変化します。デザインウィンドウ下側のステータスバーでコーナーを配置する際、座標値を確認することができます。
3. ボードシェープを定義したら、終了するには右クリックか、ESCキーを押します。Altium Designerでは、最初に配置したポイントから最後に配置したポイントを自動的に結び、形を作成するので、完全に閉じた形状を作成する必要はありません。
新たに作成された基板外形の内側にはグリッドが表示されます。

座標指定による形状の定義

正確な寸法に基づく形を定義するには、マウスの代わりにJump Locationのショートカットキーを使用することができます。これを行うには:
1. 原点をPCBの左下側に設定(Edit » Origin » Set)します。
2. Design » Board Shape » Redefine Board Shapeを実行し、マウスを放します。
3. Jキーを押し、Jumpサブメニューを表示します。Oキーを押し、先程設定した原点へジャンプします。ENTERキーを押し、新しいボードシェープの最初の頂点を定義します。
4. J, L キーを押し、Jump to Locationダイアログを表実します。X-Locationの欄がアクティブになっていますので、次の頂点を設定するX座標の値を入力します。(このときマウスには触れないでください)
5. TAB キーを押し、 Jump to LocationダイアログのY-Location欄に移動し、Y座標の値を入力します。
6. 値を入力したらENTERキーを押し、ダイアログを閉じます。カーソルは、入力した位置に移動します。マウスには触れず再度ENTERキーを押し、この頂点を確定します。
7. 再度、J, L キーを押し、Jump to Locationダイアログを表示します。次の頂点のX座標を入力し、TABキーを押し、Y座標を入力し、ENTERキーを押します。この頂点を定義するためENTERキーを押します。
8. すべての頂点が定義され、座標値が原点(0, 0)に戻るまで、このプロセスを繰り返し行います。このときマウスには触れずにENTERキーを押すようにしてください。

3Dを使ったボード外形の再定義

この機能は、インポートされた3D STEPモデルの表面データを使って、ボードの外形を再定義します複雑なボード形状も素早く生成することができ、電子系と機械系の設計エリアの統合を助長します。これを行うには:
1. Place » 3D Body [ショートカットP, B]を選択して、STEPモデル (*.step or *.stp) をインポート します。.
2. Design » Board Shape » Define from 3D body [ショートカットD, S, S]を選択します。このコマンドを使う前に、ワークスペース内に3Dのモデルを保持していなくてはなりません。また、3Dモードにしておく [ショートカット 3]必要があります。 .
3. 3Dのモデルをクリックして選択すると、カーソルが十字形に変わります。求める表面データを選択してください。
4. STEPモデルの平坦な表面データをクリックすると、それが新しいボードの外形になります。モデルの周りにカーソルを動かし、表面データに行き当たると、残りのモデルが透明になって、そのモデルを浮かび上がらせます。
注記 :XYプレーンにそろえられている表面データだけが、ボードの外形に使えますXYプレーンへの調整が必要なモデル表面のデータを選択すると、Confirmationダイアログを通して、作業の続行前に表面データをそろえるように求められます。このダイアログでは、選択した表面データを使って、ボードのトップ、またはボトムの表面に関するモデルを配置することもできます。これが意味するのは、モデルの垂直な位置を同時に設定できるということです。モデルをそろえた後、再び、Design » Board Shape » Define from 3D Bodyを選択する必要があります。ボードの外形が再定義されたら、3Dのモデルを見えないようにするオプションが与えられます。

ボードシェープの頂点移動

サイズ変更などでボードシェープを修正する場合、ボード全体を定義し直すより、頂点を移動すると作業が簡単に行える場合があります。
1. Design » Board Shape » Move Board Verticesを実行します。カーソルが大きな十字に変更し、ボード外形に編集用ハンドルが表示され、頂点の選択と移動が行えます。
2. 移動したい頂点でクリックし、新しい位置へ移動します。
3. ラインセグメント上の小さな十字のハンドルを移動することで、新たな頂点が追加できます。
4. 右クリックかESCキーを押し、ボード外形を終了します。

ボードシェープの移動

Move Board Shapeコマンドを使って、ボードシェープだけを移動することができます。既に配置されているコンポーネントや接続は影響を受けません。
デザインシートと関連してボードシェープの位置を変える必要がある場合、Board Optionsダイアログ(Design » Board Options)のDisplay Sheetオプションを有効にして、シートを表示するようにしてください。Altium Designerでのシートの使用方法に関する詳細は、このチュートリアルの PCBシートの使用法 を参照してください。

ボードシェープだけを移動するには:
1. Design » Board Shape » Move Board Shape を実行すると、ボード外形がカーソルのところにフローティングの状態で表示されます。
2. ボードシェープを移動し、新しい位置でクリックし、配置します。

ボードシェープを既に配置されているすべてのコンポーネントや接続と共に移動するには:
1. すべてを選択(Ctrl + A)するか、あるいは移動したいオブジェクトを、ボードシェープを含めてセレクトします。
2. 選択したオブジェクト上で直接クリックすると、カーソルが大きな十字に変化します。選択した領域がボックス表示されますので、シート上の新しい位置へドラッグします。
あるいは適切なオブジェクトを選択し、Edit » Move » Move Selectionを実行します。移動の際の基準点を設定するためにクリックし、セレクションを移動し、配置するところでクリックします。

PCBシートの使用法

PCBエディタでのシートは、印刷用ページを表現するための特別な作画機能で、Board Optionsダイアログ を使ってコントロールします。新規PCBファイルを作成すると、デフォルトのシートがサイズ10000 x 8000milで自動的に作成されます。最初は表示されていませんが、表示すると、ボードアウトラインのバックに白色で表示されます。
Altium Designerで用意されているPCBのサンプルファイル(Altium DesignerがインストールされているExamplesフォルダ)のほとんどは、ボーダー、グリッドリファレンス、タイトルブロックがメカニカルレイヤのMechanical16に作画された白いシートの上にボードが表示されます。

メカニカルレイヤにオブジェクトを配置し、これらのレイヤをシートにリンクすることで、独自のテンプレートが作成でき、表示・非表示が切り替えられます。既存のPCBテンプレート(Altium DesignerがインストールされているTemplatesフォルダ)からコピーすることで、ボーダー、グリッド、タイトルブロックを含んだシートをPCBファイルに追加できます。
シートのサイズと位置はBoard Options ダイアログのSize及びLocation で、手動で変更できます。また、シートは、リンクしているメカニカルレイヤに配置されているオブジェクトにあわせ、自動的にサイズが変更されます。リンクしているメカニカルレイヤの内容が変化した場合は、View » Fit Sheetコマンドか、Design » Board Shape » Auto-Position Sheetコマンドを実行すると再計算が行われます。

シートを表示

PCBエディタでシートを表示するには:
1. Design » Board Options を実行し、Board OptionsダイアログのSheet Position セクションにあるDisplay Sheetオプションを有効にします。
このDisplay Sheetオプションを無効にすると、シートはいつでも非表示にすることができます。リンクしているすべてのメカニカルレイヤも非表示になります。OKをクリックします。
2. シートを表示するには、View » Fit Sheet を選択 [ショートカットV, H (View) またはショートカット Z, S (Zoom)]します。ボードシェープの周囲に、デフォルトでは、サイズ10000 x 8000milの白いスペースが表示されます。

3. シートの色は、Design » Board Layers & Colors [ショートカット L] を実行し、View ConfigurationsダイアログのSystem Colorsにある Sheet Area Color および Sheet Line Color で新しい色を選択することで変更できます。作成したカスタムビューをビュー設定として保存し、繰り返し再利用することができます。
4. タイトルブロックやボーダー、グリッドなどの図面用テンプレートがある場合は、メカニカルレイヤにインポートし、View Configurationsダイアログで、これらのレイヤをシートにリンクします。それからDesign » Board Shape » Auto-Position Sheet を実行すると、シートサイズが自動的にメカニカルレイヤに配置されているオブジェクトを囲んだ大きさになります。

既存のPCBテンプレートからシートを定義

ボーダー、グリッド、タイトルブロックを含んだシートはAltium Designerで用意されているPCBテンプレートドキュメントからコピーし、作成したPCBドキュメントに貼り付けることで、いつでも定義することができます。Altium Designerの Templates フォルダには、定義済みのPCBテンプレートがあります。シートサイズのテンプレートは、A.pcbdoc から A0.pcbdocまであります。
1. 新たにシートサイズを追加したいPCBドキュメントをオープンします。既存のデフォルト・シートサイズを表示し、新しいシートを配置し易くするため、V, H (view sheet) あるいは、Z, S (zoom sheet)を実行します。
2. 既存のPCBテンプレートからPCB上のすべてのオブジェクトが収まるようなシートサイズを持ったもの(例えば「A2.pcbdoc」)をオープンします。これを行うには、FilesパネルのNew from Template領域からPCB Templatesをクリックします。このオプションが表示されていない場合は、その他のオプションを折りたたむためにFilesパネルの各セクションの右側にある上向きの矢印をクリックします。PCB TemplatesをクリックするとChoose existing Documentダイアログが表示されます。
PCBの Templates フォルダに移動し、(例えば)「A2.pcbdoc」 を選択し、Openをクリックします。テンプレートが新しいデザインウィンドウに新規PCBデザインドキュメント、「PCB1.PcbDoc」としてオープンされます。
3. テンプレートファイルのすべての内容をセレクト(Ctrl + A)し、クリップボードにコピー(Ctrl + C) します。もう一度クリックして、コピーの参照ポイントを設定します。保存しないで、「Pcb1.pcbdoc」を閉じます
4. デザインウィンドウ上側のタブをクリックし、元のPCBドキュメントに切替えます。CTRL + Vで、新規のシートを既存のPCBにペーストします。テンプレートの内容がMechanical16レイヤにペーストされます。
5. 次にMechanical16レイヤを表示し、シートとリンクします。Design » Board Layers & Colors を選択して View Configurations ダイアログを表示します。Mechanical16用にShow, Enable, Linked to Sheetの各オプションを有効にします。

例えば、キープアウト領域をKeepoutレイヤに定義するなど、特定レイヤのオブジェクトに関する操作を行う場合は、その他のレイヤを非表示にするシングルレイヤ・モードに切替えることができます。SHIFT + Sでシングルレイヤモードに切り替わりますもう一度SHIFT + Sを押すとすべてのレイヤが元通りすべて表示されます。
6. Single Layer Mode にチェックを入れるとView Configurations ダイアログの View Options ページのシングルレイヤ・モードが有効な場合でも常にシートが表示されます。OKボタンをクリックし、ダイアログを閉じます。
7. 最後にシートボーダーを含む、シートのサイズを変更することができます。V, H (view sheet) あるいは、Z, S (zoom sheet)を実行します。Linked to sheetに設定したレイヤに配置されているオブジェクトの範囲にシートが設定されます。この場合、Mechanical16レイヤに定義されているシートボーダーを含んだ領域になります。
8. Mechanical16に切替え、必要なオブジェクトを追加したり、不要なものを削除することで、例えばタイトルブロックの編集が可能です。シートは、もう一度V, H あるいは、Z, Sを実行すると、すべてのオブジェクトを含んだサイズに変更されます。作成したカスタムビューをビュー設定として保存し、繰り返し再利用することができます。

キープアウト

ボードシェープと同じ様に、基板の周囲に配置用・配線用に境界を定義する必要があります。これはKeepoutレイヤにオブジェクトを配置することで行います。このレイヤに配置したオブジェクトは、コンポーネントと配線がここから外側へ行かないように定義するものです。通常、基板端に近いところにコンポーネントや配線が行われない様、キープアウトはボードシェープの少し内側に定義します。また、取り付けネジなどの機構的なオブジェクトや実装で要求される条件を満たすため、配線やコンポーネント用のキープアウトを定義することができます。
キープアウトの境界は、ラインやアーク、フィルなどのオブジェクトで定義できます。
新規PCBを作成する際に、AT やEurocardなどのテンプレートを使用した場合、キープアウトが自動的に含まれます。A2.pcbdocなどのシートサイズのテンプレートにはキープアウトは含まれていません。

全レイヤに対するキープアウト定義

新規PCBを次の方法で作成した場合は、自身でキープアウトを作成する必要があります:

  • メニューからFile » New » PCB を実行するか、あるいはFilesパネルのNewセクションからPCB File inをクリックした場合
  • Files パネルのNew from TemplateセクションからPCB Templatesをクリックし、PCB シートサイズテンプレート(例えば、A2.pcbdoc)を選んだ場合

これらのコマンドでは、デフォルトのボードシェープが作成されるだけなので、ボードシェープを定義した後、キープアウトを追加する必要があります。
すべての信号層に対して適用されるキープアウトを定義するには:
1. Keep-Outレイヤタブでクリックします。すべての層に適用されるのは、このレイヤだけになります。
キープアウトを定義する際には、配置モードが利用できます。
SHIFT+ SPACEBAR でモードが切り替わります。
SPACEBARでStartと Endモードが切り替わります
BACKSPACEで直前に配置したトラックセグメントを削除できます。
TABキーでLine Constraints dialogダイアログが表示され、属性変更ができます。
2. Place » Lineを実行します。キープアウトの頂点でクリックし、閉じた形状を定義します。
3. キープアウトトラックの配置が終了すれば、右クリックかESCキーを押し、ラインの配置モードを終了します。

レイヤ別のキープアウト定義

各信号層別にキープアウトを定義することができます。これを行うには:
1. 必要なレイヤのレイヤタブをクリックします。
2. (Place » Keepoutのサブメニューを使って)レイヤ別のキープアウトオブジェクトを配置し、境界、あるいはキープアウトの領域を定義します。レイヤ別のキープアウトは、標準的なオブジェクトにキープアウト属性を有効にしたものです。これらのオブジェクトは、そのレイヤと同じ色で表示され、周囲はキープアウトの色で表示されます。レイヤ別のキープアウトは、ガーバーやODB++出力には含まれません。

PCBワークスペースの設定

これでボードシェープ、シート、キープアウト領域が作成されました。次にグリッド、レイヤ、PCBエディタのデザインルールの設定を簡単に紹介します。これで基板設計の準備が整います。

グリッド

基板上でコンポーネントの配置する前に、適切な配置グリッドが設定されているか確認してください。PCBエディタのワークスペース上のコンポーネント以外のすべてのオブジェクトはSnap Grid(スナップグリッド)に従って配置されます。このグリッドは、使用する配線テクノロジに適した値にする必要があります。

グリッドを設定するには:
1. Design » Board Options [ショートカットDO]を選択してBoard Optionsダイアログを開いてください。.
2. リストを使うか、値を直接入力し、Snap GridComponent Gridの値を設定します。スナップグリッドの値は、通常、コンポーネントのピン間隔の倍数か約数に設定します。 例えば、ピン間が100milのコンポーネントの間を配線する場合は、25milのスナップグリッドが使用されます。コンポーネントグリッドは、コンポーネントの配置だけに適用されます。
3. 注記 :このダイアログでは、Electrical Gridの設定も行うことができます。エレクトリカルグリッドは、電気的なオブジェクトを配置する際に適用され、設定したグリッドの範囲内にカーソルが近づくとスナップグリッドを無視し、電気的なオブジェクトに引き込まれます。
4. また、2つの異なる表示用グリッドも設定できます。これらは表示用だけに使用されます。OKボタンをクリックし、ダイアログを閉じます。
5. グリッドを変更したり、無効にしたりするには、ショートカットキーが使えます。Gでスナップグリッドのメニューが現れ、SHIFT + Eで、エレクトリカルグリッドのオンオフが切り替わります。

ビュー設定におけるレイヤスタックとその他の非信号層の定義

PCB エディタは、View Configurations ダイアログで使用可能なビュー設定と呼ばれるレイヤ、サーフェス、色、表示およびその他の項目の定義と共に、PCB のデザインを 2D モードまたは 3D モードで表示することができます。2D または 3D のビュー設定を、繰り返し使用するために保存することができます。メインメニューからDesign » Board Layers & Colors [ショートカットL]を選択して、View Configurationsダイアログを開いてください。.
2D モデルはマルチレイヤ環境であり、コンポーネントの配置、配線、接続など、通常の PCB デザイン作業に適しています。3D モデルは、デザインを内部および外部からフル 3D モデルとして調べ、部品の干渉や製造前の外観をチェックするのに便利です。2D モードと 3D モードを切り替えるには、File » Switch To 3D または File » Switch To 2D(ショートカット 2(2D)、3(3D))を選択します。. PCB エディタのワークスペースの下部には一連のレイヤタブがあります。編集作業のほとんどは特定のレイヤに対して実行されます。

PCBエディタには、3種類のレイヤがあります:

  • エレクトリカルレイヤ ここには32の信号層と16のプレーン層が含まれます。デザインのエレクトリカルレイヤは、Layer Stack Manager ダイアログ(Design » Layer Stack Manager)で追加・削除が行えます。詳細は、次のセクション レイヤスタックマネージャの使用法 を参照してください。
  • メカニカルレイヤ - 基板外形の定義や寸法線、組立て図の作成など、デザインの必要に応じて、汎用のレイヤとして16のメカニカルレイヤが用意されています。これらのレイヤは、ガーバー出力生成時に含めることができます。View Configurations ダイアログで、メカニカルレイヤの追加、削除、名前の設定を行うことができます。作成したカスタムビューをビュー設定として保存し、繰り返し再利用することができます。Only show enabled mechanical layersオプションを有効にすると、有効なレイヤだけがリストに表示されます。
    メカニカルレイヤを使用できるようにするには、有効にする必要があります。Enable 欄のオプションを有効にすることで、そのメカニカルレイヤが、明確に PCB ファイルのデータベースの一部になります。有効なメカニカルレイヤだけがデータベースの一部になることができます。デザインオブジェクトがあるメカニカルレイヤを無効にすることはできません。メカニカルレイヤ名を編集するには、レイヤ名をクリックし、F2を押します。
    Showオプションでメカニカルレイヤの表示をコントロールできます。Display In Single Layer Mode オプションをオンにすると、シングルレイヤモードが使用された(SHIFT + S)ときにそのレイヤが表示されます。
    Linked To Sheetオプションを有効にするとそのメカニカルレイヤをPCBのシートに関連付けすることができます。リンクされたメカニカルレイヤは、(Board Optionsダイアログの)Display Sheetオプションで非表示にすることができます。これらはまた、Board ShapeサブメニューのAuto-position sheetが選択された場合、シートの範囲を自動的に決定するのに使用されます。
  • 特別レイヤ - ここにはトップ、ボトムのシルクスクリーンレイヤ、ソルダ及び、ペーストマスクレイヤ、ドリルレイヤ、キープアウトレイヤ(電気的な境界を定義するのに使用)、マルチレイヤ(マルチレイヤパッドやビアに使用)、コネクションレイヤ、DRCエラーレイヤ、グリッドレイヤ、ホールレイヤが含まれます。

レイヤスタックマネージャの使用法

簡単なデザインは、片面や両面基板で配線が行えます。より複雑なデザインの場合は、Layer Stack Manager ダイアログを使ってレイヤを追加することができます。シグナル、インターナルプレーン、絶縁(サブストレート)層の3種類がレイヤスタックに追加できます。伝送線路解析を実行する場合、これらは適切な値を設定する必要があります。
1. Layer Stack ManagerダイアログでDesign » Layer Stack Manager [ショートカットDK] を選択します。

2. 必要に応じ、既存のレイヤをクリックして選択し、Add LayerAdd Planeボタンをクリックすることで、信号層、プレーン層をデザインに追加することができます。新しいレイヤやプレーンは、現在選択しているレイヤの下に追加されます。必要なレイヤを追加すれば、Move Up及びMove Downボタンで、レイヤスタックを設定することができます。
3. レイヤの属性を編集するには、レイヤ名の上でダブルクリックを行います。(あるいは、レイヤをセレクトし、Propertiesボタンを押します。)レイヤの属性、銅箔の厚みや絶縁体の属性などは、シグナルインティグリティで使用されます。
4. スタックアップスタイルでは、レイヤスタックでの絶縁レイヤの順序を参照します。デフォルトでは、Layer Pairs、Internal Layer Pairs、Build-Up の3つのスタックアップスタイルがサポートされています。スタックアップスタイルを変更することで、レイヤスタックにおけるコアとプリプレグの構成が変更されます。ダイアログ右上にあるドロップダウンリストから適切なスタックアップスタイル選択してください。ブラインドビアやベリードビアを使用する場合やシグナルインティグリティ解析を詳しく行う場合、スタックアップスタイルの定義は重要です。ブラインドビアやベリードビアを使用する場合は、Configure Drill Pairsボタンで、ドリルペアを定義する必要があります。
5. OKボタンをクリックし、ダイアログを閉じます。

デザインルールの設定

これでデザインルールを設定する準備ができました。PCBエディタでデザインルールを設定するには、PCB Rules and Constraints Editor ダイアログ(Design » Rules)を使って行います。

あるいは、Design Rule Wizard(Design » Rule Wizard)を使って始めることができます。この段階で、完璧なデザインルールを作成するのは、エラーが発生した時にオンラインDRC(Design Rules Check)で、すぐにエラー箇所を見つけるためではなく、最初に配置を行う際にエラーの発生を防ぐためです。オートルーターも、その実行中に設定したデザインルールを参照します。

一度ルールを作成すれば、配線幅やコンポーンネント間の最小クリアランスなどのルールは、良く似たプロジェクトで再利用することができます。個別のデザインルールをインポート・エクスポートするは、PCB Rules and Constraints Editor ダイアログのDesign Ruleツリー上で右クリックします。
詳細は、AR0111 PCBのデザインルール設定と違反の解消 を参照してください。

回路図の情報をPCBへ転送

回路図ドキュメントから回路情報を新規PCBに転送する前に、次のことを確認してください:

  • PCBファイルが回路図と同じ .PrjPCBプロジェクトファイルに属している
  • 必要なPCBフットプリントが利用できる状態になっている

ライブラリの使用方法に関する詳細は、AR0104 コンポーネント、モデル、ライブラリの概要 を参照してください。

回路図エディタでプロジェクトをコンパイル(Project » Compile Project)し、エラーの修正を行い、Design » Update PCB Documentコマンドを使ってECOを生成し、対象となるPCBに回路の情報を転送します。

PCBの更新に関する詳細は、チュートリアルTU0117 PCB設計入門 を参照してください。

Labels
  • None