Altium Wiki

Information and resources for electronic product designers

Skip to end of metadata
Go to start of metadata

Altium Designer のジョブ出力オプションは、印刷ベースの出力をサポートしています。もちろん、PCBの2次元、3次元、両表示に対応しています。 2D印刷出力では、印刷の完全なコントロールが可能です。すなわち、レイヤベースの「含める/除外する」設定や、各レイヤごとに、オブジェクトのレンダリング方法の設定がコントロールできます。 3次元のPCB 印刷では、標準ビューとカスタムビューのサポートが可能です。

Output GeneratorOG0105 (v1.3) April 29, 2008

印刷ベースの出力

Altium DesignerにおけるPCBプロジェクト用の印刷ベースの出力は、"出力コンフィギュレーションファイル"(*.OutJob)を作成することで可能になります。 出力ジョブを作成するときは、一定範囲のドキュメント、たとえば、合成描画や回路図作画などを含む一般的な2次元のPCB印刷出力が可能です。 2D 印刷出力は、PCB Printout Properties ダイアログで構成します。 3D PCB 印刷出力(PCB 3D Prints)は、PCB 3D Print Settings ダイアログで構成します。
出力ジョブ ファイルを作成するには、File » New » Output Job Fileを選択します。 新しい出力ジョブ ファイルが、新規のファイルとして、出力ジョブ エディタウィンドウに表示されます。

図1 出力ジョブは、OutJob ファイルとして構成され、印刷ベースの出力をフルコントロールできます。

2Dの印刷ベース出力

PCB Printout Propertiesダイアログでは、生成したい、特定の印刷ベースのドキュメンテーションに必要な出力の定義と管理を行うことができます。
ダイアログのメインのエリアは、基本的に3つの列に分かれています:

  • Printouts & Layers - 現在定義されている印刷出力とそれらを構成しているレイヤが記載されています。
  • Include Components - 印刷出力にどのコンポーネントを含めるかコントロールすることができます。
  • Printout Options - その他の印刷出力に関するオプションをコントロールすることができます。


図2 PCB Printout Properties ダイアログで、すべての2D印刷ベースの出力を構成します。

新規印刷出力の追加

現在の設定に新たに印刷出力を追加するには、PCB Printout Properties ダイアログ上での右クリックメニューからInsert Printoutコマンドを選択します。


図3 右クリックメニューで新規出力を追加

印刷は、既存の印刷の下に追加され、デフォルトで名前、New PrintOut 1がつけられます。 また、デフォルトでは、Include Components 欄のすべてのオプションが有効

です。
図4 追加出力の表示

印刷出力の設定


図5 印刷を構成する Printout Propertiesダイアログ

新たに追加した印刷の構成や既存の印刷出力の構成の編集は、Printout Properties ダイアログで行います。 このダイアログを表示するには、プリントアウト名のフィールド(Printouts & Layers)をダブルクリックするか、あるいは名前フィールドの上で右クリックして、表示されるポップアップメニューからPropertiesを選択します。
Printout Nameフィールドでは、必要に応じて印刷の名前を変更することができます。たとえば、意味のある名前をつけて、印刷出力の性質や目的がすぐにわかるようにすることができます。 印刷出力の名称は、PCB Printout Propertiesダイアログからも直接編集することができます。 必要な印刷出力の名前フィールドの上で一度クリックし、新しい名称を入力してください。

  • ダイアログのComponents領域では、印刷出力にどのコンポーネントを含めるかをコントロールすることができます。 例えば、印刷出力がボードのトップサイドのレイヤだけに関するものであれば、トップレイヤに配置されているコンポーネントと、トップとボトムの両レイヤにパッドがあるコンポーネント(例えば、PCBエッジコネクタ)だけを表示させることができます。
  • ダイアログのOptions 領域は、印刷に関する高度なオプションを提供します。たとえば、PCBエディタで使用するフォントには3種類(Default, Serif, Sans Serif)あり、これらのフォントの置き換えをして印刷をするかどうかを指定します。 これらのフォントの指定はPCB Print Preferencesダイアログ(プリントプリファレンスの設定 のセクションを参照)で行います。
  • ダイアログのPad Display Options領域は、印刷出力でのパッドの表示に関するオプション - パッド番号や関連ネットの表示とテキストのフォントサイズをコントロールすることができます。
  • Layers 領域は、印刷出力の"核心部分"です。レイヤの追加や編集、レイヤ順序の変更などの印刷出力が設定できます。 新規レイヤを追加や既存レイヤの編集では、Layer Propertiesダイアログが表示されます。 必要に応じ、レイヤの設定(「レイヤの設定 」のセクション参照)が行えます。

注 : 追加の新規レイヤは、すべてレイヤリストの下に追加されます。 これはイメージがレンダリングされるときに、最後に追加したレイヤがプリンタのメモリで最初に作画されることを意味します。 その後、各レイヤのイメージが順にレンダリングされます。 Move UpMove Down ボタンで、イメージのレンダリング順序を変更できます。

新規レイヤの追加


図6 Layer Properties ダイアログを使って、印刷レイヤを構成

印刷出力に新たにレイヤを追加するには、次の2つのどちらかの方法で行えます:

  • 印刷出力の設定中にzPrintout Properties ダイアログを表示させる方法。 Addボタンで、新しいレイヤをLayersリストに追加します。 新しいレイヤはリストの一番下に追加されますが、ダイアログには順序を変更するためのコントロールがあります。
  • PCB Printout Properties ダイアログから直接行う方法。 新レイヤを追加したい印刷出力のところで右クリックを行い、表示されたポップアップメニューからInsert Layerを選択します。 新しいレイヤが既存の印刷出力用レイヤの下に追加されます。 PCB Printout Propertiesダイアログでは、レイヤの順序は変更できません。 変更できるのは、Printout Propertiesダイアログだけです。

レイヤの構成

新たに追加したレイヤの設定、既存レイヤの設定を編集するには、関連するLayer Propertiesダイアログにアクセスします。 このダイアログは、新規レイヤを追加するときに表示されます。 このダイアログにアクセスして、既存レイヤを編集するには、次のどちらかを実行します:

  • ペアレントの印刷出力用にPrintout Properties ダイアログにアクセスして、レイヤを選択。Edit ボタンを押してください。
  • PCB Printout Properties ダイアログのPrintouts & Layers欄で、レイヤ名を直接ダブルクリックしてください。

印刷出力に新しいレイヤを追加する場合、最初に追加したいレイヤをPrint Layer Typeのドロップダウンリストから選択します。 リストには、ソースPCBドキュメントとして定義されている、現在のすべてのレイヤが含まれています。ここから任意のPCBレイヤを印刷出力に含めることができます。
ダイアログ中央の3つのエリアは、レイヤ上のプリミティブがどのように印刷されるかを決定するコントロール - Full、Draft(アウトライン)モード、Off(非表示)を提供しています。 これによって何がページに印刷されるか、完璧にコントロールできます。
例として、組み立て図面を考えてみましょう。これには次のようなレイヤが含まれています。:

  • コンポーネントのオーバーレイ
  • トップレイヤ(表面実装部品用)
  • マルチレイヤ(スルーホールパッド用)

トップレイヤはコンポーネントプリミティブを表示するように構成されます。したがって、表面実装パッドは表示、フリープリミティブは非表示になり、配線は表示されません。 マルチレイヤについてもコンポーネントプリミティブを表示するように設定されます。したがって、スルーホールコンポーネントのパッドは表示、フリープリミティブは非表示になり、ビアは表示されません。
ドリルレイヤを追加/編集する場合は、必要に応じて追加オプションを設定します。ダイアログの下側に以下のオプションがあります。:


  • 図7 PCB Print Preferences ダイアログと4つの領域
    レイヤペアの指定 - ドリルドローイングとドリルガイド情報の計算用
  • ドリルドローイングのシンボルとサイズ
  • ドリルドローイングレジェンドのソート順

印刷プリファレンスの設定

PCB Printout Properties ダイアログの左下にある Preferences ボタンをクリックすると、PCB Print Preferences ダイアログが開きます。 このダイアログで定義される全オプションが、それぞれの印刷ベース出力に適用されます。

カラー&グレースケール

この領域では、印刷可能な各レイヤに使用する色をコントロールできます。 それぞれのレイヤごとに、グレースケールやカラーで印刷を行う場合の色を設定できます。 左側のカラーパレットをクリックして、グレースケールシェードのレンジを設定してください。


図9 Choose Color ダイアログ


図8 グレースケールシェードの選択

右側のカラーパレットをクリックすると、Choose Colorダイアログが表示され、そこから定義済みの色のレンジを選択したり、カスタムカラーを作成できます。
PCBエディタでPCBデザインに設定しているのと同じ色で印刷を行いたい場合は、Retrieve Layer Colors From PCBボタンを押してください。

注 : この機能を使用すると、右側のカラーパレットで設定されている各レイヤの色は上書きされます。 クレースケールの設定は、マニュアルで変更するまで変わらずにそのまま残ります。 カラー、またはグレースケールで印刷を行うには、関連するオプション - ColorGray - を関連するページの設定ダイアログの印刷出力で有効にします。 所定の印刷デバイス用のカラー印刷モードは、それに応じたプロパティ(属性)ダイアログで設定する必要があります。

新規の印刷出力に含める

メカニカルレイヤを印刷出力にそれぞれ追加するのと同様、それらをすべての印刷出力に自動的に含めることもできます。その場合、親となるドキュメントタイプの印刷ジョブが、所定の印刷デバイスに送られます。 ダイアログのこの領域を使って、16のメカニカルレイヤを必要に応じて有効/無効にできます。

代用フォント


図10 Font ダイアログを使ったフォントの代用

PCBエディタで使用されている3つのフォント(Default、Serif、Sans Serif)は、印刷出力時にウィンドウズの別フォントに置き換えることができます。 ダイアログのこの領域のオプションを使って、代用フォントの指定と有効化ができます。
目的のフォント欄の横にある ... ボタンをクリックして、ウィンドウズ標準のFont ダイアログにアクセス。ここで求める代用フォントを選択できます。
OKをクリックすると、フォントの名前がフォント欄に入力されます。

注 : 代用フォントは、PCB Print Preferences ダイアログで、グローバルに有効/無効にできます。一方、Printout Properties ダイアログのEnable Font Substitutionオプションでは、個々の印刷出力のレベルで、各印刷ベースの出力タイプをコントロールできます。

オプション

ダイアログのこの領域には、Print Keepout Objects というオプションだけが用意されています。ここで、キープアウトされているデザインオブジェクトを印刷ドキュメントに含めるかどうかのフルコントロールができます。

右クリックメニュー

以下のリストは、PCB Printout Properties ダイアログで、右クリックメニューとしていつでも利用できるコマンドです:

  • Create Final - このコマンドを使用すると、ソースPCBドキュメントに対して、定義済みの最終アートワークの印刷セットがすぐに作成できます。
  • Create Composite - このコマンドを使用すると、ソースPCBドキュメントに対して、定義済みのマルチレイヤコンポジット印刷がすぐに作成できます。
  • Create Power-Plane Set - このコマンドを使用すると、ソースPCBドキュメントに対して、定義済みのパワープレーン図面がすぐに作成できます。
  • Create Mask Set - このコマンドを使用すると、ソースPCBドキュメントに対して、定義済みのソルダ/ペーストマスク図面がすぐに作成できます。
  • Create Drill Drawings - このコマンドを使用すると、ソースPCBドキュメントに対して、定義済みのドリル図面とドリルガイドがすぐに作成できます。
  • Create Assembly Drawings - このコマンドを使用すると、ソースPCBドキュメントに対して、定義済みの組み立て用図面がすぐに作成できます。
  • Create Composite Drill Guide - このコマンドを使用すると、ソースPCBドキュメントに対して、定義済みのコンポジットドリル図面がすぐに作成できます。
  • Insert Printout - このコマンドを使用すると、印刷ベースの出力に応じた新たなプリントアウトが、現在の印刷設定に追加されます。
  • Insert Layer - このコマンドを使用すると、新しいレイヤが、フォーカスされている印刷出力に追加されます。 新しいレイヤは、既存の印刷出力用レイヤのリストの一番下に追加されます。
  • Delete - このコマンドを使用すると、フォーカスされているレイヤを親となる印刷出力から削除します。または、フォーカスされている印刷出力を現在構成されているプリントセットから削除します。 削除の際は、確認を求められます。 全レイヤを印刷出力から削除したり、全印刷出力をプリントセットから削除したりしてしまわないようにしています。
  • Properties - このコマンドを使用すると、Layer Properties ダイアログか Printout Properties ダイアログのどちらかにアクセスすることができます。どちらが表示されるかは、フォーカスエントリがそれぞれ、レイヤか、印刷出力かによります。
  • Preferences - このコマンドを使用すると、PCB Print Preferences ダイアログが表示されます。 ここで、すべてのプリントセットに適用されるグローバルなオプションを定義できます。

3D印刷ベースの出力の構成

PCB 3D Print Settings ダイアログで、ジョブ出力ファイル用に、PCBの 3D印刷出力の選択、生成ができます。 印刷出力のいくつかにおいては、すでに、複数のインスタンスが利用できるようになっています(このために、ジョブ出力ファイルの Add New Documentation Output コントロールを使用しました)。これは、異なるパースで、望むとおりのボードのビューを印刷できるので、3Dでは特に便利です。
ダイアログは、4つの領域に分かれています:

  • Render Resolution - このオプションは、印刷用の3D"画像"の品質用です。 適用可能な解像度はプリンタには依存しません。
  • View to Print - ボードの平面ビューから選択できます。つまり、ボードに対して垂直なカメラパース、あるいは、カスタムビューです。
  • View Configuration - 現在のビュー構成を適用して、表面の色、見通し、不透明性、ボードの厚さなどを設定できます。
  • Preview - どんな風に印刷されるか、正確に再現します。


図11 PCB 3D Print Settings ダイアログで、全3D 印刷ベース出力を構成します

カスタム3Dの印刷出力

ボードのカスタムビューでは、表面の色、見通し、不透明性、ボードの厚さなどに関するさまざまな設定を生かしたままで、回転、ズームを行うことができます。 これらのオプションを使って、ハイレベルなディテールやデザインのハイライトエリアを提供し、効果を生み出すビューを生成します。

ボードのカスタム 3D ビューを印刷出力として作成する方法は、以下のとおりです:
PCB エディタウィンドウで、3D モード [ショートカット 3]に入ります。 3D ビューをコントロールして、希望のパースにします。 ジョブ出力ファイルに戻り、PCB 3D Prints の欄をダブルクリックして(または、右クリックして、ショートカットメニューからConfigure を選択)、PCB 3D Print Settings ダイアログを開きます。 Custom オプションをクリックして、Take Current Camera Position ボタンを押します。 Preview パネルは新しいパースに更新されます。 OK をクリックして、カスタム設定を現在の PCB 3D 印刷出力に設定します。

カスタムの表面色を適用したい、などの場合は、以下のとおりです:
PCBエディタウィンドウで、View Configurations ダイアログ [ショートカット L] を開きます。 このダイアログで、希望のビュー構成オプションを設定、適用します。 PCB 3Dに適用するために、このビュー構成を保存する"必要"がないことに注意してください。 ジョブ出力ファイルに戻り、PCB 3D Print Settings ダイアログを開きます。Take Current View Configuration ボタンを押します。 Preview パネルは新しいビュー構成の設定に更新されます。 ビュー構成は一度適用すると、すべてのView to Print オプションに適用されます。. OK をクリックして、ビュー構成を現在の PCB 3D 印刷出力に設定します。
Output Job Configurationファイルを保存して、新しい 3D 印刷出力をキープします。

注記

ダイアログで利用可能な各オプションの詳細については、「What's This Help」機能を使用してください。 ダイアログの右上にある疑問符( )のボタンをクリックしてから、フィールドまたはオプションをクリックすると、そのフィールドまたはオプションの情報がポップアップ表示されます。

右クリックメニューから利用できる定義済みのプリントセットコマンドを使用して、新しいプリントセット構成を作成すると、現在のプリントセットがすべて置き換えられます。 実行する前にこの作成作業を続行するかどうか、確認のダイアログが表示されます。 確認を実行してしまうと、プリントセットを元に戻す事はできません。

印刷ベース出力は、次のどちらかの方法で作成することができます:

  • Output Jobファイル(*.OutJob)で適切に構成されたアウトプットジェネレーターを使用します。 構成されたアウトプットジェネレーターを実行すると、出力が生成されます。
  • File » Print メニューコマンドを使って、アクティブなPCBドキュメントから直接実行します。 現在有効なデフォルトのプリントセットで、出力が生成されます。

注 : File » Printメニューコマンドを使って、PCBエディから出力を直接作成する場合は、Output Job Configurationファイルで定義されている構成とは、別の内容が構成されます。 このケースでは、Options for Projectダイアログ(Project » Project Options)のDefault Printsタブを使用して、デフォルトの印刷構成とページレイアウトを、それぞれの印刷に関連する生成可能な出力に合わせて構成します。


図12 Options for Project ダイアログの Default Prints タブ

ここで定義された構成オプションは、Output Job ファイル中の同じ出力タイプ用に定義されたものとは異なり、区別されています。 前者の場合、設定はプロジェクトファイルに保存され、後者の場合は、Output Jobファイルに保存されます。

PCBエディタのFileメニューからアクセスされるページとプリンタに関する設定オプションも、Output Job ファイルからアクセスされるオプションと区別されています。 これについても前者はプロジェクトファイルに、後者はOutput Jobファイルに保存されます。

Labels
  • None