Altium Wiki

Information and resources for electronic product designers

Skip to end of metadata
Go to start of metadata
You are viewing an old version of this page. View the current version. Compare with Current ·  View Page History

部品配置出力オプション

概要

部品配置出力オプションの設定は、Pick and Place Setupダイアログで行います。

Output GeneratorOG0104 (v1.2) March 26, 2008

 

 

 

部品配置設定ダイアログ

Pick and Place Setupダイアログは、部品配置の出力オプションのすべてを構成する手段を提供します。
Pick and Place Setupダイアログでは、出力したいフォーマット(CSV 、Text、あるいはその両方)を決定します。また、コンポーネント位置の座標値の単位系をインチかミリで指定できます。
出力が生成されると、そのファイルには次のようにPCBデザインの名前が使用されます:

  • PCBDesignName.csv
  • PCBDesignName.txt

生成されたファイルには、デザイン内の各コンポーネントに関する次の情報が含まれています:

  • Designator(部品番号)
  • Footprint(フットプリント)
  • Location*(位置)
  • Layer (テキストバージョンのファイルでは、T(Top)、B(Bottom)と表記されます。
  • Rotation(回転角)
  • Comment(コメント)
  • 配置情報は、元になるPCBライブラリのコンポーネントのフットプリントで指定した基準点によって、次の3つの方法で表現されます:
  • Mid X, Mid Y - コンポーネントの中心点の座標
  • Ref X, Ref Y - ユーザーが定義したコンポーネントの基準点座標
  • Pad X, Pad Y - コンポーネントのパッドデジグネータが1の座標

注記

使用できる各オプションの詳細情報を表示するには、ダイアログの What's This Help 機能を使用します。ダイアログの右上にある疑問符(?)のボタンをクリックしてから、フィールドまたはオプションをクリックすると、そのフィールドまたはオプションの情報がポップアップ表示されます。

部品配置出力は、次の2つのどちらかの方法で生成することができます:

  • Output Job Configurationファイル(*.OutJob)で適切な設定を行ったアウトプットジェネレータを使用します。出力は、設定したアウトプットジェネレータを実行することで生成されます
  • アクティブなPCBドキュメントからメニューコマンドFile » Assembly Outputs » Generates pick and place filesを直接実行します。Pick and Place SetupダイアログのOKボタンをクリックすると、すぐに出力が生成されます

注記 :Pick and Place Setupダイアログで定義されている設定は、PCBから直接出力を生成する際に適用され、Output Job Configurationファイルの同じ出力タイプの設定とは区別されています。前者の場合、設定はプロジェクトファイルに保存され、後者の場合は、Output Job Configurationファイルに保存されます

CSVとテキスト以外の形式で部品配置を生成したい場合は、レポートマネージャを使うことでそれが可能となります。これはOutput Job Configurationファイルの一部として簡単に設定できます。Report OutputsカテゴリにBill of Materials(部品表)のアウトプットジェネレータを追加し、部品配置の情報であることが判るように名前を付けます。Data Sourceフィールドでは、情報を生成したいPCBドキュメント名を選択します。
エントリをダブルクリックしてください。追加した項目をダブルクリックすると、Name欄で設定したアウトプットジェネレータ名のダイアログが表示されます。 ジェネレータの名前を部品配置とした場合、ヘッダがPick and Place for PCB Document [PCBName]というダイアログが表示されます。ここでレポートとして必要な情報の設定を行います。


生成するファイルの出力パスは、Options for ProjectダイアログのOptions タブで設定します。デフォルトの出力パスは、プロジェクトファイルが存在しているフォルダにサブフォルダが作成され、ProjectNameという名称になります。出力パスは必要に応じて変更することができます。Options タブのUse a separate folder for each output typeオプションを有効にすると、部品配置ファイルは、更にPick Place Outputというサブフォルダが作成され、そこに保存されます。

データを作成すると出力はプロジェクトに追加され、ProjectsパネルのGeneratedフォルダ内の適切なサブフォルダ内に表示されます。各出力タイプでフォルダを分けた場合は、Projectsパネルにそれに対応したGeneratedフォルダが追加されます。 (例えば:Generated (Pick Place Output))

更新履歴

Date

Version No.

Revision

05-Dec-2005

1.0

New release

04-Mar-2008

1.1

Updated Page size to A4.

26-Mar-2008

1.2

Minor edits and updates.

ソフトウェア、ハードウェア、文書、および関連資料
Copyright © 2008 Altium Limited.
All rights reserved.この文書の印刷は、(1) 個人的使用に限定し、ネットワークコンピュータやあらゆる種類の媒体にコピーや送信を行わない、かつ (2) 文書の変更をまったく行わない、という条件でのみ行うことができます。Altium Limited の事前の書面による許可なく、本書の全体または一部を問わず、機械的または電子的な複製、他言語への翻訳を禁じます。 ただし、公表するレビュー目的での抜粋を除きます。本書の無許可の複製は、各国の法律でも禁止されています。違反者は、罰金や実刑を含む刑事罰と民事罰両方の対象となることがあります。Altium、Altium Designer、Board Insight、CAMtastic、CircuitStudio、Design Explorer、DXP、LiveDesign、NanoBoard、NanoTalk、Nexar、nVisage、PCAD、Protel、SimCode、Situs、TASKING、Topological Autorouting、およびそれぞれに対応するロゴは、Altium Limited またはその子会社の商標または登録商標です。本書に記載されているそれ以外の登録商標や商標はそれぞれの所有者の財産であり、商標権を主張するものではありません。

Labels
  • None