Altium Wiki

Information and resources for electronic product designers

Skip to end of metadata
Go to start of metadata
Altium Designer 18.0 は、世界で最も人気のあるエレクトロニクス製品設計環境のメジャーアップデートです。このバージョンでは、新しい機能や改善した機能が含まれているだけでなく、設計者の生産性を最適化することも注力しています。
 

Altium Designer 18.0 は、以下により、生産性を向上します:

  • 大幅なパフォーマンスの改善 - 100 種類のネットで ActiveRoute を実行、複雑な GND ネットの同期等のコンピュータの集中的なタスクは、かなり速くなりました。
  • 改善された応答性により、3D PCB をスムーズに回転、ズームできます。
  • ユーザインターフェースを見直しました。

Altium Designer 18.0 では、新しい外観と雰囲気になり、基板設計の操作性を向上します。メインエディタの色彩方針から、新しいより幅広いパネル、プリファレンスや管理されたコンテンツサーバへの素早いアクセス等、この更新されたバージョンの Altium Designer では、より合理化して設計できます。

以下のような変更点があります:

  • 新しい色彩方針。Altium Designer は、暗い背景、より明るい文字で表示されます。調査によると、文字指向のインターフェースは、一般的に明るい背景で暗い文字が最適ですが、画像集中型インターフェースは、暗い背景で明るい内容が目により良いと思われます。
  • 新しい Properties パネルにより、エディタ内のオブジェクト ダイアログが不要になりました。そのため、オブジェクトをより素早く容易に配置、編集できます。また、新しいパネルにより、合理化して親、子プロパティへアクセスできます。
  • 新しい Active Bar により、PCB、回路図、Draftsman、ライブラリ ドキュメントでの配置に関してコントロールできます。
  • パネルプリファレンスは、あまり使用しないものを除去して、合理化しています。
  • Vaults パネルは、Explorer パネルに変更されています。

このドキュメントの目的は、Altium Designer 18.0 の主要なユーザインターフェースの変更内容を説明することです。このバージョンの新しい機能や、既存の機能の拡張、改善点に関する詳細な情報は、その他のドキュメントに記載されています。このドキュメントでは、改善したユーザインターフェースや、その利点について説明します。ソフトウェアの外観の主要な変更(デザインワークスペースを包括的に活性化させ、設計の生産性を向上する変更)を確認できます。

新しい色彩テーマ

Altium Designer の全体的な色彩テーマを木炭のような背景に変更しました。この新しいテーマにより、より多くのワークスペースに対応できます。パネルや、いくつかのダイアログも、新しい色彩テーマに変更しました。


新しい Altium Designer のワークスペース

      
新しい Altium Designer のパネルの色彩方針 (Projects パネルと PCB List パネルの例)


新しい色彩方針を、いくつかのダイアログへ適用しました (Project Options の例)。

メニューの変更

削除した DXP メニュー

DXP メニューは、目的の場所を素早く表示できるボタンやコマンドに変更しました(一般的に使用する要素を、より容易にアクセスできる標準的な場所へ移動しました)。重要な変更は、以下の項目で説明します。

My Account ページの名称を License Management に変更

Altium Designer のライセンスを設定するために使用する My Account ページの名称は、そのページの使用方法を明確にするために、License Management に変更しました。

プリファレンスの表示

Altium Designer のプリファレンスは、下図に示すように、ワークスペースの右上にある ボタンをクリックして容易に表示できます。


プリファレンスを表示するには、ハイライト表示した箇所をクリックします。


Altium Designer のプリファレンスを表示

License Management の表示

License Management ページを表示するには、下図に示すように、ワークスペースの右上のドロップダウンをクリックしてから License Management を選択します。


License Management ページを表示するには、ハイライト表示したドロップダウンをクリックしてから License Management をクリックします。

License Management の表示。

Extensions & Updates の表示

Extensions & Updates ページを表示するには、下図に示すように、ワークスペースの右上のドロップダウンをクリックしてから Extensions and Updates を選択します。


Extensions & Updates
ページを表示するには、ハイライト表示したドロップダウンをクリックしてから Extensions and Updates をクリックします。

Extensions & Updates ページの表示。

管理されたコンテンツサーバへのアクセス

管理されたコンテンツサーバのサインイン/サインアウト

管理されたコンテンツサーバへサインインするには、下図に示すように、ワークスペースの右上のドロップダウンをクリックしてから Sign in を選択します。


サーバへサインイン。

サーバへサインインしている時、下図に示すように、ワークスペースの右上に、アカウントクレデンシャルが表示されます。


アカウントクレデンシャルは、サーバへサインインしている時、表示されます。

サーバからサインアウトするには、下図に示すように、ワークスペースの右上にあるドロップダウンをクリックしてから Sign out を選択します。


サーバからサインアウト。

管理されたコンテンツサーバへアクセス

管理されたコンテンツサーバへサインインしたら、ワークスペースの右上のドロップダウンをクリックしてから管理されたコンテンツサーバを選択して、新しい Explorer パネルからアクセスできます。

 

また、Explorer パネルは、ワークスペースの右下にある Panels タブをクリックしてから Explorer を選択して、表示できます。

 

   Altium フォーラムへのアクセス

Altium フォーラム(フィードバックの提供や、Altium Designer の使用方法について話し合える)は、下図に示すように、メインメニューから Help » User Forums をクリックして、アクセスできます。


ユーザフォーラムヘのアクセス。

検索

検索 機能は、下図に示すように、ワークスペースの右上にあります。

検索 機能の場所。

その他のコマンド

  • Customize コマンドは、メニューバーで右クリックして利用できます。
  • Run Process コマンドは、使用頻度が少ないため、削除しました。

削除した回路図のメインメニューコマンド

以下は、理論的に基づいて削除した回路図コマンドのリストです。一部のコマンド機能は、パネル等に変更されています(これについては、以下で説明します)。

  • Design » Add/Remove Library - Libraries パネルに統合しました。
  • Design » Document Options メニュー - オブジェクトを選択していない時の Properties パネルに移行しました。
  • Edit » Change - オブジェクトを選択して、Properties パネルで編集するように変更しました。
  • Edit » Clear - 使用頻度が少ない。

 

Clear コマンドは、削除しました。この機能は、既存の Delete コマンド(以前のように、Edit メニューから利用できます)へリファクタリングしました。Delete コマンドには、2 つのモードがあり、ワークスペースで現在、オブジェクトを選択しているか、選択していないか考慮します:
現在、セレクトしているオブジェクト - セレクトした箇所は、ドキュメントから削除されます。
現在、セレクトしているオブジェクトが無い - カーソルが、十字に変わり、オブジェクトを削除できるモードになります。オブジェクト上にカーソルを置いてクリックするか、または Enter を押して削除できます。更にオブジェクトを削除するか、または右クリック、Esc を押して、オブジェクトを削除するモードを解除します。

 

  • Edit » Duplicate - Rubber Stamp コマンドに統合しました。
  • Edit » Rubber Stamp - Duplicate を移行しました。
  • File » Link Sheet to Vault - 直接、編集する方法に変更しました。
  • File » Release Manager - 直接、編集する方法に変更しました。
  • Place » Manual Junction - オートジャンクションが、自動で追加されるので必要ありません。
  • Place » Hyperlink - この機能は、Text String オブジェクトの一部です。
  • Place » Directives » PCB Layout - 使用頻度が少ない。
  • Place » Directives » Net Class - 一般的な Place » Directives » Parameter Set コマンドを使用して、実行できます。
  • Place » Directives » Stimulus - 使用頻度が少ない。
  • Place » Directives » Test Vector Index - 使用頻度が少ない。
  • Place » Directives » Probe.
  • Place » Directives » Instrument Probe.
  • Place » Drawing Tools » Pie Chart - 使用頻度が少ない。
  • Place » Drawing Tools » Elliptical Arc - 使用頻度が少ない。
  • Place » Notes » Ellipse - 使用頻度が少ない。
  • Place » Notes » Rectangle - 使用頻度が少ない。
  • Place » Notes » Polygon - 使用頻度が少ない。
  • Tools » NoERC Manager - 使用頻度が少ない。
  • Tools » Harness Definition Problem Finder - 使用頻度が少ない。

削除した PCB のメインメニューコマンド

以下は、理論的に基づいて削除した PCB コマンドのリストです。一部のコマンド機能は、パネル等に変更されています(これについては、以下で説明します)。

  • Edit » Build Query (Shift+B) - 使用頻度が少ない; ルールとフィルタで作業している時に利用できる機能。
  • Edit » Clear - 使用頻度が少ない。

 

Clear コマンドは、削除しました。この機能は、既存の Delete コマンド(以前のように、Edit メニューから利用できます)へリファクタリングしました。Delete コマンドには、2 つのモードがあり、ワークスペースで現在、オブジェクトを選択しているか、選択していないか考慮します:
現在、セレクトしているオブジェクト - セレクトした箇所は、ドキュメントから削除されます。
現在、セレクトしているオブジェクトが無い - カーソルが、十字に変わり、オブジェクトを削除できるモードになります。オブジェクト上にカーソルを置いてクリックするか、または Enter を押して削除できます。更にオブジェクトを削除するか、または右クリック、Esc を押して、オブジェクトを削除するモードを解除します。

 

  • Edit » Change - 使用頻度が少ない。
  • Edit » Rubber Stamp - Duplicate を移行しました。
  • Place » Coordinate - Draftsman のツールに移行しました。
  • Place » Design View - Draftsman のツールに移行しました。
  • View » Net Color Override - View Configuration パネルの View Options タブにあるAdditional Options の項目で利用できます。

  • Tools » Component Placement » Auto Placer - 廃止しました。
  • Tools » Component Placement » Stop Auto Placer - 廃止しました。
  • Tools » Component Placement » Shove - 廃止しました。
  • Tools » Component Placement » Shove Depth - 廃止しました。
  • Tools » Density Map - 廃止しました。
  • Tools » Grid Manager - グリッドは、Board モード(オブジェクトを選択していない時)で、Properties パネルの Grid Manager の項目で定義します。

  • Tools » Guide Manager - ガイドは、Board モード(オブジェクトを選択していない時)で、Properties パネルの Grid Manager の項目で定義します。

  • Tools » Legacy Tools - 新しいツールに移行しました。
  • Design » Board Layers & Colors - View Configuration パネルで利用できます。
  • Design » Board Options メニュー - いくつかのオプションは、Properties パネルへ移動しました。または、Draftsman の機能に移行しました。
  • Reports » Board Information - Board モード(オブジェクトを選択していない時)で、Properties パネルの Board Information の項目に表示されます。

File メニュー

メインメニューからアクセスする File メニューを合理化し、ファイルに固有のコマンドのみにしました。

回路図ドキュメント用の File メニューの例。

合理化したプロジェクト作成コマンド

新しいプロジェクトを作成するための新しいサブメニュー(File » New » Project をクリックしてアクセス)を再構成し、主なプロジェクトタイプをより簡潔に表示しました。以下を選択できます:

  • PCB Project - 新しい PCB プロジェクトを作成するために選択します。新しい PCB_Project.PrjPCB が、Projects パネルに表示されます。
  • Multi-board Design Project - 新しいマルチボード プロジェクトを作成するために選択します。新しい MultiBoard_Project.PrjMbd が、Projects パネルに表示されます。
  • Integrated Library - 新しい統合ライブラリ プロジェクトを作成するために選択します。新しい Integrated_Library.LibPkg が、Projects パネルに表示されます。
  • Project - このオプションを選択すると、New Project ダイアログが表示されます。そこで、新しいプロジェクトの詳細を指定できます。

作成できる新規ファイル タイプ

  • Multi-board Schematic (*.MbsDoc) - マルチボード プロジェクトがアクティブ ドキュメントの時に利用できます。
  • Mutli-board Assembly (*.MbaDoc) - マルチボード プロジェクトがアクティブ ドキュメントの時に利用できます。

削除した新規ファイル タイプ

  • Text Document (*.txt)
  • Component Library (*.CmpLib)
  • PCB3D Library (*.PCB3DLib) - 3D 編集環境に変更しました。
  • Java Script Unit (*.js)
  • Java Script Form (*.js)
  • TCL Script Unit (*.tcl)
  • Enable Basic Script Unit (*.bas)
  • VB Script Unit (*.vbs)
  • VB Script Form (*.vbs)

 

File » New コマンドから上記ファイル タイプを作成することはできませんが、以前のデザインで使用している場合、ファイルを編集できます。

 

右クリックメニューの変更
 

回路図と PCB 編集領域での右クリックメニューを一掃して合理化し、必要なコマンドのみ残しました。


回路図(左の図)とPCB(右の図)のマイナス領域での右クリックメニュー。

削除した回路図の右クリックメニューのコマンド

  • Refactor
  • Grid
  • View
  • Workspace Panels
  • Find Component
  • Place Part
  • Options
削除したワイヤの右クリックメニューのコマンド
  • Wire
  • Bus Entry
  • Break Wire

削除したバスの右クリックメニューのコマンド

  • Bus
  • Bus Entry
  • Break Wire

削除したシグナルハーネスの右クリックメニューのコマンド

  • Break Wire

追加した回路図の右クリックメニューのコマンド

  • Project Options - Project Options ダイアログを開く。
  • Preferences - Preferences ダイアログを開く。

プリファレンスの変更

新しいプリファレンス ページ

Data Management - Servers 

Data Management - Servers プリファレンス ページを使用して、管理されたコンテンツサーバやプロジェクトリリース オプションを設定できます。


Preferences ダイアログの Data Management - Servers ページ   

Data Management - Component Rule Checks 

Data Management - Component Rule Checks プリファレンス ページは、コンポーネントエラーのレポート方法を設定するために使用します。

0.
Preferences ダイアログの Data Management - Component Rule Checks ページ   

Multi-board Schematic - Defaults

Multi-board Schematic - Defaults プリファレンス ページは、マルチボード回路図のプリミティブのデフォルトを設定するために使用します。


Preferences ダイアログの Multi-board Schematic - Defaults ページ(Text が選択されている状態

Multi-board Assembly - General

Multi-board Assembly - General プリファレンス ページは、PCB から何をインポートするか設定するために使用します。


Preferences ダイアログの Multi-board Assembly - General ページ

Multi-board Assembly - View Configuration

Multi-board Assembly - View Configuration プリファレンス ページは、色や表示オプションを設定するために使用します。


  Preferences ダイアログの Multi-board Assembly - View Configuration ページ

更新したプリファレンス ページ

Defaults ページ

Defaults ページを更新し、多くのプリミティブのデフォルト設定を追加しました。下図は、例として Schematic - Defaults ページの Blanket プリミティブを示します。


Preferences ダイアログの Schematic - Defaults ページにある Blanket プリミティブのデフォルト設定

System - General



  • Open Home Page if no documents open オプションは、Startup 領域から削除しました。

  • General 領域内の Enable debug memory manager オプションを削除しました。

  • Advanced ボタンを追加しました。Advanced Settings ダイアログで、下図のように、高度な設定を行えます。


新しい Advanced Settings ダイアログ

 

ダイアログに記述している通り、これらの設定を変更すると、Altium Designer が不安定になる場合があります。変更する時、慎重に行ってください。

 

System - View



  • Desktop 領域の Exclusions オプションを削除しました。
  • Desktop 領域のレイアウトを読み込み、保存、リセットできます。
  • Show Navigation Bar As 領域を削除しました。
  • General 領域の Show full path in title bar オプションを削除しました。
  • Favorites panel オプションを削除しました(Favorites パネルは、削除しました)。
  • Documents Bar 領域内の Auto-hide the documents barMultiline documents bar オプションを削除しました。
  • 新しい UI Theme 領域を追加しました。UI テーマを設定し、プレビューを表示できます。

System - Navigation



  • Masking オプションを削除しました。この機能は、SCH Filter パネルで行います。
  • Dimming オプションと、dimming コントロール用のスライダーバーを追加しました。
  • Cross Select Mode 領域内の Masking オプションの名称を Dimming に変更しました。

System - Projects Panel



  • General 領域の Show open/modified statusShow Grid オプションを削除しました。
  • Grouping 領域の名称を Documents Grouping に変更しました。そのオプションは、同じままです。
  • Structure View 領域を削除しました。
  • Components Grouping と言う名称の新しい領域を追加しました。この領域内のオプションは、デジグネータ、コメント、owner sheet、not groupでコンポーネントをグループ化できます。

System - New Document Defaults



  • FPGAに関連したドキュメント デフォルトを削除しました。

Data Management - Version Control



  • CVS - Concurrent Versions System プロバイダを削除しました。

Data Management - Parts Providers



  • Data Management - Suppliers プリファレンス ページの表題を Data Management - Parts Providers へ変更し、Altium Parts Providers 拡張機能と連動しました。
  • Altium Parts Options 領域で、Move Up/DownFilter オプションを削除しました。

Schematic - General



  • Units オプションを追加しました(以前は、Schematic - Default Units ページにありました)。オプションは、Mils、または Millimeters のみです。

 

以前にインチ系単位で作成した回路図は、Mil で開きます; 以前にメートル系単位で作成した回路図は、Millimeter で開きます。

 

  • No-ERC MarkersNotes のオプションを Include with Clipboard オプションから削除しました。それらの項目は、親項目が有効な(チェックが入っている)場合、デフォルトでクリップボードに含まれます。
  • current document がデフォルトで選択されているので、Document scope for filtering and selection オプションを削除しました。

Schematic - Graphical Editing



  • ストリングが常に表示されるので、Convert Special Strings オプションを削除しました; 無効な場合、パラメータ名が表示されます。
  • Double Click Runs Inspector オプションを削除しました(Inspector パネルを削除したため)。
  • Enable Auto Pan オプションを Auto Pan Options 領域に追加しました。
  • Undo/Redo 領域を削除しました。このオプションは、Advanced Settings ダイアログ(System - General プリファレンス ページの Advanced ボタンをクリックして表示)の Preference NameSchematic.UndoStackSize オプションにある Value Default Value で設定できます。 

Schematic - Compiler



  • Manual Junctions Connection Status オプションを削除しました。
  • Dim level for read-only objects in compiled documents tabs スライダーバーを削除しました(回路図の Editor タブの Dimming コントロールは、Preferences ダイアログの System - Navigation ページに移行しました)。

Schematic - AutoFocus



  • Dim Unconnected Objects 領域内の Dim Level スライダーバーを削除しました。

Schematic - Grids



  • Snap Distance を追加しました。
  • Electrical Grid を削除しました。

PCB Editor - General



  • Double Click Runs Inspector オプションを削除しました(Inspector パネルを削除したため)。
  • Other 領域内の Undo/Redo オプションを削除しました。このオプションは、Advanced Settings ダイアログ(System - General プリファレンス ページの Advanced ボタンをクリックして表示)の Preference Name が PCB.UndoStackSize オプションにある Value Default Value で設定できます。 
  • Enable Auto Pan オプションを Autopan Options 領域に追加しました。有効な場合、編集していて十字カーソルがアクティブな時、ドキュメントビューウィンドウの端を超えてカーソルを移動すると、その方向にパンします。

  • 新しいオプション Repour all dependent polygons after editingPolygon Rebuild 領域に追加しました。

  • Collaboration 領域の DXP App Server オプションを削除しました。

PCB Editor - Display



  • Default PCB View Configurations3D Bodies オプションを削除しました。Configurations と 3D bodies は、View Configuration パネルの View Options タブにある General Settings オプションに依存して表示されます。

  • Flyover ZoomAlpha BlendingOrdered Blending オプションを削除しました。
  • Antialiasing On/Off オプションを使用して、3Dアンチエイリアスを有効/無効にできます。
  • レイヤ順を指定するための Layer Drawing Order 領域を追加しました。

PCB Editor - Board Insight Display



  • Live Highlighting オプションをより簡潔にしました。Shift キーを押した時、ライブハイライティングを表示するには、Live Highlighting only when Shift Key Down を有効にします。

PCB Editor - DRC Violations Display



  • Show Violation Detail 領域を削除しました。

削除したプリファレンス ページ

  • System - Altium Vault - 新しい Data Management - Servers プリファレンス ページへ移行しました。
  • System - Desktop Layouts -  View メニューを使用して、より直感的になりました。
  • Data Management - Vaults - 新しい Data Management - Servers プリファレンス ページへ移行しました。
  • Schematic - Default Units - Schematic - General プリファレンス ページへ移行しました。
  • PCB Editor - Board Insight Lens - 使用頻度が少ない。
  • PCB Editor - PCB Legacy 3D - 従来の項目。
  • 全ての Wave プリファレンス ページ - 使用頻度が少ない。

プロジェクト オプションの変更

  • FPGA 設計機能は AD から削除しているため、FPGA に関連した項目のオプションは、Error Reporting タブから削除しました。Hover the cursor over the image below to view the previous version of the Error Reporting tab.



以下は、削除した項目のリストです:

  • Violations Associated with Buses 領域で削除した項目:
    • Arbiter loop in OpenBus document
    • Cascaded interconnects in OpenBus document
    • Forbidden OpenBus Link
    • Mismatching Address/Data Widths of OpenBus Ports
  • Violations Associated with Code Symbols 領域 - 全ての項目。
  • Violations Associated with Configuration Constraints 領域 - 全ての項目。
  • Violations Associated with Documents 領域で削除した項目:
    • Conflicting Constraints
    • HDL Identifier Renamed
    • Missing child HDL entity for sheet symbol
    • Missing Configuration Target
    • Missing sub-Project sheet for component
    • Multiple Configuration Targets

パネルの変更

パネルの表示

現在のエディタ(PCB、回路図、Draftsman、ライブラリ等)で利用できるパネルを表示するには、ワークスペース右下の Panels タブを使用します。


Panels タブを使用してパネルを表示。

 

パネルは、メインメニューの View » Panels をクリックして、サブメニュー コマンドからも表示できます。

 

セレクション後のフィルタ

下図に示すように、パネルの右上に新しいフィルタ機能を追加しました。

この機能は、パネルに表示する情報をフィルタリングできます。下図に示すように、フィルタアイコンのドロップダウンをクリックして、フィルタ内容を表示します。

ドロップダウン(下図に示すように)でオブジェクトをクリックできます。そして、パネルには、フィルタをかけたオブジェクトの情報は表示されません。

フィルタは、下図に示すように、フィルタアイコン自体をクリックして全体で無効/有効にできます。

新しいパネル

Properties パネル

     
例として、回路図コンポーネントと PCB Board 設定を示す Properties パネル。

新しい Properties パネルには、ワークスペースで選択している項目に関する情報やコントロール機能が含まれています。ワークスペースで何も選択していない場合、パネルには、PCB ドキュメントではボード オプションが、回路図ドキュメントではドキュメント オプションが、ライブラリ ドキュメントではライブラリ オプションが、マルチボード ドキュメントではマルチボード オプションが表示されます。また、BOM document (*.BomDoc) では全般的なドキュメント オプションを表示して、素早く変更できます。また、ワークスペースでオブジェクト(アーク、テキストストリング、ワイヤ等)を配置する時、配置前にオブジェクトを設定できます。Selection Filter の項目は、ワークスペースで選択する、しないものをコントロールできます。

オブジェクトの配置

Place コマンド、または新しい Active Bar を使用してオブジェクトを配置する時、オブジェクトを選択した後、Tab キーをクリックして、配置前にProperties パネルで目的の設定を行えます。"配置モード" に戻る準備ができたら、ワークスペース上にある "一時停止" シンボルをクリックして、配置モードに戻ります。

Properties パネルの上部にある Search 機能(下図でハイライトされている)では、目的の項目をパネル内で検索できます。

Properties パネルの右上にある 2 つのボタンを使用して、パネルの内容をコントロールできます。

同じプロジェクトの開いているドキュメントにある全てのオブジェクトタイプをProperties パネルに含めるには、 ボタン(左のボタン)をクリックします。

現在のドキュメントのみにある全てのオブジェクトタイプを Properties パネルに含めるには、 ボタン(右のボタン)をクリックします。

View Configuration パネル

View Configuration パネルでは、PCBのレイヤや、それに関連した色、表示設定、3D設定、マスクを編集、コントロールできます。また、レイヤペア等の、より複雑な操作を容易に行えます。

View Configuration パネルでは、PCB ドキュメントのレイヤをコントロールできます。

パネルの上部にある Search 機能は、目的の項目をパネル内で検索できます。

レイヤの有効/無効

下図に示すように、各レイヤグループのコントロールを切り換えて、1 つのレイヤ、複数のレイヤ、全てのレイヤを有効、または無効にすることができます。 


ハイライト表示されたコントロールを使用して、レイヤグループを有効、または無効にすることができます。この例では、Component Layers は、全て有効であることを示しています。

下図に示すように、上部のコントロールを使用して、全体のレイヤを有効/無効に切り換えできます。


ハイライト表示されたコントロールをクリックすると、グループ全体を切り換えできます。上図では、Component Layers全ての項目が有効になっています。

下図に示すように、コントロールを切り換えて、各グループの個々の項目を有効、または無効にすることもできます。


Component Layers グループのハイライト表示された個々の項目は、無効になっています。

オブジェクトの表示

View Options タブの Object Visibility 領域を使用して、オブジェクトの透過表示をコントロールできます。

3D 設定

View Options タブの 3D Settings 領域は、3D 表示を設定するために使用します。

 

3D Settings 領域を表示するには、下図に示すように、General Settings 領域の 3D 設定を On に設定する必要があります。

 

Mask と Dim 設定

View Options タブの Mask and Dim Settings 領域を使用して、マスク、輝度(dimming)、ハイライト設定を行えます。

その他のオプション

View Options タブの Additional Options 領域では、Net Color Override を含む様々な表示設定を行えます。

既存のパネルの変更

Projects パネル

  • Projects パネルには、Navigator パネルにもある多くの機能が含まれています。
  • Projects パネルの左上にある新しいコントロールでは、ワンクリックでその機能を実行できます。

Projects パネルでのコントロール

  • ボタンを使用して、現在のドキュメントを保存できます。このオプションは、現在のドキュメントを変更した場合のみ利用できます。
  • ボタンを使用して、現在のプロジェクトをコンパイルできます。
  • ボタンを使用して、Project Options ダイアログを開けます。
  • ボタンを使用して、ドロップダウン(下図に示した)からパネルに関する設定を行えます。

  • 新しい Search 機能は、パネル内の特定のドキュメントを検索できます。この機能は、Search テキストボックスに文字を入力する時に "フィルタ" として働きます。

    
Projects パネルの新しい Search 機能(左図); 動作中の新しい Search 機能(右図)。

  • ComponentsNets 用のフォルダは、プロジェクトをコンパイルした後、Projects パネルに表示されます。


ComponentsNets フォルダは、プロジェクトをコンパイルした後、Projects パネルに表示されます。

  • Document Status - ドキュメントを開いている、変更した状態を示す、ドキュメント名の右にあったインジケータは、削除しました。

Projects パネルでの右クリックメニュー

Projects パネルでの右クリックメニューを合理化し、以下で説明するように、右クリックを実行した項目に関するコマンドのみが表示されます。

  • ワークスペースの右クリックメニュー

  • プロジェクトの右クリックメニュー

  • 回路図ドキュメントの右クリックメニュー

  • PCB ドキュメントの右クリックメニュー

  • 回路図と PCB ドキュメントを開いて、それらに関する Properties パネルを同時に表示できます。これは、2つのモニターを使用している時、特に役立ちます - 回路図で 1 つのモニター、PCB で 1 つのモニター。各ドキュメント用の Properties パネルを開いて、リアルタイムで変更、表示できます。

PCB ActiveRoute パネル


より効果的な PCB ActiveRoute パネル。

PCB ActiveRoute パネルを強化し、より幅広い配線を行えます。

SCH Filter パネル 

 

  • Mask out オプションにスライダーバーを追加し、レベルをコントロールできます。

削除したパネル

  • 3D Visualization - 使用頻度が少ない。
  • Board Insight - 使用頻度が少ない。
  • Clipboard - 使用頻度が少ない。
  • Compiled Object Debugger - 使用頻度が少ない。
  • Favorites - 使用頻度が少ない。
  • Files - 使用頻度が少ない。
  • PCB Inspector - Properties パネルに移行しました。
  • PCBLIB Inspector - Properties パネルに移行しました。
  • Sch Inspector - Properties パネルに移行しました。
  • SCHLIB Inspector - Properties パネルに移行しました。
  • Sheet - 使用頻度が少ない。
  • Shortcuts - コンテキスト依存のショートカットの詳細は、Properties パネルに表示されます。
  • To-Do - 使用頻度が少ない。

オブジェクトの削除

削除した回路図オブジェクト

  • Hyperlink - 使用頻度が少ない。機能は、テキストストリングへ統合しました。
  • Elliptical Arc - 使用頻度が少ない。
  • Manual Junction - 使用頻度が少ない。
  • Test Vector Index Directive - 使用頻度が少ない。

 

回路図エディタで、上記リストのオブジェクトを配置できませんが、以前のデザインで使用していた場合、そのオブジェクトは含まれます。ただし、そのオブジェクトやプロパティは、編集できません。

 

削除した PCB オブジェクト

  • Coordinate
  • Design View

以下の Dimension オブジェクトを削除しました:

  • Baseline Dimension
  • Center Dimension
  • Datum Dimension - Ordinate dimension オブジェクトに変わりました。
  • Linear Diameter Dimension
  • Radial Diameter Dimension

削除した Flipped on Layer プロパティ

コンポーネントのプロパティから Flipped on Layer プロパティを削除しました。コンポーネントのレイヤに関する 方向 は、Layer Stack Manager ダイアログで定義します。

バリアントの作業に関するコントロール

バリアントを使用するには、Projects パネルからコントロールします(Variants ツールバーは、削除しました)。以前のように、Projects パネルにある目的のプロジェクトを右クリックしてから Variants コマンドを選択して、Variant Management ダイアログを表示できます。必要に応じて、バリアントを定義してから OK をクリックします。パネル内のそのプロジェクト下に Variants フォルダが作成されます。そのフォルダには、ベースデザインのバリアント ([No Variations]) や定義した全てのバリアントが含まれます。現在のバリアントは、下図に示すように、太字、白文字で表示されます。リストにある任意のバリアントをアクティブにするには、目的のバリアントをダブルクリックするか、または右クリックし Set as current を選択します。


現在のバリアントは、Projects パネルで太字、白文字で表示されます。

Active Bar

新しい Active Bar から、よく使用する配置、配線コマンドを利用できます。Active Bar により、回路図、PCB、Draftsman、ライブラリ ドキュメントでオブジェクトを容易に配置できます。また、メインメニューを使用しないで、ワンクリックで PCB ドキュメントで配線を行えます。ツールバーのコントロールは、現在、作業しているエディタに依存します(例を下図に示します)。ツールバーは、デザイン ワークスペースの上部中央に表示されます。

 

ツールバーのコントロールをクリックすると、すぐ配置モードになり、カーソルが十字に変わります。

コントロールするためのドロップダウンを表示するには(右下の小さい三角で示された)、ツールバーのコントロール上で右クリック、またはそこにカーソルを置き、左クリックし続けます。それから、利用できるオプションを選択できます。配置のために、カーソルは十字に変わります。

Active Bar からオブジェクトを使用した後、ボタンは、そのオブジェクトに変わります。

 


Place Wire ドロップダウンを示す、回路図ドキュメントの新しい Active Bar


Place Polygon ドロップダウンを示す、PCB ドキュメントの Active Bar


 Line ドロップダウンを示す Draftsman ドキュメントの Active Bar

 


Place Line ドロップダウンを示す回路図ライブラリ ドキュメントの Active Bar

Quick Access バー

Quick Access バーは、ワークスペースの左上にあります。このバーで、現在、フォーカスしたドキュメントを保存、既存のドキュメントを開く、undo や redo 機能等、よく使用するコマンドに素早くアクセスできます。また、 ボタンを使用して、ワンクリックで全てのドキュメントを保存できます。


Quick Access バーを使用して、素早くドキュメントを保存、開いたり、undo、または redo を実行できます。

システムの通知

新しい Notifications ボタンは、下図に示すように、ワークスペースの右上で利用できます。 をクリックして、Altium Designer システムの通知を確認できます。通知を利用できる時、アイコンは数字で表示されます。


Notifications ボタンを使用して、システムの通知を確認できます。

その他の GUI の変更

  • Snap ボタンを PCB エディタから削除しました。Snap Options は、ワークスペースで何も選択していない時、Board モードの Properties パネルから設定します。


Properties パネルの Snap Options

  • 回路図の Editor タブでの Dimming は、Preferences ダイアログの System - Navigation ページにある Highlight Methods 領域で定義します。

  • PCB エディタから Mask Level ボタンを削除しました。マスク(PCB での輝度、ハイライトも含む)は、View Configuration パネルの View Options タブにある Mask and Dim Settings 領域で定義します。


View Configuration パネルの Mask と Dim 設定  

  • mechanical レイヤの Linked To Sheet オプションを削除しました。
  • ドキュメントを非表示にする機能を、ドキュメント タブでの右クリックメニューから削除しました。
  • Clear ボタンを削除しました。
  • Home ページ(StartWorkspace ("Sea of Documents" と呼ばれます)、DocumentationAdmin タブ)を削除しました。以前の Admin タブにあった情報については、このドキュメントの Accessing License Management の項目を参照してください。

 

English
Labels
  • None