Altium Wiki

Information and resources for electronic product designers

Skip to end of metadata
Go to start of metadata
You are viewing an old version of this page. View the current version. Compare with Current ·  View Page History
Summary

This application note highlights the key concepts you need to be aware of when moving from Cadence Allegro PCB <sup>®</sup> to Altium Designer. It identifies Altium Designer's functionality and how to get started - helping you ramp up your productivity and quickly take advantage of this powerful and flexible electronic product development environment.


You've made the switch to Altium Designer – a single, unified application that incorporates all the technologies and capabilities necessary for complete electronic product development – and now you're keen to get on with the design process. This application note gives you a jump start on the basics of designing in Altium Designer. It also shows how easy it is to transfer your Allegro PCB designs into Altium Designer.

Getting Started – Converting Your Allegro PCB Designs

The translation of Allegro Design files can be handled by Altium Designer's Import Wizard. Complete flexibility is found in all pages of the wizard, giving you as little or as much control as you would like over the translation settings before committing to the actual translation process.
 

The Allegro2Altium.bat file and the AllegroExportViews.txt file are located in the \System folder of Altium Designer installation.

The Import Wizard handles both Allegro PCB Design files (*.brd) and Allegro ASCII Extract files (*.alg). If you have Allegro PCB Editor versions 15.2 or 16 installed, you can directly translate Allegro PCB Design files (*.brd) into Altium Designer PCB files (*.PcbDoc).
Allegro ASCII Extract files (*.alg) are created using the Allegro PCB Editor, plus the Allegro2Altium.bat and AllegroExportViews.txt files included in your Altium Designer installation. Once these ASCII Extract files have been created, you can translate them into Altium Designer PCB files (*.PcbDoc) on machines that do not have Cadence Allegro PCB Editor installed. The Allegro2Altium.bat file and the AllegroExportViews.txt file are located in the \System folder of Altium Designer installation.

The benefit of this, is that you only need one licensed copy of Cadence Allegro PCB Editor to convert all of your designs into Allegro ASCII Extract files (*.alg), which can then be distributed to other team members for translation.

Using the Import Wizard to Convert Allegro PCB files

The Import Wizard can be launched from the Altium Designer's File menu. Choose Allegro Design Files from the list of File Types.
Files in the Import Wizard translate as follows:

  • Allegro Binary PCB Design files (*.brd) translate to Altium Designer PCB files (*.PcbDoc).
  • Allegro ASCII Extract Files (*.alg) translate to Altium Designer PCB files (*.PcbDoc).
    Alternatively, drag your Allegro Design Files into the Projects Panel which will automatically launch the wizard in Allegro Import mode.

Figure 1. Use the Import Wizard to convert Allegro PCB files into Altium Designer PCB files

Follow the pages of the Import Wizard to customize and complete the conversion of your Allegro Design Files.

Importing Allegro Designs


Use the Add button on the Importing Allegro Designs page to load the Allegro Design files (*.brd) or (*.alg) for processing. Click on the Next button to continue through the wizard.

Note: If you to attempt to add Allegro Design Files (*.brd) to the Import Wizard and you do not have Cadence Allegro installed, the following warning will be displayed:

Analyzing Files

The Analyzing Files page is where each Allegro file is analyzed by the Import Wizard to check if the data is valid and if it can be translated.

The Buttons will become active when the analysis of the files is complete.

Reporting Options

Use the Reporting Options page to enable or disable the settings for logging all errors, all warnings and all events respectively.

A Log Report in ASCII file format (*.LOG) is generated for each translated Allegro PCB file. This log is saved in the \Imported sub folder of your original Allegro files. Open the Log Report after translation in a text editor to examine the details.

Default PCB Specific Options

Specify Polygon Connect and Plane Connect Options for the PCB import process. Enable the Import Auto-Generated Copper Pour Cutouts option to import the voids that are auto generated in Allegro PCB Editor as cutouts when the file is translated. The default options are displayed below.

Current PCB Layer Mappings

All used Allegro PCB layers must be mapped to an Altium Designer layer prior to import when using the Import Wizard. Layer Mapping is a mapping between the names of the Allegro PCB layers and Altium Designer PCB layers.

Figure 2. Use the Layer Mapping Options from the Menu button or the Pop up menu in the Import Wizard to associate Allegro PCB layers to Altium Designer layers.

Default mapping is provided by the Import Wizard to build the layer mapping for each PCB. Layer mapping can be customized for each of your designs to be imported. You may wish to import multiple Allegro PCB designs and map the same Allegro layer to the same Altium Designer layer. You can set your layer mapping once and use this layer mapping for all of your files to be imported.
The advantage of importing in this manner is that batch layer management can save time when importing multiple designs. The disadvantage to using this is that Default Layer Mapping is not always intelligent with differing structures in designs, and so some manual changes may be required.
Use the Menu button on the Import Wizard or right click on the Allegro and Altium Designer Layer Mapping List to manipulate the layer mapping of Allegro PCBs to Altium Designer PCBs. The Invert Selection menu item inverts the items that were selected to not selected and those that were not selected to selected in the Layers list of the Wizard. This is a handy way to quickly choose layers to map to Altium Designer layers.
You can use the Load and Save Layer Mapping Configuration files using the Load Layer Mapping and Save Layer Mapping menu items respectively to quickly apply layer mapping for Allegro and Altium Designer layers.

Current PCB Options - Reviewing the Output Project Structure


Each of the imported Allegro Design Files are located in a separate sub directory in a specified Project Output Directory. You can further customize the PCB projects by dragging Allegro Design filenames to other Projects in the PCB Projects list.

Output PCB Projects

The Output PCB Projects page is where each Allegro PCB is converted to an Altium Designer PCB document (*.PcbDoc) in a design project. This process can be time consuming due to intensive tasks such as loading geometry data, translating nets and components and generating vias and copper pour polygons. You can monitor the status bar on the bottom of Altium Designer workspace to see which operation is taking place. Please wait until the Cancel, Back, Next and Finish buttons are enabled to indicate the processing is complete.

Completion

If the translation process is successful, the Wizard is completed. You can click to close the wizard and start working on your translated PCB design in Altium Designer. Cleanup will be performed on this translated PCB document first before you can perform edits on it.
Read on to find out more about Altium Designer and your PCB designs.

The Altium Designer Environment

The Altium Designer environment offers a complete electronic product development environment for all areas of design – from schematic capture to the generation of PCB output, as well as complete FPGA design, development and on-chip debugging.
The environment is fully customizable, allowing you to set up the workspace to suit the way you work. Consistent selection and editing paradigms across the different editors allow you to easily switch between various designs tasks all within the Altium Designer environment.

User Interface Elements

Perhaps the single biggest difference that you will notice when you start working in Altium Designer is that there is only one application used to create and edit all design files, regardless of the type of file – schematics, PCB, library, text, and so on. No longer will you have to switch between different applications when you want to move from viewing the schematic to the PCB. All the files (referred to as documents which are described further below) open in the same executable, each appearing on a separate document Tab within Altium Designer.

Figure 3. As you move from one type of document to another from the Projects panel, the menus and toolbars automatically switch, giving you the right editing environment for that document.

Altium Designer has full support for multiple monitors too. If you have multiple monitors on your PC you can easily drag a document out of Altium Designer and drop it on the second monitor, greatly enhancing your design productivity.
To get you started let's review some of the basic terminology that you'll need to know as you work in Altium Designer.

Working with Documents

In Altium Designer, the logical design area begins with a document, and for each document there is a file stored on the hard drive. This means that for each Altium Designer PCB document there is a file, an important conceptual difference to remember.
There can also be multiple design documents of varying types, depending on the nature of the design you are working on.

Figure 4. Basic file operations: new PCB and schematic document types can be easily created via File » New, or by right-clicking on the project in the Projects panel.

Accessing Your Project Documents

All design documents and generated output files, including your translated PCB design files, are stored as individual files on your hard disk. Your design documents can be accessed by opening the project first and then opening the individual documents or any individual document can be opened directly, using the File » Open menu command.

Workspace Panels

Workspace panels are a basic form of the Altium Designer user interface. Whether specific to a particular document editor or used on a more global, system-wide level, they present information and controls that aid your productivity and allow you to design more efficiently.

Accessing Panels

When Altium Designer is first started, a number of panels will already be open. Some panels, including the Files and Projects panels, will appear grouped and docked to the left side of the application window. Others, including the Libraries panel will be in pop-out mode and appear as buttons on the right-hand border of the application window.
You will also notice that your translated files will be grouped somewhat differently than you are used to seeing. Whether you need to open a specific document such as a schematic, or need information or control to design on a more global, system-wide level, it can all be done using the Projects panel.
As you open and make active the documents within various editors you will notice that the resources and available panels will change dynamically; the menus, available panels, and toolbars will quickly change to match the document type you are currently focused on for editing. You'll want to familiarize yourself with how to access these panels, manage, group, and control your display modes to get the most out of the productivity features that are provided here. Press F1 when the cursor is over a panel for more information on that panel.

Figure 5. At the bottom of Altium Designer window are a number of buttons that provide quick access to the available workspace panels, in context with the Document Editor that you are using.

Projects Panel

Altium Designer also features project management capabilities but there are conceptual differences you'll need to get firm in your mind first. The Altium Designer approach to managing your project is that all design documents (schematic, PCB, libraries, etc.) are linked to the project file, both for management and access to certain design features such as design verification, comparison, and synchronization.
The Altium Designer presentation through the Projects panel provides high visibility and a complete view of everything you need in your project, not just the schematic part of it. The project file, which is what you are viewing in the Projects panel, contains links to all your documents in your design, as well as any other project-level definitions.
The essential concepts of project-based design are discussed later in the Project-based design section.

Figure 6. The Storage Manager panel is invoked via the System button at the bottom of the Altium Designer window.

Storage Manager Panel

Altium Designer features a dedicated Storage Manager panel to allow you greater control over the management of files in your projects. It allows you to navigate the active project in terms of its file storage in Windows.
Not only can you see immediately which documents are part of the project and where they are stored, but also see other files that are stored but not explicitly added to the project. The Storage Manager is multi-functional and can be used for everything from general everyday file management tasks such as renaming or deleting files, management of backups, through to integrating with your company's version control system.
Your project file is listed at the top of the panel in the Folders region, corresponding to the root directory, with all other folders and sub-folders contained within that directory displayed below, in their storage hierarchy.
This Files in Project region of the panel lists all documents currently stored in the root directory or sub-folder thereof, for the active project.
If the active project in the Folders region of the panel is under version control and you are using either the CVS or SVN version control systems, then selecting a document belonging to that project (in the Files region of the panel) will populate the VCS Revisions region with a history list for that document.
The Local History region presents a local history for the currently focused document in the Files region of the panel.

Figure 7. The Storage Manager panel has four key regions: Folders, Files in Project, VCS Revisions, and Local History.


Navigation Toolbar – Document Navigation

You can have many design documents and projects open at any time, so Altium Designer provides a Navigation toolbar to find the specific design you need quickly. Since everything is integrated into Altium Designer there is no need to switch to another application when you need to view a different type of design file. The Navigation toolbar is available to assist in the direct navigation of design documents, and can be accessed at any time from within any of the document editors.

 

Browsing Viewed Documents

The field at the left of the bar allows you to navigate to any directory or document on a network or local storage directly, as well as any page on the internet. Browsing previously-viewed documents is easy using the left and right arrow buttons to go forward and back through previous area, just as you would within an Internet Browser.

Integrated Navigation Home Page

Click the Home Page button to access the Navigation Home Page, a top level page where all navigation support pages can be accessed as well as product updates and the Altium SUPPORTcenter.

Figure 9. The Navigation Home Page.

Favorites

Like an internet browser, Altium Designer supports the concept of defining Favorites. Once the Favorites panel is displayed (via the System button on the status bar) you can right-click in the Favorites panel to mark the current view of the active document as a favorite. Double-click on a favorite to return to that document, zoomed to the exact area and location you require.
As well as views of documents in your design, favorites can include links to any directory or  document on the network or local storage, as well as any page on the internet.

Immediate Access to Help

For further information about the Favorites panel as well as many other topics in Altium Designer, open the Knowledge Center panel (click the Help button on Status line). When the Knowledge Center panel is open it will auto-load help on the object, command, or menu entry currently under the cursor if you pause, or you can press F1 to load the topic immediately.

Project-based Design

Figure 10. The Projects panel is your view into your project. Right-click in the Projects panel to access all project-related commands.

Now that we've covered some of the basics of the Altium Designer environment, it is time to talk about designing. The starting point for every design created in Altium Designer is a project file.
It's a simple and important concept – an Altium Designer project is a set of design documents whose output defines a single implementation. For example, the schematics and PCB in a PCB project output the fileset required to manufacture a single printed circuit board, while the schematics (and HDL) in an FPGA project output the fileset required to program a single FPGA. The project file brings together all of the design documents that make up the project.
Altium Designer supports a number of different types of projects, including: PCB, FPGA, Embedded Projects, Core Projects, Integrated Libraries, and Script Projects.

Project File Role

The project file stores all project-relevant settings, including a link to each document in the project, and all project-relevant settings. Each document in the project is stored as a separate file, which is linked to the project via a relative reference for files on the same logical drive, or an absolute reference for files on a different logical drive. Outputs generated from the project are also referenced in the project file.

The exact set of project options stored will depend on the project type. It will include those options configured in the Options for Project dialog, such as:

  • Compiler error check settings
  • Design synchronization settings
  • Design compiling settings
  • Location of output files
  • Multi-channel annotation settings
  • Output settings such as reports, print Gerber, etc...

Projects Panel Role

The Projects panel is one of the more commonly-used panels in day to day work. It allows you to make changes to your project options, add to and remove documents from the project, change the display options of projects, change the order of documents within a project, or even how you would like to display information in the Projects panel.
All of your translated design files will appear in the Projects panel, organized into their respective projects that were automatically created for them. The environment also supports multiple projects being open at the same time. These can be unrelated projects, or related.

Compilation – a Cornerstone of Altium Designer

Compilation is a cornerstone concept of the Altium Designer environment. Compilation is a process that allows you to harness many powerful design features.
When you select Project » Compile Project the compilation process works out the structural relationships between the source schematic (or HDL) documents in the project, then determines the net-level connectivity within each sheet, and finally the connectivity between the sheets. All this component and connective intelligence from your schematics design is written into an internal data structure that can then be used for many post-compilation activities, such as comparing and showing differences between schematics, parameter managing, parametric navigation of your design, cross probing back and forth between the schematics and PCB, and much more.

Where are my nets and components from my design?

You're going to notice that connectivity is not as explicit in your design as it was before, but rather has to be extracted from the design using the compilation process. This is available through the right-click menu in the Projects panel, or using the Project » Compile Project menu command.
Once the design is compiled the sheet-level hierarchy, as well as all the components, nets and buses are displayed in the Navigator panel. From here you can easily locate any component, bus, net or pin throughout the entire design. And if you hold the Alt key as you click on an object in the Navigator panel it is highlighted on the PCB as well as the schematic – no longer will you need to inspect net lists to review design connectivity.

Verifying Your Design – Expanded Error Checking

Another benefit that results from compiling a project in Altium Designer is built-in error reporting. This is completely configurable for your needs and can be done before your project is compiled. Right-click either on the project file and invoking the Project Options command, or also through the Project menu.

Figure 11. The Error Reporting tab in Project Options dialog.

PCB Layout and Design

With increasing component densities and faster signal speeds and transitions, successful board layouts today rely on design systems that unify the design definition with the physical layout and routing. Altium Designer offers such a PCB system which includes a number of familiar features to help you place and route your board.
But unlike the Allegro PCB environment, these capabilities are available in a less constrained way – smoothing your design process by peeling away design complexity and allowing you to navigate and manipulate your design easier. For example, you can place objects at anytime and start a route anywhere without ever having to switch modes. The PCB Editor environment of Altium Designer features innovative panels and dialogs efficiently designed for selection and editing of objects in large, dense designs.

PCB Editor Environment

When the PCB Editor is active (i.e. a PCB document (*.PcbDoc) is open and active) the main application window will contain:

  • A main design window in which you can start designing, capable of display in both 2D and 3D
  • menus and toolbars that are specific to the PCB Editor
  • workspace panels that are both global and editor-specific

Figure 12. Any object placement, routing, or graphical editing is carried out on the PCB document which appears as a tab in the main design window.

Placing Design Objects

Many of the equivalent placement and routing commands in Altium Designer that you'll be interested in are located in the Place menu of the PCB Editor. Whether you are placing arcs, circles, pads, via, components, polygon pours, or are interactively routing, it can all be done from this menu.
By comparison, the Design menu in Altium Designer has a different conceptual context and contains command more relevant to the actual design or design process as a whole. Design synchronization, rules, the Layer Stack Manager, Netlist, and Board Options are a few examples of the available commands.

Editing Design Objects

Figure 13. You can instruct to match target objects based on object attributes.

Design objects in Altium Designer must also be selected first to be edited and there are a number of ways of selecting objects depending on your need. The Windows standard mouse click shortcuts can be used. This includes placing the cursor over and object and left-clicking to select one object. Holding the left-mouse button down and dragging a selection rectangle will select all the objects within an area. In addition to these standard selection methods, there is a new specialized dialog and panel designed specifically for selecting and editing multiple objects.

Find Similar Objects Dialog

To select many objects, including those spread out over a dense design, you can use the Find Similar Objects dialog (Figure 13). Right-click on one of the objects being edited and select Find Similar Objects from the right-click popup menu. Only documents which are open in the project are affected by any changes you make in this dialog.

PCB Inspector Panel

Unlike anything you may have seen in Allegro PCB Editor, the PCB Inspector panel (Figure 14) displays the properties of whatever you have selected. This could be one object or many objects. The PCB Inspector panel enables you to navigate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, this panel can be used to make changes to multiple objects of the same kind from one convenient location.

Figure 14. When you type a value into the PCB Inspector and press ENTER, the value of that property is changed for all selected objects.

The PCB Inspector panel has some handy qualities for everyday use. Unlike Allegro PCB where you must open dialogs to edit, the Inspector is a panel and can be visible all the time – much more efficient if you are making many reviews in your design. It can also display the common properties of different objects and let you edit them.
The panel is basically divided into two main regions:

  • Filtering controls to define which objects are displayed in the panel (display scope).
  • Sections of attributes for objects falling under the defined display scope.
    Selected objects can be of the same or differing type. Common properties that have the same value will show that value, otherwise the value will display <...>.

Setting Up the Workspace

Getting your workspace set up after transferring your design is relatively straightforward. However, you should be aware that environment settings offer substantially more control compared to the Allegro PCB Editor and have some differences in naming.
Environment settings which are global to all PCB documents in any editor are called Preferences while those that pertain to an individual PCB document are called Board Options. They are located in different menu locations.
In Altium Designer, the Preferences dialog is also found under the Tools menu, as well as the DXP menu for convenience. Remember that these are only global settings. Document-specific settings and anything relevant to the design itself are located under the Design menu.
These settings are apt to much more comprehensive than you've seen before as they incorporate all document editors and all phases of electronic design. Having everything in one location and accessible in a tree-like navigation structure allows you to quickly and efficiently set system-wide preferences and gives you greater control over your working environment.

PCB Preferences – Global Settings

Altium Designer centralizes the setting of environment options across all document editors within a single context-sensitive and comprehensive dialog – the Preferences dialog (Figure 15). Accessible from Tools » Preferences [shortcut T, P], it features a tree-like navigation structure.
Some examples of system preferences that may be found here include those that assist in positioning components easier such as Online DRC, Snap to Center, and Selection preferences.

Figure 15. Changing any of the Preferences will affect all PCB documents you work on.

PCB Board Options – Document Settings

All options for the placement grid, measurement units, sheet position, and designator display are found in the Board Options dialog. With a PCB document active in the main design window (for this and all of the following context-sensitive dialogs), select from the main menu Design » Board Options [shortcut D, O] to open the Board Options dialog.

$body

Importing Your Design Rules

Altium Designer allows you to transfer your favorite design rules from another board. Design rules can be exported from, and imported to, the PCB Rules and Constraints Editor dialog (Figure 17).

Figure 17. To Import, select Import Rules from the pop-up menu. The Choose Design Rule Type dialog will open.

View Configurations (Layers and Colors)

View configurations are settings that control many PCB workspace display options for both 2D and 3D environments, and apply to the PCB and PCB Library Editors. The view configuration last used when saving any PCB document is also saved with the file. This enables it to be viewed on another instance of Altium Designer using its associated view configuration. View configurations can also be saved locally and be used and applied at any time to any PCB document. Any PCB files that you open which do not have an associated view configuration are displayed using a system default one.
Note: The View Configurations dialog provides access to 2D color settings for layers and other system-based color settings – these are system settings, that is, they will apply to all PCB documents and are not part of a view configuration. Color profiles for the 2D workspace can also be created and saved, similarly to view configurations, and can be applied at any time.

Select Design » Board Layers & Colors [shortcut: L] from the main menu to open the View Configurations dialog (Figure 22).

This dialog enables you to define, edit, load and save view configurations. It has settings to control which layers to display, how to display common objects such as polygons, pads, tracks, strings etc, displaying net names and reference markers, transparent layers and single layer mode display, 3D surface opacity and colors and 3D body display.
You can apply view configurations using the View Configurations dialog or by selecting them directly from the drop-down list on the PCB Standard toolbar.
You can quickly navigate between the layers of your design by selecting the layer tabs at the bottom of the main design window. Helpful shortcut keys from the numeric keypad include the '+' and '--' for cycling through all visible layers, and the ' * ' to cycle through visible signal layers.

Layer Stack Manager

Designed to give you immediate visual feedback about how your layer stack-up is defined, the Layer Stack Manager is found in Design » Layer Stack Manager [shortcut D, K]. The Layer Stack Manager offers in a visual 3D format.

Figure 18: The Layer Stack Manager dialog shows a cross-section of the board as you design. Layers may be added or redefined in this dialog.

Layers are easily managed from here. You can associate nets to planes, change the number of layers, define layer and substrate thickness and reassign electrical layer data.

Enabling Specific Layers

Enabling or disabling layers for routing is treated as a rule in Altium Designer. It is easily found in the PCB Rules and Constraint Editor dialog under Design » Rules.

Figure 19. Selecting the Routing rules from the PCB Rules and Constraint Editor dialog will allow you to set a constraint for enabling or disabling layers for routing.

Defining Layer Routing Direction

Routing direction for each enabled signal layer in the design is defined as part of the Situs Autorouter setup. A little more configuration is required to do this than you may have done in the past. First you must first ensure that there is a Routing Layers rule with a Query of All. All enabled signal layers (as defined in the Layer Stack Manager) will be listed. Layer directions can then be defined in the Layers Directions dialog which is accessed by Auto Route » Setup » Edit Layer Direction.

Figure 20: Defining the primary routing direction for layers to suit the flow of connection lines. Situs uses topological mapping to define routing paths, so it is not constrained to route horizontally or vertically.

Should you wish to exclude a particular net (or class of nets) from being routed by the autorouter, simply define a Routing Layer rule targeting that net or net class and, in the Constraints region for that rule, ensure that the Allow Routing option for each enabled signal layer is disabled.

Interactive Routing

Altium Designer also has interactive routing modes for interactive routing. Modes for interactive routing are not dependent on licensing options, and are all available in the PCB Editor.
The PCB Editor in Altium Designer is a connectivity-aware design environment. At all stages of routing your design, the software monitors and manages net list connectivity. Because the connectivity Analyzer automatically monitors the completion status of the net you are routing, you can route without regard to the arrangement of the from-tos. Once you complete a connection, the entire net is reanalyzed and connection lines are added and reoptimized as necessary.
The PCB Editor also features a sophisticated "look-ahead" feature that operates as you place tracks. The track segment that is connected to the cursor is called a look-ahead segment and is shown in outline/draft mode as you move the cursor. The segment between this look-ahead segment and the last-placed segment is the current track that you are placing (shown in final mode).
The three interactive modes are all available in the Place and right-click menus.

Standard Interactive Routing Mode

 
Standard Interactive Routing can be started from Place » Interactive Routing and allows you to place down track segments to define a routing path. It monitors where you click and applies all applicable design rules and updates the connectivity as soon as you finish a route. Interactive Routing shortcuts are shown in Table 2 at the end of this document.
You must have a signal layer active before you can begin routing. Display the layer that you would like to start on by enabling the Show checkbox for the layer in the View Configurations dialog [shortcut L]. Once you are displaying the signal layer, the tab for it will display in the main design window. Click on the Layer tab at the bottom of the workspace to make it the current (active) layer, ready to route on.

Via On Layer Change

Press the * key on the numeric keypad to change to another signal layer while routing. A via will automatically be inserted, the properties of the via are determined by the applicable Routing Via Style design rule.

Setting Up the Routing Layers

Routing layers, also referred to as signal layers, are set up in the Layer Stack Manager dialog (Design » Layer Stack Manager). Use the dialog controls to add layers and set their location in the layer stack.
The display of all layers, and the addition of mechanical layers, is controlled through the View Configurations dialog (Design » Board Layers & Colors).

Figure 22. The display of all layers is controlled in the View Configurations dialog.


Interactive Routing Mode

Interactive Routing is a more intelligent interactive routing mode, working in a more intuitive way while attempting to completely route the chosen connection along the shortest path. It can use horizontal, vertical, and diagonal segments while automatically walking around obstacles along the path. Interactive Routing can automatically complete the entire connection if both the start and end nodes are on the same layer, while maintaining any applicable design rules.

Select Place » Interactive Routing from the menu to start routing, or select the command from the right-click menu.
Since Altium Designer's routing tool is interactive, you control the behavior using the cursor and the built-in shortcuts. It has a basic mode of operation where it will attempt to route up to the current cursor location as you move the mouse around the workspace, without clicking to commit track segments. Reaching the target end point, a click on the pad will complete the route.
Also available while interactive routing is auto-complete where it will attempt to seek out a path from the connection start point to the end point and attempt to route it. Use the shortcut, CTRL+Click on a pad or connection line to auto complete it or press the shortcut while in the middle of routing a connection, and the entire connection is routed! Interactive Routing shortcuts are shown in Table 2 .

Differential Pair Routing Mode

Differential pairs are routed as a pair – that is, you route two nets simultaneously. To route a differential pair, select Place » Differential Pair Routing from the menu. You will be prompted to select one of the nets in the pair, click on either to start routing. Figure 26 shows a differential pair being routed. To make the connection lines for the pair easier to see, click on the pair in the Differential Pairs Editor (PCB panel). This will mask all other nets in the design.
Differential pairs are routed using Altium Designer's Smart Interactive Routing mode, which is described earlier in this document. Standard routing shortcuts remain, such as pressing the * key on the numeric keypad to switch to the next routing layer. During differential pair routing, the Smart Interactive Routing shortcuts are also available, as shown in Table 3 .
But before you can route, differential pairs must be first defined.

Defining Differential Pairs on the Schematic

Differential pairs are defined on the schematic by placing a differential pair directive (Place » Directive) on each of the nets in the pair. The net pair must be named with net label suffixes of _N and _P. Placing a differential pair directive on each pair net applies a parameter to the net, which has a parameter Name of DifferentialPair and a Value of True.
Differential pair definitions are transferred to the PCB during design synchronization.

Figure 24. Place directives on the schematic to define differential pairs.

Defining Differential Pairs on the PCB

Differential pairs should be defined on the schematic, however, differential pair objects can be defined in the PCB Editor.
To create a differential pair object, select Differential Pairs Editor mode in the PCB panel and click the Add button. From the resulting Differential Pair dialog (Figure 25), select existing nets for both the positive and negative nets, give the pair a name and click OK.

Figure 25: Create a pair on the PCB using the Differential Pair dialog.

You can also create differential pair objects using net names conforming to a naming convention with a common prefix, followed by a consistent positive/negative suffix, for example, TX0_P and TX0_N. To do this, click the Create From Nets button in the PCB editor panel to open the Create Differential Pairs From Nets dialog. Use the filters at the top of the dialog to show net pairs, based on existing net names.

Figure 26: Both nets in the differential pair are routed simultaneously.

Viewing and Managing the Pairs

Differential pair definitions are viewed and managed in the PCB panel, set to Differential Pairs Editor.

Using the Differential Pair Wizard to Define the Rules

Clicking the Rule Wizard button in the Differential Pairs Editor (PCB panel) will walk you through the process of setting the required design rules. Note that the scope used for the created rules will depend on what was selected when the Rule Wizard button was clicked – if one pair was selected the rules will target the nets in and that pair, but if a differential pair class was selected then the rules will target the nets in and all pairs in that class.

Optimizing and Controlling Net and Differential Pair Lengths

Tuning and matching route lengths is a standard technique for maintaining data integrity in a high-speed digital system, and an essential ingredient of differential pair routing.
Interactive Length Tuning and Interactive Diff Pair Length Tuning features (launched from the Tools menu) allow a dynamic means of optimizing and controlling net or differential pair lengths by allowing variable amplitude wave patterns to be inserted according to the available space, rules, and obstacles in your design. Length tuning properties can be based on design rules, properties of the net, or values you enter into a dialog (press TAB to open dialog whilst interactively length tuning).
Once you have launched the command, click on the routed net or differential pair and move the mouse along it to add tuning segments. The interactive length tuning cursor provides you with information during the tuning process including before and current track lengths as well as a graphical representation to gauge how close you are to the ideal lengths. The yellow cursor bars indicate the possible minimum and maximum lengths. The green bar indicates the target length, as determined from the applicable Matched Length and Max Length design rules, or the settings in the Interactive Length Tuning dialog (Figure 27). The sliding indicator shows how close you are to achieving a match.
The interactive length tuning tools can be configured for:

  • Target Length
    - can be specified either according to design rules, another net, or manually. The Clip to target length checkbox will precisely clip mitered wave patterns to the target length.
  • Pattern – wave styles are mitered with lines, mitered with arcs, and rounded. You have control over amplitude, gap and dynamic amplitude increments. It is possible to have more than one pattern on a net.
    While interactively length tuning you can vary any aspect of the length tuning parameters. Press the ~ (tilde) key during length tuning to display the available shortcuts, or refer to Table 4 at the end of this document.




Figure 27. Current length as well as valid length range is displayed dynamically using the gauge bar. Pressing TAB while routing will bring up the Interactive Length Tuning dialog where you can make changes as needed.

Design Rules

Designs today may have specific requirements for individual nets, components, as well as such issues as crosstalk, reflections, and net lengths. It's not possible to satisfy all the requirements of PCB designs by considering only clearances between tracks, pads, and vias.
All design rules in Altium Designer, whether they are for layout, testing, or fabrication, are integrated and accessed from a single dialog – the PCB Rules and Constraint Editor.
Additionally, rules are not pre-defined but user-defined, and consequently very powerful. All default rules are based on a scope (described later) that applies to the whole board, with the exception of Fanout Control rules. With a well-defined set of design rules, you can complete boards of the toughest requirements.

Design Rule Categories

True to the unified nature of the Altium Designer which incorporates all phases of electronic design, design rules are accessed from a single dialog – the PCB Rules and Constraint Editor. There are ten rule categories that cover all respective aspects of design verification.

Altium
Designer
Rule Category


Comments

Placement

Room Definitions, Component Clearances, Component Orientations. Permitted Layers, Nets to Ignore, and Component Height.

Routing

Differential pairs routing can be checked from within the PCB Editor.
Widths, topologies. Priority, layers, corners, via styles and fanout control.

High Speed

Matched Net Lengths, Length and parallel segments. All rules easily checked between layout and the schematic without importing.

Electrical

Integrated into Altium Designer's PCB Editor.

Manufacturing

Verified within the PCB Editor environment using the CAM Editor. Minimum Annular Ring, Acute Angle, Hole Size, and Layer Pairs.

SMT

SMD To Corner, SMD To Plane, and SMD Neck-Down.

Plane

Power Plane Connect Style, Power Plane Clearances, and Polygon Connect Style.

Mask

Solder and Paste Mask Expansion

Test Point

Styles and usages

Signal Integrity

In addition to standard set of design rules for DRC, signal integrity analysis is integrated directly into the PCB Editor (Tools » Signal Integrity).

Table 1. A table with some of the Altium Designer design rules.

Creating and Editing Design Rules

All categories of design rules can be created, edited and managed from a single location in Altium Designer. With the PCB as the active document, select Design » Rules from the main command menu to invoke the PCB Rules and Constraint Editor dialog.

Figure 28. The PCB Rules and Constraint Editor dialog where all design rules can be managed.

Using Design Rules Checking (DRC)

Altium Designer features both batch and online DRC. Both the logical and physical integrity of your design can be verified. Checks can be made against any or all enabled design rules and can be made online as you are working. They can also be defined as a batch check, with results reported immediately in the Message panel as well as a generated report.

Batch DRC

Batch DRC allows you to manually run a design check at any time during the board layout process. Configuring for this is done through the Design Rule Checker dialog, accessed through Tools » Design Rule Checker in the PCB Editor. When setting up your batch DRC, additional options can be defined by clicking on the Report Options folder, in the folder-tree pane of the Design Rule Checker dialog. These options include the generation of the DRC report.
After the check has completed, all violations will appear in the Messages panel.

Figure 29. After setting up all your options, a batch DRC is initiated by clicking the Run Design Rule Check button.

In the folder-tree pane on the left side of the dialog, each of the design rules categories whose rule types can be checked are listed under the Rules To Check folder. Click on the root folder (Rules To Check) to list all checkable design rule types, across all categories, in the main editing window of the dialog (Figure 29).
In the folder-tree pane on the left side of the dialog, each of the design rules categories whose rule types can be checked are listed under the Rules To Check folder. Click on the root folder (Rules To Check) to list all checkable design rule types, across all categories, in the main editing window of the dialog.

Online DRC

The Online DRC is turned on as an option in the PCB Editor - General page of the Preferences dialog Tools » Preferences. Once enabled, Online DRC runs in the background as you work flagging and automatically preventing design rule violations.

Figure 30. Online DRC is an option that has to be turned on in the Preferences dialog.

You can also conveniently enable or disable Online and Batch checking for each rule you wish to check in the Design Rule Checker dialog (Figure 31).

image092.jpg!

Figure 31. Use the options available from the right-click pop-up menu to quickly enable/disable checks of all rule types, or to enable checks of all used rule types only.

It may arise that a design object is covered by more than one rule with the same scope. In this instance, a contention exists. All contentions are resolved by the priority setting. The system simply goes through the rules from highest to lowest priority and picks the first one who's scope expression (s) matches the object(s) being checked.

Scoping

A concept in Altium Designer's PCB Editor, rules scope – the extent of a rule's application. A scope is effectively a query that you build to define all the member objects that are governed by that rule, giving you full control.
In Altium Designer, scoping allows you to decide exactly what a rule's precedence will be and how it will be applied to target objects through a query. You can even define multiple rules of the same type, but each targeting different objects. Queries are easily accessed for any rule (Figure 34). Advanced (Query) options are also available to help you write your own, more complex queries.

Figure 32. Double-clicking on any rule while in the PCB Rules and Constraint Editor dialog will bring up the specific query for that rule in the right pane.

All default design rules have a scope (Full Query) of ALL, meaning that they apply to the whole board.
In addition to scoping, there is also a user-defined priority setting. The combination of rule scoping and priority is very powerful and gives an unprecedented level of control that allows you to precisely target the design rules for your board.

If you do not want to use a design rule, but may want to use it in the future, rather than delete it you can simple disable it. Toggle the correponding Enable opiton for the rule in the relevant list.

Rules Priority

As you create a new rule in Altium Designer, it is automatically given a Priority setting. This setting defines the order in which multiple rules of the same type are applied when, for example, performing a DRC. Each new rule you add for the same rule type will be given the highest priority setting, i.e. 1. You can then change the priority order that exists for rules of the same type using the Edit Rule Priorities dialog which is accessed from the Priorities button in the PCB Rules and Constraint Editor dialog.

Figure 33. When you select on a root folder of category or type, you can see the Priority and Scope for each of the defined rules.

Initially the Edit Rule Priorities dialog will list all rule instances for that rule type that is currently selected in the PCB Rules and Constraint Editor dialog. Defined rules are listed in order of current priority – from 1 (highest) downwards.

Figure 34. Select a rule entry and use the Increase Priority and Decrease Priority buttons to move rules up or down in priority order.

The PCB Editor allows you to easily export and import rule sets, enabling you to store and retrieve your favorite design rule configurations for the job at hand (discussed later).

Signal Integrity

Altium Designer offers in addition to the standard set of design rules for DRC, Signal Integrity analysis integrated directly into the PCB Editor (Tools » Signal Integrity). This includes pre-layout and post-layout Signal Integrity analysis capabilities that you can perform from either the Schematic or the PCB Editors, evaluate net screening results against predefined tests, perform reflection and crosstalk analysis on selected nets, and display waveforms.

Running Signal Integrity from a PCB Project

When running a Signal Integrity analysis from a PCB document, the PCB must be part of a project along with the related schematics. Note that you could also run Signal Integrity from any of the schematic documents in the project and will have the same effect as running it from the PCB. This will allow both reflection and crosstalk analysis to be performed.
You can have some of the schematic components in the PCB but any that have been placed must be linked with Component Links. This can be checked by selecting Project » Component Links. Note also that any unrouted nets will use the Manhattan length between pins to calculate a track length estimate for analysis purposes.

Project Outputs

The OutputJob Editor allows you to define and manage Output Job Configuration files (*.OutJob). An Output Job file allows you to define all your design output configurations – assembly, fabrication, reports, net lists, etc. – exactly as required but all in a single and portable document. You can even create multiple Output Job Files and add them to your project, for example to create a separate assembly output from the fabrication output. In fact, through its portable nature, an Output Job file can be defined once and used in multiple and differing projects, allowing you to use your favorite configurations quickly and easily without the need to set the individual output again and again.

OutputJob Editor

You can create a new file of this type for any active project by using either the File » New » Output Job File (as shown in Figure 35) command or right-clicking on a project in the Projects panel and choosing Add New to Project » Output Job File from the pop-up menu that appears.

Figure 35. Fabrication output job file for the converted PCB project.

The Output Job file is divided into a number of categories that reflect the function of the output. These include Assembly, Documentation, Fabrication, Netlist, and Report Outputs.

Auto-loading Fabrication Output into the CAM Editor

When generating Gerber, ODB++, NC Drill or IPC-356-D output, you can specify that one or more of these types of output to be automatically imported into a new CAM Editor document (*.CAM). This is performed using the Output Job Options dialog (Figure 36), accessed from the OutputJob Editor's Tools menu.

Figure 36. Configuring CAM Editor auto-load options.

Enable the corresponding check boxes for the outputs you wish to auto-load upon generation. Although you can enable one output type
- e.g. Gerber
- and run just the associated output generator, typically you would enable NC Drill, IPC-356-D and either Gerber or ODB++ and then run the associated output generators as a batch process.
Once these options are defined they will persist. This means that the next time you run the output generators, the resulting output would be loaded into another new CAM document. If you wish to be able to update just the existing CAM document, enable the Reset auto-load options after generation option. This results in the clearance of all auto-load options after the initial generation. You can then gain access to the CAM Editor's Rescan and Reload commands , which perform time-stamp comparison of generated and existing (imported) files and loading of data into existing layers respectively.

Documenting with Smart PDF

Smart PDF is a built-in PDF generation wizard that quickly generates a PDF for either selected documents or the whole project, complete with clickable bookmarks to each component, net and pin in your design.

Figure 37. Use Smart PDF to generate bookmarked PDFs of your designs, ideal for design reviews and product documentation.

The Altium Designer Smart PDF wizard (Figure 37) is launched from the File menu, and will guide you through the steps required to export a design to PDF.

Library and Component Management

Altium Designer supports working directly from the source symbol or model libraries, an ideal approach when the schematic and PCB are designed by separate organizations. There are also integrated libraries. All libraries may be viewed and managed at any time from the Projects and Libraries panels.

Altium Designer Libraries

An integrated library in Altium Designer is one where the source symbol, footprint, and all other information (e.g. SPICE and other model files) are compiled into a single file. During compilation checks are made to see how relationships are defined, to validate the relationship between the models and the symbols and to bundle them into a single integrated library. This file can not be directly edited after compilation, offering portability and security.
All of Altium Designer's 70,000+ components are supplied in integrated libraries, from which the source libraries can be extracted at any time if required.

Library Types

There are four types of libraries used in the Altium Designer environment: model, schematic, integrated and database.

Model

These libraries contain the models for each component representation as per their design domain and are each stored in their respective "model containers", called model libraries. In some domains, there will be typically one model per file and they are referred to as model files (*.mdl,*.ckt). In other design domains, models are usually grouped into library files according to how the user has grouped them such as PCB footprints grouped into package-type libraries (*.PcbLib).

Schematic

These libraries contain source schematic components and their model interface definitions (*.SchLib).

Integrated

An integrated library (*.IntLib) is a compiled file, that includes schematic libraries along with all models referenced in the symbols' model interface definitions; which could include footprint model libraries, simulation model files, and 3D model libraries.

Some Basics on Library Management

Libraries are installed (added) to the Altium Designer environment, making their components available in all open projects. Display the Libraries panel, from there you can install and remove libraries. Libraries can also be linked to any project, and you can also define project search paths, useful for referencing simulation models.

A Brief Note on Database Linking

Appreciating the fact that many designers like to link from the components in their electronic design software to their company database, Altium Designer has strong support for linking and transferring database data through the design process and into the Bill of Materials.
Two techniques are supported, one where the Altium Designer library symbol holds all model references and also includes links into an external database, the second where the database holds all model references and other company information. While database connections in Altium Designer are set up for MS Access databases (*.mdb files) by default, any ODBC-compliant database can be accessed.

Interactive Routing Shortcuts

~ (tilde)

Display list of shortcuts

CTRL
+ Click

Auto-complete segments to target

BACKSPACE

Remove last segment

ESC

Terminate current trace

SHIFT
+ A

Add accordion sections (interactive length tuning)

SHIFT
+ C

Toggle auto-complete

SHIFT
+ G

Toggle length tuning gauge

SHIFT
+ H

Toggle Hug mode

SHIFT
+ O

Toggle visible routing area

SHIFT
+ P

Toggle Push mode

SHIFT
+ Q

Toggle glossing

SHIFT
+ R

Toggle routing mode

SHIFT
+ S

Switch layer for current trace

SHIFT
+ V

Select favorite via size

SHIFT
+ W

Open Choose Favorite Width dialog.

, (comma)

Decrease arc setback

SHIFT
+ . (comma)

Decrease arc setback 10x

. (full stop / period)

Increase arc setback

SHIFT
+ . (full stop / period)

Increase arc setback 10x

ENTER

Place Segment

+ (plus)

Next Layer (numeric keypad)

- (minus)

Previous Layer (numeric keypad)

* (multiply)

Next Signal Layer (numeric keypad)

SPACEBAR

Cycle corner direction

SHIFT
+ SPACEBAR

Cycle corner styles (if restrict to 90/45° is not enabled)

TAB

Edit trace properties

1

Toggle Look-ahead Mode – Switches between 1 and 2 segment placement mode

2

Add via, no layer change

SHIFT
+ 2

Add fanout via, tool immediately waits for next fanout to route and via to place

3

Cycle track width source

4

Cycle via size source

6

Force walk-around (with key pressed)

7

Switch leader trace or switch routing target in single trace mode

8

Toggle dynamic routing mode

9

Switches to opposite routing point

Table 2. Interactive Routing shortcut keys.

Interactive Differential Pair Routing Shortcuts

~ (tilde)

Display list of shortcuts

CTRL
+ Click

Commit auto complete segments (if applicable)

BACKSPACE

Remove last segment

SHIFT
+ BACKSPACE

Remove last cluster of segments

ESC

Terminate current trace

SHIFT
+ R

Toggle routing mode

SHIFT
+ W

Open Choose Favorite Width dialog.

ENTER

Place segment

+ (plus)

Next layer

- (minus)

Previous layer

* (multiply)

Next signal layer

SPACEBAR

Toggle corner direction

SHIFT
+ SPACEBAR

Cycle corner styles (if restrict to 90/45° is not enabled)

TAB

Edit trace properties

3

Cycle track width source

4

Cycle via size source

5

Toggle Auto-complete

6

Change via mode

7

Switch leader trace (diff pair) or switch routing target

Table 3. Interactive Differential Pair Routing shortcut keys.

Interactive Length Tuning Shortcuts

~ (tilde)

Display list of shortcuts

TAB

Edit tuning pattern settings

BACKSPACE

Remove last segment

SPACEBAR

Next tuning pattern

SHIFT
+ SPACEBAR

Previous tuning pattern

SHIFT
+ R

Toggle Routing Mode

, (comma)

Decrease pattern amplitude by one increment

. (full stop / period)

Increase pattern amplitude by one increment

1

Decrease miter or radius

2

Increase miter or radius

3

Decrease pattern gap by increment

4

Increase pattern gap by increment

Y

Toggle amplitude direction

Table 4. Interactive Length Tuning shortcut keys.

For Further Reference

Below are references to other articles and tutorials in the Altium Designer Documentation Library that talk more about the conceptual information as well as walking you through specific tasks. Remember, you can also browse through the Help contents, and use F1 and What's This at any time in a dialog for more details.

Labels
  • None