Altium Wiki

Information and resources for electronic product designers

Skip to end of metadata
Go to start of metadata

Application Note AP0133 (v2.5) April 18, 2008

ODB++ 出力オプションは、ODB++ Setup ダイアログで設定します。

ODB++設定ダイアログ


図1 ODB++ Setup ダイアログは、エンベデッドボードアレイ(面付け)に対するレイヤの相互干渉を表示します。ここで、いくつかの干渉違反が赤色で表示されていることに注意してください。
ODB++ Setup ダイアログでは、いくつかのツールを使用してODB++ ファイルの出力オプションを設定します。
ODB++ Setup ダイアログを使用して、生成される出力の一部としてプロットしたい特定のレイヤを有効にします。 Plot Layers ボタンでコマンドにアクセスし、プロットする全レイヤをすばやく有効 / 無効 にします。あるいは、使用するレイヤだけを有効にします。
がーバーファイルの生成と同様に、どのメカニカルレイヤを全ODB++レイヤに追加するのか指定することもできます。
ダイアログには、ODB++ プロファイルレイヤを生成するのに使われるソースを指定できるフィールドも含まれています。 このプロファイルレイヤはボードを囲んでいるバウンダリを含んでいます。 デフォルトでは、フィールドは Board Outline に設定されています。 ボード外形とも呼びますが、これは、バウンダリを定義している閉じたポリゴン形状、あるいは、PCBの境界のことです。 新しいPCBを作る際に作成され、プロファイルレイヤを作成するには最適のソースです
デザイン中に関連するボード外形がない場合は、ボード(KeepOut レイヤや特定のメカニカルレイヤなど)の境界を表すのに、どのソースPCBレイヤを閉じたポリゴンの定義に使うか、選ぶことができます。
Export only objects inside the board outline オプションは、ソースのPCBドキュメントがエンベデッドボードアレイのオブジェクトを含んでいる場合にだけアクセスできるようになります。 その名のとおり、エクスポートされるオブジェクトの外形についてコントロールできます。 あるオブジェクト(テキストなど)がボードの外側に配置されていて、外形に接触しているような場合に、このオプションが有効になっていると、そのオブジェクトもエクスポートされます。

注記

使用できる各オプションの詳細情報を表示するには、ダイアログの What's This Help 機能を使用します。 ダイアログの右上にある疑問符( )のボタンをクリックしてから、フィールドまたはオプションをクリックすると、そのフィールドまたはオプションの情報がポップアップ表示されます。

ODB++ 出力は、次の2つのどちらかの方法で生成することができます:

  • Output Job Configurationファイル(*.OutJob)で適切な設定を行ったアウトプットジェネレーターを使用します。 構成されたアウトプットジェネレーターを実行すると、出力が生成されます。
  • アクティブなPCBドキュメントで、メニューコマンドFile » Fabrication Outputs » ODB++ Filesを直接実行します。 ODB++ Setup ダイアログのOKボタンをクリックすると、すぐに出力が生成されます。

注 : 出力がPCBから直接生成された場合にODB++ Setup ダイアログで行われた設定は、Output Job Configurationファイルの同じ出力タイプの設定とは区別されています。 前者の場合、設定はプロジェクトファイルに保存され、後者の場合は、Output Job Configurationファイルに保存されます

ODB++ 出力を生成するときは、出力が新規のCAMドキュメントで自動的に開くように指定できます。 この方法は、どのように出力を生成したかによって設定箇所が異なります:

  • Output Job Configurationファイルからの場合 - ODB++ Outputのオートロードオプションを、Output Job Options ダイアログ(出力ジョブ エディタからTools » Output Job Options)で有効にします。
  • PCBから直接の場合 - Open outputs after compileオプションを、Options For Project ダイアログ(Project » Project Options)の Optionsタブで有効にします。


ODB++ フォーマットでは、標準のファイルシステム構成を使っています。 ODB++ のジョブは独立のディレクトリツリーになっています。コンピュータシステム間でジョブツリーごと転送できるので、データが失われないようになっています。 ODB++ のファイルはすべて読み取り可能なASCII ファイルです。
データベースのジョブは単一のフォルダ(odb)になっており、以下のサブフォルダで構成されています: フォント、入力、マトリクス、misc、STEP、シンボル、ユーザ
STEP のフォルダには、フォルダレイヤを含むさまざまなサブフォルダが含まれています。これらのサブフォルダには、それぞれのレイヤ用の出力が含まれていて、ドリル情報やコンポーネント上などと同様に、ODB++ Setup ダイアログでプロッティングを有効に設定できます。
シンボルのフォルダには、単一のレイヤグラフィックがあり、STEPの各グラフィックレイヤ内から参照することができます。
マトリクスのフォルダには、物理的なレイヤの並び順と、ドリルデータ(スルー、ブラインド、埋込、その他)との関係の定義があります。
ユーザフォルダには、生成された DRC ルールファイル(*.drc)が含まれます。このファイルを生成するためのオプションが ODB++ Setup ダイアログで有効になっている場合です。



ODB++ 出力をPCB デザインから生成すると、すべてのレイヤ上にあるすべてのプロット可能なオブジェクトがエクスポートされます。 ボード外形の枠の中にあるデザインオブジェクトだけをエクスポートしたい場合は、境界の外にあるオブジェクトを含むすべての追加レイヤがプロッティングされなくなることに注意してください。

ODB++ 出力をPCBデザインから生成する際に、エンベデッドボードアレイや面付け(Figure 1参照)が含まれていると、レイヤの相互干渉について、デザインが自動的に解析されます。

  • Flipped(反転している)エンベデッドボードは、レイヤスタックが反転して表示されます。
  • 異なる中間信号レイヤと内部プレーンは、まだ同じ中間レイヤのパネルに表示されています。
  • 中間信号レイヤと内部プレーンは、再度、それぞれ、反転されます


生成するファイルの出力パスは、Options for ProjectダイアログのOptions タブで設定します。 デフォルトの出力パスは、プロジェクトファイルが存在しているフォルダにサブフォルダが作成されます。名称は、Project Outputs for ProjectName です。 出力パスは必要に応じて変更することができます。 別々の出力タイプに、別々のフォルダを使用するオプションは、Options タブでを有効になります。ODB++ ファイルは、さらにその下の、ODB++ Output というサブフォルダに書き込まれます。.

生成された出力はプロジェクトに追加され、Projectsパネルに表示されます。場所は、Generatedフォルダ内の適切なサブフォルダです。 出力タイプでフォルダを分けた場合は、それぞれに対応したGenerated フォルダが、Projects パネルに追加されます(例えば: Generated (ODB Output))。

Labels
  • None