Altium Wiki

Information and resources for electronic product designers

Skip to end of metadata
Go to start of metadata

Tutorial TU0132 (v1.0) May 22, 2008

Altium Designerは、MCADデータとのハイレベルな相互作用を提供します。 つまり、MCADデータをPCBデザインに対して直接インポートし、操作、チェックできます。 MCAD データファイルをリンクすることで、Altium Designerの中で最新ファイル情報を維持する事ができます。
複数の工程から構成されているので、メカニカルデザインとエレクトロニクスデザインの2つの工程の統合は複雑になっています。 Altium Designerはより迅速、簡単に、メカニカル設計者との共同作業が可能になる直感的なツールを装備しています。

ECAD - MCAD の相互作用

部品などのレイアウトを行なった後で、PCBデザインと筐体との組み立てチェックが行なえる事が理想です。 今までは、PCBデータを一度MCADで扱えるファイルフォーマットにエクスポートして組み立てチェックを行い、その結果を再びPCBの側へフィードバックしていました。

STEP形式への統合

Altium Designer はメカニカルCADと3Dモデル化プログラムの両方で扱えるSTEP形式のデータフォーマットを採用しています。STEP (Standard for Exchange of Product model data) は工学アプリケーションで広く採用されており、Altium Designerで生成されたデータが容易にメカニカルCADで使用できることを意味しています。STEP形式は、非常に複雑なオブジェクトをモデル化するのに適しており、製品化前の機械的なチェックに使用するのに理想的な形式です。
また、STEP形式はコンポーネントの立体的な詳細を表現でき、部品メーカから部品使用者へ提供されています。これにより、PCBライブラリ内のフットプリントにSTEPモデルをインポートする事が容易になります。正確なモデルを使用することで、以前よりも高いレベルでコンポーネントのクリアランスをチェックすることができます。
Altium DesignerはSTEP AP203とSTEP AP214のフォーマットをサポートしています。 ただし、STEP AP203の場合、色彩情報が失われる事にご注意ください。

可能な相互作業

データをSTEP形式に変更する事で、

  • 現実的な物理モデルとしてコンポーネントのフットプリントにSTEPモデルファイルをインポート可能です。
  • 筐体やPCBに実装されない部品などのSTEPモデルファイルをインポートまたは埋め込み可能です。
  • PCB (基板のみ、もしくは組み立て後) のSTEPモデルファイルをエクスポート可能です。
  • STEPモデルファイルから基板外形を作成可能です。

リンクしたSTEPモデルファイル

ファイルリンクは、アプリケーションとソースデータファイルとの「ライブな」関係を提供する一般的な概念です。 Altium Designerはオリジナルのソースファイルに変更が入った場合、すぐに変更を認識し、リンクされたファイルを更新できます。 つまりメカニカル設計者と共同して設計を行えば、リンクファイルの修正に対するエラーを軽減でき、より効率的に最新情報を管理する事ができます。
Altium DesignerはSTEPファイルを含むフォルダを「Watched」(監視対象)として指定し、使用します。 指定された「Watched」は常にモニタされ、変更が発生したファイルは自動検出します。 ファイルをリンクする場合、「Watched」を指定する必要があります。モデルサーチパスの設定方法は、「モデルサーチパスの設定」をご参照ください。
SPTEファイルはPCBエディタのみでリンク可能です。 PCBライブラリエディタにおけるリンクはサポートしていません。
リンクファイルのもう一種類は、埋め込みファイルです。 埋め込みファイルデータは、Altium Designerのドキュメントにコピーされます。そのため、オリジナルのソースファイルを自動的にモニタしません。
注意 埋め込みファイルはオリジナルのファイルが存在する場合に限り、変更が発生した時点で更新可能です。

MCAD相互作用の例

以下は、Altium DesignerのMCAD相互作用についての一例です。 この例ではAltium DesignerのPCBドキュメントに対して2つの筐体データをリンクします。 リンク後、 PCBとそれぞれの筐体を正確に配置し、コンポーネントクリアランスのデザインルールを設定し、基板と部品そして筐体間でクリアランスをチェックします。
また、筐体の突起にコネクタをあわせるように部品と機械的なデータをともに編集予定です。 更に、インポートしたSTEPモデルから基板外形の作成する例も紹介します。
本例では、Altium Designerのインストールディレクトリ内に含まれているExamples/Tutorials/multivibrator_stepフォルダの multivibrator_step.pcbdoc ファイルを使用します。このフォルダには、必要になるSTEPモデルも含まれています。 幾つかの局面では、デザインが実世界を完全に再現していないかもしれませんが、Altium Designerで最大限例証するために選択されました。
注意: 本例では既にコンポーネントフットプリントに3D外形が作られ、使われています。

モデルサーチパスの設定

まず、STEPファイルをリンクするモデルサーチパスを設定します。以下の手順を実行してください。
1. プリファレンスダイアログのPCB Editor - Models ページを開きます。(DXP » プリファレンス) STEPファイルをリンクするためにモデルサーチパスを設定するページです。
2. Model Search Path 欄の をクリックし、フォルダ参照ダイアログを開きます。 Altium Designerインストールディレクトリ内の Examples/Tutorials/multivibrator_step フォルダを指定します。 OK ボタンをクリックし、ダイアログを閉じます。
注意: .(サブフォルダ)と..(親フォルダ)を使う事でプロジェクトフォルダに対して絶対パスではなく相対パスでの設定が可能です。相対パスは、PCBプロジェクトフォルダを元に検索するので、絶対パスにおける指定の必要はありません。
3. プリファレンスダイアログに戻り、モデルサーチパスを確認します。追加ボタンをクリックし、Watchedパスとしてモデルサーチパスに追加されます。複数のwatchedフォルダを追加する事ができます。
4. OK ボタンをクリックし、プリファレンスダイアログを閉じます。

PCBドキュメントにSTEPファイルの配置とリンク

次のステップは、PCBドキュメントにSTEPファイルを配置し、リンクさせます。 本例では、PCBデータ multivibrator_step に対して2つの筐体STEPファイルがあります。 モデルは、非PCBデータであり、free-floating 3D外形です。
注意: リンクされたデータに更新が入った場合、Altium Designerで最新データを維持するために、更新されたSTEPファイルを再生成、更新作業が必要です。
1. Altium Designerインストールディレクトリ内Examples/Tutorials/multivibrator_step フォルダを指定し、multivibrator_step.pcbdoc ファイル (ファイル » 開く) を開きます。
2. 配置 » コンポーネント 外形を選択します。 3D外形ダイアログが開きます。 このダイアログでは、全ての3D外形のコントロールができます。 3Dモデルタイプ内のジェネリック ステップ モデル オプションを選択し、STEPモデルにリンクボタンをクリックします。 モデル選択ダイアログが開き、watchedフォルダのコンテンツが表示されます。
注意: 2Dもしくは3D表示モードで3D外形の配置が出来ます。 [ショートカット: 2 (2D), 3 (3D)]
3. multivibrator_base.step ファイルを選択し、OKボタンをクリックします。 モデルがカーソルにThe model 現れ、ワークスペース内の配置箇所でクリックします。 (このチュートリアルではPCBか羅離して配置してください) PCBドキュメントにSTEPファイルがリンクされました。 ファイルを変更するとAltium Designerが自動的に更新します。
4. 3D外形ダイアログが再び表示され、他のモデルの配置ができます。 STEPモデルにリンクボタンを再び押し、モデル選択ダイアログでmultivibrator_cover.step ファイルを選択します。
5. 筐体データを配置後、キャンセルボタンをクリックし、  3D外形ダイアログを閉じます。
筐体のベースとカバーの2つのモデルを配置しましたが、PCBデータ上に配置しただけです。 (図 1) 次のステップでPCBデータ上の適切な位置に筐体データを配置します。
注意: 3Dモードで3D外形が表示されない場合、PCBパネルの3D外形表示オプション内の2つのオプションがイネーブルになっているか確認してください。

1.ワークスペース内のPCBとfree-floating 3D外形

STEPモデルを正しく配置

物理的に正確なシミュレートを行うため、ワークスペース内にPCBドキュメントと筐体のfree-floating 3D外形が共に配置されました。
異なるアプリケーションからインポートしたSTEPファイルを正確に配置する事が重要です。例えば、STEPモデルの原点がAltium DesignerのPCBドキュメントの原点と全く異なる場合、STEPモデルを調整する必要があります。
Altium Designerは、基板上で配置調整を行うために、頂点やユーザ定義の参照点(スナップポイント)をSTEPモデルで使います。 また、PCBに対して高さの制御と同様に3D外形の回転もできます。
本例では、PCBに対して筐体のベースとカバーに距離がある事がわかります。 筐体カバーは幾つかの方向に回転する必要があります。STEPモデルの配置方法はいくつかあります。

  • 基板の表面に対してSTEPモデルを垂直に配置する
  • 一つの基準点を使用してSTEPモデルの位置を変更する
  • 3つの基準点を使用してSTEPモデルを回転し調整する
  • STEPモデルの面や両面をボードの表面にあわせて回転する
  • 3D外形のダイアログのジェネリック ステップ モデルで直接制御する

本例では、筐体のベースとカバーをそれぞれの方法を使用し、回転・配置を行ないます。 正確な位置決定を行うためにこれらの方法を組み合わせて使用する事ができます。

モデルの計測と基準点のスナップポイントの配置

モデルとPCBドキュメントの方向が共有されている場合(例えば、STEPモデルのX、YおよびX軸はPCBドキュメントの方向と対応している)、一つのスナップポイントを基準として位置決めができます。本例では、筐体のベースはPCBの方向と対応しています。
筐体のベースとPCBを見たときに、PCBに対して筐体のベースに突起がある事がわかります。 PCBにはこの突起に対応する穴がないので、一つ作成する必要があります。 対応するボードの切り抜きを配置するために突起の位置とサイズを計測する事ができます。
まず、ボードがフィットする筐体のベース領域を計測しましょう。 筐体のベースにはPCBを配置するために周辺や中央に正方形の突起がデザインされています。これらの領域には、電気的オブジェクト(トラックやパッド)を配置しないようにします。
1. 3D表示にします。 [ショートカット: 3]
2. ツール » STEP 3D外形配置 » スナップポイント間の計測を選択します。
!worddav8dd3507dd03cb33dc18f8d93bd4275c0.png|height=59,width=62!3. 筐体のベースをクリックし、選択します。カーソルはモデル上の頂点を検索するための3Dポジショナルカーソル(青い6軸)に変化します。
4. 図2に示されるようにカーソルを移動し、モデルの角をクリックすることで長さを測定してください。 2つ目のポイントを選択後、長さ情報が表示されます。 Side 1を測定すると長さがおよそ52mmある事がわかります。OKボタンをクリックしてダイアログを閉じ、測定モードに戻ります。
注意: Altium Designerの計測単位はImperialであるため、metric単位を使用した場合、非常に小さい丸め誤差が発生するかもしれません。 この場合、実サイズは52.00000mmですが、imperialからmetricに変換した際に、0.00001mmの丸め誤差があります。

2. PCBサイズに対するSTEPモデルの測定
5. もう一度筐体ベースをクリックし、Side 2の頂点を選択します。 測定結果は同じです。 直角か否かの判断として対角線を計る事ができますが、この筐体ベースは正方形です。
さて、筐体のベースに基板がフィットするかクリアランスを含めてチェックを行ないます。


3. スナップポイントの配置_1. レポート » 基板情報を選択します。 _PCB情報のダイアログが開き、 様々な情報を表示します。
2. 全般 タブ をクリックし、ボード寸法でサイズを確認します。 本例では、ボードは50.8 x 50.8mmです。 ボードは各縁に対してそれぞれ0.6mmのクリアランスを保ってフィットします。
STEPモデルから直接、基板外形を定義する事もできます。 この機能を使用する場合は、「Creating a Board Shape Directly From a STEP Model 」をご参照ください。
次のステップでは、筐体ベースの中央にある突起にスナップポイントを配置します。 ボードには、突起を配置するためのカットアウトが必要で、カットアウトはキープアウトエリアに配置します。
1. ツール » STEP 3D外形配置 » スナップポイントを頂点に作成を選択します。
2. 筐体のベースをクリックし、選択します。カーソルはモデル上の頂点を検索するための3Dポジショナルカーソル(青い6軸)に変化します。
3. カーソルを移動し、2つの突起の4つの角でクリックしスナップポイントを配置します。 赤矢印は、支えの突起で、青矢印は突起の配置を示しています。 突起については、突起上面ではなく、支えの突起と接続している下部の角にスナップポイントを配置してください。 右クリックもしくは、ESCキーをクリックし、スナップポイントの配置モードを解除します。 図 3 はスナップポイントを配置した図です。.
注意: スナップポイントの表示色は、System Colorsに依存します。 ビュー設定(2D 表示で有効)ダイアログ内、レイヤと表示色のページでシステム配色でより明確に見る事ができます。[ショートカット: L]. また、システム配色を変更すると全てのPCBドキュメントが変更されます。
4. 更に筐体のベースの中央にスナップポイントを追加します。突起中央が筐体ベースの中央と仮定します。 再度、スナップポイントの配置モードにし、筐体のベースをクリックします。
5. スペースバーを押しmid-pointモードに入り、2頂点間にスナップポイントを配置します。 突起の対角線上2つのスナップポイントをクリックし、右クリックもしくはESCキーでスナップポイントの配置モードを解除します。
次に、ボードを筐体ベースに配置します。 ステップ5で配置した中央のスナップポイントを基準点とし、調整するためにボード中央にパッドを配置します。
1. PCBを編集するために、2D表示モードにします。[ショートカット: 2]
注意: ボードの左下にある原点は、ボードの中央を検索しやすくしています。 編集 » 原点 を使用することで原点の編集ができます。
2. 配置 » パッド [ショートカット: P, P] を選択し、パッドの配置モードに入ります。
3. 編集 » ジャンプ » 座標指定 [ショートカット: J, L] を選択し、Jump to Location ダイアログを開きます。 このダイアログでは、カーソルが移動する座標を指定できます。
4. X-LocationY-Location 欄ともに25.4mmと入力します。 (ボードの寸法は50.8 x 50.8mmなので、半分の位置する必要があります) OKボタンを押し、ダイアログを閉じるとカーソルが指定した座標位置に移動します。
5. ENTER ボタンを押し、パッドを配置します。 参照用のパッドがボードに配置されました。

一つの参照点を使用したモデルの配置

次のステップでは、スナップポイントとPCB上の参照点を使用して筐体のベースを配置します。 この方法では、配置されたスナップポイントを必要とせず、STEPモデルの頂点を使用できます。 本例では、頂点がないので、スナップポイントを使用します。
1.3D表示モードに入ります。
2. ツール » STEP 3D外形配置 » STEPモデルの位置決めを選択します。
!worddav25c569b97b9850e4e7c056e7539ba347.png|height=118,width=180!3. 筐体のベースをクリックし、選択します。カーソルがモデル上の頂点やスナップポイントを検索するための3Dポジショナルカーソル(青い6軸)に変化します。
4. TAB キーを押し、セレクト可能なポイント指定ダイアログを開きます。端点オプションをディセーブルにし、OKボタンを押します。 3Dポジショナルカーソルはスナップポイントにだけ留まります。

_4. ボードの参照位置の取得_5. モデル中央にカーソルを移動し、中央のスナップポイントでクリックします。
6. カーアソルをボード中央に移動し、中央の参照パッドでクリックします。 PCBの参照パッドに対してX、YおよびX軸上で正確に中央のスナップポイントに調整され筐体のベースが移動します。
注意: ボードオプションダイアログ[ショートカット: D, O]でエレクトリカル グリッドがイネーブルになっている場合、電気的なオブジェクトのホットスポット(パッド、トラック、ビア等)にカーソルが移動すると緑色の三角柱カーソル(図4)が現れます。 このモードはオブジェクトへのスナップに有効です。 更に、ボードオプションダイアログのすべてのレイヤでスナップオプションをディセーブルにすることでスナップ可能なオブジェクトの数を減らす事ができます。
筐体のベースがXとY軸方向に調整されましたが、垂直方向には正確な配置ができていません。ボード表面に対してモデルの高さを設定する必要があります。

モデルの高さ設定

STEPモデルを配置するときに、3DのワークスペースでSTEPモデルの原点を元にPCBの表面に対して垂直方向の設定を行ないます。PCBの表面もしくは裏面のいずれかからもモデルの垂直位置を指定できます。 本例では、筐体ベースの中央に配置した突起にPCBを配置します。
筐体のベースとPCBを見ます。突起の中央に配置したスナップポイントに対してボード表面が調整されている事がわかります。 筐体のベースにボードの裏面が接続されるように正します。 その後、筐体ベースに配置した突起を使用してボードの裏面からの筐体の高さを指定します。
1. 3D表示モードに入ります。 [ショートカット: 3]
2. 筐体ベースをダブルクリックし、3D 外形ダイアログを開きます。
3. 外形配置面のリストからBottom Sideを選択します。
4. OKボタンを押し、ダイアログを閉じると変更が適応されます。
筐体ベースが上下逆であることに注意してください。 X軸に沿って筐体ベースを180° 回転する必要があります。

5. 3D 原点マーカー注意: どの軸に対して回転するか特定するときに3D原点マーカーを使用します。 ビュー設定ダイアログ[ショートカット: L]の基板素材と表面処理ページの原点マークを表示オプションをイネーブルにする事で表示されます。 (図 5)
1. 筐体ベースの3D 外形 ダイアログを開きます。
2. ジェネリック ステップ モデルRotation X° 欄に180と入力します。
3. OKボタンを押し、ダイアログを閉じると変更が適応されます。
筐体ベースのモデルが正しい方向を向きました。 次のステップでは、筐体ベースの突起をボードに対して調整します。
1. ツール » STEP 3D外形配置 » モデルの頂点から高さを設定を選択します。
2. 筐体ベースを選択すると、カーソルが3Dポジショナルカーソルに変化します。
3. カーソルを突起表面の角に移動し、クリックします。 ボード面やカスタムの高さを指定できる Choose Height ダイアログが開きます。
4. ボード表面 オプションを選択し、OKボタンを押してダイアログを閉じます。
筐体ベースの突起表面は、ボードの裏面に正確に調整されました。次のステップでは、筐体ベース/PCBに対して筐体カバーを適切に配置します。
偶然の変更を防ぐために筐体データの位置を固定する事ができます。 3D外形 ダイアログのプロパティ欄のロックをイネーブルにすることで固定できます。

モデルの方向指定

本例では、インポートした筐体カバーのSPTEモデルがPCBドキュメントの軸に対して異なる方向を向いています。PCBに対して調整し回転させる必要があります。 幾つかの方法があります。

ボードの表面に対してモデルの方向指定

この方法は、STEPモデルの選択された平面や表面をボード表面に対して調整し、ボードのX-Y面に対して垂直に配置します。
調整後のモデル垂直位置は、デフォルトで3D外形ダイアログの外形配置面により決められています。
本例では、In this example, we will orient the housing cover using the boss in the center as this needs to be at board level and also happens to be in line with surface that butts up against the housing base. 以下の手順を実行します。
1. ツール » STEP 3D外形配置 » 基板端面と一致させる.を選択します。

6. ボードと平行にするために選択したSTEPモデルの表面
2. 筐体カバーをクリックし、選択します。
3. 図6のように筐体カバーの中央にある突起面をクリックし、方向がかわります。 カーソルをモデル上で移動すると選択されている表面以外は透過表示になり、表面を簡単に見つける事ができます。
筐体カバーは、ボード表面に対して平行に回転しました。 同様にボードの先端に対して選択した面の垂直位置調整が必要です。 筐体ベースに対して行なったように、ボードの参照点に対して筐体カバーの中央突起にスナップポイントを追加し、X-Y軸に正しい位置決定を行ないます。 本例では、ボードに対して筐体のベースとカバーの突起にあわせてボードを挟み込む事ができます。 カバーを置くことについては、一つの参照点を使用したモデルの配置をご参照ください。筐体カバーを配置後、位置を固定します。

3つの参照点を使用したモデルの回転

この方法は、STEPモデルとボード上で3つの参照点が必要です。 スナップポイントを配置する必要はなく、STEPモデルの頂点を使用することができます。 本例では、頂点を使用します。3つの頂点の関係は以下の通りです。
一つ目のポイント - 主な支点としての役割 - STEPモデルで選択された一つ目の参照点は、ボード上で選択された最初の参照点にあわせられます。
二つ目のポイント - 整列ポイントとしての役割 - STEPモデル上の一つ目のポイントから2つ目のポイントを結んだ線に対してあわせられます。
三つ目のポイント - STEPモデルの方向を定義 - STEPモデルは、2つ目のポイントを定義したときに作成される線に対して回転します。 STEPモデルの3つの参照点とボード表面が交差します。 図 7 をご参照ください。 - 色づけされた数値はSTEPモデルの参照点を示し、白丸の数値は、ボード上の整列や回転の支点を表しています。 STEPモデルの配置結果は右図をご参照ください。

7. 3つの参照点を使用したSTEPモデルの配置
1. ツール » STEP 3D外形配置 » STEPモデルの位置と方向を合わせる を選択します。
2. 筐体カバーをクリックし、選択します。カーソルがスナップポイントにだけ留まる3Dポジショナルカーソルに変化します。
3. 図9に示されるように、1、2、3の順番で頂点をクリックします。選択された順番にボード上の3つの対象点が調整されます。

8. 電気的オブジェクトではなく、ボード外形もスナップを使用した正確な配置
モデルを調整し回転させるためにボード上で正確なポイントを選択する必要があります。 ポイントを選択する際、エレクトリカルグリッドが有効な状態で電気的なオブジェクトを用意に選択できます。
例えば、ビアがボードの縁に平行に配置されている場合は有効ですが、そうでない場合は、モデルが正確に配置されるように、3つのポイントを正確に配置する必要があります。 2つ目の方法として、基板外形が直線の場合、エレクトリカルグリッドが基板外形にスナップする機能を使う方法があります。 ボード オプションダイアログ[ショートカット: D, O]のエレクトリカル グリッドの基準点へスナップボード外形もスナップをイネーブルにします。一度、イネーブルにすると参照点としてボードの角を選択する事ができます。 (図 8).
1. 図10に示すように1、2、3の順でボードの角をクリックします。参照点を選択した順番でSTEPモデルの3つの参照点が調整されます。

_9. STEPモデル上の3つの参照点の選択._筐体カバーは、ボードの縁(そして筐体ベース)に対して平行に回転しました。 筐体カバーの高さとX-Y軸に対する最終調整が必要です。 筐体ベースに対して行ったように、ボード上の参照パッドに対して筐体カバーの中央突起を合わせるためにスナップポイントを追加します。本例では、ボードに対して筐体のベースとカバーの突起にあわせてボードを挟み込む事ができます。 カバーを置くことについては、一つの参照点を使用したモデルの配置をご参照ください。筐体カバーを配置後、位置を固定します。

3D 外形ダイアログを使用したModelの回転

この方法では、3D 外形ダイアログ(図 11) のジェネリック ステップ モデル欄で回転や高さの制御を行ないモデルの位置を決めます。

Figure 10. Selecting corresponding alignment points on the board.注意: 3D外形の移動や回転を行うためのキーボード ショートカットは本資料内表 1 に記載されています。
STEPモデルの手動での回転は90°などの単純な回転に適しています。 ダイアログに記載された回転軸はPCBドキュメントの軸に対応しています。つまり、モデルの軸に対して回転するのではなく、PCBドキュメントの軸に対して回転します。
1. STEPモデルをダブルクリックし3D外形ダイアログを開きます。
2. ジェネリック ステップ モデル欄にX、Y、Z軸に対する回転角度やボード表面に対するZ軸方向のスタンドオフの4つの設定項目があります。
注意: STEPモデルは、アプリケーションの原点を使用するとPCBドキュメントの軸に対して正確に回転しません。
3. Rotation X° / / 欄に適切な回転角度を入力し、OKボタンをクリックします。

_11. 3D 外形ダイアログを使ったSTEPモデルの回転_4. 設定後、モデルがどのように回転したかを確認し、必要に応じて回転調整を行なってください。
ボードのX-Y軸に対して平行になるようにモデルを回転します。筐体ベースを処理したのと同様にボード上の参照パッドに対して筐体カバーの突起にスナップポイントを追加する事でX-Y軸に対して筐体カバーを正しく配置する事ができます。 本例では、ボードに対して筐体のベースとカバーの突起にあわせてボードを挟み込む事ができます。 カバーを置くことについては、一つの参照点を使用したモデルの配置をご参照ください。筐体カバーを配置後、位置を固定します。
注意: 位置決めが完了した後、PCBドキュメントから参照パッドを削除します。

STEPモデルを使用したボード編集


_12. PCBパネル内3D Modelsモード_筐体にPCBがおさまるようにPCBを編集します。 本例では、突起を配置するためのボードカットアウトと突起部分に電気的なオブジェクトが配置されないようにキープアウトを定義する必要があります。
操作を行うために、ワークスペース上で対象外の部品を視覚的に隠すことができます。 PCBパネルでは、様々なタイプの3Dモデルを区別し、表示に対する制御を行うことができます。PCBパネルを開き、パネルトップのリストから3D Modelsを選択します。パネル中央のリスト欄でFree Modelsを選択することで、フリーの3D外形のリストがパネル下部に表示されます。パネルリスト下部で、 multivibrator_base をクリックし、選択します。表示制御のリストを使用し、Hideを選択します。これにより、筐体ベースが非表示になります。
パネルの3D外形 表示オプション欄でShow Simple 3D Bodies をディセーブルにし、押し出しの3D外形の表示を非表示にします。( 図 12)
更に表示をクリアにするために ビュー設定ダイアログを開き[ショートカット: L]、配色と表示オプションをディセーブルにします。( 図 13) 結果は 図 14,のようになり、筐体カバーの下側が見れます。

Figure 13. Using the View Configuration to hide parts of the design.
図 15 では、筐体カバーとベースが'合った'ことを示します。 PCBパネル内で筐体カバーを50%の透過表示に設定することでPCBが完全に表示できます。

_14. Disabling the display of objects to see into the assembly._筐体組立のために筐体の突起部には部品やトラックが配置されないように編集する必要があります。また、コネクタはカバーの開口部に合うように位置を変更する必要があります。

15. multivibrator の筐体が組立られた。透過表示を使用することで、組み立てた後の内部モデル見る事ができる
. Referencing Locations on a Model and Applying them to the PCB
コネクタのためにボードカットアウトとキープアウト領域をボード上で移動する必要があります。 2Dのワークスペースで電気的オブジェクトと同様に引き込みが可能なので、スナップポイントを配置する事が適当です。
ボードカットアウトを作成するために、筐体ベース上のスナップポイントを使用します。 しかし、1つ問題があります。現在、突起頂点にスナップポイントを配置しているため、突起とボードカットアウトの端に幾つかのクリアランスを指定する必要があります。そのため、スナップポイント間に線を配置します。そして、クリアランスに従って、両側に0.25mmオフセットを作ります。 正確な位置制御を行うために、PCB Inspectorパネルを使用して、PCBドキュメント上のグリッドに依存せずにオフセットを作ります。
1. 2Dモードに入ります。
注意: シグナルレイヤにてオブジェクトの位置変更を行わないために、メカニカルレイヤを使用します。
2. 配置 » ライン [ショートカット: P, L] を選択し、ライン配置モードに入ります。
3. スナップポイント完にラインを配置し、長方形を作成します。 Snap points have the equivalent of an electrical hot-spot so that you can snap to their centers. ボード オプションダイアログでエレクトリカル グリッドすべてのレイヤでスナップをイネーブルにすることで操作が可能にあります。
4. 長方形の配置後、ワークスペース右下にあるPCBボタンからPCB Inspectorパネルを開きます。筐体ベースにある突起に対して必要な0.25mmのクリアランスをパネルを使用して設定します。
5. ラインをクリックすることでPCB Inspectorパネルに表示されます。 Graphical 欄で X1, Y1, X2, Y2 座標のエンドポイントが表示されます。 (図 16)

Figure 16. Using the PCB Inspector panel to precisely move objects.
6. 原点から最も遠いX1座標を選択し、!+0.25mmと入力して ENTERを押します。 エンドポイントは、右に0.25mm移動します。
注意: 構文は以下の通りです。 ! は現地点を意味します。(本例では、 ラインのエンドポイントの座標を示します); + や - 現地点から加算や減算します。 値や単位は移動する距離を示します。
7. Y軸にも同様に、エンドポイントに対して0.25mm追加します。
8. 同じ線に対して現在のX差表から0.25mmマイナスし、Y軸には0.25mm追加します。
9. 4つの線に対して同様にエンドポイントを移動します。
次のステップでは、これらのラインからボードカットアウトを作成します。
1. 4つのラインを選択します。
2. ツール » コンバート » Cセレクトしたプリミティブからボードカットアウト作成を選択します。
3. オリジナルのラインを削除します。
ボードカットアウトが生成されました。 次のステップでは、突起のスナップポイントの周辺にキープレイアウト領域を作成します。 キープレイアウトに対してはスナップポイントの周辺にクリアランスを必要としません。
1. 配置 » ライン を選択し、ラインの配置モードに入ります。
2. 突起周辺に長方形を形成するためにスナップポイント間にラインを配置します。2Dのワークスペースで電気的オブジェクトと同様に引き込みが可能なので、スナップポイントを配置する事が適当です。ボード オプションダイアログでエレクトリカル グリッドすべてのレイヤでスナップをイネーブルにすることで操作が可能にあります。
3. 4つのラインを選択します。
4. ツール » コンバート » セレクトしたプリミティブからリジョン作成を選択します。 リジョンオブジェクトが作成されました。
5. リジョンを選択し、右クリックし表示されたポップアップメニューからプロパティを選択してカッパー エリアダイアログを開きます。
6. キープアウト オプションをイネーブルにし、配置レイヤリストから Multi-Layer を選択してOKボタンをクリックします。領域は全ての層に対してキープアウト領域に変換されました。
7. オリジナルのラインを削除します。
8. キープアウト領域を避けてNetC2_1 を再配線してください。
基板外形は現在、筐体の縁に対してクリアランスを保った状態で可能なスペースに配置しています。 2つの突起間のキープアウト領域が定義され、交差していたトラックは移動されました。 本例の次のステップでは、コネクタY1 を筐体カバーの開口部に合うように位置をかえます。

Figure 17. Moving components to snap point references.
STEPモデルとコンポーネントの整列
筐体カバーの開口部に対してコネクタ (Y1) を並べるために、隙間の各コーナーにスナップポイントを配置します。2Dモードにてスナップポイントを使用し、コネクタを移動します。
1. ツール » STEP 3D外形配置 » スナップポイントを頂点に作成 を選択します。
2. 筐体カバーをクリックし、選択します。
3. 筐体カバーの開口部の各角にスナップポイントを配置します。 筐体カバーの外側の角にスナップしないように注意します。
4. 2Dモードに入ります。
5. コネクタY1 を選択し、スナップポイントにより生成された長方形内に移動します。(図 17)

18. The connector repositioned to suit the housing cover (3D).
注意: コネクタを正確に配置するためにショートカット G キーを押すことでスナップグリッドを再調整できます。表示されたリストから、より小さいスナップグリッド、0.025mmを選択します。 新たに設定したスナップグリッドの値は、ショートカットメニューや3D 外形ダイアログで設定されなおすまで反映されます。
6. コネクタパッドに対して再配線を行ないます。 (図 17)

19. The board after modification.
コネクタは、筐体カバーの開口部に対して並べられる必要があります。 つまり、製品では、コネクタY1 がソケットに対して合う事を意味します。 (図 18) 変更後、ボードは 図 19のようになります。

3D外形から基板外形を作成

3D外形(STEPモデルやシンプル 3D外形)の表面から基板外形を定義することができます。 つまり、メカニカル技術者が生成したモデルに対して必要な基板外形を使用する事ができるという意味です。 STEPモデルから基板外形を定義するだけではなく、リンクする事ができるため、関連するSTEPファイルに変更が入った場合、自動的に更新されます。(詳しくは、Placing and Linking STEP Files to the PCB Documentを参照してください)
モデルはボードの模写である必要はありません。3D外形のあらゆる平面を使用できます。 Any circular holes in the surface are created as pads on the generated board shape and are automatically created as a union, meaning that moving one, moves them all and the positional relationship between them is maintained. Non-circular holes are also created as a union, however, are board cutout polygonal regions.
基板外形のために使用された3D外形は、ドキュメント内でフリーの3D外形として保持されています。 The default vertical positioning of it, after the board shape is redefined, is taken from the Body Side value (3D Body dialog) for it.
本例では、Altium Designerインストールディレクトリ内 Examples/Tutorials/multivibrator_step フォルダに基板外形作成可能なSTEPモデルがあります。 以下の操作により、STEPモデルから基板外形を定義します。
1. 配置 » コンポーネント外形を選択し、3D外形ダイアログを開きます。3D モデルタイプ欄の ジェネリック ステップ モデルを選択します。
2. STEPファイルとリンクしているならば、 STEPモデルにリンク ボタンをクリックします。そうでないならば、埋め込みSTEPモデルボタンを押します。 モデル選択ダイアログで必要なファイルを選択します。
注意: 3D外形は2D、3Dのいずれのモードでも配置できます。 [ショートカット: 2 (2D), 3 (3D)]
3. board.step ファイルを選択し、OKボタンを押します。 カーソルにモデルが追従します。ワークスペース内でクリックし、配置します。ステップモデルがPCBドキュメントに配置されました。 (図 20)
注意: ワークスペース内でモデルを配置した場所に基板外形が生成されます。
4. ボードモデルを配置後、3D外形ダイアログ内のキャンセル ボタンを押し、配置モードを解除します。
5. 3Dモードになっていない場合は、3Dモードに入ります。そして、 デザイン » 基板外形 » 3D外形から定義を選択します。
6. ボードモデルをクリックし、選択します。
7. ボードモデルの表面をクリックします。これにより、新しい基板外形が生成されます。 モデル周辺でカーソルを移動する事で表面を検出できます。検出された表面以外のモデルは透過表示されます。
注意: X-Y軸に平行な表面だけが基板外形を作れる場合があります。 X-Y軸に対して平行にする必要がある面を選択した場合、確認 ダイアログにて調整後、操作が可能になります。 このダイアログでボードの表面もしくは裏面として関連付けし、モデルを配置できます。 つまり、同時にモデルの垂直方向も定義できます。 面の調整後、 デザイン » 基板外形 » 3D外形から定義 を選択し、指定します。
8. 基板外形の定義後、3D外形の非表示を行います。

20. STEPモデル~生成した基板外形

21. オリジナルのボードとインポートしたモデル
基板外形が、モデルのサイズに適合されました。 (図 21)

3D外形を使用したコンポーネントのクリアランスチェック

ボードと筐体の位置関係の定義ができましたので、筐体とコンポーネント間の栗かランスチェックをかけることができます。 迅速な目視チェックにより、幾つかのコンポーネントが筐体カバーと接触していることがわかります。Altium Designerは、ボード上のコンポーネントとフリーの3D外形間のクリアランスチェックのためのデザインルールを提供します。そのため、筐体やその他のコンポーネントと十分な間隔をもっていいないコンポーネントを特定する事ができあす。

デザインルールを使用したコンポーネントクリアランスチェック

そのルールは、デザインルールのPlacementカテゴリにあります。 デザイン » デザインルール [ショートカット: D, R] を選択し、PCBルールと制約条件編集ダイアログを開きます。

22. 3D外形のクリアランスチェックのためのPCBデザインルール.
クリアランスチェックを行うために、対象となるコンポーネントやオブジェクトを指定する必要があります。 本例では、以下のルールを適用します。

  • ジェネラルルールとしてボードに実装された全てのコンポーネントに対して最小クリアランスを設定します。 このルールは、コンポーネント間だけではなく、コンポーネントと筐体間のクリアランスチェックも行ないます。
  • 筐体カバーとベースの3D外形に対して、お互いに接合を許容するルールを指定します。
  • 筐体カバーの開口部とコネクタの垂直方向クリアランスを定義します。


23. 正確なモデルを使用したコンポーネントのクリアランスチェック.
コンポーネントのクリアランスチェックには2つのルールがあります。水平方向と垂直方向です。 実際の距離は、コンポーネントの3D外形の正確な立体情報に基づいています。 これにより、一つのコンポーネント上に他のコンポーネントが張り出している事を許容できます。 (図 23)
Its is also possible to check clearance infinitely. This is useful where you want to check that a component has nothing at all covering it, regardless of distance. 本例では、コネクタに対して、このようなクリアランスチェックを使用します。

Figure 24. Setting up a component clearance rule.
コンポーネントクリアランスルールの設定
図 25 は、ComponentsOnBoardと名づけられた、コンポーネントクリアランスルールを示しています。このルールでは、ボード上の全てのコンポーネントに対して定義されています。このルールでは、筐体の3D外形を含め、全てのコンポーネントの周辺に1.5mmのクリアランスが必要であることを定義しています。 クエリでは、 isComponent を使用し、水平・垂直方向に1.5mmの値を数値指定で定義しています。近接違反した距離を表示をイネーブルにする事で視覚的に違反距離を表示することができます。

フリー3D外形のクリアランスルールの設定


Figure 25. Setting up a clearance rule for free-floating 3D bodies.
デザインルールチェックを実行する (ツール » デザインルール チェック) と、1.5mm以内に存在するコンポーネントの3D外形に対してエラーが発生します。 また、コンポーネント間だけではなく、コンポーネントの3D外形とフリーの3D外形間で1.5mm以内に存在する場合もエラーが発生します。 しかし、筐体のカバーとベースに対しては、物理的に接合させる必要があるため、このルールは適切ではありません。そのため、フリーの3D外形に対してゼロクリアランスが可能になるようにルールを設定する必要があります。
そのため、FloatingBodiesという名の別のコンポーネントクリアランスルールを作成します。筐体カバーとベースに対して識別子(3D外形ダイアログ内の識別子)を使用します。図 23 に示されるように、クエリに(id='multivibrator_cover') or (id='multivibrator_base')を使用し、水平・垂直方向に数値指定で0mmのクリアランスルールを設定します。

3D外形に対して制限なしのクリアランスルールの設定

最後に、筐体の開口部にコネクタ Y1のソケットが配置できるようにルール設定を行ないます。図 24 は、水平方向に制限なしのクリアランス設定を示しています。

Figure 26. Infinite vertical component clearance checking using the shape of the model.
筐体カバーに対して識別子(3D外形ダイアログ内の識別子)を使用して ConnectorY1 という名のコンポーネントクリアランスルールを設定します。First Obejectとしてコネクタを指定するためにクエリには inComponent ('Y1')を使用します。コネクタと筐体カバー間の垂直方向クリアランスチェックをかけられるようにsecond objectにはid='multivibrator_cover'のクエリを使用し、水平方向に数値指定で0.3mm、垂直方向には制限なしの設定を行ないます。 図 23.
このルールは、This rule will, in effect, take the 3D bodies making up the base of the connector, add 0.3mm around their perimeter as clearance and then project that area upwards. If that projection passes through any objects, a violation will occur.

ルールの優先順位設定


Figure 27. Setting up an infinite vertical clearance rule.
Altium Designerはルールの階層化をサポートしています。つまり、適用するルールの順番を定義できます。 1つのルールが他のルールの範囲をカバーしている場合、本例では、ComponentsOnBoardConnectorY1 をカバーしています。そのため、ConnectorY1 のルールの優先順位を高くする必要があります。この状態でデザインルールチェックを実行した場合、コンポーネント Y1に対して、ComponentsOnBoard よりも先にConnectorY1 のチェックが行なわれます。, with component Y1 not being eligible for subsequent rules.
PCBルールと制約条件編集ダイアログ内 優先度 ボタンをクリックし、ルール優先度の編集ダイアログで優先順位を設定します。(図 26)
次のステップでは、デザインルールチェックを実行し、問題箇所の修正を行います。

Figure 28. Defining rule priorities.

 

デザインルールの実行と3D外形とコンポーネント間の違反箇所修正


Figure 29. Use the Design Rule Checker dialog to select which rules to check and run them.
デザインルールチェックを実行すると、幾つかの違反が発生します。 本例では、3D外形間の定義したコンポーネントクリアランスルールに着目します。
デザインルール チェック ダイアログを使用し、実行するデザインルールを指定します。 ツール » デザインルール チェック [ショートカット: T, D] を選択し、ダイアログを開きます。 (図 29)
デザインルールチェック実行後、Altium Designerはい半のリストをレポート(HTML形式)として生成する事ができます。レポートから直接PCBエディタの違反箇所にハイパーリンクの機能を使用し、ジャンプする事がかのうです。 ダイアログ左にあるReport Optionsフォルダをクリックし、レポートファイル作成エラーマーク付加オプションをオンにします。これにより、PCBドキュメント上で違反箇所をハイライトされます。
Component Clearanceで既に設定済みの近接違反した距離を表示オプションをイネーブルにしているため、違反箇所のポイント間の距離を表示する事ができます。これにより、違反を修正するためのソース特定に有効です。3D外形が他の3D外形に達している場合、違反は「衝突」を示します。
デザインルール チェックダイアログ左にあるPlacement をクリックし、Component Clearanceのバッチをイネーブルにします。(図 29) DRC実行ボタンをクリックします。 選択したデザインルールに対して違反のレポートが表示されます。(図 30)

30. The Design Rule Verification report, showing any violations found.

Figure 31. Highlighted 3D body collisions and violations.
ドキュメントに戻るとFigure 31のように違反箇所がハイライト表示されているのを確認できます。 ズームしたり、筐体カバーの内部を見ることで、F図 31に示されるように、部品の衝突を見ることができます。 Q1, Q2, C1C2の4つのコンポーネントが筐体カバーと衝突しています。
図 33では、抵抗 R2の先端と筐体カバーとのクリアランス違反になっています。 その距離は1.22674mmで、設定した1.5mmのクリアランスをわずかに下回っています。
違反を解消するために、衝突している部品をボードの裏面に移動します。また、抵抗は現在の一から遠くに移動します。

Figure 32. Viewing 3D body collisions in 3D.

Figure 33. Component Clearance rule violation distances, viewed in 3D.
次のステップでは違反に対する対応を行ないます。

3D外形間の違反解消

違反を解消するために、筐体カバーとQ1, Q2, C1C2を見ます。筐体カバーよりも筐体ベースがより深さを持っているため、コンポーネントをボード裏面に配置することで解決できることがわかります。
1. 2Dモードに入ります。 ツール » エラーマーク解除 [ショートカット: T, M].を選択し、違反表示を解除します。
2. コンポーネント Q1を選択し、右クリックします。ポップアップメニューから プロパティ  を選択し、コンポーネント ダイアログを開きます。
3. コンポーネント プロパティ欄の配置レイヤにてBottom Layerを選択します。Click OK ボタンをクリックし、ダイアログを閉じます。
4. コンポーネント C1に対しても2 と 3を実行します。衝突部品をボード裏面に移動した事で違反が解決しているかDRC実行を再度行ないます。

Figure 34. Repositioning components to resolve violations with other 3D bodies.
Q2C2 に対しても同様に違反を解消し、デザインルールを行なってください。
注意: Bottomレイヤに部品を移動することは部品をフリップ表示することとは違います。 部品のフリップは現在の配線に対してピンを反対にすることです。 更に違反を修正するために操作が必要です。
違反がなくなるまで R2 を移動します。 ドキュメント編集中に違反箇所をハイライトするようにコンポーネントクリアランスの "オンライン"をチェックする事で容易に違反箇所をなくすように操作できます。デザインルール チェック ダイアログを開き、Component Clearanceルール (Placementカテゴリ)のオンラインにチェックを入れ、Closeボタンをクリックします。
1. 2Dモードに入り、R2を選択します。
2. カーソルをR2上に移動しすると4方向の矢印に変化します。コンポーネントをクリックし、違反が出ない位置にドラッグして移動します。
注意: 部品の移動中、違反のハイライトの色は濃い緑色で表示されます。部品を配置後、違反はハイライトされます。
3. R2の新しい位置でトラックを再配線します。 結果は 図 34のようになります。
4. デザインルールチェックを実行するとコンポーネントクリアランス違反はありません。
違反がなくなるとPCBと筐体が組立の状況でフィットすることでしょう。もし、MCADデザイナーが彼らのアプリケーションで検証を行いたい場合、PCBドキュメントを互換性のあるファイルで供給することができます。詳細は Altium DesignerからPCB MCADデータをエクスポート を参照ください。

Altium DesignerからPCB MCADデータをエクスポート

MCADアプリケーションの互換性を持たせるために、データを変換します。 Altium Designer は、詳細の3次元モデルとしてPCBドキュメントを一般的なSTEPフォーマットでエクスポートできます。また、同様に2次元モデルとしてAutoCAD DWG/DXFファイルの出力もできます。 どのようなデータをエクスポートするか制御することができます。 3D外形やアセンブリのための一部分を含めPCB全体をエクスポートすることができます。
注意: もしPCBドキュメントに実装部品ではないfree-floating 3D外形が含まれる場合(本チュートリアルで使用した、筺体カバーやベース)、エクスポートファイルにこれらを含みたくないこともあるかもしれません。そのような場合は、それらを非表示にし、選択したオブジェクトのみエクスポートすることができます。 選択したオブジェクトをエクスポートする場合、2Dモードにする必要があります。3Dモードでは、完全にオブジェクトの概念をサポートしているわけではありません。

PCBドキュメントをSTEPファイルでエクスポート

本チュートリアルで操作したPCBデータをSTEPファイルとして以下の手順でエクスポートします。
1. ファイル » 名前を付けて保存 もしくは ファイル » コピーに名前を付けて保存を選択します。 Save Asダイアログが開きます。
2. 保存したいディレクトリを指定し、ファイル名を指定します。ファイルの種類リストから Export STEPを選択します。

Figure 35. A range of PCB STEP export options is available.
3. 保存ボタンをクリックします。 STEPエクスポート オプションダイアログが開きます。(図 35) このダイアログでは、何をエクスポートするか指定できます。
注意: ボードは常にエクスポートされます。
4. STEP エクスポート オプション ダイアログを使用し、エクスポートファイルにどのデータを含むか指定します。
3D外形付きコンポーネント 欄では、ドキュメントに含まれる部品の3D外形やfree-floating3D外形ともにエクスポートします。 2Dモードで作成されている必要があることを覚えておいてください。 ボードのみをエクスポートしたい場合は、すべてではなく、セレクト範囲のみエクスポートを選択してください。
3D外形 エクスポートオプション欄では、STEPモデルもしくはシンプル外形いずれをエクスポートするか選択できます。シンプル外形を優先を選択した場合、シンプル外形をエクスポートします。また、STEPモデルを優先にした場合、STEP3D外形がエクスポートされます。また、両方の外形モデルをエクスポートを選択した場合は、STEP3D外形とシンプル外形が共にエクスポートされます。シンプル外形のみ利用可能な場合は、常にエクスポートされます。
パッド穴と基板カットアウト欄では、すべてもしくは選択されたボード上の穴、つまりビアやボードカットアウトのエクスポートを指定できます。
5. OK ボタンをクリックし、エクスポートが完了します。

PCBドキュメントをDWG/DXFファイルでエクスポート


Figure 36. A range of PCB DWG/DXF export options is available.
Altium DesignerとAutoCAD間のファイル互換性は、2次元のファイルのみです。これらのファイルはAutoCADや他のMCADアプリケーションでPCBの組立情報を2D(X-Y軸)で表現されます。 3D外形情報は供給されません。
本チュートリアルで使用したPCB例をDWGもしくはDXFファイルとして出力します。
1. ファイル » 名前を付けて保存 もしくは ファイル » コピーに名前を付けて保存を選択します。 Save As ダイアログが開きます。
2. 保存したいディレクトリを指定し、ファイル名を指定します。ファイルの種類リストからExport AutoCAD Filesを選択します。
3. 保存ボタンをクリックします。 AutoCADへエクスポート ダイアログが開きます。(図 36) このダイアログでは、何をエクスポートするか指定できます。
4. AutoCADへエクスポートダイアログを使用し、どの情報を含ませるか、また、エクスポートするファイルフォーマットを選択できます。
オプション欄では、AutoCADのバージョンやファイルフォーマット、単位を指定できます。しかし、PCBドキュメント内の全てのオブジェクトが古いDWG/DXFファイルフォーマットに変換されない事があります。
欄では、パッドやビアをレイヤ毎にわけてエクスポートするか選択できます。
コンポーネント欄では、コンポーネントのフットプリントを個々のプリミティブとして描くかもしくは、ブロックとして描くか選択できます。つまり、オブジェクトの融合かぐループとして描くかを選択します。
トラックと円弧欄では、エクスポートファイル内で終端をどのように描くかを指定します。
線幅0でエクスポートするプリミティブ欄では、物理的に製造や形状として使用しない線をMCADアプリケーションで線幅0として描くことを選択できます。
5. OK ボタンをクリックし、エクスポートが完了です。
本チュートリアルは以上で終了です。 You have now explored some of the design potential when integrating MCAD data and Altium Designer.

3D 外形の配置ショートカット

~ (tilde)

ショートカットのリスト表示

+ (plus)

次レイヤへ移動

  • (minus)

前レイヤへ移動

L

ペアのメカニカルレイヤへ3D外形を移動

TAB

3D外形ダイアログにて3D外形のプロパティを編集

X

X軸に沿って3D外形を反転

Y

Y軸に沿って3D外形を反転

SPACEBAR

反時計回りに3D外形を回転

SHIFT + SPACEBAR

3D外形を時計回りに回転

2

X軸に対して3D外形を反時計回りに回転

3

Z軸に対して1スナップグリッド分高さを下げる

4

Y軸に対して3D外形を反時計回りに回転

6

Y軸に対して3D外形を時計回りに回転

8

X軸に対して3D外形を時計回りに回転

9

Z軸に対して3D外形を1スナップグリッド分高さを下げる

 (left arrow)

X軸に対して3D外形を1スナップグリッド分左に移動

SHIFT +  (left arrow)

X軸に対して3D外形を10スナップグリッド分左に移動

 (right arrow)

X軸に対して3D外形を1スナップグリッド分右に移動

SHIFT +  (right arrow)

X軸に対して3D外形を10スナップグリッド分右に移動

 (up arrow)

Y軸に対して3D外形を1スナップグリッド分下に移動

SHIFT +  (up arrow)

Y軸に対して3D外形を10スナップグリッド分下に移動

(down arrow)

Y軸に対して3D外形を1スナップグリッド分上に移動

SHIFT +  (down arrow)

Y軸に対して3D外形を10スナップグリッド分上に移動

Table 1. 3D body placement shortcut keys.
注意: 回転は、プリファレンスダイアログ内 PCB Editor - General回転角に基づいています。移動量は、スナップグリッド設定に基づきます。

Labels
  • None