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このチュートリアルでは、CAMtastic DXP を使用して様々

な CAM ファイルのインポート、エクスポートを行う為の方

法を説明します。 

 

 
このチュートリアルで、CAMtastic にガーバーや ODB++ファイルをインポートして Quick Load コマ

ンドの操作を説明します。Quick Load は、フォルダに保存されている全ての CAM ドキュメント（ガ

ーバー、ODB++、アパーチャリストファイル(*.lst)、NC ドリル HPGL/HPGL2 や IPC-D-356 ネットリ

スト）をインポートすることが可能です。 

CAMtastic の File » Import メニューには、選択されたガーバー、ODB++、ネットリスト(IPC-356-D)、 
NC ドリル、Mill/Rout、DXF/DWG や HPGL/HPGL2 ファイルをインポートする為の個別のコマンドが

用意されています。このチュートリアルでは、AutoCAD DWG ファイルと Mill/Rout ファイル(.rte)をイ

ンポートする為の 2 つのコマンドを使用します。 

CAMtastic のインポートはデフォルトでは、Protel からエクスポートされたファイルをインポートする

為の設定になっています。このチュートリアルでは、例として Protel を使用して設計された 4 Port 
Serial Interface の PCB ファイルを使用します。他の CAD/CAM プログラムで作成されたファイルをイ

ンポートする時は、それらの出力設定に着目し、それに応じて CAMtastic インポートダイアログを編

集します。File » Setup » Import/Export を選択して表示される Preferences – Import/Export ダイアロ

グでは、ガーバーファイルをインポート、エクスポートする為のデフォルト設定を行うことが可能で

す。これは RS-274D のガーバーや NC ドリルの為に必要で、Gerber RS-274X, IPC-356-D や ODB++
ファイルでは必要ありません。 

また、CAMtastic で利用できる Export オプションを簡単に確認します。 

Quick Load を使用してファイルをインポート 
Quick Load コマンドは、フォルダ内に保存されているすべての CAM ファイルをインポートします。

もし、ボード上に穴（例えば、スルーホールまたは、ブラインド、ベリードビア）がある場合は、少

なくとも信号層（例えば、トップやボトムのガーバーファイル）と一つかそれ以上の NC ドリルファ

イル（Excellon 2 フォーマット）を読み込む必要があります。 

最初にブランクの CAM ファイルを作成し、設定オプションを見てから Quick Load を使用して必要な

ファイルをインポートします。 

TU0102  (v1.0) December 18, 2003 1 



CAMtastic でのインポート、エクスポート 

新規 CAMtastic ドキュメントの作成 
1. メニューから File » New » CAM Document を選択して、新規 CAM ドキュメントを作成します。

CAMtastic1.Cam というブランクの新規 CAMtastic ドキュメントがデザインウィンドウに表示さ

れます。 

2.File » Save（ショートカット Ctrl+S）を選択してドキュメントを保存します。ファイル名に例えば、

4 Port Serial Interface.CAM と入力し、ファイルの保存場所を指定し、OK をクリックしま

す。 

 

インポートオプションの設定 

新規 CAMtastic ドキュメントにガーバー、NC ドリルやネットリストファイルをインポートする前に、

Gerber Import 設定と同様にインポートオプションを設定する必要があります。これらの値は、デフォ

ルトとして CAMDXP.ini ファイルに保存されます。View » CAM Editor を選択して、CAM エディタ

画面モードであることを確認します。既に CAM エディタに設定されている場合は、そのコマンドは

グレー表示になっています。あるいは、現在のエディタは CAMtastic パネルの上部に表示され、ドロ

ップダウンリストを使用して切り換えることができます。 

1. File » Setup » Import/Export を選択します。Preferences – Import/Export ダイアログの

Import/Export タブが表示されます。 
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デフォルトのインポートフォーマットが、アパーチャ定義（エンベデッドアパーチャ）を含む RS-
274-X（拡張ガーバーフォーマット）であることを確認します。もし必要ならば、ボタンをクリッ

クしてフォーマットを変更します。 

2. ガーバーファイルのデフォルトのインポート設定を行うことができる Gerber Import Settings ダイ

アログを表示させる為に、Import Settings をクリックします。OK をクリックして、デフォルト

設定を適用します。 

 

3. また、データをインポートする時に、CAMtastic が新しいレイヤを追加できるように設定する必要

があります。CAMtastic では、データベース内に同一のレイヤタイプが存在する場合でも、新しい

レイヤを追加することが可能です。あるいは、新しいレイヤを追加せず、既存のレイヤを使用する

こともできます。既存のレイヤを使用するのは、異なる PCB データを同じデータベースファイル

に読み込み、同じ CAM パネル上で面付けする場合に便利です。 

このチュートリアルでは、インポートして自動で新しいレイヤを作成する為、Preferences – 
Import/Export ダイアログの Create new layer オプションにチェックが入っていることを確認しま

す。 
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4. 最後にインポートするファイルのファイル名の拡張子を確認します。ファイルの拡張子を確認する

か、新しい拡張子を追加する為に、Preferences – Import/Export ダイアログの Miscellaneous タ

ブをクリックします。 

 

5. ここに表示されたファイルの拡張子は、インポートされたファイルの形式を決定します。例えば、ガ

ーバーファイルのクイックロードは、*.A??、または *.G??の拡

張子の全てのファイルを検索し、読み込みます。セミコロン(;) 
で区切って、必要な拡張子を追加することができます。このチ

ュートリアルでは、デフォルトの設定を適用する為、そのまま

OK をクリックします。 
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クイックロードを使用して CAM ファイル

をインポート 
新規 CAMtastic ドキュメントにガーバー、NC ドリル、ネットリス

トファイルをインポートします。一括で同じフォルダ内の全てのフ

ァイルをインポートするクイックロードオプションを使用します。 

1. File » Import » Quick Load を選択します。File Import – Quick 
Load ダイアログが表示されます。\Program 
Files\Altium2004\Examples\Tutorials\CAMtastic 
Imports & Exports\Gerbers フォルダを指定してからダブ

ルクリックし、ディレクトリ内の利用できるファイルを表示さ

せます。 

読み込むガーバーが RS-274-X フォーマットでサンプルファイ

ルと同じく FS（Format Setting:フォーマット設定）コマンドを

含んでいる場合は、デフォルト設定をそのまま適用します。 

そうでない場合は、Detect Aperture Formats ドロップダウンリ

ストからアパーチャフォーマットを指定し、Gerber Options
または、Default Units ボタンをクリックし、設定ダイアログを表示します。 

OK をクリックするとガーバーファイルがロードされます。 
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2. ガーバーファイルが読み込まれると、Import Drill Data ダイアログが表示されます。 

 

3. Import Drill Data ダイアログのデフォルト設定を適用する為に、OK をクリックします。NC ファイ

ルが CAMtastic にインポートされ、デザインウィンドウに表示されます。IPC ネットリストファイ

ルが最後にロードされます。 

 

注記 : P-CAD デザインから生成されたガーバーファイルをインポートする場合、エラーファイル

（Load Error.rpt）が開き、Quick Load could not determine the statement ‘T00  Invalid Tool 
Code’ from the Drill/Rout File(s) という、メッセージが表示されます。T00 は、P-CAD ファイルで

のファイルの終りを表します。この為、このエラーファイルは、無視して閉じることができます。 

4. レイヤ名やその他の情報を表示する為に、ワークスペースパネルの下部にある CAMtastic タブを

クリックします。パネルヘルプを表示する為に CAMtastic パネル上で F1 キーを押します。 
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5. File » Save (ショートカット Ctrl+S)を選択し、ファイルを保存します。 

クイックロードを使用して ODB++ファイルをインポート 
ODB++インポートオプションは、CAMtastic に ODB++ファイルをインポートします。もし、NC ドリ

ルデータが Protel から生成された場合、ODB++インポートが完了した後に NC ドリルデータを別にイ

ンポートする必要があります。 

他の CAD/CAM パッケージでは、既に ODB++形式にドリル穴データを含んでいるので、NC ドリルデ

ータを別にインポートする必要はありません。 

1. メニューから File » New » CAM Document を選択します。ブランクの新規 CAMtastic ドキュメン

トがデザインウィンドウに表示されます。 

2.File » Import » Quick Load を選択します。File Import – Quick Load  ダイアログが表示されます。 

 

3. Program Files\Altium2004\Examples\ Tutorials\CAMtastic Imports & 
Exports\ODB++フォルダを指定し、ダブルクリックしてこのディレクトリで利用できるサブフォ

ルダを表示させます。 

4. OK をクリックすると ODB++ファイルがロードされ、Steps Table ダイアログが表示されます。 
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このダイアログには、現在のドキュメントの為に、ロードした ODB++データベースに定義された

全ての ODB++ステップが表示されます。ステップは、ステップ名とそのステップに関連したオブ

ジェクトの数で見分けられます。 

5. OK をクリックして、ステップに割り当てられた全てのデフォルト値を適用します。デザインがイ

ンポートされます。CAMtastic パネルの Steps タブがリフレッシュされ、右クリックのポップアッ

プメニューから適切なコマンドを選択してステップを追加または修正できます。 
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NC ドリルファイルのインポート 
Protel で生成された ODB++ファイルをインポートしてから、この

デザインに関連した NC ドリル情報をインポートする必要がありま

す。これは、ODB++ファイルがインポートされた後、個別にイン

ポートする必要があることに注意して下さい。 

1. File » Import » Drill を選択します。File Import - NC Drill ダイア

ログが表示されます。Protel の PCB エディタで作成された NC
ドリルデータのファイル拡張子は、.txt です。 

2. Program 
Files\Altium2004\ Examples\Tutorials\CAMtastic 
Imports & Exports\4 Port Serial Interface.txt を
選択し、OK をクリックします。Import Drill Data ダイアログが

表示されます。 

 
3. OK をクリックしてデフォルトを適用します。NC ドリルデータは、個別のレイヤ（レイヤ名は、

ファイル名に基づきます。例えば、4_port_serial_interface.txt。）でインポートされま

す。 

4. ファイルを保存します(ショートカット Ctrl+S)。 

その他のファイルタイプのインポート 

File » Import メニューのオプションにより、CAMtastic へ次のファイルタイプを別々に、または選択

してインポートすることができます：ガーバー; ODB++; ネットリスト; ドリル; Mill/Rout; DXF/DWG; 
HPGL/HPGL2 
インポートしたいファイルにアパーチャ情報が無い場合は、File » Import » Aperture File (using 
Wizard formats)を選択して、あらかじめ決められたテンプレートフォーマットを使用しているアパー

チャファイルを読み込むことができます。または、File » Import » Custom Aperture Library File 
(*.lib)を選択して、カスタムアパーチャライブラリファイル(*.lib)を読み込むことができます。 

このチュートリアルの後では、DXF/DWG や Mill Rout ファイルのインポートについて説明します。 
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DXF/DWG のインポート 
CAMtastic に AutoCAD DXF/DWG ファイルをインポートすることができ、各ドローイングレイヤが異

なるレイヤタイプに置き換えられます。最初にデフォルトオプションを使用して DWG をインポート

します。その後、カスタムオプションを使用します。 

標準的な PCB のインポート 
1. CAM エディタ画面が表示されていることを確認します。そうでない場合、Import DXF/DWG オプ

ションは利用できません。 

2. メニューから File » New » CAM Document を選択して、新規 CAMtastic ファイルを作成します。

ブランクの CAMtastic ドキュメントがデザイン画面に表示されます。 

3. File » Import » DXF/DWG を選択します。Open Auto CAD DXF/DWG File ダイアログが表示され

ます。 

 

3. Program Files\Altium2004\Examples\Tutorials\CAMtastic Imports & Exports\4 
Port Serial Interface.DWG ファイルを指定し、Open をクリックします。DXF/DWG Import 
Wizard ダイアログが表示されます。 

 

4. このチュートリアルでは、PCB ボードの DWG ファイルをインポートしている為、Standard PCB 
(Double-sided, etc.)を選択し、OK をクリックします。インポートプロセスが開始し、結果がデザ

インウィンドウに表示されます。 
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5. ファイルを保存します(ショートカット Ctrl+S)。 

Custom Import Options を使用して DXF/DWG ファイルをインポート 
1. CAM エディタ画面であることを確認します。 

2. メニューから File » New » CAM Document を選択し、新規の CAMtastic ファイルを作成します。 
ブランクの CAMtastic ドキュメントがデザインウィンドウに表示されます。 

3. File » Import » DXF/DWG を選択します。Open Auto CAD DXF/DWG File ダイアログが表示され

ます。 
4. Program Files\Altium2004\Examples\Tutorials\CAMtastic Imports & Exports\4 

Port Serial Interface.DWG のファイルを指定し、Open をクリックします。DXF/DWG 
Import Wizard ダイアログが表示されます。 

5. チュートリアルのこの項目では、DWG ファイルをインポートし、マニュアルでオプションを設定

する為、Custom Import Options を選択し OK をクリックします。Import DXF/DWG ダイアログ

が表示されます。 
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6. 検知された各レイヤは、インポートを行う為に自動で選択されます。オプションの 4 つの欄は、レ

イヤ別に用意されています。最初のレイヤ名は 0(ゼロ)であることに注意して下さい。AutoCad か
らインポートする場合、これは重要なレイヤで、全てのフラッシュがこのレイヤに保存されていま

す。CAMtastic は、インポートで適切なレイヤにこれらを分配する為、このゼロレイヤにチェック

が入っている必要があります。 

7. 各レイヤの FRD (Flash Round/Donut Pads)オプションにチェックを入れます。このオプションが

選択されている場合、丸やドーナツ形状は DXF/DWG ファイル内で検知され、フラッシュアパー

チャが自動で作成されます。これらのオプションについての詳細な情報は、ダイアログヘルプの?
をクリックし、オプションの上をクリックして下さい。 

8. Units が Inches に、Scale が 1.0 に設定されていることを確認します。 

9. Options ボタンを押し、Advanced Options ダイアログを表示させます。 
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10. 最上部の OWP(Outline Width Polyline)モードと Fill OWP オプションを選択します。 

11.Options タブをクリックし、Move Layer 0 block objects と Exclude trace endcap を選択します。

必要ならば、Line width を 0.005 に、Rectangle flash ratio を 6 に変更します。 

 

12. Options タブ内の Text options ボタンを押し、Default Font Style タブ内の AutoCAD SHX を選

択します。フォントが、romans.shx に設定されます。 

 

これが表示されない場合は、Browse ボタンを押して shxfont フォルダを指定します。Text Line 
Width / Fill Mode タブ内で Use same line width for all を選択し、線幅の値として 0.001 と入力

します。 

13. 全てのダイアログが閉じられるまで OK をクリックします。DWG ファイルが、CAMtastic に読み

込まれます。 
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Mill Rout ファイルのインポート 
このコマンドは、現在のドキュメントに Mill/Rout データファイルをインポートする為に使用されます。 

1. File » Import » Mill/Rout を選択します。File Import – 
Mill/Rout ダイアログが表示されます。 

2. ドリルファイル（Program 
Files\Altium2004\Examples\Tutorials\ CAMtast
ic Imports & Exports\cam.rte）を指定し、インポー

トします。OK をクリックすると Import Mill/Rout Data ダイ

アログが表示されます。 

 

3. OK をクリックしてデフォルトを適用します。データは、レ

イヤ名がファイル名（例えば、cam.rte）に基づいて個別

のレイヤでインポートされます。 
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4. ファイルを保存します(ショートカット Ctrl+S)。 

5. もし、Mill Rout レイヤを修正したい場合は、最初に NC Editor にする必要があります。View » NC 
Editor を選択すると、Rout メニューオプションが利用できるようになります。 

CAMtastic からファイルをエクスポート 
全ての CAMtastic 出力は、File » Export メニューを通して作成されます。オリジナルのデータを修正

した場合や Test Point、NC Drill データをガーバーフォーマットとして保存する必要がある場合は、フ

ァイルをエクスポートする必要があります。 

次のエクスポートオプションが、CAM エディタで用意されています：Gerber; Netlist; IPC-D-350, 
Save Drill, Mill/Rout, DXF, Part Centroids, Aperture List, Library, Bitmap (*.bmp) 
ドリルエクスポートオプションを利用するには、NC エディタである必要があります。 

Protel の PCB へのエクスポートについての詳細な情報は、CAMtastic Reverse-Engineering PCBs for 
Protel Users アーティクルを参照して下さい。 

ガーバーのエクスポート 

1. ガーバーファイル（例えば、4 Port Serial Interface.CAM）をインポートして、このチュ

ートリアルで以前に作成した CAMtastic ドキュメントを開きます。View » CAM Editor を選択し

ます。 

2. デフォルトエクスポート設定を確認します。File » Setup » Import/Export を選択します。

Preferences – Import/Export ダイアログの Import/Export タブが表示されます。 
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デフォルトエクスポートフォーマットが RS-274-X（アパーチャ（エンベデッドアパーチャ）定義

を含む拡張ガーバーフォーマット）であることを確認します。 

3. Export Settings をクリックし、ガーバーファイルのデフォルトエクスポート設定を行う為の

Gerber Export Settings ダイアログを表示させます。OK をクリックし、デフォルト設定を適用し

ます。OK をクリックし、Preferences – Import/Export ダイアログを閉じます。 

4. File » Export » Gerber を選択します。Export Gerber(s)ダイアログが表示されます。 

 

5. OK をクリックしてデフォルト設定を適用します。Write Gerber(s)ダイアログが表示されます。 
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6. エクスポートを行うすべてのガーバーファイルのチェックボックスにチェックを入れます。あるい

は、右クリックメニューを使って選択するか、SPACEBAR を使用してセレクションを切り替え、

エクスポートするファイルを選択します。 

出力ファイルフォーマットが正しくない場合は、OK ボタンは使用できなくなることに注意して下

さい。出力ファイル名は、スペースや大文字を含めることはできず、64 文字以内である必要があ

ります。新しいファイル名を入力するには、ファイル名をダブルクリックします。ファイル名の拡

張子を変更するには、ガーバーファイル名を選択してから右クリックし File extensions を選択し

ます。Enter Value ダイアログで新しい拡張子（最大 3 文字）を入力し、OK をクリックします。 

7. … ボタンをクリックしてエクスポートするファイルの保存場所を選択します。OK をクリックする

とファイルがエクスポートされます。 

ネットリストのエクスポート 

2 つのフォーマットでネットリストをエクスポートすることができます。IPC-D-356 フォーマット 
(.net)でネットリストをエクスポートするには、File » Export » Netlist コマンドを使用します。IPC-
D-350 ネットリスト(.ipc)でエクスポートするには、File » Export » IPC-D-350 を使用します。これ

らのコマンドを使用する前に、インポートしたデータから CAMtastic でネットリストを抽出する必要

があります。 

1. CAM エディタであることを確認しま

す。ネットリストを抽出していない場

合は、Tools » Netlist » Extract を選

択します。インポートデータの確認に

ついての詳細は、チュートリアル

「CAMtastic によるデータ検証」を参

照して下さい。 

2.File » Export » Netlist を選択します。

Write IPC-D-356 ダイアログが表示さ

れます。 
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3. .net ファイルを選択し、このネットリスト（テストポイント）レポートを出力する為に、保存す

る場所を選択し、場合によってはファイル名を変更します。OK をクリックするとファイルがエク

スポートされます。 

ドリルファイルのエクスポート 

1. NC エディタ(View » NC Editor)を選択します。 

2. File » Export » Drill を選択します。Export Drill Data ダイアログが表示されます。 

 

3. Save をクリックしてデフォルトを適用します。Write Drill ダイアログが表示されます。 

 

4. このドリルファイルをエクスポートする為に、保存する場所を選択し、場合によってはファイル名

(.drl)を変更し、OK をクリックします。ドリルファイルが指定した場所にエクスポートされま

す。 
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更新履歴 
 

Date Version No. Revision 

18-Dec-2003 1.0 New product release 

Software, documentation and related materials:  

Copyright © 2003 Altium Limited. 

All rights reserved. Unauthorized duplication, in whole or part, of this document by any means, mechanical or 
electronic, including translation into another language, except for brief excerpts in published reviews, is prohibited 
without the express written permission of Altium Limited. Unauthorized duplication of this work may also be 
prohibited by local statute. Violators may be subject to both criminal and civil penalties, including fines and/or 
imprisonment. Altium,  DXP, Design Explorer, nVisage, Nexar, Protel, P-CAD, Tasking, CAMtastic, Situs and 
Topological Autorouting and their respective logos are trademarks or registered trademarks of Altium Limited. All 
other registered or unregistered trademarks referenced herein are the property of their respective owners and no 
trademark rights to the same are claimed. 
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