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このチュートリアルではライブラリエディタを使用して、

回路図コンポーネントと PCB フットプリントを新規作成す

る方法を説明します。このチュートリアルで使用されてい

る用語の説明が用語集として最後にまとめられています。

 

 
このチュートリアルでは回路図と PCB の操作環境とコンポーネントの配置や編集について理解されて

いるもとして説明を行っています。このチュートリアルで使用したコンポーネントやライブラリは、

Altium2004\Examples\Tutorials\Creating Components フォルダに収められています。 

このチュートリアルでは以下の内容を説明します： 

• ライブラリの新規作成 

• シングルまたは複合の回路図シンボルの新規作成 

• 回路図ライブラリエディタのレポートを使用してコンポーネントのチェック 

• マニュアル作業、または Component Wizard を利用して PCB フットプリントを新規作成 

• PCB ライブラリエディタのレポートを使用してのコンポーネントチェック 

• 新しいコンポーネントとモデルを使って統合ライブラリを新規作成 

回路図コンポーネントの新規作成 
回路図ライブラリエディタは回路図コンポーネントの作成、修正、及びコンポーネントライブラリの

管理ができます。ライブラリエディタは、回路図エディタとよく似ており、Place Pin ツールが追加さ

れている以外は、同じグラフィカルオブジェクトを使用します。回路図コンポーネントはパーツとし

て分割することができ、シンクロナイズの際に用いられる、PCB 用ライブラリまたは統合ライブラリ

に格納された PCB フットプリントとの関連付けを指定します。 

コンポーネントは、回路図エディタ上でドローイングツールを使用して作成した形状を回路図ライブラ

リへコピー＆ペーストして新規コンポーネントを作成するか、回路図ライブラリエディタ内で同じくド

ローイングツールを使用して作成することができます。 

回路図ライブラリ 
回路図ライブラリ(.SchLib)は Altium2004\Library フォルダにある統合ライブラリ(.IntLib)の
重要な構成要素です。統合ライブラリから回路図ライブラリを作成するには、統合ライブラリをオー

プンした際のダイアログで Yes を選択し、ソースライブラリを作成してから編集します。詳しくは

｢統合ライブラリの作成｣チュートリアルを参照してください。 

また、Design » Make Project Library コマンドを使用し、アクティブプロジェクトの回路図ドキュメ

ントで使用している全コンポーネントから新規に回路図ライブラリを作成することも可能です。 
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コンポーネントの作成 

回路図ライブラリの新規作成 
コンポーネントを作成する前に、それを保存する回路図ライブラリを作成しておくことが必要です。

新しい回路図ライブラリの作成方法は以下のステップを実行してください： 

1. メニューから File » New » Schematic Library を選択します。ファイル名称 Schlib1.SchLib 
で新しい回路図ライブラリが空のコンポーネント Component_1 を表示した状態でデザインウィン

ドウに開かれます。 

2. 例えば、ライブラリファイル名称を Schematic Components.SchLib に変更したい場合は、メ

ニューから File » Save As を選択し、セーブするフォルダを指定してから、ファイル名のフィー

ルドに名称を拡張子（.SchLib）付きで入力し 保存(S) ボタンをクリックしてセーブします。 

3. SCH Library タブをクリックし SCH Library パネルをオープンします。 

 

回路図コンポーネントの新規作成 
既存のライブラリに新しい回路図コンポーネントを作成するには通常メニューから

Tools » New Component を選択します。しかし、新しいライブラリを作成した場合に

は空のコンポーネント「Component_1」が既に開かれていますので、ここでは単に

NPN transistor とリネームします。 

1. SCH Library パネルの Components リストから Component_1 をクリックし、メニ

ューから Tools » Rename Component を選択します。New Component Name ダイアログに新し

いユニークな（他と重複しない）識別しやすいコンポーネント名称、例えば TRANSISTOR NPN と

入力します。 

NPN component 
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コンポーネントの作成 

2. もし必要があれば Edit » Jump » Origin [ショートカット J, O] コマンドで原点を画面中央に移動

させます。カーソルが原点にあることを確認するには、画面左下のステータスに表示されている座

標値で確認できます。Altium から供給されたコンポーネントはシートの中心を通るクロスヘアーの

近くに作成されています。コンポーネントの基準ポイントとは、コンポーネント配置の際の基準と

なるポイントのことです。回路図コンポーネントでは、この基準ポイントにもっとも近い“ホット

スポット”（通常はピンの先端）がコンポーネント原点になります。 

2. もし必要があれば Edit » Jump » Origin [ショートカット J, O] コマンドで原点を画面中央に移動

させます。カーソルが原点にあることを確認するには、画面左下のステータスに表示されている座

標値で確認できます。Altium から供給されたコンポーネントはシートの中心を通るクロスヘアーの

近くに作成されています。コンポーネントの基準ポイントとは、コンポーネント配置の際の基準と

なるポイントのことです。回路図コンポーネントでは、この基準ポイントにもっとも近い“ホット

スポット”（通常はピンの先端）がコンポーネント原点になります。 

3.  Library Editor Workspace ダイアログを Tools » Document Options [ショートカット T, D]で開き、

Snap grid を 1 に、Visible grid を 10 に設定します。 
3.  Library Editor Workspace ダイアログを Tools » Document Options [ショートカット T, D]で開き、

Snap grid を 1 に、Visible grid を 10 に設定します。 

ショートカ

を使えば、

リッドが

グル動作で

できます 

セッティングが完了すれば OK をクリックしてダイアログを閉じます

いない場合は Page Up キーを押します。 
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4. NPN トランジスタを例にあげて新規作成してみます。まず始めにコン

します。メニューから Place » Line [ショートカット P, L] を選択する

から Place Line  を選んでライン配置を開始します。その時 TAB キ

PolyLine ダイアログが開いてラインの属性が変更できます。座標(0, 1
垂直のラインを(0,-19) まで引きマウス右クリックで終了させます。次

インを(0,-7)から(10,0)までと(0,-13)から(10,-10)まで引きます。この際

てラインの角度配置モードを Any Angle に変更します。マウス右クリ

ンの配置を終了します。 

5. ポリゴンを使って矢印を作成します。ポリゴンは Place » Polygon  [
ト P, Y] またはツールバーから Place Polygon  を選択して配置し

に TAB キーを押すと Polygon ダイアログが開いて属性を変更できま

頂点を作成したら、右クリックか ESC キーでポリゴン配置モードを

6. コンポーネントをセーブ [ショートカット Ctrl+S] します。 

回路図コンポーネントへのピンの配置 
コンポーネントのピンは、そのコンポーネントに電気的な特性を持った接

更にピンは表示のための属性も持っています。 

回路図ライブラリエディタでコンポーネントにピンを配置するには： 
編集時には

ットキーG
スナップグ

1,5,10 とト

簡単に変更
 

。もしグリッドが表示されて

3 

ポーネントの形状

か、ツールバー

から作成

ーを押すと

)でクリックして

に 2 本の斜めラ

Shift+SPAC
ックまたは E

EBAR を押し

SC キーでライ

ショートカッ

ます。配置中

す。3 角形の

終了します。 

続ポイントを定義します。



コンポーネントの作成 

1. Place » Pin [ショートカット P, P] または ツールバーから  1. Place » Pin [ショートカット P, P] または ツールバーから   をクリックすると、ピンがカーソ

ル上に電気的な接続点と反対側を掴んだ形で表示されるので、そちら側をコンポーネントの外形に

沿って配置します。  

2. ピン配置する前に TAB キーを押すとピンの属性

を変更できる Pin Properties ダイアログが表示さ

れます。ピン配置前に最後が数字で終わるピン

ナンバー(Designator)であった場合は、次のピン

を配置する時に自動的にピンナンバーがインク

リメントします。 

3. Pin Properties ダイアログの Display Name フィ

ールドにはそのピンの名称を、Designator フィ

ールドにはピンの（ユニークな）番号をそれぞ

れ記入します。回路図でピン名やピン番を表示

させる場合には、Visible チェックボックスをチ

ェックしておきます。 

4 T

4. ピンの電気的属性を Electrical Type のプルダウ

ンリストから選択します。このピン属性は、プ

ロジェクトのコンパイル、または回路図ドキュ

メントの解析時に実行される Electrical Rules 
Checker が参照し、ピンの電気的接続エラーの診

断に使用されます。このコンポーネントの例で

は Passive に設定されています。 
外形から

や番号の

い場合

chematic 

ブ内の Pin 
ョンの値

  。 

5.  ピンの長さを Length フィールドに 1/100 インチを単位した値で入力し

このコンポーネントでは 20 を入力して OK をクリックします。 

6. 配置中に SPACEBAR を押せば、ピンが 90°単位で回転できます。ピ

端だけが電気的接続ポイントであり、その端がコンポーネント外形の遠

位置することに注意してください、ピンの非電気的接続ポイントはピン

の側です。   

7. ピン名称、ピンナンバー、電気的タイプを正しく設定して、コンポーネ

に必要なすべてのピンを追加していきます。 

8. コンポーネントへの全てのピンの追加が終了すれば File » Save [ショー

セーブして終了します。 

ピン追加の注意点 
• ピン配置後にピン属性をセットするには、そのピンをダブルクリックす

の Pins リストをダブルクリックします。 

• ピンの名前の上にバーを表示したい場合は、その文字の後ろにバック

例えば M\C\L\R\/VPP と記入すれば表示は となります。 

• 電源や GND ピンなど回路図では表示させないピンは、Hide チェック

ヒドゥン（非表示）ピンは Connect To フィールドに記入されている電

れます。例えばフィールドに VCC と記入されていれば、回路図にコン

には、このピンは自動的に VCC ネットに接続されます。 
コンポーネント

の、ピンの名前

位置を変更した

は、Tools » S
Preferences の

Schematic タ

Margin オプシ

で変更できます

ます。

ンの片

くに

名称
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ント

トカットカット Ctrl+S] で

るか、SCH Library パネル

スラッシュ(\) を記入します。

ボックスをオンにします。

源や GND ネットに接続さ

ポーネントが配置された際



コンポーネントの作成 

• デザインウィンドウ内の全てのヒドゥンピンを表示させるには、View » Show Hidden Pins [ショ

ートカット V, H]を使用します。ピン名称とピンナンバーは同様に表示されます。 

• Component Pin Editor ダイアログを使用すると、ピンの属性がピン個別の Pin Properties ダイアロ

グを経由しないで直接編集できます。Component Pin Editor ダイアログは、Library Component 
Properties ダイアログ左下の Edit Pins をクリックすると表示されます。 

 

• 複数のパートがあるコンポーネントでは、選択されたパートに関連したピンが Component Pin 
Editor ダイアログで白地のバックグランドにハイライト表示されます。その他の選択されていない

パートのピンはグレーのバックグランドですが、同様にピンの編集を行なうことはできます。編集

を行ないたいピンを選択してから Edit ボタンをクリックすれば、Pin Properties ダイアログが表示

されます。 

回路図コンポーネントのプロパティ設定  
各コンポーネントには Default Designator、PCB footprint、Models といった各種プロパティ（属性）

を設定できます。さらに回路図シートで編集できる数々な Parameters などのプロパティも設定できま

す。コンポーネントのプロパティを設定するには： 

1. SCH Library パネルの Components リストから編集したいコンポーネントを選択し、Edit ボタンを

クリックすると Library Component Properties ダイアログが表示されます。 
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コンポーネントの作成 

 

2. Default Designator のフィールドに Q?、Comment フィールドには回路図シートに配置された際に

表示されるコメントとして、例えば NPN と入力とします。?マークは、デジグネーターが回路図に

配置する際に自動的にインクリメント（この場合では Q1, Q2 と）することを可能にします。これ

らを画面に表示させる時は Visible のチェックボックスがオンになっていることを確認してくださ

い。 

3. 他の必要なモデルやパラメータの設定が完了すれば、ダイアログを閉じます。 

回路図コンポーネントへのモデルの追加 
シミュレーションやシグナルインティグリティに使用されるモデルファイルと同様に、回路図コンポ

ーネントに関連した PCB フットプリントのモデルも複数登録しておくことができます。後で回路図の

ドキュメントにコンポーネントを配置する際に、Component Properties ダイアログで適切なモデルを

選ぶことができます。 

コンポーネントにモデルを登録するには、いくつかの方法があります。モデルはベンダーが供給する

モデルファイルをウェブサイトからダウンロードするか、既存の Altium libraries から追加します。

PCB のフットプリントのモデルは C:\Program Files\Altium2004\Library\Pcb フォルダ下の

PCB ライブラリ(.pcblib ファイル)に、シミュレーションに使用する SPICE モデル(.ckt や .mdl フ

ァイル)は C:\Program Files\Altium2004\Library フォルダ下の統合ライブラリの中に用意さ

れています。 

モデルファイルの検索 
Schematic Library エディタでコンポーネントにモデルを追加する場合、コンポーネントからモデル情

報へのリンクは次のサーチ方法によります： 
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コンポーネントの作成 

1. まず、現在オープンしているプロジェクトに含まれているライブラリパッケージが検索されます。 

2. 次にインストールされているリストの順序で、ライブラリから利用可能な（統合ライブラリではな

い）PCB ライブラリが検索されます。なおリストの順序は変更できます。   

3. 最後に、プロジェクトサーチパスで設定されたパスにある全てのモデルライブラリを検索します。

このパスは Options for Project  ダイアログ(Project » Project Options)で設定されています。モデ

ルを検索するために、サーチパスの下位にあるライブラリは読み込まれないことに注意してくださ

い、コンパイラがモデルを検索する場合はそれらを取り込みます 

回路図ライブラリエディタと回路図エディタでの、モデルのサーチ方法に関するより詳しい解説は、

「コンポーネント、モデルおよびライブラリのコンセプト 」アーティクルを参照してください。 

このチュートリアルでは、コンポーネントとモデルファイルのリンク方法について上記の 1. の方法で

行ないます。つまりライブラリパッケージをコンパイルして統合ライブラリを作成する前の、必要な

モデルファイルを回路図ライブラリと共にライブラリプロジェクトに追加した状態を想定しています。 

回路図コンポーネントへのフットプリントモデルの追加 
まず、PCB ドキュメントとのシンクロナイズに使用されるフットプリントを追加します。フットプリ

ントを追加する回路図コンポーネントの名称は BCY-W3 とします。回路図ライブラリエディタで、

PCB フットプリントモデルを回路図コンポーネントにリンクする際、そのモデルは統合ライブラリで

はなく PCB ライブラリに存在する必要があることに注意してください。 

1. Component Properties ダイアログのモデルリストセクションにある Add ボタンをクリックすると

Add New Model ダイアログが開きます。 

 

2. Model Type のドロップダウンリストから Footprint を選択し OK ボタンをクリックすると PCB 
Model ダイアログが開きます。 

3. Browse ボタンをクリックし、開いた Browse Libraries ダイアログに既に存在しているモデルを探

します。（または、PCB ライブラリエディタで作成する予定のモデル名を入力します。） 

4.  Browse Libraries ダイアログで Find ボタンをクリックすると、Search Libraries ダイアログが開き

ます。 

5.  Scope を Libraries on Path にしてから Browse Folder  ボタンをクリックします。開いたフォ

ルダの参照ダイアログで \Altium2004\Library\Pcb フォルダを選んで OK をクリックします。 

6. Search Libraries ダイアログの Include Subdirectories にチェックマークが付いていることを確認

し、Name フィールドに BCY-W3 と入力して Search ボタンをクリックします。 
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コンポーネントの作成 

 

7. Cylinder with Flat Index.PcbLib が検索されたら、Search Libraries ダイアログの Select
ボタンをクリックし、開いた Browse Libraries ダイアログから BCY-W3 を選択してモデルをインス

トールします。OK ボタンをクリックして PCB Model ダイアログに戻ります。 

 

8. OK をクリックしてモデルを追加すると、追加したモデルの名称が Component Properties ダイア

ログのモデルリストに加えられています。 

 

回路シミュレーションモデルの追加  
回路シミュレーションで使用する SPICE モデル(.ckt と.mdl ファイル)は、標準では C:\Program 
Files\Altium2004\Library フォルダの統合ライブラリの中に含まれており、デザインの解析を

行なう場合には、必ず追加する必要があります。 
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コンポーネントの作成 

ライブラリのシミュレーションモデルを利用する場合は、必要なモデルを含んだ.Intlib ファイルを

開き（File » Open コマンドでライブラリを開くとソースライブラリが抽出されます）、モデルファイ

ルをフォルダ（統合ライブラリを開いた際に作成される）からコピーして使用します。 

1.  Component Properties ダイアログのモデルリストセクションにある Add ボタンをクリックします。

開いた Add New Model ダイアログのドロップダウンリストから Simulation を選んで OK をクリ

ックすると SIM Model – General / Generic Editor ダイアログが開きます。 

 

2. この例では Model Kind のドロップダウンリストから Transistor を選択します。選択すると Sim 
Model – Transistor/BJT ダイアログが表示されます。 
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コンポーネントの作成 

3. Model Sub-Kind から BJT を選択し Model Name フィールドにモデルの名称を NPN（モデルファイ

ル名は NPN.mdl になります）と入力します。Description フィールドには NPN BJT と入力し OK
をクリックします。OK をクリックするとモデルリストにモデル名 NPN が追加されている

Component Properties ダイアログに戻ります。 

シグナルインティグリティモデルの追加  
シグナルインティグリティシミュレーションではコンポーネントモデルではなくピンモデルの方を使

用します。シグナルインティグリティシミュレーション用のコンポーネント設定では、デフォルトの

Type と Technology オプションを使用するか IBIS モデルをインポートします。 

1. シグナルインティグリティモデルを追加するには、Component Properties ダイアログのモデルリ

ストセクションの Add ボタンをクリックします。Add New Model ダイアログが開きます。  

2. Model Type のドロップダウンリストから Signal Integrity を選んで OK をクリックすると、Signal 
Integrity Model ダイアログが開きます。 

 

3. IBIS ファイルをインポートするには、Import IBIS ボタンをクリックしてから.ibs ファイルのあ

る場所を指定します。今回の例では Model Name と Description フィールドに NPN と記入し Type
フィールドのプルダウンメニューから BJT を選択します。OK をクリックするとモデルリストに

モデルが追加された Component Properties ダイアログに戻ります。 

 

シグナルインティグリティモデルの追加と編集方法に関する詳細な説明は「シグナルインティグリ

ティ 」チュートリアルを参照してください。 

コンポーネントパラメータの追加    
パラメータとは部品に関する追加情報の設定を意味します。部品の製造元や日付といった、データを

識別するストリングのようなパラメータをドキュメントに記述することができます。ストリングパラ

メータではまた、部品の定数（抵抗であれば 100K といった）を記述することもできます。 
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パラメータには部品を回路図に配置した時に表示されるスペシャルストリングをセットすることがで

き、他のパラメータでは、シミュレーション用の定数や回路図エディタから PCB のデザインルールを

設定する場合などに使用できます。回路図部品にパラメータを追加するには： 

1.Component Properties ダイアログのパラメータリストセクションの Add ボタンをクリックすると、

Parameter Properties ダイアログが表示されます。  

 

2. パラメータの名称と値を入力します、この際パラメータがテキストである場合は、Type フィール

ドで String が選択されていることを確認してください。部品を回路図に配置した際に、値を回路

図に表示させたい場合には、Value フィールドの Visible ボックスにチェックマークを入れてくだ

さい。OK をクリックすると Component Properties ダイアログのパラメータリストに新しいパラ

メータが追加されています。 

間接参照ストリング 
間接参照ストリングを使って、回路図上に表示可能なコンポーネントのパラメータフィールドを設定

することができます。また、回路シミュレーションを実行する際に DXP によって使用させることも可

能です。すべての追加した部品パラメータは間接参照ストリングとして使用することができます。間

接参照ストリングとして使用するとき、パラメータの名称は ‘= ‘ で区切られた接頭辞を持ちます。 

Value パラメータ 
Value パラメータは、部品に関する一般的な情報のために使用することができます。抵抗やコンデン

サーといったディスクリート部品では、シミュレーションで使用する値を入力します。 

PCB エディタ内でコンポーネントの Comment（コメント）として扱われる部品情報を間接参照スト

リングを使用して設定することができます。DXP は Comments フィールドの内容を Value パラメータ

の文字で置き換える間接参照をサポートしており、値を（Value という名称のパラメータと Comment
フィールドに）2 回設定する必要はありません。   
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1. Component Properties ダイアログのパラメータリストセクションの Add ボタンをクリックすると 
Parameter Properties ダイアログが表示されます。 

2. 名称を Value 、値を 100k と入力します。この値は、部品を回路図シートに配置後シミュレーシ

ョンを起動した際に使用されます。パラメータの Type に String が選択されていることと、Value
フィールドの Visible チェックボックスがチェックされていることを確認してください。フォント

の種類や表示色などの項目を設定して OK ボタンをクリックすると、Component Properties ダイ

アログに新しいパラメータがセットされます。 

3. Component Properties ダイアログの Properties セクションの Comment フィールドをクリックし

てから、ドロップダウンリストより =Value を選択し Visible をオフにします。 

 

4. File » Save [ショートカット Ctrl+S]コマンドで、部品と設定した属性をセーブします。 

5. 回路図エディタでスペシャルストリングを表示させる時は、Preferences ダイアログ (Tools » 
Schematic Preferences ) の Graphical Editing タブにある Convert Special Strings オプション

を有効にしておいてください。回路図ドキュメントから PCB ドキュメントをアップデートした後

に、コメントが表示されていない時は、フットプリントの Components ダイアログで Comment が
非表示に設定されていないか確認してください。 

複合パートで構成された回路図部品の新規作成  
チュートリアルの次の章では、4 つのパートで構成された Quad 2-IN AND ゲート 74F08SJX を作成し

ます。さらに IEEE シンボルを使い、別モードの表示も作成します。 

1. 回路図ライブラリエディタのメニューから Tools » New Component [ショートカット T, N] を選

択すると、New Component Name ダイアログが開きます。 

 
74F08SJX のパート A シンボル

2. 新しい部品の名称を 74F08SJX と入力して OK ボタンをクリックします。SCH Library パネルに新

しい部品の名称が追加され、空の状態のシートが原点を中心にして表示されます。 

3. 新しい部品の最初のパートを図「74F08SJX のパート A シンボル」に示した形で、ピンや下記に示

す詳細を含めて作成します。今回の例では、他のパートは最初のパートを原型としてピンナンバー

だけ変更することで作成します。 
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部品外形の作成  
部品の外形は複数のラインやアークなどで構成されます。まず、Edit » Jump » Origin [ショートカッ

ト J, O]コマンドで、原点が画面の中心にあることを確認します。またグリッドが表示されている[ショ

ートカット Page Up]ことも確認してください。 

ラインの配置 
1. メニューから Place » Line [ショートカット P, L] を選択するか、ツールバーの  をクリックす

ると、カーソルがクロスヘアーに変わりライン配置モードになります。 

2. ライン配置中に TAB キーを押すと、ラインのプロパティが変更できます。表示した Polyline ダイ

アログでラインの巾を Small に設定します。 

3. Design Explorer の左下のステータスバーに表示されている X, Y 座標を確認しな

がら、(25, -5)の位置でマウスをクリックまたは ENTER キーを押してラインを引

き始めます。次に、カーソルを次のポイントまで移動させ、クリックでポイント

を確定させます。この様に各頂点を設定していきます。（各頂点の座標は (0,-5); 
(0,-35) と (25,-35)） 

4. ラインの配置が完了したら、マウス右クリックまたは ESC キーを押します。再度

ックまたは ESC キーを押して配置モードを終了し、部品をセーブしておきます。 
、マウス右クリ

アークの配置 
アークは、アークの中心点、半径、アークの開始点と終了点のそれぞれの 4 ポイントを、マウスまた

は Enter キーで指定して配置します。  

1. メニューから Place » Arc [ショートカット P, A] を選択して、アーク配置モードを開始します。 

2. TAB キーを押すと、Arc ダイアログが開いて、アークのプロパティが変更できます。Radius（半

径）を 15、Line Width（線巾）を Small に設定します。 

 

3. カーソルを中心点 (25, -20) のポジションに移動しクリックすると、中心点が確定しカーソルは Arc 
ダイアログで設定した半径 15 mils の位置までジャンプします。 

4. 半径を設定すると、カーソルはアークの開始ポイントにジャンプします。 
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5. カーソルをアーク開始ポイントまで移動させ、クリックで確定させ

るとカーソルはアーク終了ポイントにジャンプします。カーソルを

移動して終了ポイントをマウスで確定させると、アークは確定しま

した。 

6. マウス右クリックまたは ESC キーを押して、アーク配置モードを

終了します。 

非表示ピンが表示された Part A 
ピンの配置 
このチュートリアルの「回路図部品へのピンの配置」で説明したのと同じ方法で、最初のパートへピ

ンを配置します。1 番ピンと 2 番ピンの Electrical types は Input で、3 番ピンは Output の設定です。 

14 TU0103 (v1.0) December 9, 2003  

GND ピン（7 番ピン）と VCC ピン（14 番ピン）の電源供給ピンはヒド

ゥンピン（回路図シートでは表示しない

ピン）です。これらのピンが Part 0 に属

することで、他のパート全てに配置する

ことができます。Part 0 は部品中のすべ

ての部分に共通のピンを格納する場所で、

部品が回路図に配置される時に、この

Part 0 にあるピンは各パートに加えられ

て配置されます。これらのパワーピンの

属性は、Pin Properties ダイアログにある

Logical タブで設定します。設定が Part Number フィールドで Part 0 に、

Electrical Type は‘Power’に、Hide チェックボックスがチェックさ

れており、接続する電源ネットのネット名を Connect To フィールドに

入力します、例えば電源ピン（14 番ピン）の接続ネットが VCC であれ

ば Connect To フィールドには VCC と入力します。以上の点を確認し

てください。 

新パートの作成 
1. Edit » Select » All [ショートカット Ctrl+A] コマンドで、部品をセ

レクトします。 

2. Edit » Copy [ショートカット Ctrl+C] コマンドで、セレクトした内

容をクリップボード（プログラム内だけで有効なクリップボード）

へコピーします。コマンドを起動すると、カーソルがクロスヘアー

に変わるので、部品外形の左上の原点をクリックします。このポイ

ントがコピーするリファレンスポイントとなり、ペーストする際の

基準点となります。 
コピー＆ペーストで全て

のパートを作成した後に

Component Edit Pins ダ
イアログ（Component 
Properties ダイアログで
Edit Pins ボタンをクリ
ックして表示）を使って
ピンの情報を更新する方
法も使用できます。 

3. メニューから Tools » New Part を選択すると、パートが追加されブラン

クのシートが表示されます。SCH Library パネルのパートの集計が更新さ

れ、部品名称左側の+マークをクリックすると、Part A と Part B と表示さ

れています。  

4. Edit » Paste [ショートカット Ctrl+V] を選択すると、先ほどコピーした部

品の外形のアウトラインが、カーソル上に表示されます、カーソルはリフ
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ァレンスポイントを掴んだ状態ですので、リファレンスポイントを原点に置いてペーストします。  

5. ペーストして新たに作成した Part B のピンをダブルクリックして Pin Properties ダイアログを表示

させ、ピンの名称とピンナンバーを変更します。 

Part B  

6. 上記 3 から 5 を繰り返し、Part C と Part D を作成しライブラリをセーブします。 

Part C       Part D 

オルタネートモードのパート作成 
1 つの部品パートに 255 種類の異なったオルタネート表示シンボルを設定することができます。これ

らのオルタネート表示モデルはド・モルガンや IEEE シンボルなど、部品に異なったグラフィカル表

示を設定することができます。IEEE 用 のシンボルは回路図ライブラリエディタの IEEE ツールバー

（View » Toolbars » Utilities）に用意されています。  

オルタネート表示シンボルを追加すると、Mode ボタンのドロップダウンリストからオルタネートの

表示を切り替えて回路図ライブラリエディタで表示できるようになります。部品が回路図シートに配

置された場合は、Component Properties ダイアログのモードドロップダウンリストで表示モードを切

り替えることができます。 

回路図ライブラリエディタのデザインウィンドウでオルタネート表示モードを追加するには： 

1.   ボタンか、メニューから Tools » Mode » Add を選択すると、 Alternate 1 用のブランクのシー

トが新たに作成されます。 

2.   一例として、下図に示したような IEEE シンボルを作成して、パートをライブラリにセーブしま

す。 

 
IEEE シンボル表示の Alternate 1 
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部品属性の設定 
1. SCH Library パネルの Components リストから部品を選択して Edit ボタンをクリックすると、部

品属性が設定できます。開いた Library Component Properties ダイアログの Default Designator フ
ィールドに U? 、Description フィールドに Quad 2-Input AND Gate と入力し、モデルリスト

のフットプリント名称に DIP14 と追加します。尚、DIP14 のフットプリントモデルは、このチュ

ートリアルの後でウィザードを使って作成します。 

2. File » Save [ショートカット Ctrl+S] を選択して部品をライブラリへセーブします。 

他のライブラリから部品の追加 
他のオープンされた回路図ライブラリから部品を複製し、それらの属性を編集することができます。

もし、その部品が統合ライブラリの部品であった場合には、.IntLib ファイルを開く (File » Open)
際のダイアログで Yes を選択して、統合ライブラリからソースライブラリ(.Schlib)を作成し、

Projects パネルからオープンできる状態にしておく必要があります。 

1. コピーしたい部品を表示しているデザインウィンドウ内の SCH Library パネルの Components リ
ストから選択します。 

2. 現在オープンされているライブラリから他のライブラリをコピーするために、メニューから Tools 
» Copy Component を選択します。Destination Library ダイアログが表示され、現在オープンされ

ている全てのライブラリのリストが表示されます。コピー先のライブラリをそのリストから選択し

ます。  

3. 部品をコピーしたいドキュメントを選択し、OK をクリックします。部品はコピーされますので、

必要があれば、コピー先で編集することができます。 

複数部品のコピー 
SCH Library パネルを使って、複数の部品を現在オープンしている他のライブラリへコピーすること

ができます。 

1. ウィンドウズの標準的な選択の操作 (クリック、 SHIFT+クリック、 CTRL+クリック) を使って複

数の部品を、SCH Library パネルの Components リストから選択し、マウス右クリックから Copy
を選択します。 

2. コピー先のライブラリへ移動し、SCH Library パネルの Components リストでマウス右クリックか

ら Paste を選択するとリストに部品が追加されます。 

ライブラリレポートを使用しての部

品チェック  
新規に作成した部品をチェックするために、現在開いて

いるライブラリから 3 種類のレポートを生成すること

ができます。全てのレポートは ASCII テキストで生成

されます。 
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レポートを生成する前に、ライブラリファイルがセーブされていることを確認します。回路図ライブ

ラリエディタに戻るには、レポートファイルを閉じます。 

部品レポート 
現在アクティブな部品の情報をレポートするには： 

1. Reports » Component [ショートカット R, C] を選択します。 

2.  'libraryname.cmp' の名称でレポートが作成されパートの数やピンの詳細がテキストエディタで

表示されます 

ライブラリレポート 
ライブラリに含まれている部品や概要をレポートするには： 

1. Reports » Library [ショートカット R, L] を選択。 

2. レポートが libraryname.rep の名称で作成され、テキストエディタで表示されます。 

部品ルールチェッカー 
部品ルールチェッカーは、ピンの重複や抜けなどをレポートします。 

1. Reports » Component Rule Check [ショートカット shortcut R, R] を選択すると、Library 
Component Rule Check ダイアログが表示されます。  

2. チェックしたい項目をセットして OK をクリックします。ルールチェックの項目に違反した部品

がリストされたレポートファイルが名称 libraryname.err で生成され、テキストエディタで表

示されます。 

3. ライブラリの違反箇所を修正し、レポートを再実行します。 

PCB フットプリントの新規作成 
チュートリアルのこの部分では、以下の項目を説明します： 

• PCB ライブラリの新規作成 

• Component Wizard を使ってフットプリントを作成 

• 特殊なフットプリントを手動で作成 

• フットプリント内で配線プリミティブを使用 

フットプリントは PCB エディタで作成し、PCB ライブラリにコピーすることも可能です。あるいは

PCB ライブラリ間でコピーする、PCB ライブラリエディタの PCB コンポーネントウィザードまたは

ドローイングツールで最初から作成する方法があります。既に PCB デザインにフットプリントが配置

されていれば、PCB エディタで Design » Make PCB Library コマンドを使えば、そのファイルだけ

で使用されているライブラリを作成することができます。 

DXP には、PCB デザインで使用できるスルーホール部品や SMD 部品の標準的なフットプリントが用

意されています。これらのフットプリントライブラリ(.PcbLib ファイル) は、DXP をインストール

したディレクトリの\Altium2004\Library\Pcb フォルダにあります。 

チュートリアルのこの項では、新しいフットプリントの作成手順の実例を説明しますが、具体的なフ

ットプリントの寸法などは、コンポーネントメーカーのデーターブックを確認してください。 
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PCB ライブラリの新規作成 
PCB ライブラリを新規作成するには： 

1. メニューから File » New » PCB Library を選択すると、PcbLib1.PcbLib のファイル名でライブ

ラリドキュメントが作成され、デザインウィンドウに空のシートが名称 PCBComponent_1 と表示

されます。 

2. File » Save As コマンドで新規の PCB ライブラリドキュメントを PCB Footprints.PcbLib に

名前を変えてセーブします。 

3. PCB Library タブをクリックして、PCB ライブラリエディタパネルを表示させます。 

 

4. PCB ライブラリエディタのコマンドを使って、フットプリントコンポーネントの追加、削除、編

集の作業ができます。 

PCB コンポーネントウィザードの使用 
PCB ライブラリエディタには、一連の質問に答えていくだけでコンポーネントフットプリントが作成

できるコンポーネントウィザードが装備されています。このウィザードを使用して DIP14 のフットプ

リントを作成してみます。 

コンポーネントウィザードを使って、新しいコンポーネントフットプリント DIP14 を作成するには： 

1. メニューから Tools » New Component [ショートカット T, C] を選択するか、PCB Library パネル

でマウス右クリックして Component Wizard を選択すると、コンポーネントウィザードがスタート

します。Next >ボタンをクリックしてウィザードを継続します。 
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2. 利用可能なオプションを選択することで、ウィザードからの質問に答えていきます。今回の例での

DIP14 のパッケージを作成するには、Dual in-line Package (DIP)のパターン

を選択し、Unit（単位）に Imperial (mill)を選択し Next >ボタンをクリックし

ます。次の画面ではパッドのサイズを 60mil、ドリルサイズを 32mil と指定し

ます。次の画面で、パッドの間隔を水平方向が 300mil、垂直方向に 100mil
入力します。単位を省略した場合は、先に指定した単位（今回は Imperial 
(mill)）が使用されます。次にシルクスクリーンの線巾を 10mil と指定し、総

ピン数を 14 と指定します。 

と

3. 最後に作成したコンポーネントの名称が DIP14 であることを確認して Next 
>ボタンをクリックすると、ウィザードの最終ページが表示されますので、

Finish ボタンをクリックしてコンポーネントの作成を終了します。新しく作

成したフットプリント DIP14 が PCB Library パネルの Components リストに

追加され、デザインウィンドウに表示されていますので、必要な修正をコンポーネントに加えるこ

とができます。 

4. File » Save [ショートカット Ctrl+S] コマンドで、フットプリントコンポーネントをライブラリに

セーブします。 

コンポーネントフットプリントを手動で作成 
フットプリントは、PCB エディタにあるデザインオブジェクト配置ツールと同様なツールを使って、

PCB ライブラリエディタ内で作成や修正をすることができます。PCB のフットプリントとして、コー

ナーマークや合わせガイドなど、電気的オブジェクト以外の部品も登録することができます。  

コンポーネントフットプリントを作成する場合、ピン以外にもコンポーネントの外形を示すトラック

やアークなどを配置することがあります、これらのオブジェクトはどんなレイヤーにも配置すること

が可能です、例えばコンポーネントの外形は Top Overlay（シルクスクリーン）レイヤーに配置され、

パッドは信号層に配置されます。フットプリントを PCB ドキュメントへコンポーネントとして配置し
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た場合、フットプリントを構成しているオブジェクトは全て、それらの定義されたレイヤーに割り当

てられます。 
た場合、フットプリントを構成しているオブジェクトは全て、それらの定義されたレイヤーに割り当

てられます。 

コンポーネントフットプリントの手動での作成方法は： コンポーネントフットプリントの手動での作成方法は： 

1. メニューから Tools » New Component [ショートカット T, C] を選択するか、PCB Library パネル

でマウス右クリックして New Blank Component を実行します。 
1. メニューから Tools » New Component [ショートカット T, C] を選択するか、PCB Library パネル

でマウス右クリックして New Blank Component を実行します。 

2. コンポーネントウイザードがスタートした場合、Cancel ボタンをクリックして、ウィザードを終

了させます。空のコンポーネントフットプリント（PCBComponent_2）がワークスペースに表示

され、手動作成が開始できます。 

2. コンポーネントウイザードがスタートした場合、Cancel ボタンをクリックして、ウィザードを終

了させます。空のコンポーネントフットプリント（PCBComponent_2）がワークスペースに表示

され、手動作成が開始できます。 
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原点マークが表示されて

いない場合は、Tools » 
Preferences [ショート

カット T, P]を選択し、 
Display タブ内の Origin 
Marker オプションをチ

ェックしてください 。 

3. このデフォルトのフットプリント名を変更するには、PCB Library パネルのリストから

PCBComponent_2（2.で新規作成された）をダブルクリックし、表示され

た PCB Library Component ダイアログ でコンポーネントの名称を変更し

ます。 

3. このデフォルトのフットプリント名を変更するには、PCB Library パネルのリストから

PCBComponent_2（2.で新規作成された）をダブルクリックし、表示され

た PCB Library Component ダイアログ でコンポーネントの名称を変更し

ます。 

4. 表示されている原点マーク（ワークスペースの 0, 0 基準ポイントの表示マ

ーク）の近くにコンポーネントフットプリントを作成するようにしてくだ

さい。カーソルを 0, 0 ポイント（ワークスペースの原点）へジャンプさせ

るには Edit » Jump » Reference [ショートカット J, R]コマンドを使用し

ます。 

4. 表示されている原点マーク（ワークスペースの 0, 0 基準ポイントの表示マ

ーク）の近くにコンポーネントフットプリントを作成するようにしてくだ

さい。カーソルを 0, 0 ポイント（ワークスペースの原点）へジャンプさせ

るには Edit » Jump » Reference [ショートカット J, R]コマンドを使用し

ます。 

基準ポイントは、コンポーネントを配置する際の基準となるポイントで、通常はパッドの一番ピン

か、コンポーネントの中心に置かれます。この基準ポイントは Edit » Set Reference コマンドの

サブメニューのオプションで、セットすることができます。 

基準ポイントは、コンポーネントを配置する際の基準となるポイントで、通常はパッドの一番ピン

か、コンポーネントの中心に置かれます。この基準ポイントは Edit » Set Reference コマンドの

サブメニューのオプションで、セットすることができます。 

フットプリントへのパッドの配置 フットプリントへのパッドの配置 
コンポーネントフットプリントの作成で、もっとも重要な点は PCB 基板にコンポーネントをハンダ付

けするのに必要なパッドの配置です。パッドはデバイスのピンの位置に正確に配置される必要があり

ます。 

コンポーネントフットプリントの作成で、もっとも重要な点は PCB 基板にコンポーネントをハンダ付

けするのに必要なパッドの配置です。パッドはデバイスのピンの位置に正確に配置される必要があり

ます。 

フットプリントへパッドを配置するには： フットプリントへパッドを配置するには： 

1. パッドを配置する前に、デザインウィンドウ下部の Top Layer タブをクリックします。 1. パッドを配置する前に、デザインウィンドウ下部の Top Layer タブをクリックします。 

2. メニューから Place » Pad [ショートカット P, P] を選択するか、2. メニューから Place » Pad [ショートカット P, P] を選択するか、  ボタンをクリックするとパッ

ドがカーソル位置に表示されます。パッドを配置する前に TAB キーを押すと、パッドのプロパテ

ィを設定できる Pad ダイアログが表示されます。 



コンポーネントの作成 

 

3. パッドのサイズと形状を設定し、Designator フィールドに 1（コンポーネントのピンナンバーと一

致した番号）と入力し、OK をクリックします。 

4. カーソルを原点位置 （0, 0）に合せてクリックするか、ENTER キーを押して最初のパッドを配置

します。 

5. 必要に応じ、次のパッドを配置する前に TAB キーを押してパッドの属性を変更します。パッドの

ピンナンバー（Designator）は自動的にインクリメントします。 

6. 必要なパッドの配置が終わったら、マウス右クリックか ESC キーを押して、パッドの配置モード

を終了します。 

7. File » Save [ショートカット Ctrl+S] コマンドでフットプリントをセーブします。 

パッドのデジグネーターとペーストアレイ 
パッドにはスペースを含めず 4 桁までの数字か、アルファベットで構成されたデジグネーター（通常

コンポーネントのピンナンバーを表す）ラベルを付けることができます。デジグネーターは、もし必

要ならばブランクのまま残すこともできます。デジグネーターの最後の文字が数字の時は、パッドを

連続的に配置する場合数字が自動的にインクリメントします。1A, 1B といったアルファベットや数字

を 1 以外の数値でインクリメントするには、ペーストアレイの機能を使用します。 

パッドのデジグネーターをセットし、クリップボードへ

ダイアログの Text Increment フィールドにインクリメ

ントする数値を入力します。以下のパッドデジグネー

ターがペーストアレイ機能で配置できます： 

• 数字 (1, 3, 5) 

コピーしてからペーストする際に Paste Array 

 (A, B, C) 

み合わせ(A1 A2,  1A 1B,  

数字をインクリメントするには、Text Increment フィ

• アルファベット

• アルファベットと数字の組

A1 B1,  1A 2A, など) 

ールドにインクリメントしたい数値を入力します。ア

ルファベット順にインクリメントしたい場合は、スキ

TU0103 (v1.0) December 9, 2003 21 



コンポーネントの作成 

ップしたい数の文字を Text Increment フィールドに入力してください。例えば、最初のパッドのデジ

グネーターが 1A の時、Text Increment フィールドに A（アルファベットの 1 番目の文字）と入力する

とインクリメントしたデジグネーターは 1A, 1B, 1C・・・となります。Text Increment フィールドに

C（アルファベットの 3 番目の文字）と入力するとインクリメントしたデジグネーターは 1A, 1D（A
から 3 文字後ろ）、1G, 1J・・・となります。 

ップしたい数の文字を Text Increment フィールドに入力してください。例えば、最初のパッドのデジ

グネーターが 1A の時、Text Increment フィールドに A（アルファベットの 1 番目の文字）と入力する

とインクリメントしたデジグネーターは 1A, 1B, 1C・・・となります。Text Increment フィールドに

C（アルファベットの 3 番目の文字）と入力するとインクリメントしたデジグネーターは 1A, 1D（A
から 3 文字後ろ）、1G, 1J・・・となります。 

1. まず必要なデジグネーター例えば 1A と設定した初期パッドを作成します。このパッドを Edit » 
Copy [ショートカット Ctrl+C]コマンドでクリップボードへコピーします。パッドのセンターをク

リックしコピーするリファレンスポイントをパッドのセンターに決めます。 

1. まず必要なデジグネーター例えば 1A と設定した初期パッドを作成します。このパッドを Edit » 
Copy [ショートカット Ctrl+C]コマンドでクリップボードへコピーします。パッドのセンターをク

リックしコピーするリファレンスポイントをパッドのセンターに決めます。 

2. Select Edit » Paste Special [ショートカット E, A] コマンドを選択し、Paste Special  ダイアログ

を表示します。Paste on current layer と Keep net name オプションをチェックします。 
2. Select Edit » Paste Special [ショートカット E, A] コマンドを選択し、Paste Special  ダイアログ

を表示します。Paste on current layer と Keep net name オプションをチェックします。 

3. Paste Array ボタンをクリックすると Setup Paste Array ダイアログが表示されます。 3. Paste Array ボタンをクリックすると Setup Paste Array ダイアログが表示されます。 

4. Item Count フィールドに 5、Text Increment フィールドに C と入力します。また Array Type を
Linear に設定し、Linear Array のフィールドにコピーされるパッドのピッチを入力して OK をクリ

ックます。 

4. Item Count フィールドに 5、Text Increment フィールドに C と入力します。また Array Type を
Linear に設定し、Linear Array のフィールドにコピーされるパッドのピッチを入力して OK をクリ

ックます。 

5. 配置の開始位置でクリックすると、設定した項目に従ってデジグネーターがインクリメントしてア

レイ配置します。 
5. 配置の開始位置でクリックすると、設定した項目に従ってデジグネーターがインクリメントしてア

レイ配置します。 

フットプリントの外形作成 フットプリントの外形作成 プリントは

r で作成し

品配置の時

er へ配置し

ショートカ

ます。

製造工程でシルクスクリーンマスクとして使用される Top Overlay レイ

に、フットプリントの外形を作成します。この外形は部品実装のガイド

ても使用されパッドの配置同様に重要です。 

製造工程でシルクスクリーンマスクとして使用される Top Overlay レイ

に、フットプリントの外形を作成します。この外形は部品実装のガイド

ても使用されパッドの配置同様に重要です。 
 1.  ライン（トラック）配置する前に、デザインウィンドウ下部にある

Overlay レイヤーのタブをクリックします。 
1.  ライン（トラック）配置する前に、デザインウィンドウ下部にある

Overlay レイヤーのタブをクリックします。 

2. まず、フットプリントの寸法が製造規格に合っているかチェックします、Q キーを押す度に、座標

がインペリアル (mil 単位) とメトリック（mm 単位）に切り替わります。単位を切り替えて各ポイ

ントの寸法を、画面下部のステータスバーに表示される座標値でチェックします。グリッドなどの

設定は Tools » Library Options で変更できます。 

2. まず、フットプリントの寸法が製造規格に合っているかチェックします、Q キーを押す度に、座標

がインペリアル (mil 単位) とメトリック（mm 単位）に切り替わります。単位を切り替えて各ポイ

ントの寸法を、画面下部のステータスバーに表示される座標値でチェックします。グリッドなどの

設定は Tools » Library Options で変更できます。 

3. 外形を作画するには、Place » Line[ショートカット P, L] コマンドか、3. 外形を作画するには、Place » Line[ショートカット P, L] コマンドか、  
ボタンをクリックし、ラインを Top Overlay レイヤーに配置します。 に配置した

なおしたい

SPACE キー

した最後の

ントから順

。 

4.  トラックの開始ポイントでクリックします。 

5. TAB キーを押すと Line Constraints ダイアログが表示されるのでライ

が 0.2mm となっていることを確認します。 

6. 各トラックの折れ曲がり点でクリックし、外形線を引いていきます。

ックの終了点ではマウス右クリックで終了します。 

7.  トラックの配置が完了したらマウス右クリックか、ESC キーを押して

させます。 

デジグネーターとコメントのスペシャルストリングの

PCB にコンポーネントを配置する前に PCB ライブラリエディタで、.De
シャルストリングを配置することができます。これらのテキストは、位

をあらかじめフットプリントに設定しておくことができます。これらは

22 
 トラック配置時

トラックを引き

場合は、BACK
を押すと、配置

トラックセグメ

に削除されます

ン巾

トラ
面実装のフット

常に Top Laye
ます。これを部

に Bottom Lay
たい場合は、L
ットキーを使い

ヤー

とし

ヤー

とし

Top Top 
トラック配置モードを終了

配置 
signator や.Comment のスペ

置、配置レイヤーや属性など

PCB ドキュメントにコンポー
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ネントが配置された際、Component ダイアログの Designator と Comments セクションの Hide オプ

ションの設定で非表示にすることができる通常のデジグネーターやコメントとは別に追加できます。 

通常、これらのスペシャルストリングは、部品配置図を作成するためにメカニカルレイヤーに配置します。

メカニカルレイヤーを表示するには、Tools » Layers & Colors を実行し、表示される Board Layers and 
Colors ダイアログ内 Mechanical layer フィールドの Enable をクリックしてから Show をクリックしま

す。 

1. デザインウィンドウ下部の Mechanical レイヤータブをクリックして、レイヤーをアクティブにす

るとタブはハイライト表示され、次に配置するテキストはこのレイヤーに配置されます。  

2. Place » String [ショートカット P, S] または、Place String ボタン をクリックします。 

3.  TAB キーを押すとテキストの入力や、フォント、配置レイヤー、サイズなどのテキストの属性が

テキスト配置前に設定できる String ダイアログが開きます。Text フィールドのドロップダウンリ

ストから .Designator を選択して、Text height（文字の高さ）を 60mil に Width（文字の線巾）を

10mil に設定して OK をクリックします。 

4. テキストを目的の位置まで移動してクリックするとテキストが配置されます。 

5. 同様の方法でスペシャルストリング .Comment も配置します。 

6. マウス右クリック、または ESC  キーを押して、テキスト配置モードを終了します。 

フットプリントを PCB ドキュメントへ配置した際にスペシャルストリングが正常に表示されない場合

は、PCB エディタの Preferences ダイアログ (Tools » Preferences ) の Display タブ Convert 
Special Strings オプションがオンになっていることを確認してください。 

PCB フットプリントへの高さ情報の付加 
フットプリントへ高さの情報を設定するには、PCB Library パネル内 Components リストのフットプ

リント名称をダブルクリックして表示される PCB Library Components ダイアログで、Height フィー

ルドにそのコンポーネントの高さを入力して OK  をクリックします。 
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異型パッドを持ったフットプリントの作成  
SOT89 を例にして異型パッドを作成する方法を紹介します。異型パッドを作成するには、パッド同士

を接続したり、あるいはパッドにトラックを接続することで実現できます。チュートリアルのこのセ

クションでは、表面実装部品 SOT89 のフットプリントに複数の配線プリミティブが含まれる場合と同

じピンに複数の接続ポイントを持つ場合について説明します。 

下図はミリ単位での、SOT89 フットプリントの寸法図面です。  

Dimensions 
(millimeters) 

 

A 5.00 

B 6.00 

C 1.35 

D 0.70 

E 1.90 

F 3.30 

G 2.30  

1. もし必要ならば、Q キーを押してインペリアル (mil) か、メトリック (mm) と単位系を変えること

ができます。現在アクティブな単位系は、DXP ウィンドウの下部のステータスバーに表示されて

いる座標値で確認することができます。 

2. Tools » Library Options[ショートカット T, O] コマンドで表示グリッドとスナップグリッドを確

認し、表示グリッドは 10mm、スナップグリッドを 1mm にセットします。 

パッドの配置 
フットプリント SOT89 を作成する際、リファレンスポイン

ト（フットプリントの原点）を 1 番ピンに設定します。つま

り、1 番ピンのセンターの座標が(0, 0)となります。 

1. パッドをフットプリントの Top Layer に配置するには、

Place » Pad [ショートカット P, P] を選択するか、  ボ
タンをクリックします。TAB キーを押して表示される

Pad ダイアログでパッドの属性を変更できますので、

Layer が Top Layer、Designator が 1（部品のピンナン

バーに一致すること）、hole size が 0mm であることを

確認して OK をクリックします。 

2. カーソル位置を合せて 3 個のパッドを配置します、この

時デジグネーターは自動的にインクリメントします。マ

ウス右クリックか ESC キーを押してパッド配置モードを

終了させます。次に配置する 0 番ピンに接続できるよう
SOT89 footprint 
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に 2 番ピンの長さと位置を修正します。 に 2 番ピンの長さと位置を修正します。 

3. 最後に 0 番ピンを配置します、Pad ダイアログの Size and Shape を Simple と Octagonal にセッ

トしてパッドのサイズと形状を設定します。 
3. 最後に 0 番ピンを配置します、Pad ダイアログの Size and Shape を Simple と Octagonal にセッ

トしてパッドのサイズと形状を設定します。 

コンポーネント外形の作成 コンポーネント外形の作成 
1.  コンポーネントのアウトラインを Top Overlay レイヤーに作成します。まずデザインウィンドウの

下部の Top Overlay タブをクリックします。次に Place » Line [ショートカット P, L] か、

1.  コンポーネントのアウトラインを Top Overlay レイヤーに作成します。まずデザインウィンドウの

下部の Top Overlay タブをクリックします。次に Place » Line [ショートカット P, L] か、 ボ

タンをクリックしてライン配置モードにします。 

2. 4 角形の最初のコーナーでクリックし、TAB キーを押して Line Constraints ダイアログを表示しま

す。ダイアログで Width をセットしレイヤーが Top Overlay であることを確認してから OK をクリ

ックします。各コーナーをクリックし、最初のコーナーまで戻ったら、マウス右クリックか、ESC
キーを押してライン配置モードを終了します。 

3. このフットプリントでは、1 番ピンの傍に 1 番ピンの表示を付けます：今回の例では 1 番ピン横の

Top Overlay にサークルを配置しますが、アウトラインの 4 角形を面取りしての表示方法もありま

す。サークルの配置は、Place » Full Circle [ショートカット P, U] または   ボタンをクリックし

ます。サークルの中心点をクリックしてからカーソルを半径 5mil の位置まで移動させてクリック

します。マウス右クリックか、ESC キーを押してサークル配置モードを終了します。サークルを

ダブルクリックすると Arc ダイアログが表示されますので、Width を 10mil に変更すると塗りつぶ

された円が作成できます。 

ソルダーマスクとペーストマスクのチェック 
ソルダーマスクとペーストマスクは、パッドごとに Solder Mask と Paste Mask のそれぞれのレイヤ

ーに自動的に作成されます。マスクレイヤーの形状はパッドの形状から作成され、マスクのサイズは

Pad ダイアログで設定した値か、または PCB エディタのデザインルールで設定した値が使用されます。 

マスクの表示 
PCB ライブラリエディタで自動的に作成されたソルダーまたはペーストマスクの確認をします。今回

の例では Top Solder レイヤーを表示して確認してみます。 

1. このレイヤーを表示するには Tools » Layers & Colors  [ショートカット L] を選択して表示され

る、Board Layers & Colors ダイアログの Mask Layers セクションの Show ボックスがオンになっ

ていることを確認します。 

2. デザインウィンドウ下部の Top Solder レイヤータブをクリックして、トップソルダーマスクを表

示させます。ショートカットキーShift+S を押し、表示をシングルレイヤーモードに切り替えます。 
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デザインルールを使ってのマスクサイズ設定 
デザインルールを使って、マスクの大きさを設定したい場合は： トラックまたは他のオブジ

ェクトを使用してフットプ

リントを作成した場合、ソ

ルダーやペーストマスク

を、マスクレイヤーにトラ

ックなどで入力する必要が

あります。 

1. Pad ダイアログの Paste Mask Expansion 、または Solder Mask Expansion
セクションの Expansion value from rules を選択します。 

2. PCB エディタのメニューから Design » Rules を選択し、表示された PCB 
Rules and Constraints Editor ダイアログの Mask カテゴリーでマスクのサイ

ズを設定できます。設定したデザインルールは、フットプリントが PCB に
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配置されてから有効になります。 

マスクのサイズ指定 
デザインルールで設定したマスクサイズを無視して、マスクサイズの設定を行なうには： 

1. Pad ダイアログの Paste Mask Expansion または Solder Mask Expansion セクションの Specify 
expansion value を選択します。 

2. 希望するマスクのサイズ（パッドサイズを基準にして、拡大または縮小する値）を入力してから

OK をクリックし、フットプリントをセーブします。 

配線プリミティブを含んだコンポーネントフットプリント 
ライブラリコンポーネントフットプリントには、信号層に配置したトラ

ックやアークなどの配線プリミティブを含ませることができます。右の

サンプルの様に SOT89 のフットプリントの 2 番ピンには、巾の広いラ

インが長方形のパッドに接続され、全体で 2 番ピンを形成しています。

これは先ほど 8 角形を使用して異型パッドを作成した方法の別のやり方

です。 

この様にフットプリントにラインやフィルなどの配線オブジェクトを追

加した場合は、パッドにだけネットが付き、他のシグナルレイヤーのオ

ブジェクトにはネットが付かないので、コンポーネントを PCB 上で動

かした場合などに、オンライン DRC によってショートエラーと認識さ

れてしまいます。しかしネット名を PCB ドキュメントに配置されたコ

ンポーネントのこれら配線プリミティブに付加することはできます。 

PCB ドキュメントに於いて、配置したフットプリントのプリミティブ
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から Design » Netlist » Update Free 

2. 線プリミティブへ再同期します。このコマン

同一ピンに複数の接続ポイントを持つフットプリント 
接続ポイントを持っていま

にネットを付加するには： 

1. PCB エディタのメニュー

信号層にトラックを配置して作成し
た異型パッドを持つ SOT89 フット

プリント Primitives from Component Pads を選択します。 

パッドが持つネット名をそのパッドに接続している配

ドは接続されているプリミティブをすべて同じパッドと同じネット（同電位）にします。 

下図のフットプリントの様に、TO-3 パッケージのトランジスタは、複数の

す。3 番ピンが 2 ヶ所にあることに注意してください。 
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回路図エディタで Design » Update PCB コマンドを実行し、回路図から PCB へデザインの情報を移

行した場合、下図の様に同一ピンナンバーのピンは、同一のネット名が付加されます。 

 

フットプリントへのソルダーマスク追加  
右の図のフットプリントは、名称 LCR1_KC1 のプッシュスイ

ッチ電極です。このフットプリントのシグナルレイヤー(Top 
Layer) はトラックとパッドで構成され、ソルダーマスクはア

ウトライン (Top Overlay) 内側に近いサイズの円形となってい

ます。 

1.  Top Overlay レイヤーにアウトラインを作成するには、デ

ザインウィンドウ下部の Top Overlay タブをクリックして

から Place » Full Circle [ショートカット P, U] またはツー

ルバーの ボタンをクリックします。座標(0, -80) mil で
クリックし、サークルのセンターを決定します。次に(100, 
-80) までカーソルを移動しクリックすると半径 100mil の
円が描けます。マウス右クリックか、ESC キーを押してサ

ークル配置モードを終了します。 
LCR1_KC1 フットプリント 

2. 次に Top Solder レイヤーにソルダーマスクを作成します。

このレイヤーを表示するために Tools » Layers & Colors 
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[ショートカット L]で Board Layers ダイアログを表示させ、Mask Layers  セクションの Top 
Solder 右の Show ボックスをチェックします。 

デザインウィンドウ下部の Top Solder タブをクリックし、センター座標(0, -80 mil)、半径 45 mil、
ライン巾 100mil の塗りつぶされたサークルを、先に示した方法で描きます。マウス右クリックか

ESC キーを押してサークル配置モードを終了します。 

3. デザインウィンドウ下部の Top Layer タブをクリックし、トラックとアークを使って電極の部分

を描きます。マウス右クリックか、ESC キーを押してトラック配置モードを終了します。 

4. フットプリントの Top Layer にパッドを配置するには、Place » Pad [ショートカット P, P] または 
ボタンをクリックします。TAB キーを押すとパッドのプロパティを変更できる Pad ダイアログ

が表示されるので、Size and Shape セクションを Simple に設定しパッドのサイズを X,Y とも

10mil、Shape をドロップダウンリストから Round を選択します。Layer が Top Layer に、

Designator が 1（部品のピンナンバーに合せること）に、Hole Size は 0mil に設定されていること

を確認して OK をクリックします。 

5. カーソルを原点（0,0）に移動し、クリックして最初のピンを配置します。次のピンを(0,-160mil) 
の位置に配置します。この時デジグネーターは自動的にインクリメントしています。マウス右クリ

ックか、ESC キーを押してパッド配置モードを終了します 

6. File » Save [ショートカット Ctrl+S] を実行して、フットプリントをセーブします。 

他のソースにあるフットプリントの追加 
既存のフットプリントを、他のライブラリに追加することができます。コピーしたフットプリントの

名前や属性などを変更して利用できます。 

他のソースに有るフットプリントをコピーして追加するには： 

• PCB ドキュメントに配置されているフットプリントを選択、コピー(Edit » Copy) し、Edit » 
Paste Component コマンドで PCB ライブラリにペーストします、または 

• PCB ライブラリエディタで Edit » Copy Component を実行しフットプリントをコピーした時は、

別の PCB ライブラリに移ってから Edit » Paste Component コマンドを実行しペーストします。

コピーされたフットプリントは、デザインウィンドウの PCB Library パネル内の Components リス

トに追加されています。 

コンポーネントフットプリントの確認  
回路図ライブラリエディタの場合と同様に、PCB ライブラリ内のコンポーネントが正確に作成された

フットプリントであるかの一連のチェックが可能です。PCB ライブラリ内のコンポーネントの確認に

は、Component Rule Check が出力するレポートが利用できます。Component Rule Checker はピンの

ダブり、デジグネーターの抜け、未接続やショートしたカッパー、不適当なコンポーネントリファレ

ンスなどのテストが可能です。 

1. レポートを出力する前に、ライブラリをセーブしておきます。 

2. Reports » Component Rule Check [ショートカット R, R] を実行し、Component Rule Check ダ
イアログを表示させます。  
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3. チェックしたい項目のチェックボックスをクリックし、OK をクリックします。エラー箇所がレポ

ートされたファイルが、ファイル名 PCBlibraryfilename.err で出力されテキストエディタで

表示されます。 

4. レポートを閉じると、PCB ライブラリエディタに復帰します。 

統合ライブラリの作成 
ここまでの解説で、いくつかのコンポーネントを含んだ回路図ライブラリとフットプリントモデルを

含んだ PCB ライブラリを作成し終わりました。これらのライブラリを統合ライブラリへコンパイルし、

まとめて統合化することができます。これらのコンポーネントは、それらのモデルを常に保持できる

様になります。コンパイルする前にシミュレーションのモデルファイルは、ソースライブラリと同じ

フォルダにコピーされる必要があることに注意してください。 

統合ライブラリを作成する方法は、チュートリアル「統合ライブラリの作成」でも解説されています。 

1. File » New » Integrated Library コマンドを実行し、ソースライブラリパッケージを作成します。

空のソースライブラリが Projects パネルに Integrated Library1.LibPkg の名称で表示され

ます。ファイル名を変えるためには File » Save As コマンドを使用します。 

2. Project » Add Existing to Project コマンドを実行し、ソースライブラリをライブラリパッケージ

を追加します。ブラウザから回路図ライブラリ(.schlib)、モデルライブラリ（PCB フットプリン

トライブラリ(.pcblib)、Protel 99 SE ライブラリ(.lib)、SPICE モデル、またはシグナルインテ

ィグリティモデル）など追加したいライブラリを選択し、開く(O) ボタンをクリックすると、

Projects パネルのソースライブラリのリストにライブラリが追加されます。 

モデルライブラリやファイルを追加しない場合は、Projects パネルのライブラリパッケージ名を

マウス右クリックして Project Options を選択し、それらが含まれているパス名を直接指定します。

フットプリントやモデルの場所を示すパスを追加するには、Options for Project  ダイアログの

Search Paths タブ内の Ordered List of Search Paths セクションの Add ボタンをクリックしま

す。 

3. ライブラリパッケージのソースライブラリやモデルファイルをコンパイルして統合ライブラリに変

換するには、Project » Compile Integrated Library を選択します。コンパイル実行中に

Messages パネルにエラーやワーニングが表示された場合は、個々のソースライブラリを修正して

から再度コンパイルします。 
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4. コンパイルが成功すると、Integrated Libraryname.INTLIB が Project Options ダイアログの

Options タブ内の Output Path で設定したフォルダに生成され使用可能になります。作成された統

合ライブラリは、Libraries パネルのライブラリリストに自動的に追加されています。 

用語集 
このチュートリアルで使用した用語の解説 

コンポー

ネント 
例えば、IC や抵抗といった PCB に配置される物理的なデバイスのこと。これらのコン

ポーネントには、単一または複数のパート（ゲートや集積抵抗など）が、一つのパッケ

ージに含まれていることもあります。 

デジグネ

ーター 
PCB の中でコンポーネントと他のコンポーネントを区別するために使用されるその部品

固有の識別子。これらはアルファベットや数字、あるいはその複合が使用できる。パッ

ドも同様に他のパッドと区別するためのピンナンバーを持ちます。 

フットプ

リント 
フットプリントは PCB 上のコンポーネントを実装するためのスペースを定義（または

モデル化）します。コンポーネントのフットプリントモデルは PCB ライブラリに格納

され、デバイスのピンを電気的に接続するためのパッドや、パッケージの物理的アウト

ラインを示すトラックやアークで構成されたセグメントを、シルクスクリーン(overlay)
レイヤーに持ちます。デバイスをマウントするための機構を持つ場合もあります。  

PCB ライブラリに格納されたフットプリントには、デジグネーターやコメントは持ちま

せんが、PCB シートに配置される際にデジグネーターやコメントが付加されコンポーネ

ントとなります。 

ヒドゥン

ピン 
回路図では表示しないコンポーネントのピン。通常、これらは電源ピンで自動的に特定

のネットに接続されます。 

ライブラ

リ 
回路図ライブラリには、個別のシートにパートを格納したコンポーネントが用意され、

PCB ライブラリはコンポーネントのフットプリントを格納します。それぞれには専用の

エディタがあります。統合ライブラリは回路図ライブラリと、そこからリンクされるモ

デルを統合され、直接エディタで編集することはできません。 

オブジェ

クト 
ライブラリエディタでワークスペースに配置することができる個々のアイテム。 

パッド パッドオブジェクトは通常フットプリントに配置し、コンポーネントのピンの接続ポイ

ントになります。 

パート 複合コンポーネントを構成する表示オブジェクトの集まり。回路図ライブラリでは個別

のシートに収納されています。 

ピン コンポーネントのピンはコンポーネントに電気的な特性を設定でき、コンポーネントの

電気的な接続ポイントになります。 
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