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回路シミュレーション解析の 

設定と実行 

概要  
Tutorial  
TU0106 (v1.0) December 9, 2003   

このチュートリアルでは、回路シミュレーションを行う為

に、アナログフィルタデザインの回路図を作成して設定を

行い、解析を実行し、結果を波形アナライザに表示するま

での手順を紹介します。 

 

 
このチュートリアルでは、回路シミュレーション解析を実行する為に回路図を作成することから始め

ます。最初に新規プロジェクトファイルを作成してからブランクの新規回路図シートを追加します。 

新規プロジェクトの作成 
チュートリアルを開始するには、新規 PCB プロジェクトを作成します： 

1. メニューから File » New » PCB Project を選択します。または、Files パネルの New のところに

ある Blank Project (PCB)をクリックします。もし、このパネルが表示されていない場合は、デザ

インマネージャパネルの下部の Files タブをクリックします。 

あるいは、タスク画面（View »Tasks）の Pick a Task の項目の Printed Circuit Board Design を

選択してから New Blank PCB Project をクリックします。 

2. Projects パネルが表示されます。新規のプロジェクトファイル

（PCB Project1.PrjPCB）がここに No Documents Added
としてリスト表示されます。  

3. File » Save Project As を選択して、新規のプロジェクトファ

イル（拡張子.PrjPCB）の名称を変更します。ファイル名を

Filter.PrjPCB と入力し、プロジェクトの保存先を指定し、

Save をクリックします。 

次に空のプロジェクトファイルに追加する回路図を作成します。この回路図は、フィルタ回路になり

ます。もし、回路図を作成する時間が無い場合は、\Program 
Files\Altium2004\Examples\Circuit Simulation\Filter フォルダに保存されている類似

のプロジェクト（Filter.PrjPCB）を開きます。 

新規回路図シートの作成 
新規の回路図シートを作成するには、次のステップを実行します： 

1. File » New » Schematic を選択します。回路図エディタのデザインウィンドウに

Sheet1.SchDoc というブランクのシートが表示され、Projects パネル内のプロジェクトの名が

表示されている下の Source Documents に回路図シートのアイコンが表示されます。 
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2. File » Save As を選択して、新規の回路図ファイル（拡張子.SchDoc）の名称を変更します。ハ

ードディスク上で回路図を保存したい場所を指定し、ファイル名の項目で Filter.SchDoc と入

力して Save をクリックします。 

回路図の作成 
図 1 に示すフィルタ回路を作成します。シミュレーションを実行する前に、回路図に付属の SIM モデ

ルを持つコンポーネントやフィルタに供給する電源ソース、入力ソース、グランドシンボル、そして

波形を表示したい場所にネットラベルを配置する必要があります。 

チュートリアルのこの項目では、コンポーネントを配置し、それらの属性を設定してからワイヤを接

続します。 

 

図 1. Filter.SchDoc 

コンポーネントの配置とライブラリの読み込み 
最初に LF411CN というオペアンプのコンポーネントを検索します。 

1. Libraries タブをクリックして Libraries ワークスペースパネルを表示させます。 

2. Libraries パネルの Search ボタンを押すか、Tools » Find Component を選択します。Search 
Libraries ダイアログが開きます。 

3. Scope を Libraries on Path に設定し、Path の欄でこれから検索するパスが指定されているか確

認します。インストールの際、デフォルトディレクトリを適用した場合、パスは、C:\Program 
Files\Altium2004(SP2)\Library になるはずです。Library フォルダを確認する為にフォルダ

アイコンをクリックします。Include Subdirectories ボックスが選択（チェック）されていること

を確認します。 
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4. LF411 に関連する全ての部品を検索する為に、Search Criteria の Name の項目に *LF411* と入

力します。* シンボルは、メーカーごとに異なる接頭辞や接尾辞が挿入されていることを考慮して

使用するワイルドカードです。 

5. Search ボタンをクリックすると検索が開始されると同時に Results タブが表示されます。検索に

一致するライブラリが Results タブに表示されます。 

 

6. NSC Operational Amplifier.IntLib ライブラリを選択します。そして、このライブラリを

Libraries パネルから利用できるようにする為に Install Library をクリックします。Search 
Libraries ダイアログを閉じます。 

追加したライブラリは、Libraries パネルの上部に表示されます。上部のリストのライブラリ名を

クリックすると、そのライブラリのコンポーネントが下にリスト表示されます。パネル内のコンポ

ーネントフィルタは、ライブラリ内のコンポーネントをすばやく検索する為に使用します。 

シミュレーション用コンポーネントの配置 
最初にオペアンプ U1 のコンポーネントを回路図に配置します。回路の一般的なレイアウトに関して

は、図 1 に示した回路図を参照して下さい。  

1. Libraries タブをクリックして、Libraries パネルが表示されることを確認します。 

2. ライブラリをアクティブにする為に、NSC Operational Amplifier.IntLib を選択します。 

3. 必要なコンポーネントを素早く検索する為にフィルタを使用します。デフォルトのワイルドカード

(*) は、ライブラリに保存されている全てのコンポーネントをリスト表示します。ライブラリ名の

下のフィルタ欄に *LF411* と入力してフィルタを設定します。Library Ref の項目の一部に

“LF411”と言う文字が含まれているコンポーネントのリストが表示されます。 

4. リスト内の LF411CN を選択してから Place ボタンをクリックします。あるいは、コンポーネント

名をダブルクリックします。オペアンプの外形がカーソルのところに移動できる（フローティン

グ）状態で表示されます。今、部品を配置するモードになっています。  
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5. 回路図に部品を配置する前に、最初にその属性を編集します。オペアンプがカーソル上にフローテ

ィングで表示されている間に TAB キーを押し、このコンポーネントの Component Properties ダ
イアログを開きます。  

 

6. ダイアログの Properties のところにある Designator 欄に U1 と入力してコンポーネントデジグネ

ータの値を最初に設定します。 

7. 次にシミュレーションを実行時に使

用する SIM モデルを確認します。こ

のチュートリアルでは、回路シミュ

レーションの推奨モデルが既に含ま

れている統合ライブラリを使用して

います。Component Properties ダイ

アログの Models リストの

LF411_NSC を選択し、Edit をクリ

ックして SIM Model – General / 
Generic Editor ダイアログを表示さ

せます。 

8. モデルファイルパス名が、NSC 
Operational 
Amplifier.IntLib 統合ライブラ

リで検索され、設定されていること

に注目して下さい。  
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ミュレータ

pice 3F5 モデ

ポートしてい

、PSpice モデ

ポートしてい

。 

Model File タブをクリックし、モデルファイルの内容を表示させます。もし、モデルファイルが

見つからない場合は、エラーメッセージがこのタブに表示されます。 

 

9. （Netlist Template タブに表示される）Netlist Template にモデルファイルからのデータが表示さ

れ、その内容を Netlist Preview タブをクリックして確認することができます。 

    

全てのダイアログが閉じられるまで OK をクリックします。 

これで回路図シートにオペアンプを配置する準備ができました。 

10. もし、図 1 の回路図を参照する場合、U1 がカーソル上にフローティングの状態であるシンボルを

反転して配置されていることに注意して下さい。オペアンプの方向を垂直に反転する為に、配置す

る前に Y キーを押します。シート上でコンポーネントを配置する場所に移動し、左クリックする

か ENTER を押して回路図に配置します。 

11. 右クリックまたは ESC キーを押して、部品配置モードを解除します。  

新規 SIM モデルファイルの追加 
回路シミュレーション（.ckt や.mdl ファイル）で使用する SPICE モデ

C:\Program Files\Altium2004\Library フォルダの統合ライブラ

保存されます。各モデルタイプは正しいファイル拡張子を使用する必要

す。 例えば、SPICE .subckt は、*.ckt ファイルで、SPICE .model は
ファイルである必要があります。 

Model Name は、SIM モデルファイルへリンクさせるのに重要ですので

認して下さい。製品に供給されている統合ライブラリ内の既存のモデル

1. Libraries パネルの Search ボタンをクリックします。  

2. Search Libraries ダイアログの Simulation モデルタイプを選択し、

す。 

ここでは統合ライブラリのコンポーネントに既に与えられたモデルでは

モデルを使用してみます。この場合、デザインのプロジェクトファイル

ルファイルをコピーすることを推奨します。 

他の統合ライブラリに保存されているシミュレーションモデルを使用し

1. 必要なモデルを含む.Intlib ファイルを開きます（File » Open を
抽出します）。  
DXP シ

は、S
ルをサ

ますが

ルはサ

ません

ルは、

リ内に

がありま

、*.mdl 
5 

、適切なモデル名であるか確

ファイル名を検索するには： 

Search ボタンをクリックしま

無く、他のシミュレーション

にメーカーから入手したモデ

たい場合： 

選択し、ソースライブラリを
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2. 出力フォルダ（統合ライブラリを開いた時に作成されたフォルダ）からプロジェクトを含むフォル

ダに、モデルファイルをコピーします。このモデルを追加し、Sim エディタを使用して修正するこ

とができます。 

試しに\Program Files\Altium2004\Examples\Circuit Simulation\Filter フォルダに保

存されている他の SPICE モデル（LF411C.ckt）を追加します。  

1. LF411C.ckt をコピーし、Windows エクスプローラを使用して、作成したプロジェクトファイル

が存在するフォルダにこのファイルを貼り付けます。 

2. Projects パネル内のプロジェクト名（Filter.PrjPCB）を選択して、右クリックし Add 
Existing to Project を選択して、プロジェクトにモデルファイルを追加します。モデルファイルを

選択し Open をクリックします。SPICE モデルファイル（LF411C.ckt）が、Projects パネル内

の Libraries\Advanced SIM サブサーキットフォルダ下のプロジェクトに追加されます。 

これで回路図内のコンポーネントへモデルを追加することができます。もし、必要ならばこのコン

ポーネントの回路図ライブラリにもモデルを追加することができます。 

3. オペアンプをダブルクリックして Component Properties ダイアログを開きます。Models の項目

で設定されている SIM モデルを削除します。削除するには、

SIM モデルを選択して Remove をクリックし、Confirm ダイア

ログで Yes をクリックします。 

4. Models List の項目の Add をクリックして Add New Model ダイ

アログを表示させます。  

5. 図にあるように Model Type のドロップダウンリストから

Simulation を選択し、OK をクリックします。SIM Model – 
General / Generic Editor ダイアログが表示されます。 

6. Model Sub-Kind リストから Spice Subcircuit を選択して Spice Prefix を X に設定し、Model 
Location の項目を表示します。ダイアログ名は、Model Sub-Kind に変更されます。  
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7. Model Name の項目に LF411C と入力します（拡張子は必要ありません）。一致するモデルを全て

の有効なライブラリから検索する為、Model Location は Any に設定します。 

DXP は、一致するモデルが見つかるとすぐにモデルの検索を停止します。統合ライブラリに関連

付けられていないモデルについては、プロジェクトに追加したモデルファイルを検索します。更に、

Options for Project ダイアログ (Project » Project Options)の Search Paths タブ内で設定されて

いる Search Paths で見つかったモデルファイルを検索します。この例では、project フォルダに保

存されているモデルファイル（LF411C.ckt）を検索します。 

モデル検索で一致するモデルが見つからない時は、Model File タブにエラーが表示されます。プ

ロジェクトをコンパイルすると、エラーは Messages パネルに表示されます。 

8. 最後の段階は、新しいモデルが回路図コンポーネントのピン番号と一致しているかピンマッピング

を確認することです。SIM Model – General / Spice Subcircuit ダイアログの Port Map タブをクリ

ックします。  

 

9. Model Pin ドロップダウンリスト（上図のダイアログ参照）から一致するピンを選択して、元の

SIM モデル（LF411_NSC）に使用されているピン番号と同じになる様、ピンマッピングを修正し

ます。 

ピン番号の順番は、Netlist Template タブで確認します。このモデルの指示は、1, 2, 3, 4, 5 であ

ることに注意してください。 
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これらは、Model File タブに表示される.SUBCKT ヘッダーと対応します。これらの番号は、この

モデルファイルでの設定で、他のモデルでは同じように一致するとは限りません。 

 

Port Map タブの Model Pin 欄で、1(1), 2(2), 3(3), 4(4), 5(5), とリスト表示されます。最初の番号

が、モデルピン番号で（Netlist Template
の%1, %2, など）、サブサーキットヘッダ

ーに対応するノード名／番号は、括弧で囲

まれます。 

サブサーキットヘッダー内の実際の番号は、

重要ではありません。重要なのは、Spice 
ネットリストに表示される接続の順番です。

これらは、.SUBCKT のヘッダー内の順番, 
（例えば、Non-Inverting Input (IN+)、 
Inverting Input (IN-)、Positive Power 

Supply (V+)、Negative Power Supply (V-) 、そして Output (OUT)）と一致する必要があります。 

ネットリストヘッダーは、各ピンの機能について記述されています。それらを適切な回路図ピンに

リンクさせる為にこの情報を使用します。例えば： 

1(1)は、+ input (Non-Inverting Input)ですので、回路図ピン 3(IN+)にリンクさせます。また

5(5)は、Output ですので、回路図ピン 6(OUT)にリンクさせます。 

10. ピンマッピングを修正したら、OK をクリックして全てのダイアログを閉じます。 

シミュレーションを行う為に、Filter 回路図の設定を続けます。 

シミュレーション用の抵抗設定 
次に 2 つの抵抗を配置します。 

1. Libraries パネルで、Miscellaneous Devices.IntLib ライブラリがアクティブになっている

ことを確認します。 

2. ライブラリ名の下のフィルタの項目に res1 と入力しフィルタを設定します。 

3. コンポーネントリストの RES1 を選択し、Place ボタンをクリックします。カーソル上に抵抗のシ

ンボルが表示されます。 

4. 抵抗の属性を編集する為に、TAB キーを押します。ダイアログの Properties 内の Designator に
R1 と入力し、最初のコンポーネントデジグネーターの値を設定します。 

元のピンマッピング 修正したピンマッピング 
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5. 回路図上に表示する為、また、このチュートリアルの後半で回路シミュレーションを実行する時に

使用する為に抵抗のパラメータの項目を設定します。Value パラメータは、一般的なコンポーネン

ト情報に使用されますが、ディスクリートコンポーネントは、シミュレーションを行う時にそれを

使用します。 

もし、コンポーネント属性に既存パラメータとして Value が無い場合は、パラメータリストの

Add ボタンをクリックし、Parameter Properties ダイアログを表示させます。Name に Value、
Value に 100k と入力します。パラメータタイプとして String が選択されていて、Value の

Visible ボックスにチェックが入っていることを確認します。OK ボタンをクリックします。 

この RES1 コンポーネントは、既に Value パラメータが設定されていますので、Value の項目に

100k と入力するだけです。 

6. ダイアログの Properties の項目で、Comment の項目をクリックしドロップダウンリストから

=Value を選択し、Visible のチェックをはずします。DXP では、Comment 欄をパラメータの内容

で置き換える「間接的参照」をサポートしており、（パラメータの Value と Comment の項目で）

値を 2 回入力する必要はありません。このデータは、2 回入力しなくても PCB と部品表に転送す

ることができます。 

7. Models リストで SIM モデル（RESISTOR ）を確認します。Models リストでモデル名を選択し、

Edit をクリックして Sim Model – General/Resistor ダイアログを表示させます。このタイプの抵抗

は、モデルファイルは必要とせず、Value パラメータで入力した Netlist Template の Value を参照

します。 

 

OK をクリックしてダイアログを閉じ、Component Properties ダイアログに戻ります。OK をクリ

ックします。 

8. 抵抗を配置する位置を決めて（図 1 の回路図参照）、左クリックまたは ENTER を押し、部品を配

置します。 

9. 次に R2 の抵抗を配置します。そのまま続けて配置すると、デジグネーターは自動でインクリメン

トされます。 
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10. 抵抗を配置した後に、右クリックまたは ESC を押して部品配置モードを解除します。 

シミュレーション用のコンデンサ設定 
次に 2 つのコンデンサを検索し、配置します。 

1. コンデンサの部品は、Libraries パネルで既に選択されている Miscellaneous 
Devices.IntLib ライブラリにあります。Libraries パネル内のコンポーネントのフィルタ欄に

cap と入力します。コンポーネントリスト内の CAP をクリックし、Place ボタンをクリックしま

す。  

2. TAB キーを押して、コンデンサの属性を編集します。Component Properties ダイアログの

Properties の Designator 欄を C1 と設定します。 

3. Value パラメータの Value の項目を 112pF に変更します。String が、パラメータタイプとして選

択されていて、Value の Visible ボックスにチェックが入っていることを確認して下さい。 

4. ダイアログの Properties の項目で Comment の項目をクリックし、ドロップダウンリストから

=Value ストリングを選択し、Visible のチェックをはずします。 

5. 統合ライブラリから Models リストに追加されている SIM モデル（CAP）を確認します。Models
リストでモデル名を選択し、Edit をクリックして Sim Model – General/Capacitor ダイアログを表

示させます。このコンデンサは、モデルファイルを必要とせず、Value パラメータからの Value を
参照します。  

 

6. OK をクリックし、Component Properties ダイアログで更に OK をクリックし、配置モードに戻り

ます。 

7. 抵抗の配置と同じ方法で、2 つのコンデンサを配置する位置を決めて配置します。C2 は 56pF に

Value を変更し、スペースキーを押してシンボルを回転し、配置します。 

8. 右クリックするか ESC を押して配置モードを解除します。 
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電源の追加 
シミュレーションを行う時に必要であるデザインに供給する電源を追加します。 

1. 最初に VDD 電源を配置します。Libraries パネルで VSRC コンポーネントを検索し、Available 
Libraries リストに Simulation Sources.IntLib ライブラリを追加します。他のシミュレーシ

ョンライブラリは、\Project Files\Altium2004\Library\Simulation フォルダに保存さ

れていることに注意して下さい。 

電源を配置する際に、TAB キーを押して属性を編集します。  

2. Component Properties ダイアログの Models リストで SIM モデル（VSRC）をクリックし、Edit を
クリックします。Sim Model – Voltage Source/DC Source ダイアログで、Model Kind が Voltage 
Source に、Model Sub-Kind が DC Source に設定されていることを確認して下さい。 

 

3. Parameters タブをクリックし、必要な電圧値を設定します。Value の項目に 5V と入力し、

Component Parameter ボックスにチェックを入れます。チェックを入れると、自動で Component 
Properties ダイアログのパラメータに‘Value’が作成されます。他の項目は、0 に設定しておいて下

さい。  
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OK をクリックし、全てのダイアログを閉じます。回路図上でクリックし、この電源を配置します。

右クリックか ESC を押して、配置モードを解除します。 

4. 次にモデルファイルパラメータの Value を -5V  に設定して VSS の電源を配置します。 

5. 最後に Simulation Sources.IntLib
からサイン波（Sinusoidal Voltage 
Source：VSIN）を追加します。配置する

前に TAB キーを押して、属性を編集しま

す。この例では、1KHz から 50KHz に周波

数を変更します。Component Properties 
ダイアログで、Models リストの SIM モデ

ル（VSIN）をクリックし、Edit をクリッ

クします。  

Sim Model – Voltage Source / Sinusoidal 
ダイアログで、Model Kind が Voltage 
Source に、Model Sub-Kind が

Sinusoidal に設定されていることを確認

して下さい。 

6. Parameters タブをクリックし、必要な電

圧値を設定します。Sim Model – Voltage 
Source / Sinusoidal ダイアログ（右図）を

参照して、パラメータ値を入力して下さい。

Netlist Template は、この情報を使用して評価され Netlist Preview に表示されます。 

OK をクリックして全てのダイログを閉じ、クリックして回路図にこの電源を配置します。右クリ

ックか ESC を押して、配置モードを解除します。 

7. 回路図を保存します[ショートカット Ctrl+S]。 
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ールバーか

ポートを配

は、View  » 
s » Utilities 
、必要なパ

トボタンを

して下さ

パワーポートの追加 
図 1 を参照して、Filter 回路図にパワーポートを追加します。 

1. Place » Power Port を選択します。TAB を押して、Power Port ダイ

属性を設定します。   

2. コンポーネントのピンに付けられたポートについては、対応するネッ

（例えば、VSS）を入力し、Style を Bar に設定します。OK をクリッ

左クリックか ENTER を押して、パワーポートを配置します。配置中

を回転するには、スペースバーを使用します。 

3. パワーポートの配置を続けます。電源(VIN、VDD や VSS)にパワーポ

加する際に、Style を Power Ground に、Net を GND に設定します。

に、Style を Circle に設定します。 

4. パワーポートを配置し終えたら、右クリックか ESC を押して配置モー

回路の配線 
配線は、回路の様々なコンポーネント間の接続を作成する過程です。回路

を参照して下さい。 

1. ワイヤ配置モードにするには、Place » Wire [ショートカット P, W]を
ールバーから Wire ツールをクリックします。回路の配線についての詳

設計入門 」を参照して下さい。 

2. ワイヤ配置モードを解除するには、右クリックするか ESC を押します

ネットとネットラベル 
シミュレーションを実行する為の最後の操作は、表示したい信号を容易に

適切な場所にネットラベルを配置することです。チュートリアルの回路で

ネットです。OUT ネット名が OUT パワーポートから読み込まれている一

ベルで認識されます。図 1 のように必要な要求されたネット上にネットラ

1. Place » Net Label [ショートカット P, N]を選択し、TAB を押してネ

クリックしてネットラベルを配置します。ネットラベルの配置につい

「PCB 設計入門」を参照して下さい。 

2. ネットラベル配置モードを解除するには、右クリックか ESC を押しま

3. File » Save [ショートカット Ctrl+S]を選択して、回路を保存します。

クト名を選択し、右クリックし、Save Project を選択して同様にプロ

プロジェクトのコンパイル 
プロジェクトのコンパイルは、デザインドキュメントの描画や電気的なル

Options for Project ダイアログ（Project » Project Options）の Error Ch
タブで既に設定されているデフォルトのルールを使用します。 

1. Filter プロジェクトをコンパイルするには、Project » Compile PCB P
専用のツ

らパワー

置するに

Toolbar
を選択し

ワーポー

クリック

い。 

アログで

ト名

クし、

にポート

ートを追
13 

OUT ポートは、Net を OUT

ドを解除します。 

図の配線を行うには、図 1

選択するか、Wiring Tools ツ

細はチュートリアル「PCB

。 

確認できるように回路上の

注目する信号は、IN と OUT
方、IN ネットは、ネットラ

ベルを配置するには: 

ットラベル名を入力します。

ての詳細は、チュートリアル

す。 

Projects パネルのプロジェ

ジェクトを保存します。 

ールエラーを確認します。

ecking や Connection Matrix

roject を選択します。 
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2. プロジェクトがコンパイルされると、警告やエラーが Messages パネルに表示されます。エラー

がある場合は、回路を見直し、全ての配線や接続が正しいか確認して下さい。 

解析の設定 
DXP では、回路図から直接シミュレーションを実行することが可能です。チュートリアルの次の項目

では、Filter 回路で作成された出力波形をシミュレートします。 

シミュレーションは、Simulate メニューコマンドを使用するか、Mixed Sim ツール

バー（View » Toolbars » Mixed Sim を選択して表示される）の適切なボタンをク

リックして設定し実行します。 

1. 回路図エディタで Filter.SchDoc を開いて、Design » Simulate » Mix Sim を選択し、

Analyses Setup ダイアログの General Setup ページを表示させます。  

 

全てのシミュレーションオプションは、ここで設定します。シミュレーションの範囲（ネットリス

トを出力するシート）やシミュレーションが完了する時に自動で表示される信号（Active 
Signals）、シミュレーションで実行したい解析形式を含みます。これらのオプションは、プロジ

ェクトファイル（保存した時）に保存され、シミュレーションが実行される時に使用される

SPICE ネットリスト(*.nsx)の作成に使用されます。 

2. 最初に計測したい回路のノードを設定します。Collect Data For の項目で、リストから Node 
Voltage, Supply Current, Device Current and Power を選択します。このオプションでは、シミ

ュレーションを実行中に計算したいデータの形式を定義します。このオプションでは各ノードでの

電圧、各電源の電流と各デバイス電流・電力のデータが保存されます。SimView Setup を Show 
Active Signals に設定します。 

3. Available Signals の項目で、IN と OUT の信号名をダブルクリックします。各信号をダブルクリ

ックすると、信号名が Active Signals の項目に移動します。また、信号リスト上でクリックしマ

ウスをドラッグするか、信号をクリックしている間 SHIFT と CTRL キーを使用して、Available 
Signals リストから複数の信号を選択することができます。選択後、> ボタンを使用して Active 
Signals リストに信号を移動します。Active Signals のシミュレーション結果は、シミュレーション

が実行された時、自動で波形解析画面に表示されます。  
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ヘルプを表示さ

は、各解析設定

で F1 を押しま

 

4. （Analyses/Options の項目にリスト表示された）各解析形式は、An
Setup ダイアログの各ページで設定されます。各解析の設定ページを

ィブにするには、解析名をクリックして下さい。  

過渡／フーリエ解析の設定 
過渡／フーリエ解析は、ユーザが指定した時間間隔で過渡出力変数（電

オシロスコープに表示されるような出力を作成します。 

動作点解析は、Use Initial Conditions オプションが有効で無い限り、回

に 過渡解析より先に自動で実行されます。もし、このオプションが有効

に定義した初期状態から計算されます。初期状態は、回路図内の各適切

回路に .IC デバイスを配置して定義することができます。 

50KHz の入力ソースを 6 周期表示するには、波形画面で表示が 60u にな

1. Analyses Setup ダイアログ内の Transient/Fourier チェックボックス

クが入っている）ことを確認して下さい。もし、Transient/Fourier A
表示されない場合、Analyses/Options リスト内の Transient/Fourie
さい。 
詳細な

せるに

ページ

す。 

alyses 
アクテ
15 

圧, 電流または電力）を計算し、

路の DC バイアスを定義する為

ならば、DC バイアスは回路

なコンポーネントに、または、

るように設定します。 

が有効になっている（チェッ

nalysis Setup ページが自動で

r Analysis をクリックして下
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2. Use Transient Defaults オプションが無効になっていることを確認して下さい。これで過渡解析パ

ラメータを変更することができます。 

3. シミュレーション画面を 60u に指定するには、Transient Stop Time を 60u に設定します。 

4. Transient Step Time の項目を 100n に設定します。これは、シミュレーションが 100ns の地点ご

とに計算されることを表します。 

5. シミュレーション中の実際のタイムステップは、収束と必要な精度を満たす為に自動で変更されま

す。Maximum Step の項目は、タイムステップサイズの変化を制限しますので、Transient Max 
Step Time を 200n に設定します。 

AC 小信号解析の設定 
AC 解析は、周波数関数として小信号の AC 出力変数を計算し、回路の周波数応答を示す出力を作成し

ます。AC 小信号解析で要求される出力は、通常、伝達関数（例えば、電圧利得）です。 

回路図には、SIM モデル AC Magnitude パラメータの値が設定された AC ソースが少なくとも 1 つ必

要です。AC Magnitude の値、周波数と振幅についてはサイン波ソース（VSIN）のパラメータで既に

設定しています。詳細については、電源ソースの設定 を参照して下さい。  

1. Analyses Setup ダイアログで、AC Small Signal Analysis が有効になっていることを確認して下

さい。 
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2. 上図のようにパラメータ値を入力します。 

3. この解析が実行されると、回路の DC バイアスを決定する為に動作点解析が先に実行されます。そ

の後、信号ソースは振幅が固定された正弦波ジェネレータに置き換えられ、指定した周波数範囲内

で、Test Points と Sweep Type の値を元に解析されます。 

シミュレーションの実行 
これで設定を有効にした解析を実行する準備ができました。今後は、毎回 Analyses Setup ダイアログ

で入力をせずに、Mixed Sim ツールバーの Run Simulation ボタンをクリックするだけでシミュレー

ションが実行できます。 

1. シミュレーションを実行するには、Analyses Setup ダイアログの下部にある OK ボタンをクリッ

クします。 

SPICE ネットリストの生成、または実際のシミュレーション過程中に作成された警告やエラーは、

Messages パネルに表示されます。次に進む前にエラーを修正して下さい。 

2. 回路にエラーが無ければ SPICE ネットリスト（*.nsx）が作成されシミュレータに渡されます。

ネットリストは、シミュレーションが実行される度に再生成されることに注意して下さい。  

3. シミュレーションが開始され、シミュレーションデータファイル（*.sdf）が開きます。各解析の

結果は、SimData エディタの波形解析画面で個別のチャートとして表示されます。動作点解析は、

回路の DC バイアスを定義する為に最初に実行されます。 

4. シミュレーションが終了すると、以下の図のような出力を確認できるはずです。 

 
オペレーティングポイント解析 
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過渡解析波形 

 
AC 小信号解析波形 

5. 波形アナライザと Sim Data パネルの使用方法についての詳細は、チュートリアル「シグナル イン

テグリティ 」内の 波形解析画面の使用 を参照して下さい。波形表示とパネルの操作は両方のツー

ルで同じ画面を使用します。 

ボードプロットの作成 
ボードプロットは、周波数の対数関数として 2 つの曲線（利得と位相の対数）で構成されています。

Y 軸はデシベル（dB）で利得と位相をリニアにプロットし、X 軸は Log スケールでいくつかの周期を
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持つチャートが作成されます。各周期は、周波数の 10 の因数を表します。このボードプロットは、

Edit Waveform ダイアログで利用できる Waveform 機能を使用して作成することができます。 

1. 波形解析画面の AC Analysis タブに、dB(in), dB(out), PHASE(in),PHASE(out)を表示します。 

2. 波形解析画面で、ネット in をクリックします。選択したネットを右クリックし、Edit Wave （ま

たは、Wave » Edit Wave ）を選択します。Edit Waveform ダイアログが表示されます。選択した

波形の形式が Expression の項目に表示されます。 

 

3. Complex Functions リスト（例えば、Magnitude (dB)）から機能を選択します。プロット上で

dB(net_name)の波形を見るには、Create をクリックします。 

4. dB(out)を作成するには、プロット上で右クリックし Add Wave to Plot を選択します。Edit 
Waveform ダイアログと同じ方法で設定できる Add Wave to Plot ダイアログが表示されます。 

5. 2 番目のプロットに PHASE(in)と PHASE(out)を作成するには、4.の操作を繰り返して下さい

（Add Wave to Plot ダイアログの Complex Functions の項目は、Phase (Deg)を選択します）。 
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6. これらの波形は必要に応じ、Edit Waveform ダイアログの Add to new Y axis を選択することで、

異なる Y 軸を追加表示させることができます。追加した Y 軸を削除する場合、この軸にプロット

された全ての波形と波形に付けられた計測カーソルも削除されますので、注意してください。

Undo 機能はありません。新たに Y 軸を追加した場合、以下の図の様に表示されます。 

  

計測カーソルの使用 
計測カーソルを使用して、3dB の位置を指定してみます。 

1. DB(out)のネット名をクリックして、波形解析画面の波形を選択します。 

2. 右クリックし、Cursor A（または、Wave » Cursor A を選択します）を選択します。マーカーを

ドラッグして、カーソル A をローパスの部分に移動します。   

3. 右クリックし、Cursor B（または、Wave » Cursor B を選択します）を選択します。Sim Data パ

ネルの Measurement の項目で B-A = -3 と表示される位置になるようにカーソル B を移動します。  
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4. Sim Data パネルの Measurement Cursors の項目のカーソル B の X 値を確認して下さい。3dB 
point  = 20kHz であることが分かります。 

 

5. カーソルをクリアするには、カーソルマーカーを選択し、右クリックして Cursor Off を選択しま

す。 

パラメータスイープ解析の実行 
いくつか解析を設定し、実行しましたが、次に周波数応答でいくつかのコンデンサ／抵抗の値を変更

した結果を見る為にパラメータスイープを設定してみます。 

パラメータスイープ解析は、定義した指定した範囲でデバイスの値をスイープさせます。パラメータ

スイープ解析を実行するには、AC, DC または過渡解析のどれかを有効にする必要があります。有効に

した解析は、パラメータスイープして複数回シミュレータが実行されます。 

この解析は、基準のコンポーネントの値とモデルパラメータを変更することができますが、サブサー

キットデータは、解析中変更できません。 

1. Filter.SchDoc タブをクリックして、デザイン画面で回路図を利用できるようにします。

Design » Simulate » Mixed Sim を選択します。Analyses Setup ダイアログの General Setup ペー

ジの SIMView Setup で Show Active Signals が選択されていることを確認して下さい。 

2. Analyses Setup ダイアログの Analyses/Options の項目で Parameter Sweep をクリックして、こ

の解析形式を有効（Enabled にチェックを入れます）にします。 

3. Primary Sweep Variable の項目でスイープさせる為のパラメータを入力します。この例では、プラ

イマリ スイープパラメータをドロップダウンリストから選択して C2[capacitance]にします。  

4. Primary Start Value を 20p に、Primary Stop Value を-20p に設定して、スイープの値の範囲を定

義します。Primary Step Value を-10p に設定して、増加ステップを定義します。  
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5. Primary Sweep Type オプションを Relative Values に設定します。Primary Start Value, Primary 
Stop Value, Primary Step Value の項目で入力した値は、パラメータの既存またはデフォルトの値

に追加されます。  

6. Enable Secondary をクリックして、Secondary Sweep Values を追加します。セカンダリ パラメ

ータを定義した場合、プライマリ パラメータは、セカンダリ パラメータの各値でスイープされま

す。 

Secondary Start Value を-80p に、Secondary Stop Value を 80p にして C1[capacitance]のセ

カンダリ スイープを設定します。Primary Step Value を 80p に設定し、増加ステップを定義しま

す。Secondary Sweep Type を Relative Values に設定します。 

 

7. OK ボタンをクリックして、シミュレーションを実行します。各プライマリ スイープは、波形解析

画面の AC Analysis と Transient Analysis タブ内の新しいプロットに

<net_name_p<sweep_number>の表記（例えば、out_p01）で波形として表示されます。 

詳細情報を表示するには（例えば、out_p01 をクリックすると、プロットの下にスイープ情報が

表示されます）、スイープ パラメータ名をクリックして下さい。 

 
以下の図で、このパラメータ スイープよってカットオフ周波数の周りの周波数応答を大きく変化

させることが判ります。  
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AC Analysis タブでのパラメータスイープ結果 

 
Transient Analysis タブでのパラメータスイープ結果 

アドバンストオプションの使用 
Analyses Setup ダイアログの Advanced Options のページは、エラーの許容度や繰り返し制限のよう

なシミュレーション計算を達成する為に設定できる SPICE 内部のオプションのリストになっています。 

 

SPICE オプションの値を変更するには（例えば、ITL1 の繰り返しの値）: 

1. 変数（例えば、ITL1）を選択します。Value の項目に新しい値を入力するか、表示される矢印ス

クロールをクリックして値を選択します。  
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らネットリ

x) を作成す

回路図がア

ドキュメン

ことを確認

い。Design 
t For Project 
e を選択して

 

2. Enter を押すか、他の項目をクリックすると、デフォルト（Def）オプションが無効になります。 

また、このページから異なる積分方法を選択することができます。例えば、回路デザインに予期しな

い高周波の発振がある場合、標準的な積分法の Trapezoidal（台形法）から Gear（ギヤ法）へ変更す

ることができます。台形法は、比較的早く正確ですが、ある条件下で振動する傾向があります。理論

上、高次ギヤ法の方が、結果はより正確ですがシミュレーション時間が長くなる欠点があります。 

シミュレーション用の SPICE ネットリストの使用 
他の回路図キャプチャツールと組み合わせて DXP シミュレータが使用できるように、SPICE ネット

リストから直接、シミュレーションを実行することができます。これを行うには： 

1. プロジェクトファイル(.PrjPcb)にネットリストを保存します。これ

レーションセッション中の設定情報を保存することができます。設

回路図を含むプロジェクトと同じ方法でプロジェクトファイルに保存

す。プロジェクトファイルは、P-CAD から最初にシミュレーションを

る時に自動で追加されることに注意して下さい。もし、ネットリスト

ードキュメントとして開いた場合、設定情報は、DXP に保存されませ

2. DXP シミュレーションエンジンは、設定情報と同様にコンポーネント

デザイン接続、モデルデータを含んだネットリストが必要です。もし

トリストにシミュレーション設定情報が無い場合、Simulate » Setup
すると新しいネットリストが<original filename>_tmp.nsx と言

のファイルは、元の.nsx ファイルからのネットリスト情報とプロジ

報を含みます。 

もし、ネットリスト中にシミュレーション情報がある場合、シミュレ

更しないで直接、実行されます。これは、ネットリストで直接、設定

ちます。もし、ネットリストに設定情報が既に含まれている場合、A
使用して、設定情報を追加または設定できないことに注意して下さい

もし、ネットリストにシミュレーション設定情報が無く、プロジェク

る場合、ネットリストは、回路図ドキュメントとプロジェクトの設定

れは、ネットリストから設定情報を削除してシミュレーションを行お

す。 

3. 一度、設定情報が無いネットリストをプロジェクトに追加すれば、S
解析を設定することができます。 

4. シミュレーションを実行するには、メニューから Simulate » Run を
ン波形は、.sdf ドキュメントに表示されます。 

5. 次回シミュレーションを実行する時に上書きされないように、ネット

して下さい。 

 

回路図か

スト(.ns
るには、

クティブ

トである

して下さ

» Netlis
» XSpic
下さい。

でシミュ

定情報は、

されま

実行す

がフリ

ん。  

情報、

、ネッ

を選択
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う名称で作成されます。こ

ェクトファイルからの設定情

ーションはネットリストを変

を変更したいユーザには役立

nalyses Setup ダイアログを

。 

トに回路図ドキュメントがあ

情報から再生成されます。こ

うとした場合にのみ発生しま

imulate » Setup を選択して

選択します。シミュレーショ

リストファイルの名称を変更
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