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このチュートリアルでは、シグナルインテグリティ解析の

実行について説明します。それは、デザインルールやシグ

ナルインテグリティ・モデルなどのデザインパラメータの

設定、回路図、PCB エディタからのシグナルインテグリテ

ィの実行、ネットスクリーニング解析で使用されるテスト

項目の設定、選択されたネットのより詳細な解析の実行、

信号線の終端、プリファレンスの設定や波形分析での操作

を含みます。 
 

 
DXP では、回路図または PCB エディタからの配線情報を元に、あらかじめ定められたテストに対し

てネットスクリーニング結果を評価し、選択されたネットの反射やクロストーク解析を実行し、デザ

インエクスプローラ内で波形を表示して PCB のシグナルインテグリティ解析を実行することができま

す。 

シグナルインテグリティの概要 

DXP では基板設計完了後だけでなく完了前にもシグナルインテグリティ解析を実行できます。DXP の

シグナルインテグリティ解析では、シミュレーションの入力として高度な伝送路計算と I/O バッファ

マクロモデル情報（IBIS）を使用します。高速信号の反射による影響、およびクロストークのシミュ

レーションの時は、業界標準のアルゴリズムに基づいた正確なシミュレーションを行ないます。 

基板の配線を完了する前に、回路図からの情報を元にあらかじめインピーダンスおよび反射シミュレ

ーションが可能です。これによって基板レイアウトを始める前に、ネットインピーダンスのミスマッ

チなどの潜在的なシグナルインテグリティの問題を確認することができます。 

配線が完了（あるいは、部分的に配線）した基板では、デザインの特性を確認する為、実際の基板と

同じようにインピーダンス、信号反射やクロストーク解析がすべて実行できます。シグナルインテグ

リティスクリーニングは、DXP デザインルールシステムの中に構築され、通常のボード DRC（デザ

インルールチェック）プロセスの一部分として、シグナルインテグリティ違反を確認することができ

ます。シグナルインテグリティに問題が発見された時、DXP では、さまざまな終端オプションの効果

を表示して、デザインを修正する前に 良の解決方法を発見することができます。 

回路図のみのプロジェクトからのシグナルインテグリティ解析の実行 

プロジェクトに PCB が無い時でも、回路図のみのデザインでシグナルインテグリティ解析を実行する

ことができます。解析は、フリードキュメントとして開かれたドキュメントでは実行しないので、回

路図は、プロジェクトの一部分である必要があります。クロストーク解析は、配線済みネットが必要

ですので、回路図のみのプロジェクトでは利用できません。 

回路図のみの方法で実行する場合、デフォルトのトラックの平均長さやインピーダンスは、SI Setup 
Options を使用して定義することができます。シグナルインテグリティ・アナライザは、回路図から
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PCB デザインルールで使用するスティミュラスと供給ネットを読み込みます。これらのルールは、

PCB レイアウトディレクティブまたはパラメーターセットディレクティブを回路図で配置することで、

ネットにルールを追加することができます。 

回路図エディタから回路図を開いて、メニューから Tools » Signal Integrity を選択します。 初に必

要なシグナルインテグリティ・モデルを設定します。そして、 初の結果が表示される Signal 
Integrity パネルが表示され、詳細な解析を実行できます。 

PCB プロジェクトからのシグナルインテグリティ解析の実行 
PCB ドキュメントからシグナルインテグリティ解析を実行する時、その PCB ドキュメントは関連す

る回路図を含むプロジェクトの一部であることが必要です。プロジェクト内の回路図からシグナルイ

ンテグリティを実行でき、同じプロジェクトの PCB からシグナルインテグリティを実行しても同じ効

果であることに注意してください。この時、反射およびクロストーク解析の両方が実行可能になって

います。 

PCB エディタのメニューから Tools » Signal Integrity を選択すると、先に記述した回路図のみの方

法と同じ過程で実行されます。 

PCB で回路図部品を関連付けることができますが、配置された部品はコンポーネントリンクでリンク

されている必要があります。これは、Project » Component Links を選択して確認することができま

す。未配線のネットは、ピン間のマンハッタン長を使用して、解析目的のトラック長を推測すること

に注意してください。 

シグナルインテグリティを実行する前に 

デザインのシグナルインテグリティ解析を正しく実行し、また正確な結果を得る為には、下記の項目

を解析開始前に行なうことが必要です。 

• ネットをシミュレーションする場合、意味のあるシミュレーション結果を得る為の重要なことは、

そのネットに接続された出力ピンが少なくとも１個は集積回路（IC）であることが必要です。この

出力ピンは、ネットに信号を供給してシミュレーション結果に反映されます。例えば、抵抗、コン

デンサ、インダクタは、ドライブソースが無いパッシブ部品である為、ネットに信号波形を供給で

きずシミュレーションが実行できません。 

• 各部品のシグナルインテグリティ・モデルタイプは、正確である必要があります。これは、回路図

ドキュメントに配置された部品に関連したシグナルインテグリティ・モデルを編集する際に、

Model Assignments ダイアログまたは Signal Integrity Model ダイアログの Type の項目に正しいモ

デルタイプをマニュアルで設定します。このエントリーが定義されていない場合は、Model 
Assignments ダイアログはその特性に基づいた部品のタイプを推測します。より詳細な説明は、

Model Assignments ダイアログでの部品にシグナルインテグリティ・モデルの追加 の項目をご参

照ください。 

• サプライネットに関するデザインルールの設定が必要です。一般的には、電源ネットと GND ネッ

トの 低２つのルールが必要で、ルールの範囲はネットまたはネットクラスで定義します。サプラ

イネットは、シグナルインテグリティで解析することができません。より詳細な説明は、回路図で

のシグナルインテグリティ・デザインルール または  PCB でのシグナルインテグリティ・デザイ

ンルール の項目をご参照ください。 

• Signal Stimulus に関するデザインルールは、デフォルト以外のスティミラスが必要な場合には、

デザインルールの設定が必要になります。 
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• PCB のレイヤースタックが正しく設定されている必要があります。シグナルインテグリティ・ア

ナライザには、分割のない連続したパワープレーンレイヤーが必要です。パワープレーンに割り当

てられたネットが解析に使用される為、分割プレーンはサポートされません。もし、それらが無い

場合は、仮定・予想したネットが使用されますので、それを避けるためにも適切なネットをパワー

プレーンにアサインしてください。各層のコアやプリプレグの厚さも正しく設定する必要がありま

す。Design » Layer Stack Manager コマンドを使用して、PCB エディタでレイヤースタックを設

定します。PCB の無い回路図のみの方法でシグナルインテグリティを実行する場合、シグナルレ

イヤー2 層パワープレーンレイヤー2 層の 4 層基板の設定をデフォルトとして使用します。もし、

デフォルト以外の層構成にしたい場合は、空の PCB を作成してレイヤースタックで設定すること

ができます。 

Model Assignments ダイアログでの SI モデルの追加 
デザインにシグナルインテグリティ・モデルを追加する も簡単な方法は、Model Assignments ダイ

アログを使用することです。 

1. メニューから Tools » Signal Integrity を選択

します。プロジェクトで 初にシグナルインテ

グリティを実行する時にシグナルインテグリテ

ィ・モデルが割り当てられていない部品がある

場合、Errors or warning found ダイアログが表

示され Model Assignments ボタンを押して SI
モデルを設定することができます。 

あるいは、Continue ボタンをクリックした場合、Signal Integrity パネルが表示され、Model 
Assignments ボタンをクリックして、いつでも Model Assignments ダイアログでモデルの設定を

行なうことができます。モデルの割り当てを変更するどのような修正も、既存の解析結果は無効と

なり、再計算が必要となることに注意してください。 

もし、モデルがすべての部品に対して既に設定されている場合、SI Setup Options ダイアログが表

示されます。詳しくは後に述べる SI 設定オプションの設定 の項目をご参照ください。 

2. Errors or warnings found ダイアログの Model Assignments ボタンをクリックすると Signal 
Integrity Models Assignments ダイアログが表示されます。 
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Models Assignments ダイアログが開いた時、シグナルインテグリティ・モデルが定義されていな

い部品に対しては相当と思われるモデルの割り付けを自動で試みます。既にモデルが定義（またモ

デル情報）されていたものを含む全ての部品は、Models Assignments ダイアログに表示されます。

各部品は、以下のリストに記述されているような状態を割り当てられます。 

Status Definition 

No match この部品に相当するモデルを見つけることができませんでした。正確

に設定するにはユーザーによる修正が必要です。 

Low confidence 強い根拠はありませんが、この部品にタイプを選択しました。 

Medium 
confidence 

合理的な確信を持ち、この部品にタイプを選択しました。 

High confidence この部品にタイプを選択しました。通常ほとんどの特性に適合しま

す。 

Model found この部品には既にモデルが割り当てられていました。 

User modified モデルの割り当てがユーザーによって修正されています。 

Model added ユーザーが、回路図ドキュメントを修正し、新しいモデルを保存して

Model Assignments ダイアログを使用した時にこの状態は使用されま

す。 

Model Assignments ダイアログでの部品モデルの修正 
1. モデルを修正したい部品を選択します。 

2. 正しい種類を選択します。シグナルインテグリティには 7 種の部品（抵抗、コンデンサ、インダク

タ、ダイオード、BJT、コネクタ、IC）があります。各部品の Type は、その欄のドロップダウン

か、右クリックメニューを使用して選択することができます。 
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3. 抵抗、コンデンサ、インダクタの場合は定数を設定してください。可能な場合、Model 
Assignments ダイアログでは、部品のコメントフィールドとパラメータに基づいて、この欄で部品

の正しい値を設定します。もし必要ならば定数の修正を行なってください。複合部品（抵抗アレー

など）の場合は、欄でクリックして表示されたダイアログで修正します（詳細は、部品への SI モ
デルのマニュアルでの追加 を参照して下さい）。 

4. 部品が IC の場合、シミュレーションで使用するピンモデルの特性を決定しますので、テクノロジ

ータイプの選択は重要です。これは、欄のドロップダウンリストを選択するか、右クリックメニュ

ー（Change Technology）の一覧から選択します。 

5. 後に、IBIS モデルといった Model Assignments ダイアログでの設定以上に詳細な指定が必要か

もしれません。これは、右クリックメニューから Advanced を選択して設定することができます。

この過程の詳細は、 部品への SI モデルのマニュアルでの追加 を参照して下さい。 

モデルの保存 

一度、部品のモデル割付の設定が完了すれば、この情報は回路図ドキュメントに保存することができ

ます。 

1. Model Assignments ダイアログで、更新する全ての部品の Update Schematic 欄にチェックを入

れます。それから、Update Models in Schematic ボタンをクリックします。 

2.選択された各部品の全ての新しいシグナルインテグリティ・モデル（または、修正したモデル）は、

回路図ドキュメントに追加されます。その後、回路図ドキュメントを保存する必要があります。 

シグナルインテグリティ解析を続けている間はモデルを保存する必要はありません。もし、モデル

が保存されていなくても、解析は Model Assignments ダイアログに表示されているモデル設定で

行なわれます。しかし、次にシグナルインテグリティ・ツールを実行した場合には、保存されてい

ない情報は失われています。 

部品へのシグナルインテグリティ・モデルのマニュアルでの追

加 

シグナルインテグリティ・モデルは、統合された部品にリンクされています。新しい統合された部品

ライブラリにシグナルインテグリティ・モデルを組み込むこともできます。 

1. 回路図エディタに配置された部品にシグナルインテグリティ・モデルを追加するには、部品をダブ

ルクリックして Component Properties ダイアログを表示させます。 
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2. Model リストで Add をクリックし、Add New Model ダイアログの Model Type で Signal Integrity 
を選択します。OK をクリックすると Signal Integrity Model ダイアログが表示されます。 

2. Model リストで Add をクリックし、Add New Model ダイアログの Model Type で Signal Integrity 
を選択します。OK をクリックすると Signal Integrity Model ダイアログが表示されます。 

3. モデルを設定して、OK をクリックします。 3. モデルを設定して、OK をクリックします。 

パッシブ部品の設定 パッシブ部品の設定 

抵抗やコンデンサなどの部品を設定する場合、種類と定数を入力する必要があります。定数は Value 
の項目に入力し、全体の部品のパラメータとして設定することができます。 
抵抗やコンデンサなどの部品を設定する場合、種類と定数を入力する必要があります。定数は Value 
の項目に入力し、全体の部品のパラメータとして設定することができます。 

抵抗アレーのような複合部品もサポートしています。部品の種類を選択した後、Signal Integrity Model
ダイアログの Setup Part Array ボタンをクリックして設定することができます。Part Array Editor ダ
イアログでは、ピンとそれらの接続に見合う定数／モデルを設定することが可能です。 

抵抗アレーのような複合部品もサポートしています。部品の種類を選択した後、Signal Integrity Model
ダイアログの Setup Part Array ボタンをクリックして設定することができます。Part Array Editor ダ
イアログでは、ピンとそれらの接続に見合う定数／モデルを設定することが可能です。 

 

IC の設定 
IC のタイプモデルを設定するには、いくつかの方法があります。 

1. Type (IC)を選択した後、テクノロジータイプを簡単に選択できます。この部品をシミュレーショ

ンする時は、そのテクノロジーの適切なピンモデルが使用されます。 
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2. より高度なコントロールが要求される場合、詳細なテクノロジーやさまざまなピンモデルを割り当

てることが可能です。これは、Signal Integrity Model ダイアログの下部にあるピンリスト中のピン

のドロップダウンリストから選択して実行できます。どのような設定の変更も、元のテクノロジー

より優先されることに注意して下さい。 

IBIS ファイルのインポート 
別の重要なオプションは IBIS ファイルをインポートする機能です。 

1.IBIS (Input/Output Buffer Information)に記述されている IC モデルの入力／出力特性を使用するには、

Signal Integrity Model ダイアログで Import IBIS ボタンをクリックします。Open IBIS File ダイア

ログから IBIS ファイルを選択して Open をクリックします。IBIS Converter ダイアログが表示さ

れます。 

 

2. IBIS ファイルに含まれた必要な部品を選択します。DXP は、IBIS ファイルを読み込み、インスト

ールしたピンモデルのライブラリ内の IBIS ファイルからピンモデルをインポートします。もし、

同じモデルが複数、発見されれば、既存のモデルを上書きするかの問い合わせがなされます。さら

に、IBIS ファイルで指定されたように、部品の全てのピンは適切なピンモデルに割り当てられま

す。 

3. 自動でモデルが割り当てられたピンの成功／不成功の結果をレポートに生成します。さらに、上部

に記述された様に、適切なピンのモデルを手動で選択してカスタマイズすることが可能です。 

4. OK ボタンをクリックすると、IBIS 情報のインポートは完了し、Signal Integrity Model ダイアログ

に戻ります。 

ピンモデルの編集 

そのピンのさまざまな電気的特性を指定して、既存のピンモデルの編集や追加することが可能です。

これは、BJT、コネクタやダイオードのような他の種類にも利用できることに注意して下さい。 
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1. ピンモデルを編集するには、Signal Integrity Model ダイアログの Add/Edit Model ボタンをクリッ

クして Pin Model Editor ダイアログを表示させます。Add/Edit Model ボタンは編集可能な種類の

場合のみ表示されています。 

 

2. 必要な変更を行なって OK をクリックします。 

3.  新しいピンモデルの追加の場合、この新しいモデルは他の部品のピンでも今後利用可能です。 

回路図でのシグナルインテグリティ・デザインルール 

シグナルインテグリティ用のパラメータとして使用される PCB のデザインルールは、回路図において

もデザインルールを定義することができます。シグナルインテグリティ解析を行なう場合、電源ネッ

トとそれらの電圧を PCB のルールで定義する必要があります。回路図の各電源ネットに PCB ディレ

クティブを追加します。 

回路図で電源ネットのデザインルールを追加するには、 

1. Place » Directives »  PCB Layout を選択します。ディレクティブがカ

ーソルに表示されます。 

2. TAB キーを押すと、未定義のルールが追加されている Parameters ダイアログが表示されます。 

3. Undefined rule を選択し、Edit ボタンをクリックすると Parameter Properties ダイアログが表示さ

れます。 
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4. Edit Rule Values ボタンをクリックすると、表示された Choose Design Rule Type ダイアログか

らルールタイプを選択できます。 

5. ダイアログをスクロールダウンさせ Signal Integrity ルールの項目から Supply Nets を選択し OK 
をクリックすると、Edit PCB Rule (From Schematic)ダイアログが表示されます。 

 

6. この電源ネットの電圧値を入力してから OK ボタンをクリックしま

す。OK をクリックして全てのダイアログを閉じます。 

7. これで適切なネットに PCB ルールの設定されたディレクティブを

配置することができます。ディレクティブがネットに適切に配置さ

れればドットが表示されます。デザインが PCB に移行された後、

ルールは PCB デザインルールに追加されます（PCB の Design » 
Rules コマンドを使用して確認することができます）。 

8. 同じように GND ネット(Voltage = 0) や他の電源ネットにも PCB ル

ールディレクティブを配置します。 

9. ディレクティブ配置モードを終了するには、右クリックします。 

回路図エディタでは、ルールの範囲（ルールの適応範囲）はパラメータが追加される場所（例えば、

ワイヤまたはピン）によって定義されることに注意して下さい。PCB エディタでは、ルールの範囲は

ルール自身内で定義することができます。 
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シグナルスティミュラスのデザインルール 

他のデザインルール設定では、シグナルスティミラスのデザインルールを回路図エディタで設定する

ことができます。このルールが適応されると、スティミラスは解析されているネットの各出力ピンに

投入されます。これは、‘all’の範囲を使用するデザインルールが要求される為、このルール用のシート

パラメータを作成する必要があります。もし、このルールを設定していない場合、デフォルトルール

オプションの値が使用されます。 

1. 回路図エディタで Design » Document Options を選択し、Document Options ダイアログの

Parameters タブをクリックしてシートパラメータを追加します。Add as Rule ボタンをクリック

して Parameter Properties ダイアログを表示させます。 

2. Edit Rule Values ボタンをクリックして Choose Design Rule Type ダイアログを表示させます。

スクロールダウンさせ、Signal Integrity ルールの項目の中にある Signal Stimulus を選択します。

OK をクリックして Edit PCB Rule (From Schematic) - Signal Stimulus ダイアログを表示させます。 

 

3. スティミュラスの種類、開始レベルや時間を選択します。OK をクリックしてダイアログを閉じま

す。 

PCB でのシグナルインテグリティ・デザインルール 
オーバーシュート、アンダーシュート、インピーダンス、スロープなどシグナルインテグリティのパ

ラメータは、標準の PCB デザインルールの様に指定することができます。PCB エディタで Design » 
Rules を選択し、これらのルールを設定します。回路図エディタでパラメータを使用してこれらのル

ールを設定することができ、それらは、PCB レイアウトへデザインを移行した後に PCB Rules and 
Constraint Editor ダイアログに表示されます。 
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これらのルールには、2 つの目的があります。一つは、PCB で DRC チェックを実行した場合にボー

ド全体を解析しルールに違反した個所をチェックします。二つ目は、Signal Integrity パネルを使用し

た時です。これらのルールは、どのネットがどのテストに通過できなかったかをグラフ式にパネルに

表示する時に使われます。 

SI 設定オプションの設定 
プロジェクトで初めて Tools » Signal Integrity を選択して実行された場合、全ての部品モデルが割

り当てられ SI Setup Options ダイアログが表示されます。 

 

TU0113 (v1.0) December 9, 2003 11 



シグナルインテグリティ解析の実行 

1. トラックのインピーダンスと平均長を設定します。これら配線の特性は、PCB からまだネットが

移行されていない、または未配線のネットがある場合にのみ使用されます。 

Supply Nets と Stimulus タブは回路図のみの方法のときに表示されます。 

2. Analyze Design をクリックするとデフォルトの初期解析が実行され、反射、クロストークを解析

する為のネットを選択することができる Signal Integrity パネルが表示されます。 

デフォルトで設定してある 4 つの検査項目と、回路図または PCB で設定したシグナルインテグリ

ティに関するデザインルールに記載された内容は、すべて初期解析の際に実行されます。これらの

検査する内容と許容範囲の設定は、シグナルインテグリティ・パネルの Menu ボタンをクリック

して表示される Set Tolerances で設定することができます。 

回路図のみの方法でのシグナルインテグリティ設定オプション 

1. PCB が無いプロジェクトで実行する場合、各種設定は、Menu ボタンをクリックし Setup 
Options を選択して表示される SI Setup Options ダイアログで Signal Integrity パネルの SI Setup 
Options を変更することができます。 

2. Track Setup タブではシミュレーションで使用するデフォルトの配線長を指定します。デフォルト

の配線長は、PCB が存在し配線長が存在する場合には使用されません（例えば、マンハッタン長

を確認することができないときには PCB のトラックの代わりにこの値を使用します）。このタブ

の Track Impedance の項目も同様に設定します。 

3. Supply Nets と Stimulus タブをクリックすると、有効なネットおよびスティミラスに関する情報

が表示されます。これらのタブでは、PCB または回路図でのルールの通常の設定方法以外に、他

のインタフェースでもこれらの特性を定義することができます。 

Signal Integrity パネルの使用 
初期設定を実行後、Signal Integrity パネルには解析結果のデータが表示されます。この解析結果やさ

まざまなテストを通過したネットは、パネルの左側のリストに表示されます。 
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システムで表示できるパネルは一つだけです。再度 Tools » Signal Integrity を実行しても、表示して

いるパネルの内容はクリアされ、新しい解析結果が上書きされることに注意してください。これはプ

ロジェクトの回路図または PCB に変更を加えた後、または新しいプロジェクトで解析を始める時に結

果を新たにする為に使用されます。 

スクリーニング結果の表示 

初期スクリーニング解析では、多数のネットを素早く解析し多くの情報を得ることができます。そし

て、反射と（または）クロストーク解析の様な、より精密な検査を行う為の評価ネットを識別します。

リストの左側に解析結果が表示されます。 

各ネットは、3 つの部類（Passed; Failed または Not Analyzed）のうちのどれか 1 つに割り当てられ

ます。 

• Passed は、定義されたテスト内容にパスしたネットを表します。 

• Failed は定義されたテスト内容にパスできなかったネットです。違反した値の欄は赤く表示されま

す。 

• Not Analyzed は何かの原因でテスト出来なかったネットを表します。テスト出来なかった原因を

表示するには、マウス右クリック（または Menu をクリック）して Show/Hide Columns を選択

し、Analysis Errors 欄を有効にします。 

Failed ネット 
解析に失敗する共通の原因の多くは、ネットに接続されたコネクタ、ダイオード、トランジスタがあ

る場合や出力ピンが全く無いあるいは複数の出力ピンがある場合です。ネットが遮られる時（双方向

ピンを含みネットに出力ピンが無い時）、各双方向ピンは、出力ピンとして別個にシミュレーション

が行われます。これらのシミュレーションから 悪の場合の結果が表示されます。スクリーニングテ

ストでは解析ができない場合でも、反射やクロストークのシミュレーションを行なう際に確認するこ

とができる可能性があることに注意してください。 

ネットは、スクリーニングと更なるシミュレーションで間違った解析結果に結びつく他のエラーを持

つことが可能です。これらのネットは赤くハイライトで表示されます。更に解析されたネット（例え

ば、PCB でまだ配線されていないネット）は、グレーで表示されます。 

Failed または Not Analyzed ネットの確認 
Failed または Not Analyzed ネットの原因を表示するには、 

1. ネットが赤くハイライト表示されている場合は、ネットを選択してからマウス右クリックで Show 
Errors を選択します。問題箇所を修正する為にクロスプローブさせることができる Messages 
panel に、メッセージが表示されます。 

2. 選択したネットの全ての情報を表示するには、右クリックして Details を選択します。Full Details 
ダイアログが表示され、スクリーニング解析から計算された情報やその他の基本的な情報が全て表

示されます。 
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3. 右クリックメニュー（または Menu をクリック）から Cross Probe を選択すると回路図または

PCB のどちらかの選択したネットにクロスプローブ（ジャンプ）します。F4 ショートカットキー

を使用して、Signal Integrity パネルとデザイン間の表示を交互に切り替える（トグル）こともでき

ます。 

4. 希望のネットを選択して右クリックし Find Coupled Nets を選択すると、単一のネットあるいは

グループのネットに連結させる（電気的連結が強い）ネットが選択されます。ネットの連結が考慮

される基準は、Preferences ダイアログ（Signal Integrity パネルの Menu ボタンから Preferences
を選択して表示されます）で設定することができます。 

5. さらに、過程またはレポート情報は、クリップボードにコピーし他のアプリケーションに貼り付け

ることができます。要求したネットを選択し、右クリックメニューから Copy を選択します。さら

に、表示されている情報の種類は、右クリックメニューから Show/Hide Columns コマンドを使

用して表示される欄を選択してカスタマイズすることができます。 

6. ハイライト表示された解析結果のレポートは、Signal Integrity パネルで右クリックメニューから

Display Report を選択して利用することができます。これは、テキストエディタでレポートファ

イル（Signal Integrity Tests Report.txt）として開き、プロジェクトに追加されます。 

Preferences の設定 
定義した全ての解析を適用する為のさまざまなプリファレンスを指定することができます。これらは

一般的な設定、統合方法や正確なしきい値も含まれています。 

プリファレンスでの変更は、全てのプロジェクトに適用されます。全てのプリファレンスの設定は

C:\Documents and Settings\User_name\Application Data\Altium2004 フォルダにファ

イル名称 SignalIntegrity.ini で保存されます。 

1. Signal Integrity パネルの Menu ボタンをクリックして Preferences を選択すると Signal Integrity 
Preferences ダイアログが開きます。 
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2. 関連するタブをクリックし、必要なプリファレンスを設定してから OK をクリックします。 

3. Signal Integrity preferences ダイアログの全ての設定項目は Defaults ボタンをクリックして、デフ

ォルトの初期状態に戻すことができます。 

General タブ 
このタブでは、シグナルインテグリティ解析の実行に関係したエラーがデザインに存在する場合、ヒ

ントあるいはワーニングを表示するなどのエラーの取り扱いについて設定します。ヒントやワーニン

グは Messages パネルにリスト表示されます。Show Warnings オプションが有効でワーニングが発

生した場合には、Signal Integrity パネルにアクセスする際に warning confirmation ダイアログが表示さ

れます。さらに波形表示の際には Signal Integrity パネルを隠しておく設定、シグナルインテグリティ

測定の際のデフォルト単位設定、Waveform Analysis 画面でのプロットタイトルの表示や FFT チャー

トの表示の設定ができます。 

Configuration タブ 
このタブでは、カップルネットとみなすネット間の 大距離や 小長さなどシミュレーションに関連

する数々のしきい値を設定できます。 

Integration タブ 
このタブでは、解析のために使用される数値積分の方式が設定できます。Trapezoidal（台形則）は解

析が比較的早く正確ですが、ある条件下では積分境界が発散する傾向があります。Gear 法では解析に

より多くの時間を要しますが計算結果はより安定している傾向があります。さらに高次の Gear 法を

使えば高精度ですが、解析に要する時間も増えていきます。Trapezoidal を使用するのがデフォルトの

設定です。 

Accuracy タブ 
このタブでは、解析に関与する計算アルゴリズムが使用する様々なしきい値や限度設定を行ないます。 
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DC Analysis タブ 
このタブでは、DC 解析に関連したさまざまなパラメータ用のしきい値や限度設定を行ないます。 

許容範囲の設定 

デザインが初めて解析される際には、4 つのデフォルトの許容範囲および回路図または PCB で設定さ

れたシグナルインテグリティで使用するルールが全て有効になっています。 

1. Signal Integrity パネルの Menu ボタンをクリックして Set Tolerances を選択すると、Set 
Screening Analysis Tolerances ダイアログが表示され、これらのルールを有効／無効に設定するこ

とができます。 

 

2. デザインが解析される際に有効としたいルールタイプ右側の Enabled チェックボックスをクリッ

クしてチェックマークを入れます。 

3. シグナルインテグリティで使用するルールを追加／変更するには、PCB Signal Integrity Rules ボ
タン（回路図のみの方法で無い場合）をクリックし、PCB Rules and Constraints Editor ダイアロ

グを開きます。必要な修正が終わったらダイアログを閉じてから Signal Integrity パネルの OK を
クリックします。 

解析の準備 

解析を実行する前に、解析するネットを選択する必要があります。もし必要があれば、Edit Buffers メ

ニューを使用して、部品の part technology やピンの属性の表示、変更やネットに終端を追加すること

ができます。 

解析するネットの選択 

ネット上の解析を行うには（反射やクロストーク）、ネットが Signal Integrity パネルの右側のリスト

で選択されている必要があります。 

1. パネル左側のリストで解析を行いたいネットをダブルクリックすると、ネット名はパネル右側にリ

ストされます。 
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あるいは左側のリストで選択したネットを右側のリストに移動させるには矢印ボタンを使用して下

さい。左側のリストで複数のネットを選択するには、Shift または Ctrl キーを押しながらマウスで

ネットをクリックします。 

 

2. ネットが選択された状態であれば、シミュレーション実行前に更に詳細な設定を行うことが可能で

す。 

Victim と Aggressor ネットの設定 
クロストーク解析を行なう場合、ネットを victim、aggressor に分類する必要があります。複数のネッ

トが選択（右側のリストに移動）された場合にのみこの機能が有効であることに注意して下さい。 

1. 右側のリストでネットを選択して右クリックし Set Aggressor または Set Victim を選択します。

ネット名左側のステータス表示が更新されます。 

2. マウス右クリックメニューから Clear Status を選択すると設定が解除されます。 

双方向ピンの方向設定 

与えられたネットに含まれる双方向ピンの Direction を設定す

ることができます。Direction を設定するには、 

17 

1. 右上のリストから影響を与えたネットを選択すると、下の

欄にそのネットに含まれるピンのリストが表示されます。 

2. ピンのリストから in/out ステータスを変更したい双方向ピ

ンを選択し、マウス右クリックメニューから Toggle In/Out
を選択するとステータスを変更できます。これらの in/out
の設定はプロジェクトに保存され次回使用する際も有効で

す。 

3. マウス右クリックのメニューから Cross Probe オプション

を選択して、関連した回路図・PCB ドキュメントのどちら

にもクロスプローブすることができます。 

バッファの編集 

入力と出力モデルやピン方向など、部品の Part Technology や
ピン属性の表示や変更することができます。右側のリストで、

選択したネットに接続されている部品を変更することができま
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す。ピンのリストでマウス右クリックして Edit Buffer を選択すれば、部品の属性を編集できます。 

コンポーネントのパートテクノロジーを変更してもそれはピン単体の特性の変更だけで、部品全体の

変更では無いことに注意してください。Edit Buffer ボタンを使用して行なう全ての変更は、回路図に

含まれるシグナルインテグリティ・モデルから設定されたテクノロジー/ピンモデルの内容を上書きし

ます。 

1. ダイアログやオプションは、ピンが属する部品のタイプ（例えば resistor, IC, BJT など）によって

変わります。Integrated Circuit ダイアログは、IC 部品用のダイアログです。 

2. Input Model と Output Model の欄は Part Technology のタイプに依存して変化します。 
Component Part Technology をドロップダウンから選択すれば、関連したデフォルトのテクノロジ

ーモデルがモデル欄に入力されます。 

3. ピンの Technology と Direction をプルダウンから選択すれば、適切な Input または Output モデル

がそれぞれの欄に表示されます。Technology や Direction の変更は、解析実行時のみで有効でロー

カルな修正です。必要な変更を行って、OK をクリックします。 

終端 

信号波形の乱れは、伝送線路における複数の反射波によるものです。これらの反射や’リンギング’は
PCB 設計においてドライバー／レシーバーのインピーダンス不整合により発生します。通常、ドライ

バーが低いインピーダンス、レシーバーが高いインピーダン

スです。 

ドライブ側での理想的な信号の質を得るには、反射を 0 にす

る（リンギングがない）ことです。リンギングのレベルは、

終端を使用することで、デザインが許容できるレベルに下る

ことができます。 

Signal Integrity パネルはネットの指定した位置に、’仮想的な

終端’を挿入して評価できるターミネーションアドバイザーを

装備しています。この方法で、物理的にボードを作成しなく

ても、自由にターミネーションの方法をシミュレーションす

ることができます。 

シミュレーションできる終端の種類には、シリーズ抵抗、プ

ルアップ抵抗（VCC へ）、プルダウン抵抗（GND へ）、プル

アップ・ダウン抵抗（VCC と GND へ）、コンデンサ付きプ

ルダウン（GND へ）、パラレルコンデンサ（GND へ）、シ

ョットキーダイオードがあります。 

各終端の種類は、リストから有効／無効を設定することがで

きます。反射またはクロストーク解析を実行した際に、有効

となった終端の種類ごとにシミュレーション波形を出力しま

す。シリーズ抵抗の終端を使用した場合、それは選択したネ

ットの全ての出力ピンに配置されます。他の終端はネットの全ての入力ピンに配置されます。 

さらに終端の 良の結果を得るには、ネットの特性に応じた 適な定数を設定することが必要です。 

1. 終端の種類を選択する時、下部にその種類に応じた終端の図が表示されています。この図では、終

端に使用する抵抗やコンデンサの 小値と 大値の定数を設定することができます。 
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2. 定数の 小値と 大値は、スイープ数（終端のリストに表示されます）が 1 以上の数値に設定され

る時に使用されます。 

3. 終端の種類についての詳細な情報は、Help (?) ボタンをクリックすれば表示されます。Suggest オ
プションが有効になっている場合は、推奨の定数が計算され（各終端の種類の情報ポップアップに

記載された公式によります）ライトグレーで表示されています。この値を採用するか、必要ならば

Suggest オプションを無効にし、他の定数を入力することもできます。 

4. もし、スイープを設定したい場合は、Perform Sweep が有効で、解析が実行される時に必要な

Sweep Steps の数が設定されていることを確認します。定数の比較検証のため、スイープごとに

波形が生成されることに注意してください。 

回路図に終端を配置 

一度、波形が作成され 適な終端が見つかれば、回路図シートに直接、終端を配置することができま

す。 それは、termination リストでマウス右クリックすることで可能です。回路図への終端の配置は、

現在、選択されたネットにのみ適用されることに注意して下さい。 

もし、’仮想の終端’としてではなく、選択した終端回路を実際に回路図に配置したいならば、 

1. Signal Integrity パネルの Termination の項目内でマウス右クリックし Place on Schematic を選択

します。 

2. 終端用に使用するライブラリコンポーネントのようなさまざまな属性の設定、部品配置を自動ある

いはマニュアルで行なうかの設定、選択したピンにのみ終端を配置する設定、部品に使用する正確

な定数などの設定項目を持った Place Termination ダイアログが表示されます。OK をクリックし

て続けます。 

 

3. シグナルインテグリティ・アナライザは、目的のピンを含んだソース回路図を検索し、そしてドキ

ュメントの空いている個所に正しい定数を持った必要な素子（抵抗、コンデンサまたは必要なもの

は何でも）やパワーオブジェクトを追加します。回路図の目的のピンに終端素子を接続します。 
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この後に、追加した素子をピンに正確に配線することが必要になるかもしれないことに注意してく

ださい。更に、PCB に、同様に追加した素子を含める場合、同期させ PCB で配線する必要があり

ます。Design » Update PCB を選択して、同様にこれらの部品を追加する為に PCB を回路図と同

期させます。 

解析の実行 

1. 必要なネットの設定（と終端オプションの選択）が完了したら、波形を生成する為に Reflection 
Waveforms または Crosstalk Waveforms ボタンをクリックします。 

2. 解析が開始され、シミュレーション波形ファイル(PCBDesignName.sdf)が作成されます。このフ

ァイルは、Projects パネルの Generated\Simulation documents フォルダに表示され、分割

されたタブで開きます。そして、Simulation Data エディタの波形解析画面に解析結果が表示され

ます。 

3. 選択した各ネットについて、チャートが生成され波形解析画面に波形が表示されます。 

 

反射 

反射解析は、複数のネットをシミュレーションすることが可能です。しかし解析するネットの数に応

じて解析に要する時間が必要になるので、ネットの数は現実的な数に留めるべきです。 
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シグナルインテグリティ・アナライザは、PCB からの層の構成や配線の情報およびドライバーレシー

バーの I/O バッファーモデルを使用してネットの各ノードの電圧を計算します。2 次元解析ソルバーは

自動的に伝送線路の電気的特性を計算します。DC 通過ロスは無視できるぐらい十分に小さいと仮定し

てモデリングされています。 

選択された各ネットについては、チャートが生成され、波形解析画面内のネット名称のタブと共に解

析結果が表示されます。チャートには、終端オプションの波形が含まれています。 

クロストーク 

クロストークの解析では、2 つ以上のネットを必要とします。通常、ノイズ発生源のネットとそのす

ぐ隣の 2 つまたは 3 つのネットが解析対象となります。 

クロストークのレベル（または EMI の範囲）は、信号線の反射の大きさに比例します。もし、信号の

乱れを少なくし反射の影響も無視できるレベルまで下ることができれば、信号はロスなく終端まで伝

達されクロストークもまた 小になるでしょう。詳細な情報は、終端の項も参照ください。 

クロストーク解析では、全てのネットは Crosstalk Analysis と言う名称のチャートに表示されま

す。 

波形解析画面の使用 

シミュレーションデータ・エディタの波形解析画面には、個々のシミュレーション解析実行毎に追加

される複数のタブがあります。各タブは複数の波形プロットを表したチャートを含み、各波形プロッ

トは複数のシミュレーションデータの波形を表示することができます。この画面には、4 つまでの測

定プロットを同時に表示することができます。  

ソースデータの選択 

初期のソースデータは、シグナルインテグリティの設定に含まれていた全てのネットから構成され、

Sim Data パネルの Waveforms の項目にリスト表示されます。更に、アクティブチャートで使用でき

るソースシミュレーション波形のリストを設定することができます。 

1. メニューから Chart » Source Data を選択するか、Sim Data パネルの Source Data ボタンをクリ

ックすると Source Data ダイアログが表示されます。このダイアログには、アクティブチャートで

使用できるソースシミュレーション波形がリスト表示されています。 
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2. Create ボタンをクリックすると Create New Waveform ダイアログが開き、新たに表示を追加した

い波形の一連のデータポイントに X、Y の値を登録するか、またはカスタムのサイン波、パルス波

の設定することができます。 

  

3. 新たな信号波形の設定を行なってから Create ボタンをクリックすると、SimData パネルの波形リ

ストに波形名称が追加されます。 

4. Source Data ダイアログでは、波形データを ASCII テキストファイル(WaveformName.wdf)で保

存することができます。これらの波形ファイルは 、いつでも再び読み込んでリストに加えること

ができます。 

5. Create ボタンで作成したユーザー設定の波形は、Edit ボタンをクリックして編集することができ

ます。詳細な情報は、ユーザー定義波形の編集の項目を参照して下さい。 

波形画面での作業 

アクティブチャートとプロットの選択 

波形解析画面の下部にあるタブ名称をクリックしてチャートを選択します。波形プロットの範囲内を

クリックすることにより、個々のプロットをアクティブにすることができます。 

ドキュメント オプション 

Document Options ダイアログ(View » Document Options)で Number of Plots Visible オプションが

All に設定されている場合、アクティブな波形プロットは、波形名称の周りが黒の実線で縁取られて識

別されます。 

Number of Plots Visible オプションが 1，2，3 または 4 に設定されている場合、アクティブな波形プ

ロットは、その表示範囲の左側に黒い矢印で識別されます。 

波形の選択 

波形解析画面で、波形名称をクリックするとその波形が選択されます。選択された波形は太線になり、

名称の隣にドットが表示されます。そして、選択されていない他の波形はマスク（薄く）表示されま
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す。Mask Level ボタンをクリックするとマスクのコントラストを調整でき、Clear ボタン（ショート

カット Shift+C または ESC キー）をクリックするとセレクションのマスクが解除されます。 

更に、矢印キーやマウスホイールを使用して、波形名を上下に移動することができます。プロットの

表示波形名称の数が多く表示しきれない場合、スクロールアローが表示され、矢印をクリックするこ

とで全リストを見ることができます。 

Document Options ダイアログ(View » Document Options)の Highlight Similar Waves オプションを

有効にすると、同じスイープでの全ての波形をハイライト表示することができます。 

波形の拡大 

波形表示の拡大したいエリアをマウスでドラッグして選択するとズーム表示します。波形全体を再度

表示するにはマウス右クリックで Fit Waveforms を選択します。 

 

波形の移動 

波形プロットから別のプロットへ波形を移動したい場合、移動したい波形の名称部分をクリックして、

移動したいプロットの場所までドラッグします。 

波形プロットの波形を表示 

新たな波形プロットで波形を表示したい場合、 

1. まず Number of Plots Visible(View » Document Options)が All に設定されていることを確認しま

す。 

2. 波形の名称部分をクリックし、ブランクの波形プロットかチャートの 後の波形プロットの更に下

までドラッグします。新しい波形プロットが作成されます。 

プロットへ波形を追加 

チャートのアクティブな波形プロットに新たな波形を追加するには、 

1. 波形プロットの領域内をクリックし、波形解析画面内で新規の波形を追加したいプロットをアクテ

ィブにします。 

2. メニューから Wave » Add Wave を選択し、Add Wave to Plot ダイアログを表示させます。 

3. シミュレーション波形のリストから波形を選択します。もし必要があれば、functions 欄に用意さ

れた演算子を Expression に追加して数学的手法で言語式を作成し、波形を加工して表示すること

もできます。 

4. Create をクリックして、新たな波形が波形プロットに追加されます。 
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ユーザー定義波形の編集 

Create New Waveform ダイアログを使用して手動で作成したユーザー定義の波形を編集することはで

きますが、シミュレーションの結果として生成された波形を編集することはできません。これらの波

形を変更するには、回路図を修正するか、PCB またはシグナルインテグリティ解析に戻り設定を変更

する必要があります。 

Edit Wave コマンドでは、既存の波形から新規の言語式を作成することができます。 

1. 波形解析画面で波形名をクリックし、編集したい波形が選択されていることを確認します。 

2. メニューから Wave » Edit Wave を選択し、Edit Waveform ダイアログを表示させます。 

3. このダイアログを使用して、選択された波形に関連する数学的手法の言語式を使用して波形を新た

に作成するか、または Waveform リストに表示されている波形リストから新しい波形を選択して波

形を変更します。 

波形の保存と再読み込み 

Tools » Store Waveform を選択して、WaveformName.wdf と言うファイル名で ASCII テキストファ

イル形式として波形を保存することができます。.wdf ファイルは X Y 値ペアによって表される一連

のデータポイントで波形を表現しています。一旦、ユーザー定義した波形が保存され、再度読み込ま

れた場合、読み込まれたその波形はもはや編集できない点に注意してください。 

保存された波形を再度、読み込むには Tools » Recall Waveform を選択し、表示された Recall Stored 
Waveform ダイアログで .wdf ファイルを選択します。波形名称が、アクティブチャートの Source 
Data 欄のリストに再度、読み込まれます。 

新しいチャートの作成 

現在の.sdf ファイルに追加する新しいチャートを作成するこ

とができます。 

1. メニューから Chart » New Chart を選択し、Create New 
Chart ダイアログを表示します。 

2. 追加する波形の名称とタイトルを記入し、X 軸のラベルと

単位を設定します。さらに複雑なデータをチャートに表示

するかどうか指定することができます。 

3. OK をクリックすると、新しいブランクチャートが波形解

析画面に表示され、このチャートのタブがドキュメントの

後に追加されます。 

FFT チャートの作成 
アクティブなチャートで高速フーリエ変換（FFT）を実行し、結果を新しいチャートで表示すること

ができます。 

1. 高速フーリエ変換を実行したいチャートを波形解析画面の下部のタブでクリックします。 

2. Chart » Create FFT Chart を選択します。FFT が実行され、結果は新しいチャートに表示されま

す。それは新しいタブ(<netname>_FFT)として追加され、画面上でアクティブチャートとして作

成されます。 
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新しいプロットの作成 

Plot Wizard を使用して、既存か新しいチャートに新しいプロットを追加することができます。 

1. メニューから Plot » New Plot を選択すると、Plot Wizard の 初のページが表示されます。追加

するプロットの名称を入力して Next をクリックします。 

 

 

2. プロットに表示する項目を設定して Next をクリックします。 

3. Add ボタンをクリックして Add Wave to Plot ダイアログで追加する波形を選択し（または、言語

式を追加）、Create をクリックします。 

4. Next をクリックして波形の追加を続けるか、Finish をクリックしてウイザードを終了させます。

新しいプロットが波形解析画面に表示されます。 

SimData パネルの使用 
SimData パネルでは、利用可能なソースデータからアクティブ波形プロットへ波形を追加したり、測

定用カーソルを使用して、選択された波形の各ポイントを測定しその情報を表示することができます。 

パネルの上部の波形項目には、シミュレーションで生成された全ての利用可能なソースデータ信号波

形のリストが表示されています。このリストは、Source Data ダイアログ (Chart » Source Data)で表

示されるリストと同じ内容です。Source Data をクリックして、このダイアログを開きます。 
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SimData パネルからプロットに波形を追加 SimData パネルからプロットに波形を追加 
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波形解析画面で選択したプロットへ波形を追加するには、Sim Data 
パネルで追加したい波形を選択してから Add Wave to Plot ボタンを

クリックします。 

波形解析画面で選択したプロットへ波形を追加するには、Sim Data 
パネルで追加したい波形を選択してから Add Wave to Plot ボタンを

クリックします。 

測定カーソル 測定カーソル 

パネルの Measurement Cursors の項目では、1 つあるいは両方の測

定カーソルを使用して測定値を表示します。 
パネルの Measurement Cursors の項目では、1 つあるいは両方の測

定カーソルを使用して測定値を表示します。 

1. 2 種類の測定カーソル(A と B) は、波形解析画面内の選択した波

形名称の部分でマウス右クリックして利用できます。カーソルを

ドラッグすることで目的の位置まで移動できます。 

1. 2 種類の測定カーソル(A と B) は、波形解析画面内の選択した波

形名称の部分でマウス右クリックして利用できます。カーソルを

ドラッグすることで目的の位置まで移動できます。 

 

2. 両方のカーソルについて、カーソルが現在割り当てられている波

形の名称と X 軸、Y 軸データの値（カーソル位置での波形の座

標）が表示されています。 

3. 計算された X と Y の値は、SimData パネルの Measurement 
Cursors の項目に表示されます。 

波形の測定 

ダイアログの Waveform Measurements の項目では、波形解析画面で

選択した波形の立ち上がり、立下り時間といったさまざまな基本的な

測定結果を表示します。 

結果の分析後 

解析結果を分析することで、例えば、選択したネットのリンギングを

押さえるための 適な終端の選択を実験することができます。さらに

回路図や PCB を変更して希望の結果に到達するまで、シグナルインテグリティを繰り返す必要があり

ます。 
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