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このチュートリアルでは、FPGA 設計を行うための概要を

説明します。アルテイウムの NanoBoard でドーターボード

Xilinx Spartan IIE を使用し、どのようにして回路図を作成

し、プログラム、ビルド、論理合成、コンパイルするかと

いう概要を紹介します。また、FPGA 設計において、サブ

シートと VHDL ファイルの使用法を簡単に紹介します。 
 

 
このチュートリアルでは、非常に簡単な回路設計を説明します。ソフトウェアを利用する高レベルの

回路図/VHDL 混在設計ではありません。もっと高度な設計を行うには、\Altium2004\Examples フ
ォルダのサンプルファイルを参照して下さい。\FPGA Hardware フォルダには、プロセッサ（回路

図/VHDL 混在マルチチャンネル LED chaser を含む）を含まないファイルが保存されています。

\FPGA Processors フォルダと\Reference Designs フォルダには、プロセッサに基づく FPGA
デザイン（デジタルシステム全体を扱う簡単な特徴などを表したファイル）が保存されています。  
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デジタル設

念が PCB
なることに

は重要で

計では、

規則通りに

。 

チュートリアルを始める前に、PC のパラレルポートに NanoBoard を
スイッチを ON にして下さい。Xilinx ウェブサイト(www.Xilinx.com)から

ンロードした Xilinx ツール（web 版）がインストールされていることを

て下さい。 

このチュートリアルでは、図 1 の Johnson Counter のサンプルファイル

って説明します。このファイルは、DXP のインストールディレクトリの

Altium2004\Examples\Tutorials\Getting started with FP
Design フォルダに保存されています。  

Johnson Counter（あるいは Twisted ring counter）は、最終段のフリッ

初段のフリップフロップの入力に接続される同期カウンタです。この J
した時は、NanoBoard 上の LED が一度に点灯します。後から回路図に

ック遅延を追加することで、カウンタは左から右へ、あるいは、右から

す。 
DXP では、

計の回路図概

設計概念と異

注目すること

す。FPGA 設

PCB 設計の

はいきません

接続し、

ダウ

確認し

を使

GA 
1 

プフロップの反転した出力が

ohnson counter の回路が動作

LED 表示を遅くする為のクロ

左へシフトするように見えま
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図 1. Johnson Counter 回路図 

FPGA プロジェクトの作成 
DXP で設計を始める為に、最初にプロジェクトを作成する必要があります。プロジェクトは、個々の

ドキュメントや出力ファイルを管理する為に使用します。FPGA 設計を行う為に、FPGA プロジェク

トを作成する必要があります。 

新規の FPGA プロジェクトを作成するには、以下の手順を実行しま

す。 
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1. メニューから File » New » Project » FPGA Project を選択する

か、Files パネルの New の項目で Blank Project (FPGA)をクリ

ックします。もし、このパネルが表示されない場合は、Files タ

ブをクリックして下さい。 

2. Projects パネルに新しいプロジェクトファイル（FPGA 
Project1.PrjFpg）が表示されます。 

3. プロジェクトファイル（拡張子.PrjFpg）の名前を変更するに

は、File » Save Project As を選択します。ファイル名の項目で Johnson_Counter.PrjFpg と

入力し、プロジェクトを保存したいハードディスクの場所を指定しま

す。そして、保存 をクリックします。 ト名やファ

ースやダッ

ないで下さ

間を空けた

ダースコア

い。 

その後の設計過程で論理合成エラーを避ける為に、プロジェクト名、

ュメント名には、スペースではなくアンダースコア(‘_’)を使用する必

あります。 

次に、Johnson Counter の回路図を作成します。 

回路図の作成 

FPGA プロジェクトは、回路図と VHDL の 2 種類のソースドキュメン

ジェクトでは、シートシンボルを使用することで両方のドキュメント
警告: プロジェク

イル名にはスペ

シュ(-)は使用し

い。もし、文字

い場合は、アン

を使用して下さ

ドキ

要が
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トをサポートしています。プロ

タイプを混在させることができ
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ます。しかし、FPGA プロジェクトでは、プロジェクトのトップ図面で回路図

を使用する必要があります。これにより、Vendor FPGA-PCB 統合環境がサポ

ートされます。 
シートシンボルを使用し

て、VHDL と回路図ドキ

ュメントを混合すること

ができます。VHDL の場

合、シートエントリー

は、VHDL ドキュメント

のポートに相当します。

デザインには、NanoBoard 上の LED の表示を遅らせる為の遅延回路が含まれ

ています。最初に、Johnson counter の回路図シートを作成します。それから、

階層構造の使用例を紹介する為に、サブシートに遅延回路を移動します。最後

に、VHDL ファイルでこのサブシートを交換します。 

Johnson Counter の回路図を作成するには、以下の手順を実行します。 

1. File » New » Schematic を選択するか、Files パネルの New の項目の Schematic Sheet をクリッ

クします。デザインウィンドウにブランクの回路図（Sheet1.SchDoc ）が表示されます。 

2. 回路図ファイル（拡張子.SchDoc）の名前を変更するには、File » Save As を選択します。ファ

イル名の項目で Johnson_Counter.SchDoc と入力し、回路図を保存したいハードディスクの場

所を指定します。そして、保存 をクリックします。 

回路図へのパーツ配置 

この回路図で使用するコンポーネントは、\Program Files\Altium2004\Library\FPGA\FPGA 
Generic.IntLib の統合ライブラリに用意されています。このライブラリは、Libraries パネルで登

録し利用することができます。 

 Generic FPGA ライブラリのコンポーネントは、このシステムでサ

ポートしている全 FPGA デバイスで使用できます。ベンダープリミ

ティブが利用可能な特別な統合ライブラリ(*FPGA.INTLIB) が
（\Program Files\Altium2004\Library のデバイスメーカー

別フォルダに）あり、これらは特定のデバイスを対象にしたもので

す。従って、それらを使用することは、デザインの移植性を妨げま

す（デザインで実際に必要になった場合にのみ使用します）。統合

ライブラリの検索、使用方法の詳細は、「統合ライブラリの作成」

チュートリアルを参照して下さい。  

それでは、Johnson Counter の回路図を作成してみます。 

1. Libraries パネルのドロップダウンリストから FPGA 
Generic.IntLib を選択して下さい。 

2. Libraries パネルで SR8CLEDB のコンポーネントを探します。

ライブラリ名の下の Masks 編集ボックスで SR8CLEDB（または、

名前の一部）と入力するかリストから探して Libraries パネルで

ブラウズすることができます。リストでコンポーネントを選択

して Place SR8CLEDB ボタンをクリックするか、コンポーネント名を選択して回路図シートにド

ラッグ移動します。 

3. カーソルにコンポーネントが表示されるはずです。もし、カーソルにコンポーネントが表示されな

い場合は、回路図のワークスペース内にカーソルを移動して下さい。回路図上の適切な位置でクリ

ックしてコンポーネントを配置します。コンポーネントのデジグネータの設定については、後でア

ノテートを実行するので心配ありません。 
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4. この回路図では、8 ビット入力バス(J8B_8S)、6 つのインバーター、1 つのORゲート(OR2N2S)、
2 つのフリップフロップ(FJKC)を使用します。図 2 のようにこれらのコンポーネントを配置します。 

5. NanoBoard にプラグインで接続するポートが必要になります。これらは、FPGA NanoBoard 
Port-Plugin.IntLib（Libraries パネルから利用できるデフォルトライブラリ）に用意されて

います。このライブラリから図 2 のように DIPSWITCH、TEST_BUTTON、

CLOCK_REFERENCE、LED を配置します。 

 
図 2. 部品が配置された Johnson Counter 回路図 

6. 最後に、Tools » Quiet Annotate か Tools » Force Annotate All を使用してデザインにデジグネ

ータを追加します。デジグネータは、この回路図上の全てのコンポーネントに自動で追加されます。 

パワーポートの追加 

2 つの GND パワーポートを配置します。 

1. Place » Power Port を選択するか、Wiring ツールバーの GND アイコンをクリックします。 

2. TAB キーを押して、 Power Port ダイアログを表示させます。Net が GND に設定されていること

を確認して、Style のドロップダウンリストから Bar を選択します。OK をクリックし、GND ポー

トを配置します。 

3. 右クリックか ESC キーを押し、配置モードを解除します。 

4. SR8CLEDB のコンポーネントの D[7..]ピンにグラウンドバスパワーポートを追加する必要があり

ます。Wiring ツールバーの VCC Bus Power Port ボタン をクリックします。TAB キーを押し

て、 Power Port ダイアログを表示させ、Net 名を GNDBUS[..]に変更し、Style が Bar に設定さ

れていることを確認します。OK をクリックし、Spacebar を押してシンボルを回転させてから回

路図に配置します。 

オブジェクト間の接続 

コンポーネントとポートを配置したので、次にオブジェクト間を接続します。オブジェクト間を接続

するには明示的か暗黙的に接続するかの 2 つの手段があります。明示的な接続方法は、2 つのオブジ

ェクト間をワイヤで接続する物理的な接続です。暗黙的な接続方法は、ワイヤとネットラベルで接続

4 TU0116 (v1.1) September 23, 2004   



FPGA デザイン入門 

します。これは実際に物理的な接続がされておらず、2 つのワイヤが同じネットラベルを共有してい

ることで接続は確立されます。 
します。これは実際に物理的な接続がされておらず、2 つのワイヤが同じネットラベルを共有してい

ることで接続は確立されます。 
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他のワイヤ、コンポーネ

ントのピン、ポートにワ

イヤを接続した時に接続

が確立されます。もし、

カーソルが、接続したい

オブジェクトの上で赤い

十字に変わる場合、ワイ

ヤのノードをそこに配置

すれば接続が確立されま

す。 

この回路図では、ワイヤとバスが必要です。最初にワイヤを配置します。ワイヤとラインを混同しな

いように注意して下さい。ワイヤは電気的な接続に、ラインは図形などの描画

に使用します。 

この回路図では、ワイヤとバスが必要です。最初にワイヤを配置します。ワイヤとラインを混同しな

いように注意して下さい。ワイヤは電気的な接続に、ラインは図形などの描画

に使用します。 

1. ワイヤを配置する為に、Place » Wire [ショートカット P, W]を選択し、配

置したい位置（通常は、コンポーネントのピンかポート）でクリックしま

す。次に、接続したい位置にカーソルを移動し、もう一度クリックします。

コンポーネントのピンかポートに接続するまでこの操作を続けます。右ク

リックか ESC キーを押してワイヤ配置モードを解除します。 

1. ワイヤを配置する為に、Place » Wire [ショートカット P, W]を選択し、配

置したい位置（通常は、コンポーネントのピンかポート）でクリックしま

す。次に、接続したい位置にカーソルを移動し、もう一度クリックします。

コンポーネントのピンかポートに接続するまでこの操作を続けます。右ク

リックか ESC キーを押してワイヤ配置モードを解除します。 

2. ワイヤが交差するジャンクションに注意して、図 3 のようにワイヤを接続

します。もし、2 つのワイヤが交差しジャンクションが発生する場合、こ

れらの 2 つのワイヤが接続されたことを意味します。もし、ジャンクショ

ンが無い場合は、接続されていません。ワイヤが接続される箇所では、自動でジャンクションが発

生します。 

2. ワイヤが交差するジャンクションに注意して、図 3 のようにワイヤを接続

します。もし、2 つのワイヤが交差しジャンクションが発生する場合、こ

れらの 2 つのワイヤが接続されたことを意味します。もし、ジャンクショ

ンが無い場合は、接続されていません。ワイヤが接続される箇所では、自動でジャンクションが発

生します。 

 
図 3. ワイヤで接続された Johnson Counter の回路図 

接続名の指定 

上記で行った接続方法は、明示的な方法です。従って、ネットラベルは必要ありません。しかし、ネ

ットラベルは回路図上の接続を分かりやすくし、問題を突き止めて接続箇所を容易に参照することが

できます。 

1. Place » Net Label [ショートカット P, N]を選択します。カーソルのところにネットラベルが表示

されます。 

2. ネットラベルを配置する前に属性を編集する為、TAB キーを押して Net Label ダイアログを表示

させます。Net の項目でネット名（例：LEFT）を入力し、OK をクリックします。 

3. ネットラベルの左下（ホットスポット）がワイヤに触れるように、ネットラベルを配置します。ネ

ットラベルがワイヤに触れるとカーソルは赤いクロスに変化します。 
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4. 下図のように他のネットにもネットラベルを配置します。ネットラベルは、各信号の識別ができれ

ば、図 4 とまったく同じ名称を付ける必要はありません。右クリックか ESC キーを押し、ネット

ラベル配置モードを解除します。 

4. 下図のように他のネットにもネットラベルを配置します。ネットラベルは、各信号の識別ができれ

ば、図 4 とまったく同じ名称を付ける必要はありません。右クリックか ESC キーを押し、ネット

ラベル配置モードを解除します。 

 

図 4. ネットラベルが配置された Johnson Counter 回路図 

バスの使用 

6 TU0116 (v1.1) September 23, 2004   

DXP 2004 では、FPGA 設計の為に複合のバスを使用することができます。バ

スは、単に信号がグループ化されたものではなく、どのようにバスの各信号が

終了点に導かれるか指定するために使用します。 

バスは、名前で判断され

ます。もし、ネットラベ

ル名の最後が数値で、そ

の前の名称が同じなら

ば、ネットラベルをグル

ープ化できます。 

バスを使用する時、バスセグメントごとにネットラベルが常に必要であること

に注意して下さい。また、バスから別のオブジェクトへ接続する場合は、常に

左から右へ接続するようにし、双方のオブジェクトのバスサイズも同じである

必要があります。 

SR8CLED に LED ポートを接続する為に、図 5 のように SQ[7..0]と言うバスを作成します。 

1. Place » Bus [ショートカット P, B]を選択して、ワイヤを配置する時と同じ配置方法でバスを配置

します。 
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マッピング

スの範囲は

読み込まれ

図 5. バスとバスエントリの追加 

2. バスに SQ[7..0]と言うネットラベルを配置します。バスには常にネットラベルを配置してくださ

い。確実に接続されている場合でも、ネットラベルがないバスは、バスの各要素がどのように終点

に接続されているか明確に特定できない為、不定となります。 

3. 次に、図 5 のようにバスエントリを追加します。Place » Bus Entry [ショートカット P, U]を選択

し、SQ0 と SQ7 のワイヤから SQ[7..0]にバスエントリを配置します。バスエントリを配置してい

る間に SPACEBAR を使用して回転させることができます。右クリックか ESC キーを押して配置

モードを解除します。 

4. DIP スイッチポートを J8B_8S に接続する為に、別のバスを追加します（図 6 参照）。 
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ス形式のネ

つまり“[ ]”)
スがよくあ

は、バスだ

る形式です

上に配置し

は動作しま

図 6. バスを備えた J8B_8S に DIP スイッチポートを接続 

5. 回路図を保存し、プロジェクトを保存します。 

デザインの確認 

クロックデバイダのサブシートを作成する前に、プロジェクトのコンパイ

FPGA Project ダイアログ(Project » Project Options)の Error Checking
ラフィカルなチェックを元に回路図のチェックを行います。 
ワイヤ上でバ

ットラベル(
を使用するミ

ります。これ

けで使用でき

ので、ワイヤ

ても DXP で
せん。 
バスの接続を

するとき、バ

左から右へと

ます。 
7 

ルを行い、Options for 
タブ内で設定した電気的、グ
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1. Project » Compile FPGA Project [project_name]を選択します。Error または Fatal Error のメッ

セージは、自動で Messages パネルに表示されます。 

2. Warnings も Messages パネルにリスト表示されますが、デザインウィンドウの下の System タブ

をクリックし、Messages(または、メニューから View » Workspace Panels » System » 
Messages を選択します)を選択してパネルを手動で表示させる必要があります。 

3. Compile Errors ダイアログのエラーについての詳細を確認する為に、Messages パネルでエラーメ

ッセージをダブルクリックします。エラー部分が回路図上でズームされハイライトされます。 

4. エラー箇所を修正し、再度、プロジェクトのコンパイルを行います。回路図とプロジェクトファイ

ルを保存します。 

デザインのコンフィギュレーション 

Johnson counter のデザインが完成しましたので、デザインで使用したい FPGA チップを指定する必

要があります（例えば、NanoBoard ドーターボードの Xilinx Spartan IIE XC2S300E-6PQ208C チッ

プ ）。これを行う為に、Configuration と Constraint ファイルを追加します。Constraint ファイルは、

NanoBoard の FPGA チップで使用するピンナンバーとデバイス名を決定します。 

1. Project » Configuration Manager を選択し、Configuration Manager for project ダイアログを表示

させます。ダイアログの Configurations の項目で Add ボタンをクリックし、New Configuration 
Name ダイアログで Configuration 名（例：NB_SpartanIIE）を入力して OK をクリックします。

Configuration 名は、確認し易くする為にターゲットに関連した名称にしてください。 

2. Constraints の項目で Add ボタンをクリックして Configuration に Constraints ファイルを追加しま

す（Choose Constraint files to add to Project ダイアログで NB1_6_XC2S300E-
6PQ208.Constraint を選択します）。Constraint ファイルは、Altium2004\Library\FPGA
フォルダに保存されています。開く をクリックします。 

3. Configuration Manager ダイアログの Configuration のチェックボックスにチェックを入れ、OK を

クリックします。 
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4. Settings と言う名前のフォルダが、プロジェクトに追加され、Constraints Files フォルダ

に Constraint ファイルが表示されます。 

5. プロジェクトファイルを保存します。 ィギュレー

ストレイン

 詳細は、

ータビリテ
ギュレーシ
トレイント
ル、デザイ
ドに再ター
して下さ

Altera Cyclone デバイスをターゲットにするには 
もし、Altera Cyclone チップをターゲットとする場合、NanoBoard に Altera 
Cyclone のドーターボードを注意して差し込みます。 

1. FPGA プロジェクトに、例えば、Altera と言う名の新しい Configuration
イル(Project » Configuration Manager)を追加します。 
コンフ

ションとコン

トについての

デザインのポ
ィ、コンフィ
ョン、コンス
のアーティク
ンを製造ボー
ゲットを参照

い。 

ファ
6 (v1.1) September 23, 2004   
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2. Altera Constraints ファイル（C:\Program 
Files\Altium2004\Library\ Fpga\NB1_6_EP1C12Q240.Constraint）を追加します。

Altera configuration が選択されていることを確認します。 

3. “Divices 画面を使用して FPGA のプログラムを実行”の次の項目に進みます。 

Johnson Counter のコンフィギュレーションが完了し、FPGA の準備ができました。残りの設計過程

は、Devices 画面で行われます。 

Devices ビューを使用して FPGA のプログラミング 
Devices ビュー(View » Devices)では、（左から右への）ワークフローに沿って、FPGA にプログラム

を送る為に必要な手順を示しています。この画面で以下のことができます。 

プロジェクトをコンパイル（エラーの確認） • 

• 

• 

• 

論理合成（EDIF ネットリストの作成） 

ビルド（例：EDIF ファイルの変換、デザインを FPGA に反映、FPGA の配置と配線、タイミング

解析の実行、FPGA をプログラムする為に使用するビットファイルの作成） 

FPGA プログラム（ドーターボードの FPGA チップ（例：Xilinx Spartan IIE）にビットファイルを

ダウンロード） 

 

このワークフローが完了すれば、NanoBoard 上の DIP スイッチをオン、オフすることでプログラムを

実行できます。 Johnson Counter デザインを FPGA へダウンロードするには： 

1. NanoBoard が正しく接続されていることを確認し、スイッチをオンにします。Devices ビューで、

Live ボタンをクリックし、Connected インジケーターが緑色に点灯していることを確認して下さ

い。 
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2. Devices ビューで、Compile をクリックします。編集が成功すると、赤色のインジケーターは、緑

色に変わります。もし、Messages パネルにエラーメッセージが表示された場合、回路図に戻りエ

ラーを修正してからファイルを保存し、再コンパイルを行います。 

10 T

ンの左にあ

ンをクリッ

の段階まで

クフローの

行できま

Program 
上のこのア

ックする

のステージ

。 

3. Synthesize をクリックします。更新された Synthesizing ダイアログが表示されます。論理合成が

成功すると、EDIF, VHDL ファイルと論理合成のログファイルが

Generated [config_name]というフォルダに作成されます。この

用された Configlation の NB_SpartanIIE が、Devices ビューの Spa
IIE アイコンの下に表示されます。 

論理合成中、ソースドキュメントは、中間の VHDL ファイルに置き換

れてからベンダーの配置・配線ツールに合った EDIF に論理合成を行

論理合成中に発見されたエラーは、中間ファイルのエラーに基づくの

題を解決する為には、ソースファイルに戻って下さい。Messages パ

ソースドキュメントと VHDL 中間ファイルのエラーが表示されますの

そのエラー内容をダブルクリックします。 

4. Build をクリックします。これは、FPGA にダウンロードされる Bit フ
セスまで進みます。それらのプロセスが完了するごとにボタンが緑色

います。必要なプロセスが全て完了した時に、Build ボタンが緑色に変

プロセスは、この例では必要ありません)。ベンダーに関するフィード

Output パネルを表示させます。 

5. ドーターボードの Spartan チップにビットファイルをダウンロードす

クリックします。 

6. Program FPGA プロセスが完了すると、NanoBoard 上の DIP スイッチ

り替えることによりプログラムを実行できます。 

スイッチ 1 で LED を右から左に表示させます • 

• 

• 

スイッチ 2 で LED を左から右に表示させます 

スイッチ 3 でプログラムを終了させます 

プログラムをリセットするには、LED の下にある Test/Reset ボタン

7. Johnson counter の本来の動作とは異なり、LED が同時に光っている

は、クロックがデフォルトで 50MHz に設定されている為です。LED
1/100 万までクロックを遅らせる必要があります。Hard Devices 装置

であるのを確認した後に、回路図にクロックデバイダを追加します。

Hard Devices 装置を使用して LED をチェック 
Instrument Rack の Hard Devices パネルでプログラムが正しく実行してい

チェックすることができます。この装置は、プログラムが実行している時

ピン番号により LED を表示します。この表示は、NanoBoard のクロック

存せず、LED を順に表示させる為に低い周波数は必要ではありません。

1. Devices 画面の Hard Devices の項目の Spartan-IIE アイコンをダブル

クします。Instrument Rack – Hard Devices ダイアログが表示されま
ステージボタ

る矢印アイコ

クして、現在

の全てのワー

ステージを実

す。例えば、

FPGA ボタン

イコンをクリ

と、前の全て

を実行します

例で使

rtan 

えら

います。

で、問

ネルに

で、
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2. Live Update チェックボックスをクリックします。 

3. スクロールダウンでピン番号 P56 を表示させます。LED アイコンは、プログラムが実行されると

同時に点灯します。 

クロックデバイダのサブシートの追加 

NanoBoard のクロックは、デフォルトでは 50MHz で動作しているので、LED 表示を遅らせる為に

Johnson Counter の回路にクロックを 1/10（CDIV10DC50 –デューティサイクル 50% バージョン）に

する 6 つのクロックデバイダを追加する必要があります。FPGA のプログラムを行っている時点で、

どのように階層設計が使用されるかを説明する為に、サブシートとしてクロックデバイダのサブ回路

を作成します。 

1. Johnson_Counter.SchDoc を開いて、クロックデバイダのサブシートを表すシートシンボルを

配置します（図 7 参照）。Place » Sheet Symbol を選択します。配置する前に TAB キーを押し

て、Sheet Symbol ダイアログの Properties タブ内で designator 名（例えば、

U_Clock_divider）とファイル名（例えば、Clock_divider.SchDoc）を入力します。OK を

クリックしてダイアログを閉じてから、シートシンボルを配置します。 

2. シートシンボルに、入出力の I/O タイプをそれぞれ設定した CLK_REF と CLK_OUT というシート

エントリーを追加します(Place » Add Sheet Entry)。 
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図 7. Clock_divider のサブシートを表すシートシンボルが配置された Johnson_Counter の回路図 

3. Design » Create Sheet from Symbol を選択し、サブシートを作成します。新規のシートシンボ

ルを配置する位置にカーソルを移動し、クリックします。シートエントリーの入力/出力の方向を

入れ換えない場合は、Confirm ダイアログで No をクリックします。新しい回路図が作成され、自

動で追加された CLK_REF と CLK_OUT のポートが配置された回路図が開きます。 

4. 図 8 の様に、FPGA Generic.IntLib から CDIV10DC50 と言う部品を選択し、クロックデバイ

ダの部品を 6 つ配置します。designator の設定について心配することはありません。部品を配置し

た後に、Tools » Annotate Quiet を選択すると、自動で Designator が設定されます。 

 

図 8. 部品とポートが配置された Clock_divider.SchDoc 

5. 回路図とプロジェクトファイルを保存します。 

6. エラーのチェックを行う為に、デザインを再コンパイルします。エラーがある場合は、修正し保存

します。 

7. コンパイル後、Projects パネルでプロジェクトのシート階層を確認できます（サブシート

(Clock_divider)は、Johnson_Counter の回路図の子シートとしてプロジェクトで認識されます）。 
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8. LED 表示の点灯速度が右から左へ（DIP スイッチ 1）または、左から右へ（DIP スイッチ 2）遅く

なった状態を確認する為に、Devices 画面に戻り、FPGA のプログラムを再度、行います。 

クロックデバイダへ VHDL ファイルを追加 
FPGA プロジェクト内のクロックデバイダ回路図サブシートに VHDL ファイルを代用します。この

VHDL ファイルは、1/100 万までクロック率を下げます。VHDL ファイルは、シートシンボルを介して

回路図にリンクされます。 

1. Projects パネルで FPGA プロジェクト名を右クリックして Add Existing to Project を選択し、プ

ロジェクトに VHDL ファイルを追加します。Choose Documents to Add to Project ダイアログから

VHDL ファイル（Clock_divider.VHD）を選択します。このファイルは、

Altium2004\Examples\Tutorials\Getting started with FPGA Design フォルダに保

存されています。 

もし、ゼロから VHDL ファイルを作成する場合、FPGA プロジェクト名を右クリックし、Add 
New to Project » VHDL Document を選択します。そして、図 9 のようなコードを入力し、ドキ

ュメントを保存します。 
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図 9. Clock_divider.VHD. 

2. 次に、回路図サブシートである Clock_divider.schdoc のシートシンボルを交換する為に、新

しい VHDL ファイルからシートシンボルを作成します。Johnson_Counter.SchDoc の回路図が

開いている状態で、Design » Create Sheet Symbol from Sheet を選択して、新しいシートシン

ボルを作成します。Choose Document to Place ダイアログから Clock_divider.VHD を選択し、

OK をクリックします。シートシンボルがカーソルに表示されます。TAB キーを押して、Sheet 
Symbol ダイアログを表示させます。VHDLEntity パラメーターが追加されたことを確認する為に、

Parameters タブをクリックします。Visible オプションが選択されていることを確認してから OK 
をクリックします。Johnson_Counter の回路図にこのシートシンボルを配置する為に、

Clock_divider.schdoc のシートシンボルの下でクリックします。 

 

もし、VHDL ファイルが複数のエンティティを含んでいる場合、VHDLENTITY パラメータで、ど

のエンティティかを示します。 
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3. Clock_divider.schdoc のシートシンボルを削除し、その場所に Clock_divider.VHD の新し

いシートシンボルを移動します。ワイヤが正しく接続されているか確認して下さい。 

 

図 10. 回路図に配置された Clock_divider.VHD のシートシンボル 

4. 回路図を保存します。 

5. Projects パネル内のドキュメント名（Clock_divider.schdoc）を右クリックし、Remove 
from Project を選択し、FPGA プロジェクトから Clock_divider.schdoc ファイルを削除しま

す。この回路図は VHDL ファイルが追加された為、不要です。FPGA プロジェクトファイルを保存

します。 

6. 最後に、VHDL ファイルでの遅延によりクロックが遅くなっているのを確認する為に、Devices ビ

ュー(View » Devices)を表示します。そして、 FPGA チップの編集、論理合成、ビルド、プログラ

ムの全てを行う為に、Program FPGA をクリックします。もし、FPGA のプログラムが成功すれ

ば、以前のように Johnson Counter を実行することができるはずです。 
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更新履歴 
 

Date Version No. Revision 

16-Jan-2004 1.0 New product release 

23-Sep-2004 1.1 Clock divider components updated 
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