
 

 

PCB デザイン入門 

概要 

Tutorial  
TU0117 (v1.0) January 22, 2004   

このチュートリアルでは、回路図を作成する為の方法、

PCB にデザイン情報を更新する方法、製造用出力ファイル

を作成する方法について概要を説明します。また、プロジ

ェクトや統合ライブラリの概念についても説明します。 

 

 
Windows 2000/XP 用の 32bit 電子設計システムである DXP の世界へようこそ。このチュートリアルで

は、マルチバイブレータのデザインを例に PCB を作成してみます。 

デザインエクスプローラ 
デザインエクスプローラは、設計者とデザインツールとのインターフェイスです。DXP をスタートし、

デザインエクスプローラを開くには、Windows のスタートメニューから Programs » Altium » DXP 
2004 を選択します。DXP を開くと、最も一般的な初期タスクが表示され、すぐに利用することがで

きます。 
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きます。 

ドキュメントタブ 

オープンしている各ドキュメン

トのデザインウィンドウ上部に

はタブがあります。タブを右ク

リックすると、ドキュメントを

閉じたり、分割したり、並べて

表示できます。 

デザインウィンドウ 

デザインウィンドウには、現

在オープンしているドキュメ

ントが表示されます。 

回路図 エディタ 

セレクションメモリ

ボタンはセレクショ

ンを保存します。マ

スクレベルボタンは

マスクされているオ

ブジェクトの濃淡を

変更します。Clear ボ
タンをクリックする

と、現在のフィルタ
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でドキュメントをグ
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PCB エディタ 

ワークスペースパネル 

ボタンをクリックすると

関連するワークスペース

パネルが表示されます。 

レイヤタブ 

PCB の各レイヤには 
タブがあります。 

デザインドキュメントの保存方法 

DXP のあらゆるデザインドキュメントや出力ファイルは、ユーザーのハードディスク上に個別ファイ

ルとして保存されます。これらのファイルは、Windows エクスプローラで検索できます。プロジェク

トファイルを作成するとデザインドキュメントへのリンクが設定されます。プロジェクトファイルは、

デザインを検証して各ファイルの同期を取るために必要なファイルです。 

新規プロジェクトの作成 

DXP のプロジェクトは、デザインに関連するすべてのドキュメントと設定へのリンクで構成されてい

ます。プロジェクトファイル(例えば xxx.PrjPCB)は、プロジェクトのドキュメントや関連する出力

設定(印刷や CAM など)を ASCII テキストファイルで表示したものです。プロジェクトに関連付けられ

ていないドキュメントを ‘フリードキュメント’ と呼びます。PCB、FPGA、埋め込みパッケージ

(VHDL)やライブラリパッケージなど、回路図シートや対象とするアウトプットへのリンクは、プロジ

ェクトに追加されます。プロジェクトをコンパイルすると、デザインを検証し、ファイル間の同期を

取り、比較を行うことができます。例えば、オリジナルの回路図や PCB などを変更すると、プロジェ

クトのコンパイル時に更新されます。 

プロジェクトの新規作成プロセスは、すべてのプロジェクトタイプで同じです。ここでは PCB プロジ

ェクトの例で説明します。まずプロジェクトファイルを作成し、次にブランクの回路図シートを作成
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して空のプロジェクトを新しく追加します。このチュートリアルの後半ではブランクの PCB を作成し、

同様にプロジェクトに追加します。 

チュートリアルを開始するため、次の操作を実行して PCB の新規プロジェクトを作成します。 

1. メニューから File » New » PCB Project を選択するか、Files パネルの New の項目で Blank 
Project (PCB)をクリックします。もし、このパネルが表示されない場合、Design Manager パネル

の下部にある Files タブをクリックします。 

あるいは、Tasks 画面(View »Tasks)の Pick a Task の項目で Printed Circuit Board Design を選

択し、New Blank PCB Project を選択します。 

2. Projects パネルが表示されます。パネルには新しいプロジェクトファイルである PCB 
Project1.PrjPCB が表示されますが、ドキュメントは追加されません。 

 

3. File » Save Project As を選択し、新しいプロジェクトファイルをリネームします(拡張子

は.PrjPCB)。プロジェクトを保存するハードディスク上のディレクトリに移動し、File Name フ

ィールドでファイル名 Multivibrator.PrjPCB を入力して Save をクリックします。 

次に、空のプロジェクトファイルに追加する回路図を作成します。ここでは、非安定マルチバイブ

レータの回路図を作成します。 

回路図シートの新規作成 

以下の手順で回路図シートを新規に作成します。 

1. File » New » Schematic を選択するか、Files パネルの New セクションで Schematic Sheet をク

リックします。デザインウィンドウに、Sheet1.SchDoc というブランクの回路図シートが表示

され、回路図ドキュメントは自動でプロジェクトに追加（リンク）されます。回路図シートは、

Projects タブ内でプロジェクト名の下の Source Documents フォルダ内にリストされます。 
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2. File » Save As を選択し、新しい回路図ファイルをリネームします(拡張子は.SchDoc )。回路図を保

存するハードディスク上のディレクトリに移動し、File Nameフィールドでファイル名

Multivibrator.SchDocを入力して Save をクリックします。 

ブランクの回路図シートがオープンすると、ワークスペースが回路図エディタに切り替わります。メ

インツールバーには新しいボタンが追加され、新しいツールバーが表示されてメニューバーに新しい

アイテムが加わります。これが回路図エディタです。 

このワークスペースをいろいろな形にカスタマイズすることができます。例えば、パネルやツールバ

ーの位置を変更したり、またはメニューやツールバーコマンドをカスタマイズすることができます。 

これでプロジェクトに新しい回路図を追加できました。次にデザインを取り込みます。 

プロジェクトへ回路図シートを追加 

プロジェクトに追加したい回路図シートがフリードキュメントとして開いている場合は、Projects パ
ネルでプロジェクト名を右クリックし、Add Existing to Project を選択します。フリードキュメント

名を選択し、Open をクリックします。あるいは、Projects パネルのプロジェクトドキュメントリス

トの中のフリードキュメントをドラッグアンドドロップします。回路図シートは、Projects タブでプ

ロジェクト名の下の Source Documents の下にリストされ、プロジェクトファイルにリンクされます。 

回路図オプションの設定 

回路図を作成する前に、使用するドキュメントオプションの設定を行います。以下の手順で設定しま

す。 

TU0117 (v1.0) January 22, 2004 5 



PCB デザイン入門 

6 

はドキュメン

ト(.dot) として

のタイトルブ

等の固有の

ことができま

DXP には、マルチレベル

のアンドゥ機能があり、何

度でも操作をやり直すこと

ができます。アンドゥの最
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できますが、使用するコン

ピュータの空き容量によっ
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1. メニューから Design » Document Options を選択すると、Document Options ダイアログが表示

されます。このチュートリアルでは A4 の大きさの図面を使用しますので、

Sheet Options タブの Standard Styles フィールドを A4 に設定します。

隣にある矢印をクリックすると、シートスタイルが表示されます。 

2. A4 を選択します。ダイアログを閉じてシートサイズを更新する為に OK ボ

タンをクリックします。 

3. ドキュメントを全体表示する為に View » Fit Document を選択します。  

DXP では、メニューホットキー(メニュー名の下線が引かれた文字)を押すとそ

のメニューが表示されます。また、いくつかのサブメニューにもキーが割り当

てられています。例えば、View » Fit Document を選択する為のショートカットはキーボードから V
キーを押し、続いて D キーを押します。多くの場合、Edit » DeSelect のようなサブメニューは直接

呼び出すことができます。例えば Edit » DeSelect » All on Current Document メニューを実行するに

は、X キーを押して DeSelect メニューを直接呼び出し、続いて A キーを押します。 

次に、回路図の環境設定を行います。 

1. Preferences ダイアログを開く為に、メニューから Tools »Schema
Preferences [ショートカット T, P]を選択します。このダイアログで

作業する回路図シートすべてに適用するグローバル環境を設定します

2. Default Primitives タブをクリックし、Permanent をチェックしま

定ができたら OK ボタンをクリックしダイアログを閉じます。 

3. 回路の作成を始める前に、File » Save [ショートカット F, S]を選択

この回路図シートを保存します。 

回路図の作成 

これで回路図を作成する準備ができました。このチュートリアルでは図

では、2 個の 2N3904 トランジスタを使用した自動起動型の非安定マル

ます。 

図 1. 非安定マルチバイブレータ 
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部品の取り出しとライブラリの登録 

DXP の回路図エディタには、数多く用意されている回路図シンボルを管理するための高度なライブラ

リ検索機能が装備されています。必要とするコンポーネントは、デフォルトで登録されているライブ

ラリ内にありますが、コンポーネントを見つける為にライブラリを検索する方法を知ることは重要で

す。以下の手順を実行し、このチュートリアルの回路を作成するた

めに必要なライブラリの登録を行います。 
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まずトランジスタを検索します。使用するトランジスタは両方とも

2N3904 です。 

1. Libraries タブをクリックすると、Libraries ワークスペースパ

ネルが表示されます。 

2. Libraries パネルで Search ボタンを押すか、または Tools » 
Find Component を選択します。Search Libraries ダイアログが

開きます。 

3. Scope が Libraries on Path に設定されていること、そして

Path フィールドには使用するライブラリへのパスが正しく入力

されていることを確認します。もし、DXP 2004 をインストー

ルする際にデフォルトディレクトリを指定した場合、ライブラ

リへのパスは、C:\Program 
Files\Altium2004\Library\となります。ライブラリフォ

ルダをブラウズする為にフォルダアイコンをクリックします。

ここでは Include Subdirectories ボックスにチェックが入って

いないことを確認します。 

4. 部品の名前に 3904 という文字がある部品をすべて検索してみま

す。まず Search Criteria セクションで Name のテキストフィー

ルドに *3904* と入力します(メーカーによって異なるプリフィ

ックスやサフィックスがつけられていることを考慮し、ワイル

ドカードのシンボル * を使用します)。 

5. Search ボタンをクリックして検索を開始します。検索が始まる

と Results タブが表示されます。正しく記入されていればライブラリファイルが検索され、

Search Libraries ダイアログに表示されます。 

6. Miscellaneous Devices.IntLib をクリックして選択します。このライブラリにはシミュレ

ーション用の BJT トランジスタが入っています。 

7. Install Library ボタンをクリックして、このライブラリを回路図エディタに登録します。但し、こ

のライブラリはデフォルトで既に登録されていますので、ボタンはグレイになっているはずです。 

8. Search Libraries ダイアログを閉じます。 

追加したライブラリは Libraries パネルの上部に表示されます。上部のリストボックスでライブラリ名

をクリックすると、下側のリストには、そのライブラリに含まれている部品の一覧が表示されます。

パネルの Filter を使うとライブラリ内の部品をすばやく見つけることができます。 

回路図にコンポーネントを配置 

最初に Q1 と Q2 の 2 つのトランジスタを配置します。配置する位置は図 1 を参考にしてください。 
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1. メニューから View » Fit Document [ショートカット V, D]を選択し、回路図シート全体を表示しま

す。 

2. ワークスペースパネルの Libraries タブをクリックすると、Libraries パネルが表示されます。 

3. Q1 と Q2 は BJT トランジスタです。このライブラリをアクティブにするため、Miscellaneous 
Devices.IntLib をクリックします。 

4. フィルタ機能を使用することにより、必要な部品をすばやく見つけ出すことができます。ワイルド

カード(*)を使用すると、ライブラリの部品がすべて表示されます。フィルタを設定するには、ライ

ブラリ名の下にあるフィルタフィールドに*3904*と入力します。Component Name フィールドの

一部に “3904” という文字がある部品のリストが表示されます。 

5. リストから 2N3904 をクリックし、Place ボタンをクリックします。または、部品名をダブルクリ

ックします。 

カーソルが十字型に変化し、トランジスタの輪郭がカーソル上に現れます。この状態が部品配置モ

ードです。カーソルを動かすと、トランジスタの輪郭がそれに応じて移動します。 

6. 図面上に部品を配置する前に、最初にその属性を編集します。トランジスタがカーソルと一緒に移

動している間に、TAB キーを押します。部品の Component Properties ダイアログが表示されます。

以下のようなダイアログオプションを設定します。 

 
回路図の部品と PCB の部

品との関連付けは、フッ

トプリントにより行われ

ます。回路図で指定した

フットプリントは、ネッ

トリストを読み込む際、

PCB ライブラリから読み

込まれます。フットプリ

ントを設定するには、回

路図上の部品をダブルク

リックしてください。 

7. ダイアログの Properties セクションで、Designator フィールドに Q1 と入力し

て最初の部品番号を設定します。 

8. 次に、PCB の部品を表すフットプリントを確認します。このチュートリアルで

は、フットプリントや回路シミュレーションの推奨モデルが含まれている統合

ライブラリを使用します。Models リストに BCY-W3/D4.7（訳注：実際の名称

は BCY-W3/E4 です。）という型番が表示されていることを確認します。その
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他のフィールドは、すべてデフォルト値のままにしておきます。OK をクリックしダイアログを閉

じます。 

これで部品を配置する準備が完了しました。 

1. カーソルをシートの中央から少し左に(トランジスタも一緒に)、移動します。 

2. 位置が決まったら、左クリックするかまたは ENTER キーを押し

図にトランジスタを配置します。 

TU0117 (v1.0) January 22, 2004 
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 » Fit Al
し、配置さ
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ます。オブ
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ことができ

3. カーソルを移動すると、先に配置されたのと同じトランジスタが

す。部品配置モードの状態が継続されているため、同じ部品を連

配置することができます。それでは 2 個目のトランジスタを配置

ださい。このトランジスタは先に配置したトランジスタと同じで

属性を設定する必要はありません。DXP で同じ部品を続けて配置

場合、部品番号が自動的にインクリメントされます。この場合、

ランジスタは Q2 になります。 

l 

4. 図 1 を見ると、Q2 のトランジスタは Q1 のトランジスタと逆向き

置されていることがわかります。トランジスタの向きを変えるに

ーソルでトランジスタを移動しているときに X キーを押します。

により水平方向に向きが変わります。 

5. カーソルを Q1 の右側に移動してください。部品を配置する位置を正確に指定したい場合には、

PAGEUP キーを押して図面を拡大してください。図面を拡大すると、グリッドが表示されます。 

るときには、

す: 

品の向きが

。 

品の向きが

。 

すと 90°ず

6. 部品を配置する位置が決まったらマウスを左クリック、または ENTER キーを押します。Q2 のト

ランジスタが配置されます。引き続き配置モードになり、カーソル

緒にトランジスタが表示されます。 

7. これですべてのトランジスタの配置が完了したので、マウスを右ク

クするか、または ESC キーを押して部品の配置を終了します。カ

ルが通常の矢印に戻ります。 

次に抵抗を 4 個配置します。 

1. Libraries パネルで、Miscellaneous Devices.IntLib ライブ

がアクティブになっていることを確認します。 

2. ライブラリ名の下にあるフィルタフィールドに res1 と入力してフ

タを設定します。 

3. 部品リストで RES1 をクリックし、Place ボタンをクリックします

れによりカーソルの上に抵抗が表示されます。 

4. TAB キーを押して、抵抗の属性を設定します。ダイアログの

Properties セクションで、Designator フィールドに R1 と入力し

の部品番号を設定します。 

5. Models リストに AXIAL-0.3 と表示されていることを確認します

6. 抵抗のパラメーターフィールドを設定し、回路図に表示します。こ

回路シミュレーションを実行する際に使用します。=Value パラメ

般的な情報として使用する事が可能ですが、ディスクリート部品で

値を使用します。また、PCB エディタでコメント情報として割り

する事も可能です。DXP では、Comment フィールドの内容をパラ
図面上に配置さ

性を変更するには

ブルクリックし、C
Properties ダイア

ます。 

ィル

。こ
て回路
編集モードや部品の

（カーソルが十字にな

き）では、カーソルが

のウィンドウの端に

が自動的にスクロー

クロールし過ぎた

ボードを V, F (View
Objects) と続けて押

れているオブジェクト

示されているようにし

ジェクトの配置中でも

する操作を実行する

ます。 

ス

現れま

続して

してく

すので、

する

次のト

に配

は、カ

これ
部品を移動してい

次の操作ができま

Y キーを押すと部

上下逆になります

X キーを押すと部

左右逆になります

スペース キーを押

つ回転します。 

と一

リッ

ーソ

ラリ
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て最初

。 

の値はチュートリアルの後半で

ーターは、コンポーネントの一

はシミュレーションの際にこの

当てられている Comment を設定

メーターで置き換える、間接的
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な参照をサポートしており、同じ値を二回設定する（パラメーター=Value と Comment フィール

ド）必要はありません。 

もし、コンポーネント属性に Value パラメーターが存在しない場合は、Parameters リストで Add 
をクリックして Parameter Properties ダイアログを表示させます。Value という名称を入力し、

値を 100k とします。パラメーターのタイプとして String が選択され、Value の Visible にチェッ

クが入っている事を確認します。OK をクリックします。 

この RES1 のコンポーネントは、既に Value パラメーターが設定されているので、Value フィール

ドに 100k と入力します。 

7. ダイアログの Properties セクションで Comment フィ－ルドをクリックし、ドロップダウンリス

トから =Value を選び、Visible のチェックをはずします。OK ボタンをクリックし、ダイアログを

閉じ、部品配置モ－ドに戻ります。 

8. 抵抗を 90°回転するには SPACEBAR を押します。 

9. 図 1 のように抵抗を Q1 のベース側へ配置します。マウスを左クリックするか、または ENTER キ

ーを押すことで部品が配置されます。 

この時点では、トランジスタと抵抗の接続について考える必要はありません。部品間の接続は後で

行います。 

10. 次に 100k の抵抗 R2 を Q2 のベース側へ配置します。2 つ目の抵抗を配置すると、部品番号が自動

的にインクリメントされます。 

11. 残りの R3 と R4 の 2 つの抵抗は値が 1k ですので、TAB キーを押して Component Properties ダイ

アログを表示し、Value の値を 1k に変更します。OK をクリックしてダイアログを閉じます。 

12. 図 1 の回路図を参考にして R3 と R4 を配置します。 

13. 抵抗をすべて配置したら、右クリックするかまたは ESC キーを押して部品配置モードを終了しま

す。 

次にコンデンサを 2 個配置します。 
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1. コンデンサも、既に Libraries パネルで選択されている Miscellaneous 
Devices.IntLib にあります。 オブジェクトを移動するに

は、カーソルをオブジェクト

上に移動し、マウスの左ボ

タンを押さえたままカーソル

を移動します。そしてマウス

の左ボタンを放すとその位

置に部品が置かれます。 

2. Libraries パネルの部品のフィルタフィールドで cap と入力します。 

3. 部品リストから CAP をクリックし、Place ボタンをクリックします。これ

によりカーソルの上にコンデンサが表示されます。 

4. TAB キーを押して、コンデンサの属性を設定します。Component 
Properties ダイアログの Properties セクションで Designator を C1 に設

定し、PCB フットプリントモデル RAD-0.3 が Models リストに追加されていることを確認します。  

5. Value パラメーターの Value フィールドを 20n に変更します。パラメータータイプとして String 
が選択されていて、Value の Visible ボックスにチェックが入っていることを確認します。OK を

クリックします。 

6. ダイアログの Properties セクションでコメントフィ－ルドをクリックし、ドロップダウンリスト

から =Value を選択し、Visible のチェックをはずします。OK ボタンをクリックし、部品配置モ－

ドに戻ります。 

7. 2 つのコンデンサも抵抗と同じ方法で位置を決めて配置します。 

8. 右クリックするか、または ESC キーを押して配置モードを終了します。 
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最後にコネクタを配置します。コネクタは Miscellaneous Connectors.IntLib にあります。 

1. Libraries パネルのライブラリリストから Miscellaneous Connectors.IntLib を選びます。

配置するのは 2 ピンのコネクタですので、フィルタを *2* に設定します。 

2. パネルのリストから HEADER2 をマウスで選択し、Place ボタンをクリックします。TAB キーを

押して属性を編集します。Designator を Y1 に設定し、PCB フットプリントモデルが HDR1X2 に

設定されていることを確認します。回路シミュレーションを実行する時、Value パラメーターが無

いコンポーネントは、電源ソースに置き換える必要があります。OK ボタンをクリックしてダイア

ログを閉じます。 

3. コネクタを配置する前に、X キーを押してコネクタを正しい向きに修正します。クリックして回路

図にコネクタを配置します。 

4. 右クリックするか、または ESC キーを押して配置モードを終了します。 

5. メニューから File » Save[ショートカット F, S]を選択し、回路図を保存します。 

これですべての部品の配置が完了しました。図 2 に示すように、部品間には配線を行うためのスペー

スが必要です。これはピンの下を横切って、その向こうにあるピンにワイヤを接続することができな

いためです。そのように接続すると、どちらのピンもワイヤに接続されてしまいます。 

コンポーネントを移動する場合は、部品をクリックし、マウスを押さえ続けたままカーソルを移動し

ます。 
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配置されたワイヤの形状や他のオ

ブジェクトを変更するには、カーソ

ルをワイヤやオブジェクトの上に

移動し、マウスをクリックします。 

。 

ワイヤが部品の接続点を横切った

り、ワイヤ同士を接続した場合に

は、自動的にジャンクションが配置

されます。 

ワイヤの配置中には以下の操作

が可能です: 

- マウスを左クリックまたは

ENTER キーを押すと、カーソルの

位置でワイヤが確定されます; 

- BACKSPACE を押すとワイヤの

最後の頂点が削除されます; 

-最後のワイヤを配置したら、右ク

リックするか、または ESC キーを

押してワイヤ配置を終了します。カ

ーソルが十字のままであれば、引

き続き他のワイヤを配置すること

ができます。 

- もう一度右クリックするか、また

は ESC キーを押すとワイヤ配置

モードを終了します

図 2. 全部品が配置された回路図 

回路の接続 

回路の接続は、さまざまなコンポーネント間の接続を構築する為の過程です。

部品間の接続を行うには、図 1 を参照して以下の手順を行ってください。 

1. 回路図シートの画面表示を編集し易い画面にする為に、PAGE UP キー

（拡大）または、PAGE DOWN キー（縮小）で調整します。Ctrl キーを

押したままマウスホイールを使用しても拡大、縮小することができます。 

2. 最初に、次の方法でトランジスタ Q1 のベースに抵抗 R1 を接続します。

ワイヤを配置する為に、メニューから Place » Wire [ショートカット P, 
W]を選択するか、Wiring ツールバーから Wire ツールをクリックします。

カーソルが十字に変わります。 

3.カーソルを R1 の下端に移動します。カーソルを適切な位置に移動すると、
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赤い接続マーカー(大きなアスタリスク)が現れます。これは、カーソルが部品の電気的な接続点に

あることを示しています。 
赤い接続マーカー(大きなアスタリスク)が現れます。これは、カーソルが部品の電気的な接続点に

あることを示しています。 

4. ワイヤを開始する点で左クリックするか、または ENTER キーを押します。カーソルを移動すると

最初にクリックした点から、現在のカーソル位置へワイヤが引かれるのが確認できます。 
4. ワイヤを開始する点で左クリックするか、または ENTER キーを押します。カーソルを移動すると

最初にクリックした点から、現在のカーソル位置へワイヤが引かれるのが確認できます。 

5. カーソルを R1 下のトランジスタ Q1 のベースまで垂直に移動します。左クリックするか ENTER
キーを押すと、クリックした位置でワイヤが確定されます。最初にクリックした位置とこの位置の

間にワイヤが配置されます。 

5. カーソルを R1 下のトランジスタ Q1 のベースまで垂直に移動します。左クリックするか ENTER
キーを押すと、クリックした位置でワイヤが確定されます。最初にクリックした位置とこの位置の

間にワイヤが配置されます。 

6. カーソルが赤い接続マーカーに変わる位置で Q1 のベースにカーソルを配置します。左クリックす

るか ENTER キーを押すと、Q1 のベースにワイヤが接続されます。 
6. カーソルが赤い接続マーカーに変わる位置で Q1 のベースにカーソルを配置します。左クリックす

るか ENTER キーを押すと、Q1 のベースにワイヤが接続されます。 

7. カーソルが十字になったままであることに注意して下さい。これは、ワイヤの配置モードであるこ

とを表します。もう一度右クリックするか ESC キーを押すと配置モードが終了してカーソルの形

状が矢印に戻りますが、今はこのままにしておきます。 

7. カーソルが十字になったままであることに注意して下さい。これは、ワイヤの配置モードであるこ

とを表します。もう一度右クリックするか ESC キーを押すと配置モードが終了してカーソルの形

状が矢印に戻りますが、今はこのままにしておきます。 

8. 次に C1 を Q1 と R1 に配線します。カーソルを C1 の左の接続点に移動して左クリックするか、ま

たは ENTER キーを押すと、新たに配線が開始されます。 
8. 次に C1 を Q1 と R1 に配線します。カーソルを C1 の左の接続点に移動して左クリックするか、ま

たは ENTER キーを押すと、新たに配線が開始されます。 

9. Q1 のベースと R1 が接続されているワイヤ上まで水平にカーソルを移動します。接続マーカーが

表示されます。 
9. Q1 のベースと R1 が接続されているワイヤ上まで水平にカーソルを移動します。接続マーカーが

表示されます。 

10. 左クリックするか ENTER キーを押してワイヤを配置し、次に右クリックするか ESC キーを押し

て配線を終了します。2 本のワイヤが自動的に接続されます。 
10. 左クリックするか ENTER キーを押してワイヤを配置し、次に右クリックするか ESC キーを押し

て配線を終了します。2 本のワイヤが自動的に接続されます。 

11. 残りの回路を接続すると、結果は図 3 のようになります。 11. 残りの回路を接続すると、結果は図 3 のようになります。 
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ワイヤがピンの終端と交差してい

る場合は、ジャンクションを削除

しても接続されます。先に進む前

に回路図が図 3 のように作成さ

れているか確認してください。  

図 3. 配線が完了した回路図 

12. 配線がすべて完了したら、右クリックするか ESC キーを押して配線モードを終了します。カーソ

ルが通常の矢印に戻ります。 

ネットとネットラベル 

接続されるそれぞれの部品ピンの集まりをネットといいます。例えば、あるネットには Q1 のベース、

R1 のピン、C1 のピンが含まれます。 

デザイン中の重要なネットを簡単に識別するためにネットラベル を追加できます。2 個の電源ネット

にネットラベルを配置するには、次の操作を実行します: 

1. Place » Net Label [ショートカット P, N]を選択します。カーソル上に点線の箱が表示されます。 
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2. 配置する前にネットラベルを編集するため、TAB キーを押して Net Label ダイアログを表示させま

す。 

3. Net フィールドに 12V と入力し、OK ボタンをクリックしてダイアログを閉じます。 

4. ネットラベルの左下がワイヤと接触するように配置します。ネットラベルがワイヤに接触すると、

カーソルは赤い十字に変わります。もし、十字マークが薄いグレイ表示ならば、それはピンに配置

しようとしていることを表します。 

5. 最初のネットラベルを配置した後も、ネットラベルの配置モードが継続されます。2 つめのネット

ラベルを配置する前に編集するため、再度 TAB キーを押します。 

6. Net フィールドに GND と入力します。OK ボタンをクリックして、ダイアログを閉じてネットラベ

ルを配置します。右クリックまたは ESC キーを押してネットラベル配置モードを終了します。 

7.File » Save [ショートカット F, S]を選択して回路を保存します。プロジェクトも同様に保存します。 

これで回路図が完成しました。 

この回路図をプリント基板にする前に、プロジェクトオプションを設定します。 

プロジェクトオプションの設定 

プロジェクトオプションには、エラーチェック用のパラメーター、接続マトリックス、Comparator 設
定、ECO 生成、出力パス、ネットリストオプション、プロジェクトパラメーターの設定があります。

DXP では、こうした設定を使用してプロジェクトをコンパイルします。 

プロジェクトがコンパイルされると、全体的なデザインや電気的なルールに基づいてデザインが検証

されます。エラーの修正が終わると、回路図が再コンパイルされ、生成された ECO によって PCB ド

キュメントなどの対象とするドキュメントに読み込まれます。プロジェクトの Comparator によりソ

ースファイルとターゲットファイルの相違点を見つけ、双方向で更新する(ファイルの同期を取る)こと

ができます。 

エラーチェック、ドキュメント比較、ECO 作成など、プロジェクトに関連する操作はすべて Options 
for Project ダイアログ(Project » Project Options )で設定します。 

組立と製造出力、レポートなどのプロジェクト出力は File メニューオプションから設定することがで

きます。Job Options ファイル(File » New » Output Job File)でジョブオプションを設定することもで

きます。詳細は、Project Outputs の設定 を参照して下さい。 

1. Project » Project Options を選択します。Options for Project ダイアログが表示されます。 
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プロジェクトに関連するオプションは、このダイアログで設定します。 

回路図の電気属性のチェック 

DXP の回路図エディタは単なる図面作成ツールではありません。これには回路の電気的接続情報も含

まれており、この機能を利用して設計した図面を検証することができます。プロジェクトをコンパイ

ルする際、Error Reporting タブと Connection Matrix タブで設定したルールに従ってエラーがチェック

され、違反があった場合は Messages パネルに表示されます。 

Error Reporting の設定 
Options for Project ダイアログの Error Reporting タブで、作画上のチェック項目を設定します。

Report Mode は違反の程度を示します。Report Mode を変更するには、変更する違反項目の隣にある

Report Mode をクリックし、ドロップダウンリストで程度を選択します。このチュートリアルでは、

デフォルトの設定を使用します。 

Connection Matrix の設定 
デザイン内の電気的接続(ピン、ポート、シートエントリ間の接続)をチェックすると、Connection 
Matrix タブ(Options for Project ダイアログ)で設定したエラーの程度でエラーレポートが作成されます。

マトリックスでは、回路図に使用されている様々なピンの種類の接続状態をチェックすることができ

ます。 

例えば、マトリックスの右側に Output Pin があります。この列と Open Collector Pin とが交差する

位置に注目してください。交差する場所がオレンジ色で表示されています。これは、出力ピンがオー

プンコレクタピンと接続されていた場合に、プロジェクトのコンパイル時にエラーが発生することを

示しています。 

エラータイプは、報告しないものから致命的エラーまで、エラーの程度によって設定できます。全体

のマトリクスをコントロールするメニューオプションを表示する為に、右クリックします。 

Connection Matrix を変更するには、次の操作を実行します: 
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1. Options for Project ダイアログで Connection 
Matrix タブをクリックします。 

2. 2 つの接続タイプ、例えば Output Sheet Entry
と Open Collector Pin が交差する場所をクリッ

クします。 

3. 交差するボックスの色が凡例で示したエラーの

色に変わるまでクリックします。例えば、オレ

ンジ色はその接続によってエラーが発生するこ

とを表します。 

このチュートリアルで作成した回路には、Passive 
Pins のみが使用されています。この接続マトリッ

クスで、未接続のパッシブピンを見つけられるか

チェックしてください。 

1. マトリックスの縦の列から Passive Pin を見つ

けてください。次に横の列から Unconnected
を見つけてください。両方の列が交差する所に

は、パッシブピンが未接続の場合のエラー状態

が示されます。デフォルトでは緑色なので、エ

ラーレポートは作成されません。 

2. 次にこのボックスを黄色になるまでクリックし、パッシブピンが未接続だとプロジェクトをコンパ

イルした場合にワーニングを報告するようにします。ここでは、このチュートリアルの後半でチェ

ックするために、意図的にエラーが出るようにします。 

Comparator の設定 
Options for Project ダイアログの Comparator タブでは、プロジェクトのコンパイル時にファイル間の

相違点を報告するか、しないかを設定します。このチュートリアルでは、ルームのような階層的な回

路設計のみに基づく機能面での違いを表示する必要はありません。コンポーネントクラスについても

同様です。 

1. Comparator タブをクリックし、Difference Associated with Components セクションで Changed 
Room Definitions, Extra Room Definitions, Extra Component Classes を見つけます。 

2. これらのオプションの右側にある Mode 欄のドロップダウンリストから Ignore Differences を選

択します。 
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これでプロジェクトをコンパイルしてエラーをチェックする準備ができました。 

プロジェクトのコンパイル 

プロジェクトをコンパイルすると、デザインドキュメントの作画上のエラーや電気的ルールのエラー

をチェックして、デバッグを行えるようになります。このチュートリアルでは、既に Options for 
Project ダイアログの Error Reporting タブと Connection Matrix タブでルールを設定しています。 

1.Multivibrator プロジェクトをコンパイルするには、Project » Compile PCB Project を選択します。 

2. プロジェクトのコンパイル時に発生したエラーは、Messages パネルに表示されます。エラーをチ

ェックする為に、このパネルをクリックします。コンパイルしたドキュメントは、フラット階層

（コンポーネントやネットがリスト表示され、接続モデルをブラウズできます）で Navigator パ
ネルにリスト表示されます。 

正しく回路図が作成された場合、Messages パネルはブランクになります。エラーメッセージが表示

された場合は回路をチェックし、すべてのワイヤと結線が正しいか確認してください。 

それでは故意にエラーが発生するように回路図を変更した後、プロジェクトを再コンパイルしてみま

しょう: 

1. デザインウィンドウ上部にある Multivibrator.SchDoc タブをクリックし、回路図をアクティ

ブドキュメントにします。 

2. R1 とトランジスタ Q1 のベースを接続しているワイヤをクリックします。小さな四角の編集ハン

ドルがワイヤの両端に表示され、ワイヤに沿って選択状態を示す点線が Selection の色で表示され

ます。ワイヤを削除するには DELETE キーを押します。 
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3. プロジェクトを再コンパイル(Project » Compile PCB Project)し、エラーメッセージがないか確

認します。 

Messages パネルが開き、回路に未接続のピンがあるというワーニングメッセージが表示されます。 

4. Messages パネルのエラーやワーニングをダブルクリックすると、Compile Error ウィンドウに違

反の詳細が表示されます。このウィンドウでエラーをクリックすると違反しているオブジェクトが

回路図に表示され、エラーのチェックや修正ができます。 

では、このセクションを終了する前にエラーを修正してください。 
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1. 回路図シートのタブをクリックし、アクティブにします。 Messages パネルのメッセ

ージをクリアするには、ウ

ィンドウを右クリックして

Clear All を選択します。

2. メニューから Edit » Undo [ショートカット Ctrl+Z]を選択します。削除し

たワイヤが復元されます。  

3. アンドゥを実行してワイヤが復元されたら、プロジェクトを再コンパイル

（Project » Compile PCB Project）し、エラーが表示されないことを確認

します。Messages パネルにはエラーメッセージが表示されないはずです。 

4. メニューから View » Fit All Objects [ショートカット V, F]を選択して回路図画面を復元し、エラ

ーのない回路図を保存します。 

5. 回路図とプロジェクトファイルを保存します。 

回路図が完成し、チェックも終了しました。次に、PCB を作成します。 
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PCB ドキュメントの新規作成 
回路図エディタから PCB エディタへデザイン情報を転送する前に、基板外形のみが含まれているブラ

ンクの PCB ファイルを作成する必要があります。 DXP で新規の PCB ファイルを容易に作成するには、

PCB ウィザードを使用する方法があります。ウィザードでは標準規格の基板外形がサポートされてお

り、カスタムサイズの基板も作成可能です。ウィザードでは、いつでも Back ボタンを押して前の画

面に戻り、内容の確認や修正ができます。 

PCB ウィザードで新規 PCB を作成するには、次の手順を実行します: 

1. Files パネル下部の New from Template セクションで

PCB Board Wizard をクリックして、PCB を新規に作

成します。画面にこのオプションが表示されない場合

は、上向き矢印をクリックしていくつかのセクション

を閉じます。 

2. PCB Board Wizard が開きます。まず

イントロダクション画面が表示されま

す。Next ボタンをクリックして次に

進みます。 

3. 単位系を Imperial に設定します。

1000 mils が 1 インチです。 

4. 次の画面では使用する基板外形を選択

します。このチュートリアルでは、独

自の基板サイズを設定することにしま

す。基板外形のリストから Custom を選択

して Next ボタンをクリックします。 

5. 次の画面では、カスタムボードオプションを入力しま

す。このチュートリアルの回路には、2x2 インチのボ

ードであれば充分なスペースが確保できます。

Rectangular を選択して Width フィールドと Height 
フィールドに 2000 と入力します。Title Block & 
Scale、Legend String、Dimension Lines は選択解除します。Next ボタンをクリックして次に進

みます。 

6. この画面ではボードのレイヤ数を指定します。ここではシグナルレイヤが 2 つ必要ですが、パワー

プレーンは必要ありません。Next ボタンをクリックして次に進みます。 

7. Thru-hole vias only を選択してデザインで使用するビアスタイルを指定し、Next ボタンをクリッ

クします。 

8. 次の画面では、部品およびトラックテクノロジ(配線)のオプションを設定します。Thru-hole 
components オプションを選択し、Number of tracks between adjacent pads を One Track に設定

します。Next ボタンをクリックして次に進みます。 

9. 次の画面では、Track/Via サイズなどのボードに適用するデザインルールを設定します。この画面

のオプションはデフォルトのままにしておきます。Next ボタンをクリックして次に進みます。 

10. Finish ボタンをクリックしてウィザードを閉じます。 
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11. PCB ウィザードにより、ボードを新規作成するために必要な情報がすべて揃いました。PCB エデ

ィタに新しい PCB ファイル PCB1.PcbDoc が表示されます。 
11. PCB ウィザードにより、ボードを新規作成するために必要な情報がすべて揃いました。PCB エデ

ィタに新しい PCB ファイル PCB1.PcbDoc が表示されます。 

 

12. PCB ドキュメントには、デフォルトサイズの白いシートとブランクのボードシェイプ(黒い領域と

グリッド)が表示されます。シートを非表示にするには、Design » Board Options を選択し、

Board Options ダイアログの Display Sheet を選択解除します。 
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13. シートを非表示にし、View » Fit Board [ショートカット V, F ]を選択

ボードシェイプのみを表示します。 

14. PCB ドキュメントは、自動的にプロジェクトに追加（リンク）され

Projects タブ内のプロジェクト名下側の Source Documents の下に

表示されます。 

15. File » Save As を選択して、新しい PCB ファイルをリネームします
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新しい PCB をプロジェクトに追加 新しい PCB をプロジェクトに追加 
プロジェクトに加えたい PCB が Free Document として開いている場合、Projects パネルの内の PCB
プロジェクトファイル上で右クリックし、Add Existing to Project を選択します。新しい PCB ファ

イル名を選択し、開くをクリックします。Projects タブにあるプロジェクト名の下の Source 
Documents のフォルダの下に PCB ドキュメントが追加され、プロジェクトファイルにリンクされま

す。プロジェクトファイルを保存します。 

プロジェクトに加えたい PCB が Free Document として開いている場合、Projects パネルの内の PCB
プロジェクトファイル上で右クリックし、Add Existing to Project を選択します。新しい PCB ファ

イル名を選択し、開くをクリックします。Projects タブにあるプロジェクト名の下の Source 
Documents のフォルダの下に PCB ドキュメントが追加され、プロジェクトファイルにリンクされま

す。プロジェクトファイルを保存します。 

デザイン情報の転送 デザイン情報の転送 

ブランクの新しい PCB に回路情報を転送する前に、すべてのライブラリが回路図と PCB の両方で使

用できることを確認します。このチュートリアルではデフォルトの統合ライブラリだけを使用してい

るため、あらかじめフットプリントも含まれています。プロジェクトをコンパイルして回路図のエラ

ーを修正したら、Update PCB コマンドを使用して ECO を生成し、対象とする PCB に回路情報を転

送します。 

PCB の更新 
プロジェクトで対象とする PCB に回路情報を送るには、次の操作を実行します: 

1. Multivibrator.SchDoc の回路図ドキュメントを開きます。 

2. Design » Update PCB Document (Multivibrator.PcbDoc)を選択します。プロジェクトがコ

ンパイルされ、Engineering Change Order ダイアログが表示されます。 

 

3. Validate Changes をクリックします。変更がすべて確認されると、

チェックマークが Status リストに表示されます。変更内容が確認され

れば、ダイアログを閉じて Messages パネルをチェックし、エラーを

アにします。 

nges ボタン

と、ECO の

成して印刷で

20 
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4. Execute Changes をクリックすると、変更内容が PCB に送られます。完了すると、Status が

Done に変わります。 
4. Execute Changes をクリックすると、変更内容が PCB に送られます。完了すると、Status が

Done に変わります。 

5. Close をクリックすると対象とする PCB が開き、図 4 に示すように部品をボードに配置できる状

態になります。コンポーネンが表示されない場合は、ショートカットキーV, D（View Document）
を使ってください。 

5. Close をクリックすると対象とする PCB が開き、図 4 に示すように部品をボードに配置できる状

態になります。コンポーネンが表示されない場合は、ショートカットキーV, D（View Document）
を使ってください。 

 
図 4. ボードの横に並べられた配置前の部品 

PCB の設計 
PCB に部品を配置し、ボードに配線を行います。 

PCB ワークスペースの設定 
ボードの部品配置を始める前に、グリッド、レイヤ、デザインルールなどの PCB ワークスペースの設

定を行う必要があります。 

グリッド 
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部品配置を始める前に、配置グリッドが正しく設定されていることを確認します。 PCB ワークスペー

スにあるすべてのオブジェクトは、スナップグリッド上に配置が行われます。このグリッドは配線条

件に合うように設定する必要があります。 

このチュートリアルの回路では、パッド最小間隔が 100 mil の標準的な

系の部品を使用します。この部品のパッド間隔をグリッドに合せるため

スナップグリッドを 50、25 mil のように 100 mil の分数で設定してくだ

この PCB では、トラック幅とクリアランスをそれぞれ 12 mil と 13 mil 
ボードウィザードのデフォルト値)に設定することにより、平行なトラッ

センター間が 25 mil になります。以上のことから、ここでもっとも適

25 mil になります。 

次の手順に従い、スナップグリッドを設定してください:  

1.Design » Board Options [ショートカット D, O]を選択し、Board O

2. ドロップダウンリストを使用して、Snap X、Snap Y 、Componen
25mil に設定するか、値を直接、入力します。このダイアログでは

設定も行えます。エレクトリカルグリッドは、電気的なオブジェクト

グリッドに関係なく電気的なオブジェクトに引き込む機能です。OK
ログを閉じます。 

部品の配置をより容易に行うために、他のいくつかの設定を行います。
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1. メニューから Tools » Preferences [ショートカット T, P]を選択し、Preferences ダイアログを開

きます。Options タブの Editing Options セクションで、Snap to Center のオプションにチェック

が入っていることを確認します。これで部品をつかんだとき、カーソルが部品の基準点に移ります。 

2. Preferences ダイアログの Display タブをクリックしてアクティブにします。このタブの Show セ

クションで、Show Pad Nets、Show Pad Numbers、Via Nets オプションのチェックをはずしま

す。このダイアログの Draft Thresholds セクションで、Strings の値を 4 ピクセルに設定し、OK
をクリックしてダイアログを閉じます。 

レイヤスタックとその他の非電気的なレイヤの設定 

PCB ワークスペースの下部には、レイヤタブがいくつか表示されています。PCB エディタでは複数の

レイヤを扱いますが、ほとんどの編集作業は特定のレイヤに対して操作を行うことになります。

Design » Board Layers & Colors [ショートカット L]を選択すると Board Layers & Colors ダイアログ

が表示されます。このダイアログでは、レイヤの表示、追加、削除、リネーム、および色の設定を行

うことができます。 

 
PCB エディタには、次の 3 種類のレイヤがあります: 

電気的なレイヤ – 電気的なレイヤには、32 のシグナルレイヤと 16 のプレーンレイヤがあります。

電気的なレイヤは、Layer Stack Manager により追加や削除が行えます。このダイアログは、

Design » Layer Stack Manager を選択すると表示されます。 

• 

• メカニカルレイヤ – 基板外形の定義や寸法線、組立の詳細、その他の機構的な情報等に使用され

るメカニカルレイヤは、16 層用意されています。これらのレイヤはプリントアウトやガーバー出

力に加えることができます。メカニカルレイヤの追加、削除、名前の設定は、Board Layers & 
Colors ダイアログで行います。 
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• 特別なレイヤ – 特別なレイヤとしては、トップとボトムシルクスクリーンレイヤ、ソルダーマス

クレイヤ、ペイストマスクレイヤ、ドリルレイヤ、キープアウトレイヤ(電気的な領域を示すため

に使用されます)、マルチレイヤ(マルチレイヤのパッドとビアに使用されます)、接続レイヤ、

DRC エラーレイヤ、グリッドレイヤ、ホールレイヤがあります。これらの特別なレイヤの表示設

定は、Board Layers & Colors ダイアログで行います。 

レイヤスタックマネージャー 

このチュートリアルのデザインは簡単なので、片面基板か両面基板で配線することができます。デザ

インが複雑になれば、Layer Stack Manager でレイヤを追加します。 

1. Design » Layer Stack Manager [ショートカット D, K]を選択し、Layer Stack Manager ダイアロ

グを表示します。 

 

2. 新たにレイヤ、およびプレーンレイヤを追加する場合、新しいレイヤは現在選択されているレイヤ

の下に加えられます。Copper thickness や Dielectric properties 等のレイヤープロパティは、伝送

線路解析に使用されます。OK をクリックしてダイアログを閉じます。 

この新しいボードで使用しないレイヤが表示されている場合には、不必要なレイヤを非表示にしてく

ださい。レイヤを非表示にするには、以下の手順を実行します: 

1. ショートカットキーL キーを押して Board Layers & Colors ダイアログを表示します。 

2. Used On をクリックすると、オブジェクトが配置されていないレイヤのチェックが外れます。 

3. 4 つの Mask レイヤと Drill Drawing レイヤは、それぞれのレイヤ名の隣にある Show ボタンのチ

ェックをはずすと非表示になります。OK ボタンをクリックしてダイアログを閉じます。 

新しいデザインルールの設定 

DXP の PCB エディタは、ルールドリブン設計環境です。この設計環境では、PCB エディタでトラッ

クの配置、部品の移動、自動配線の実行などを行ってデザインを変更した場合、PCB エディタはそれ

ぞれの操作をモニターし、デザインルールが守られているかどうかをチェックします。そしてルール

が守られていない場合には、その箇所を違反としてハイライト表示します。 

ではデザインルールを設定したあと次の作業に進み、どのようにデザインエラーが表示されるか確認

してみましょう。 
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デザインルールには 10 のカテゴリがあり、さらにデザインルール・タイプに細かく分類されています。

デザインルールは、電気的(Electrical)、配線(Routing)、製造(Manufacturing)、配置(Placement)、伝送

線路解析(Signal Integrity)をカバーしています。 

それでは、電源のネットに関する線幅を指定するデザインルールを設定してみます。 

これらのルールを設定するには、以下の手順を実行して下さい: 

1. PCB をアクティブなドキュメントにして、メニューから Design » Rules を選択します。 

2. PCB Rules and Constraints Editor ダイアログが表示されます。ダイアログの左側にある Design 
Rules パネルに、ルールの各カテゴリが表示されます。Routing をダブルクリックするとカテゴリ

が展開され、配線ルールが表示されます。次に Width をダブルクリックすると、利用可能な線幅

ルールが表示されます。 

 

3. Design Rules パネルの各ルールをクリックします。各ルールをクリックすると、ダイアログの右

上セクションにはルールのスコープ(ルールの対象とするもの)が、右下セクションにはルールの内

容が表示されます。これらのルールには、デフォルトのものと、PCB ドキュメントを新規作成し

たときに Board Wizard で設定したものとがあります。 

4. Width をクリックすると、このルールのスコープと内容が表示されます。このルールはボード全体

に適用されます。 
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DXP の強力な機能の 1 つであるデザインルール・システムは、同じタイプのルールをそれぞれ異なる

オブジェクトに対して、複数設定することができます。ルールの対象となるオブジェクトの集まりは、

ルールのスコープで指定します。ルールシステムでは、あらかじめ定義された階層に基いて各オブジ

ェクトに対してルールが与えられます。 

例えば、Width constraint ルールが Whole board(すべてのトラックがこの幅であることを意味します)
で、2 つめの Width constraint ルールがグランドネットの場合、このルールは前のルールを無視します。

さらに 3 番目がグランドネットの特定のセグメントに関するものであれば、このルールは前の 2 つの

ルールを無視します。ルールは優先順に表示されます。 

現在、Width constraint ルールは 1 つしか設定されておらず、これが Whole board（基板全体）(width 
= 12 mil)に適用されています。次に、12V ネットと GND ネット(width = 25 mil)の新しい Width 
constraint ルールを追加します。Width constraint ルールを新たに追加するには、以下の手順を実行し

て下さい: 

1. Design Rules パネルで Width カテゴリを選択し、右クリックして New Rule を選択し、12V ネッ

トだけを対象に Width constraint ルールを新しく追加します。 

新しいルール名 Width_1 が表示されます。Design Rules パネルでこの新しいルールをクリック

して、スコープと内容を修正します。 

2. Name フィールドに 12V or GND と入力します。PCB Rules and Constraints Editor ダイアログを

閉じると、Design Rules パネルの名前が更新されます。 

3. 次に Query Builder を使ってルールスコープを設定します。正しい構文が判っていれば、スコープ

に直接入力できます。もし、クエリが解らない場合は、Advanced ボタンをクリックし Query 
Helper を使用します。 

4. Query Builder ボタンをクリックして、Building Query from Board ダイアログを開きます。 
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5. Add first condition をクリックし、ドロップダウンリストから Belongs to Net を選択します。

Condition Value フィールドでリストからネット 12V を選択し、クリックします。Query Preview
に InNet (‘12V’)と記述されます。 

6. GND ネットを追加する為に、Add another condition をクリックしてスコープを拡張します。

Belongs to Net を選択し、Condition Value で GND を選択します。 

7. オペレータ‘AND’をクリックして、ドロップダウンから OR を選択しオペレータを変更します。

Query Preview に InNet(‘12V’) OR InNet(‘GND’)と記述されていることを確認します。 

8. OK をクリックして Building Query from Board ダイアログを閉じます。これで、Full Query セク

ションのスコープが新しいクエリに更新されました。 

9. PCB Rules and Constraints Editor ダイアログの下のセクションで、Minimum、Preferred、 
Maximum Width フィールドに既に設定されている値(10mil)をクリックして、25mil に変更します。

Minimum value を変更する前に、最初に、Maximum Width フィールドを設定しなければならない

ことに注意して下さい。Design Rules パネルで他のルールを選択するかダイアログを閉じた時に、

ここで設定した内容が保存されます。 
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10. 最後に、全体のスコープである Width のルールをクリックし、Minimum、Maximum、Preferred 
Width フィールドが全て 12mil に設定されていることを確認します。Close をクリックし、PCB 
Rules and Constraints Editor ダイアログを閉じます。 

ボードを手動または自動で配線する時に、GND と 12V のトラック幅は 25mil になり、それら以外のト

ラック幅は全て 12mil になります。 

PCB 上への部品配置 
部品を正しい位置に配置します。 

1. ショートカットキーの V, D を押すと画面が拡大され、ボードと部品が表示されます。 

2. コネクタ Y1 を配置する為、カーソルをコネクタのアウトラインのところに移動し、マウスの左ボ

タンを押し続けます。カーソルの形状が十字に変わり、部品の基準点に移動します。マウスボタン

を押した状態でマウスを移動し、部品をドラッグします。 

3. 図 5 の様に、ボードの左端の方へ（コンポーネントの全体がボードの範囲内に配置される様に）フ

ットプリントを配置します。 
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部品を移動

最適化が行

によって、

適な配置を

ドとして使

きます。 

図 5. 部品が配置されたボード 

4. マウスボタンを放すと、その位置に部品が配置されます。部品と共に

意してください。 

5.   図 5 を参考にして残りの部品を配置します。部品を回転する必要が

接続ラインは図 5 の様になります。接続ラインは、部品を移動する

部品の文字も同じ要領で配置が行えます。カーソルを文字の上に移

SPACEBAR で回転できます。 

DXP には、強力なインタラクティブ配置ツールが含まれています。これ

抗を等間隔に整列させてみましょう。 

1. SHIFT キーを押さえたまま、4 つの抵抗それぞれを左クリックします

Selections のシステムカラーで設定した色のセレクションボックスが

クションボックスの色を変更するには、Design » Board Layers & 
択します。 

2. Utilities ツールバーから Align Components by Top Edges ボタン

Interactive Placement » Align メニューから選択します。4 つの抵抗

て整列されます。 

3.  Utilities ツールバーで Make Horizontal Spacing of Components E
4. デザインウィンドウで任意の場所をクリックし、すべての抵抗のセレ

抗は、等間隔で整列されます。 

フットプリントの変更 

今、フットプリントが配置されていますがコンデンサのフットプリント

ンデンサのフットプリントを小さいものに変更します。 

1. まず、新しいフットプリントを探してみます。Libraries パネルをク

ら Miscellaneous Deivices.IntLib を選択します。Libraries
接続ラインは、

すると自動的に

われます。これ

接続ラインは最

行うためのガイ

用することがで
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接続ラインが移動する点に注

あれば SPACEBAR を使用し、

と自動的に最適化が行われます。 

動してドラッグすれば移動でき、

らの機能を使用し、4 つの抵

。選択した抵抗のまわりに、

それぞれ表示されます。セレ

Colors [ショートカット L]を選

をクリックするか Tools » 
は、一番上の抵抗を基準にし

qual ボタンをクリックします。 

クトを解除します。4 つの抵

が大きめになっています。コ

リックしライブラリリストか

パネル内の Footprints をクリ
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ックし、フットプリントの一覧を表示させます。コンデンサを検索する為に Filter フィールドに

rad と入力します。フットプリント名をクリックするとフットプリントが下に表示されます。

RAD-0.1 が小さいフットプリントに相当します。 

2. コンデンサをダブルクリックし、Component ダイアログの Footprint を RAD-0.1 に変更して下さ

い。直接、新しいフットプリント名を入力するか、… ボタンをクリックし Browse Libraries ダイ

アログからフットプリントを選択します。OK をクリックすると新しいフットプリントがボ－ドに

現れデジグネーターが置き換えられます。 

3. 下図のような PCB デザインになるはずです。 

  

全てコンポ－ネントが配置され、トラックを引く準備ができました。 

ボードのマニュアル配線 

配線とは、ボード上にトラックとビアを配置することにより部品間を接続することです。DXP では、

配線作業を簡単にするために、洗練されたマニュアル配線ツールと、強力な Situs トポロジカル自動

配線ツールが新たに用意されています。この自動配線ツールでは、ボード全体や一部の高品質な配線

をボタン 1 つで行うことができます。 

自動配線機能を使うと簡単にボードを配線することができますが、トラックを正確に配置したい場合

や、決められた経路で配線を行いたい場合には、マニュアルによる配線を行う必要があります。こう

した場合には、ボードの一部または全体をマニュアルで配線できます。チュートリアルのこのセクシ

ョンでは、ボトムレイヤのみを使用しボード全体の配線をマニュアルで行います。 
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接続情報の "ラッツネスト" をガイドに、ボトムレイヤにトラックを配置してみます。 

DXP の PCB では、トラックは連続したセグメントによって形成されています。配置方向を変化させ

る度に、新しいトラックセグメントが始まります。また、DXP は、トラックを垂直、水平、45°等に

配置できるため、熟練技術者のような配線が容易に行えます。尚、ここで紹介する操作はデフォルト

の設定を使用していますが、必要に応じてカスタマイズすることが可能です。 

1. Bottom Layer を表示させ、使用できるようにする為

に、ショートカットキーL キーを押して Board 
Layers & Colors ダイアログを表示させます。Signal 
Layers セクションの Bottom Layer の隣の Show のチ

ェックボックスをクリックします。OK をクリックす

ると Bottom Layer タブがデザインウィンドウに表示

されます。 

クリックすると 

トラック配置が開

始されます。カー

ソルを R1 の下側

のパッドに移動し

ます。 

 
 
 
接続ラインによ

り、対象とするパ

ッドに配線できま

す。 

 
配置中のセグメン

ト 

 
先行セグメント 

 
カーソルを R1 の

パッドに合わせま

す。 
 

もう一度クリック

すると、このトラ

ックセグメントが

配置されます。 

 
さらにもう一度ク

リックすると、次

のトラックセグメ

ントが 

配置されます。 

この部分が配線さ

れました。 
 

2. メニューから Place » Interactive Routing [ショート

カット P, T]を選択するか、または Interactive 
Routing ボタンをクリックします。カーソルの形状

が十字に変わり、トラック配置モードになります。 

3. ドキュメントワークスペースの下部にあるレイヤタブ

を確認してください。現在、TopLayer タブがアクテ

ィブになっています。今回はボトムレイヤにトラック

を配置するので、レイヤを切り換えます。キーボード

のテンキーより * キーを押してください。使用できる

シグナルレイヤが切り替わります。今度は

BottomLayer タブがアクティブになります。 

4. カーソルをコネクタ Y1 の一番下のパッドに合わせま

す。トラックの開始点で左クリックするか、または

ENTER キーを押します。 

5. カーソルを抵抗 R1 の下側のパッドに移動します。ト

ラックがどのように配置されているか、注意して下さ

い。デフォルトでは、トラックは垂直、水平、45°
方向に制限されます。また、トラックが 2 つのセグ

メントになっていることに気づくはずです。最初の

（パッドからスタートした）部分は青色になっていま

す。これが実際に配置するトラックセグメントです。

（カーソルが置かれている）次のセグメントは先行セ

グメントで、アウトラインで表示されています。この

セグメントにより、次に配置するトラックセグメント

の場所を決めて、トラックの向きは 45°または 90°
のままで簡単に配置できます。 

6. カーソルを抵抗 R1 の下側のパッドの中心に移動した

後、左クリックするか ENTER キーを押して下さい。

この時、最初のトラックセグメントは青色になり、ボ

トムレイヤに配置されたことを示します。カーソルを

少し動かしてみると、まだカーソル上に 2 つのトラ
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ックセグメントがあることがわかります。すなわち、次にマウスをクリック

すると配置される青色のセグメントと、トラックの配置に役立つアウトライ

ン表示された "先行" セグメントです。 

ックセグメントがあることがわかります。すなわち、次にマウスをクリック

すると配置される青色のセグメントと、トラックの配置に役立つアウトライ

ン表示された "先行" セグメントです。 

トラックの配置の際、大

きな十字のカーソルを使

用することができます。

カーソルのサイズを変更

するには、 Tools » 
Preferences を選択しま

す。Preferences ダイア

ログの Options タブに

ある Cursor Type から 
Large 90 を選択してく

ださい。 

7. 再度カーソルを R1 の下側のパッドに置きます。前のセグメントからパッド

までのセグメントが青色で表示されます。左クリックして青色のセグメント

を配置します。 

7. 再度カーソルを R1 の下側のパッドに置きます。前のセグメントからパッド

までのセグメントが青色で表示されます。左クリックして青色のセグメント

を配置します。 

これで最初の配線が完了しました。 これで最初の配線が完了しました。 

8. カーソルを抵抗 R4 の下側のパッド上へ移動します。青色のセグメントが

R4 に伸びています。左クリックしてこのセグメントを配置します。 
8. カーソルを抵抗 R4 の下側のパッド上へ移動します。青色のセグメントが

R4 に伸びています。左クリックしてこのセグメントを配置します。 
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先行セグメントがクリッピングしており、カ

ーソルから離れています。PCB エディタで

は、誤って他のオブジェクトを横切ってトラ

ックを配線し、エラーが発生しないようにな

ています。この場合は、コンデンサを迂回

して配線します。 

9. カーソルを抵抗 R3 の下側のパッドに移動します。このセグメントは青色で

はなく、アウトライン形状の先行セグメントで表示されています。トラックセグメントの配置では、

垂直/水平または 45°角の配置モードを相互に切り換えるこ

とができます。現在は、45°モードになっています。

SPACEBAR を押すと、セグメントのスタートモードが水平

/垂直に切り替わります。セグメントは現在青色で表示され

ています。左クリックするか ENTER キーを押すと、セグメ

ントが配置されます。 

9. カーソルを抵抗 R3 の下側のパッドに移動します。このセグメントは青色で

はなく、アウトライン形状の先行セグメントで表示されています。トラックセグメントの配置では、

垂直/水平または 45°角の配置モードを相互に切り換えるこ

とができます。現在は、45°モードになっています。

SPACEBAR を押すと、セグメントのスタートモードが水平

/垂直に切り替わります。セグメントは現在青色で表示され

ています。左クリックするか ENTER キーを押すと、セグメ

ントが配置されます。 

10. カーソルを抵抗 R2 の下側のパッドに移動します。もう一度

SPACEBAR を押してセグメントをスタートモードに切り換

えます。左クリックするか ENTER キーを押すと、セグメン

トが配置されます。 

10. カーソルを抵抗 R2 の下側のパッドに移動します。もう一度

SPACEBAR を押してセグメントをスタートモードに切り換

えます。左クリックするか ENTER キーを押すと、セグメン

トが配置されます。 

っ

11. 以上で最初のネットの配線が終了しました。右クリックする

か、または ESC キーを押してトラックの配置を終了します。

カーソルの形状は十字のままでトラック配置モードであるこ

とを示しており、引き続き次のトラックを配置できます。

END キーを押すと画面が再描画され、配線したネットを確認できます。 

11. 以上で最初のネットの配線が終了しました。右クリックする

か、または ESC キーを押してトラックの配置を終了します。

カーソルの形状は十字のままでトラック配置モードであるこ

とを示しており、引き続き次のトラックを配置できます。

END キーを押すと画面が再描画され、配線したネットを確認できます。 

12.残りの部分も、この手順と同じ方法で配線できます。図 6 にマニュアル配線したボードを示します。 12.残りの部分も、この手順と同じ方法で配線できます。図 6 にマニュアル配線したボードを示します。 

 

図 6. ボトムレイヤにマニュアル配線された状態 

13. デザインを保存します[ショートカット F, S または Ctrl+S]。 



PCB デザイン入門 

32 TU0117 (v1.0) January 22, 2004  

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

トラック配置のキーポイント 

トラックを配置する際のキーポイントを次に示します: 

マウスを左クリックすると（または ENTER キーを押すと）、そのレイヤの色のトラックセグメン

トが配置されます。アウトライン表示されているセグメントは、先行トラックを表しています。配

置されたトラックはそのレイヤの色で表示されます。 

SPACEBAR を押すと、配置するトラックセグメントの水平／垂直スタートモードと 45°スター

トモードが切り替わります。 

END キーを押すと画面が再描画されます。 

ショートカットキーV, F を押すと、再描画されすべてのオブジェクトが画面に表示されます。 

PAGEUP キーや PAGEDOWN キーを押すと、カーソル位置を中央にして画面表示の拡大、縮小を

行います。マウスホイールを使用すると画面のスクロールができ、Shift キーを押しながらマウス

ホイールを動かすと左右にスクロールし、Ctrl キーを押しながらホイールを使用すると、画面表示

の拡大、縮小を行います。 

BACKSPACE キーを押すと、最後に配置したトラックセグメントを削除します。 

右クリックするか、または ESC キーを押すとトラックの配置が終わり、新たにトラックを配置で

きます。 

ネットが異なる箇所へは配線できません。DXP は、接続違反が無いか絶えず監視しており、違反

があった場合には警告します。 

トラックセグメントを削除するには、左クリックします。クリックしたトラックに編集ハンドルが

表示されます。DELETE キーを押すと、トラックセグメントが削除されます。 

DXP では簡単に再配線できます。それまでの冗長なトラックセグメントは右クリックすると自動

的に削除され、新しいトラックセグメントが配線されます。 

PCB のトラックがすべて配線されたら、右クリックするか ESC キーを押して配線モードを終了し

ます。カーソルが通常の矢印に戻ります。 

以上でボードのマニュアル配線が終了しました。 

ボードの自動配線 

DXP で自動配線がいかに簡単に行えるかを、以下の手順で確認します: 

1. まずメニューから Tools » Un-Route » All [ショートカット U, A]を選択し、ボードを未配線の状態

に戻します。 

2. Autoroute » All [ショートカット A, A]を選択します。Situs Routing Strategies ダイアログが表示

されます。Route All をクリックします。Messages パネルに自動配線の過程が表示されます。 

このように DXP の自動配線では、簡単に熟練した PCB 設計者と同様の配線結果が得られ、また

PCB ウィンドウで直接配線が行われるため、配線ファイルのエクスポートやインポートといった

作業が不要となります。 

3. File » Save [ショートカット F, S ]を選択し、保存します。 

自動配線されたトラックは、2 種類の色で表示されています。赤は部品面を示すトップレイヤで、青

はボトムレイヤを示しています。自動配線は Routing Layers デザインルールで規定されているレイ

ヤに配線を行います。これは PCB Board Wizard によって設定されています。また、2 種類の電源ネッ
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トのトラック幅が太くなっていますが、これは新たに 2 つの Width デザインルールを設定したためで

す。 

配線結果は部品の位置によって変わり、図 7 と同じにはならない可能性があります。 

 
図 7. 自動配線によるボード 

この PCB は、PCB 作成ウィザードではじめに定義したように、トップレイヤとボトムレイヤを使用

する両面基板として配線することができます。メニューより Tools » Un-Route » All [ショートカット

U, A]を選択し、ボードを未配線の状態に戻します。これまでと同じ要領で配線を行いますが、配線中

にレイヤを切り換えるには*キーを押します。レイヤを切り換えると、DXP は自動的にビアを挿入しま

す。 

ボードデザインの確認 
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DXP は、階層的デザイ

ンルールをサポートして

います。定義された各ス

コープや同じクラスの多

くのルールをセットする

事ができます。ルールの

priority はルールの優先

順位を決定します。

DXP は、PCB をより完全なものにするために多くのデザインルールのタイプを定義することができる、

ルールドリブン設計環境です。一般的に、デザインプロセスの開始時にデザインルールを設定し、設

計終了時にルールに従ってデザインが作成されているか確かめます。 

チュートリアルの前半で、配線デザインルールを追加し、トラック幅に関する

ルールを追加しました。その他の多くのルールはすでに PCB Board Wizard に

よって作成されています。 

配線が終了した PCB に対して、デザインルールに合致しているか確認するた

めデザインルールチェック(DRC)を実行します: 
 1. Design » Board Layers & Colors [ショートカット L]を選択し、System 

Colors セクションの DRC Error Markers オプションの隣にある Show ボ

タンにチェックが入っていることを確認します。もし、エラーがある場合は DRC エラーマーカー

が表示されます。 

2. メニューから Tools » Design Rule Check [ショートカット T, D]を選択します。オンライン及び、

バッチ DRC の双方のオプションは、Design Rule Checker ダイアログ内で設定できます。カテゴ

リをクリックするとすべてのルールが表示されます。 
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3. すべてのオプションをデフォルトの状態で Run Design Rule Check ボタンをクリックします。

DRC が起動し、レポートファイル（Multivibrator.DRC）が開きます。その結果は、

Messages パネルにも表示されます。PCB ドキュメントをアクティブにする為にクリックすると、

デザインルールに違反しているトランジスタのパッドは、緑色にハイライト表示されています。 

4. Messages パネルでエラーリストを調べます。リストには PCB デザインで発生した違反が表示さ

れています。Clearance Constraint ルールの下に 4 つの違反箇所が記載されている点に注目して

下さい。トランジスタ Q1 と Q2 のパッドが、13 mil のクリアランスルールに違反していることが

わかります。 

5. Messages パネルのエラーをダブルクリックすると、PCB での配置場所に移動します。 

PCB をレイアウトする前に、ルーティングテクノロジや実際のデバイスの特性を確認し、Clearance 
Constraint ルールを設定します。エラー箇所に対しては、現在のクリアランスデザインルールを再検

討し、対策を決定します。 

トランジスタのパッド間の実際のクリアランスを調べるには、次の操作を実行します: 

1. PCB ドキュメントをアクティブな状態にした後、カーソルをトランジスタの 1 つに合わせ、

PAGE UP キーを押して拡大表示します。 

2. Reports » Measure Primitives  [ショートカット R, P ]を選択します。カーソルの形状が十字に変

わります。 

3. カーソルをトランジスタの左側のパッドの中心に移動した後、左クリックするか ENTER キーを押

します。パッドにトラックが接続されている場合、いずれかの選択を促すポップアップメニューが

表示されるので、トランジスタのパッドを選択し

ます。 

4. カーソルをトランジスタの中央のパッドの中心に

移動して左クリックするか、または ENTER キー

を押します。もう一度ポップアップメニューから

トランジスタのパッドを選択します。情報ボック

スが表示され、パッド間の最短距離は 10.63mil と
表示されます。 
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5. 情報ボックスを閉じ、右クリックか ESC キーで測定モードを終了します。さらにショートカット

V, F で、ドキュメント全体を表示します。 

現在のクリアランスデザインルールを見てみます。 

1. メニューから Design » Rules [ショートカット D, R]を選択し、PCB Rules and Constraints Editor
ダイアログを表示します。Electrical カテゴリをダブルクリックすると、ダイアログの右側に電気

的なルールがすべて表示されます。ダイアログの右側で Clearance をダブルクリックし、

Clearance をクリックすると、クリアランスのルールが表示されます。ダイアログの下側にルー

ルが 1 つ表示され、ボード全体の最小クリアランスが 13 mil に設定してあることがわかります。

トランジスタのパッド間のクリアランスはこの幅よりも小さく、これが DRC を実行した際エラー

表示された原因です。 

トランジスタのパッド間は 10 mil よりやや大きいことがわかっているため、トランジスタだけは

デザインルールのクリアランスを 10 mil に設定します。 

2. Design Rules パネルで Clearance タイプを選択し、右クリックして New Rule を選択し、

clearance constraint ルールを新しく追加します。 

3. 新しい Clearance ルール（Clearance_1）をクリックします。表示されたダイアログの

Constraints セクションで Minimum Clearance を 10 mil に設定します。 

4. Advanced (Query)をクリックし、次に Query Helper をクリックして Memberships Checks から

構文を作成するか、もしくは直接、Query フィールドに以下の構文を入力します: 
HasFootprintPad(‘BCY-W3/E4’,’*’) 
*(アスタリスク)は BCY-W3/E4 のフットプリントの '任意のパッド' を示します。 

5. Second Object のスコープは All のまま、Close をクリックし PCB Rules and Constraints Editor ダ
イアログを閉じます。 

6. Design Rules Checker ダイアログ(Tools » Design Rule Check)の Run Design Rule Check ボタ

ンをクリックし、DRC を再実行してみます。ルール違反はない筈です。 

7. PCB とプロジェクトファイルを保存します。 

これで PCB レイアウトが完全なものになりましたので、次はドキュメントの出力です。 

プロジェクトアウトプットの設定 

印刷用ファイルや出力ファイルのようなプロジェクトアウトプットは、他のプロジェクトにコピーや

貼り付けを行うことができ、修正が可能な Output Job ファイルで設定します。もしくは、File メニュ

ーから個々のコマンドを選択し設定します。 

1. File » New » Output Job File を選択します。そして、設定したい出力を選択してからダブルクリ

ックし、その出力設定を変更します。設定が完了したら Output Job ファイルを保存します。 

2. 出力ファイルを、出力タイプによって個々のフォルダに送りたい場合は、Project » Project 
Options を選択し、Options タブをクリックします。そして、Use separate folder for each 
output type をクリックしチェックマークを入れ、OK をクリックします。 

印刷 

PCB のレイアウトと配線が終了したことにより、出力ドキュメントを作成する準備が整いました。こ

れらのドキュメントには、PCB の製造データ、実装図面、部品の位置情報等が含まれます。 
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これらの図面を作成する為に、DXP には洗練されたプリントエンジンが含まれており、印刷工程を完

全にコントロールすることができます。一緒に出力する PCB レイヤを細かく設定したり、図面（プリ

ントアウト）をプレビューして縮尺や印刷方向を設定し、印刷する前に正確な出力イメージを捉える

ことができます。 

これらの図面を作成する為に、DXP には洗練されたプリントエンジンが含まれており、印刷工程を完

全にコントロールすることができます。一緒に出力する PCB レイヤを細かく設定したり、図面（プリ

ントアウト）をプレビューして縮尺や印刷方向を設定し、印刷する前に正確な出力イメージを捉える

ことができます。 

ここではデフォルトの出力設定を使用してプレビューを作成します。 ここではデフォルトの出力設定を使用してプレビューを作成します。 

1. PCB のメニューから File » Print Preview を選択します。PCB が解析され、デフォルト状態のプ

リント出力がプリントプレビューウィンドウに表示されます。Close をクリックします。 
1. PCB のメニューから File » Print Preview を選択します。PCB が解析され、デフォルト状態のプ

リント出力がプリントプレビューウィンドウに表示されます。Close をクリックします。 

2. プリンタにコンポジット図面を送る為に、File » Print を選択します。 2. プリンタにコンポジット図面を送る為に、File » Print を選択します。 

3. ターゲットプリンタや印刷方向、縮尺を変更するには、メニューから File » Page Setup を選択し

ます。使用したいプリンタを選択し、Printer Paper が Landscape に設定されていることを確認し

ます。高度な印刷オプションは、このダイアログからも利用できます。 

3. ターゲットプリンタや印刷方向、縮尺を変更するには、メニューから File » Page Setup を選択し

ます。使用したいプリンタを選択し、Printer Paper が Landscape に設定されていることを確認し

ます。高度な印刷オプションは、このダイアログからも利用できます。 

製造用出力ファイルの作成 製造用出力ファイルの作成 

PCB 設計プロセスの最終段階は、製造用ファイルの作成です。主なファイルとしては、ガーバーファ

イル、NC ドリルファイル、部品位置情報ファイル、部品表、およびテストポイントファイル等の、製

造と実装用のデータがあります。出力ファイルは File » New » Output Job File で設定するか、また

は File » Fabrication Outputs メニューでコマンドを選択して設定します。製造用ドキュメントの設

定は、プロジェクトファイルの一部として保存されます。 

PCB 設計プロセスの最終段階は、製造用ファイルの作成です。主なファイルとしては、ガーバーファ

イル、NC ドリルファイル、部品位置情報ファイル、部品表、およびテストポイントファイル等の、製

造と実装用のデータがあります。出力ファイルは File » New » Output Job File で設定するか、また

は File » Fabrication Outputs メニューでコマンドを選択して設定します。製造用ドキュメントの設

定は、プロジェクトファイルの一部として保存されます。 

ガーバーファイルの生成 ガーバーファイルの生成 

コンポーネントオーバーレイ、トップシグナルレイヤ、ボトムシグナルレイヤ、ソルダーマスクレイ

ヤ等の各ガーバーファイルは、実際の PCB の各レイヤにそれぞれ対応します。尚、ガーバーファイル

や NC ドリルファイルを生成する前に、PCB の製造業者へ必要なデータの形式について問い合わせて

おく必要があります。 

コンポーネントオーバーレイ、トップシグナルレイヤ、ボトムシグナルレイヤ、ソルダーマスクレイ

ヤ等の各ガーバーファイルは、実際の PCB の各レイヤにそれぞれ対応します。尚、ガーバーファイル

や NC ドリルファイルを生成する前に、PCB の製造業者へ必要なデータの形式について問い合わせて

おく必要があります。 

このチュートリアルの PCB 製造ファイルを作成するには、次の操作を実行します: このチュートリアルの PCB 製造ファイルを作成するには、次の操作を実行します: 

1. PCB をアクティブなドキュメントにして、File » Fabrication Outputs » Gerber files を選択しま

す。Gerber Setup ダイアログが表示されます。 
1. PCB をアクティブなドキュメントにして、File » Fabrication Outputs » Gerber files を選択しま

す。Gerber Setup ダイアログが表示されます。 
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もし、出力ファイルを作

成した時に自動で開きた

くない場合は、Project 
» Project Options を選

択し、Options タブをク

リックして Open 
Outputs after compile 
のチェックをはずして下

さい。 
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2. Layers タブをクリックして出力したいレイヤを選択します。右クリックして Plot Layers を選択

し、Used On を選択します。他はデフォルト設定を適用しますので OK をクリックします。 

3. ガーバーファイルが生成され、CAMtastic! が開いてファイルが表示されます。ガーバーファイル

は Project Outputs フォルダに保存されます。このフォルダは、プロジェクトファイルが保存

されているフォルダに自動的に作成されます。各ファイルにはレイヤ名に対応したファイルの拡張

子が追加され、例えば、Gerber Top Overlay のファイルは Multivibrator.GTO となります。こ

れらのファイルは、Projects パネルの Generated Documents のフォルダの下に追加されます。 

部品表の作成 

1. 部品表を作成するには、PCB ドキュメント（Multivibrator.PcbDoc）をクリックし、Reports 
» Bill of Materials を選択します。Bill of Materials for PCB ダイアログが表示されます。 

 

2. このダイアログで部品表を作成します。部品表に追加したい項目の隣にある Show をクリックし

ます。 

3. 部品表の欄でコンポーネントをグループ化するには、グループ化したい項目を Other Columns で

選択し、Grouped Columns にドラッグ移動して下さい。例えば、Footprint でグループ化するには、

Other Columns で Footprint を選択し Grouped Column にドラッグして下さい。リストは

Footprint ごとに分類されます。 
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4. Report をクリックすると、部品表のプリントプレビューが表示されます。Print ボタンをクリック

するとこのプレビューが印刷できます。また、Export ボタンをクリックすると Microsoft Excel
の.xls のようなファイル形式でエクスポートできます。ダイアログを閉じます。 

これで PCB の設計プロセスがすべて完了しました。 

より詳細な調査のために 

このチュートリアルでは、DXP の強力な機能のいくつかを紹介しました。ここでは回路図を作成し、

デザインの過渡シミュレーションの実行し、PCB での設計や配線を行いました。これらは全て DXP
に搭載されている統合ツールです。しかし、これらは DXP で供給されている強力なデザイン機能の一

部に過ぎません。 

一度、DXP の機能について調べると、より簡単に設計できる機能を発見することができます。ソフト

ウェアの機能を実証する為に、多くのサンプルファイルが含まれています。メニューから File » Open 
を選択し、通常の方法でサンプルファイルを開くことができます。サンプルファイルは、\Program 
Files\Altium2004\Examples\のフォルダに保存されています。このフォルダ内には、ボードデザ

インのサンプルファイルの他に、DXP の特別な機能を備えたサンプルファイルが保存されている多く

のサブフォルダも含まれています。 

DXP のアナログ、デジタルシミュレーションの機能を検証する為に、Circuit Simulation サブフ

ォルダを確認します。アンプや電源などのアナログのサンプルファイルと同様に、混在モード、関数、

ソース依存型線形・非線形のサンプルや真空管などの様々なサンプルファイルがあり、回路デザイン

を検証することができます。 

ロジックのスイッチング、デザインクロックスピードの更なる高速化に伴い、デジタル信号の質は、

より重要になります。DXP には、ボードレイアウトを正確に設計し分析できる洗練された伝送線路解

析ツールが含まれています。インピーダンス、オーバーシュート、アンダーシュート、スロープなど

の伝送線路解析に必要な設定は PCB デザインルールで定義され、標準のデザインルールチェックで検

査されます。 

もし、より詳細な解析が必要なネットがある場合は、反射やクロストーク解析が実行できる Signal 
Integrity Analyzer へデザインを渡す為に Tools » Signal Integrity を選択します。その結果は、実行し

た内容を検証でき、波形から直接、測定できるオシロスコープのような波形アナライザに表示されま

す。 

 
この入門チュートリアルをご覧頂きありがとうございます。 
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更新履歴 
 

Date Version No. Revision 

22-Jan-2004 1.0 New product release 

Software, documentation and related materials:  

Copyright © 2004 Altium Limited. 

All rights reserved. Unauthorized duplication, in whole or part, of this document by any means, mechanical or 
electronic, including translation into another language, except for brief excerpts in published reviews, is prohibited 
without the express written permission of Altium Limited. Unauthorized duplication of this work may also be 
prohibited by local statute. Violators may be subject to both criminal and civil penalties, including fines and/or 
imprisonment. Altium,  DXP, Design Explorer, nVisage, Nexar, Protel, P-CAD, CircuitStudio, NanoBoard, NanoTalk, 
Tasking, CAMtastic, Situs and Topological Autorouting and their respective logos are trademarks or registered 
trademarks of Altium Limited. All other registered or unregistered trademarks referenced herein are the property of 
their respective owners and no trademark rights to the same are claimed. 
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