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このチュートリアルでは、社内のコンポーネントデータベ

ースから回路図に配置したコンポーネントへリンクさせる

方法を説明します。データベースリンクは、部品表

（BOM）に含めることができるコンポーネントパラメータ

へデータベースからデータを移行させることができます。 
 

 
DXP では、外部にあるデータベースを PCB プロジェクトの回路図に配置されたコンポーネントにリ

ンクさせることで、部品管理システムから DXP 設計環境へ情報を引き渡すことができます。 

リンクは、PCB プロジェクト(.PrjPCB) や Library プロジェクト(.LibPkg)に追加された Database 
Link ファイルを通して回路図コンポーネントパラメータと外部のデータベース間を確立させます。こ

のファイルは MS-Access および MS-SQL server 接続の事前定義サポートと同様、リンクは ODBC 接

続を通して指定されます。 

次ページの図は、DXP で MS Access データベースと回路図コンポーネントとの間の Database Link フ

ァイルを使用して形成されたリンクの例を示します。このチュートリアルでは、リンクするデータベ

ースに関して、\Program Files\Altium2004\Examples\Reference Designs\4 Port 
Serial Interface フォルダにあるサンプルを例に、これらのリンクがどのように設定されるのか

を説明します。このサンプルプロジェクトは、回路図コンポーネントが\Program 
Files\Altium2004\Examples\Cis フォルダ内にある Example database.mdb という名称の

MS Access データベースにリンクしています。 
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MS Access database 
*.mdl file 

DXP Schematic Editor 

Database Link file (*.DbLink) 

Component Properties ダイアログのパラメータ パラメータが表示されたコンポーネント 

部品管理システムが、サンプルプロジェクト 4 Port Serial Interface の回路図コンポーネントにリンクしています。 部品管理システムが、サンプルプロジェクト 4 Port Serial Interface の回路図コンポーネントにリンクしています。 

データベースファイルの使用 データベースファイルの使用 
DXP でのデータベース接続は、デフォルトでは MS Access データベース（*.mdb ファイル）用に設

定されていますが、ODBC 準拠であればどのようなデータベースでもアクセスすることができます。

これは外部データベースとして Excel ファイル（*.xls）を使用することも可能です。データベース

として Excel ファイルを使用することに関しての詳細は、このチュートリアルで後に説明する Excel
ドキュメントへのリンク を参照してください。 

1. MS Access を使用して、コンポーネント情報を含んでいるデータベースファイル（*.mdb）を作

成します。MS Access で複数のテーブルを使用するデータベースの設定方法は、サンプルファイ
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ルの\Program Files\Altium2004\Examples\Cis\Example database.mdb を参考にして

ください。  

 

2. データ形式がデータベースファイルで正確に設定されることを確認してください。例えば、テキス

トにはテキストストリングパラメータを使用します。データベースファイル（*.mdl）を保存して

閉じ、MS Access を終了します。 

3. DXP を起動して、\Program Files\Altium2004\Examples\4 Port Serial Interface
フォルダにある PCB プロジェクト 4 Port Serial Interface.PrjPCB を開き、プロジェク

トの回路図ドキュメントを開きます。 

ファイルの作成 
データベースファイルは既に準備されていますが、DXP の中で Database Link ファイル(*.DbLink)を
作成する必要があります。Database Link (DbLink)ファイルは、回路図ドキュメント上に配置されたコ

ンポーネントとデータベース間のリンクを定義する為に使用されます。このファイルが設定されてい

る場合、回路図上のコンポーネントは、リンクしたパラメータの更新によりデータベースからの情報

で更新することができます。 

Database Link ファイルは、4 Port Serial Interface プロジェクトに既に存在しますが、新規ファイルを

作成し、それが使用できることを実際に試してみます。もし、別の外部データベースにプロジェクト

を接続したい場合は、新たな Database Link ファイルを設定する必要があります。 

1. PCB プロジェクトに Database Link ファイルを追加するには、Projects パネルのプロジェクト名 4 
Port Serial Interface.PrjPCB を選択し、メニューから File » New » Database Link File
を選択します。 
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2. 新たに作成されたファイル Database Links1.DbLink がデザイン画面に表示され、Projects パ

ネル中のサブフォルダ Settings\Database Link Files に追加されます。 

データベース接続の指定 
Database Link ファイルが追加されれば、データベースへの接続を指定することができます。そして、

どのデータベースフィールドが、どのデザインパラメータと一致している必要があるか、また更新が

どのようにデザインに反映されるかなどを指定することができます。   

1. プロジェクトをデータベースに

接続するには、Tools » 
Database Connection を選択し、

ます。Database Connection ダイ

アログの Connection タブが表示

されます。接続はデータリンク

ファイル（*.udl）、または外

部データベースファイル（例え

ば、 *.mdb）にリンクを指定す

るコネクションストリングの記

述によっても行えます。サンプ

ルのデータベースへのリンクは、

C:ドライブからの絶対パスを指定していることに注意してください。必要な場合は、Database 
Connection ダイアログでこれらを変更して下さい。 

2. このチュートリアルでは、Access データベースファイルへの接続ストリングを使用します。そこ

で、Use Connection String を選択し Build ボタンをクリックします。Data Link Properties ダイ

アログが表示されます。デフォルトの OLE DB provider（Microsoft Jet 4.0 OLE）が Provider タブ

内に設定されます。 
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3. Connection タブからブラウズボタン  をクリックし、Sele
ァイル名（例えば、C:\Program Files\Altium2004\ Ex
database.mdb）を選択して、接続したいデータベース名を

Open をクリックします。  

4. データベースへの接続が成功したことを確認するには、Test 
Connection をクリックしてください。接続が成功すれば、確

イアログが表示されます。全てのダイアログが閉じられるまで

をクリックして下さい。 

5. 一度接続されると、Database Link ファイル(*.DbLink)は、T
Browser および Database Links タブにデータを表示させます。

6. 使用したい Table が有効になっていることを確認して下さい。

Database Link ファイル中の Table Browser タブでは、データ

ステーブルを参照することができます。内容の修正は、外部デ

ベースで行う必要があります。ここでは参照のみで修正は行う

はできません。 
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Database Links タブは、各テーブルのデータベースフィールドをデザインパラメータと関連付け

るために使用されます。データベースリンクの設定に関する詳細は、このチュートリアルの デー

タベースリンクオプションの設定 の項を参照してください。 

 

キーフィールド及びキーパラメータの設定 
回路図中のパラメータをデータベースファイルの情報に対応させるには、Database Key Field が

Database Link ファイルを通して Part Key Parameter と一致している必要があります。キーフィール

ドは、通常パーツ管理番号のようなデータベース中のコンポーネントを固有に識別する為のものです。

情報は、まず配置された回路図コンポーネントに存在する選択した Part Key Parameter 名が読み込ま

れ、次にデータベースファイル中の選択されたデータベースキーフィールドを検索します。それらが

一致した場合、データベース中のそのレコードからのセルは、回路図コンポーネント中のマップされ

たパラメータに渡されます。 

キーフィールドは、各接続テーブル用の Database Link ファイルで設定されます。初めにデータベー

スの中で、回路図パーツからテーブル行へ一致させるために使用

されるキーフィールドとして、1 つの Database Key Field 及び 1
つの既存のデザインパラメータ（Part Key Parameter）を指定し

ておく必要があります。もし、適切な Part Key Parameter が存

在しない場合は、それを作成しておく必要があります。詳細は、Parameter Manager を使用して Part 
Key Parameter の作成 の項を参照してください。キーフィールドとキーパラメータを対応させるに

は： 

1. Database key field のドロップダウンリストからデータベースで見つかった標題欄を選択してくだ

さい。サンプルの 4 Port Serial Interface プロジェクトでは、データベースの Part Number フィー

ルドは、回路図コンポーネントの Part Number パラメータに対応しています。 

2. Part key parameter のドロップダウンリストから、PCB プロジェクトの回路図ドキュメントで見

つかったパラメータ名を選択し、Database Link ファイルを保存します。 

複数のフィールドとパラメータの SQL との一致 
先に記載されている Single key lookup は、一つのデータベース欄と一つのデザインパラメータ間の適

切な相互関係を必要としますが、Where 節を使用して複数のデータベースフィールドとパラメータ間

のキーを一致させることができます。この高度な機能は、SQL の熟練したユーザにのみ推奨されます。 

6 TU0119 (v1.1) November 18, 2004  



データベースからコンポーネントへのリンク 

下記の Where 節の例は、複数のフィールドとパラメータ間のキーを一致させる為の基準形式を表しま

す。この場合、データベーステーブルの一つの列は、3 つの異なるパートパラメータを使用してリン

クされます。 

Capacitance = '{Capacitance}' AND Tolerance = {Tolerance} AND 
Manufacturer = '{Manufacturer}'  

下記の 2 番目の例は、SQL ステートメントを介してキーを一致させる強力な利点をいくつか示してい

ます。 

[Package] = '{Footprint}' AND '[Value]' like '{Comment}%' AND [Tolerance] 
<= {Tol} + 0.01 and [Tolerance] >= {Tol} - 0.01 

デザインパラメータは、常に括弧内で参照されることに注意して下さい。シングルクォートで囲まれ

たこれらの括弧は、パラメータ値をストリングとして扱います。パラメータがシングルクォートで囲

まれていない場合、その値は数値として扱われます。データベース欄の角括弧は、MS データベース

（Access など）でのみ使用できます。そうでない場合は使用しないで下さい。クォートは、データベ

ースカラム名にスペースや予約語を含んでいる場合だけに必要です。 

Parameter Manager を使用して Part Key Parameter を作成 
配置した回路図コンポーネントに Database Link ファイルの Part Key Parameter として使用するのに

適切なパラメータが無い場合、Parameter Manager を使用して、全ての関連するコンポーネントに新

しいパラメータを追加することができます。4 Port Serial Interface のサンプル回路図の各コンポーネ

ントには既に Part Number パラメータが追加されているので、チュートリアルのこの項目は、行う必

要がありません。 

Parameter Manager を使用して新しいパラメータを追加するには： 

1. 回路図エディタで必要な回路図ドキュメントを開き、メニューから Tools » Parameter Manager
を選択します。Parameter Editor Options ダイアログが表示されます。 

 

2. 回路図中の全てのパーツに新たなパラメータを追加するには、Parameter Editor Options ダイアロ

グの Include Parameters Owned By の項目から Parts を選択し、Criteria 欄は All Objects を選択

します。OK をクリックすると、Parameter Table Editor ダイアログが表示されます。 
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3. Add Column をクリックします。Add Parameter ダイアログが表示されます。新しいパラメータ

名を入力し、Add to all objects をクリックします。Value を入力する必要はありません。OK をク

リックします。 

 

4. Accept Changes (Create ECO)をクリックして Engineering Change Order ダイアログを表示させ

ます。 

 

5. Validate Changes をクリックします。確認が完了すれば（Status 欄に緑のチェックマークが表示

されます）、Execute Changes をクリックします。 

6. 更新が終了したら Close をクリックします。新しいパラメータは、回路図中のコンポーネントに

追加されます。これらの更新結果の確認は、回路図ドキュメント中でコンポーネントをダブルクリ

ックして Component Properties ダイアログを表示して行えます。新しいパラメータが Parameters
リストに追加されます。 

データベースリンクオプションの設定 
回路図からデータベースまでの接続が設定され、キーフィールドとパラメータが設定されれば、デー

タベースにある値は Database Link ファイルの Database Links タブの中でそれらをマッピングする

ことにより、回路図に転送することができます。   
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データベースリンクオプションのデフォルト設定 
回路図ドキュメントに対するパラメータの追加、更新、削除のデフォルトアクションを設定すること

ができます。例えば、データベースに値があるときだけ、コンポーネントにパラメータを常に追加し

たい場合、パラメータを更新するか削除するかを選択することができます。これらの動作は、Update 
from Database コマンドを実行する際に実行されます。これらのデフォルトは、Database Link ファイ

ル中の詳細なインスタンスで無効にすることができます。 

1. デフォルトオプションを設定するには、Tools » Options を選択します。または、セル上で右クリ

ックし Options を選択します。Database Link Options ダイアログが表示されます。  

 

2. 外部データベース中の対応するフィールドからの情報を持った、配置済みの回路図コンポーネント

のパラメータを更新する場合に適用されるデフォルトの動作を設定します。ドロップダウンリスト

からデフォルトのオプションを選択します。 

3. このダイアログで定義した設定した Update Values、Add To Design、Remove From Design の

内容は、関連する Database Link ファイル内で、Default エントリが選ばれたときだけ適用されま

す。データベースからパラメータの更新を行う場合、これらのデフォルト設定を使用するか、また

は、個々に更新、追加、削除の動作を設定でき、十分なコントロールを行うことができます。OK
をクリックして Database Link ファイルに戻ります。 

データベースリンクの作成 
回路図コンポーネントを更新する時に行われるデフォルトの動作が設定されましたので、Database 
Link ファイルでデータベースリンクを作成する必要があります。  

Database Link ファイルの Database Links タブ内でデータベースリンクを作成するには： 

1. 列をハイライトさせ Ctrl+D を押します。  

2. デザイン用の Design Parameter が作成され、データベースフィールド名と同じ名称が付けられま

す。Database Link Options ダイアログで設定された、デフォルト更新のオプション（デフォル

ト）はすべて有効になっています。   
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3. データベースフィールドを（既存か新規）異なるパラメータ名にリンクさせたい場合は、Design 
Parameter 名をクリックして選択し、再びクリックしてドロップダウンリストから新しいパラメー

タ名を選ぶか、あるいは直接入力して設定します。 

4. 1 からの操作をデータベースリンクが必要なものに対して繰り返し行います。緑のチェックマーク

は、データベースフィールド名とデザインパラメータの間でリンクが確定していることを示してい

ます。 

各パラメータの更新オプションの変更 
データベースからのパラメータ値を更新する場合に、それぞれのフィールドで、デフォルト設定を無

効にすることもできます。Update Values、Add To Design、Remove From Design の Default を変更

するには： 

1. 編集する項目をクリックして選択します。再びクリックすると矢印が表示され、ドロップダウンリ

ストが利用可能であることを示します。 

 

2. デフォルト動作を無効にしたいデータベースフィールドのドロップダウンリストから必要な動作を

選択します。選択した動作は Database Link ファイルの中で更新されます。Database Link ファイ

ルを保存します。 

Engineering Change Order (ECO)を使用して、データベースから回路図ドキュメントを更新する場合、

指定した変更を拒否することもできます。 

データベースからの回路図の更新 
必要な設定がすべて定義されたら、Update from Database コマンドを使用して Engineering Change 
Order を作成して設定の更新を行います。 

10 TU0119 (v1.1) November 18, 2004  



データベースからコンポーネントへのリンク 

1. 回路図ドキュメントに戻り、メニューから Tools » Update from Database を選択し、 データベ

ースのパラメータ値と同期させます。Update from Database ダイアログが表示され、このダイア

ログで更新したい回路図ドキュメントおよびコンポーネントタイプを選択できます。  

 

2. 更新する回路図ドキュメントおよびコンポーネントタイプを（チェックマークを入れて）選択し、

更新の範囲を設定してから OK をクリックします。外部データベースとパーツとの対応が確認され、

次に更新される回路図パーツのリストが Select Parameter Changes ダイアログに表示されます。  

 

3. このダイアログでは更新を有効にするか、あるいは除外かをパラメータ単位で決定できます。

Update All をクリックするか、あるいは更新したいオブジェクトだけを選択します。これは、パ

ラメータがデータベースから更新される最後のコントロールの機会を与えます。次に Accept 
Changes (Create ECO)をクリックすると、Engineering Change Order ダイアログが表示されます。 

 

4. Validate Changes をクリックして、Status が OK である（チェックマークが付いている）ことを

確認してください。Execute Changes をクリックするとパラメータが更新されます。変更が実行

されれば、Close をクリックします。 

5. 配置されている回路図コンポーネントのパラメータは更新されます。これらの更新結果は、

Parameter Manager を使うか、List パネルの中でクエリ IsParameter を使用するか、あるいは回

路図ドキュメントのコンポーネント上でダブルクリックして表示される Component Properties ダ

イアログで確認することができます。 
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Excel ドキュメントとのリンク 
データベース接続は、デフォルトでは Access データベース（*.mdb ファイル）用に設定されていま

すが、ソースデータベースとして Excel ファイルも使用することができます。 

既存の Excel ドキュメントを回路図ドキュメントにリンクするには：  

1. File » New » Database Link File を選択して、PCB プロジェクトに Database Link ファイル

（*.DbLink）を追加します。 

2. Tools » Database Connection を選択します。Use Connection String を選択して Build をクリ

ックすると、Data Link Properties（データ リンク プロパティ） ダイアログが表示されます。 

3. Provider タブをクリックし、Microsoft Jet 4.0 が選択されていることを確認します。これは

Access データベースファイルに使用される新しい Database Link ファイルのためのデフォルト設

定です。 

 

4. All タブをクリックして下さい。Extended Properties の項目をダブルクリックして、プロパティ

の値を編集 ダイアログ内の“プロパティの値”の項目に Excel 8.0 と入力し、OK をクリックし

ます。 
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5. 接続タブをクリックして、ブラウズボタン  を押し、Access データベースの選択 ダイアログか

ら Excel (.xls)ファイルを検索します。“ファイルの種類”の項目をすべてのファイル(*.*)に変

更し、目的の Excel ファイルを指定してから開くをクリックします。 

6. 接続のテスト ボタンをクリックします。接続が成功すれば確認のメッセージが表示されます。 

7. Database Link ファイルは、Excel の各シートをそれぞれ独立したテーブルとして表示します。必

要なテーブルが有効になっていることを確認してください。テーブル名にはドル記号($)が追加さ

れていますが、これは Excel の予約語でリンクした値に影響しません。 

8. 外部ソースとして Access データベースを使用した時と同様の方法で、必要となるデータリンクを

（Ctrl+D を使用して）作成し、キーフィールドの設定や更新のオプションを作成してください。  

9. Database Link ファイルを設定し、保存してから Tools » Update from Database を選択して ECO
を実行します。指定した回路図ドキュメントで選択されたコンポーネントパラメータは、データベ

ースから更新されます。 

BOM 生成時に新しいパラメータを使用 
新しいパラメータと更新された値がデザインへ取り込まれたなら、Report Manager を使用して新しい

コンポーネント情報を取り込んだ部品表（Bill of Materials）を作成することができます。次のステッ

プでは、この作成手順を要約して解説します。Excel テンプレートを使用して、BOM データを整列し、

出力することに関しての詳細は、部品レポートのカスタマイズのチュートリアルを参照して下さい。 

1. Excel BOM テンプレートファイルで、新しいカラム名、例えば Column=Part Number を追加し

て下さい。新しいテンプレート（例えば BOM Default Template1.xlt）を\Program 
Files\Altium2004\Templates フォルダに保存し、テンプレートファイルを閉じます。 

2. DXP で Reports » Bill of Materials を選択して、Report Manager (タイトルは、BOM を生成する

場合には Bill of Materials (By Part Type) for Project [Project name.PRJPCB]ダイアログ)を表示させ

ます。 
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3. カラム名（例えば、ダイアログ内の Other Columns の項目の Part Number）隣の Show ボックス

をクリックすることにより、レポートの中で表示させたいカラムを選択します。 

4. ブラウズボタン  を押して新しいテンプレート名（例えば、BOM Default Template1.xlt）
を検索し、開くをクリックして Template の項目にファイル名を表示させます。 

5. Excel ボタンをクリックして、作成される Excel スプレッド・シートをプレビューします。BOM
には、追加された新しい欄（Part Number）からのデータが表示されています。 

6. Open Exported にチェックマークを入れ Excel をクリックし、MS Excel で DXP BOM の新しい

Excel スプレッドシートを開きます。   

  

7. 更に必要ならば、Excel の BOM を修正することができます。 
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