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Protel DXP へようこそ 
Windows 2000/XP 用の 32bit 電子設計システム、Protel DXP の世界へようこそ。この Protel DXP では、

最初のコンセプトの段階から最終のボードレイアウトまでのすべてを容易に実現できる、統合された開

発環境が提供されます。 

DXP は、全てのツールを デザインエクスプローラ という単一のアプリケーション環境で使用することが

できます。Protel DXP を起動しデザインエクスプローラがオープンした後は、タブを選択するだけです

べてのデザインツールを使用することができます。また、共通化された操作性とカスタマイズ可能なユ

ーザー環境を手に入れることができます。 

このチュートリアルでは、回路図の作成方法、デザイン情報を PCB に更新する方法、製造用出力ファイ

ルを作成する方法について概略を説明します。また、プロジェクト、統合ライブラリ、および回路シミ

ュレーションのコンセプトについても説明します。 

Protel DXP デザインエクスプローラ 
デザインエクスプローラは、設計者とデザインツールとのインターフェイスです。DXP をスタートし、

デザインエクスプローラをオープンするには、Windows のスタートメニューから Programs » Altium » 
Protel DXP をセレクトします。DXP をオープンすると、最も一般的な初期タスクが表示され、すぐに利

用することができます。 

ク

ュ

システムメニュー 
下向矢印のアイコンを

リックしてシステムメニ

ーを表示し、システム環

境を設定します。その他

のメニューとツールバー

は、編集するドキュメン

トのタイプに応じて自動

的に切り替わります。 

 

ワークスペースパネル 
ファイルパネル、プロジ

ェクトパネル、ヘルプア

ドバイザ・パネルで構成

されています。パネル

のタイトルをクリックして

新しい場所にドラッグす

ると、移動、ドッキング、

クリッピングができま

す。 
パネル下部のタブをクリ

ックすると内容が表示さ

れます。 

 
パネルコントロール

パネルコントロール・

リストで、エディタ固

有の共有パネルを

選択します。 
ヘルプアドバイザ

ナチュラルランゲ

ージ・ヘルプシステ

ムを使用すると、

問題の解決方法を

素早く探し出すこと

ができます。 
ワークスペースパネル

タブをクリックすると、別

のポップアウト・パネル

が表示されます。表示さ

れたパネルも、移動、ド

ッキング、クリッピング

ができます。 
ワークスペース 
すばやくスタートでき

るように、よく使うファ

イルが配置されてい

ます。 
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例えば、デザインドキュメントの作成時に回路図エディタと PCB エディタとを容易に切り換えることが

できます。このとき、デザインエクスプローラのツールバーとメニューは作業中のエディタに応じて変わ

ります。ワークスペースパネルには、名前が最初にワークスペースの右下に表示されるものもあります。

名前をクリックするとパネルが開き、作業環境に応じて移動、ドッキング、クリッピングができます。 

次に示すデザインエクスプローラでは、複数のドキュメントとエディタが同時にオープンされ、ウィン

ドウが並べて表示されています。 

デザインウィンドウ 
デザインウィンドウには、現

在オープンしているドキュメ

ントが表示されます。 

レイヤータブ 
PCB の各レイヤーに

は タブがあります。

ドキュメントタブ 
開いているドキュメントの

デザインウィンドウ上部に

は、それぞれ独自のタブ

があります。タブを右クリッ

クすると、ドキュメントをク

ローズしたり、分割したり、

並べて表示できます。 

ワークスペースパネル

ボタンをクリックすると、

関連するワークスペース

パネルが表示されます。

グラフィカル表示とリスト表示 
デザインウィンドウでドキュメ

ントをグラフィカル表示したり、

オブジェクトの属性をリスト表

示 (View » Workspace 
Panels > List) することがで

きます。 
Schematic エディタ
マスクレベルボタン  
マスクされているオブ

ジェクトの濃淡を変更

します。Clear ボタンを

クリックすると、現在の

フィルタがクリアされま

す。 

PCB エディタ 
ワークスペースパネル

ボタンをクリックすると

関連するワークスペー

スパネルが表示され

ます。 
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デザインドキュメントの保存方法 
DXP のあらゆるデザインドキュメントや出力ファイルは、ユーザーのハードディスク上に個別ファイル

として保存されます。これらのファイルは、Windows エクスプローラで検索できます。プロジェクトフ

ァイルを作成するとデザインドキュメントへのリンクが設定されます。プロジェクトファイルは、デザ

インを検証して各ファイルの同期を取るために必要なファイルです。 

新規プロジェクトの作成 
DXP のプロジェクトは、デザインに関連するすべてのドキュメントと設定へのリンクで構成されていま

す。プロジェクトファイル(例えば xxx.PrjPCB)は、プロジェクトのドキュメントや関連する出力設定

(印刷や CAM など)を ASCII テキストファイルで表示したものです。プロジェクトに関連付けられていな

いドキュメントを ‘フリードキュメント’ と呼びます。PCB、FPGA、埋め込みパッケージ(VHDL)やライ

ブラリパッケージなど、回路図シートや対象とするアウトプットへのリンクは、プロジェクトに追加さ

れます。プロジェクトをコンパイルすると、デザインを検証し、ファイル間の同期を取り、比較を行う

ことができます。オリジナルの回路図や PCB などを変更すると、プロジェクトのコンパイル時に更新さ

れます。 

プロジェクトの新規作成プロセスは、すべてのプロジェクトタイプで同じです。ここでは PCB プロジェ

クトの例で説明します。まずプロジェクトファイルを作成し、次にブランクの回路図シートを作成して

空のプロジェクトを新しく追加します。このチュートリアルの後半ではブランクの PCB を作成し、同様

にプロジェクトに追加します。 

チュートリアルを開始するため、次の操作を実行して PCB の新規プロジェクトを作成します。 

1. デザインウィンドウの Pick a Task セクションで、Create a new Board Level Design Project をク

リックします。 

 

または、Files パネルの New セクションで Blank Project (PCB)をクリックします。このパネルが表

示されていない場合は、ワークスペース右下の Files ボタンをクリックするか、またはデザインマネ

ージャのパネル下部にある Files タブをクリックします。 

2. Projects パネルが表示されます。パネルには新しいプロジェクトファイルである PCB 
Project1.PrjPCB が表示されますが、ドキュメントは追加されません。 

 

3. File » Save Project As をセレクトし、新しいプロジェクトファイルをリネームします(拡張子

は.PrjPCB)。プロジェクトを保存するハードディスク上のディレクトリに移動し、File Name フィ

ールドでファイル名 Multivibrator.PrjPCB を入力して Save をクリックします。 

次に、空のプロジェクトファイルに追加する回路図を作成します。 

ここでは、非安定マルチバイブレータの回路図を作成します。 

回路図シートの新規作成 
以下の手順で回路図シートを新規に作成します。 

1. File » New » Schematic をセレクトするか、Files パネルの New セクションで Schematic Sheet を
クリックします。デザインウィンドウに、Sheet1.SchDoc というブランクの回路図シートが表示

されます。 
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2. File » Save As をセレクトし、新しい回路図ファイルをリネームします(拡張子は.SchDoc )。回路図を

保存するハードディスク上のディレクトリに移動し、File Nameフィールドでファイル名

Multivibrator.SchDocを入力して Save をクリックします。 

ブランクの回路図シートがオープンすると、ワークスペースが回路図エディタに切り替わります。メイ

ンツールバーには新しいボタンが追加され、新しいツールバーが表示されてメニューバーに新しいアイ

テムが加わります。これが回路図エディタです。 

このワークスペースをいろいろな形にカスタマイズすることができます。例えば、フローティングツー

ルバーの位置を変更できます。位置を変更するには、ツールバーのタイトル部分をクリックしたまま新

しい位置までドラッグします。ツールバーをドッキングするには、メインウィンドウの上下左右の端ま

で移動させます 

これでプロジェクトに新しい回路図を追加できました。次にデザインを取り込みます 

回路図シートのプロジェクトへの追加 
プロジェクトに追加したい回路図シートがフリードキュメントとしてオープンされている場合は、

Projects パネルの Free Documents セクションにある回路図ドキュメント上で右クリックを行い、Add 
to Project をセレクトします。回路図シートは、Projects タブでプロジェクト名が表示されている下側

の Schematic Sheets のところに移動し、プロジェクトとリンクします。 

回路図オプションの設定 
回路図を作成する前に、使用するドキュメントオプションの設定を行います。以下の手順で設定します。 

1. メニューから Design » Document Options をセレクトすると、Document Options ダイアログが表

示されます。このチュートリアルでは A4 の大きさの図面を使用しますので、Sheet Options タブの

Standard Styles フィールドを A4 に設定します。隣にある矢印をクリックすると、シートスタイル

が表示されます。 

2. A4 に設定するには、スクロールバーを使ってスクロールアップします。 

3. 設定ができたら OK ボタンをクリックしてダイアログボックスをクローズしてください。図面の大き

さが A4 に更新されます。 
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4. 図面全体を表示するには View » Fit Document をセレクトします。  
DXP には、マルチレベル

のアンドゥ機能があり、何

度でも操作をやり直すこと

ができます。アンドゥの最

大回数はユーザーが設定

できますが、使用するコン

ピュータの空き容量によっ

て制限されます。 

DXP では、メニューホットキー(メニュー名の下線が引かれた文字)を押すとそのメニューが表示されます。

また、いくつかのサブメニューにもキーが割り当てられています。例えば、View » Fit Document をセ

レクトするには、キーボードから V キーを押し、続いて D キーを押します。多くの場合、Edit » 
DeSelect のようなサブメニューは直接呼び出すことができます。例えば Edit » DeSelect » All メニュー

を実行するには、X キーを押して DeSelect メニューを直接呼び出し、続いて A キーを押します。 

次に、回路図の環境設定を行います。 

1. メニューから Tools »Schematic Preferences [ショートカット T, P]をセレクトします。これにより

Preferences ダイアログボックスが表示されます。このダイアログでは、作業する回路図シートすべ

てに適用するグローバル環境を設定します。 

2. Default Primitives タブをクリックして Permanent にチェックを入れます。設定ができたら OK ボ

タンでダイアログボックスをクローズしてください。 
回路図シートはドキュメン

トテンプレート(.dot) プとし

て保存し、会社のタイトル

ブロックやロゴ等の固有の

情報を含めることができま

す。 

3. 回路の作成を始める前に、File » Save [ショートカット F, S]をセレクトしてこの回路図シートを保

存します。 

回路図の作成 
これで回路図を作成する準備ができました。このチュートリアルでは図 1 の回路を使用します。ここで

は、2 個の 2N3904 トランジスタを使用した自動起動型の非安定マルチバイブレータ回路を作成します。 

 

図 1. 非安定マルチバイブレータ 

部品の取り出しとライブラリの登録 
DXP の回路図エディタには、数多く用意されている回路図シンボルを管理するための高度なライブラリ

検索機能が装備されています。以下の手順を実行し、このチュートリアルの回路を作成するために必要

なライブラリの登録を行ってください。  

まずトランジスタを検索します。使用するトランジスタは両方とも 2N3904 です。 

1. Libraries タブをクリックすると、Libraries ワークスペースパネルが表示されます。 

2. Libraries パネルで Search ボタンを押すか、または Tools » Find Component をセレクトします。

Search Libraries ダイアログが開きます。 

3. Scope が Libraries on Path に設定されていること、Library Type が Integrated に設定されているこ

と(すべての部品情報を含む統合ライブラリのみを検索するため)、そして Path フィールドには使用

するライブラリへのパスが正しく入力されていることを確認します。ライブラリへのパスは、DXP
インストール時のデフォルトでは C:\Program Files\Altium\Library\となります。ここでは

Include Subdirectories ボックスにチェックが入っていないことを確認します。 

4. 部品の名前に 3904 という文字がある部品をすべて検索してみます。まず Search Criteria セクション

で Name のテキストフィールドに *3904* と入力します(メーカーによって異なるプリフィックスや

サフィックスがつけられていることを考慮し、ワイルドカードのシンボル * を使用します)。 
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5. Search ボタンをクリックして検索を開始します。検索を開

始すると Results タブが表示されます。正しく記入されてい

ればライブラリファイルが検索され、Search Libraries ダイ

アログに表示されます。 

6. Miscellaneous Devices.IntLib をクリックしてセレク

トします。このライブラリにはシミュレーション用の BJT ト

ランジスタが入っています。 

7. Install Library ボタンをクリックして、このライブラリを回

路図エディタに登録します。但し、このライブラリはデフォ

ルトで既に登録されていますので、ボタンはグレイになって

いるはずです。 

8. Search Libraries ダイアログをクローズします。 

追加したライブラリは Libraries パネルの上部に表示されます。

上部のリストボックスでライブラリ名をクリックすると、下

側のリストには、そのライブラリに含まれている部品の一覧

が表示されます。パネルの Filter を使うとライブラリ内の部

品をすばやく見つけることができます。 

回路図上に部品を配置する 
最初に Q1 と Q2 の 2 つのトランジスタを配置します。配置する

位置は図 1 を参考にしてください。  

1. メニューから View » Fit Document [ショートカット V, D]を
セレクトし、回路図シート全体を表示します。 

2. ワークスペースパネルの Libraries タブをクリックすると、

Libraries パネルが表示されます。 

3. Q1 と Q2 は BJT トランジスタです。このライブラリをアク

ティブにするため、Miscellaneous Devices.IntLib を

クリックします。 

4. フィルタ機能を使用することにより、必要な部品をすばやく

見つけ出すことができます。ワイルドカード(*)を使用すると、

ライブラリの部品がすべてデフォルトで表示されます。フィ

ルタを設定するには、ライブラリ名の下にあるフィルタフィールドに*3904*と入力します。

Component Name フィールドの一部に “3904” という文字がある部品のリストが表示されます。 

5. リストから 2N3904 をクリックし、Place ボタンをクリックします。または、部品名をダブルクリッ

クします。 

カーソルが十字型に変化し、トランジスタの輪郭がカーソル上に現れます。この状態が部品配置モ
回路図の部品と PCB の部

品との関連付けは

Footprint(フットプリン

ト)により行われます。

回路図で指定したフット

プリントは、ネットリス

トを読み込む際、PCB ラ

イブラリから読み込まれ

ます。フットプリントを

設定するには、回路図上

の部品をダブルクリック

してください。 
ードです。カーソルを動かすと、トランジスタの輪郭がそれに応じて移動します。 

6. 図面上に部品を配置する前に、まず必要なプロパティを記入します。トランジスタがカーソルと一

緒に移動している間に、TAB キーを押します。部品の Component Properties ダイアログが表示され

ます。 

8 



 

 

7. ダイアログの Properties セクションで、Designator フィールドに Q1 と入力して最初の部品番号を

設定します。 

8. 次に PCB の部品を表すフットプリントを確認します。このチュートリアルでは統合ライブラリを使

用したため、フットプリントや回路シミュレーションには推奨モデルが使用されています。Models
リストに BCY-W3/D4.7 という型番が表示されていることを確認します。その他のフィールドは、

すべてデフォルト値のままにしておきます。 

これで部品を配置する準備が完了しました。 

1. カーソルをシートの中央から少し左に(トランジスタも一緒に)、移動します。 

2. 位置が決まったら、左クリックするかまたは ENTER キーを押してトランジスタを配置します。 

3. カーソルを移動すると、先に配置されたのと同じトランジスタが現れます。部品配置モードの状態

が継続されているため、同じ部品を連続して配置することができます。それでは 2 個目のトランジ

スタを配置してください。このトランジスタは先に配置したトランジスタと同じですので、属性を

設定する必要はありません。DXP で同じ部品を続けて配置する場合、部品番号が自動的にインクリ

メントされます。この場合、次のトランジスタは Q2 になります。 
プレートカーソルで部品を移動

しているときには、次の操作が

できます： 

Y キーを押すと部品の向きが

上下逆になります。 

X キーを押すと部品の向きが

左右逆になります。 

スペース キーを押すと 90°ず

つ回転します。 

4. 図 1 を見ると、Q2 のトランジスタは Q1 のトランジスタと逆向きに

配置されていることがわかります。トランジスタの向きを変えるに

は、カーソルでトランジスタを移動しているときに X キーを押しま

す。これにより水平方向に向きが変わります。 

編集モードや部品の配置モード（カー

ソルが十字になっているとき）では、

カーソルがドキュメントのウィンドウの

端に来ると、画面が自動的にスクロ

ールします。 

スクロールし過ぎた場合、キーボード

を V, F (View » Fit All Objects) ボ
と続けて押し、配置されているオブジ

ェクトがすべて表示されているように

します。オブジェクトの配置中でも表

示に関する操作を実行することがで

きます。 

5. カーソルを Q1 の右側に移動してください。部品を配置する位置を

正確に指定したい場合には、PAGEUP キーを押して図面を拡大して

ください。図面を拡大すると、グリッドが表示されます。 

6. 部品を配置する位置が決まったらマウスを左クリック、または

ENTER キーを押します。Q2 のトランジスタが配置されます。引き

続き配置モードになり、カーソルと一緒にトランジスタが表示され

ます。 

7. これですべてのトランジスタの配置が完了したので、マウスを右ク

リックするか、または ESC キーを押して部品の配置を終了します。カーソルが通常の矢印に戻りま

す。 
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次に抵抗を 4 個配置します。 

1. Libraries パネルの Miscellaneous Devices.IntLib がアクティブになっていることを確認しま

す。 

2. ライブラリ名の下にあるフィルタフィールドに res1 と入力してフィルタを設定します。 

3. 部品リストで RES1 をクリックし、Place ボタンをクリックします。これによりカーソルの上に抵

抗が表示されます。 

4. TAB キーを押して、抵抗の属性を設定します。ダイアログの Properties セクションで、

Designator フィールドに R1 と入力して最初の部品番号を設定します。 

5. Models リストに AXIAL-0.3 と表示されていることを確認します。 
図面上に配置された部品

の属性を変更するには、

部品をダブルクリックし、

Component Properties ダ
イアログをオープンしま

す。 

6. 抵抗のパラメーターフィールドを設定し、回路図に表示します。この値はチュートリアルの後半で

回路シミュレーションを実行する際に使用します。Value パラメーターは、コンポーネントの一般的

な情報として使用する事が可能ですが、ディスクリート部品ではシミュレーションの際にこの値を

使用します。また、PCB エディタでコメント情報として割り当てられている Comment を設定する

事も可能です。DXP では、Comment フィールドの内容をパラメーターで置き換える、間接的な参照

をサポートしており、同じ値を二回設定する（パラメーターValue と Comment フィールド）必要は

ありません。 パラメーターValue 欄をクリックし、値（Value）を 100k としてください。

（Parameters リストで Value の名前を選択している場合は、Edit を押します。） 

（このコンポーネントでは、Value というパラメーターが含まれているはずですが、もし、無い場合

は Parameter リストの下にある Add をクリックし、Parameter Properties ダイアログを表示します。

Value という名称を入力し、値を 100k とします。パラメーターのタイプとして String を選択しま

す。Value の Visible はチェックし、OK をクリックします。） 

7. ダイアログの Properties セクションで Comment フィ－ルドをクリックし、ドロップダウンリスト

から =Value を選び、Visible のチェックをはずします。OK ボタンをクリックし、ダイアログをク

ロ－ズし、部品配置モ－ドに戻ります 

8. 抵抗を 90°回転するには SPACEBAR を押します。 

9. 図 1 のように抵抗を Q1 のベース側へ配置します。マウスを左クリックするか、または ENTER キー

を押すことで部品が配置されます。 

この時点では、トランジスタと抵抗の接続について考える必要はありません。部品間の接続は後で

行います。 

10. 次に 100k の抵抗 R2 を Q2 のベース側へ配置します。2 つ目の抵抗を配置すると、部品番号が自動

的にインクリメントされます。 

11. 残りの R3 と R4 の 2 つの抵抗は値が 1k ですので、TAB キーを押して Component Properties ダイア

ログを表示し、Value の値を 1k に変更します。 

12. 図 1 の回路図を参考にして R3 と R4 を配置します。 

13. 抵抗をすべて配置したら、右クリックするかまたは ESC キーを押して部品配置モードを終了します。 

次にコンデンサを 2 個配置します。 

1. コンデンサも Miscellaneous Devices.IntLib にあり、すでに Libraries パネルで選択されて

います。 

ト 2. Libraries パネルの部品のフィルタフィールドで cap と入力します。 

3. 部品リストから CAP をクリックし、Place ボタンをクリックします。これによりカーソルの上にコ

ンデンサが表示されます。 

4. TAB キーを押して、コンデンサの属性を設定します。Component Properties ダイアログの

Properties セクションで Designator を C1 に設定し、PCB フットプリントモデル RAD-0.3 が

Models リストに追加されていることを確認して、値が 20n の Comment パラメータを作成します。 
オブジェクトを移動するに

は、カーソルをオブジェク

上に移動し、マウスの左ボ

タンを押さえたままカーソ

ルを移動します。そしてマ

ウスの左ボタン放すとその

位置に部品が置かれま

す。 
5. Parameter フィ－ルドの設定が回路図に表示されます。Parameter リストの Value 欄をクリックし、

値（Value）を 20n としてください。（このコンポーネントも、Value というパラメーターが含ま

れているはずですが、もし、無い場合は Parameter リストの下にある Add をクリックし、
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Parameter Properties ダイアログを表示します。Value という名称を入力し、値を 20n とします。

パラメーターのタイプとして String を選択します。Value の Visible はチェックし、OK をクリック

します。） 

6. ダイアログの Properties セクションでコメントフィ－ルドをクリックし、ドロップダウンリストか

ら =Value を選択し、Visible のチェックをはずします。OK ボタンをクリックし、部品配置モ－ド

に戻ります。 

7. コンデンサも抵抗と同じ方法で位置を決めて配置します。 

8. 右クリックするか、または ESC キーを押して配置モードを終了します。 

最後にコネクタを配置します。コネクタは Miscellaneous Connectors.IntLib にあります。 

1. 配置するのは 2 ピンのコネクタです。フィルタを *2* に設定します。 

2. パネルのリストから HEADER2 をマウスでセレクトし、Place ボタンをクリックします。TAB キー

を押して属性を編集し、Designator を Y1 に、PCB フットプリントモデルを HDR1X2 に設定します。

設定ができたら OK ボタンをクリックしてダイアログをクローズします。 

3. コネクタを配置する前に、X キーを押してコネクタを正しい向きに修正します。その後でコネクタを

回路図上に配置します 

4. 右クリックするか、または ESC キーを押して配置モードを終了します。 

5. メニューから File » Save[ショートカット F, S]をセレクトし、回路図を保存します。 

これですべての部品の配置が完了しました。図 2 に示すように、部品間には配線を行うためのスペース

が必要です。これは、ピンの下を横切ってその向こうにあるピンにワイヤを配置することができないた

めです。そのように配置すると、どちらのピンもワイヤに接続されてしまいます。 

移動するには部品をクリックし、マウスを押さえ続けたままカーソルを移動します。 

 

図 2. 全部品が配置された回路図. 

回路の接続 
次に、配置した部品間をワイヤによって接続します。部品間の接続を行うには、図 1 を参照して以下の

手順を行ってください。 

1. メニューから View » Fit All Objects [ショートカット V, F]をセレクトして、回路図シートの全体を

表示します。 

2. まず、次の方法でトランジスタ Q1 のベースに抵抗 R1 を配線します。メニューから Place » Wire 
[ショートカット P, W]をセレクト、またはワイヤリングツールバーから Wire ボタンをクリックして

ワイヤの配置を開始します。カーソルの形状が十字型に変わります。 

3. カーソルを R1 の下端に移動します。カーソルを適切な位置に移動すると、赤い接続マーカー(大き

なアスタリスク)が現れます。これは、カーソルが部品の電気的な接続点にあることを示しています。 

11 



 

4. ワイヤを開始する点で左クリックするか、または ENTER キーを押します。カーソルを移動すると最

初にクリックした点から、現在のカーソル位置へワイヤが引かれるのが確認できます。 

5. カーソルを R1 下のトランジスタ Q1 の左側まで垂直に移動しま

す。左クリックするか ENTER キーを押すと、クリックした位

置でワイヤが折れ曲がります。最初にクリックした位置とこの

位置の間にワイヤが配置されます。 

6. カーソルを Q1 のベースに置くと、赤い接続マーカーに変わり

ます。左クリックするか ENTER キーを押すと、Q1 のベースに

ワイヤが接続されます。 

7. 右クリックするか ESC キーを押すと、このワイヤの配置は終了

します。ただしカーソルが十字のままであれば、引き続き他の

ワイヤを配置することができます。もう一度右クリックするか

ESC キーを押すと配置モードが終了してカーソルの形状が矢印

に戻りますが、今はこのままにしておきます。 

8. 次に C1 を Q1 と R1 に配線します。カーソルを C1 の左の接続

点に移動して左クリックするか、または ENTER キーを押すと、

新たに配線が開始されます。 

9. Q1 のベースと R1 が接続されているワイヤ上までカーソルを移

動します。接続マーカーが表示されます。 

10. 左クリックするか ENTER キーを押してワイヤを配置し、次に

右クリックするか ESC キーを押して配線を終了します。2 本のワ

11. 残りの回路を接続すると、結果は図 3 のようになります。 

図 3. 配線が完了した回路図 

12. 配線がすべて完了したら、右クリックするか ESC キーを押して配

が通常の矢印に戻ります 

ネットとネットラベル 
接続されるそれぞれの部品ピンの集まりをネットといいます。例えば、

R1 のピン、C1 のピンが含まれます。 

デザイン中の重要な箇所を簡単に識別するためにネットラベルが追加で

2 個の電源ネットにネットラベルを配置するには、次の操作を実行しま

1. メニューから Place » Net Label をセレクトします。カーソル上に

2. 配置する前にネットラベルを編集するため、TAB キーを押して N
す。 
配置されたワイヤの形状やオブジェクトを変更

するには、カーソルをワイヤやオブジェクトの

上に移動し、マウスをクリックします。 

ワイヤが部品の接続点を横切ったり、ワイヤ

同士を接続した場合には、DXP により自動的

にジャンクションが配置されます。 

ワイヤの配置中には以下の操作が可能で

す。 

- マウスを左クリックまたは ENTER キーを押

すと、カーソルの位置でワイヤが折れ曲がり

ます。 

- BACKSPACE を押すとワイヤの頂点が削

除されます。 

- 最後のワイヤを配置したら、右クリックする

か、または ESC キーを押してワイヤ配置を終

了します。カーソルが十字のままであれば、引

き続き他のワイヤを配置することができます。

- もう一度右クリックするか、または ESC キー

を押すとワイヤ配置モードを終了します。 
イヤが自動的に接続されます。 
ワイヤがピンの終端と交

差している場合は、ジャン

クションを削除しても接続

されます。先に進む前に回

路図が図 3 のように作成

されているか確認してくだ

さい。 
 

線モードを終了します。カーソル

あるネットには Q1 のベース、

きます。  

す： 

点線の箱が表示されます。 

et Label ダイアログを表示させま
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3. Net フィールドに 12V と入力し、OK ボタンをクリックしてダイアログをクローズします。 

4. ネットラベルの左下がワイヤと接触するように配置します。ネットラベルがワイヤに接触すると、

カーソルは赤い十字に変わります。 

5. 最初のネットラベルを配置した後も、ネットラベルの配置モードが継続されます。2 つめのネットラ

ベルを配置する前に編集するため、再度 TAB キーを押します。 

6. Net フィールドに GND と入力し、OK ボタンをクリックしてダイアログをクローズし、ネットラベル

を配置します。 

7. File » Save [ショートカット F, S]をセレクトして回路を保存します。 

これで回路図が完成しました。 

この回路図をプリント基板にする前に、プロジェクトのオプションを設定します。 

プロジェクトのオプション設定 
プロジェクトのオプションには、エラーチェック用のパラメーター、接続マトリックス、Comparator 設
定、ECO 生成、サーチパスがあり、サーチパスでは、ライブラリのようなドキュメントや指定するプロ

ジェクトパラメータをプログラムが検索するフォルダを表示します。DXP では、こうした設定を使用し

てプロジェクトをコンパイルします。 

プロジェクトがコンパイルされると、全体的なデザインルールや電気的なルールに基づいてデザインが

検証されます。エラーの修正が終わると、回路図が再コンパイルされ、生成された ECO によって PCB
ドキュメントなどの対象とするドキュメントに読み込まれます。プロジェクトの Comparator によりソー

スファイルとターゲットファイルの相違点を見つけ、双方向で更新する(ファイルの同期を取る)ことがで

きます。 

エラーチェック、ドキュメント比較、ECO 作成など、プロジェクトに関連する操作はすべて Options for 
Project ダイアログ(Project » Project Options )で設定します。 

ネットリスト、シミュレータ、ドキュメント(印刷)、組立と製造アウトプット、レポートなどのプロジェ

クトアウトプットはすべて Outputs for Project ダイアログで設定します。詳細は、「プロジェクトアウト

プットの設定」を参照してください。 

1. Project » Project Options をセレクトします。Options for Project ダイアログが表示されます。 

 

プロジェクトに関連するオプションはすべてこのダイアログで設定します。 

回路図の電気属性のチェック 
DXP の回路図エディタは単なる図面作成ツールではありません。これには回路の電気的接続情報も含まれ

ており、この機能を利用して設計した図面を検証することができます。プロジェクトをコンパイルする際、

DXP の Error Reporting タブと Connection Matrix タブで設定したルールに従ってエラーがチェックされ、

違反があった場合は Messages パネルに表示されます。 
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Error Reporting の設定 

Options for Project ダイアログの Error Reporting タブで、作画上のチェック項目を設定します。Report 
Mode は違反の程度を示します。Report Mode を変更するには、変更する違反項目の隣にある Report 
Mode をクリックし、ドロップダウンリストで程度を選択します。このチュートリアルでは、デフォルト

の設定を使用します。 

Connection Matrix の設定 
エラーレポートを実行してデザイン内の電気

的接続(ピン、ポート、シートエントリ間の接

続)をチェックすると、Options for Project ダイ

アログボックスの Connection Matrix タブに、

発生したエラーの程度が表示されます。マト

リックスでは、回路図に使用されている様々

なピンの種類の接続状態をチェックすること

ができます。  

例えば、マトリックスの右側に Output Pin が

あります。この列と Open Collector Pin とが

交差する位置に注目してください。交差する

場所がオレンジ色で表示されています。これ

は、出力ピンがオープンコレクタピンと接続

されていた場合に、プロジェクトのコンパイ

ル時にエラーが発生することを示しています。  

エラータイプは、報告しないものから致命的

エラーまで、エラーの程度によって設定でき

ます。  

Connection Matrix を変更するには、次の操作

を実行します： 

1. Options for Project ダイアログで Connection Matrix タブをクリックします。 

2. 2 つの接続タイプ、例えば Output Sheet Entry と Open Collector Pin が交差する場所をクリックしま

す。 

3. 交差するボックスの色が凡例で示したエラーの色に変わるまでクリックします。例えば、オレンジ

色はその接続によってエラーが発生することを表します。 

このチュートリアルで作成した回路には、Passive Pins(抵抗、コンデンサ、コネクタのピン)と Input 
Pins (トランジスタのピン)のみが使用されています。この接続マトリックスで、未接続のパッシブピンを

見つけられるかチェックしてください。 

1. マトリックスの横の列から Passive Pin を見つけてください。次に縦の列から Unconnected を見つ

けてください。両方の列が交差する所には、パッシブピンが未接続の場合のエラー状態が示されま

す。デフォルトでは緑色なので、エラーレポートは作成されません。 

2. 次にこのボックスを黄色になるまでクリックし、パッシブピンが未接続だとプロジェクトをコンパ

イルした場合にワーニングを報告するようにします。ここでは、このチュートリアルの後半でチェ

ックするために、意図的にエラーが出るようにしています。 

Comparator の設定 
Options for Project ダイアログの Comparator タブでは、プロジェクトのコンパイル時にファイル間の相

違点を報告するか、しないかを設定します。このチュートリアルでは、階層的な回路設計のみに基づく

機能面での違いを表示する必要はありません。 

1. Comparator タブをクリックし、Difference Associated with Components セクションで Changed 
Room Definitions、Extra Room Definitions、Extra Component Classes を見つけます。 

2. 右側にある Mode 列で、ドロップダウンリストから Ignore Differences をセレクトします。 
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これでプロジェクトをコンパイルしてエラーをチェックする準備ができました。 
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プロジェクトのコンパイル 
プロジェクトをコンパイルすると、デザインドキュメントの作画上のエラーや電気的ルールのエラーを

チェックして、デバッグを行えるようになります。このチュートリアルでは、Options for Project ダイア

ログの Error Reporting タブと Connection Matrix タブでルールを設定しています。 

1. Multivibrator プロジェクトをコンパイルするには、Project » Compile PCB Project をセレクトしま

す。 

2. プロジェクトのコンパイル時に発生したエラーは、デザインウィンドウ下部の Messages パネルに

表示されます。コンパイルしたドキュメントは Compiled パネルに一覧表示され、水平階層、リス

ト表示された部品とネット、閲覧可能な接続モデルも同時に表示されます。 

正しく回路図が作成された場合、Messages パネルはブランクになります。エラーメッセージが表示され

た場合は回路をチェックし、すべてのワイヤと結線が正しいか確認してください。 

それでは故意にエラーが発生するように回路図を変更した後、プロジェクトを再コンパイルしてみまし

ょう： 

1. デザインウィンドウ上部にある Multivibrator.SchDoc タブをクリックし、回路図をアクティブ

ドキュメントにします。 

2. C1 とトランジスタ Q1 のベースを接続しているワイヤをクリックします。小さな四角の編集ハンド

ルがワイヤの両端に表示され、ワイヤに沿って選択状態を示す点線が選択した色で表示されます。

ワイヤを削除するには DELETE キーを押します。 

3. Project » Compile PCB Project をセレクトしてプロジェクトを再コンパイルし、エラーメッセージ

がないか確認します。 

Messages パネルがオープンし、回路に未接続の入力ピンがあるというワーニングメッセージが表示

されます。また、Project Options ダイアログの Error Reporting タブのオプションにより、入力ピ

ンがフローティング状態になっている場合のエラーを検出できます Messages パネルのメッセ

ージをクリアするには、ウィ

ンドウを右クリックして 
Clear All を実行します。 

4. Messages パネルのエラーをクリックすると、Compile Error ウィンドウに違反の詳細が表示されま

す。このウィンドウでエラーをクリックすると違反しているオブジェクトが回路図に表示され、エ

ラーのチェックや修正ができます。 

では、このセクションを終了する前にエラーを修正してください。 

1. 回路図シートのタブをクリックし、アクティブにします。 

2. メニューから Edit » Undo [ショートカット E, U]をセレクトします。削除したワイヤが復元されます。 

3. アンドゥを実行してワイヤが復元されたら、Project » Compile PCB Project をセレクトしてプロジ

ェクトを再コンパイルし、エラーが表示されないことを確認します。Messages パネルにはエラーメ

ッセージが表示されないはずです。 

4. メニューから View » Fit All Objects [ショートカット V, F]をセレクトして回路図を復元し、エラー

のない回路図を保存します。 
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PCB ドキュメントの新規作成 
回路図エディタから PCB エディタへデザイン情報を転送する前に、基板外形のみが含まれているブラン

クの PCB ファイルを作成する必要があります。DXP で PCB ファイルを新規作成するには、PCB ウィザ

ードを使用する方法があります。ウィザードでは標準規格の基板外形がサポートされており、カスタム

サイズの基板も作成可能です。ウィザードでは、いつでも Back ボタンを押して前の画面に戻り、内容の

確認や修正ができます。 

PCB ウィザードで新規 PCB を作成するには、次の手順を実行します： 

1. Files パネル下部の New from Template セクショ

ンで PCB Board Wizard をクリックすると、PCB
を新規に作成できます。画面にこのオプションが

表示されない場合は、上向き矢印をクリックして

いくつかのセクションをクローズします。 

2. PCB Board Wizard がオープンしま

す。まずイントロダクショ

ン画面が表示されます。

Next ボタンをクリックして

次に進みます。 

3. 単位を Imperial（インチ系）

に設定します。1000 mils が

1 インチです。 

4. 次の画面では使用する基板

外形を選択します。このチ

ュートリアルでは、独自の

基板サイズを設定すること

にします。基板外形のリス

トから Custom を選択して Next ボタ

ンをクリックします。 

5. 次の画面では、カスタムボードオプションを入力

します。このチュートリアルの回路には、2x2 イン

チのボードであれば充分なスペースが確保できま

す。Rectangular を選択して Width フィールドと

Height フィールドに 2000 と入力します。Title 
Block & Scale、Legend String 、Dimension Lines は選択解除します。Next ボタンをクリックし

て次に進みます。  

6. この画面ではボードのレイヤー数を指定します。ここではシグナルレイヤーが 2 つ必要ですが、パ

ワープレーンは必要ありません。Next ボタンをクリックして次に進みます。 

7. Thru-hole vias only を選択してデザインで使用するビアスタイルを指定し、Next ボタンをクリック

します。 

8. 次の画面では、部品およびトラックテクノロジ(配線)のオプションを設定します。Thru-hole 
components オプションを選択し、Number of tracks between adjacent pads を One Track に設定

します。Next ボタンをクリックして次に進みます。 

9. 次の画面では、ボードに適用するデザインルールを設定します。この画面のオプションはデフォル

トのままにしておきます。Next ボタンをクリックして次に進みます。 

10. この最後の画面では、作成するカスタムボードをテンプレートとして保存し、入力したパラメータ

によるボードを新規に作成できます。チュートリアルではテンプレートとして保存しないため、こ

のオプションにはチェックを入れません。Finish ボタンをクリックし、ウィザードを終了します。 

11. PCB ウィザードにより、ボードを新規作成するために必要な情報がすべて揃いました。PCB エディ

タに新しい PCB ファイル PCB1.PcbDoc が表示されます。 
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12. PCB ドキュメントには、デフォルトサイズの無地のシートとブランクのボードシェイプ(黒い領域と

グリッド)が表示されますシートを非表示にするには、Design » Board Options をセレクトし、

Board Options ダイアログの Display Sheet を選択解除します。 

 

の

DXP で提供されている他の PCB テンプレートから、独自の外形線、グリッド設定、タイトルブロッ

クを追加できます。ボードシェイプ、シート、テンプレートの使い方の詳細は、「ボードシェイプ

とシート」のチュートリアルを参照してください。 

13. シートを非表示にし、View » Fit Board [ショートカット V, F ]をセレクトしてボードシェイプのみ

を表示します。 
さらにチュートリアルが必

要な場合は、 F1 を押すと

DXP ヘルプとオンラインド

キュメントが表示されま

す。Articles & Tutorials
リンクをクリックして下さ

い。 

14. PCB ドキュメントは、自動的にプロジェクトに追加（リンク）され、Projects タブ内のプロジェク

ト名下側の PCBs のところに移動します。 

14. File » Save As をセレクトして新しい PCB ファイルをリネームします(拡張子は .PcbDoc)。PCB を

保存するハードディスク上のディレクトリに移動し、ファイル名を Multivibrator.PcbDoc とし

て保存します。 

新しい PCB をプロジェクトに追加 
プロジェクトに加えたい PCB が Free Document としてオープンされている場合、Projects パネルの

Free Document 内の PCB ドキュメントを右クリックし Add to Project をセレクトします。Projects タブ

にあるプロジェクト名の PCBs に PCB ドキュメントが追加されます。 

デザイン情報の転送 
ブランクの新しい PCB に回路情報を転送する前に、すべてのライブラリが回路図と PCB の両方で使用

できることを確認します。このチュートリアルではデフォルトの統合ライブラリだけを使用しているた

め、あらかじめフットプリントも含まれています。プロジェクトをコンパイルして回路図のエラーを修

正したら、Update PCB コマンドを使用して ECO を生成し、対象とする PCB に回路情報を転送します。 

PCB の更新 
プロジェクトで対象とする PCB に回路情報を送るには、次の操作を実行します： 

1. 回路図を表示し、Design » Update PCB  (Multivibrator.PcbDoc)をセレクトします。プロジェ

クトがコンパイルされ、Engineering Change Order ダイアログが表示されます。 
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2. Validate Changes をクリックします。変更がすべて確認されると、Status リストにチェックが表示

されます。変更内容が確認されなければ、ダイアログをクローズして Messages パネルをチェック

し、エラーがあればクリアします。 

Report Changes ボタン

をクリックすると、ECO の

レポート作成して印刷でき

ます。 

3. Execute Changes をクリックすると、変更内容が PCB に送られます。完了すると、Status が Done
に変わります。 

4. Close をクリックすると対象とする PCB がオープンし、図 4 に示すように部品をボードに配置でき

る状態になります。コンポーネンが表示されない場合は、ショートカット V, D（View Document）
を使ってください。 

 

図 4. ボードの横に並べられた配置前の部品 

PCB の設計 
PCB に部品を配置し、ボードに配線を行います。 

PCB ワークスペースの設定 
ボードの部品配置を始める前に、グリッド、レイヤー、デザインルールなどの PCB ワークスペースの設

定を行います。 

グリッド 
部品配置を始める前に、配置グリッドが正しく設定されていることを確認します。PCB ワークスペース

にあるすべてのオブジェクトは、スナップグリッド上に配置が行われます。このグリッドは配線条件に

合うように設定する必要があります。 

このチュートリアルの回路では、パッド最小間隔が 100 mil の標準的なインチ系の部品を使用します。こ

の部品のパッド間隔をグリッドに合せるためには、スナップグリッドを 50、25 mil のように 100 mil の分

数で設定してください。この PCB では、トラック幅とクリアランスをそれぞれ 12 mil と 13 mil (PCB ボ

ードウィザードのデフォルト値)に設定することにより、平行なトラックのセンター間が 25 mil になりま

す。以上のことから、ここでもっとも適したスナップグリッドサイズは、25 mil になります。 

次の手順に従い、スナップグリッドを設定してください：  
PCB エディタでサポートさ

れている単位系はインチと

メートルです。View » 
Toggle Units をセレクト

すると、単位系が切り替わ

ります。 
1. メニューから Design » Board Options [ショートカット D, O]をセレクトします。Board Options ダ

イアログが表示されます。 

2. Grids タブで、Snap X、Snap Y 、Component X 、Component Y の値を 25mil に設定します。

このダイアログでは、エレクトリカルグリッドの設定も行えます。エレクトリカルグリッドは、電

気的なオブジェクトを配置する場合に、スナップグリッドに関係なく電気的なオブジェクトに引き

込む機能です。OK ボタンをクリックしてダイアログをクローズします。 

部品の配置をより容易に行うために、他のいくつかの設定を行います。 

1. メニューから Tools » Preferences [ショートカット T, P]をセレクトし、System Preferences ダイア

ログをオープンします。Options タブの Editing Options セクションで、Snap to Center のオプショ

ンにチェックが入っていることを確認します。これで部品を掴んだとき、カーソルが部品の基準点

に移ります。 
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2. System Preferences ダイアログの Display タブをクリックしてアクティブにします。このタブの

Show セクションで、Show Pad Nets、Show Pad Numbers、Via Nets オプションのチェックをは

ずします。このダイアログの Draft Thresholds セクションで、Strings の値を 4 ピクセルに設定し、

ダイアログをクローズします。 

レイヤースタックとその他のレイヤーの設定 
PCB ワークスペースの下部には、レイヤータブがいくつか表示されています。PCB エディタでは複数の

レイヤーを扱いますが、ほとんどの編集作業は特定のレイヤーに対して操作を行うことになります。

Design » Board Layers & Colors をセレクトすると Board Layers ダイアログが表示されます。このダイ

アログでは、レイヤーの表示、追加、削除、リネーム、および色の設定を行います。 

 

PCB エディタには、次の 3 種類のレイヤーがあります： 

• 電気的なレイヤー – 電気的なレイヤー - 電気的なレイヤーには、32 のシグナルレイヤーと 16 のプレ

ーンレイヤーがあります。電気的なレイヤーは、レイヤースタック・マネージャにより追加や削除

が行えます。このダイアログは、Design » Layer Stack Manager をセレクトすると表示されます。 

• メカニカルレイヤー – 基板外形の定義や寸法線、組立の詳細、その他の機構的な情報等に使用され

るメカニカルレイヤーは、16 層用意されています。これらのレイヤーはプリントアウトやガーバー

出力に加えることができます。メカニカルレイヤーの追加、削除、名前の設定は、Board Layers ダ

イアログで行います。 

• 特別なレイヤー – 特別なレイヤーとしては、トップとボトムシルクスクリーンレイヤー、ソルダー

マスクレイヤー、ペイストマスクレイヤー、ドリルレイヤー、キープアウトレイヤー(電気的な領域

を示すために使用されます)、マルチレイヤー(マルチレイヤーのパッドとビアに使用されます)、接

続レイヤー、DRC エラーレイヤー、グリッドレイヤー、ホールレイヤーがあります。これらの特別

なレイヤーの表示設定は、Board Layers ダイアログで行います。 

レイヤースタック・マネージャ 
このチュートリアルのデザインは簡単なので、片面基板か両面基板で配線することができます。デザイ

ンが複雑になれば、レイヤースタック・マネージャでレイヤーを追加します。 

1. Design » Layer Stack Manager をセレクトし、Layer Stack Manager ダイアログを表示します。 
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2. 新たにレイヤー、およびプレーンレイヤーを追加する場合、新しいレイヤーは現在選択されている

レイヤーの下に加えられます。Copper thickness や Dielectric properties 等のレイヤープロパティは、

伝送線路解析に使用されます。OK ボタンをクリックしてダイアログをクローズします。 

この新しいボードで使用しないレイヤーが表示されている場合には、不必要なレイヤーを非表示にして

ください。 

レイヤーを非表示にするには、以下の手順を実行します： 

1. ショートカットキーの L を押して Board Layers ダイアログを表示します。 

2. 右クリックして Used On をセレクトすると、オブジェクトが配置されていないレイヤーは非表示に

なります。 

3. 4 つのマスクレイヤー（Mask）とドリルドローイング・レイヤー（Drill Drawing）は、それぞれの

レイヤー名の隣にある Show ボタンのチェックをはずすと非表示になります。OK ボタンをクリック

してダイアログをクローズします。 

新しいデザインルールの設定 
DXP の PCB エディタは、ルールドリブン設計環境です。この設計環境では、PCB エディタでトラック

の配置、部品の移動、自動配線の実行などを行ってデザインを変更した場合、PCB エディタはそれぞれ

の操作をモニターし、デザインルールが守られているかどうかをチェックします。そしてルールが守ら

れていない場合には、その箇所をハイライト表示します。  

ではデザインルールを設定したあと次の作業に進み、どのようにデザインエラーが表示されるか確認し

てみましょう。 

デザインルールには 10 のカテゴリがあり、さらにデザインルール・タイプに細かく分類されています。

デザインルールは、電気的(Electrical)、配線(Routing)、製造(Manufacturing)、配置(Placement)、伝送線

路解析(Signal Integrity)をカバーしています。 

それでは、電源のネットに関する線幅を指定するデザインルールを設定してみます。 

これらのルールを設定するには、以下の手順を実行して下さい： 

1. PCB をアクティブなドキュメントにして、メニューから Design » Rules をセレクトします。 

2. PCB Rules and Constraints Editor ダイアログが表示されます。ダイアログの左側にある Design 
Rules パネルに、ルールの各カテゴリが表示されます。Routing をダブルクリックするとカテゴリが

展開され、配線ルールが表示されます。次に Width をダブルクリックすると、利用可能な線幅ルー

ルが表示されます。 
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3. Design Rules パネルの各ルールをクリックします。各ルールをクリックすると、ダイアログの右上

セクションにはルールのスコープ(ルールの対象とするもの)が、右下セクションにはルールの内容が

表示されます。これらのルールには、デフォルトのものと、PCB ドキュメントを新規作成したとき

に Board Wizard で設定したものとがあります。 

4. Width をクリックすると、このルールのスコープと内容が表示されます。このルールはボード全体

に適用されます。 

 

DXP の強力な機能の 1 つであるデザインルール・システムは、同じタイプのルールをそれぞれ異なるオ

ブジェクトに対して、複数設定することができます。ルールの対象となるオブジェクトの集まりは、ル

ールのスコープで指定します。ルールシステムでは、あらかじめ定義された階層に基いて各オブジェク

トに対してルールが与えられます。 

例えば、Width constraint ルールが Whole board(すべてのトラックがこの幅であることを意味します)で、

2 つめの Width constraint ルールがグランドネットの場合、このルールは前のルールを無視します。さら

に 3 番目がグランドネットの特定のセグメントに関するものであれば、このルールは前の 2 つのルール

を無視します。ルールは優先順に表示されます。 

ここでは Width constraint ルールは 1 つしか設定されておらず、これが Whole board（基板全体）に適用

されています。次に、12V ネットと GND ネットに新しい Width constraint ルールを追加します。Width 
constraint ルールを新たに追加するには、以下の手順を実行して下さい： 
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1. Design Rules パネルで Width カテゴリを選択し、右クリックして New Rule を選択し、12V ネット

だけを対象に Width constraint ルールが新しく追加します。 

新しいルール名 Width_1 が表示されます。Design Rules パネルでこの新しいルールをクリックし

て、スコープと内容を修正します。 

2. Name フィールドに 12V or GND と入力します。PCB Rules and Constraints Editor ダイアログをク

ローズすると、Design Rules パネルの名前が更新されます。 

3. 次に Query Builder を使ってルールスコープを設定します。正しい構文が判っていれば、スコープに

直接入力できます。  

Where the First object matches セクションで Net をクリックします。Query Kind セクションに  
InNet( ) と表示されます。All ボタンの隣のドロップダウンリストクリックして使用できるネット

のリストから 12V を選択します。構文が InNet (‘12V’)に更新されます。 

 

4. 次に Query Helper でスコープを拡張し、ネット GND に対しても同じ設定を行ないます。 
Advanced (Query) をクリックし、更に Query Helper をクリックします。Query Helper ダイアログ

が表示されます。 

 

5. Query セクションの InNet(‘12V’) の後でクリックし、Or ボタンをクリックします。構文が   
InNet(‘12V’) or に変わります、Or で別のネットにルールが適用できるようになります。 
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6. PCB Functions カテゴリの Membership Checks をダブルクリックし、Name セクションから InNet 
をダブルクリックします。  

7. Query セクションに新しい構文  InNet( ) が追加され、括弧内に利用可能なネット名が表示されま

す。そこで GND をクリックして選択します。あるいは、PCB Objects List カテゴリの Nets をクリ

ックし。リストから GND を選びます。InNet(‘12V’) or InNet(‘GND’) という構文が作成され

ます。  

8. Check Syntax をクリックして構文が正しいことを確認し、OK をクリックして 表示されたメッセー

ジをクローズします。エラーメッセージが表示された場合は構文を修正します。 

9. これらの確認が終われば、OK ボタンをクリックして Query Helper ダイアログをクローズします。

Full Query セクションのスコープが更新されます。  

10. PCB Rules and Constraints Editor dialog ダイアログの一番下のセクションにある Minimum, 
Preferred, Maximum 幅フィールドで、これまでのルールである 10mil をクリックして新しい値を入

力し、25mil に変更します。Minimum の値を変更する前にまず、Maximum の値を変更する必要が

ありますので、注意してください。新しいルールが設定され、別のルールを選択するかダイアログ

をクローズすると保存されます。 

 

11. 最後にオリジナルの Width という名前の Board スコープ幅ルールが Minimum、Maximum、

Preferred の幅フィールドが 12mil に設定されていることを確認します。OK ボタンをクリックして

PCB Rules and Constraints Editor ダイアログをクローズします。 

この設定で配線を行なうと、GND と 12V のトラック幅は 25mil で、それ以外はすべて 12mil になります。 

PCB 上への部品配置 
部品を正しい位置に配置します。画面を拡大してボードを表示します。.  

1. ショートカットキーの V, D を押すと画面が拡大され、ボードと部品が表示されます。 

2. コネクタ Y1 を配置するため、カーソルをコネクタのアウトラインのところに移動し、マウスの左ボ

タンを押し続けます。カーソルの形状が十字に変わり、部品の基準点に移動します。 

3. マウスボタンを押した状態でマウスを移動し、部品をドラッグします。 

4. コネクタをドラッグ中に SPACEBAR を押すと、コネクタが 90°ずつ回転し、図 5 のようにボード

の左端に配置することができます(部品が、ボードの内側に配置されていることを確認します)。 
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図 5. 部品が配置されたボード 

5. マウスボタンを放すと、その位置に部品が配置されます。部品と共に接続ラインが移動する点に注

意してください。 

6. 図 5 を参考にして残りの部品を配置します。部品を回転する必要があれば、SPACEBAR を使用しま

す。接続ラインは、部品を移動すると自動的に最適化が行われます。 

部品の文字も同じ要領で配置が行えます。カーソルを文字の上に移動してドラッグすれば移動でき、

SPACEBAR で回転できます。文字の位置を修正する前に次のセクションでは、DXP の強力なグローバ

ル編集機能を使って、最終的なボードで特に必要のない部品のコメント(値)を非表示にします。 
接続ラインは、部品を移動

すると自動的に最適化が行

われます。これによって、

接続ラインは最適な配置を

行うためのガイドとして使

用することができます。 

DXP には、強力なインタラクティブ配置ツールが含まれています。これらの機能を使用し、4 つの抵抗

を等間隔に整列させてみましょう。 

1. SHIFT キーを押さえたまま、4 つの抵抗それぞれを左クリックします。選択した抵抗のまわりに、

Selections のシステムカラーで設定した色のセレクションボックスがそれぞれ表示されます。セレク

ションボックスの色を変更するには、Design » Board Layers & Colors をセレクトします。 

2. Component Placement ツールバーの Align Components by Top ボタンをクリックします。4 つの

抵抗は、一番上の抵抗を基準にして整列されます。 

3. 次に、Component Placement ツールバーの Make Horizontal Spacing of Components Equal ボタ

ンをクリックします。 

4. デザインウィンドウで任意の場所をクリックし、すべての抵抗のセレクトを解除します。4 つの抵抗

は、等間隔で整列されます。 

フットプリントの変更 
今、フットプリントが配置されていますがコンデンサのフットプリントが大きめになっています。コン

デンサのフットプリントを小さいものに変更します。 

1. まず、新しいフットプリントを探してみます。Libraries パネルをクリックしライブラリーリストか

ら Miscellaneous Deivices.IntLib を選択します。Libraries パネル内の Footprints をクリッ

クし、フットプリントの一覧を表示させます。コンデンサを検索する為に Filter フィールドに rad 
と入力します。フットプリント名をクリックするとフットプリントが下に表示されます。RAD-0.1
が小さいフットプリントに相当します。 

2. コンデンサをダブルクリックし、Component ダイアログの Footprint を RAD-0.1 に変更して下さい。

OK をクリックすると新しいフットプリントがボ－ドに現れデジグネーターが置き換えられます。 

3. 下図のような PCB デザインになるはずです。 
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全てコンポ－ネントが配置され、トラックを引く準備ができました。 
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ボードのマニュアル配線 
配線とは、ボード上にトラックとビアを配置することにより部品間を接続することです。DXP では、配

線作業を簡単にするために、洗練されたマニュアル配線ツールと、強力な Situs トポロジカル自動配線ツ

ールが新たに用意されています。この自動配線ツールでは、ボード全体や一部の高品質な配線をボタン 1
つで行うことができます。 

 

クリックするとト

ラック配置が開始

されます。カーソ

ルを R1 の下側の

パッドに移動しま

す。 

 

 

 

接続ラインによ

り、対象とするパ

ッドに配線できま

す。 

 

 

配置中のセグメン

ト 

 

先行セグメント 

カーソルを R1 の

パッドに合わせま

す。 

 

 

もう一度クリック

すると、このトラ

ックセグメントが

配置されます。 

 

 

さらにもう一度ク

リックすると、次

のトラックセグメ

 

自動配線機能を使うと簡単にボードを配線することができ

ますが、トラックを正確に配置したい場合や、決められた

経路で配線を行いたい場合には、マニュアルによる配線を

行う必要があります。こうした場合には、ボードの一部ま

たは全体をマニュアルで配線できます。チュートリアルの

このセクションでは、ボトムレイヤーのみを使用しボード

全体の配線をマニュアルで行います。 

接続情報の "ラッツネスト" をガイドに、ボトムレイヤーに

トラックを配置してみます。 

DXP の PCB では、トラックは連続したセグメントによっ

て形成されています。配置方向を変化させる度に、新しい

トラックセグメントが始まります。また、DXP は、トラッ

クを垂直、水平、45°等に配置できるため、熟練技術者の

ような配線が容易に行えます。尚、ここで紹介する操作は

デフォルトの設定を使用していますが、必要に応じてカス

タマイズすることが可能です。 

1. メニューから Place » Interactive Routing [ショート

カット P, T]をセレクトするか、または Placement ツ
ールバーの Interactive Routing ボタンをクリックし

ます。カーソルの形状が十字に変わり、トラック配置

モードになります。 

2. ドキュメントワークスペースの下部にあるレイヤータ

ブを確認してください。現在、TopLayer タブがアク

ティブになっています。今回はボトムレイヤーにトラ

ックを配置するので、レイヤーを切り換えます。キー

ボードより * キーを押してください。使用できるシグ

ナルレイヤーが切り替わります。今度は

BottomLayer タブがアクティブになります。 

3. カーソルをコネクタ Y1 の一番下のパッドに合わせま

す。トラックの開始点で左クリックするか、または

ENTER キーを押します。 

大

使

。

更

ト

か

4. カーソルを抵抗 R1 の下側のパッドに移動します。ト

ラックがどのように配置されているか、注意して下さ

い。デフォルトでは、トラックは垂直、水平、45°方

向に制限されます。また、トラックが 2 つのセグメン

トになっていることに気づくはずです。最初の(パッド

からスタートした)部分は青色になっています。これが

実際に配置するトラックセグメントです。次のセグメ
トラックの配置の際、

きな十字のカーソルを

用することができます

カーソルのサイズを変

するには、 Tools » 
Preferences をセレク

します。Preferences ダ
イアログの Options タ
ブにある Cursor Type
ら Large 90 を選択して

ください。 

ントが配置されま

す。 

この部分が配線さ

れました。 

ント(カーソルが置かれている)は先行セグメントで、

アウトラインで表示されています。このセグメントに

より、次に配置するトラックセグメントの場所を決め

て、トラックの向きは 45°または 90°のままで簡単

に配置できます。 

5. カーソルを抵抗 R1 の下側のパッドの中心に移動した後、左クリックするか ENTER キーを押して下

さい。この時、最初のトラックセグメントは青色になり、ボトムレイヤーに配置されたことを示し

ます。カーソルを少し動かしてみると、まだカーソル上に 2 つのトラックセグメントがあることが
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わかります。すなわち、次にマウスをクリックすると配置される青色のセグメントと、トラックの

配置に役立つアウトライン表示された "先行" セグメントです。 

6. 再度カーソルを R1 の下側のパッドに置きます。前のセグメントからパッドまでのセグメントが青色

で表示されます。左クリックして青色のセグメントを配置します。 

これで最初の配線が完了しました。 

7. カーソルを抵抗 R4 の下側のパッド上へ移動します。青色の

セグメントが R4 に伸びています。左クリックしてこのセグ

メントを配置します。 

8. カーソルを抵抗 R3 の下側のパッドに移動します。このセグ

メントは青色ではなく、アウトライン形状の先行セグメント

で表示されています。トラックセグメントの配置では、垂直

/水平または 45°角の配置モードを相互に切り換えることが

できます。現在は、45°モードになっています。

SPACEBAR を押すと、セグメントのスタートモードが水平/
垂直に切り替わります。セグメントは現在青色で表示されて

います。左クリックするか ENTER キーを押すと、セグメン

トが配置されます。 

9. カーソルを抵抗 R2 の下側のパッドに移動します。もう一度

SPACEBAR を押してセグメントをスタートモードに切り換

えます。左クリックするか ENTER キーを押すと、セグメントが

先

ー

は

ッ

っ

し

10. 以上で最初のネットの配線が終了しました。右クリックするか、

の配置を終了します。カーソルの形状は十字のままでトラック

引き続き次のトラックを配置できます。END キーを押すと画面が

認できます。 

11. 残りの部分も、この手順と同じ方法で配線できます。図 6 にマ

 

図 6. ボトムレイヤーにマニュアル配線された状態 

12. デザインを保存します。 

トラックを配置する際のキーポイントを次に示します： 

• マウスを左クリックすると(または ENTER キーを押すと)、
ントが配置されます。アウトライン表示されているセグメントは

配置されたトラックはそのレイヤーの色で表示されます。 

• SPACEBAR を押すと、配置するトラックセグメントの水平

トモードが切り替わります。 
行セグメントがクリッピングしており、カ

ソルから離れています。 PCB エディタで

、誤って他のオブジェクトを横切ってトラ

クを配線し、エラーが発生しないようにな

ています。この場合は、コンデンサを迂回

て配線します。 
配置されます。 

または ESC キーを押してトラック

配置モードであることを示しており、

再描画され、配線したネットを確

ニュアル配線したボードを示します。 

そのレイヤーの色のトラックセグメ

、先行トラックを表しています。

/垂直スタートモードと 45°スター
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• END キーを押すと画面が再描画されます。 

• ショートカットキーV, F を押すと、再描画されすべてのオブジェクトが画面に表示されます。 

• PAGEUP キーや PAGEDOWN キーを押すと、カーソル位置を中央にして画面表示の拡大、縮

小を行います。 

• BACKSPACE キーを押すと、最後に配置したトラックセグメントを削除します。 

• 右クリックするか、または ESC キーを押すとトラックの配置が終わり、新たにトラックを配置

できます。 

• ネットが異なる箇所へは配線できません。DXP は、接続違反がないか絶えず監視しており、違

反があった場合には警告します。 

• トラックセグメントを削除するには、左クリックします。セグメントの編集ハンドルが表示さ

れ、残りのトラックはハイライト表示されます。DELETE キーを押すと、トラックセグメントの選

択がクリアされます。 

• DXP では簡単に再配線できます。それまでの冗長なトラックセグメントは右クリックすると自

動的に削除され、新しいトラックセグメントが配線されます。 

• PCB のトラックがすべて配線されたら、右クリックするか ESC キーを押して配線モードを終了

します。カーソルが通常の矢印に戻ります。 

以上でボードのマニュアル配線が終了しました。 

ボードの自動配線 
DXP で自動配線がいかに簡単に行えるかを、以下の手順で確認します： 

1. まずメニューから Tools » Un-Route » All [ショートカット U, A]をセレクトし、ボードを未配線の

状態に戻します。 

2. メニューから Autoroute » All [ショートカット A, A]をセレクトします。 

3. 自動配線が終了したら、END キーを押して画面を再描画します。 

このように DXP の自動配線では、簡単に熟練した PCB 設計者と同様の配線結果が得られ、また

PCB ウィンドウで直接配線が行われるため、配線ファイルのエクスポートやインポートといった作

業が不要となります。 

4.  File » Save [ショートカット F, S ]をセレクトし、保存します。 

自動配線されたトラックは、2 種類の色で表示されています。赤は部品面を示すトップレイヤーで、青は

ボトムレイヤーを示しています。自動配線は Routing Layers デザインルールで規定されているレイヤー

に配線を行います。これは PCB Board Wizard によって設定されています。また、2 種類の電源ネットの

トラック幅が太くなっていますが、これは新たに 2 つの Width デザインルールを設定したためです。 

配線結果は部品の位置によって変わり、図 7 と同じにはならない可能性があります。 
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図 7. 自動配線によるボード 

この PCB は、PCB 作成ウィザードではじめに定義したように、トップレイヤーとボトムレイヤーを使用

する両面基板として配線することができます。メニューより Tools » Un-Route » All [ショートカット U, 
A]をセレクトし、ボードを未配線の状態に戻します。これまでと同じ要領で配線を行いますが、配線中

にレイヤーを切り換えるには *キーを押します。レイヤーを切り換えると、DXP は自動的にビアを挿入し

ます。 

ボードデザインの確認 
DXP は、PCB をより完全なものにするために多くのデザインルールのタイプを定義することができる、

ルールドリブン設計環境です。一般的に、デザインプロセスの開始時にデザインルールを設定し、設計

終了時にルールに従ってデザインが作成されているか確かめます。 

チュートリアルの前半で、配線デザインルールを追加し、トラック幅に関するルールを追加しました。

その他の多くのルールはすでに PCB Board Wizard によって作成されています。 

配線が終了した PCB に対して、デザインルールに合致しているか確認するためデザインルールチェック

(DRC)を実行します： 

1. Design » Board Layers & Colors[ショートカット L]をセレクトし、System Colors セクションの

DRC Error Markers オプションの隣にある Show ボタンにチェックが入っていることを確認します。

DRC エラーマーカーがある場合、これが表示されます。 
て

ス

多

る

ス

順

2. メニューから Tools » Design Rule Check [ショートカット T, D]をセレクトします。On-line および

DRC の双方のオプションは、Design Rule Checker ダイアログ内で設定できます。カテゴリをクリ

ックするとすべてのルールが表示されます。 
DXP は、階層的デザイ

ンルールをサポートし

います。定義された各

コープや同じクラスの

くのルールをセットす

事ができます。ルール

コープはルールの優先

位を確定します。 
 

3. すべてのオプションをデフォルトの状態で Run Design Rule Check ボタンをクリックします。DRC
が起動し、結果が Messages パネルに表示されます。また、デザインルールに違反しているトラン

ジスタのパッドは、緑色にハイライト表示されています。 

4. エラーリストを調べます。リストには PCB デザインで発生した違反が表示されています。

Clearance Constraint ルールの下に 4 つの違反箇所が記載されている点に注目して下さい。トラン

ジスタ Q1 と Q2 のパッドが、13 mil のクリアランスルールに違反していることがわかります。 

5. Messages パネルのエラーをダブルクリックすると、PCB での配置場所に移動します。 

PCB をレイアウトする前に、ルーティングテクノロジや実際のデバイスの特性を確認し、Clearance ル

ールを設定します。エラー箇所に対しては、現在のクリアランスデザインルールを再検討し、対策を決

定します。 

トランジスタのパッド間の実際のクリアランスを調べるには、次の操作を実行します： 

1. PCB ドキュメントをアクティブな状態にした後、カーソルをトランジスタの 1 つに合わせ、

PAGEUP キーを押して拡大表示します。 
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2. Reports » Measure Primitives  [ショートカット R, P ]をセレクトします。カーソルの形状が十字に

変わります。 

3. カーソルをトランジスタの下側のパッドの中心に移動した後、左クリックするか ENTER キーを押し

ます。パッドにトラックが接続されている場合、い

ずれかの選択を促すポップアップメニューが表示さ

れるので、トランジスタのパッドを選択します。 

4. カーソルをもう一方のトランジスタの中心に移動し

て左クリックするか、または ENTER キーを押します。

もう一度ポップアップメニューからトランジスタの

パッドを選択します。情報ボックスが表示され、パ

ッド間の最短距離は 10.63mil と表示されます。 

5. 情報ボックスをクローズし、右クリックか ESC キーで測定モードを終了します。さらにショートカ

ット V, F で、ドキュメント全体を表示します。 

現在のクリアランスデザインルールを見てみます。 

1. メニューから Design » Rules [ショートカット D, R]をセレクトし、PCB Rules and Constraints 
Editor ダイアログを表示します。Electrical カテゴリをダブルクリックすると、ダイアログの右側に

電気的なルールがすべて表示されます。ダイアログの右側で Clearance をダブルクリックし、

Clearance_1 をクリックすると、クリアランスのルールが表示されます。ダイアログの下側にルー

ルが 1 つ表示され、ボード全体の最小クリアランスが 13 mil に設定してあることがわかります。ト

ランジスタのパッド間はこの幅よりも小さく、これが DRC を実行した際エラー表示された原因です。 

トランジスタのパッド間は 10 mil よりやや大きいことがわかっているため、トランジスタだけはデ

ザインルールのクリアランスを 10 mil に設定します。 

2. Design Rules パネルで Clearance タイプをセレクトし、右クリックして New Rule をセレクトして

clearance constraint ルールを新しく追加します。 

3. 新しい Clearance ルールをダブルクリックし、表示されたダイアログの Constraints セクションで

Minimum Clearance を 10 mil に設定します。 

4. Advanced (Query)をクリックし、次に Query Helper をクリックして Memberships Checks の構文

を作成するか、または Expression フィールドに次のような構文を入力します： 
HasFootprintPad(‘BCY-W3/D4.7’,’*’) 
*(アスタリスク)は BCY-W3/D4.7 のフットプリントの '任意のパッド' を示します。  

5. OK ボタンをクリックしてダイアログをクローズします。  

6. Design Rules Checker ダイアログ(Tools » Design Rule Check)の Run Design Rule Check ボタン

をクリックし、DRC を再実行してみます。ルール違反はない筈です。 

これで PCB レイアウトが完全なものになりましたので、次はドキュメントの出力です。 
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プロジェクトアウトプットの設定 
プロジェクトアウトプットには印刷用ファイルや出力ファイルがあり、Outputs for Project ダイアログで

設定します。 

1.   Project » Project Options をセレクトします。 
Project [project_name]ダイアログが表示され

ますので、Default Print タブをクリックしま

す。 

2. 設定するアウトプットをクリックします。

Configure ボタンがアクティブであれば(グレ

ー表示でなければ)、そのアウトプットの設定

を変更できます。 

3. 設定が終了したら Close ボタンをクリックし

ます。 

4. アウトプットをタイプに応じて個別のフォル

ダに保存するには、Project » Project Options
をセレクトして Options タブをクリックし、

Use separate folder for each output type を

クリックしてから OK をクリックします。 

Windows プリンタによる印刷 
PCB のレイアウトと配線が終了したことにより、

出力ドキュメントを作成する準備が整いました。

これらのドキュメントには、PCB の製造データ、

実装図面、部品の位置情報等が含まれます。 

これらの図面を作成するために、DXP には洗練さ

れたプリントエンジンが含まれており、印刷工程

を完全にコントロールすることができます。一緒

に出力する PCB レイヤーを細かく設定したり、図面(プリントアウト)をプレビューして縮尺や印刷方向

を設定し、印刷する前に正確な出力イメージを捉えることができます。 

ここではデフォルトの出力設定を使用してプレビューを作成し、次に設定を変更します。 

1. PCB のメニューから File » Print Preview をセレクトします。PCB が解析され、デフォルト状態の

プリント出力がプリントプレビューウィンドウに表示されます。Close をクリックします。 

2. プリント出力内に含まれる PCB レイヤーのセットを確認するには、File » Default Prints をセレク

トします。Outputs for Project ダイアログの Default Print タブが表示されます。Composite 
Drawing をセレクトし、Configure ボタンをクリックします。PCB Printout Properties ダイアログ

が表示されます。右クリックメニューのオプションでレイヤーの追加や削除ができます。OK ボタン

をクリックしてダイアログをクローズします。 

3. Project ダイアログをクローズする前に、Combination Drill Guide のレイヤー設定を変更します。

Fabrication Outputs セクションで Composite Drill Drawing をセレクトし、Configure ボタンをク

リックします。デフォルトでは、このプリント出力には穴位置を小さな十字で表示するドリルガイ

ドと、穴径を特別な形状で示すドリルドローイングの両方のレイヤーが含まれています。 

ドリルガイドレイヤーは一般的なドリル図面には必要ありません。このレイヤーを削除するには、

Printouts & Layers の列の DrillGuide レイヤーを右クリックし、ポップアップメニューから Delete を

セレクトします。OK ボタンをクリックしてダイアログをクローズします。 
プリントプレビューで右

クリックメニューから

Edit » Copy from the を

セレクトすると、現在の

プリント出力をクリップ

ボードにコピーして他の

アプリケーションに貼り

付けることができます。 

File » ExportMetafile を

セレクトすると、プリン

ト出力を WMF ファイル

としてハードディスクに

エクスポートできます。 
出力ファイルを作成して

も自動的にオープンしな

いようにするには、

Project » Project 
Options をセレクトし、

Options タブをクリック

し、Open Outputs after 
compile を選択解除しま

す。 
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4.  Default Print にチェックを入れ、ダイアログを閉じます。次に File » Print Preview を実行し、ドリ

ル図面を表示します。Print ボタンをクリックするとプリンタの設定が表示され、OK ボタンをクリ

ックすると指定したプリンタに図面が送信されます。 

 

5. Close ボタンをクリックしてプリントプレビューウィンドウをクローズします。 

6. 出力先のプリンタを変更してページの向きと縮尺を設定するには、Project ダイアログで Page 
Setup ボタンをセレクトするか、またはメニューから File » Page Setup をセレクトします。プリン

タを選択し、印刷の向きを横に設定します。 

7. 設定が終了したら、すべてのダイアログをクローズします。 

製造用出力ファイルの作成 
PCB 設計プロセスの最終段階は、製造用ファイルの作成です。主なファイルとしては、ガーバーファイ

ル、NC ドリルファイル、部品位置情報ファイル、部品表、およびテストポイントファイル等の、製造と

実装用のデータがあります。出力ファイルは File » New » Output Job File で設定するか、または File » 
Fabrication Outputs メニューでコマンドを入力して設定します。製造用ドキュメントの設定は、プロジ

ェクトファイルの一部として保存されます。 

ガーバーファイルの生成 
コンポーネントオーバーレイ、トップシグナルレイヤー、ボトムシグナルレイヤー、ソルダーマスク等

の各ガーバーファイルは、実際の PCB の各レイヤーにそれぞれ対応します。なお、ガーバーファイルや

NC ドリルファイルを生成する前に、PCB の製造業者へ必要なデータの形式について問い合わせておく必

要があります。 
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このチュートリアルの PCB 製造ファイルを作成するには、次の操作を実行します： 

1. PCB をアクティブなドキュメントにし、File » Fabrication Outputs »Gerber files をセレクトしま

す。Gerber Setup ダイアログが表示されます。 

 

2. OK ボタンをクリックしてデフォルト設定を適用します。ガーバーファイルが生成され、CAMtastic
がオープンしてファイルが表示されます。ガーバーファイルは Project Outputs フォルダに保存

されます。このフォルダは、プロジェクトファイルが保存されているフォルダに自動的に作成され

ます。ファイルにはレイヤー名に対応したファイルの拡張子が追加され、例えば、Gerber Top 
Overlay のファイルは Multivibrator.GTO となります。 

部品表 
1. 部品表を作成するには、Report » Bill Of Material をセレクトします。 

2. このダイアログでは、部品表レポ－トに必要な情報をドラッグにより設定できます。Other Column
セクションで必要無い情報は Show のチェックを外します。 

 

3. Report…ボタンをクリックすると、部品表のプリントプレビューが表示されます。Print ボタンをク

リックするとこのプレビューが印刷できます。また、Export ボタンをクリックすると指定したファ

イル形式(例えば Microsoft Excel の.xls)でエクスポートできます。 

4. ダイアログをクローズします。 

これで PCB の設計プロセスがすべて完了しました。 
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回路のシミュレーション 
DXP は、回路図から直接回路シミュレーションを実行できます。チュートリアルの次のセクションでは、

マルチバイブレータ回路の出力波形を検証してみます。 

シミュレーションの設定 
シミュレーションを実行する前に、マルチバイブレータの電力用電圧ソースやシミュレーション用のグ

ランドリファレンス、さらに回路上に波形表示する各ポイントに対してはネットラベルを追加する必要

があります。 

1. ウィンドウ上部の Multivibrator.SchDoc タブをクリックして、回路図をアクティブにします。 

2. コネクタを電圧ソースに置き換えます。コネクタを削除するにはコネクタ本体をクリックし、コネ

クタの周りにセレクションボックスが点線で表示されたら DELETE キーを押します。 

3. その際に、電圧ソースの配置に必要なスペースを確保するためにワイヤの終端を移動します。12V
のワイヤの終端を移動するため、ワイヤをクリックして選択します。小さな四角い編集用ハンドル

が表示されたら、ワイヤ終端のハンドルをクリックし、向きが変わるまでハンドルを上に移動しま

す。もう一度クリックするとハンドルの表示が消えます。 

4. 同じ要領で、GND ワイヤの終端をシートの下部へ移動します。 

5. View » Toolbars » Simulation Sources をセレクトして Simulation Sources ツールバーを表示しま

す。  

6. Simulation Sources ツールバーで+12V のボタンをクリックします。電圧ソースのシンボルがカーソ

ル上に表示されます。TAB キーを押して属性を編集します。表示されたダイアログで Attributes タ

ブをクリックし、Designator フィールドを V1 にします。OK ボタンをクリックしてダイアログをク

ローズし、12V と GND ワイヤの間に電圧ソースを配置します。 

7. 12V と GND ワイヤの先端を同じ方法でもう一度移動し、図 9 のように電圧ソースに配線します(図 9
はシミュレーションの準備が完了した回路図)。 

 

図 9. シミュレーションの準備が完了した回路図 

シミュレーションを行う前に、最後の設定として回路内で波形を計測するポイントにネットラベルを配

置します。それにより、解析後目的の波形を容易に表示できます。チュートリアルの回路では、2 つのト

ランジスタのベース、コレクタを対象とします。 

1. メニューから Place » Net Label [ショートカット P, N]をセレクトします。TAB キーを押すとネット

ラベルの属性を編集できます。Net Label ダイアログで Net フィールドを Q1B に設定し、ダイアロ

グをクローズします。 
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2. カーソルを Q1 のベース側から出ているワイヤ上に置きます。ネットラベルの配置については、図 9
を参照してください。左クリックするか ENTER キーを押すと、ワイヤにネットラベルが配置されま

す。 
ネットラベルの電気的な

接続点は、左下の隅の部

分になります。この部分

がワイヤに接続されてい

るか注意してください。 

3. TAB キーを押し、Net フィールドを Q1C に変更します。 

4. カーソルを Q1 のコレクタ側から出ているワイヤ上に置いて左クリックし、2 つ目のネットラベルを

配置します。 

5. 同様に、Q2B と Q2C の部品番号を持つネットラベルを Q2 のベース側とコレクタ側にそれぞれ配置

します。 

6. ネットラベルの配置が完了したら、右クリックするか ESC キーを押して配置モードを終了します。 

7. シミュレーションを行う前に、別の名前で回路を保存します。File » Save As [ショートカット F, A]
をセレクトし、Save As ダイアログに Multivibrator simulation.SchDoc と入力します。 

トランジェント解析の実行 
必要な準備がすべて揃いましたので、トランジェント解析の設定を行います。チュートリアルの回路で

は、RC 時間定数は 100 k x 20 n = 2 ms です。5 つの振動のサイクルを表示するために波形表示の間隔を

10 ms とします。 

1.  メニューから Design » Simulate » Mixed Sim をセレクトし、Analyses Setup ダイアログを表示しま

す。シミュレーションのオプションはすべてこのダイアログで設定します。 

 

2. まず回路内で計測するノードを設定します。Collect Data For フィールドのリストから Node 
Voltage and Supply Current を選択します。このオプションでは、シミュレーション実行中に計算

するデータのタイプを指定します。 

3. Active Signals フィールドで、シグナル名 Q1B、Q2B、Q1C、Q2C をダブルクリックします。ダブ

ルクリックされた信号は Active Signals フィールドに移動します。 

4. この解析では、Operating Point Analysis と Transient/Fourier にチェックが入っていることを確認

します。Transient/Fourier Analysis Setup が自動的に表示されない場合は、解析名の

Transient/Fourier をクリックします。 

5. Use Transient Defaults オプションが無効になっていることを確認します。無効になっていれば

Transient Analysis パラメータが使用できます。 
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6. 10m のシミュレーションウィンドウを指定するには、Transient Stop Time フィールドを 10m  に設

定します。 

7. Transient Step Time フィールドを 10u に設定し、シミュレーションが 10u ごとのポイントを表示

するようにします(全部で 1000 ポイントあれば、正確な結果を得るには十分です)。 

8. シミュレーションを行う際、実際のタイムステップは、収束させるために自動的に変更されます。

Maximum Step フィールドは、タイムステップのサイズの変化を制限します。Transient Max Step 
Time を 10u に設定します。 

以上でトランジェント解析を行う準備が整いました。 

1. Analyses Seup ダイアログの下側にある OK ボタンをクリックし、シミュレーションを実行します。 

2. シミュレーションが終了すると、図 10 に示すような出力波形が表示されます。 

 

図 10. マルチバイブレータの出力波形 

以上でシミュレーションおよび波形表示が終了しました。  
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回路上の部品の値を変更する場合は、再度シミュレーションを実行します。それでは、C1 をダブルクリ

ックして属性を編集し、値を 47n に変更してトランジェント解析を再度行ってみます。出力波形のマー

ク/スペース比が不均等になります。. 

より詳細な調査のために 
このチュートリアルでは、DXP の強力な機能の一部を紹介したにすぎません。これまで DXP の統合ツー

ルを使用し、回路図の作成、デザインのトランジェントシミュレーションの実行、PCB の設計と配線を

行いました。しかし、このチュートリアルで紹介された部分は、DXP が備えている能力のごく一部です。 

DXP を調べるとすぐに、設計を容易にするための優れた機能に気がつくはずです。ソフトウェアの様々

な機能を理解して頂くために、多くのサンプルファイルが含まれています。これらのサンプルは、デザ

インエクスプローラのメニューから File » Open をセレクトするとオープンできます。サンプルは、

\Program Files\Altium\Examples\フォルダにインストールされています。このフォルダには PCB
デザインのサンプルがあります。またサブフォルダには DXP の各機能を体験できるサンプルが含まれて

います。 

\Circuit Simulation\サブフォルダには、DXP のアナログ/デジタルシミュレーション機能を使った

サンプル回路が収録されています。アナログのサンプルのほかに、アンプや電源を使ったサンプル、混

在回路サンプル、数学的サンプル、線形、非線形サンプル、真空管サンプルなどが含まれています。 

スイッチングロジックやクロックスピードの高速化により、デジタル信号の品質は更に重要になってい

ます。DXP は、洗練された伝送線路解析ツールが装備され、ボードレイアウトを正確に解析します。こ

の伝送線路解析では、インピーダンス、オーバーシュート、アンダーシュートやスロープが、PCB デザ

インルールで定義され、標準的にチェックされます。 

各ネットに対して詳細を検証する場合は、Tools » Signal Integrity をセレクトします。Signal Integrity 
Analyzer が起動し、Reflection や Cross talk シミュレーションを実行できます。解析結果は、オシロスコ

ープの様な波形で表示され、この波形から値を読み取ることもできます。 

アドオンツール 
Protel のデザインエクスプローラはオープンクライアント/サーバーアーキテクチャに基づいて開発され

ているため、Protel やサードパーティから供給されるアドオンツールを利用して、DXP の機能を拡張す

ることができます。アドオンツールはデザインエクスプローラ環境下で統合され、新しい機能やサービ

スの提供により DXP デザインツールの能力を向上させます。Protel の Web サイトwww.protel.com で
は、最新のアドオンツールのリストを参照することができ、この中のほとんどのツールは直接ダウンロ

ードすることができます。 

以上で DXP 入門チュートリアルの説明を終了します。ご利用いただきありがとうございました。 
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ショートカットキー 

デザインエクスプローラショートカット 
左クリック カーソル下のドキュメントを選択 
ダブルクリック カーソル下のドキュメント編集 
右クリック  ポップアップメニューの表示  
Ctrl + F4 アクティブなドキュメントをクローズ 
Ctrl + Tab オープンしているドキュメントの切り替え 
下記の所から Drag & Drop 
• あるプロジェクトから別のものへ   選択したドキュメントを移動  
• エクスプローラから DXP へ  選択したドキュメントをフリードキュメントして開く  
Alt + F4 DXP を閉じる 

回路図とＰＣＢで共通のショ－トカット 
Shift スクロール中の速度を高速にする 
Y オブジェクトの移動中、 Y 軸に沿って反転 
X オブジェクトの移動中、 X 軸に沿って反転 
Shift+ ↑ ↓ ← → 矢印キ－の方向に 10 グリッドづつカ－ソルを移動  
↑ ↓ ← → 矢印キ－の方向に 1 グリッドづつカ－ソルを移動 
Space 再描画中止 
Esc 現在の作業を中止 
End 画面の再描画 
Home カーソル位置が画面の中心に来るように再描画  
PageDown または Ctrl + ホイール ズームアウト 
PageUp または Ctrl + ホイール （カーソル位置を中心に）ズームイン 
マウスホイール 上下にスクロール 
Shift + マウスホイール 左右にスクロール 
Ctrl + Z アンドゥ 
Ctrl + Y  リドゥ 
Ctrl + A  すべてを選択 
Ctrl + S  カレントドキュメントの保存 
Ctrl + C  コピー 
Ctrl + X 切り取り 
Ctrl + V  貼付け 
Ctrl + R 選択したオブジェクトをコピーし、繰り返し貼付け 
Delete セレクションの削除 
V, D ドキュメントの全体表示 
V, F オブジェクトの全体表示 
X, A セレクトされたのもをすべて解除 
右クリックし続ける スライダーハンドで画面をスライド 
左クリック オブジェクトのフォーカス／セレクト  
右クリック メニューのポップアップ／現在の操作の中止  
オブジェクト上で右クリックし、  

Find Similar をセレクト Find Similar ダイアログの表示 
左クリックし、そのままドラッグ エリアの内側を選択  
左クリックし続ける オブジェクト／セレクションの移動  
ダブルクリック オブジェクトの編集 
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Shift + 左クリック オブジェクトの選択／選択解除 
TAB 配置中の属性編集 
Shift + C フィルターの解除 
Shift + F オブジェクトをクリックし、Similar Objects ダイアログを表示 
Y Quick Queries メニューのポップアップ 
F11 Inspector パネルの表示／非表示 
F12 List パネルの表示／非表示 

回路図のショートカット 
Alt 元の位置に対して垂直及び水平方向にオブジェクトを移動 
G スナップグリッドの設定切替え 
Spacebar 移動中のオブジェクトを 90°ずつ回転 
Spacebar 配置中のワイヤ／バス／ラインのスタート／エンドモード切替え 
Shift + Spacebar 配置中のワイヤ／バス／ラインのプレ－スメントモ－ドを切替え 
Backspace 配置中のワイヤ／バス／ラインの直前の頂点を削除 
左クリックし続け Delete フォーカスされているワイヤの頂点を削除 
左クリックし続け Insert フォーカスされているワイヤに頂点を追加 
Ctrl + 左クリックしドラッグ オブジェクトのドラッグ移動 

PCB のショートカット 
Shift + R  配線モード（Ignore, Avoid, Push obstacle）の切替え 
Shift + E エレクトリカルグリッドオン／オフ切替え 
Ctrl + G スナップグリッドダイアログを表示 
G スナップグリッドメニューを表示 
N コンポーネントの移動中、ラッツネストを非表示にする 
L 移動中のコンポーネントの配置レイヤー切替え 
Backspace 配置中のトラックの直前の頂点を削除  
Shift + Space 配置中のトラックのプレ－スメントモ－ドを切替え 
Space 配置中のトラックのスタート／エンドモードを切替え 
Shift + S シングルレイヤーモードオン／オフ切替え 
O, D, D, Enter すべてのプリミティブをドラフトモードにする 
O, D, F, Enter  すべてのプリミティブをファイナルモードにする 
O, D Preferences ダイアログの Show/Hide タブ表示 
L Board Layers ダイアログ表示 
Ctrl + H 配線済みコパーの選択 
Ctrl + Shift + 左クリック トラックの折り曲げ 
+（numeric keypad） アクティブレイヤー切替え（インクリメント） 
-（numeric keypad） アクティブレイヤー切替え（デクリメント） 
*（numeric keypad） シグナルレイヤー切替え 
M, V ポリゴンプレーンの頂点移動 
Alt 配線モードを Avoid-obstacle から Ignore-obstacle モードへ切替え 
Ctrl 配線中、エレクトリカルグリッド一時的に無効にする 
Ctrl + M  距離の測定 
Shift + Space 移動中のオブジェクト回転（時計回り） 
Space 移動中のオブジェクト回転（反半時計回り） 
Q 単位の切替え（mm 系／インチ系） 
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