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DXP のマルチ・ディメンショナルキャプチャー  
このチュートリアルでは、DXP を使用して回路図と VHDL の混在したデザインを作成し、シミュレー

ションを実行するまでの一連の工程を説明します。このチュートリアルは、VHDL コードとテストベ

ンチファイルを作成する知識がある方向けに書かれており、これ以降 FPGA プロジェクトの作成、

FPGA ソースの作成、必要となる回路図とテストベンチドキュメントの準備、VHDL モデルと VHDL
ライブラリの使用、VHDL シミュレーションを実行し Waveform Viewer で波形を解析するまでを見て

いきます。なお、このチュートリアルで使用するサンプルは\Altium\Examples\FPGA\BCD 
Counter フォルダにあります。  
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FPGA プロジェクトの作成 
チュートリアルの最初に FPGA プロジェクトを作成します： 

1. デザインウィンドウの Pick a Task セクション内の

Create a new FPGA Design Project をクリックします。  

あるいは、メニューから File » New » FPGA Project を選択するかまたは、Files パネルの New
セクション内の Blank Project (FPGA)をクリックします。Files パネルが表示されていない場合

は、パネル下部の Files タブをクリックして表示し

ます。  
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成されな

用するに

ードの間に

記述しま

s off 
s on 
できます 

anslate_off 
anslate_on 

2. 作成した FPGA Project1.PrjFpg が、Projects パネルに

No Documents Added と表示されてリストに加えら

れています。 

3. メニューから File » Save Project As を選択して、

作成したプロジェクトファイルの名称（拡張

子.PrjFpg は付けたまま）を変更します。プロジェク

トを保存したいハードディスクの場所を指定し、ファ

イル名(N) フィールドに変更するプロジェクトファイルの名称 BCD.PrjFpg と入力して 保存(S) 

ボタンをクリックします  

プロジェクトへ VHDL ドキュメントを追加 
このチュートリアルでは、４ビット BCD カウンターの VHDL コードソースファイル 
\Altium\Examples\FPGA\BCD Counter\BCD.VHD を追加することにします。  

1. Projects パネルのプロジェクト名の上で、マウスを右クリックして Add to Project を選択すれば

VHDL ファイルをプロジェクトに追加できます。ファイルの場所とファイル名を指定してから 開
く(O) ボタンをクリックします。 

2. 追加された VHDL ドキュメントは、Projects パネルの VHDL Docum

下に表示されます。 ファイル名をダブルクリックするとテキスト

タが開き、このファイルを編集することができます。 

3. プロジェクトをセーブします (File » Save)。 

VHDL ドキュメントの新規作成 
新しい VHDL ドキュメントを作成してプロジェクトに追加したい場合に

1. メニューから Select File » New » VHDL Document を選択すると、

VHDL ドキュメント VHDL1.Vhd が Projects パネルの VHDL Docum
フォルダ下に作成されます。同時にテキストエディタが開き、すぐ

とができます。  

2. 必要なコードを入力した VHDL ファイルを.VHD 拡張子付きでセー

3. プロジェクトをセーブします (File » Save)。 

次は、BCD カウンターを回路図入力で入力し、プロジェクトファイルに
VHDL に論理合

いコードを使

は、以下のコ

プログラムを

す。 

-- rtl_synthesi
-- rtl_synthesi
こちらも使用

-- synopsys tr
-- synopsys tr

ents の
エディ

は： 

新規

ents

に VHDL コードを入力するこ

ブ (File » Save As) します。 

追加します。 
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VHDL のトップ階層回路図作成 
FPGA プロジェクトでは回路図および VHDL の 2 タイプのソースドキュメントをサポートしています。

両タイプがプロジェクトに混在することも可能です、しかし VHDL でのソースでは、構造化 VHDL で

作成される必要があります。シートシンボルを介して、同一プロジェクトに両タイプのドキュメント

を混在させることが可能です。  

BCD カウンタープロジェクトでは、１枚の回路図を作成する必要があるので、下の例に示した回路図

BCD8.SchDoc を作成します。  

 
1. メニューから File » New » Schematic を選択するか、または Files パネルの New セクションに

ある Schematic Sheet をクリックすると、空白の回

路図 Sheet1.SchDoc がデザインウィンドウで表示

されます。  

2. File » Save As を選択し、新たに作成された回路図

のファイル名を変更して（拡張子 .SchDoc は付けた

まま）セーブします。開いた Save ダイアログで、回

路図を保存するフォルダを指定して、ファイル名（N）

のフィールドに BCD8.SchDoc と入力して 保存(S) 

をクリックます。  

3. 回路図のテンプレートを読み込むには、Design » 
Template » Set Template File Name を選択し、開いたダイアログで \Altium\Templates

3 
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フォルダにある A4.SchDot を選んで 開く(O) ボタンをクリックします。テンプレートがセッ

トされるまで各ダイアログに OK をクリックし、回路図をセーブします。 

VHDL ファイルからシートシンボルを作成する 
シートシンボルを使うと、VHDL と回路図の混在使用が可能です。VHDL の場合、シートシンボルに

生成されたシートエントリが VHDL ドキュメントの各ポートに対応しています。 

1. デザインウィンドウに新規回路図が表示されている状態で、メニューから Design » Create 
Symbol From Sheet を選択すると、ドキュメントからシートシンボルが生成されます。今回の例

では、VHDL ドキュメント BCD.VHD 中のエンティティ BCD のために、シートシンボル H1 を生

成します。 

2. 表示している Choose Document to Place ダイアログで、BCD.VHD を指定して OK ボタンをクリ

ックします。 
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にあるエン

くリンクす

DLEntity パ

ートシンボ

ることが必

VHDL ファ

ンティティ

きるからで

3. 今回のケースでは VHDL エンティティは１つでしたが、VHDL ドキュメントに複数のエンティテ

ィが存在する場合は、Choose VHDL Entity ダイアログが表示されるので、

そこから１つのエンティティを指定します。以上の操作でカーソル

ートシンボルが表示されます。 

 

4. シートシンボルを回路図に配置する前に TAB キーを押すとシートシ

Designator を H1 にセットするなどの設定できます。Parameters タ

に生成された VHDLENTITY パラメータがすでにセットされており

要なパラメータも追加することができます。 
VHDL ファイル

ティティに正し

るために、VH
ラメータは、シ

ルに常に存在す

要です。これは

イルが複数のエ

を含むことがで

す。

上にシ
ンボルのプロパティを、

ブをクリックすると、自動的

、他の description といった必
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5. 回路図にシートシンボルを配置したら、下図を参考にしてシートエントリやテキストの位置を変

更します。 
ターゲットファイルがソ

ースドキュメントと思わ

れるときは、シートシン

ボルを使用すべきです。

ターゲット VHDL ファイ

ルが、デザインのライブ

ラリィドキュメントと思

われるときは、モデルと

ライブラリィを使用すべ

きです。 

 

6. 1 から 5 までを繰り返し 2 個目のシートシンボルを、Designator を H2 と設定してから配置し、回

路図をセーブします。 

回路図コンポーネントの配置 
デザインに回路図シンボルを使用することもできますが、その場合には、そ

のコンポーネントの VHDL ビヘイビアモデルが、モデルファイルか VH
イブラリに記述されていることが必要です。今回はその両方を使用した

示すために、まず初めにコンポーネントを配置します。このデザインで

するコンポーネントを含んだ回路図ライブラリは

\Altium\Examples\FPGA\BCD Counter\SCH Library\BCD.Sch
あります。 

リィは、す

を含んだ１

ァイルか、

の実体を含

ルとしての

をサポート

 
1. 回路図ライブラリを追加するには、Projects パネルの BCD.PrjFp
DL ラ

例を

使用

Lib に

統合ライブラ

べてのモデル

つの大きなフ

それぞれ１つ

む個別ファイ

VHDL モデル

しています。
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部分を右クリックして Add To Project を選択し、BCD.SCHLIB を指定して 開く(O) をクリック

します。 

2. 次に 2 つのコンポーネントを配置します。メニューから Place » Part [ショートカット P, P]を選

択し、開いた Place Part ダイアログの Lib Ref フィールドに BUFGS と入力してバッファーコンポ

ーネントを、同様に Lib Ref フィールドに PARITYC と入力してパリティコンポーネントを、上の

回路図を参考にして配置します。 

回路図へのポートの配置 
Clock インプットポートを配置します： 

1. メニューから Place » Port [ショートカット P, R] を選択します。カーソルの形状が変りポートの

アウトラインがカーソル上に表示されています、TAB キーを押して Port Properties ダイアログを

表示させます。Name フィールドに Clock と入力し、I/O Type に Input を指定します。ポートシ

ンボル形状を変更したい場合は Style を Right に変更して OK ボタンを押します。これらの設定

は、他のポートを配置する際にも有効になります。 

 

2. ポートの配置位置をクリックし、マウスを移動してポートの長さを決定してから再度クリックし

て配置を完了します。  

3. 1 と 2 を繰り返して、他の入力ポートを配置します。  

4. バスの信号線 Lower[3..0] のポートを、Port Properties ダイアログで I/O Type を Output に Style 
を Left に設定し Name フィールドに LOWER[3..0]と入力してから OK ボタンを押してポートを

配置します。 

5. マウスを右クリックするか、または ESC キーを押してポート配置モードを終了します。. 

接続の作成 
以上で、回路図の接続が開始できます。 

6 
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1. ワイヤを配置するには、メニューから Place » Wire [ショートカット P, W] を選択し、ワイヤを

引き始めるポイント（通常はポートやコンポーネントのピン）でクリックします。カーソルを移

動させ、接続したい次のポイントで再度クリックします。他のポートやコンポーネントのピンま

での、接続が完了するまで繰り返し、マウス右クリックで終了します。ワイヤ配置モードを終了

するにはマウス右クリックか ESC キーを押します。 

Place » Wire [ショートカット P, W] を選択し、ワイヤを

引き始めるポイント（通常はポートやコンポーネントのピン）でクリックします。カーソルを移

動させ、接続したい次のポイントで再度クリックします。他のポートやコンポーネントのピンま

での、接続が完了するまで繰り返し、マウス右クリックで終了します。ワイヤ配置モードを終了

するにはマウス右クリックか ESC キーを押します。 

2. 回路図ファイル BCD8.SchDoc を参考にして配線を引いていきます、その際ワイヤが交差してい

る位置でのジャンクションの有無に注意してください。もし 2 本のワイヤが交差しそこにジャン

クションがあるならば、この 2 本のワイヤは接続されます。もしジャンクションが無ければ、こ

れらは接続されていません。この回路図では、ワイヤが接続されるポイントには自動的にジャン

クションが配置されます。 

2. 回路図ファイル BCD8.SchDoc を参考にして配線を引いていきます、その際ワイヤが交差してい

る位置でのジャンクションの有無に注意してください。もし 2 本のワイヤが交差しそこにジャン

クションがあるならば、この 2 本のワイヤは接続されます。もしジャンクションが無ければ、こ

れらは接続されていません。この回路図では、ワイヤが接続されるポイントには自動的にジャン

クションが配置されます。 

バスの配線 バスの配線 
バスから他のオブジェクトへ接続する場合は、バスメンバーは左から右へと決定されます、またバス

のメンバーの数は両者同一でなければなりません。 
バスから他のオブジェクトへ接続する場合は、バスメンバーは左から右へと決定されます、またバス

のメンバーの数は両者同一でなければなりません。 

ポート LOWER[3..0]へバスを接続します： ポート LOWER[3..0]へバスを接続します： 

1. メニューから Place » Bus [ショートカット P, B] を選択し、バス配

ードにします。 
1. メニューから Place » Bus [ショートカット P, B] を選択し、バス配

ードにします。 
な接続を

スにはネ

要です。2. ポート LOWER[3..0]とシートエントリ OCD[3..0]間を、ワイヤを

したときと同じやり方でバスを配置します。  
2. ポート LOWER[3..0]とシートエントリ OCD[3..0]間を、ワイヤを

したときと同じやり方でバスを配置します。  

ネットラベルの追加 ネットラベルの追加 
接続にネットラベルを付けておくのは、後にデバックを簡単に行なえる

しネットラベルが無ければ、DXP はネットラベルを出力時に生成します

をネット LRCO にだけ付加します。 

接続にネットラベルを付けておくのは、後にデバックを簡単に行なえる

しネットラベルが無ければ、DXP はネットラベルを出力時に生成します

をネット LRCO にだけ付加します。 

1. メニューから Place » Net Label [ショートカット P, N] を選択する

カーソルの上に表示されます。 
1. メニューから Place » Net Label [ショートカット P, N] を選択する

カーソルの上に表示されます。 

2. ネットラベルを配置する前に TAB キーを押すと、表示した Net La
イアログでネットラベルのプロパティが編集できます。ネットラベ

LRCO を Net フィールドに入力して OK ボタンをクリックします。

2. ネットラベルを配置する前に TAB キーを押すと、表示した Net La
イアログでネットラベルのプロパティが編集できます。ネットラベ

LRCO を Net フィールドに入力して OK ボタンをクリックします。

3.  カーソルを、ネットラベルの文字の左下（ホットスポットと呼びま

が、目的のワイヤに触る位置まで移動させると、カーソルが赤いク

変るので、その位置にネットラベルを配置します。 

3.  カーソルを、ネットラベルの文字の左下（ホットスポットと呼びま

が、目的のワイヤに触る位置まで移動させると、カーソルが赤いク

変るので、その位置にネットラベルを配置します。 

4. 配置が終了したら、マウスを右クリックするか ESC キーを押して

ラベル配置モードを終了します。 
4. 配置が終了したら、マウスを右クリックするか ESC キーを押して

ラベル配置モードを終了します。 

5. File » Save を選択して回路図をセーブします。 5. File » Save を選択して回路図をセーブします。 

VHDL テストベンチファイルの追加 VHDL テストベンチファイルの追加 

テストベンチファイルとは、デザインの実行をテストするシーケンスを

ルです。テストベンチファイルはコア・デザインの一部ではないので、
置モ置モ DXP では確実

行なうため、バ

ットラベルが必
配置配置
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様になる良いやり方です。も

。今回の例ではネットラベル

様になる良いやり方です。も

。今回の例ではネットラベル

と点線に囲まれたラベルが、と点線に囲まれたラベルが、
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Design » Create Sheet 
From Symbol, や 
Design » Create VHDL 
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ンドを使うと、VHDL フ
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ントをすぐさま別のシー

トで宣言（declare）や
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ことができます。

す）

ロスに

す）

ロスに

ネットネット

 

記述した VHDL ソースファイ

デザインの階層やネットリス
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トには含まれません。テストベンチはシミュレートするデザインの最上層に存在されるべきファイル

です。  

このチュートリアルでは、\Altium\Examples\FPGA\BCD Counter\BCD.VHDTST にあるテスト

ベンチを、このプロジェクトで追加して使用します。  

1. Projects パネルのプロジェクト名称の上で右クリックし、Add to Project を選択しファイルを指

定してから 開く(O) ボタンを押して、この VHDL ファイルを FPGA プロジェクトに追加します。 

2. VHDL テストベンチドキュメントがプロジェクトに追加され、Projects パネルの VHDL 
Testbenches フォルダ下にリストされます。ファイル名をダブルクリックするとテキストエデ

ィタで表示され編集ができます。 

3. プロジェクトをセーブします (File » Save)。 

VHDL テストベンチの新規作成 

新しい VHDL テストベンチドキュメントを作成してプロジェクトに追加したい場合は： 

1. Files パネルの New セクションの Other Document » VHDL Testbench を選択します。  

2. <name>.VHDTST、 この場合 BCD.VHDTST ファイルが作成され、Projects パネルの VHDL 
Testbenches フォルダ下にリストされます。 

3. 作成したテストベンチファイルをオープンし、必要なテストベンチコードを入力してから、この

ファイルをセーブします。  

VHDL モデルの追加 
デザインの作成はほとんど終了しましたが、まだシミュレーション用のビヘイビアモデルを含んでい

ない２つのコンポーネントがあります。この BUFGS コンポーネントにモデルを追加します。 

このチュートリアルでは BUFGS コンポーネントの VHDL ビヘイビアモデルを含んだ、

\Altium\Examples\FPGA\BCD Counter\VHDL Models\BUFGS.VHDMDL を追加してみます。 

1. Projects パネルのプロジェクト名称の上で右クリックし、Add to Project を選択しファイルを指

定してから 開く(O) ボタンを押して、この VHDL ファイルを FPGA プロジェクトに追加します。 

2. VHDL モデルドキュメントがプロジェクトに追加され、Projects パネルの VHDL Model 
Libraries フォルダ下にリストされます。ファイル名をダブルクリックするとテキストエディ

タで表示され編集ができます。 

3. プロジェクトをセーブします (File » Save)。 

VHDL モデルドキュメントの新規作成 
新しい VHDL モデルドキュメントを作成してプロジェクトに追加したい場合は： 

1. Files パネルの New セクションの Other Document » VHDL Testbench を選択します。 

2.   <name>.VHDMDL のフォーマット、この場合では BUFGS.VHDMDL のファイル名でセーブします。

セーブされたファイルは Projects パネルの VHDL Model Libraries フォルダ下にリストされま

す。 
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3. 作成した VHDL モデルファイルをオープンし、このコンポーネントのエンティティとアーキテク

チャーコードを入力してから、ファイルをセーブします。 

この VHDL モデルを BUFGS コンポーネントに追加します。シミュレーターはそのコンポーネントの

モデルを検出して、コンパイルプロセスに組み込みます。これを行なうには： 

1. 回路図シート上の BUFGS コンポーネントをダブルクリックし Component Properties ダイアログ

を表示させます。  

2. ダイアログ右下にある Models セクションの Add ボタンを押して、Add New Model ダイアログを

表示します。そのドロップダウンリストから VHDL を指定して OK ボタンを押すと、VHDL Model 
Properties ダイアログが開きます。 

3. モデルの名前は、VHDL モデルファイルの中のエンティティと同じでなければならないので、

BUFGS と入力します。このコンポーネントは統合ライブラリのオリジナルではないので、From 
integrated library ラジオボタンはグレーアウトしています。 すでにモデルファイルは FPGA プ

ロジェクトの追加されていますので、場所を指定する必要はありません。 あるいは直接 Options 
for Project dialog (Project » Project Options)ダイアログの Search Paths タブに、フルパスで

Altium\Examples\FPGA\BCD Counter\VHDL Models\と入力しておくこともできます。  

4. Description フィールドには BUFGS と入力します。この特殊なモデルは、シミュレーションとシ

ンセシスの両方に使用できるモデルですので、Simulation/Synthesis ボックスには Simulation 
and Synthesis と表示されています。OK を押してダイアログを閉じます。 

VHDL ライブラリの使用 
PARITYコンポーネントはVHDLライブラリを利用します。VHDLライブラリには、様々なコンポーネ

ント、パッケージ、タイプ、定数などを含んだVHDLドキュメントが含まれます。これらのファイルは、

VHDLライブラリファイルの名称と同じ論理名にマップされています。 

VHDL コード内で Library と Use ステートメントを使用することで、このライブラリからエキスポー

トされたすべての VHDL ファイルの構造を利用することができます。シミュレーターは、最初にすべ

ての VHDL ライブラリをコンパイルし、続いてプロジェクトのモデルファイルとソースドキュメント

をコンパイルします。 

このチュートリアルでは Parity コンポーネントのビヘイビアコードをエキスポートした VHDL ライブ

ラリファイル\Altium\Examples\FPGA\BCD Counter\VHDL Library\BCD_LIB.VHDLIB を追

加します。 

1. FPGA プロジェクトに VHDL ライブラリを追加するには、Projects パネルのプロジェクト名の上

で右クリックし Add to Project を選択、ファイルを指定して  開く(O)  ボタンを押します。 

9 

2. VHDL ライブラリドキュメントはプロジェクトに追加され、

Projects パネルの VHDL Libraries フォルダの下にリストされます。

ファイル名をダブルクリックすると、テキストエディタが開きファ

イルの閲覧や編集ができます。 

回路図に配置できる VHDL コード

のキーワードは以下の通りです。

.VHDL_ENTITY_HEADER 

.VHDL_ENTITY_GENERIC 

.VHDL_ENTITY_DECLARATION

.VHDL_ENTITY_STATEMENT 

.VHDL_ARCH_HEADER 

.VHDL_ARCH_DECLARATION 

.VHDL_STATEMENT 

3. プロジェクトをセーブします (File » Save)  
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VHDL ライブラリドキュメントの新規作成 
新しい VHDL ライブラリドキュメントを作成して、プロジェクトに追加する場合は： 

1. Files パネルの New セクションから Other Document » VHDL Library を選択します。  

2.  <name>.VHDLIB のフォーマット、この場合では BCD_LIB.VHDLIB のファイル名でセーブしま

す。セーブされたファイルは Projects パネルの VHDL Libraries フォルダ下にリストされます。 

3. VHDL » Edit Library を選択すると、ライブラリのドキュメントを追加できる Edit VHDL Library
ダイアログが開きます。  

VHDL ライブラリを作成したかまたは既存のライブラリを使用したかにかかわらず、以下のステップ

を行なってください： 

1. BCD_LIB.VHDLIB ドキュメントがオープンされていることを確認してから、VHDL » Edit 
Library を選択すると、Edit VHDL Library ダイアログが開き PARITY.VHD と UTILITY.VHD の 2
つのファイルが表示されています。最初のファイルは、Parity コンポーネントのためのエンティ

ティ宣言を含んでいます、2 番目のファイルには、パリティ機能を持つ Utility と呼ばれるパッケ

ージが入っています。ライブラリをコンパイルする順序は下から順に行なわれます、この場合、

PARITY.VHD の前に UTILITY.VHD がコンパイルされます。 

2. ファイルの並びが適切な順序であることを確認して OK ボタンを押します。 

3. VHDL » Edit Library を選択すると、ライブラリのドキュメントを追加できる Edit VHDL Library
ダイアログが開きます。 

プロジェクトに BCD.VHDLIB ライブラリドキュメントを追加しましたが、デザインで適切なリファレ

ンスを付ける必要があります。VHDL ファイルでこれらを行なうには Library と Uses ステートメント

を使います。しかし回路図でコンポーネントを使用しているときは、以下のことを行なう必要があり

ます： 

1. BCD8.SchDoc ドキュメントがオープンされていることを確認してから、Place » Text Frame を

選択します。回路図の左下に移動しそこにテキストフレームを配置してから、ダブルクリックし

て Text Frame ダイアログを表示させます。Text のとなりの Change ボタンを押して TextFrame 
Text ダイアログを表示します。 

2. 回路図の中で、VHDL コードの特別なヘッダを挿入することができます。この場合 Library ステー

トメントを挿入したいので、ライブラリステートメントの宣言.VHDL_ENTITY_HEADER を記述しま

す。下に示したテキストを入力し、OK ボタンをクリックします。 
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プロジェクトのセットアップ 
トップ階層の回路図と VHDL ファイルをプロジェクトに追加したので、プロジェクトのオプションを

設定します。 

1. FPGA プロジェクトに追加してある VHDL または回路図、例えば BCD.VHD をオープンします。 

2. メニューから Design  » FPGA Options を選択し、開いた VHDL Project Options ダイアログで設

定します。 

 

順序で

ファイルが

するには、

references
s Panel タブ

ションで設

  

3. Design Documents タブには、このプロジェクトに含まれるソー

キュメントのリストが表示されています。ドキュメントは下から

にコンパイルされます、この場合では BCD.VHD が最初にコンパ

れ次に回路図、最後にテストベンチファイルの順となります。ド

アンドドロップまたは Compile Sooner と Compile Later（Men
ンをクリックして表示）を使えばドキュメントの順序を、上の図

に変更できます。DXP » System Preferences で開く Design Ex
Preference ダイアログ Projects Panel タブ内の Show document 
コンパイルされる

Projects パネルの

表示されるように

DXP » System P
を選択し Project
内の Sort By セク

定できます。  

スド

上の順

イルさ

ラッグ

u ボタ

のよう

plorer 

position in project にチェックマ

11 



DXP での VHDL と回路図キャプチャー 

ークを付けて数字を表示するように設定した場合には、Projects パネルのドキュメント隣の数字

にもドキュメントの順序が反映されます。 

4. VHDL Project Libraries タブには、このプロジェクトに含まれているライブラリのリストが表示

されています。この例ではライブラリは１つしか含まれていませんが、ライブラリは下から順に

ビルドされます。そのためリストの最後のライブラリが最初にコンパイルされ、リスト一番上の

ライブラリが最後にコンパイルされることになります。Menu ボタンをクリックするか、ライブ

ラリ名称の部分で右クリックすると、ライブラリに適応できるコマンドを見ることができます。 

5. Simulation タブをクリックして Top-level entity/configuration フィールドにエンティティの名称を

入力します、この例ではテストベンチファイル BCD.VHDTST で定義されている通り、トップ階層

のエンティティは TestBCD です。 

 

デザインのコンパイル 
以上でデザインをコンパイルする準備が整いました。ライブラリファイル、モデルファイル、ソース

ファイルの順番でコンパイルされます。回路図ファイルは VHDL に変換され、対応する VHDL ファイ

ルはシミュレーターによってコンパイルされます。 

1. プロジェクトに含まれたソースドキュメントどれかをオープンした状態で、メニューから

Simulator » VHDL Compile を選択すると、Project Outputs フォルダに回路図ドキュメントから変

換された BCD8.VHD が作成され、Projects パネルの Generated VHDL Documents フォルダ下

に表示されます。 

2. メニューから View » Workspace Panels » Messages を選択するか、Messages タブをクリック

して Messages パネルを開き、コンパイル中に発生したかもしれないエラーを確認してください。

もし Messages パネルにエラーかウォーニングが表示されていたなら、エラー行をダブルクリッ

クすることで、その原因となる VHDL コードの該当行または回路図上の該当部分へジャンプする

ことができます。 

3. VHDL ファイルまたは回路図を修正し、プロジェクトファイルをセーブします。 

12 
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Smart Compile 
コンパイラーには、コンパイルする際の順序を自動的に決定するオプションがあります。このオプシ

ョンは‘Smart Compile’と呼ばれ、FPGA Preferences ダイアログ(Tools » FPGA Preferences)の
Smart recursive compile オプションをオンにすることで機能します。ボトムアップの順序でデザイ

ンが全てコンパイルされるか、これ以上コンパイルされるファイルが無くなるまで再帰的にコンパイ

ルを続行します。プロセスの最後に、コンパイルの順序を調整することができます。 

デザインのシミュレーション 
以上で、デザインのシミュレーションを始めることができます。シミュレーションを開始する前に、

ソースまたはライブラリドキュメントに変更があった場合、プリファレンスの設定を変更する必要が

あるかもしれません。 

1. テストベンチファイル<name>.VHDTST、この場合は BCD.VHDTST をオープンします。 

2. Design  » FPGA Options を選択し、VHDL Project Options ダイアログの設定をチェックまたは

変更します。  

3. Tools » FPGA Preferences を選択し、FPGA Preferences ダイアログの設定をチェックまたは変

更します。Show Waveform や Add top level signals to Waveform といった Wave Options が
選択されていれば、Waveform Viewer が自動的にオープンします。確認して OK ボタンをクリッ

クします。 
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4. Simulation タブをクリックして Simulation パネルを表示します。 

5.  Simulator » Simulate を選択すると、シミュレーションがイニシャライズされ、 Edit Simulation 
Signals ダイアログが表示されます。 

 
14 
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6. どのシミュレーション波形を、表示あるいはイネーブルにするかを選択してください。イネーブ

ルにすると、信号の推移をトラッキングします、Show Wave  だけ選択しているときには、波形

は観察できますが時間的推移はセーブされません。Done ボタンをクリックすると空白の.SO フ

ァイルが作成され Waveform Viewer が開きます。ドキュメントタブをクリックすると表示されま

す。 

 

 ‘U’ は ‘Undefined’を意味することに注意してください。これらの値はシミュレーションを実行し

たときに変更されます。 

7.  シミュレーションがイニシャライズされたならば、テストベンチの中で指定された時間の終わり

までシミュレーションを実行するか、またはデバッグモードを開始できます。 

デバッグモード 
デバッグモードの時、VHDL メニューから Custom Step (Simulator » Custom Step), Step Time, 
Delta Step, Step Into または Step Over といった、ステップバイステップのシミュレーションオプシ

ョンが使用できます。現在の実行ポイントを確認したい場合は FPGA Preferences ダイアログの

Show Execution Point オプションをチェックしてください。 

ブレークポイントの設定 
ブレークポイントの設定は：VHDL ファイルが開かれている状態で、ブレークポイントが設定できる

ラインに、青い小さな点が左側マージン部分に表示されています。  

1. ブレークポイントを設定したい行の横のマージン部分をクリックすると、X マークが表示された

赤い点で示された、ブレークポイントマークが表示されます。 

2. ブレークポイントを解除するには、再度ブレークポイントマークをクリックします。 

3.  Breakpoints タブをクリックするとブレークポイント・データが表示された Breakpoints パネル

が開きます。 

15 
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シミュレーションの実行 
シミュレーションがセットアップされると、すべての Run オプションが Simulator メニューから利用

可能になります。 

1. 適切な実行命令、例えば Simulator » Run を選択すると Enter Time Step ダイアログが表示され

るので、シミュレーションの実行時間を入力して OK ボタンをクリックします。入力した実行時

間は Simulator » Run for <time step>コマンドのためのデフォルト時間になります。 

2. シミュレーションが実行され、実行中には VHDL メニューの、Stop, End と Restart コマンドが

使用できます。  

3. シミュレーションの結果は、Simulation パネル、Waveform Viewer、Messages パネルで確認する

ことができます。Simulation パネルでは VHDL デザインの構造と有効な信号の変数と型、シミュ

レーション・タイム時の値を確認することができます。

 
Waveform Viewer では各イベント間の時間の計測 (Edit » Measure Time) 、遷移点または time 
marks を設定したポイントへのジャンプ (Edit » Jump) 、信号のグループ化 (Edit » Insert » 
Signal Group) 、信号の比較 (Edit » Insert » Comparison) が行なえます。 

ウォッチ・ポイントの設定 
VHDL Watches パネルを表示すると、ウォッチ・ポイントを設定することができます。  

1. Simulation パネルから VHDL Watches パネルへ、信号をドラッグアンドドロップします。あるい

は右クリックメニューからでも同様の操作ができます。  

2. VHDL Watches タブをクリックして VHDL Watches パネルを表示すれば、設定したウォッチ・ポ

イントの確認ができます。 

16 
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