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このアプリケーションノートでは、Altium Designer での回路図オブジェクトの配置や編集方法を紹介

します。 

 

 
このアプリケーションノートでは、回路図エディタで使用される一般的なデザインオブジェクトの配置と編集方法の概要を紹介しています。ワイヤやパー

ツなど、複雑なオブジェクトに関しては、より詳細な説明が記載されています。 

オブジェクト配置の基本 

グリッドとカーソル 
回路図エディタでオブジェクトを配置する前に、容易に配置を行えるよう、グリッドを設定します。Altium Designer では、表示用のビジブルグリッド、

配置用のスナップグリッド、接続箇所の作成を補助するエレクトリカルグリッドの 3 種類のグリッドが用意されています。グリッドは、ドキュメントオプション

になり、個別のデザインファイルに保存されます。このため、グリッドの設定は各デザインドキュメントで異なっている可能性があります。最初に
Document Optionsダイアログ（Design » Document Options）でグリッドを設定してください。  

ビジブルグリッドは、ズームレベルに応じて表示できるスペースがあれば、ラインかドットで表示されます。スナップグリッドは、回路図のデザインオブジェク

トを配置、移動する場合にカーソルがロックされるグリッドです。エレクトリカルグリッドは、オフグリッドパーツがあった場合、接続を行うため、スナップグリッ

ドを無視します。接続を行うため、ワークスペースで電気的なオブジェクトを移動した場合、他の電気的なオブジェクトのエレクトリカルグリッドの範囲

内に近づけると、カーソルがオブジェクトに引き込まれ、「ホットスポット」（赤い十字）が表示されます。エレクトリカルグリッドは、現在のスナップグリッドの

値より大きな値に設定すると、電気的なオブジェクトを 1 格子分離して配置するのが難しくなるので、スナ

ップグリッドより若干小さく設定すべきです。 

グリッドは、キーボードやマウスによるショートカットで簡単に値や有効・無効の切り替
えが行えます。例えば、G キーでスナップグリッドが 1、5、10と切り替わります。
Preferences ダイアログ（Tools » Schematic Preferences あるいは、ショートカット T, 
P）の Schematic – Gridsページを使って、Imperial（インチ）とMetric（ミリ）のグリッ
ドのプリセットができます。 

また、必要に応じて Preferencesダイアログの Schematic – Graphical Editingページの 
Cursor セクションでカーソルタイプの設定を変更することが可能です。例えば、カーソルタイプの設定で Large Cursor 90 の
オプションを選択すると、デザインオブジェクトの配置や移動を行う場合、カーソルがデザインウィンドウの端まで表示され
ます。 

デザインオブジェクトの配置 
回路図のデザインオブジェクトの配置方法の基本的な手順を以下に示します。 

1. 配置したいオブジェクトのタイプを選択します。オブジェクトタイプの選択は、Place（配置）メニューから項目を選択（例えば、
Place » Wire）するか、Placementツールバーのどれかをクリックします。配置のためのショートカットキーも用意されて
います。（例えば P, W でワイヤが配置されます。）コンポーネント（パーツ）を配置するには、Library パネルの Place
ボタンをクリックするか、Library パネルに表示されているコンポーネント名を選択し、ドキュメント上にドラッグします。 

2. 配置のためにオブジェクトが選択されると、カーソルは十字に変わり、編集モードであることを示します。そしてオブジェクトがカーソルのところにフロー

ティングの状態で表示されます。 

3. 配置中にオブジェクトの属性を編集するには、TABキーを押します。これによって、オブジェクトの Propertiesダイアロ
グが表示され、様々なオプションの変更が可能となります。  
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属性の設定が終了すれば、OKボタンをクリックし、配置モードへ戻ります。  

配置中にオブジェクトの編集を行うと、デジグネータのように数字を含んだ識別子が自動的にインクリメントされていきます。また、配置中に行った

変更は、そのオブジェクトタイプのデフォルト値になります。Preferencesダイアログ（T, P）の Schematic– Default Primitives ページ
にある Permanentオプションが有効でなければ、配置中に行ったオブジェクト属性の変更によってオブジェクト属性のデ
フォルト値が更新されます。 

4. オブジェクトを配置するにはカーソルを適切な位置に移動し、左クリックか ENTERキーを押します。ワイヤやポリゴンなどの

複雑なオブジェクトでは、カーソルの移動とクリックを繰り返して、オブジェクトの頂点をすべて配置します。 

注記 :オートパンの機能が有効であれば、編集ウィンドウの端を越えてカーソルを移動させるとドキュメントの表示エリアを移動することができます。

オートパンのスタイルとスピードは、Preferencesダイアログの Schematic – Graphical Editingページで設定が可能です。 

Preferencesダイアログの Schematic – AutoFocusページにあるオートフォーカスオプションで、接続されているオブジ
ェクトを配置または編集するときに回路図画面を自動的にズームしたり、現在配置しているワイヤに関係のないワイヤをす
べて薄暗く表示するなどのコントロールができます。 

その他、ズーミングやパンニングオプションは、ショートカットキーやマウスホイールで行えます。配置時に Ctrl+マウスホイールで、ズームイン、
ズームアウトが行えます。また、ホイールボタンを押して上に移動するとズームインし、下に移動するとズームアウトしま
す。Preferencesダイアログの Schematic – Mouse Configurationページで、マウスの動作の設定が可能です。 

5. オブジェクトを配置した後も、配置モードが継続され（カーソルが十字のマークのまま）、同じタイプの別のオブジェクトがすぐに配置できます。 

6. 配置モードを終了するには、右クリックか ESCキーを押します。ポリゴンの配置の様に、いくつかのケースでは、これを 2 回行う必要

があります。1 回でオブジェクトの配置を終了し、更にもう 1 回実行することで配置モードを終了します。配置モードを終了すると、カーソルはデフ

ォルトの形状に戻ります。 

特定のデザインオブジェクトに関する詳細は、回路図エディタでオブジェクト上にカーソルを移動させ、F1キーを押して
ください。Knowledge Centerパネルに該当するオブジェクトの詳細が表示されます。  

リエントラントな編集 
回路図エディタには、リエントラント（再帰可能）編集と呼ばれる強力な機能が用意されています。これは、ある操作を実行中に、その操作を中止す

ることなく、ショートカットキーで別の操作を実行する機能です。例えば、パーツを配置中、SPACEBARで回転させることができ、配置
の作業がキャンセルされることはありません。パーツの配置が済めば、次のパーツが現れ、回転させることができます。  

再帰編集が有効に使える例としては、ポートにワイヤを接続する場合で、先にワイヤの配置を始めてから、まだ、配置していないポートに接続をする

場合です。ワイヤの配置モードを終了する必要はなく、単にポートを配置するショートカットキー（P, R）を使ってポートを配
置し、Escキーでポートの配置を終了し、ワイヤをポートに接続します。 
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回路図ドキュメント上の距離の測定 
回路図エディタには、距離ツールが Reports メニューにあります（Reports » Measure Distance または Ctrl+M ショートカ
ットキー）。このツールを使用して、回路図ドキュメント上の 2 つの点の間の距離を測定することができます。 

このコマンドを実行すると、回路図ドキュメント上の 2 つの点をクリックするよう求められ、2 つの点を選択すると、
Information ダイアログに、全体の Distance 値、X Distance と Y Distance の値が、小数点以下 2 桁で表示されます。  

測定単位は、回路図ドキュメントで選択したシステム単位で決まります（Design » Document Options）。ダイアログに測定
単位が含まれていない場合、そのドキュメントはデフォルト単位 DXP（1 単位は 10 ミル）を使用するように設定されている
ことを意味します。システム単位を切り替えることで、Imperial と Metric の単位を切り替えることができます（View » 
Toggle Units）。 

グラフィカルオブジェクトの配置 
回路図オブジェクトは、グラフィカルと電気的なオブジェクトの 2 つのグループに分けられます。   

ラインや円弧、文字などのグラフィカルオブジェクトを配置するには、Utilities ツールバー（View » 
Toolbars » Utilities）から利用可能な、Drawing Tools ツールバーを使用します。Paste Array（Edit » Paste 
Array）を除く、Drawingツールバーの機能は Place » Drawing Toolsメニューからアクセスすることがで
きます。 

電気的なオブジェクトの配置 
回路図の電気的なデザインオブジェクトは、実際の回路を作画するために用いられます。電気的オブジェクトには、コンポーネント（パーツ）とワイヤや、

バス、ポートのように接続するためのオブジェクトが用意されています。電気的オブジェクトを配置するには、PlaceメニューかWiringツー
ルバー（View » Toolbars » Wiring）を使用します。  

 

次のセクションではパーツ（コンポーネント）とワイヤの 2 つのオブジェクトタイプの配置方法を紹介します。  

パーツの配置 
Place » Part (P, P)を選択するか、ワイヤリングツールバーの  ボタンをクリックします。Place Part ダイアログが表示され
ます。Lib Ref フィールドにコンポーネントの名称を入力するか、ブラウズボタン (…)をクリックし、ライブラリからパート
を検索するか、適切なライブラリを追加します。Historyボタンをクリックすると以前配置したパーツを検索することができま
す。 

 
また、パーツは、Library パネルの Place ボタンや回路図のライブラリエディタからでも配置できます。あるいは Libraries パ
ネルでコンポーネント名をリストから選択し、ドキュメント上にドラッグすると、カーソル上にフローティングの状態で現れ、
配置が可能となります。クリックで配置が確定します。 
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パーツの配置には、スナップグリッドをお使いください。ピンエンドをグリッドポイント、例えば、10 に固定することができます。G キーでスナップグリッドが 1、

5、10 と切り替わります。 

ワイヤの配置 
ワイヤは、ポイント間の電気的な接続を示すために使用されます。ワイヤを配置するときには、

誤ってラインコマンドを使用せずに、必ず、Place » Wire コマンド  を使用して
ください。また、ワイヤの配置コマンドは回路図ドキュメント上で右クリックか、
Wiring ツールバーからも実行できます。 

ワイヤの終端は、電気的なオブジェクトの接続ポイントと接続する必要があります。例えば、ワイヤを

ピンに接続するには、ワイヤの終端をピンのホットエンドに接続します。ワイヤを配置するときには、エレクトリカルグリッドの範囲内にある別の電気的な

オブジェクトに近づけると、カーソルがオブジェクトに引き込まれ、「ホットスポット」（赤い十字）が表示されます。このホットスポットによって有効な接続ポ

イントが示され、カーソルはエレクトリカル接続ポイントに自動的に引き込まれます。ワイヤはホットスポット上で終了すると、自動的に切断されます。 

エレクトリカルグッドをスナップグリッドより大きな値を設定すると、電気的なオブジェクトを 1 格子分離して配置するのが難しくなるので、スナップグリッド

より少し小さな値に設定することをお勧めします。  

配置したワイヤが電気的なオブジェクトに接続していない状態で、配線を中断するには右クリック（あるいは ESCキー）を実
行します。更に、右クリック（あるいは ESCキー）を実行すると、配置モードを終了します。 

ワイヤの配置中、BACKSPACEキーで直前に配置した頂点を削除することができます。 

ワイヤの配置モード 
ワイヤを配置するときには、SHIFT+SPACEBARでワイヤの配置モードが切り替わります。用意されている配置モードは以下のとお

りです：  

• 90度 

• 45度 

• フリーアングル 

• オートワイヤ 

モードは、ワイヤを配置する際のコーナーの作成方法と、配置角度がどのように作成されるかを指定します。SPACEBAR を押すと開始と終了
のサブモードが切り替わるか（90°モードまたは 45°モードの場合）、フリーアングルとオートワイヤモード間で切り替わりま
す（これらのモードのいずれかがアクティブな場合）。  

オートワイヤモードは特別なモードで、指定した回路図上の 2 点を自動的に接続します。オートワイヤ機能が自動的に障害物を避けて接続します。

このモードで TABキーを押すと、オートワイヤのオプション設定を行う、Point to Point Router Optionsダイアログが表示さ
れます。 

ジャンクション 
ワイヤには、オートジャンクション機能が用意されています。ワイヤの始点か終点が別のワイヤやピンに接続するとジャンクションオブジェクト（ドット）が自

動的に挿入されます。オートジャンクションとマニュアルジャンクションの表示、ジャンクションサイズと色
は、Preferencesダイアログの Schematic - Compilerページでコントロールすることができます。また、
ワイヤの交差を設定し、既存のワイヤを交差に変換するためのオプションが、Preferences ダイアログの
Schematic – General ページに用意されています。 

配置したワイヤの編集方法はこのアプリケーションノート後半にある 配置したワイヤの編集 を参照してください。 
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回路デザインオブジェクトの編集 
回路図上に配置したオブジェクトには、様々な編集方法が用意されています。オブジェクトはドキュメント内での移動や、ドキュメント内およびドキュメ

ント間での切り取り、コピー、貼り付けなどの操作が可能です。また、オブジェクトの色、デジグネータ、ネット割り付けなど属性の変更も可能です。 

ポリライン形状（バス、ワイヤ、ポリゴン、ラインなど）などのいくつかのオブジェクトでは、配置後にグラフィカルに形状を変更することができます。 

一つのオブジェクトを編集することも、クエリなどの強力な編集機能を使ってデザイン全体のオブジェクトを編集することも可能です。Find Similar 
Objectsダイアログや SCH Listパネル、SCH Inspectorパネルなどの強力なツールで、グループ化したオブジェクを一度に編
集することができます。  

詳細は、チュートリアルTU0115 複数オブジェクトの編集 を参照してください。 

配置されたコンポーネント（パーツ）とフットプリントは、それらの属性ダイアログで変更が可能です。あるいはライブラリエディタで変更し、更新することが

できます。ピンは、回路図の Component Propertiesダイアログ（の Edit Pins ボタン）から Component Pin Editor を使って編集
することができます。  

ライブラリエディタを使用してのパーツやフットプリントの作成や編集方法の詳細は、チュートリアル TU0103 ライブラリ・コンポーネントの作成 を参

照してください。 

配置されたオブジェクトのグラフィカルな編集 
ワークスペースに表示されているオブジェクトをグラフィカルに編集するのは簡単です。これを行うには、まず、オブジェクトを選択する必要があります。  

オブジェクトが選択されると、オブジェクトの移動やグラフィカルな属性が変更できます。オブジェクトを選択するためにク
リックすると、「ハンドル」や頂点が表示されます。 選択されたオブジェクトをグラフィカルに編集するには、ハンドル

上でクリックし、ボタンを押さえ続けます。オブジェクトのそのポイントがカーソルとともに移動しますので、新しい位置にマウスを移

動させ、サイズを変更しボタンを放します。オブジェクトを移動するには、オブジェクト上でマウスボタンを押さ
え続け、ドラッグします。また、削除するには、Deleteキーを押します。  

配置されたワイヤの編集 
頂点の移動、セグメントの移動、ワイヤ全体の移動、ワイヤを伸ばすなど、配置されたワイヤの編集方法はいくつか用意されています。また、ワイ
ヤのPropertiesダイアログにあるVerticesタブから頂点の追加や削除が可能です。詳細は、Propertiesダイアログから頂点の編集を参

照してください。 

ワイヤの頂点移動による編集 
ワイヤの頂点を移動するには、ワイヤをクリックして選択します。移動したい頂点上にカーソルを移動すると、カーソル

が 2 方向の矢印に変わります。図のようにマウスボタンをクリックしたまま、頂点を新しい位置にドラッグします。 

ワイヤセグメントの移動 
ワイヤのセグメントを移動することも可能です。ワイヤを選択し、カーソルをセグメントの上に移動すると、カーソルが 4

方向の矢印に変わります。下の図のようにマウスボタンをクリックしたまま、セグメントを新しい位置にドラッグします 

 

ワイヤ全体の移動 
形状を変えずにワイヤ全体を移動するには、選択をしないで単にドラッグをします。 

 

ワイヤの延長 
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配置されたワイヤは伸ばしたり、頂点を追加することができます。ワイヤを選択し、カーソルをワイヤの終端に移動す

ると 2 方向の矢印に変化します。ワイヤの終端をクリックしてドラッグすると、「ルックアヘッド」セグメントが表示され、

新しい位置でクリックすると配置されます。カーソルを移動中、SHIFT + SPACEBARで配置モードを変更
することができます。 
同じ方向に伸ばしたい場合は、選択した終端をドラッグする際に ALT キーを押してください。 

ワイヤの切断 
Edit » Break Wireコマンドでワイヤセグメントを 2つに切断することができます。このコマンドは、カーソルがワイ

ヤ上にあるときに右ボタンクリックを実行することでも利用できます。（デフォルトでは）表示される「カッターボックス」をワイヤセグメン

ト上に配置することで、カットします。カットされる部分は、図のようにマスク表示されます。カットされる長さは、2 つセグメントの距

離になります。コマンドを実行中、SPACEBARを押すと、カットする長さが（セグメントにスナップ、グリッドサイズにスナッ
プ、固定長の）3つのモードで切り替わります。TAB キーを押すと、固定長の長さやその他のカッターオプションが設定でき
ます。ワイヤをカットするにはクリックします。右クリックか、ESCキーを押すとワイヤ切断モードが終了します。ワイヤ切断のオプシ
ョンは Preferenceダイアログの Schematic – Break Wire ページでも設定が可能です。  

Preferenceダイアログの Schematic – General ページの Components Cut Wiresオプションも設定することができます。こ
のオプションと Optimize Wires and Busesオプションが有効であれば、コンポーネントをワイヤ上に配置すると、ワイヤが
2つに分割され、その終端がコンポーネントの 2つのピンと自動的に接続されます。 

マルチワイヤ 

 
Drag and release one vertex and all aligned 
vertices will move to remain aligned. 

回路図エディタのマルチワイヤ編集モードでは、複数のワイヤを同時に延長することができ

ます。平行した複数のワイヤで、終端座標が同じになっているものの一つのワイヤをドラッ

グすると、選択されているその他のワイヤも移動し、終端の位置が揃います。  

回路図オブジェクトの移動とドラッグ 
Altium Designerでのオブジェクトの移動は、それに接続されているオブジ
ェクトに関係なく、移動が行われます。例えば、コンポーネントを移動する場合、

そこに接続されているワイヤは移動しません。逆に、コンポーネントのドラッグでは、移動後、

ワイヤとの接続が維持されます。選択したオブジェクトを移動する際、常に電気
的な接続を維持したい場合は、Preferencesはダイアログの Schematic – 
Graphical Editingページの Always Drag オプションを有効にします。 

オブジェクトの移動 
単独の選択されていないオブジェクトあるいは、選択されている複数のオブジェクトをマウ

スのドラッグで移動することができます。また、特に配置されているオブジェクトの
前後にオブジェクトを移動したい場合、Edit » Moveコマンドを使用するこ
とができます。 

シート内でオブジェクトを移動する場合には、あらかじめオブジェクトを選択する必要はありません。単に電気的なホットスポットマークが表示されるま

でマウスボタンを押さえ続け、コンポーネント／オブジェクトを新しい位置へドラッグします。カーソルが一番近い電気的なホットスポットに移動します。

例えば、オブジェクトをクリックしたとき、カーソルはピンに も近ければそこに移動します。これは Preferencesダイアログの Schematic – 
Graphical Editingページの Object’s Electrical Hot Spot オプション（デフォルト）、または Center of Objectオプションに
よって移動やドラッグする際の動作が決まります。 

オブジェクトの移動中： 

• SPACEBAR を押すと、オブジェクトは回転します。回転は、反時計回りで 90°ステップで回転します。
SHIFT+SPACEBAR を押すと、オブジェクトは時計回りで回転します。 

• Xキー、Y キーを押すと X軸、Y軸に沿って、それぞれオブジェクトが反転します。 

• ALTキーを押すと、移動方向が垂直、水平方向のいずれかに制限されます。 

オブジェクトの移動 
選択したオブジェクトを移動するには、回路図ドキュメント上で Ctrl キーと矢印キーの組み合わせを使用するか（垂直または
水平）、Ctrl キーと Shift キーと矢印キーの組み合わせを使用します。 

選択したオブジェクトの移動は、Document Options ダイアログ（Document » Options またはショートカット D, O）の現在
の Snap Grid 設定に応じて設定されます。このダイアログでスナップグリッド値を変更します。このグリッド値は、Altium Designer のス
テータスバーにも表示されます。Preferences ダイアログの Schematic - Grids ページを使用して Imperial（インチ）と Metric
（ミリ）のグリッドのプリセットを設定することもできます。スナップグリッド設定値を切り替えるには、ショートカット G 
を使用します。あるいは、View » Gridsのサブメニューや右クリックメニューから Grids を選択します。 
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• Ctrl キーを押しながら矢印キーを押すと、選択したオブジェクトは、現在のスナップグリッド値に応じて少し移動します。 

• Ctrl キーと Shift キーを押したまま矢印キーを押すと、選択したオブジェクトは、スナップグリッド値に 10 を掛けた分だけ
大きく移動します。 

オブジェクトのドラッグ 
Edit » Move » Drag コマンドで 、コンポーネント（パーツ）やポート、ワイヤ、バスなど、ワイヤが接続されているオブジェ
クトの接続を維持した状態での移動が可能です。カーソルが十字に変化し、ドラッグしたいオブジェクトの上でクリックする
か、ENTERキーを押します。オブジェクトを移動し、適切な位置でクリックするか、ENTERキーを押します。引き続き、他の

オブジェクトが移動するか、あるいは、右クリックか ESC キーでドラッグモードを終了します。 

選択した複数のオブジェクトを、接続を維持したままドラッグするには、Edit » Move » Drag Selectionコマンドを使用しま
す。 

あるいは、ショートカットキーを使用してオブジェクトをドラッグすることも可能です。クリックするときに CTRL キーを押さえ続け、マウスを
移動します。ドラッグを始めた後、CTRLキーを放しても構いません。これはオブジェクトを複数選択した場合も動作します。CTRLキ
ーを使用すると、Preferencesダイアログの Always Dragオプションの設定が一時的に切り替わりますので、注意してくださ
い。 

オブジェクトをドラッグしている間は： 

• ドラッグ中に SPACEBARか、SHIFT+SPACEBARを押すと、ワイヤの配置モードが変化します。 

• 移動中、CTRL+SPACEBARでオブジェクトが回転します。回転は、反時計回りで 90°ステップで回転します。 

• 移動中、X か Yキーを押すと、X軸、Y軸に沿って反転します。 

• 移動中、SPACEBARを押すと、オブジェクトに接続されているワイヤのモードが変化します。 

• 移動中、ALT キーを押すと、移動方向が最初に移動した方向によって、垂直、水平方向のいずれかに制限されます。  

オブジェクトの移動をロックする 
回路図オブジェクトが誤って移動されるのを防ぐために、これらのオブジェクトの Locked 属性を有効にして、グラフィカル
に編集できないようにすることができます。ロックされたデザインオブジェクトを編集しようとすると、Confirm ダイアログ
が表示され、動作を続行するかどうかを質問されます。  

Preferences  ダイアログの Schematic - General ページで Protect Locked Objects オプションが有効になっており、このデ
ザインオブジェクトの Locked オプションが有効になっている場合、このオブジェクトは移動できず、メッセージも表示され
ません。ロックされたオブジェクトを含むオブジェクトグループを選択しようとしても、ロックされたオブジェクトは選択されません。 

コピー＆ペーストの使用法 
回路図エディタでは、回路図ドキュメント内やドキュメント間でオブジェクトのコピー、ペーストができます。例えばコンポーネントをあるドキュメントから別

のドキュメントへコピーすることができます。オブジェクトをウィンドウズのクリップボードへコピーし、別のドキュメントへ貼り付けることができます。テキストは

ウィンドウズのクリップボードから回路図のテキストフレームへコピーすることができます。また、Microsoft Excel などの他のアプリケーションや
Altium Designer内のグリッドスタイルコントロールから、テーブルタイプのセレクションを直接コピー／ペーストすることが
できます。更に、高度なコピー／ペーストの操作は、スマートペースト機能を使って行えます。 

コピーしたいオブジェクトを選択し、Edit » Copy (Ctrl+C) を選択してコピーするオブジェクトの原点でクリックします。こ
れは、貼り付けする際、正確な位置にオブジェクトを配置するためです。尚、この機能を利用するには、Preferences ダイア
ログの Schematic – Graphical Editing ページの Clipboard Reference オプションが有効である必要があります。 

スマートペーストの使用 
回路図エディタのスマートペースト機能により、選択したオブジェクトを他のオブジェクトに変換して、ペーストすることができます。例えば、選択したネッ

トラベルをコピーし、スマートペーストにより一回の操作で、ポートとしてペーストしたり、選択したシートエントリをネットラベル+ワイヤとしてペーストするこ

とができます。 
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スマートペーストを使用して、コピーしたシートエントリをネットラベル+ワイヤに変更 

スマートペーストする時に、特定のオブジェクトをコントロールすることもできます。チェックボックスを無効にして、特定オブジェクト

のスマートペーストを行わせません。 

その他の便利な機能は、選択した回路をグラフィックとして貼り付ける機能です。これを使用して、他のシートにある回路のグラフィックな箇所を簡単

に含めることができ、必要に応じてそのサイズを設定します。Edit » Smart Paste を選択して、貼り付ける時に、クリップボードにコピ
ーされたオブジェクトを変更します。 

シート上でのテキスト編集 
テキストストリングは、回路図エディタ上で直接編集することができます。クリックしてテキストストリング、テキストフレーム、ノートの
いずれかを選択し、再度クリックする（あるいはショートカットキーF2を押す）と、回路図シート上で直接テキストが編集で
きます。この動作は、Preferencesダイアログの Schematic – Generalページにある Enable In-place Editingオプションをオ
フにすることで無効にできます。  

アノテーションとリ・アノテーション 
Altium Designer には、3 種類のアプローチが用意されています。回路図レベルのアノテーション、ボードレベルのアノテーション、PCB アノテーションで

す。   

回路図のアノテーション機能では、パラメータによりコンポーネントを一致させることができ、すべてのデジグネータまたは
重複するデジグネータのリセット、PCB ドキュメントから回路図へのバックアノテート、回路図シート毎のデジグネータイン
デックスコントロール、サフィックスオプションが用意されています。  

回路図エディタで、Tools » Annotate Schematics コマンドを使用して Annotate ダイアログを開きます。そこで、カレント
プロジェクトの選択したシート内のすべてまたは選択した部品のデジグネータを、固有に連続した順番で再割り当てできます。 
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Annotateダイアログがオープンされているとき F1キーを押すと、このプロセスの詳細情報が表示されます。 

また、Annotate ダイアログを実行せず、現在、デジグネータが割り当てられていない部品へ固有のデジグネータを割り当てる
には Tools » Annotate Schematics Quietly コマンドを使用します。このコマンドは、以前 Annotate ダイアログで設定した
回路図アノテーション設定に従います。Annotate Schematics Quietly は、重複に対して固有のデジグネータを割り当てませ
ん。 

アクティブプロジェクトのすべてのコンポーネント デジグネータをリセットする場合、必要に応じて、Tools » Reset 
Schematic Designators コマンドを使用できます。または、重複しているデジグネータをリセットする場合は Tools » Reset 
Duplicate Schematic Designators コマンドを使用します。 

Annotate ダイアログで定義した回路図アノテーション設定に従って、すべてのコンポーネント デジグネータをリ-アノテート
するには、Tools » Force Annotate All Schematics コマンドを使用します。 

PCBドキュメントでデジグネータをリ-アノテートする時、生成されたWAS-ISファイルを使用して、バックアノテート
（Tools » Back Annotate Schematics）により、アクティブプロジェクトのソース回路図シート内のコンポーネントのデジグ
ネータを更新できます。 

ボードレベルアノテーションは、回路図エディタを通じて、コンパイルしたコンポーネント（コンポーネントの物理的なビュー）をアノテートすることです。

Tools » Board Level Annotate コマンドを使用して Board Level Annotate ダイアログを開きます。このダイアログで、命名方
式に基づきコンパイルしたコンポーネントの命名規則の計算、PCBドキュメントからコンパイルしたドキュメントへのバック
アノテート、カスタム名の指定、すべてのデジグネータのリセットを行うことができます。 

 
Board Level Annotation ダイアログでは、アノテートオブションを通じた命名方式のカスタマイズ、すべてのデジグネータのリセット、コンポ
ーネントに対するカスタム名の作成を行うことができます。 
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PCB エディタで、Tools » Re-Annotate コマンドを使用して Positional Re-Annotate ダイアログを開き、デジグネータを前後
関係に依存して再割り当てすることができます。リ・アノテーション操作によって、ファイル名に日付と時刻を含む固有の 

*.WAS ファイルが生成されます。このファイルは、回路図のアノテーションまたはボードのアノテーション中にバックアノテーションを実行するときに

使用されます。 

 
デザインのアノテーションの詳細については、アプリケーションノートAP0140 設計のアノテーションについて を参照してくだ
さい。 

オブジェクトの属性編集 
オブジェクトの属性を表示、編集するには、次のいずれかの方法で、Properties ダイアログをオープンします： 

• 配置中などオブジェクトがカーソルで移動できるフローティング状態の時、TABキーを押し、Properties ダイアログをオ
ープンします。 

• 配置されているオブジェクトをダブルクリックし、直接オープンします。 

• メニューから Edit » Change を実行し、編集モードに入ります。編集したいオブジェクトをクリックします。編集モードを終了する
には、右クリックか ESC キーをクリックします。 

• 配置されたオブジェクトを選択するためにクリックし、次に紹介する SCH Inspectorや SCH Listパネルを使って編集しま
す。 

Propertiesダイアログから頂点の編集 
バス、ワイヤ、ポリライン、ポリゴンオブジェクトの Properties ダイアログにある Vertices タブで、頂点の座標を編集できま
す。例えば、Wire properties ダイアログには Vertices タブがあります。そこで必要に応じて選択したワイヤオブジェクトの
個々の頂点を編集できます。 

 

タブには、ワイヤの現在のすべての頂点がリスト表示されます。ワイヤに新しい頂点を追加、既存の頂点の座標を編集、選択した頂点全体を削除

できます。 

Menu ボタンをクリック、またはメインリスト領域内で右クリックし、表示されたポップアップメニューから希望の設定（頂点の編集、追加、削除、またはセ

ルのコピー、貼り付け、選択、移動）を選択します。Move Wire By XY コマンドは、全体のワイヤオブジェクトを移動します。Move 
Wire By ダイアログで、各頂点の X、Y座標に適用する値を入力できます。 
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SCH Inspectorパネルでのオブジェクト編集 
SCH Inspector パネルでは、現在アクティブな、または開いているドキュメントの 1
つ、または複数のデザインオブジェクトの属性を表示および編集できます。SCH 
Filter パネル(F12)、または Find Similar Objects コマンド（Shift+F、または選択し
たオブジェクトを右クリックし、Find Similar Objects を選択）と併用して使用する
と、同じ種類の複数のオブジェクトを変更できます。 

1つ、または複数のオブジェクトを選択して、F11 を押すか、または SCH Inspector 
タブをクリックして SCH Inspector パネルを表示します。もし、パネルが表示されな
い場合、ステータスバーにある SCH ボタンをクリックし SCH Inspectorを選択する
か、または View » Workspace Panels » SCH » SCH Inspectorを選択します。また、
デザインオブジェクトをダブルクリックした時、オブジェクトの Properties ダイアロ
グを表示する代わりに SCH Inspector パネルを表示するには、Preferences ダイアロ
グの Schematic – Graphical Editing ページの Double Click Runs Inspector オプシ
ョンで設定できます。 

SCH Inspector パネルは、選択したオブジェクトに共通な属性を表示するだけである
ことに注意してください。リスト表示された属性は SCH Inspector パネルで修正で
きます。新しい属性を入力しチェックボックスをクリック、またはドロップダウンリストから選択します。

Enter を押すか、またはパネルの他のセルをクリックして変更を実行します。  

複数のオブジェクトを編集するには、チュートリアルTU0115 複数オブジェクトの編集 を参照してく

ださい。 

SCH Listパネルでのオブジェクト編集  
オブジェクト（または、複数のオブジェクト）を選択して、Shift+F12 を押して SCH 
List パネルを表示します。SCH Filter パネル (F12) 、または Find Similar Objects コ
マンド(Shift+F) と併用して使用する時、複数のデザインオブジェクトをターゲットと
し編集できます。SCH Listパネル上部の View/Edit ドロップダウンメニューから Edit
を選択して、SCH Listパネルからオブジェクトの属性を変更できます。  

 

SCH Listパネルの Object Kindのリストからオブジェクトをダブルクリックすると、そのオブジェクトの Propertiesダイアログが表示されま
す。 
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更新履歴 

Date Version No. Revision 

05-Jan-2004 1.0 New product release 

24-Mar-2005 2.0 Renamed from Object Placement and Editing. Concentrates on Schematic 
Editor objects only in Altium  SP3. 

29-Nov-2005 2.1 Updated for Altium Designer 6 

3-Oct-2007 2.2 Updated for Altium Designer 6.8 

14-Mar-2008 2.3 Updated Page Size to A4. 
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