
 

 

ライブラリコンポーネントの作成 

概要  

Tutorial  
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このチュートリアルでは、Altium Designerの回路図と PCBのライブラリ・エディタ
を使用して、回路図コンポーネントと PCBフットプリントを作成する方法を説明し
ます。 このチュートリアルで使用されている用語の説明が用語集として最後にまと
められています。 

 

 
このチュートリアルでは以下の内容を説明します。 

• ライブラリの新規作成 

• シングル、または複合の回路図シンボルの新規作成 

• 回路図ライブラリ・エディタのレポートを使用したコンポーネントのチェック 

• マニュアル、または PCB Component Wizard を利用した PCBフットプリントの新規作成 

• 異型パッド形状を含む、その他の特別なフットプリントの作成 

• 3次元コンポーネントの詳細(3Dボディ) 

• PCBライブラリ・エディタのレポートを使用したコンポーネント・フットプリントをチェック 

• 新しいコンポーネントとモデルを使用した統合ライブラリの新規作成 

このチュートリアルは、回路図と PCBエディタの操作環境についての理解、また、コンポーネントの配置や編集について慣れ
ている方を対象としています。 このチュートリアルで使用したコンポーネントやライブラリは、Altium Designerがインストー
ルされているフォルダ内の Creating Componentsに収められています。 

回路図ライブラリ、モデルと統合ライブラリ 
回路図コンポーネントシンボルは、回路図ライブラリ(.SchLib)で作成されます。 これらのライブラリのコンポーネントは、
個別のフットプリント・ライブラリやモデル・ファイルで定義されたフットプリントやその他のモデルを参照します。 これら
の個別のコンポーネント・ライブラリからコンポーネントを配置できます。 または、シンボル・ライブラリ、フットプリン
ト・ライブラリ、モデル・ファイルを統合ライブラリ(.IntLib)へコンパイルできます。  

統合ライブラリの長所は、持ち運びやすさ（1つのファイルにまとめられています）と、内部のコンポーネントやモデルを編
集できないようになっている点です。 Altium Designerのコンポーネントの多くは（ISO に対応した約 70,000のコンポーネン
ト）統合ライブラリとなっており、Altium DesignerがインストールされているフォルダのLibraryに保存されています。 統合ラ
イブラリからは、ソース・ライブラリを抽出することができます。統合ライブラリを開いてExtract Sourcesを選択してくださ
い。編集可能なコンポーネントとして開かれます。 詳細については、TU0111 統合ライブラリの作成 を参照してください。 

更に、Design » Make Project Libraryコマンドを使用して、アクティブなプロジェクトの回路図ドキュメントに配置されてい
るすべてのコンポーネントの回路図ライブラリを作成できます。 

回路図コンポーネントの作成 
回路図ライブラリ・エディタは、回路図コンポーネントを作成、修正し、コンポーネント・ライブラリを管理するために使用
します。 これは、回路図エディタに似ており、ピン・ツールが付加された同じグラフィック・デザイン・オブジェクトを共有
します。 

コンポーネントは、回路図ライブラリ・エディタ内のデザイン・オブジェクトを使用して作成します。 または、ある回路図ラ
イブラリから他の回路図ライブラリへ、あるいは回路図エディタから回路図ライブラリ・エディタへコピー、ペーストできま
す。 

新規のライブラリ・パッケージと回路図ライブラリの作成 
コンポーネントを作成する前に、それらを保存する新規回路図ライブラリを作成しておくことが必要です。 このライブラリは、
個別のファイルでモデルを参照して独立したライブラリとして作成することができます。 コンポーネントを作成するには、回
路図ライブラリと参照したモデルを統合ライブラリ・パッケージでコンパイルすることです。 これはライブラリを作成する前
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に、新規のライブラリ・パッケージを作成する必要があることを意味します。 ライブラリ・パッケージ(.LibPkg)は、統合ラ
イブラリの基本で、コンパイルして個々の回路図ライブラリ、フットプリント・ライブラリ、モデル・ファイルを 1つの統合
ライブラリ・ファイルに結び付けます。   

新規の統合ライブラリ・パッケージと空の回路図ライブラ
リを作成するには、次のステップを実行してください。 

図 2 NPNトランジス
タのシンボル 

Always Show 
Comment/DesignatorオオオオラをLibr
ary Editor 

ダラダダダかか有有ににに、ラWorkspace
ラララライイイイララ内の現現のラララララ

ララ用に のスララComment/Designator
ラダを表表ささささささささささ。

図 3 Library Editor Workspaceダイアログで単位やその他のシート
属性を設定 

1. File » New » Project » Integrated Libraryを選択しま
す。 新しいライブラリ・パッケージ、
Integrated_Library1.LibPkgが作成されます。 これは、
Projectsパネルに表示されます。 

2. Projectsパネル内のライブラリ・パッケージ名を右ク
リックし、表示されるメニューから Save Project As
を選択します。 New Library.LibPkg を入力し、適
切な場所を指定して Save ボタンをクリックします。 
拡張子を入力しない場合、拡張子は自動で追加される
ことに注意してください。 

3. File » New » Library » Schematic Libraryを選択し、
空の回路図ライブラリを追加します。 
Schlib1.SchLibという名称で新規のライブラリが作
成され、デザイン・ウィンドウに Component_1という
空のコンポーネント・シートが表示されます。 

4. File » Save As を選択し、Schematic 
Components.SchLib という名称でライブラリを保存します。 

図 1 新規のライブラリ（デフォルトの Component_1という名称で作成
されます）

5. SCH Libraryタブをクリックし、SCH Libraryパネルを開きます。 

新規の回路図コンポーネントの作成 
既存のライブラリで新規の回路図コンポーネントを作成するには、通常、Tools » New Componentを選
択します。しかし、新規のライブラリは常に空のコンポーネントシートが含まれる為、Component_1と言
う名称を変更して最初のコンポーネント（NPNトランジスタ）を作成します。 

1. SCH Libraryパネルの Componentsリストから、Component_1を選択し、Tools » Rename 
Componentを選択します。 Rename Componentダイアログで新しいコンポーネント名（例えば、
NPN）を入力し、OKをクリックします。 

2. 必要ならば、Edit » Jump » Origin [ショートカット J, O]を選択して、デザイン・ウィンドウの中央
（シートの原点）にカーソルを移動します。 原点にカーソルが移動しているかどうかは、画面の左下
のステータスを確認してください。 Altiumで用意されているコンポーネントは、シートの中央にある
縦と横の線が交差する位置を原点として作成されています。 常に、この原点の近くでコンポーネント
を作成する必要があります。 回路図上にコンポーネントを配置する時、この原点に一番近い電気的な
ホットスポット（ピンの端）でコンポーネントを、 � ’つかみ’ ます。 

3. 単位やスナップ、表示グリッドは、Library Editor Workspaceダイアログ(Tools » 
Document Options, ショ
ートカット T, D)で設定で
きます。  

さこかの つの設設は、3 Preferencesダラ
ダダダのSchematic – 
Gridsペラペさ設設ささささ。 

ダラグイを変変ささ必必さがさ時は、Librar
y Editor 
Workspaceダラダダダを開かかかにか、イ
ラーライのＧを押にに、簡簡にススグオダラ

グイを1, 5, 
さ切り換えささささささささ。10  

図 3に従って、Library 
Editor Workspaceオプショ
ンを設定します 。  それ
から、Unitsタブをクリッ
クし Imperial Unitsを有効
にして DXP Defaultsを指
定します。 OKボタンをク
リックし、ダイアログを閉
じます。 もし、ダイアログ
を閉じた時に回路図ライブ
ラリ・エディタの表示グリ
ッドが見えない場合、表示
するまで Page Upキーで

図 3
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拡大します。 ズームは、カーソルの周りで動作するので、原点の近くにカーソルを置いておくこと
に注意してください。 

Utilities toolbar  

 
4. NPNトランジスタを作成するため、初めにコンポーネントのボディを定義します。 Place » Line[シ
ョートカット P, L],を選択します。または、Place Line  ツールバーボタンを (Utilities ツールバ
ーの中にあります)クリックします。 必要ならば、TABキーを押して、PolyLineダイアログでライ
ンの属性を設定します。 図 4をガイドにして(グリッドラインを使用すると簡単に配置できます)、
垂直にラインを配置します。   

一度クリックして最初のラインの最初の端を決め、もう一方の端までマウスを移動してクリックし、
確定させます。右クリックか ESCを押してラインの配置を終了します。 カーソルに十字マークが表
示されている場合は、まだラインの配置モードになっていることに注意してください。 

図 4 NPNのボディ 

5.その他の 2 つのラインを作成します。 このトランジスタでは、不規則な角度にラインを配置します。 ラインを配置する時、
水平/垂直、または 45度に限定されることに気づくでしょう。 配置モードを切り換えるには、ラインを配置中に Shift + 
Spacebarを押します。 モードの 1つにフリーの角度の配置モードがあります。 このモードにより、正確にラインを定義
することができます。 これらの 2つのラインを定義した後、配置モードを解除するには、ESCを押します。 

6. 矢印の先は、閉じたポリゴンで作成します。 Place » Polygon[ショートカット P, Y],を選択します。または、Place 
Polygon ツールバー ボタン (Utilities ツールバー)をクリックします。 ポリゴンを配置する前に、TAB キーを押して
Polygonダイアログで属性を設定します。 Border WidthをSmallestに設定し、Draw Solidを有効にします。 そして、fillと
border色を同じ色（基準色 229）に設定してOKをクリック、しダイアログを閉じます。 三角形の各頂点を定義し、右クリ
ックして終了します。 右クリックか、ESCを押してポリゴンの配置モードを終了します。 図 5は、ポリゴンの頂点の座標
を示します。 

ダラググググかラララの正正か位位は

、重必さはがりささで。 
ラララララララココララさ重必かささ

は、ピラの場場か、ピラのホグラスラ
グラさ呼ばこさ特特か場場ささ。 
さこは、電電電か接接を構構ささ場場

さ、ピラは常に配配に適ささダラグイ

さ配位さすさささ。  

  
図 5 矢印の先端の座標が正しいか確認するには、座標情報を使用してください。 

7. コンポーネントを保存します[ショートカット Ctrl + S]。 

回路図コンポーネントにピンを追加 
コンポーネントのピンは、コンポーネントに電気的な属性を割り当てて、接続箇所を定義します。 
また、グラフィカルな属性も割り当てられます。 

コンポーネントにピンを配置するには: 

1. Place » Pin [ショートカット P, P]を選択するか、  ツールバーボタンをクリックします。 ピ
ンがカーソルに表示されます。 カーソル側が電気的にホットな端子になり、コンポーネントの
ボディ側と逆の位置に配置します。  

2. ピンを配置する前、配置中にTABキーを押してピンの属性を編集します。 Pin Propertiesダイ
アログ(図 8)が表示されます。 ピンを配置する前にピン属性を定義した場合、定義した設定がデフォルトになります。 そし
て、ピン番号と数値のピン名称は配置するごとに自動的にインクリメント(+1)されていきます。 

 
図 6 ピン名称と番号が表示さ
れた NPNシンボル 

3. Pin Propertiesダイアログで、Display Name欄にピン名称(最初の NPNのピン番号である 1)を、Designator欄にピン番号
(同じく 1)を入力します。 もし、回路図シート上にコンポーネントを配置した時にピン名称と番号を表示したい場合は、
Visibleのチェックボックスにチェックを入れます。 

4. ドロップダウン・リストからピンの Electrical Typeを設定します。 このタイプは、回路図シートの電気的な接続エラーを
検知するために、プロジェクトをコンパイルする時、または回路図ドキュメントを分析する時に使用します。 このコンポ
ーネントの例では、すべてのピンの Electrical Typeが Passiveで設定されています。 

5. このピンの長さを設定し、OKをクリックします。 （このコンポーネントの全てのピンを 20に設定します。 
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6. カーソルにピンが表示されている時に SPACEBAR を押すと、ピンを 90ºごとに回転でき
ます。 ピンの一端だけが電気的な接続ポイント（ホットスポット）であり、この端子は、
コンポーネントのボディ側と逆側に配置する必要があることを覚えておいてください。 
ピンの非電気的な接続ポイントの先に、ピン名称があります。  

図 7 3つすべてのピンのピン名称
と番号の表示を編集 

7. コンポーネントを完成させるのに必要なピンを更に追加し、ピン名称、番号、シンボル、
電気的なタイプがに示された NPNシンボル と同様になっているか確認します。  図 6

 

 

ピラ名名、さまは番番さララララララ

ラのーコグ間の距距を ラライの(1 10
分の の簡位さ変変にまし場場は、0 1 )

Tools » Schematic 
を選選に、Preferences Schema

tic — General ペラペのPin 
Margin オオオオラを変変にささ。 

  
図 8 ピンを配置する前にピン属性を設定 

8. もし、ピン名称と番号をすべて表示して配置した場合、容易に一回の操作ですべての表示状態を変更できます。 これを実
行するには、3つのピンだけを選択（Shift + クリックで各ピンを選択）し、F11 を押して Inspectorパネルを表示させま
す。そして、 のように Show Nameと Show Designatorのオプションを無効にします。  図 7

9. これでコンポーネントの作画は終了しました。File » Save を選択してファイルを保存します。   

ピン追加時の注意点 
• ピン配置後にピン属性をセットするには、そのピンをダブルクリックするか、SCH Libraryパネルの Pinsリストをダブル
クリックし Pin Propertiesダイアログを開きます。 あるいは、上記のように Inspectorで複数のピンを編集します。 

• ピンの名前の上にバーを表示したい場合は、その文字の後ろにバックスラッシュ(\)を使用します。 例えば、M\C\L\R\/VPP 
と記入すれば表示は となります。 

• 電源や GNDピンなど回路図では表示させない（ヒドゥン）ピンは、Hide オプションを有効にします。 ヒドゥン・ピンは
Connect Toフィールドに記入されている電源や GNDネットに接続されます。 例えば、VCC用のピンは、コンポーネント
の配置時、自動的に VCCネットに接続されます。  

• ヒドゥン・ピン、またはヒドゥン・ピンのピン名称/番号を表示させるには、View » Show Hidden Pinsを選択します。  

• Component Pin Editor ダイアログを使用すると、ピンの属性がピン個別のPin Propertiesダイアログを経由しないで直接編
集できます。 Library Component Propertiesダイアログ(このダイアログを開くには、SCH Library パネルのコンポーネント
名をダブルクリック)で、Edit Pinsをクリックすると、Component Pin Editorダイアログが表示されます(図 9)。 

 
図 9 Component Pin Editorダイアログですべてのピンの表示、編集が可能 

• 複数のパートがあるコンポーネントでは、選択されたパートに関連したピンが Component Pin Editorダイアログで白地の
バックグランドにハイライト表示されます。 その他の選択されていないパートのピンはグレーです 選択されていないパー
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トでも、同様にピンの編集を行なうことはできます。 ピンを選択して Editボタンをクリックすると、Pin Propertiesダイ
アログが表示されます。 
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回路図コンポーネントの属性設定  
各コンポーネントには、Default Designator、PCB footprint、Models、コンポーネントに定義されている Parameterなどの属性
があります。 コンポーネントの属性を設定するには: 

1. SCH LibraryパネルのComponentsリストからコンポーネントを選択し、Editボタンをクリックするかコンポーネント名を
ダブルクリックします。 Library Component Propertiesダイアログ(図 10)が表示されます。  

 
図 10 基本的なコンポーネント属性は、Library Component ダイアログで定義します。 

2. Default Designator（例えば、Q?）を入力します。 ?マークを入力すると、コンポーネントの配置時に、デジグネータ名が
自動的にインクリメント（この場合では Q1, Q2）されるようになります。コンポーネントの配置前にデジグネータを定義
しておくこと（配置前にオブジェクトを編集するには、配置中に TABを押します。 ）が必要です。 

3. Commentを入力すると、コンポーネントの配置時に表示させることができます（例えば、NPNなど）。 Designatorと
Commentフィールドの Visibleオプションが有効であることを確認します。 Comment フィールドがブランクのままの場
合、コンポーネントを配置する時に自動で Library Referenceの名称が割り当てられます。 

4. Descriptionフィールドにトランジスタの詳細な説明（例えば、Transistor, NPN Generic）を入力します。 ここで
入力した文字はライブラリ検索で検索され、Librariesパネルに表示されます。 

5. その他の欄はデフォルト値のままにし、必要に応じてモデルやパラメータを追加してください。 
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回路図コンポーネントにモデルを追加 
回路シミュレーションやシグナルインティグリティ解析に使用されるモデル・ファイルと同様、回路図コンポーネントに関連
した PCBフットプリントのモデルも複数登録しておくことができます。 コンポーネントに複数のモデル（例えば、複数のフ
ットプリント）が割り当てられている場合、回路図にコンポーネントを配置する時、
Component Propertiesダイアログで適切なモデルを選択できます。  

図 11 Sch Libraryパネルを利用
してモデルを追加 

モデルの調達は、既存の Altiumライブラリからモデルを使用するか、Webからベンダのモデ
ル・ファイルをダウンロードするかして、自分自身で作成することができます。  

PCBフットプリント・モデルは、C:\Program Files\Altium Designer\Library\Pcbフォルダに、
PCB libraries (.PcbLib)という形で提供されています。 PCBライブラリには、多くの PCBフ
ットプリントを含めることが可能です。  

回路シミュレーションに使用される SPICEモデル（.cktや.mdlファイル）は、Altium 
Designerがインストールされたフォルダの Library内にある統合ライブラリに保存されます。 
新規のコンポーネントを作成する場合、デバイス・ベンダのウェブサイトから Spiceモデルを入
手するのが一般的です。 また、XSpice Model Wizard(Tools » XSpice Model Wizard)を使用し
て、Spiceモデルタイプを作成してコンポーネントに追加することができます。  

回路図ライブラリ・エディタのModel Managerでは、コンポーネントモデルの概要を確認でき
編集することができます。 例えば、同じモデルを、複数の選択したコンポーネントに追加する
ことができます。 Model Managerを実行するには、Tools » Model Managerを選択します。 

あるいは、モデルを既存のコンポーネントに追加することもできます。SCH LibraryパネルのModelリストの下にあるAddボタ
ンをクリックするか図 11 路図ライブラリ・エディタ・ワークスペースのModels領域を使ってください。 Models画面を表
示するには、の様にワークスペースの右下にある 

、回
 矢印 クリックしますを 図 12。 

      
 図 12 Models画面を表示するには、ワークスペース下部の矢印をクリックします。 それから、Addボタンを使用してモデルの種類を選択し、
新規モデルを追加します。 

1. 回路図ライブラリ・エディタ・ワークスペースでModels画面を表示させます。上下の矢印シンボル をクリックしてくだ
さい。図 12  

モデル・ファイルの保存場所を検索 
回路図ライブラリ・エディタでコンポーネントにモデルを追加した時、モデルはリンクされますが、モデル・データは回路図
コンポーネントにコピー、保存されません。 これは、ライブラリ作成中や、コンポーネントを回路図シートに配置する時に、
リンクしたモデルを利用できる必要があることを意味します。 

ライブラリ・エディタで作業している時、コンポーネントからモデル情報へのリンクは、以下の検索場所を使用して決められ
ます。 

1. 最初に既存のライブラリ・パッケージ・プロジェクトに含まれるライブラリが検索されます。 

2. 次に、Librariesリストに登録されている PCB libraries（統合ライブラリではありません）が検索されます。 注 : ライブラ
リのリストが指定できます。  

3. 最後に、Project検索パスに表示されているモデル・ライブラリが検索されます。 サーチパスは、Options for Projectダイア
ログ(Project » Project Options)で定義されます。 注 : 検索パスにあるライブラリ内にあるモデルは表示できませんが、コ
ンパイラは検索時にモデルが含まれています。 

回路図ライブラリ・エディタや回路図エディタでモデルを検索する方法の詳細な情報については、AR0104 コンポーネント、
モデル、ライブラリの概要 を参照してください。  
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このチュートリアルでは、コンポーネントやそのモデル・ファイルをリンクするために、別の方法を使用します。 ライブラ
リ・パッケージをコンパイルして統合ライブラリを作成する際は、モデルが保存されているさまざまな場所から統合ライブラ
リにコピーされます。 

回路図コンポーネントへのフットプリント・モデルの追加 
最初に PCBエディタでのコンポーネントを表すフットプリント（他のデザインツールでは、パターン、またはデカルとして知
られています）のモデルを追加します。 回路図コンポーネントに必要なフットプリントは、BCY-W3と言うフットプリントで
す。  

注 : 回路図ライブラリ・エディタの回路図コンポーネントに PCBフットプリント・モデルをリンクする時、モデルは統合ライ
ブラリでは無く、PCBライブラリに存在する必要があります。 

1. Library Component PropertiesダイアログのModelsの項目で Add ボタンの右側にある小さい矢印をク
リックします。 そして、の様にリストから Footprintを選択します。   図 13

図 13 フットプリ
ント・モデルを
コンポーネント
に追加 

 
図 15 フットプリント・ライブラリの検索 

図 15 BCY-W3のフットプリントの検索結果 

 
図 17 PCBモデルを回路図コンポーネントにアサイ
ン 

図 162. PCB Modelダイアログが表示されます( )。 

3. Browseボタンをクリックし、Browse Librariesダイアログを開きます。 このダイアログでは、ライブラ
リ・プロジェクト、または Installedライブラリ・リストに追加されているフットプリント・ライブラリ
を検索することができます。  

4.  既存のライブラリで目的のフットプリントが無い場合、ライブラリを検索する必要があります。 これを
実行するには、Browse Librariesダイアログで Findボタンをクリックします。 Libraries Searchダイアログが表示されます。

 図 15

5. Scopeを Libraries on Pathに、Pathを Altium Designerがインストールされているフォルダの Library\Pcbに設定します。
Include Subdirectoriesオプションが有効になっていることを
確認します。 

6. ダイアログの上部のクエリ欄に BCY-W3 と入力し、Searchを
クリックします。 

7. Browse Librariesダイアログに、PCBライブラリ（Cylinder 
with Flat Index.PcbLib）に保存されているフットプリン
トがリスト表示されます。  このライブラリから BCY-W3

を選択し、OKをクリックして PCB Modelダイアログに戻りま
す。 

図 15

8. このライブラリを使用するのは初めてなので、このライブラリ
を登録するかの確認のダイアログが表示されます。 Confirm ダ
イアログの Yes をクリックします。 フットプリント・モデル
情報が更新され、PCB Modelダイアログにそのライブラリが追
加されます。 

9. OKをクリックしてモデルを追加します。 ワークスペース下部
にModel画面が表示されます。  図 17

 

図 16 フットプリント・モデルがコンポーネントに追加されます。 
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回路シミュレーションモデルの追加 
SPICEモデルは、回路シミュレーション(.ckt や.mdlファイル)で使用します。一般的にデバイス・ベンダのウェブサイトか
ら供給されています。 使用しようとしているデバイスが既存のライブラリで利用できる場合、それには Spiceモデルが含まれ
ています。 このチュートリアルの手順を実行する為に、 
C:\Program Files\Altium Designer\Examples\Tutorials\Creating Componentsフォルダで適切な一般的な NPNモデルを検索し、
ライブラリを保存したフォルダにこのモデルをコピーします。 

1. Spiceモデルがどのように参照されているかは、プロジェク
トによります（モデルはリンクされることを思い出してくだ
さい）。 その他のソース・ファイルとしてそれをプロジェ
クトに追加できます(Projectsパネルでプロジェクト・ファ
イル名を右クリックして、Add Existing to Projectを選択
します)。 しかし、もし、簡単に編集できない参照するソー
ス・ファイルとしてモデル・ファイルを表示する場合、普通
のプロジェクト・ファイルとしてそれを含めません。 この
場合、それを参照する最も適切な方法は、シミュレーショ
ン・モデル・ファイルを含むフォルダに Search Pathを定義
することになります。 これを実行するには、メニューから
Project » Project Optionsを選択し、Search Pathsタブを
クリックします。 

 
図 19 現在の作業フォルダでのサーチパス 

図 19 すべての Spiceモデルの種類の指定や設定は、Sim Modelダ
イアログで行います。 

2. Addをクリックして新規の検索パスを定義します。Edit 
Search Pathダイアログが表示されます。  

3. 特に必要でない限り Include sub-folders in searchオプシ
ョンは、常に無効にしてください。検索プロセスが非常に遅
くなります。  

4. デフォルトの検索パスは、現在のフォルダです。 作業フォ
ルダにモデルをコピーしてから OKをクリックします。 モ
デルが検索されたか確認するには、Optionsダイアログの
Refresh Listボタンをクリックします( )。 検索パスが
定義され、作業フォルダに保存されたモデルが自動で検索さ
れます。 

図 19

5. 今、モデルを作成しているプロジェクト(ライブラリ・パッ
ケージ New Library.LibPkg)で利用できます。 これで、
NPNコンポーネントにシミュレーション・モデルを追加で
きるようになります。 これを実行するには、フットプリン
ト・モデルを追加する方法と同じ方法を実行します
（Simulationモデルを選択する方法を除く）。 SIM Model 
– General / Generic Editorダイアログが表示されます( )。 図 19

Model 
は、 モコググモName SIM

ラグへララリさささのに重必

ささのさ、適切かモコグ名拡(
張張かに さがさか正確ににか)
ださし。 
注注 ダラダダダの : Found 
In region - 
正にしモコグさ見つかささラ

スラ表表さこささ。 
図 20 NPNモデルの設定 

図
20

6. NPNはトランジスタですので、Model Kindのドロップダ
ウン・リストから Transistorを選択します。 ダイアログ
は、Sim Model - Transistor/BJTダイアログになります(

)。 

7. BJTがModel Sub-Kindとして選択されていることを確認
します。  

8. このチュートリアルでは、Model Nameの欄に NPN(モデ
ル・ファイル NPN.mdl 用)というモデル・ファイルの名称
を入力します。 名称を入力するとす
ぐにモデルが検知されます。 モデル
が見つかった場合、ダイアログにパス
/名称が、そして Found Inと表示され
ます。  

9. 適切な Description（例えば、
Generic NPN）を入力します。  

 モデル・ファイル(.mdl)が無い場合、
Createボタンをクリックして、簡単
にシミュレーション・モデル・ファイ
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ルを作成してコンポーネントに割り当てることができる Spice Model Wizardを実行します。 ルを作成してコンポーネントに割り当てることができる Spice Model Wizardを実行します。 

図 22 NPNトランジスタについて設定したシグナ

  10. OKをクリックして、モデルNPNがModelsリストに追加されたLibrary Component Propertiesダイアログに戻ります。図 2110. OKをクリックして、モデルNPNがModelsリストに追加されたLibrary Component Propertiesダイアログに戻ります。図 21

 
図 21 Models画面にリストされた NPNのフットプリントとシミュレーション・モデル 

シグナルインテグリティ・モデルの追加 
ルではなく、

するには、Signal Integrityを選
。 

2. タンをクリックして

3. 、モデルがModelsリストに追加されたLibrary 

シグナル・インテグリティ・シミュレータは、コンポーネントモデ
ピンモデルを使用します。 シグナル・インテグリティ・シミュレーションのコ
ンポーネントを設定するには、Typeと Technologyオプション（デフォルトで
用意されているピン・モデルを使用する）を設定するか、IBIS モデル（基本的
に一組のピンモデル）をインポートします。 

1. シグナル・インテグリティ・モデルを追加
択し、それ以外はフットプリントを追加した方法と同じ作業を実行します
Signal Integrity Modelダイアログが表示されます。   

IBISファイルをインポートしたい場合、Import IBISボ
必要な.ibsファイルを指定します。 このチュートリアルでは、デフォル
トで用意されたピン・モデルを使用します。 Type を BJT に設定し、 適切
な Model Name と Description を入力します (たとえば、 NPN)。図 22を
ご覧ください。  
OKをクリックして
Component Propertiesダイアログに戻ります。図 23 

 ル・インテグリティ・モデル・エディタ 

図 23 シミュレーションとシグナル・インテグリティ・モデルが、トランジスタに追加されます。 

インティグリティ解析の実行を参照シグナル・インテグリティ・モデルの追加、編集についての詳細は、TU0113 シグナル
してください。 
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コンポーネントパラメータの追加 
コンポーネント・パラメータでは、コンポーネントについての追加情報を定義することができます。 こ
れは、BOM、製造データ、コンポーネント・データシートへの参照、デザインルール、または PCBク
ラスへの割り当ての様な設計指示情報、Spiceシミュレーション・パラメータなどで必要なデータを含
みます。パラメータには、コンポーネントに必要な情報を追加することができます。  

ラララララ内の全ララララララ

ラのパライラパの編編さ管管に

は、パライラパパララペパ 
(Tools 
イメイラを使用にささ。)  

回路図コンポーネントにパラメータを追加するには: 

1. パラメータは、Library Component Propertiesダイアログでコン
ポーネントに追加します。 ダイアログを開くには、Sch Library
パネルのリストでコンポーネント名をダブルクリックします。  

2. 新規のパラメータを追加するには、Library Component Properties 
ダイアログの Parameters for… セクション内の Add ボタンをク
リックし Parameter Propertiesダイアログを表示させます（ 

 ）。  
図

24

3. パラメータの名称と値を入力します。 テキスト・ストリングが必
要な場合は、Stringがパラメータ Type として選択されているこ
とを確認してください。また、コンポーネントが回路図シートに
配置された時に値を表示したい場合は、値の Visible オプション
が有効になっていることを確認してください。 OKをクリックし
ます。 パラメータは、Library Component Propertiesダイアログ
の Parametersリストに追加されます。 

図 24 パラメータは、Parameter Propertiesダイアログで設定
します 

コンポーネントからデータシートへのリンク用パラメータ 
パラメータは、コンポーネントからデータシートの様な参考資料へリンクさせることができます。 リンクは、特定のコンポー
ネント・パラメータを追加することにより構築されます。 参照ドキュメントにアクセスするには F1ボタンを使用します。 複
数のドキュメントを参照するには、右クリック・メニューを使用します。 

HelpURL 
コンポーネントに予約されたパラメータ名（HelpURL）が含まれている場合、カーソルがコンポーネント上にある時に F1ボ
タンを押すと、URLが表示されます。 URLには実際のウェブアドレス、テキストファイル、PDFファイルが指定できます。 
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コンポーネントリンク 
2 つ目の手法は、複数のリンク、各リンクの名称をサポートしています。 ここでは、パラメータ（リンクされたドキュメント、
または URLを示すもの）を追加し、次に、このリンクのラベルを定義します。 パラメータは、次のように定義します。 

 パラメータ名 パラメータ値の例 

1番目のパラ
メータ 

ComponentLink1URL C:\MyDatasheets\XYZDatasheet.pdf 

2番目のパラ
メータ 

ComponentLink1Description Datasheet for XYZ 

1番目のパラ
メータ 

ComponentLink2URL C:\MyDatasheets\AlternateXYZDatasheet.pdf 

2番目のパラ
メータ 

ComponentLink2Description Datasheet for Alternate XYZ 

同じパラメータのペアを使って、リンクはいくつでも定義できます。た
だし、インクリメンタルな指定はできません。 データシートリンクを
使ったコンポーネント上で右クリックすると、Context メニューの中に、
Reference メニューのエントリが表示されます。メニューから各コン
ポーネントリンク用のエントリを見つけてください（ ）。 図 25

Libraries パネルでコンポーネントを閲覧するときにも、コンポーネン
トとデータシートのリンクが使用できます。 –  F1キーまたは、パネル
のコンポーネント名の上で右クリックすると、リンク先ドキュメント
/URLにアクセスします。 

 

 

 

 
図 25 右クリックしてデータシート・リンクを実行  

間接的に参照する文字 
後で何らかの文字を入力するため、場所を確保しておく定義が必要になることがあります。 例えば、回路図のテンプレートで、
DesignedByというパラメータを使用したいとします。 この場合、その値はテンプレートを適用した新規回路図において定義
します。 Altium Designerでは、間接的に文字を参照する手法で、この要求をサポートします。 回路図シートレベルで、ドキ
ュメント・パラメータとして、例えば DesignedByというパラメータを追加し、その値をブランクにします。 実際のドキュメ
ントには通常の文字として、=DesignedBy を配置します。 = は、間接参照を行っている文字であることを示し、文字を表示
する代わりに、ドキュメント・パラメータ DesignedByの現在の値を表示します。 注 : デフォルトでは、間接的な文字は解析
されず、最終的な値が表示されます。これを有効にするには、Preferences ダイアログの Schematic – Graphical Editing ペー
ジで、Convert Special Stringsオプションを有効にします。 パラメータの Value がブランクの場合、何も表示されません。
Convert Special Strings オプションがデフォルトで無効になっているからです。 

間接的に参照する文字は、コンポーネントにも使用できます。Visibleオプションを有効にしてコンポーネントに追加されてい
るパラメータを表示するのと同様に、コンポーネントの Comment  フィールドの文字を間接的に表示することもできます。  

間接的に参照する文字が役に立つ状況は、コンポーネントを PCBデザインや回路シミュレーションの双方で使用している場合
です。 回路図から PCBデザインへデータを移行する際、回路図の Comment欄が PCBコンポーネントの Comment 欄にマッ
プされます。 しかし、回路シミュレーションでは Comment 欄は使用されません。 シミュレータは、コンポーネントの多く
の属性を必要とするからです。例えば、BJTには 5つのシミュレーション属性があります。 これらの 5つの属性は、パラメー
タとして定義されます。 この場合、回路シミュレーション・パラメータは、パラメータの名称を = 記号の後に入力することに
より、間接的に参照する文字を使用して Comment欄にマップできます。 例えば、抵抗には 1つのシミュレーション・パラメ
ータ（Value）が割り当てられています。 もし、抵抗の Comment欄が=Valueに設定されていれば、Valueパラメータの内容
が Comment として表示されます。 もし、シミュレーション中に抵抗値を調整している場合、PCBレイアウトにデザインを移
行する時に正しい抵抗値が使用されます。  
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シミュレーションパラメータ 
上記に記載した様に、間接的に参照する文字の機能は、コンポーネントのComment欄にパラメータをマップするのに使用でき
ます。 注 : シミュレーション・パラメータは、シミュレーション・モデルに構築され、手動でコンポーネントにそれらを追加
する必要が無いことに注意してください。 作成しているトランジスタのシミュレーション・モデルを編集する場合、BJTモデ
ルがの様な 5つのシミュレーション・パラメータを持っていることがわかるでしょう。図 26  

図 26 シミュレーション・パラメータは、Sim Modelダイアログで
定義します。 

シミュレーション・パラメータに簡単にアクセスしたい、または回路図にそれらを表示したい、または出力ドキュメントにそ
れらを含めたい場合など、各パラメータの隣の Component parameter のチェックボックスを有効にして、コンポーネント・
パラメータにすることができます。 
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コンポーネントをチェックし、レポートを作成 
新規のコンポーネントが正しく作成されているか確認するには、3つのレポートを作成します。 ライブラリ・ファイルが、レ
ポートが作成される前に保存されているか確認してください。 レポート・ファイルを閉じて、回路図ライブラリ・エディタに
戻ります。 

コンポーネント・ルール・チェッカ 
ラララララララ・ ピラかかモコグへのララリは、ラララララララ・グラグ・イチググ

さイチグリさこささで。  コンポーネント・ルール・チェッカでは、ピンのダブリやミスなどのエ
ラーをチェックします。 さのララリのレレグは、統場ラララララにラララララ・パグパラペをララパラグささ

時にイチグリさこささ。 
ララパラグさこま統場ラララララを使用ささつかりさかかにか、ラララララ・パグパ

ラペを使用ににラララララを作作に管管ささ際には便便にかりささ。ララパラグささ

さささ、より包包電かラララララララの検検さささささ。 

1. Reports » Component Rule Check [ショートカット R, R]を選択し
ます。 Library Component Rule Check ダイアログが表示されます(

)。  
図

27

2. 確認したい属性を設定します。 OKをクリックします。 
libraryname.errという名のレポートが、テキストエディタに表
れ、ルール・チェックに違反したコンポーネントがリスト表示されます。 

3. 必要な修正をライブラリに行い、ルールチェックを再度、実行します。  

4. 回路図ライブラリを保存します。 

コンポーネント・レポート 
アクティブなコンポーネントのすべての情報をリスト表示するレポートを作成するには: 

1. Reports » Component [ショートカット R, C]を選択します。  

2. 'libraryname.cmp'という名のレポートがテキストエディタに表れ、コンポーネントの
各パートの数やピン情報が表示されます。  図 27 既存のコンポーネントをテ

ストするために Component Rule 
Checkダイアログを設定 ライブラリレポート  

ライブラリの各コンポーネントのレポートを作成するには: 

1. Reports » Library Report [ショートカット R, L]を選択します。 

2. Library Report Settingsダイアログで必要なレポートを設定します。 

レポートは、選択した形式によりMicrosoft Word、またはウェブブラウザで開きます。  

コンポーネントをその他のライブラリからコピー 
その他の開いている回路図ライブラリからも回路図ライブラリへコンポーネントをコピーし、必要な属性を編集することがで
きます。 コンポーネントが統合ライブラリの一部である場合、.IntLib ファイルを開き(File » Open)、Yes を選んでソース
ライブラリを抽出する必要があります。 生成されたソースライブラリ(.SchLib)は、Projectsパネルから開きます。 

1. SCH Libraryパネルの Componentsリストで、コピーしたいコンポーネントを選択すると、そのコンポーネントがデザイ
ンウィンドウに表示されます。 

2. Tools » Copy Componentを選択して、既存のライブラリ・コンポーネントからその他の開いているライブラリ・ドキュ
メントへコンポーネントをコピーします。 Destination Libraryダイアログが表示され、開いているすべての回路図ライブラ
リ・ドキュメントがリスト表示されます。 

3. コンポーネントをコピーしたいドキュメントを選択します。 OKをクリックすると、コピーしたコンポーネントが目的のラ
イブラリに追加され、必要なら編集もできます。 

複数のコンポーネントのコピー 
SCH Libraryパネルを利用して 1つ、または複数のコンポーネントもコピーできま
す。 コンポーネントをパネルの名称リストから選択します。標準的な CTRL + クリ
ック、や SHIFT + クリック機能が使用できます。次に、選択したコンポーネント上
で  右クリックして、Copy をポップアップメニューから選びます。  を参照し
てください  

図 28

Components リストで右クリックすると : 

• 同じライブラリにコンポーネントを貼り付けることができます。 

• その他の開いているライブラリにコンポーネントを貼り付けることができます 

14 TU0103 (v2.2) May 22, 2008 

図 28 既存のライブラリから選択したコンポ
ーネントをコピー 
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• 同じ手法を使用して、回路図のコンポーネントを開いているライブラリへのコピー、貼り付けができます 
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複数のパートを持つ新規の回路図コンポーネントの作成 
作成したトランジスタのシンボルは、コンポーネント全体（デバイス・メーカーによって供給された物理的なパッケージを表
す 1つのシンボル）を表します。  

1つの物理的なコンポーネントは、パートの集まりとして表される場合があります。 例えば、8つの抵抗を含む抵抗アレイが
あります。 各抵抗は、その他の抵抗と独立して使用できます。 その他の例では、2入力 ANDゲートの 74F08があります（こ
のデバイスには、4つの独立した 2入力 AND ゲートがあります。 ）。 コンポーネントは、各 4つのゲートを 1つのシンボル
として描画でき、もし、回路図で、各ゲートを 4つの分割したゲートとして描画する場合、より役に立ちます。 このような一
組の分割したパートとして配置するコンポーネントを、マルチ・パート・コンポーネントと呼びます。  

チュートリアルのこの項では、74F08SJX Quad 2-IN AND を作成する方法を説明します。 また、交互に別の形状のモデルを表
示できるコンポーネント（デバイスの IEEE規格を表現）を作成します。 

1. 回路図ライブラリ・エディタで、Tools » New Component [ショートカット T, C]を
選択します。 New Component Nameダイアログが表示されます( )。  図 29

2.新規コンポーネントの名称を入力し（例えば、74F08SJX）、OK をクリックします。 
新規コンポーネントの名称が SCH Library パネルの Components リストに表示され、
シートの中央に十字の線（原点）のある空のコンポーネントシートが、表示されます。 

図 29 新規コンポーネントの名称を入
力 

3. これで、新規コンポーネントの最初のピンを作成できるようになります。上図のよう
に、ピンが含まれています。詳細は、以下のセクションで説明します。 最初のパート
は、その他のパートの基準として使用されます。ピン番号だけは、各パートで変更する必要があります。 

コンポーネントのボディを作成 
このコンポーネントのボディは、複数のセグメントと円弧で構成されています。 コンポーネント・シートの原点がワークスペ
ースの中央にあることを確認してください。Edit » Jump » Origin [ショートカット J, O]を選択します。 グリッドについても
表示されていることを確認してください[ショートカット Page Up]。 

ラインの配置 
1. 現在のグリッド設定が Altium Designerのステータスバー（左下）に表示されることに注意してく
ださい。 いつでも 3種のグリッド設定を切り換えることができます。Gキーを押してください。
ここでは、グリッドを 5に設定しています。 

2. Place » Line [ショートカット P, L]を選択するか、  ツールバーボタンをクリックします。 カー
ソルが、十字に変わり、複数セグメントのラインを配置するモードになります。 

3. TABキーを押して、ラインの属性を設定します。 Polylineダイアログで、線幅を Smallに設定し
ます。 

4. ステータスバーの左端に表示される X, Y座標を参照し、25, -5 になるところへカーソルを移動し
ます。 クリックするか ENTER を押し、線を引き始めます。 マウスを移動し、ラインのセグメン
トを定義する頂点（0,-5; 0,-35; 25,-35)で左クリックします。  

図 30 最初のパートのボ
ディを定義するために
Polylineを配置します。

5. ラインの配置が完了したら、右クリック、または ESCを押します。  

6. 完成したポリラインは、 の様になります。 コンポーネントを保存します。 図 30

アークの配置 
アークは、アークの中心点、半径、開始点、終了点の 4ステップで配置しま
す。 注 : アークの配置では、クリックの代わりに Enterを押すことができま
す。  

1. Place » Arc (Center) [ショートカット P, A]を選択します。 アークがカー
ソルの上に現れ、アークの配置モードになります。 

2. TABキーを押して、アークの属性を設定します。 Arcダイアログが表示
されます。 半径を 15、開始点を 270、終了点を 90、ライン幅を Small
に設定します( )。 図 31

図 31 アークの属性は、ダイアログ、またはマウス
を使用して定義できます。 

3. アークの中心点を決めるため、25, -20の位置にカーソルを移動して
Enter を押すか左クリックします。 マウスを移動する必要はありません。 
カーソルは、Arcダイアログで設定した様に 15の半径を定義する正確な
位置にジャンプします。 Enterを押します。  

16 TU0103 (v2.2) May 22, 2008 



ララララララララララララの作作 

4. それから、カーソルは、ダイアログで設定した様にアークの開始点にジャンプします。 マウスを移動しないで Enter を押
し、開始点を受け入れます。カーソルが終了点までジャンプするので、そこで再び、Enterを押します。 

5. 右クリックするか、ESCを押して、アークの配置モードを抜けます。 

信号ピンの追加 
最初のパートにピンを追加します。このチュートリアルの最初の方にある回路図コンポーネ
ントにピンを追加  の項目で説明したのと同じ手法を使用します。 1、2番ピンにInput、3
番ピンにOutputの電気的属性を割り当てます。 ピンの長さを 20に設定します。 完成した
パートは、 のようになります。 図 34

 
図 34 コンポーネント 74F08SJXの
パート A。 input/outputを示す三角
形は表示上の機能です。
Preferencesダイアログの
Schematic – Generalページの Pin 
Directionオプションで設定します。

パート 2、3、4の作成 
1. Edit » Select » All [ショートカット Ctrl + A]を使用してコンポーネントを選択します。 

2. Edit » Copy [ショートカット Ctrl + C]を選択し、このパートをクリップボードにコピー
します。 

3. Tools » New Partを選択します。 空白のコンポーネントシートが表示されます。 SCH 
Libraryパネル内のパートカウンターが更新され、Part Aと Part B が含められます。
SCH Library パネル内の Componentsのリストでコンポーネント名の左にある + をクリ
ックすると、 の様になります。  

 

 
図 34 Part Bが追加されます 

 

 
図 34 74F08SJXの Part B 

図 34

4. Edit » Paste [ショートカット Ctrl + V]を選択します。 コンポーネントパートの外形が
カーソルの上に現れるので、シートの原点に対して相対的に同様な場所に、Part Aとし
て配置します(シートの中央の黒い十字の部分が原点です)。 必要ならば、元のパートと
同じ位置になるまでコピーしたパートを選択し移動します。  

5. 新しいパート、Part Bのピン情報を更新します。各ピンをダブルクリックして、Pin 
Propertiesダイアログでピン名称、番号を変更します。 完成すると、Part Bは  の
ようになります。 

図 34

6. 上記の 3から 5のステップを繰り返し、 図 35 のように、残りの 2つのパート、Part 
とPart Dを作成します。 ライブラリを保存します。 

C

      
図 35 74F08SJXの Part C と Part D 

パワーピンの追加 
パワー・ピンを定義するには、2つの方法があります。 5番目のパートをコンポーネントに作成することができ、そのパート
に VCCや GNDピンを配置します。 この方法を使用する場合、再アノテーション中にどのゲートもスワップされないようにす
るには、Component Propertiesダイアログの Locked オプション( )を有効にする必要があります。  

2つ目の方法は、パワー・ピンを Hiddenピン  として定義することです。 この場合、それらは特別なネットに自動的に接続さ
れます。  

Hiddenパワーピンは、マルチパート・コンポーネントの特定のパートに属さず、すべてのパートに属します(どのパートが配
置されているかに関らず、回路図に存在するそのコンポーネントのパートすべて)。 この要件を満たすには、ピンを Part 0に
割り当てます。つまり、コンポーネントの各パートに追加したいピンを保存するために使用する特別なパートです。  

1. コンポーネントに GND (ピン番号 7)と VCC (ピン番号 14)のピンを追加します。Part Number 属性を 0に、Electrical 
Type を Power に、Hide ステータス Hiddenに、Connect toのネット属性を GNDと VCCにそれぞれ設定します。  

2. Hiddenオブジェクトを表示するには、メニューから View » Show Hidden Pinsを選択します。 完成したパートは、  
のように表示されます。 パワーピンが各パートに現れることを確認します。 

図 36

コンポーネントの属性設定 
1. コンポーネントが Componentsリストで選択されているときに、SCH Libraryパネルの

Editボタンをクリックして、コンポーネント属性を設定します。 Library Component 
Properties ダイアログを設定します。Default Designator で U? を指定し、Description 
を Quad 2-Input AND Gate に指定、フットプリント名 DIP14 を Models リストに
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追加します。 このチュートリアルの後半では、PCB Component Wizardを使用して DIP14のフットプリントを作成しま
す。 

2. File » Saveを選択して、ライブラリのコンポーネントを保存します。 
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パートにおけるAlternate表示モードの作成 
255種類の Alternate表示モード  をコンポーネントパートに追加できます。 これらの表示モードは、DeMorgan、または IEEE
の表現のように、異なる形状のコンポーネントを作成することができます。 IEEE シンボルの選択は、Sch Lib IEEEツールバ
ー(View » Toolbars » Utilities)、または Place » IEEE Symbols から有効にすることができます。 各 Alternate表示モデルは、
ノーマルモードと同じピンのセットを持つ必要があります。 

パートのAlternate表示が追加されている場合、図 37の様にModeツールバーのModeツールからAlternate モードを選択すると、
そのモードがSchematic Libraryエディタに表示され編集することができます。 

Schematic Libraryエディタのデザインウィンドウに表示されるコンポーネント・パートに Alternate表示モードを追加するに
は: 

1. Tools » Mode » Addを選択するか、  ボタンをクリックします。Alternate 1のブランクシートが表示されます。 

2. 一般的には、Normalモードで作成されたパートをコピーし、新規の Alternateモードにそれを貼り付けします。 この方法
で正しいピンのセットが作成され、必要ならば形状やピンの位置を修正できます。  

3. ライブラリを保存します。 

一度、コンポーネントを回路図シートに配置したら、表示モードは、Component Properties ダイアログの Graphical の項目の
Mode リストから選択することができます。 

                    
図 37 ANDゲートの IEEEを表すために使用した表示モード Alternate 1 
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PCBコンポーネントのフットプリントの作成 
チュートリアルのこの項目では、次の内容について説明します:  

ググラオラララは、そこかを配位に

ま基基の最最電かサライに関関かか

、常にラグオ面かか作作さこささ。 
レラレに独特の属属、まさえば表面

実実のパグイやソグダパスリの設定

かなは、ラララララララの配位配に

ググラオラララを基基の反反反に反

転ささまささ、自自電に適切か下下

レラレに移移さこささ。 

• 新規 PCBライブラリの作成 

• PCB Component Wizardを使用した、回路図コンポーネントに関するフットプリントの作成 

• 手動によるフットプリントの作成 

• 異型パッド形状を含む、特別なフットプリントの条件 

• 3次元コンポーネントボディについての詳細（3Dボディ) 

フットプリントは、PCBエディタから PCBライブラリへコピーしたり、PCBライブラリ間でコピー
できます。 または、PCBライブラリエディタの PCB Component Wizard、または描画ツールを使
用してゼロから作成できます。 PCBデザインにすべてのフットプリントが配置されている場合、
PCBエディタで Design » Make PCB Libraryコマンドを使って、それらのフットプリントだけが含
まれた PCBライブラリを作成することができます。 

Altium Designerには、定義済みのスルーホールや SMDコンポーネントフットプリントなど、PCBデ
ザインで使用するための包括的なライブラリが含まれています。 フットプリント・ライブラリ(.PcbLib files)は、Altium 
Designerがインストールされたディレクトリの Library\Pcbフォルダに保存されています。  

チュートリアルのこのパートで、手動で作成するフットプリントは、必要な手順を説明するだけです。寸法は正確ではありま
せん。 新規のフットプリントを作成する場合、メーカーのデータシートに対して一致しているか、常に確認してください。 

新規PCBライブラリの作成 
 新規の PCBライブラリを作成するには: 

1. File » New » Library » PCB Libraryを選択します。 新規の PCBライブラリドキュメ
ント、PcbLib1.PcbLib が作成され、空のコンポーネントシート、
PCBComponent_1 が表示されます。 

2. 新規の PCBライブラリ・ドキュメントの名称を、たとえば、PCB 
Footprints.PcbLib に変更します。File » Save Asを選択してください。 新規の
PCBフットプリントライブラリは、ライブラリパッケージ内に入れる必要があります
( )。 図 38

3. PCB Libraryタブをクリックして、PCB Libraryパネルを開きます。 

4. PCB Library Editor ワークスペースのグレー領域をクリックして、 図 39 のようなグ
リッドが表示されるまで PageUpキーを数回押します。 

図 38 フットプリントライブラリ追加
後のライブラリパッケージ PCB Library Editor コマンドを使用して、新規の PCBライブラリのフットプリントコン

ポーネントを追加、削除、編集する準備ができました。  
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図 39 フットプリントを作成する準備ができた新規の PCBライブラリ 

PCBコンポーネントウィザードの使用 
PCB ライブラリエディタには、PCB Component Wizard が含まれていて、ユーザのリクエストに応じたコンポーネントフッ
トプリントが作成できます。 DIP14のフットプリントを作成するために、ウィザードを使用します。  

 

図 40 PCB 
Component Wizard 
を利用して、DIP14
のフットプリントを

 
図 41 DIP14のフットプリントを作成するウィザードの作業 

Component Wizard を使用して、新規のコンポーネントフットプリント（DIP14）を作成するには: 

1. Tools » Component Wizard [ショートカット T, C]を選択します。 PCB Component Wizardが自動的に立ち上がります。 
Next >をクリックしてウィザードを進めます。 

2. 有効なオプションからの質問に選択で答えていきます。 DIP14を作成するには、Dual in-line Package (DIP)を Patternとし
て選択し、単位を Imperial 、ラウンドパッド 60mil、穴サイズを 32mil （寸法線の値を選択、入力)、 パッド間の距離を
300mil（水平方向）、100mil（垂直方向）に設定、パッド数を設定する画面まではデフォルト設定を適用します。 パッド
数を設定する画面では、14 と入力します。 

3. ウィザードの最後のページまで Next >をクリックし、最後のページで Finishをクリックします。 新規のフットプリントの
ファイル名、DIP14 が PCB Libraryパネルの Componentsリストに表示され、その新規のフットプリントがデザインウ
ィンドウに表示されます（ ）。 必要なら更にコンポーネントを編集できます。 図 40
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4. File » Save [ショートカット Ctrl + S]を選択して、その新規のフットプリント・コンポーネントがあるライブラリを保存し
ます。 

IPCフットプリントウィザードの使用 
PCB Component Wizard と同様に、
IPC Footprint Wizard でコンポーネン
トフットプリントを作成できます。 フ
ットプリントを定義するパッドやトラ
ックの属性を入力するように求めるの
ではなく、IPC Footprint Wizard  は、
実際のコンポーネントの大きさを入力
として採用します。 IPC-7351 標準用
に開発された方式に基づいて、ウィザ
ードはフットプリントを生成します。
パッドやトラックなど、Altium 
Designer の標準オブジェクトが使用さ
れます。 ウィザードは PCB Library 
Editor の Tools メニューから起動でき
ます。 

図 42 IPC Footprint Wizard は、コンポーネントの大きさに基づいて、フットプリントを作成し
ます
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手動によるフットプリントの作成 
フットプリントは、PCBライブラリエディタ内で作成され、修正されます。PCBエディタで利用できるツールとデザインオブ
ジェクトのセットを使用します。 どんなものでも、PCBフットプリントとして保存できます。コーナーマーカー、フォトツー
ルのターゲット、機構的な定義が含まれます。 注 : 一度、フットプリントが PCBに配置されると、形状や機構の要求に応じ
て、Type 属性が設定できます。 これらの設定の詳細な情報を確認するには、ComponentダイアログのWhat’s This helpを使
用してください。 

コンポーネント・フットプリントは、コンポーネント・ピンの接続
を構成するためのパッドを配置し、トラックやアークで外形を定義
して作成します。 デザインオブジェクトは、どんなレイヤにも配置
できます。 しかし、通常、外形は Top Overlay（シルク・スクリー
ン）レイヤに、パッドはマルチレイヤ（スルーホール・コンポーネ
ント・ピン用）、または部品面の信号レイヤ（表面実装コンポーネ
ント・ピン用）に作成します。 PCBドキュメントにフットプリン
トを配置する時、フットプリントを構成するすべてのオブジェクト
は定義されたレイヤに割り当てられます。 

作作配にススグオダラグイを変変さ

さには、 を押にささ。Ctrl+G  
ダラグイを表表、さまは非Visible

表表にささには、 イラを押ににL Vi
ew Configurations 
ダラダダダを表表にささ。 
原原パラグさ表表さこかし場場は、

View Configurations 
ダラダダダを開さ、View 
Configurations 
ペラペのOrigin Marker 
オオオオラを有有ににささ。 

NPNトランジスタのフットプリントをマニュアルで作成するには: 

1. フットプリントを作成する前に、単位とグリッドが適切である
ことを確認してください。 Tools » Library Options [ショート
カット D, O] を選択して、Board Options ダイアログを表示しま
す。Units が Imperial、Snap Grid が XY方向に 10milであるこ
とを確認します。 作成するフットプリントのパッド間隔を目的
の間隔にするため、Gridを設定する必要があります。 Visible Grid 1を 10milに、Visible Grid 2を 100mil に設定します。 

図 43 Board Options ダイアログで単位とグリッドを設定 

2. Tools » New Blank Component [ショートカット T, W]を選択すると、空のコンポーネント・フットプリントのワークスペ
ースが作成されます。 ここで、新規のライブラリに空のフットプリントが作成されるのでそれ
を使用します。 

3. デフォルトの空フットプリントの名称を変更するには、PCB Libraryパネルのリストでその名称
（たとえば、PCBComponent_1）をダブルクリックします。 ここでは、チュートリアルの最初
の方で使用した名称、BCY-W3を入力しましょう。新しいフットプリント名を PCB Library 
Component ダイアログに入力します。 

4. 原点マーカで表示されたワークスペースの参照ポイント（0, 0）の周りにフットプリントを作成
することをお薦めします。 作業中に原点にカーソルをジャンプさせるには、ショートカット J, 
Rを使用します。  

参照ポイントとは、コンポーネントを配置するときに、コンポーネントを � ’つかんだ’ カーソル
の位置のことです。 一般的に、参照ポイントはコンポーネントのパッド 1の中心、または幾何
学的なオブジェクトの中心になります。 参照ポイントは、いつでもこれらのどちらかに設定で
きます。Edit » Set Referenceのサブメニューのオプションを使用してください。 

新規のフットプリントにパッドを配置 
Pad 属性ダイアログにはビューアがあり、定義されているレイヤ上のパッド形状を検討することができます。 パッド用の通常
の円形、楕円形（スロット）、四角形のホールを定義して、それらの箔付け属性（箔付けする、しない）の切り替えルことが
できます。また、サーマルレリーフの生成、クリアランス計算、ガーバー出力、ODB++、NCドリルなどをサポートするのに
必要なすべての作業を自動的に扱うことができます。 NCドリル出力（NC Drill Excellon format 2）では、3種の異なるホール
用と箔付けする、しないの別によって、6個の異なる NCファイルが生成されます。 

新規のコンポーネント・フットプリントを作成するのに最も重要な手順の一つは、コンポーネントを PCBに半田付けするため
に使用するパッドを配置することです。 これらは、物理的なデバイス上のピンに対して、正しい位置に正確に配置する必要が
あります。 

パッドを配置するには: 

1. Place » Pad [ショートカット P, P]を選択するか、  ツールバーボタンをクリックします。 パッドがカーソル上に表示さ
れます。 最初のパッドを配置する前に、TABキーを押してパッド属性を定義します。 Padダイアログが表示されます（
45

図
）。 

2. ダイアログの各領域を編集します（図 45）。 これで、伸びたパッドが作成されました。 

3. ステータス・バーに表示される座標を目安にして、最初のパッドを X:0, Y:-50に位置決めし、クリック（または、ENTER
を押）します。 
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4. 最初のパッドを配置後、カーソル上に次のパッドが表示されます。 カーソルを X:0, Y:0に合わせてクリックし、2番目のパ
ッドを配置します。 注 : パッドの部品番号は自動的にインクリメントされます（出現順に数字が振られます）。 

5. X:0, Y:50にカーソルを移動し、クリックして 3つ目のパッドを配置します。  

6. 右クリックするか、ESCを押して、パッドの配置モードを抜けます。 3つのパッドは  の様に配置されます。 図 44

7. フットプリントを保存します。 File » Save [ショートカット CTRL + S]を選択してください。 

 

 

表面実実用のパグイは、Layer属
属を に設設にささ。Top Layer  
各レラレさ異かなまサラサさ必必

かスグラホラグパグイにつしには

、Size and 
Shape属属を使用にささ。 

 
図 44 段階 1, パッドを配置 図 45 最初のパッドを配置する前にパッド属性を設定 

パッドのデジグネータ（部品番号） 
グラソグ上に浮かでさしさパグイをパ

ウスを使わわに配位ささには、J, L 
オオララググラを使用にに、Jump 
to Location 
ダラダダダを表表ささささ。 TAB 
を押にに、 さX Y 
の欄を移さ来ささ、ENTER 
さ変変を受け入こささ。ENTER 
をかを一一押ささ、パグイさワラリス

ペラスに配位さこささ。 

パッドにはデジグネータ（通常、コンポーネントのピン番号）でラベルをつけることができます。
20までの英数字が使用できます。 デジグネータは、必要ならブランクのままにすることができます。  

数字で始まる、または数字で終わるデジグネータを繰り返し配置すると、番号が自動的にインクリ
メントされます。 アルファベットでインクリメント機能を利用する場合は（例えば、1A, 1B）、
Paste Array機能を使用します。 

ペースト・アレイ機能 
パッドをクリップボードにコピーする前にパッドのデジグネータを設定することで、ペーストアレ
イ機能を使用した自動的な配置シーケンスをパッドのデジグネータに適用できます。 Paste Arrayダ
イアログの Text Incrementの項目を設定すると、以下のようなパッドのデジグネータシーケンスで配置できます: 

• 数字（1, 3, 5） 

• アルファベット（A, B, C） 

図 46 複数のパッドを一度にペースト 

• アルファベットと数字の組み合わせ（A1 A2、または 1A 1B、または A1 B1、ま
たは 1A 2Aなど） 

• 数字順にインクリメントさせるには、Text Incrementの項目をインクリメントし
たい値に設定します。 

• アルファベット順にインクリメントするには、Text Incrementの項目をスキップ
したいアルファベットに設定します。 例えば、もし最初のパッドのデジグネータ
が 1Aの場合、A（アルファベットの最初の文字）をインクリメント１のデジグネ
ータに設定します。 項目に C（アルファベットの 3番目の文字）を設定すると、
デジグネータは 1A, 1D（Aの 3つ後の文字）, 1Gなどになります。 
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ペーストアレイの機能を利用するには: 

• 最初のパッドを作成し必要なデジグネータを設定します(例えば、1A)。 Edit » Copy [ショートカット Ctrl + C]を使用して、
クリップボードにこのパッドをコピーします。 

• Edit » Paste Special [ショートカット E, A]を選択します。 Paste Specialダイアログが表示されます（図 46）。  

• Paste Arrayボタンをクリックし Setup Paste Arrayダイアログを表示させます。 必要に応じて各項目を設定します。 

PCBシルク層（コンポーネントオーバーレイ）に外形を描画 

ラライ かかミラ に座(mil) (mm)
標簡位を切り換えさには、Qを押

にささ。 

PCBシルク層に表示される外形は、Top Overlayに定義します。 配置中にコンポーネントをボードの下層に反転させた場合、
シルク層は自動的に Bottom Overlay レイヤに変更されます。  

1.  アーク、またはライン（トラック）などのシルクのオブジェクトを配置する前に、メイン編集ウィ
ンドウの下の Top Overlayレイヤタブをクリックします。 

2. 最初に、図 47 の様にアークを配置します。 アークを配置するには、メニューからPlace » Arc 
(Center)を選択します。 カーソルをX:0, Y:0に移動してクリックし、アークの中心を定義します。 アークの半径や開始、
終了角度がわかっている場合は、対話的な定義による設定を経ることなく、ずっと簡単にアークを配置することができます。
配置したアークはArcダイアログで編集します。  

3. アークの半径を定義するためにどこかをクリックし、再度クリックしてアークの開始角度を定義します。 必要なら、
Spacebarを押して、終了角度を定義する前にアークの方向を切り換えることができます。図 47 の様に方向を設定し、再
度クリックしてアークの終了角度を定義します。 右クリックしアークの配置モードを抜けます。 

 配置したアークをダブルクリックし、Arcダイアログを表示させます。 次のように属性を設定します: Width=6mil、
Radius=105mil、Start Angle=55、 End Angle=305。 

ラララの配位配に間間えま場場

は、BACKSPACE 
さ最最に配位にまララグリを消

ににかださし。 

4. 次に、ラインを配置します。 Place » Line [ショートカット P, L]を選択するか、  ボタンをクリ
ックします。 アークの端の近くにカーソルを移動し、図 47 のようにPageUp を押してズームイン
します。 アークの端にカーソルを近づけると、カーソルがアークの端の中心に引き込まれます。 
これは、オブジェクトの端にカーソルを引き込む電気的なグリッドを表します。 クリックしてライ
ンセグメントを始めます。  

5. TABを押して、線幅（6mil）を設定し、Line Constraintsダイアログでレイヤを確認します。 

6. アークのもう一方の端へマウスを移動し、クリックしてラインを配置します。 注 : ラインを配置中、Shift + Spacebarキ
ーを押すと、配置角度の切り換えができます。 

7.  ラインの配置モードを抜けるには、右クリック、または ESCを押します。 

        
図 47 配置されたアーク。ライン配置の開始時に電気的なグリッドを使用してアークにカーソルを引き込み、完成したシルク 

異型パッド形状のフットプリントを作成 

    

異型形状のパッドを持つフットプリントを作成する必要がある場合
があります。 この場合、ライブラリエディタで利用できるデザイン
オブジェクトを使用して作成しますが、覚えておく必要がある重要
な要因があります。  

ソフトウェアでは、パッド形状に基づいてソルダ、ペーストマスク
が自動で作成されます。 もし、不規則な形状を構築する為にパッド
を使用すれば、そのパッドと一致する不規則なマスクが正しく作成
されますが、ライン（トラック）、フィル、カッパーエリア、また
はアークなど、その他のオブジェクトから異型の形状を作成する場
合、ソルダマスクとペーストマスクのレイヤに適切な大きさのオブ 図 48 複数のオブジェクトを配置して不規則な形状のパッドを作

成
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ジェクトを配置してソルダ、またはペーストマスクを定義する必要があります。 

図 48 は、異なる設計者によって作成された SOT-89のフットプリントの 2つのバージョンです。 左の図は、中央に大きな異
型形状のパッドを配置して 2つのパッドを使用しています。 右の図は、パッドとライン(トラック)を使用しています。 後者で
は、手動でソルダとペーストマスクを作成する必要があります。 

フットプリントにプリミティブを含むコンポーネントの管理 
デザインを移行する時、各コンポーネントで指定したフットプリントがライブラリから抽出されボードに配置されます。 フッ
トプリント内の各パッドには、回路図のコンポーネントのピンに接続されたネット名と同じネット属性が割り当てられます。 
もし、フットプリントのパッドが銅箔のプリミティブに接触している場合、これらのプリミティブには自動でネット名が割り
当てられず、デザインルール違反になります。 この場合、ネット名を割り当てる更新過程を実行する必要があります。  

PCBエディタには、広範囲のネット管理ツールが含まれています。実行するには、メニューからDesign » Netlist » C
Physical Netsを選択します。 

onfigure 
図 49 は、Configure Physical Netsダイアログです。図 51 に示すスイッチのフットプリントで

見つかった余分なプリミティブを更新するのに使用します。 Menu ボタンをクリックしてオプションのメニューを表示させ、
New Net Name 領域をクリックして、ネットを選択。割り当てのないプリミティブへネットを割り当てます。 

 
図 49 Configure Physical Netsダイアログで、ネットが無いフットプリントのプリミティブにネット名を更新 

複数のパッドが同じピンに接続されたフットプリント 
図 50

図 50

 に示すフットプリント（TO-3のトランジスタ）は、そのフットプリン
トに相当する回路図コンポーネントのピンにリンクされた複数のパッドを持
っています。 このコンポーネントについては、2つの実装穴のパッド共、同
じ� ‘3’のデジグネータが割り当てられています。  

回路図エディタで Design » Update PCBコマンドを使用して、PCBへデザ
イン情報を移行すると、PCBエディタで両方のパッドに接続線が表示されま
す（それらは、  の様に同じネット上にあります）。 これらの両方共、
配線できます。 

図 50 2つのパッドに、同じネットの 3のデジグネ
ータが割り当てられた TO-3のフットプリント 特別なソルダマスクの取り扱いで必要なこと 

図 51 に示すフットプリントは、PCBの表面レイヤの銅箔に直接、接触させ
る押しボタンスイッチの接触箇所です。 

導電性があるゴムのスイッチパッドを PCB上に配置し、ボタンを押すと、フット
プリントの両方の指状パターンと接触し、導通が生まれます。 

導通させるには、両方のパターンがソルダマスクで覆われている必要はありません。 
円状のソルダマスクの開口は、アークの幅が半径と同じ、または半径より大きいア
ークを配置することにより作成できます。 これは、2つの指状パターンのところ
に円で作成されます。  

指状のパターンは、アーク、水平のライン、パッドで定義されています。 パッド
は、接続箇所の定義に必要です。  

注 : ボードの半田面にコンポーネントを配置する時、手動で配置したソルダ・マス
クは自動で半田面に移動します。 
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その他のフットプリント属性 

ソルダ、ペースト、マスク 
ソルダ、ペーストマスクは、Solder Maskと Paste Maskレイヤそれぞれの各パッドの箇所に自動
で作成されます。 Maskレイヤの形状は、PCBエディタで設定されたソルダ・マスクとペース
ト・マスクのデザインルール、または Padダイアログで指定されたパッドの端からの拡張、また
は縮小されたパッド形状になります。  

パッド属性には、ソルダ・マスク、ペースト・マスクの拡張度の設定があります。 ここでは、部
分的にパッドの拡張度を設定できますが、通常、ここでの設定は行いません。 一般的には、PCB
エディタのペーストマスクとソルダ・マスクのデザインルールで適切な拡張度を設定します。 一
つのルールを定義すれば、ボード上の全てのコンポーネントの拡張度を設定できます。 もし必要
ならば、ボード上の特定のフットプリント、または特定のコンポーネントの特定のパッドなどの
様な特定の条件を割り当てたその他のルールを追加することができます。  

図 52 ソルダ・マスクが表示
されたパッド 

マスクの表示 
PCBライブラリ・エディタで、自動で定義されているソルダ・マスク/ペースト・マスクを確認するには、Maskレイヤを表示
します。 

1. マスクレイヤを表示させるには、View Configurationsダイアログ（Tools » Board Layers & Colors  [ショートカット L]）
を開いて、Show オプションを各マスクレイヤについて有効にし、OKをクリックします。 

2. デザインウィンドウ下部のレイヤタブ（例えば、Top Solder）をクリックして、ソルダマスクを表示します（ ）。 
注 : 各パッドの端の周りに、Top Solder Maskレイヤの色で表示されるリングは、ソルダマスクの拡張の度合いにより、マ
ルチレイヤパッドから突き出したソルダマスク形状の端を表します。これは、multilayer が描画順序のトップのレイヤだか
らです。 レイヤの描画順序は、Preferencesダイアログの PCB Editor - Display ページで設定されています。 

図 52

マスクのエクスパンション（開口サイズ）をデザインルールで設定 
デザインルールでマスクのエクスパンション（開口サイズ）を設定するには: 

1. Expansion value from rules オプションが、Pad ダイアログの Paste Mask Expansion、または、Solder Mask 
Expansion のセクションで有効になっていること確認します。 

2. PCBファイルを開いて（PCBファイルが開いてなくても、簡単に仮の新規 PCBを作成できます）、PCBエディタのメニ
ューから Design » Rules を選択し、Maskカテゴリのデザインルールを PCB Rules and Constraints Editorダイアログで確
認します。 これらのルールは、フットプリントを PCBに配置した時に反映されます。 注 : ルールシステムは階層構造にな
っており、必要ならば、ボード全体に適用させる通常のルールを無視して、より高い優先度を持つルールを定義できます。 

マスクのエクスパンションを手動で指定 
デザインルールのエクスパンジョンを無効にするには、パッド属性のマスクエクスパンジョンを指定します: 

1. Padダイアログの Paste Mask Expansion または Solder Mask Expansion セクションの Specify expansion value を選
択します。 

2. 値を入力し OKをクリックします。 フットプリントを保存します。 

デジグネータとコメント文字 

デフォルトのデジグネータとコメント文字 
今、ライブラリで作成しているのはフットプリントです。 基板にフットプリントを配置すると、デジグネータとコメントが割
り当てられます。これを、コンポーネントと呼びます。 フットプリントを作成する時、デジグネータとコメント文字を手動で
定義する必要はありません。 これらは、フットプリントを基板に配置する時、自動で追加されます。 これらの文字の位置は、
Componentダイアログのデジグネータとコメント文字の Autopositionオプションで決まります。 Preferencesダイアログの
PCB Editor – Defaultsページで文字の位置（サイズ）を事前に定義できます。 

デジグネータとコメント文字の追加 
デジグネータ、またはコメント文字を追加したい状況があるかもしれません。 例えば、設計者はレイヤ別に出力する図面でコ
ンポーネントが配置される位置にデジグネータのシルクが必要である一方、基板製造業者は、デジグネータを含む各コンポー
ネントの詳細な製造図面が必要です。 このようなデジグネータを追加したい場合、フットプリントに.Designator のスペシ
ャル・ストリング（.Comment のスペシャル・ストリングもあります。 ）を含めることで対応できます。 基板製造業者に渡す
図面を作成するには、ライブラリ・エディタでメカニカルレイヤに.Designator のスペシャル・ストリングを配置します。 
それから、このレイヤの図面を印刷します。  
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この機能が必要な場合、以下の方法を実行します: 

1. 必要なメカニカルレイヤを表示します。各メカニカルレイヤの Show と Enable オプションを、View Configurations ダイ
アログ（Tools » Board Layers & Colors）で有効にします。 

2. このレイヤをアクティブにするには、デザイン・ウィンドウの下部のMechanicalレイヤタブをクリックします。 タブがハ
イライト表示され、すべての新しいテキストはこのレイヤに配置されます。   

3. Place » String [ショートカット P, S]を選択するか、Place String ボタンをクリックします。  

4.  テキストストリングを入力しその属性（例えば、フォント、サイズ、レイヤ）を定義するには、テキストを配置する前に、
TAB キーを押します。 Stringダイアログが表示されます。 Textのドロップダウン・リストから.Designator を選択しま
す。 テキストの Height（高さ）を 40mil に、Width（幅）を 6mil に設定して OKを押します。 デジグネータの左下に
は、.Designatorのストリングのドットがあります。 

5. これでテキスト・ストリングを配置できます。 テキストストリングを回転させるには Spacebarを押します。 必要な場所
に移動し、クリックして配置します。 右クリック、または ESCを押して、ストリング配置モードを抜けます。  

6. 必要であれば、同じ手順を実行して.Commentのスペシャル・ストリングを配置します。 

7. 特別なストリングをテストするには、PCBにフットプリントを配置します。 PCB Libraryパネルでフットプリント名を右
クリックし Placeを選択して、フットプリントを配置できます（PCBファイルが開いているとき）。 フットプリントを
PCBドキュメントに配置してもデジグネータが表示されない場合は、PCBエディタの View Configurationsダイアログ、
View Optionsページで、Convert Special Strings オプションが選択されているか確認してください。 

特別なレイヤ指定要求の取り扱い 
グルードット、またはソルダー・マスクの様な PCBコンポーネントに割り当てる
特別な必要条件があります。 これらの特別な必要条件の多くは、コンポーネントを
実装する配置面に関連しており、コンポーネントを反転する時、コンポーネントに
関連するオブジェクトもボードの反対面に反転する必要があります。  

Altium Designerの PCBエディタでは、滅多に使用しない特別な目的のレイヤを含
めるのではなく、”レイヤペア”という機能を利用してこの要求をサポートします。 
レイヤペアとは、ペアとして定義された 2つのメカニカルレイヤです。 コンポーネ
ントをボードのある面から反対面に反転する時はいつでも、ペアとなったメカニカ
ルレイヤのオブジェクトは、そのペアの反対面のメカニカルレイヤに反転します。  

この方法を使用して、グルードット（または、その他の特別な条件）を含めるのに
適切なメカニカルレイヤを選択します。 そして、オブジェクトを使用してその形状
を定義します。 ボードにフットプリントを配置する時、レイヤペアを設定する必要
があります。 これにより、このコンポーネントをボードの反対側に反転する時にそ
のオブジェクトを移行するレイヤが指定されます。 注 : レイヤペアは PCBライブ
ラリエディタでは定義できません。PCBエディタで定義します。  

図 53 PCBエディタでのレイヤペア定義 

3次元コンポーネントの詳細機能 3D 
今日のエレクトロニクス製品はより精密で複雑になっており、PCB設計者はコンポーネントの水平方向のクリアランスの条件
以上のことを考慮する必要があります。 また、高さ制限やコンポーネントの下にコンポーネントを配置するオプションを考慮
する必要があります。 さらに、最終的な PCBファイルを機構 CADツールへ移行し、開発中の製品を仮想的に組み立て、パッ
ケージの完成度を確認する必要があります。 Altium Designerには、これらの異なる状況に対応する機能が多数、搭載されてお
り、もちろん、その中にはリアル 3Dビジュアライゼーションが含まれています。 

PCBフットプリントへ高さ情報を追加 
最も簡単なレベルでフットプリントに高さ属性を追加できます。 これを実行するには、PCB Libraryパネルの Components
リストのフットプリント名をダブルクリックし、PCB Library Componentsダイアログを表示させます。 そして、Heightの項
目にコンポーネントの高さを入力します。  

Height デザインルールは、ボード設計中に定義できます（PCBエディタで Design » Rules を選択します）。 一般的には、コ
ンポーネントのクラス、またはルームを定義して最大のコンポーネントの高さについてテストします。 

フットプリントに 3Dボディを追加 
よりリアルなコンポーネントレンダリングのため、3Dビューモード[ショートカット 2 (2D), 3 (3D)] が PCB ライブラリエディ
タに用意されています。3Dボディのオブジェクトはフットプリントに追加できます。3Dボディは有効なメカニカルレイヤ上
でのみ、フットプリントに追加できます。 押出成型のようなシンプルな 3Dボディは、2Dポリゴンタイプのオブジェクトです。
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表面カラーと高さの属性を持っており、3Dのレンダリング時には、引っ張ったような、あるいは型で押し出したような形をし
ています。 3Dボディは球体や円筒形も作成できます。 

複数のの 3Dボディは、コンポーネントの物理的なサイズと形状を全方向にわたって定義するために結合させることができ、
コンポーネントクリアランスのデザインルールで使用されます。 高精度の 3Dモデルはコンポーネントクリアランスのチェッ
クの精度を向上させ、視覚的な訴求力と完成した PCBアセンブリのリアリティを向上させます。 

Altium Designerは、PCBフットプリントへダイレクトに 3D STEPモデル（*.step or *.stp files）をインポートし、3Dモデル
をレンダリングする機能をサポートしています。 この機能的な拡張は、STEPモデルを Altium Designerのドキュメントに組込
むか、リンクすることができるようにします。ただし、リンクされた STEPモデルは、PCBライブラリエディタでは扱えませ
ん。 

注 : コンポーネントを反転させると、3Dボディもボードの反対側に反転します。 3Dボディデータ（メカニカルレイヤ内）を
別のメカニカルレイヤに反転させたい場合は、PCBドキュメントにレイヤペアを定義する必要があります。詳細は、特別なレ
イヤ指定要求の取り扱いをご覧ください。 

3Dボディを手動で配置 
3Dボディは、手動で PCBライブラリエディタ内に配置することができます
（Place » 3D Body） それらは、PCBライブラリエディタのフットプリント
（および、PCBエディタに配置されたフットプリント）にも自動的に追加され
ます。 3D Body Manager ダイアログ (Tools » Manage 3D Bodies for 
Library/Current Component)を使用してください。 

注 : 3Dボディは、2Dモデルにも、3Dモデルにも配置できます。 図 54 - DIP-14 コンポーネントの詳細 
ここで、このチュートリアルで以前に作成したフットプリント DIP14 に 3Dボ
ディを追加してみましょう。 PCB ライブラリエディタで 3Dボディを手動で配置するには:  

 

 
図 55 - DIP-14 3Dのフ
ットプリント 

1. PCB Library パネルで、DIP-14 エントリをダブルクリックすると、PCB Library Component ダイア
ログが開きます（ ）。名称、高さ意、記述がわかります。 コンポーネントの高さが、ここでは
重要です。実際に高さのある 3Dボディを作る必要があるからです。  

図 54

 注 : コンポーネントの諸元について製造元のデータが利用できる場合は、それをお使いください。 

2. Place » 3D Bodyを選択します。 コマンドの起動後、3D Body ダイアログが表示されます (図 56) 。
Extruded オプションを 3D Model Type 領域から選びます。 

 

3. Properties 領域で、3Dボディオブジェクトに特定の名前(Identifier)を付けます。Body Side (基板の
どちらの側で 3Dボディプロジェクトを垂直にするか) は、Top Side のままにしておいてください。  

 注 : コンポーネントには、ピンのように、PCBから突き出しているネガティブスタンドオフの高さを
入力できます。 スタンドオフの高さはデザインルールチェッカではチェックされません。 

4. Overall Height を 200mil に、Standoff Height（ボードから 3Dボディ下部までの距離）を 0mil に
設定。3D Color の色を適当に設定します。 

5. OK をクリックして、3D Body ダイアログを閉じます。配置モードにな
ります。 2Dでは十字形、3Dでは青色の円錐にカーソルが変化します。  

6. カーソルを移動させ、クリックして、ボディの開始点を固定します。続
いて、一連の頂点ポイントを固定して、ボディのポリゴン形状を定義し
ます。 

7. 最後の頂点ポイントを配した後、右クリック、または ESC を押してボ
ディの配置を完成させます。 Altium Designerでは、最初に配置したポ
イントから最後に配置したポイントを自動的に結び、形を作成するので、
完全に閉じたポリゴンを作成する必要はありません。 

形状の定義中に SHIFT + SPACEBAR を使って、いくつかのコーナーモー
ドを切り替えることができます。 切り替え可能なモードは次のとおり: 自由
アングル、45°、アークつき 45°、90°アークつき 90° アークの半径は自由に
増減できます。SHIFT + . （ピリオド）、または、SHIFT + , （コンマ）を
それぞれ使用します。 SPACEBAR で、コーナーの向きを切り替えること
ができます。 

押出 3Dボディオブジェクトが選択されているときは、編集ハンドルが各頂
点に表示されます。 カーソルが変化して、  ハンドルを捉えたら、クリッ
ク&ドラッグで頂点を動かすことができます。 このカーソルが縁の中間に表
示されたら、クリック&ドラッグで頂点をその縁に追加し、動かすことがで
きます。  
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カーソルが変化して、  オブジェクトの縁を捉えたら、クリック&ドラッグで縁を動かすことができます。 

カーソルが変化して、  オブジェクトを捉えたら、クリック&ドラッグで 3Dボディを動かすことができます。 3Dボディは
ドラッグして、回転させたり、反転させたりできます。 編集コントロールを使って、3Dボディの形状を調整してください。 

配置モードのときに BACKSPACE キーを使うと、最後に配置した頂
点を削除できます。 キーを繰り返し使うと、ポリゴンの外形を '崩す' 
ことができ、最初にはじめたところに戻ることができます。 

この形状は、Component Clearance 設計ルールに適合しています。し
かし、3Dビジュアライゼーション用としては、不十分かもしれません。 
さらに 3Dボディを設計して、コンポーネントの詳細を追加すること
もできます。 

図 59 TO-39 3D モデ
ル 

3D ボディを完成させると、3D Body ダイアログが表示されます。 3D 
ボディの配置を続けるか、Cancel をクリック、または ESC を押して
ダイアログを閉じます。  は Altium Designerが作成した DIP14 
3Dです。 

図 57

3D ボディを 3D で見たいときは、3 を押して、3D ビューモードに入
ります。 3D ボディが見れないときは L を押して、View 
Configurations ダイアログを開きます。Physical Materials ページの 
Show Simple 3D Bodies オプションを有効にするか、あるいは、3D 
Bodeis Display Options コントロールを PCB パネル上で使用してく
ださい。,3D モデルモードになります。 2D モードに戻るには、2を押します。 

図 57 DIP14 の 3D の例 このモデルには 16の 3Dボディ - メ
インボディ、足、円筒によるピン 1参照マーカ - が使われて
います。 

PCBライブラリを保存します。 

3D Body をインタラクティブに作成 
3D ボディオブジェクトをフットプリントから対話的に作成するのは、手動のやり方とよく似ています。 基本的な違いは、フ
ットプリントの詳細を含む既存のオブジェクトから、3D ボディとして”押し出す”ことのできる閉じた形状を検出するのに、
Altium Designerを使うことです。 これは、3D Body Manager ダイアログで行います。 

注 : ”閉じている” ポリゴンだけが 3D ボディオブジェクトを作成できます。 

3D Body Manager ダイアログを使用して、トランジスタパッケージ用の 3D ボディ、TO-39 を定義しましょう。 パッケージ
ボディのカーブ形状や位置づけタブのおかげで、このアプローチは形状を手動で定義しようとするよりも簡単です。 

3D Body Manager ダイアログを使用するには: 

1. ライブラリで、TO-39 フットプリントをアクティブにします 

2. Tools » Manage 3D Bodies for Current Component を選択します。 3D Body Manager ダイアログが表示されます。 

 

図 58 3D ボディが追
加された TO-39 2D フ
ットプリント

図 60  3D Body Manager ダイアログを使って、既存のプリミティブから 3D ボディオブジェクトをクイック作成 
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図 61 3D ボディの詳細が表示される PCBLib List パネル 

1）を

3. コンポーネントのシルク外形に基づいた形状を作成
するには、リストに表示される 2 番目のオプション、
Polygonal shape created from primitives on 
TopOverlayを使用します。 ダイアログのこの行で、
Action 行の Add to (component_name)をクリック
し、Registration Layer をボディオブジェクトが配
置されるメカニカルレイヤに設定します（この場合
は Mechanical1）。Overall Height に適当な値、た
とえば 180milに設定。Body 3D Color は適当な色
に設定します。 図 60 をご覧ください。 リストをスクロールして、コンポーネントモデルを定義するのに使いたい、いず
れかの閉じたポリゴンを選択します。 

4.Closeをクリックすると、3Dボディの形状は  のようにコンポーネント上に表示されます。 ライブラリを保存します。 図 58

図 59 は、TO-39 用に完成された 3D モデルです。 このモデルは、5つの 3Dボディオブジェクトから構成されています。 

• ひとつはベースで、フットプリント外形（全体の高さ 50mil、スタンドオフの高さ 0mil、ボディ 3D の色は灰色）から作成
されます。 

• ひとつは、ケーシングのボディで、配置された円形から作成され、閉じたポリゴンをそこから選び出します。その際、3D 
Body Manager ダイアログによって検出され、次のような属性 - 全体の高さは 180mil、スタンドオフの高さは 0mil、色
は灰色 - を付与されます。 

• ひとつはピンで、これも配置された円形 （全体の高さ 0mil、スタンドオフの高さ -450mil、色は金色）から作成されま
す。 これはコピーされ、ペーストされ、残りのピンを作成するのに、2回、位置決めされています。 

3D ボディを編集するには、右クリックして、ポップアップメニューからProperties を選んで、3D Body ダイアログを開きま
す（図 56）。 PCBLib List パネル（図 6 使って、3D ボディをリストし、直接、編集することもできます。 

3D Body の詳細については、TR0112 PCBエディタとオブジェクトのリファレンス ドキュメントの 3D ボディのセクションを
参照してください。 

3DボディとしてSTEPモデルをインポート 
多くのコンポーネントベンダが詳細な 3Dモデルを提供して、一般的なメカニカル CADパッケージで使用されています。 
Altium Designerは 3D STEP モデル（*.step or *.stp）を直接、コンポーネントフットプリントにインポートすることができま
す。 モデルを自作するより、時間が節約され、さらに洗練されたモデルにすることもできます。 

STEP ファイルでは、AP214、AP203 フォーマットがサポートされています。 AP203 フォーマットでは彩色がサポートされ
ていません。インポートされたモデルは、グレイスケールで表示されます。 

リンクされたSTEPモデル 
リンクされた STEP モデルは、PCB ライブラリエディタではサポートされていません。 組込み STEP モデルはサポートされ
ていません。 

STEPモデルのインポート 
STEP モデルのインポート手順は、以下のとおりです: 

1. Place » 3D Body [ショートカット P, B]を選択します。 3D Body ダイアログが表示されます。 

2. Generic STEP Model オプションを 3D Model Type 領域で選択します。 

3. Embed STEP Model ボタンをクリックします。 Choose Model ダイアログが表示されます。そこで *.step や *.stp ファイ
ルを確認することができます。  

4. 目的の STEP を選択し、 Open ボタンを押して Choose Model ダイアログを閉じます。 

5. 3D Body ダイアログに戻り、OK をクリックして閉じます。 3D ボディがカーソルの上に表示されます。 

6. ワークスペース内でクリックして、ロードされた選択モデルとともに、3D ボディオブジェクトを配置します。 

STEP モデルの位置決めと向き 
STEP モデルがインポートされると、プレースホルダ 3D ボディがモデルを収納するためにリサイズされます。 生成アプリケ
ーション内で使用されている原点のせいで、PCBドキュメントの座標軸に対して、STEP モデルを正確に方向付けるのは難し
いかもしれません。 STEPモデルのグラフィカルな位置決めを行うには、いくつかの方法があります。モデルを扱うために配
置されている参照ポイント（snap points でわかります）を使用するか、ボードに対するモデルの表面または表層を使用します。 
非グラフィカルな位置決めは、 3D Body ダイアログの Generic STEP Model 領域の設定で実行できます 

STEPモデルの位置決めと向きについての詳細は、TU0132 MCADオブジェクトとPCBデザインの統合 を参照してください。 
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その他のソースからフットプリントを追加 
PCBライブラリに既存のフットプリントをコピーできます。 コピーしたフットプリントは名称を変更したり編集を行うことが
できます。 

もし、既存のフットプリントを PCBライブラリにコピーしたい場合、以下のことができます:  

• PCBドキュメントで配置したフットプリントを選択し、コピーして（Edit » Copy）、開いている PCBライブラリに Edit 
» Paste Component を使用してペーストします。  

• Edit » Copy Component を選択して、PCBライブラリエディタにコピーするフットプリントをアクティブにします。コピ
ー先の PCBライブラリを開き、Edit » Paste Component を選択します。  

• 一つ、または複数のフットプリントを PCBライブラリパネルのリストで選択します。標準的な操作、Shift + クリック、ま
たは、Ctrl + クリックしたまま、右クリックで、Copyを選択します。コピー先のライブラリに切り替えて、フットプリン
ト名のリストで右クリックし Pasteを選択します。 
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コンポーネントのフットプリントの確認 
回路図ライブラリエディタには一連のレポート機能があり、フットプリントが
正しく作成されているか確認し、どのコンポーネントが既存の PCBライブラ
リにあるか特定できます。 既存の PCBライブラリのすべてのコンポーネント
を確認するには、Component Rule Checkのレポート機能を実行します。 
Component Rule Checkerは、複数のプリミティブ、パッドのデジグネータの
誤り、未接続の銅箔、不適当なコンポーネントについてチェックします。 

図 62 デザインで使用する前に、ライブラリ内のフ
ットプリントを検証 

1. レポートを実行する前にライブラリ・ファイルを保存します。 

2. Reports » Component Rule Check [ショートカット R, R]を選択して、
Component Rule Checkダイアログを表示させます。  

3. すべてのチェックボックス有効にして、OKをクリックします。 
PCBlibraryfilename.err と言うレポートが作成され、テキストエディ
タに表示されます。 どんなエラーもチェックされます。 

4. レポートを閉じて PCBライブラリ・エディタに戻ります。 

統合ライブラリの作成 
これまで以下のような操作を行ってきました: 

 

• 統合されたライブラリパッケージ（コンパイルされた統合ライブ
ラリのソースプロジェクト）を作成しました。 

• 新規の回路図ライブラリをライブラリパッケージに追加し、回路
図コンポーネントを作成しました。 

• コンポーネントがその他の領域で使われる際に使用するモデルを
特定しました。ボードデザイン、または回路シミュレーションな
どです。 

• 新規の PCBフットプリントライブラリをライブラリパッケージ
に追加し、フットプリントを作成しました。 

• 特別なフットプリントを扱う方法について説明しました。  

このチュートリアルの最後の手順では、ライブラリパッケージをコン
パイルして統合ライブラリを作成し、コンポーネントやすべての参照
モデルを含む一つのファイルを作成します。 たとえ、統合ライブラ
リを使用しないでソースライブラリとモデルファイルから直接、作業
する方を好んだとしても、ライブラリパッケージをコンパイルする強
力な動機があります。 これにより、広範囲なコンポーネントやコン
ポーネントに関連するモデルをチェックすることができます（
）。 

図
63

ライブラリパッケージをコンパイルするには: 

図 63コンパイル時にエラーチェックが実行されます 
1. Project » Compile Integrated Libraryを選択して、統合ライブ
ラリのライブラリパッケージ内のソースライブラリやモデルファ
イルをコンパイルします。 コンパイル中に見つかったエラー、ま
たはワーニングは、Messagesパネル（View » Workspace Panels » System » Messages）に表示されます。 Messages
パネルでエラーをダブルクリックすると、詳細情報を表示して、コンポーネントにジャンプします。 この方法でソースラ
イブラリのエラー箇所を修正し、統合ライブラリを再コンパイルします。 

2. 新規の Integrated Libraryname.INTLIB が作成され、Project Optionsダイアログの Optionsタブで指定した出力フォルダに
保存されます。 新規の統合ライブラリは自動で Installed Librariesのリストに追加され、Librariesパネルに表示されます。  

Design » Make Integrated Libraryコマンドを使用して、完成したプロジェクトから統合ライブラリを作成できることに注意
してください。 これは最初にソースライブラリを作成し、それから統合ライブラリを作成する方法です。 

統合ライブラリの詳細については、TU0111 統合ライブラリの作成を参照してください。 
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用語 
以下の用語がこのチュートリアルで使用されています。 

ラララララララ ラララララララは、ーライに配位さこさ物管電かコデラスささ。編集集集、抵抵かな。  
さこかのラララララララには、一つのパララ、さまは複複のパララさ構作さこにしさかのさがりささ。  

ーコグ3D  ーコグはララポラさ形作さこまオラペチリラさ、有有かイグメググレラレ上のググラオラララに追追ささささ。3D  
水水水水、垂垂水水のオレララさ、ラララララララの物管電かサラサさ形形を設定ささますに使用ささささ。さきでさラララダラグさこま

リラダララスイチグリや、 ビペイダララビラオオ ラを可可にににしささ。3D  3D 
ーコグオラペチリラは、ラララララララググラオラララににけさ モコグのオレラスホグダさにに、さま、 に実実さこかし自STEP PCB
由由由オラペチリラ、ハウペラダやダアラララかなさにに活用ささささ。  

コペダララパ（ 由

由番番、識特張）  
固有の識特張。 さ、特設のラララララララをその他のラララララララかか見分けさますに使用にささ。PCB  
コペダララパは、ダググモレグラ、複数、さまはその組み場わささ表ささささささささ。  
パグイさは、さかに、ラララララララのピラ番番に一一ささ固有のコペダララパさ割り当にかこささ。   

ググラオラララ ググラオラララは、 上に実実さこさララララPCB ラララに必必かスペラスを設定（ さまは、モコグ化） にささ。  
ラララララララのググラオラララモコグは、 ラララララに保保さこささ。PCB  
ググラオラララには、コデラスのピラへ接接ささますのパグイさ、オグリ（ オラデラレラ） レラレ上にララグリさまはダラリアダイララさ

作作さこまパグパラペの物管電か外形さ含さこにしささ。 さかに、コデラスの実実ささ機可さ含さこにしささ。   

ラララララ内のググラオラララには、コペダララパ、さまはライララはがりささで。PCB  
オララ上に配位さこ、コペダララパやライララさ割り当にかこま時PCB に、そこかはラララララララにかりささ。  

ヒイヒラピラ ラララララララには保現さささ、表表ささ必必さ無しピラささ。  
一一電には、パワラピラささ。指設にまラグラに自自電に接接さこささ。  

ラララララ  集集回ラララララは、個々 のオララに保保さこまラララララララやそのパラパの一一ささ。  
ラララララは、ラララララララググラオラララを含みささ。 各ラララララパラオには、そこ自自のエコグパさがりPCB  ささ。  

統場ラララララは、集集回ラララララを関関にまモコグさ結場ささささ。ラララララエコグパさは垂接、編編ささささで。  

オラペチリラ ラララララエコグパのワラリスペラスに配位さささ個々 のダラアアささ。  

パグイ パグイオラペチリラは、通常、ググラオラララに使用さこ、ラララララララピラの接接パグイを生作にささ。  

パララ ダラググググオラペチリラの編さりさ、複複のコデラスを持つラララララララの一つを表にささ。  
パララは、集集回ララララララララララララのラララララララ内さ個特のオララに保保さこささ。  

ピラ ラララララララのピラは、ラララララララに電電電か属属を割り当にに、接接接場を設定にささ。  
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更新履歴 

Date Version No. Revision 

09-Dec-2003 1.0 New product release 

24-Nov-2004 1.1 Updated for DXP 2004 SP2.  

23-Aug-2005 1.2 Revised and updated for Altium Designer SP4. Component bodies included. 

12-Dec-2005 1.3 Path references updated for Altium Designer 6 

9-Jun-2006 1.4 Updated for Altium Designer 6.3 in regards to new pad hole kinds and updated Pad properties dialog. 

12-Sep-2006 1.5 Reference to the IPC Footprint Wizard added. 

05-Jan-2007 1.6 Amended order of parameter entries in table under Component Links section. 

12 Nov-2007 1.7 Updated for Altium Designer 6.8 

21-Dec-2007 1.8 Updated for 6.9. 

22-Jan-2008 1.9 Added detailed STEP model import/orientation for 6.9 

29-Jan-2008 2.0 Removed incorrect document reference. 

12-Feb-2008 2.1 Changed component body references to 3D body. 

22-May-2008 2.2 Converted to A4, added STEP model references to TU0132 for S08. 
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