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このチュートリアルでは、アナログフィルタデザインの回路図を作成して、回路シミュレーションをセットア

ップします。設定、解析の実行、を回路図上で行い、結果を波形アナライザで表示するまでをカバ

ーします。 

 

 
このチュートリアルでは、回路シミュレーション解析を実行するために回路図を作成することから始めます。最初に新規プロジェクトファイルを作成してか

らブランクの新規回路図シートを追加します。 

新規プロジェクトの作成 
チュートリアルを開始するには、新規 PCBプロジェクトを作成します: 

1. メニューから File » New » Project » PCB Projectを選択するか、または Filesパネル
の Newの項目にある Blank Project (PCB)をクリックします。もし、このパネルが表
示されていない場合は、ワークスペースパネルの下部の Files タブをクリックします。 

あるいは、Altium Designer Home Page (View » Home) の Pick a Task の項目の Printed 

Circuit Board Designを選択してから New Blank PCB Projectをクリックします。 

2. Projectsパネルが表示されます。新規のプロジェクトファイル（PCB 
Project1.PrjPCB）がここに No Documents Addedとしてリスト表示されます。  

3. File » Save Project Asを選択して、新規のプロジェクトファイル（拡張子.PrjPCB）の名称を変更します。ファイル名を
Filter.PrjPCBと入力し、プロジェクトの保存先を指定し、Saveをクリックします。 

次に空のプロジェクトファイルに追加する回路図を作成します。この回路図は、フィルタ回路になります。もし、回路図を作成する時間が無い場
合は、Altium Designer がインストールされている場所の Examples\Circuit Simulation\Filter フォルダに保存され
ている類似のプロジェクト（Filter.PrjPCB）を開きます。 

新規回路図シートの作成 
新規の回路図シートを作成するには、次のステップを実行します:  

1. File » New » Schematicを選択します。回路図エディタのデザインウィンドウに Sheet1.SchDoc というブランクの回路
図シートが表示され、Projectsパネル内のプロジェクト名が表示されている下の Source Documentsに回路図シートのアイ
コンが表示されます。 

2. File » Save As を選択して、新規の回路図ファイル（拡張子.SchDoc）の名称を変更します。ハードディスク上で回路図を
保存したい場所を指定し、ファイル名の項目で Filter.SchDoc と入力して Saveをクリックします。 

TU0106 (v1.6) April 20, 2008 1 



Defining & Running Circuit Simulation Analyses 

回路図の作成 
図 1.Filter.SchDoc 

に示すフィルタ回路を作成します。 Before we can run a simulation, the schematic must contain components with SIM models attached, 
voltage sources to power the filter, an excitation source, a ground reference for the simulations and some net labels on the points of the circuit 
where we wish to view waveforms.シミュレーションを実行する前に、回路図に付属の SIMモデルを持つコンポーネントやフィルタに供給する

必要があります。 

チュートリアルのこの項目では、コンポーネントを配置し、それらの属性を設定してからワイヤを接続します。 
電源ソース、入力ソース、グランドシンボル、そして波形を表示したい場所にネットラベルを配置する

 
図 1.Filter.SchDoc 

3.S
。

ックし、ライブラリフォルダを確認します。Include Subdirectoriesオプションが有効（チェック）になっ

4. 

されていることを考慮して使用するワイルドカ

5. 

 Amplifier.IntLib ライブラリに保
存されています。 

コンポーネント配置とライブラリの読み込み 
最初に LF411CN というオペアンプのコンポーネントを検索します。 

1. Librariesタブをクリックして Librariesワークスペースパネルを表示させます。 

2.Librariesパネルの Searchボタンを押すか、Tools » Find Componentを選択します。Libraries Searchsダイアログが開きます。 

copeを Libraries on Pathに設定し、Pathの欄でこれから検索するパスが指定されているか確認します。インストールの際、
デフォルトディレクトリを適用した場合、パスは、C:\Program Files\Altium Designer\Library\になるはずです
必要ならば、フォルダアイコンをクリ

ていることを確認します。 

LF411に関連するすべての部品を検索する為に、Libraries 

Searchダイアログの上部のテキスト入力欄に*LF411* と入
力します。*（アスタリスク）は、メーカーごとに異なる接頭辞や
接尾辞が挿入
ードです。 

Searchボタンをクリックすると検索が開始され、検索結果が
Libraries パネルに表示されます。 必要なコンポーネントは、
NSC Operational

2 TU0106 (v1.6) April 20, 2008 



Defining & Running Circuit Simulation Analyses 

シミュレーション用コンポーネントの配置 
最初にオペアンプ U1のコンポーネントを回路図に配置します。回路の一般的なレイアウトに関しては、図 1に示した回路図を
参照してください。  

1. Librariesパネルの Componentsリストで LF411CN を選択し、Place LF411CNボタンをクリックします。あるいは、コンポーネン

ト名をダブルクリックします。  

2. ライブラリが登録されていない場合、Confirmダイアログが表示さ
れます。  

3. ライブラリを登録するには、Yesをクリックします。オペアンプのシン

ボルがカーソル上に現れます。今は、部品の配置モードになっています。  

4. 回路図に部品を配置する前に、まず、その属性を編集します。オペアンプが
カーソルにある時に TAB キーを押して Component Propertiesダイアログを表示させます。  

 

5. ダイアログの Propertiesセクションに、最初のコン
ポーネントデジグネータの値を設定します。
Designatorの項目に U1 と入力してください。 

6. 次に、シミュレーションを実行する時に使用する 
SIM  モデルを確認します。このチュートリアルでは、回

路シミュレーション用の推奨モデルが既に含まれている統合ラ

イブラリを使用します。Component Propertiesダイアログ
の Modelsリストの LF411_NSC を選択します。 そ
して、Edit をクリックし SIM Model – General / 

Generic Editorダイアログを表示します。 

7. モデルファイルパス名が、NSC Operational 
Amplifier.IntLib 統合ライブラリで検索され、
設定されていることに注目してください。  
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Model Fileタブをクリックし、モデルファイルの内容を表示させます。もし、モデルファイルが見つからない場合は、エラーメッセージが

このタブに表示されます。 

Altium Designer のシ
ミュレータ サポート
は、Spice 3F5 モデ
ルと PSpice モデル
の大半です。. 

 

8. （Netlist Templateタブをクリックして表示される）Netlist Templateにモデルファイルからのデータが表示され、その内容
を Netlist Previewタブをクリックして確認することができます。 

    

OKをクリックして、すべてのダイアログを閉じます。  

これで回路図シートにオペアンプを配置する準備ができました。 

9. もし、図 1の回路図を参照する場合、U1がカーソル上にフローティングの状態であるシンボルを反転して配置されている
ことに注意してください。オペアンプの方向を垂直に反転するには、配置する前に Yキーを押します。シート上でコンポー
ネントを配置する場所に移動し、左クリックするか ENTERを押して回路図に配置します。 

10. 右クリックまたは ESCキーを押して、部品配置モードを解除します。   

新規SIMモデルファイルの追加 
回路シミュレーション（.ckt や.mdl ファイル）で使用する SPICEモデルは、Altium Designer がインストールされている場
所の Library フォルダの統合ライブラリ内に保存されます。正しい拡張子をそれぞれのモデルタイプに使用してください。例えば、
SPICE .subcktは*.cktファイルでないと見つけられなくなり、SPICE .model は*.mdl ファイルでないと見つけられなくなり
ます。  

Model Nameは、SIMモデルファイルへリンクさせるのに重要ですので、適切なモデル名であることを確認してください。
Altium Designer の統合ライブラリ内の既存のモデルファイル名を検索するには: 

1. Librariesパネルの Searchボタンをクリックします。Libraries Searchダイアログが表示されます。 

2. 供給されたライブラリで利用できるすべてのシミュレーションモデルを検索するには、次のクエリを入力します:  

HasModel('SIM','*',False)と入力し、Searchボタンをクリックします。 

更に、クエリにより詳細な情報を追加することにより、検索範囲を狭くすることができます。 例えば、LF411 に関するモデルだけを検索するには、

次のクエリを使用します: 

HasModel('SIM','*LF411*',False) 

クエリの詳細については、Query Helper（Libraries SearchダイアログのHelperボタンをクリック）を使用するか、TR0110 
クエリ言語リファレンスを参照してください。 

3. 検索結果が Librariesパネルに表示されます。 

既に統合ライブラリのコンポーネントに供給されているモデルではなく、その他のモデルをデザインで使用したい場合があるかもしれません。この場合、メ

ーカーから入手したモデルファイルをデザインのプロジェクトファイルにコピーすることをお薦めします。  

その他の統合ライブラリに属するシミュレーションモデルを使用したい場合: 

1. 必要なモデルを含む.Intlib ファイルを開きます（File » Open を選択し、ソースライブラリを抽出します）。  

2. 出力フォルダ（統合ライブラリを開いた時に作成されたフォルダ）からプロジェクトを含むフォルダに、モデルファイルをコピーします。それから、この
モデルを追加し、必要ならば Simエディタを使用して修正することができます。 

試しに、Altium Designer がインストールされている場所の Examples\Circuit Simulation\Filter フォルダに保存されて
いる他の SPICEモデル（LF411C.ckt）を追加します。  

1. LF411C.cktをコピーし、Windowsエクスプローラを使用して、作成したプロジェクトファイルが存在するフォルダにこ
のファイルを貼り付けます。 

2. Projectsパネル内のプロジェクト名（Filter.PrjPCB）を選択して、右クリックし Add Existing to Projectを選択して、プ
ロジェクトにモデルファイルを追加します。モデルファイルを選択し Openをクリックします。SPICEモデルファイル
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（LF411C.ckt）が、Projectsパネル内の Libraries\AdvancedSim Sub-Circuits フォルダ下のプロジェクトに追加
されます。 

これで回路図内のコンポーネントへモデルを追加することができます。もし、必要ならば回路図ライブラリのこのコンポーネントへモデルを追加するこ

ともできます。 

3. オペアンプ(U1)をダブルクリックして、Component Propertiesダイアログを開きます。Modelsの項目で設定されている SIM

モデルを削除します。 削除するには、SIMモデルを選択して Removeをクリックし、Confirmダイアログで Yesをクリック
します。 

4. Models Listの項目の Add をクリックして Add New Modelダイアログを表示させます。  

5. Model Typeのドロップダウンリストから Simulationを選択し、OKをクリックします。SIM Model – General / Generic Editor

ダイアログが表示されます。  

6. Model Sub-Kindリストから Spice Subcircuitを選択して Spice Prefixを Xに設定し、Model Locationの項目を表示します。ダ
イアログ名は、Model Sub-Kindに変更されます。  

7. Model Nameの項目に LF411C と入力しま
す（拡張子は必要ありません）。 一致す
るモデルをすべての有効なライブラリから
検索する為、Model Locationは Anyに設定
します。  

Altium Designerは、一致するモデルが見つ
かるとすぐにモデルの検索を停止します。
統合ライブラリに関連付けられていないモデルにつ

いては、プロジェクトに追加したモデルファイルを検

索します。 更に、Options for Project ダイアログ 

(Project » Project Options)の Search Paths タ

ブ内で設定されている Search Paths で見つかっ

たモデルファイルを検索します。この例では、
projectフォルダに保存されているモデルフ
ァイル（LF411C.ckt）を検索します。 

モデル検索で一致するモデルが見つからな
い時は、Model Fileタブにエラーが表示されます。プロジェクトをコンパイルすると、エラーは Messagesパネルに表示さ
れます。  

8. 最後の段階は、新しいモデルが回路図コンポーネントのピン番号と一致しているかピンマッピングを確認することです。SIM Model – General / 

Spice Subcircuitダイアログの Port Mapタブをクリックします。  

 

9. Model Pinドロップダウンリスト（上図のダイアログ参照）から一致するピンを選択して、元の SIMモデル（LF411_NSC）
に使用されているピン番号と同じになる様、ピンマッピングを修正します。  
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ピン番号の順番は、Netlist Templateタブで確認します。このモデルの指示は、1, 2, 3, 4, 5であることに注意してください。 

 

これらは、Model Fileタブに表示される.SUBCKT ヘッダーと対応します。 これらの番号は、このモデルファイルでの設定で、他のモ

デルでは同じように一致するとは限りません。 

 

Port Mapタブの Model Pin 欄で、1(1), 2(2), 3(3), 4(4), 5(5), とリスト表示されます。 最初の番号が、モデルピン番号で
（Netlist Templateの%1, %2, など）、サブサーキットヘッダーに対応
するノード名／番号は、括弧で囲まれます。 

サブサーキットヘッダー内の実際の番号は、重要ではありません。 重要なのは、

Spice ネットリストに表示される接続の順番です。これらは、.SUBCKTのヘ
ッダー内の順番 （例えば、Non-Inverting Input (IN+)、 Inverting Input 

(IN-)、Positive Power Supply (V+)、Negative Power Supply (V-) 、そ
して Output (OUT)）と一致する必要があります。 

 

ネットリストヘッダーは、各ピンの機能について記述されています。それらを適切

な回路図ピンにリンクさせる為にこの情報を使用します。例えば: 
Modified pin mapping Original pin mapping 

1(1)は、+ input (Non-Inverting Input)ですので、回路図ピン 3(IN+)にリンクさせます。 

また 5(5)は、Output ですので、回路図ピン 6(OUT)にリンクさせます。 

10. ピンマッピングを修正したら、OKをクリックしてすべてのダイアログを閉じます。 

シミュレーションを行う為に、Filter回路図の設定を続けます。 
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シミュレーション用の抵抗の設定 
次に 2つの抵抗を配置します。 

1. Librariesパネルで、Miscellaneous Devices.IntLib ライブラリがアクティブになっていることを確認します。 

2. ライブラリ名の下のフィルタの項目に res1 と入力しフィルタを設定します。 

3. コンポーネントリストの RES1を選択し、Placeボタンをクリックします。カーソル上に抵抗のシンボルが表示されます。 

4. TABキーを押して、抵抗の属性を編集します。ダイアログの Properties内で、最初のコンポーネント識別子の値を
Designatorフィールドに R1と入力して設定します。 

5. 抵抗のパラメータの項目を設定します。設定は、回路図上に表示され、このチュートリアルの後半で回路シミュレーションを実行する時に使用し

ます。Valueパラメータは、一般的なコンポーネント情報に使用されますが、ディスクリートコンポーネントは、シミュレー
ションを行う時にそれを使用します。  

もし、コンポーネント属性に既存パラメータとして Valueが無い場合は、パラメータリストの Addボタンをクリックし、
Parameter Propertiesダイアログを表示させます。Nameに Value、Valueに 100kと入力します。Stringが、パラメータタ
イプとして選択されていて、Valueの Visibleボックスにチェックが入っていることを確認してください。OKをクリックし
ます。 

6. ダイアログの Propertiesの項目で Commentの項目をクリックし、ドロップダウンリストから=Valueストリングを選択し、
Visibleのチェックをはずします。Altium Designerでは、Comment欄をパラメータの内容で置き換える「間接的参照」をサポ
ートしており、（パラメータの Valueと Commentの項目で）値を 2回入力する必要はありません。このデータは、2回入力
しなくても PCBと部品表に転送することができます。 

7. Modelsリストで SIMモデル（RESISTOR ）を確認します。Modelsリストでモデル名を選択し、Editをクリックして Sim 

Model – General/Resistorダイアログを表示させます。このタイプの抵抗は、モデルファイルは必要とせず、Valueパラメー
タで入力した Netlist Templateの Valueを参照します。 

 

OKをクリックしてダイアログを閉じ、Component Propertiesダイアログに戻ります。OKをクリックします。 

8. 抵抗を配置する位置を決めて（図 1の回路図参照）、左クリックまたは ENTERを押し、部品を配置します。 

9. 次に R2の抵抗を配置します。そのまま続けて配置すると、デジグネータは自動でインクリメントされます。 

10. 抵抗を配置した後に、右クリックまたは ESCを押して部品配置モードを解除します。  
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シミュレーション用のコンデンサの設定 
次に 2つのコンデンサを検索し、配置します。 

1.コンデンサの部品は、Libraries パネルで既に選択されている Miscellaneous Devices.IntLib ライブラリにあります。
Librariesパネル内のコンポーネントのフィルタ欄に capと入力します。コンポーネントリスト内の CAPをクリックし、
Placeボタンをクリックします。  

2. TABキーを押して、コンデンサの属性を編集します。Component Propertiesダイアログの Propertiesの Designator欄を C1

と設定します。 

3. Valueパラメータの Valueの項目を 112pF に変更します。Stringが、パラメータタイプとして選択されていて、Valueの
Visibleボックスにチェックが入っていることを確認してください。 

4. ダイアログの Propertiesの項目で Commentの
項目をクリックし、ドロップダウンリストか
ら=Valueストリングを選択し、Visibleのチェ
ックをはずします。  

5. 統合ライブラリから Modelsリストに追加され
ている SIMモデル（CAP）を確認します。
Modelsリストでモデル名を選択し、Editをク
リックして Sim Model – General/Capacitorダイ
アログを表示させます。このコンデンサは、
モデルファイルを必要とせず、Valueパラメー
タからの Value を参照します。  

6. OK をクリックして、Component Propertiess に戻り

ます。OK をクリックすると配置モードに戻り
ます。 

7. 抵抗の配置と同じ方法で、2つのコンデンサを
配置する位置を決めて配置します。 C2は
56pFに Valueを変更し、スペースキーを押し
てシンボルを回転し、配置します。 

8. 右クリックか ESCを押して、配置モードを抜けます。 

電源の追加 
シミュレーションを行う時に必要である、デザインに供給する電

源を追加します。 

1. 最初に VDD電源を配置します。Librariesパネルで
VSRCコンポーネントを検索し、Available Libraries

リストに Simulation Sources.IntLib ライ
ブラリを追加します。他のシミュレーションライ
ブラリが、Altium Designerをインストールした場
所の Library\ Simulation フォルダに保存さ
れていることに注意してください。 

電源を配置する際に、TABキーを押して属性を編
集します。  

2. Component Propertiesダイアログの Modelsリスト
で SIMモデル（VSRC）をクリックし、Editをク
リックします。Sim Model – Voltage Source/DC 

Sourceダイアログで、Model Kindが Voltage 

Sourceに、Model Sub-Kindが DC Sourceに設定さ
れていることを確認してください。 

3. Parametersタブをクリックし、必要な電圧値を設
定します。Valueの項目に 5V と入力し、Component Parameterオプションをチェックします。チェックを入れると、自
動で Component Propertiesダイアログのパラメータに‘Value’が作成されます。他の項目は、0に設定しておいてください。  

OKをクリックし、すべてのダイアログを閉じます。回路図上でクリックし、この電源を配置します。右クリックか ESCを押して、
配置モードを抜けます。 
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4. 次にモデルファイルパラメータの Valueを-5V に設定して VSS

の電源を配置します。 

5. 最後に Simulation Sources.IntLib からサイン波
（Sinusoidal Voltage Source：VSIN）を追加します。 配置する前
に TABキーを押して、属性を編集します。この例では、1KHzか
ら 50KHzに周波数を変更します。 Component Properties ダイア
ログで、Modelsリストの SIMモデル（VSIN）をクリックし、
Editをクリックします。  

Sim Model – Voltage Source / Sinusoidal ダイアログで、Model 

Kindが Voltage Sourceに、Model Sub-Kindが Sinusoidalに設定さ
れていることを確認してください。 

6. Parametersタブをクリックし、必要な電圧値を設定します。Sim 

Model – Voltage Source / Sinusoidalダイアログ（右図）を参照して、
パラメータ値を入力してください。Netlist Templateは、この情報を
使用して評価され Netlist Previewに表示されます。 

OKをクリックしてすべてのダイログを閉じ、クリックして回路図に
この電源を配置します。右クリックか ESCを押して、配置モードを
抜けます。 

7. 回路図を保存します[ショートカット Ctrl + S]。 

 

 

 

 

 

 

 

パワーポートの追加 
図 1を参照して、Filter回路図にパワーポートを追加します。 

メニューバーからパ
ワーポートを配置す
るには、 View » 
Toolbars » Utilities を
選択して、必要なパ
ワーポートのボタン
をクリックしてくだ
さい

1. Place  »  Power Port を選択します。TABを押して、Power Portダイアログで属性を設定します。   

2. コンポーネントのピンに付けられたポートについては、対応するネット名（例えば、VSS）を入力し、
Styleを Barに設定します。OKをクリックし、左クリックか ENTERを押して、パワーポートを配置し
ます。配置中にポートを回転するには、スペースバーを使用します。 

3. パワーポートの配置を続けます。電源(VIN、VDDや VSS)にパワーポートを追加する際に、Styleを Power 

Groundに、Netを GND に設定します。OUTポートは、Netを OUTに、Styleを Circleに設定します。 

4. パワーポートを配置し終えたら、右クリックか ESCを押して配置モードを解除します。  
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回路の配線 
配線は、回路の様々なコンポーネント間の接続を作成する作業です。回路図の配線を行うには、図 1を参照してください。 

1. ワイヤ配置モードにするには、Place » Wire [ショートカット P, W]を選択するか、Wiring Toolsツールバーから Wireツールを
クリックします。  

回路図の配線に関する詳細は、チュートリアルTU0117 PCB設計入門 を参照してください。 

2. ワイヤ配置モードを解除するには、右クリックするか ESCを押します。  

ネットとネットラベル 
シミュレーションを実行する為の最後の操作は、表示したい信号を容易に確認できるように回路上の適切な場所にネットラベルを配置することです。

チュートリアルの回路で注目する信号は、INと OUTネットです。OUTネット名が OUTパワーポートから読み込まれている一
方、INネットは、ネットラベルで認識されます。図 1のように必要なネット上にネットラベルを配置するには: 

1. Place » Net Label [ショートカット P, N]を選択し、TABを押してネットラベル名を入力します。クリックしてネットラベルを配置し

ます。  

ネットラベルの配置に関する詳細は、チュートリアルTU0117 PCB設計入門 を参照してください。 

2. 右クリックか、ESCを押すと、ネットラベルの配置モードを抜けます。 

3. File » Save [ショートカット F, S]を選択してボードを保存してください。Projectsパネルでプロジェクト名を選択して右ク
リックし、Save Projectを選択して同様にプロジェクトを保存します。 

プロジェクトのコンパイル 
プロジェクトのコンパイルは、デザインドキュメントの描画や電気的なルールエラーを確認します。Options for Project ダイアログ（Project » 

Project Options）の Error Checkingや Connection Matrixタブで既に設定されているデフォルトのルールを使用します。 

1. Filterプロジェクトをコンパイルするには、Project » Compile PCB Projectを選択します。 

2. プロジェクトがコンパイルされると、警告やエラーが Messagesパネルに表示されます。エラーがある場合は、回路を見直し、す

べての配線や接続が正しいか確認してください。 

解析の設定 
Altium Designerでは、回路図から直接シミュレーションを実行することが可能です。チュートリアルの次の項目では、Filter回
路で作成された出力波形をシミュレートします。 

シミュレーションは、Simulateメニューコマンドを使用するか、Mixed Simツールバー（View » Toolbars » Mixed 

Simを選択して表示される）の適切なボタンをクリックして設定し実行します。 

1. 回路図エディタで Filter.SchDoc を開いて、Design » Simulate » Mix Sim を選択するか、または Mixed Simツールバーの
Setupアイコン をクリックし Analyses Setupダイアログの General Setupページを表示させます。回路図で警告やエラー
がある場合、Messagesパネルに表示されます。Analyses Setupダイアログを閉じ、問題点を修正します。 そして、再度、
Setupツールを選択する前に Messages

パネルを閉じます。 

すべてのシミュレーションのオプションは、ここで

設定します。 シミュレーションの範囲（ネットリ

ストを出力するシート）やシミュレーションが完

了する時に自動で表示される信号（Active 

Signals）、シミュレーションで実行したい解析

形式を含みます。これらのオプションは、
プロジェクトファイル（保存した時）
に保存され、シミュレーションが実行
される時に使用される SPICEネットリ
スト(*.nsx)の作成に使用されます。 

2. 最初に計測したい回路のノードを設定します。

Collect Data Forの項目で、リストから
Node Voltage, Supply Current, Device Current and Power を選択します。このオプションでは、シミュレーションを実行中に計算したいデー

タの形式を定義します。 すなわち、各ノードでの電圧、各電源の電流と各デバイス電流・電力のデータが保存されます。SimView Setupを
Show Active Signalsに設定します。 
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3. Available Signalsの項目で、INと OUTの信号名をダブルクリックします。各信号をダブルクリックすると、信号名が Active 

Signalsの項目に移動します。また、信号リスト上でクリックしマウスをドラッグするか、信号をクリックしている間 SHIFT

と CTRLキーを使用して、Available Signalsリストから複数の信号を選択することができます。選択後、> ボタンを使用して
Active Signalsリストに信号を移動します。Active Signalsのシミュレーション結果は、シミュレーションが実行された時、
自動で波形解析画面に表示されます。  

詳細なヘルプを表示さ
せるには、各解析設定
ページで F1を押しま
す。 

 

4. （Analyses/Optionsの項目にリスト表示された）各解析形式は、Analyses Setupダイアログの各ページで設定されます。各

解析の設定ページをアクティブにするには、解析名をクリックしてください。  

過渡／フーリエ解析の設定 
過渡／フーリエ解析は、ユーザが指定した時間間隔で過渡出力変数（電圧, 電流または電力）を計算し、オシロスコープに表示
されるような出力を作成します。  

動作点解析は、Use Initial Conditionsオプションが有効で無い限り、回路の DCバイアスを定義する為に 過渡解析より先に自動
で実行されます。もし、このオプションが有効ならば、DC バイアスは回路に定義した初期状態から計算されます。初期状態は、
回路図内の各適切なコンポーネントに、または、回路に .IC デバイスを配置して定義することができます。 

50KHz の入力ソースを 6周期表示するには、波形画面で表示が 60uになるように設定します。 

1. Analyses Setupダイアログ内の Transient/Fourierオプションが有効になっている（チェックが入っている）ことを確認して
ください。もし、Transient/Fourier Analysis Setupページが自動で表示されない場合、Analyses/Optionsリスト内の
Transient/Fourier Analysisをクリックしてください。 

 

2. Use Transient Defaultsオプションが無効になっていることを確認してください。 これで過渡解析パラメータを変更することができ

ます。 

3. シミュレーション画面を 60uに指定するには、Transient Stop Timeを 60uに設定します。 

4. Transient Step Timeの項目を 100n に設定します。 これは、シミュレーションが 100nsの地点ごとに計算されることを表し
ます。 

5. シミュレーション中の実際のタイムステップは、収束と必要な精度を満たす為に自動で変更されます。Maximum Stepの項目は、タイムステ
ップサイズの変化を制限しますので、Transient Max Step Timeを 200nに設定します。 
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AC小信号解析の設定 
AC解析は、周波数関数として小信号の AC出力変数を計算し、回路の周波数応答を示す出力を作成します。AC小信号解析で
要求される出力は、通常、伝達関数（例えば、電圧利得）です。 

回路図には、SIMモデルで AC Magnitudeパラメータの
値が設定された AC ソースが少なくとも 1 つ必要です。
AC Magnitudeの値、周波数と振幅についてはサイン波
ソース（VSIN）のパラメータで既に設定しています。
詳細については、電源ソースの設定 を参照してくださ
い。  

1. Analyses Setupダイアログで、AC Small Signal 

Analysis オプションが有効になっていることを確認し
てください。 

2. 上図のようにパラメータ値を入力します。 

3. この解析が実行されると、回路の DCバイアスを決
定する為に動作点解析が先に実行されます。その
後、信号ソースは振幅が固定された正弦波ジェネ
レータに置き換えられ、指定した周波数範囲内で、Test Pointsと Sweep Typeの値を元に解析されます。 

シミュレーションの実行 
これで設定を有効にした解析を実行する準備ができました。  

今後は、毎回 Analyses Setupダイアログで入力をせずに、Mixed Simツールバーの Run Mixed Signal Simulationボタン をクリ
ックするだけでシミュレーションを実行できることに注意してください。 

1. シミュレーションを実行するには、Analyses Setupダイアログの下部にある OKボタンをクリックします。 

SPICEネットリストの生成、または実際のシミュレーション過程中に作成された警告やエラーは、Messagesパネルに表示
されます。次に進む前にエラーを修正してください。 

2. 回路にエラーが無ければ SPICEネットリスト（*.nsx）が作成されシミュレータに渡されます。ネットリストは、シミュレーション

が実行される度に再生成されることに注意してください。  

3. シミュレーションが開始され、シミュレーションデータファイル（*.sdf）が開きます。各解析の結果は、SimDataエディ
タの波形解析画面で個別のチャートとして表示されます。 動作点解析は、回路の DCバイアスを定義する為に最初に実行
されます。 Waveform Analysis window:SimData Editor Circuit simulation:SimData Editor 

4. シミュレーションが終了すると、以下の図のような出力を確認できるはずです。 

 

AC小信号解析波形 
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動作点解析 過渡解析波形 

 

過渡解析波形 

波形アナライザとSim Dataパネルの使用方法の詳細については、TU0113 シグナルインティグリティ解析の実行 の内の 

Using the Waveform Analysis Window を参照してください。 波形表示とパネルの操作は両方のツールで同じ画面を使用します。 

ボードプロットの作成 
ボードプロットは、周波数の対数関数として 2つの曲線（利得と位相の対数）で構成されています。Y軸はデシベル（dB）の
利得と、位相をリニアにプロットし、X軸は Logスケールでいくつかの周期を持つチャートが作成されます。各周期は、周波
数の 10の因数を表します。このボードプロットは、Edit Waveformダイアログで利用できる Waveform機能を使用して作成する
ことができます。  

1. 波形解析画面の AC Analysisタブに、dB(in), dB(out), 

PHASE(in),PHASE(out)を表示します。  

2. 波形解析画面で、ネット inをクリックします。 選択したネットを右
クリックし、Edit Wave（または、Wave  »  Edit Wave ）を選択します。Edit 

Waveformダイアログが表示されます。選択した波形の形式が Expressionの
項目に表示されます。 

3. Complex Functionsリスト（例えば、Magnitude (dB)）から機能を選択し
ます。プロット上で dB(net_name)の波形（例えば、dB(in)）を見るに
は、Createをクリックします。 

4. dB(out)を作成するには、プロット上で右クリックし Add Wave to Plotを
選択します。Edit Waveformダイアログと同じ方法で設定できる Add Wave 

to Plotダイアログが表示されます。 

5. 2番目のプロットに PHASE(in)と PHASE(out)を作成するには、4.の操作
を繰り返してください（Add Wave to Plotダイアログの Complex Functions

の項目は、Phase (Deg)を選択します）。 
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6. これらの波形は必要に応じ、Edit Waveformダイアログの
Add to new Y axisを選択することで、異なる Y軸を追加表
示させることができます。追加した Y軸を削除する場合、
この軸にプロットされたすべての波形と波形に付けられた
計測カーソルも削除されますので、注意してください。
Undo機能はありません。新たに Y軸を追加した場合、右側
に表示されます。 

計測カーソルの使用 
計測カーソルを使用して、3dBの位置を指定してみます。 

1. DB(out)のネット名をクリックして、波形解析画面の波形を選択します。  

2. 右クリックし、Cursor A（または、Wave  »  Cursor Aを選択します）を選択します。マーカーをドラッグして、カーソル A

をローパスの部分に移動します。  

3. 右クリックし、Cursor B（または、Wave  »  Cursor Bを選択します）を選択します。Sim Dataパネルの Measurementの項目
で B-A = -3と表示される位置になるようにカーソル Bを移動します。  

     

4. Sim Dataパネルの Measurement Cursorsの項目のカーソル Bの X値を確認してください。 3dB point  = 20kHzであることが
分かります。 

 

5. カーソルをクリアするには、カーソルマーカーを選択し、右クリックして Cursor Offを選択します。 
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パラメータスイープ解析の実行 
いくつか解析を設定し、実行しましたが、次に周波数応答でいくつかのコンデンサ／抵抗の値を変更した結果を見る為にパラメータスイープを設定し

てみます。  

パラメータスイープ解析は、定義した指定した範囲でデバイスの値をスイープさせます。パラメータスイープ解析を実行するには、AC, DCま
たは過渡解析のどれかを有効にする必要があります。 有効にした解析は、パラメータスイープして複数回シミュレータが実行されます。 

この解析は、基準のコンポーネントの値とモデルパラメータを変更することができますが、サブサーキットデータは、解析中変更できません。 

1. Filter.SchDocタブをクリックして、デザイン画面で回路図を利用できるようにします。Design  »  Simulate  »  Mixed 

Sim を選択します。Analyses Setupダイアログの General Setupページの SIMView Setupで Show Active Signals が選択されて
いることを確認してください。 

2. Analyses Setupダイアログの Analyses/Optionsの項目で Parameter Sweepをクリックして、この解析形式を有効（Enabled

にチェックを入れます）にします。 

3. Primary Sweep Variableの項目でスイープさせる為のパラメータを入力します。この例では、プライマリ スイープパラメー
タをドロップダウンリストから選択して C2[capacitance]にします。  

4. Primary Start Valueを 20p に、Primary Stop Valueを-20p に設定して、スイープの値の範囲を定義します。Primary Step 

Valueを-10p に設定して、増加ステップを定義します。  

5. Primary Sweep Typeオプションを Relative Valuesに設定します。Primary Start Value, Primary Stop Value, Primary Step Value

の項目で入力した値は、パラメータの既存またはデフォルトの値に追加されます。  

6. Enable Secondaryをクリックして、Secondary Sweep Valuesを追加します。セカンダリ パラメータを定義した場合、プライ
マリ パラメータは、セカンダリ パラメータの各値でスイープされます。  

Secondary Start Valueを-80p に、Secondary Stop Value を 80p にして C1[capacitance]のセカンダリ スイープを設定し
ます。Primary Step Valueを 80p に設定し、増加ステップを定義します。Secondary Sweep Typeを Relative Valuesに設定し
ます。 

 

7. OKボタンをクリックして、シミュレーションを実行します。各プライマリ スイープは、波形解析画面の AC Analysisと
Transient Analysisタブ内の新しいプロットに<net_name_p<sweep_number>の表記（例えば、out_p01）で波形として
表示されます。  

詳細情報を表示するには（例えば、out_p01 をクリックすると、プロットの下にスイープ情報が表示されます）、スイー
プ パラメータ名をクリックしてください。  

 
以下の図で、このパラメータ スイープによってカットオフ周波数の周りの周波数応答を大きく変化させることが判ります。  
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AC Analysisタブでのパラメータスイープ結果 

 

Transient Analysisタブでのパラメータスイープ結果 

アドバンスオプションの使用 
Analyses Setupダイアログの Advanced Optionsのページは、エラーの許容度や繰り返し制限のようなシミュレーション計算を
達成する為に設定できる SPICE内部のオプションのリストになっています。 

 
SPICEオプションの値を変更するには（例えば、ITL1の繰り返しの値）: 

1. 変数（例えば、ITL1）を選択します。Valueの項目に新しい値を入力するか、表示される矢印スクロールをクリックして値
を選択します。  

2. Enterを押すか、他の項目をクリックすると、デフォルト（Def）オプションが無効になります。 

また、このページから異なる積分方法を選択することができます。  例えば、回路デザインに予期しない高周波の発振がある場合、標準的な積分法

の Trapezoidal（台形法）から Gear（ギヤ法）へ変更することができます。台形法は、比較的早く正確ですが、ある条件下で振動する傾向がありま

す。理論上、高次ギヤ法の方が、結果はより正確ですがシミュレーション時間が長くなる欠点があります。 
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シミュレーション用のSPICEネットリストの使用 

回路図からネットリ
スト(.nsx) を作成する
には、回路図がアク
ティブドキュメント
であることを確認し
てください。 Design 

» Netlist For Project » 

XSpiceを選択する
か、または Mixed Sim

ツールバーの
Generate XSpice 

Netlistアイコン を
クリックしてくださ
い。 

他の回路図キャプチャツールと組み合わせて Altium Designer シミュレータが使用できるように、SPICE ネットリストから直接、
シミュレーションを実行することができます。これを行うには: 

1. プロジェクトファイル(.PrjPcb)にネットリストを保存します。これでシミュレーションセッション中の設定情報

を保存することができます。設定情報は、回路図を含むプロジェクトと同じ方法でプロジェクトファイルに保存されます。プ
ロジェクトファイルは、P-CADから最初にシミュレーションを実行する時に自動で追加されることに
注意してください。もし、ネットリストがフリードキュメントとして開いた場合、設定情報は、Altium 

Designerに保存されません。  

2. Altium Designerシミュレーションエンジンは、設定情報と同様にコンポーネント情報、デザイン接続、
モデルデータを含んだネットリストが必要です。もし、ネットリストにシミュレーション設定情報が無
い場合、Simulate  »  Setupを選択すると新しいネットリストが<original filename>_tmp.nsx と
言う名称で作成されます。 このファイルは、元の.nsxファイルからのネットリスト情報とプロジェク
トファイルからの設定情報を含みます。 

もし、ネットリスト中にシミュレーション情報がある場合、シミュレーションはネットリストを変更しないで直接、実行されます。

これは、ネットリストで直接、設定を変更したいユーザには役立ちます。もし、ネットリストに設定情報が既に含ま
れている場合、Analyses Setupダイアログを使用して、設定情報を追加または設定できないことに注意
してください。 

もし、ネットリストにシミュレーション設定情報が無く、プロジェクトに回路図ドキュメントがある場合、ネットリストは、回路図ドキュメントとプロジェク

トの設定情報から再生成されます。これは、ネットリストから設定情報を削除してシミュレーションを行おうとした場合にのみ発生します。 

3. 一度、設定情報が無いネットリストをプロジェクトに追加すれば、Simulate ＂ Setupを選択して解析を設定することができ
ます。  

4. シミュレーションを実行するには、メニューから Simulate “ Runを選択します。シミュレーション波形は、.sdfドキュメ
ントに表示されます。 

5. 次回シミュレーションを実行する時に上書きされないように、ネットリストファイルの名称を変更してください。 

シミュレーションの詳細については、TR0113 シミュレーションモデルと解析のリファレンスまたは TR0117 デジタル
SimCodeリファレンスを参照してください。 
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更新履歴 

Date Version No. Revision 

9-Dec-2003 1.0 New product release 

17-Feb-2005 1.1 Updated for SP2 including Libraries Search queries. 

30-Jun-2005 1.2 Updated for Altium Designer SP4. 

12-Dec-2005 1.3 Path references updated for Altium Designer 6 

23-Jan-2006 1.4 Updated reference to PSpice model support 

18-Mar-2008 1.5 Updated Page Size to A4. 

20-Apr-2008 1.6 Updated path references. 
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