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このチュートリアルでは、シグナルインティグリティ解析の実行について説明しま
す。 デザインルールやシグナルインティグリティ・モデルなどのデザインパラメータ
の設定、回路図、PCBエディタからのシグナルインティグリティの実行、ネットスク
リーニング解析で使用されるテスト項目の設定、選択されたネットのより詳細な解析
の実行、信号線の終端、プリファレンスの設定や波形分析での操作を含みます。 

 

 
Altium Designerでは、回路図または PCBエディタから、PCBのシグナルインティグリティ解析を実行し、あらかじめ定めら
れたテストに対するネットスクリーニング結果を評価し、選択されたネットの反射やクロストーク解析を実行し、Waveform 
Analysisウィンドウで波形を表示、操作することができます 

シグナルインテグリティの概要 
Altium Designerでは、基板設計完了後だけでなく完了前にもシグナルインティグリティ解析を実行できます。 Altium Designer
のシグナルインティグリティ解析では、シミュレーションの入力として高度な伝送路計算と I/Oバッファマクロモデル情報
（IBIS）を使用します。 高速信号の反射による影響、およびクロストークのシミュレーションの時は、業界標準のアルゴリズ
ムに基づいた正確なシミュレーションを行ないます。  

基板の配線を完了する前に、回路図からの情報を元にあらかじめインピーダンスおよび反射シミュレーションが可能です。 こ
れによって基板レイアウトを始める前に、ネットインピーダンスのミスマッチなどの潜在的なシグナルインティグリティの問
題を確認することができます。 

配線が完了（あるいは、部分的に配線）した基板では、デザインの特性を確認する為、実際の基板と同じようにインピーダン
ス、信号反射やクロストーク解析がすべて実行できます。 シグナルインティグリティスクリーニングは、Altium Designerデザ
インルールシステムの中に構築され、通常のボード DRC（デザインルールチェック）プロセスの一部分として、シグナルイン
ティグリティ違反を確認することができます。 シグナルインティグリティに問題が発見された時、Altium Designerでは、さま
ざまな終端オプションの効果を表示して、デザインを修正する前に最良の解決方法を発見することができます。  

回路図のみのプロジェクトからのシグナルインティグリティ解析の実行 
プロジェクトに PCBが無い時でも、回路図のみのデザインでシグナルインティグリティ解析を実行することができます。 解
析は、Free Documentとして開かれたドキュメントでは実行できないので、回路図は、プロジェクトの一部分である必要があ
ります。 クロストーク解析は、配線済みネットが必要ですので、回路図のみのプロジェクトでは利用できません。 

回路図のみの方法で実行する場合、デフォルトのトラックの平均長さやインピーダンスは、SI Setup Optionsを使用して定義
することができます。 シグナルインティグリティ・アナライザは、回路図から PCBデザインルールで使用するスティミュラ
スと供給ネットを読み込みます。 これらのルールは、PCBレイアウトディレクティブまたはパラメータセットディレクティブ
を回路図で配置することで、ネットにルールを追加することができます。 

回路図エディタから回路図を開いて、メニューから Tools » Signal Integrityを選択します。 最初に必要なシグナルインティ
グリティ・モデルを設定します。 そして、最初の結果が表示される Signal Integrityパネルが表示され、詳細な解析を実行でき
ます。 

PCBプロジェクトからのシグナルインティグリティ解析の実行 
PCBドキュメントからシグナルインティグリティ解析を実行する時、その PCBドキュメントは関連する回路図を含むプロジ
ェクトの一部であることが必要です。 プロジェクト内の回路図からシグナルインティグリティを実行でき、同じプロジェクト
の PCBからシグナルインティグリティを実行しても同じ効果であることに注意してください。 この時、反射およびクロスト
ーク解析の両方が実行可能になっています。 

PCBエディタのメニューから Tools » Signal Integrityを選択すると、先に記述した回路図のみの方法と同じ過程で実行され
ます。 

PCBで回路図部品を関連付けることができますが、配置された部品はコンポーネントリンクでリンクされている必要がありま
す。 これは、Project » Component Linksを選択して確認することができます。 未配線のネットは、ピン間のマンハッタン
長を使用して、解析目的のトラック長を推測することに注意してください。  
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シグナルインテグリティを実行する前に 
デザインのシグナルインティグリティ解析を正しく実行し、また正確な結果を得るには、下記の項目を解析開始前に行なうこ
とが必要です。 

• ネットをシミュレーションする場合、意味のあるシミュレーション結果を得る為の重要なことは、そのネットに接続された
出力ピンが少なくとも１個は集積回路（IC）であることが必要です。 この出力ピンは、ネットに信号を供給してシミュレ
ーション結果に反映されます。 例えば、抵抗、コンデンサ、インダクタは、ドライブソースが無いパッシブ部品である為、
ネットに信号波形を供給できずシミュレーションが実行できません。  

• 各部品のシグナルインティグリティ・モデルタイプは、正確である必要があります。 これは、回路図ドキュメントに配置
された部品に関連したシグナルインティグリティ・モデルを編集する際に、Model Assignments ダイアログまたはSignal 
Integrity ModelダイアログのTypeの項目に正しいモデルタイプをマニュアルで設定します。 このエントリが定義されてい
ない場合、Model Assignmentsダイアログはその特性に基づいた部品のタイプを推測します。 より詳細な説明は、 Model 
AssignmentsダイアログでのSIモデルの追加の項目をご参照ください。 

• サプライネットに関するデザインルールの設定が必要です。 一般的には、電源ネットとGNDネットの最低 2つのルールが
必要です。 これらのルールの範囲はネットまたはネットクラスで定義します。 サプライネットは、シグナルインティグリ
ティで解析することができません。 より詳細な説明は、回路図でのシグナルインティグリティのデザインルール 、または
PCBでのシグナルインティグリティのデザインルールの項目をご参照ください。 

• Signal Stimulusに関するデザインルールは、デフォルト以外のスティミュラスが必要な場合には、デザインルールの設定が
必要になります。  

• PCBのレイヤスタックが正しく設定されている必要があります。 シグナルインティグリティ・アナライザには、分割のな
い連続したパワープレーンレイヤが必要です。 パワープレーンに割り当てられたネットが解析に使用される為、分割（ス
プリット）プレーンはサポートされません。 もし、それらが無い場合は、仮定・予想したネットが使用されますので、そ
れを避けるためにも適切なネットをパワープレーンにアサインしてください。 各層のコアやプリプレグの厚さも正しく設
定する必要があります。 Design » Layer Stack Manager コマンドを使用して、PCBエディタでレイヤスタックを設定し
ます。 PCBの無い回路図のみの方法でシグナルインティグリティを実行する場合、シグナルレイヤ 2層パワープレーンレ
イヤ 2層の 4層基板の設定をデフォルトとして使用します。 もし、デフォルト以外の層構成にしたい場合は、空の PCBを
作成してレイヤスタックで設定することができ Signal IntegrityLayer Stack Managerます。 

Model Assignments ダイアログでのSIモデルの追加 
デザインにシグナルインティグリティ・モデルを追加する最も簡単な方法は、Model Assignmentsダイアログを使用すること
です  

1. メニューから Tools » Signal Integrityを選択します。 プロジェクトで
最初にシグナルインティグリティを実行する時にシグナルインティグリ
ティ・モデルが割り当てられていない部品がある場合、Errors or 
warning foundダイアログが表示されModel Assignmentsボタンを押し
て SIモデルを設定することができます。 

あるいは、Continueボタンをクリックした場合、Signal Integrityパネ
ルが表示され、Model Assignmentsボタンをク
リックして、いつでもModel Assignmentsダイ
アログでモデルの設定を行なうことができます。 
モデルの割り当てを変更するどのような修正も、
既存の解析結果は無効となり、再計算が必要と
なることに注意してください。 

もし、モデルがすべての部品に対して既に設定
されている場合、SI Setup Optionsダイアログが
表示されます。 詳しくはSI 設定オプション の項
目をご参照ください。 

2. Errors or warnings foundダイアログのModel 
Assignmentsボタンをクリックすると Signal 
Integrity Models Assignmentsダイアログが表示
されます。 

Models Assignmentsダイアログが開いた時、シ
グナルインティグリティ・モデルが定義されて
いない部品に対しては相当と思われるモデルの
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割り付けを自動で試みます。 既にモデルが定義（またモデル情報）されていたものを含むすべての部品は、Models 
Assignmentsダイアログに表示されます。 各部品は、以下のリストに記述されているような状態を割り当てられます。 

 

状態 説明 

No match Model Assignments ダイアログは、この部品に相当するモデルを見つけることができません
でした。 正確に設定するにはユーザの修正が必要です。 

Low confidence Model Assignments ダイアログは、この部品にタイプを選択しました。ただし、強い根拠は
ありません。 

Medium confidence Model Assignmentsダイアログは、この部品にタイプを選択しました。これには、合理的な根
拠があります。 

High confidence Model Assignmentsダイアログは、この部品にタイプを選択しました。 通常ほとんどの特性
に適合します。 

Model found この部品には既にモデルが割り当てられていました。 

User modified Model Assignmentsダイアログが当初割り当てていたと思われる状態から、ユーザの修正によ
ってこの状態になりました。 

Model added ユーザーが、回路図ドキュメントを修正し、新しいモデルを保存して、Model Assignmentsダ
イアログを使用した時にこの状態は使用されます。 

Model Assignments ダイアログでの部品モデルの修正 
1. モデルを修正したい部品を選択します。 

2.正しい種類を選択します。 シグナルインティグリティには 7種の部品（抵抗、コンデンサ、インダクタ、ダイオード、BJT、
コネクタ、IC）があります。 各部品の Typeは、その欄のドロップダウンか、右クリックメニューで選択することができま
す。 

3. 抵抗、コンデンサ、インダクタの場合は定数を設定してください。 可能な場合、Model Assignmentsダイアログでは、部品
のコメントフィールドとパラメータに基づいて、この欄で部品の正しい値を設定します。 もし必要ならば定数の修正を行
なってください。 複合部品（抵抗アレーなど）の場合は、欄でクリックして表示されたダイアログで修正します（詳細は、
シグナルインティグリティのモデルを部品へマニュアルで追加 を参照してください）。 

4. 部品が ICの場合、シミュレーションで使用するピンモデルの特性を決定しますので、テクノロジータイプの選択は重要で
す。 これは、欄のドロップダウンリストを選択するか、右クリックメニュー（Change Technology）の一覧から選択しま
す。 

5. 最後に、IBISモデルといったModel Assignmentsダイアログでの設定以上に詳細な指定が必要かもしれません。 これは、右
クリックメニューからAdvancedを選択して設定することができます。 この過程の詳細は、シグナルインティグリティのモ
デルを部品へマニュアルで追加 を参照してください。 

モデルの保存 
一度、部品のモデル割付の設定が完了すれば、この情報は回路図ドキュメントに保存することができます。  

1. Setup Signal Integrity ダイアログで、更新するすべての部品の Update Schematic欄にチェックを入れます。 それから、
Update Models in Schematicボタンをクリックします。  

2. 選択された各部品のすべての新しいシグナルインティグリティ・モデル（または、修正したモデル）は、回路図ドキュメン
トに追加されます。 その後、回路図ドキュメントを保存する必要があります。 

シグナルインティグリティ解析を続けている間はモデルを保存する必要はありません。 もし、モデルが保存されていなく
ても、解析はModel Assignmentsダイアログに表示されているモデル設定で行なわれます。 しかし、次にシグナルインテ
ィグリティ・ツールを実行した場合には、保存されていない情報は失われています。 
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シグナルインティグリティのモデルを部品へマニュアルで追加 
シグナルインティグリティ・モデルは、統合された部品にリンクされています。 新しい統合された部品ライブラリにシグナル
インティグリティ・モデルを組み込むこともできます。  

1. 回路図エディタに配置された部品にシグナルインティグリティ・モデルを追加するには、部品をダブルクリックして
Component Propertiesダイアログを表示させます。  

 

2. Model list 領域の Add ボタンをクリックし、Add New Modelダイアログで Signal Integrity をモデルタイプとして選びま
す。 OKをクリックします。 Signal Integrity Model ダイアログが表示されます。  

3. モデルを設定して、OKをクリックします。 

パッシブ部品の設定 
抵抗やコンデンサなどの部品を設定する場合、種類と定数を入力する
必要があります。 定数は Valueの項目に入力し、全体の部品のパラメ
ータとして設定することができます。 

抵抗アレーのような複合部品もサポートしています。 部品の種類を選
択した後、Signal Integrity Modelダイアログの Setup Part Arrayボタ
ンをクリックして設定することができます。 Part Array Editorダイア
ログでは、ピンとそれらの接続に見合う定数／モデルを設定すること
が可能です。 

ICの設定 
ICのタイプモデルを設定するには、いくつかの方法があります。  

1. Type (IC)を選択した後、テクノロジータイプを簡単に選択できます。 この部品をシミュレーションする時は、そのテクノ
ロジーの適切なピンモデルが使用されます。 

2. より高度なコントロールが要求される場合、詳細なテクノロジーやさまざまなピンモデルを割り当てることが可能です。 
これは、Signal Integrity Modelダイアログの下部にあるピンリスト中のピンのドロップダウンリストから選択して実行でき
ます。 どのような設定の変更も、元のテクノロジより優先されることに注意してください。 

IBISファイルのインポート 
別の重要なオプションは、IBISファイルをインポートする機能です。 

1. IBIS (Input/Output Buffer Information)ファイルに記述されている ICモデルの入力／出力特性を使用するには、Signal 
Integrity Modelダイアログで Import IBISボタンをクリックします。 Open IBIS Fileダイアログから IBISファイルを選択し
て Openをクリックします。 IBIS Converterダイアログが表示されます。 
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2. IBISファイルに含まれた必要な部品を選択します。 Altium Designerは、
IBISファイルを読み込み、インストールしたピンモデルのライブラリ内の
IBISファイルからピンモデルをインポートします。 もし、同じモデルが複
数、発見されれば、既存のモデルを上書きするかのメッセージが表示されま
す。 更に、IBISファイルで指定されたように、部品のすべてのピンは適切
なピンモデルに割り当てられます。 

3. 自動でモデルが割り当てられたピンの成功／不成功の結果をレポートに生成
します。 更に、上部に記述された様に、適切なピンのモデルを手動で選択し
てカスタマイズすることが可能です。 

4. OKボタンをクリックすると、IBIS情報のインポートは完了し、Signal 
Integrity Modelダイアログに戻ります。 

ピンモデルの編集 
そのピンのさまざまな電気的特性を指定して、既存のピンモデルの編集や追
加することが可能です。 これは、BJT、コネクタやダイオードのような他の
種類にも利用できることに注意してください。 

1. ピンモデルを編集するには、Signal Integrity Modelダイアログの
Add/Edit Modelボタンをクリックします（ボタンがこのタイプに対して
有効な場合）。 Pin Model Editorダイアログを表示させます。 

2. 必要な変更を行なって OKをクリックします。 

3.  新しいピンモデルの追加の場合、この新しいモデルは他の部品のピンで
も今後利用可能です。 

回路図でのシグナルインティグリティのデザインルール 
シグナルインティグリティ用のパラメータとして使用される PCBのデザインルールは、回路図においてもデザインルールを定
義することができます。 シグナルインティグリティ解析を行なう場合、電源ネットとそれらの電圧を PCBのルールで定義す
る必要があります。 回路図の各電源ネットに PCBディレクティブを追加します。 

回路図で電源ネットのデザインルールを追加するには 

1. Place » Directives » PCB Layoutを選択します。 ディレクティブがカーソルに表示され ます。 

2. TABキーを押すと、未定義のルールが追加されている Parametersダイアログが表示されます。 

3. Undefined ruleを選択し、Editボタンをクリックします。 Parameter Propertiesダイアログが表示されます。 

 

4. Edit Rule Valuesボタンをクリックすると、表示された Choose Design Rule Typeダイア
ログからルールタイプを選択できます。 

5. ダイアログをスクロールダウンさせ Signal Integrityルールの項目から Supply Netsを選択
します。 OKをクリックします。 Edit PCB Rule (From Schematic)ダイアログが表示されます。 

6. この電源ネットの電圧値を入力してから OKボタンをクリックします。 OKをク
リックしてダイアログを閉じます。 

7. これで適切なネットに PCBルールの設定されたディレクティブを配置すること
ができます。 ディレクティブがネットに適切に配置されればドットが表示されま
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す。 デザインが PCBに移行された後、ルールは PCBデザインルールに追加されます（PCBの Design » Rulesコマンド
で確認することができます）。 

8. 同じように GNDネット(Voltage = 0)や他の電源ネットにも PCBルールディレクティブを配置します。 

9. ディレクティブ配置モードを終了するには、右クリックします。 

回路図エディタでは、ルールの範囲（ルールの適応範囲）はパラメータが追加される場所（例えば、ワイヤまたはピン）によ
って定義されることに注意してください。 PCBエディタでは、ルールの範囲はルール自身内で定義することができます。  

シグナルスティミュラスのデザインルール 
他のデザインルール設定では、シグナルスティミュラスのデザインルールを回路図エディタで設定することができます。 この
ルールが適応されると、スティミュラスは解析されているネットの各出力ピンに投入されます。 これは、� ‘all’の範囲を使用す
るデザインルールが要求される為、このルール用のシートパラメータを作成する必要があります。 もし、このルールを設定し
ていない場合、デフォルトルールオプションの値が使用されます。 

1. 回路図エディタで Design » Document Optionsを選択し、
Document Optionsダイアログの Parametersタブをクリックしてシ
ートパラメータを追加します。 Add as Ruleボタンをクリックして
Parameter Propertiesダイアログを表示させます。 

2. Edit Rule Valuesボタンをクリックして Choose Design Rule Type
ダイアログを表示させます。 スクロールダウンさせ、Signal 
Integrityルールの項目の中にある Signal Stimulusを選択します。 
OKをクリックします。 Edit PCB Rule (From Schematic) - Signal 
Stimulus ダイアログが表示されます。 

3. スティミュラスの種類、開始レベルや時間を選択します。 OKをクリックしてダイアログを閉じます。 

PCBでのシグナルインティグリティのデザインルール 
オーバーシュート、アンダーシュート、インピーダンス、スロープなどシグナルインティグリティのパラメータは、標準の
PCBデザインルールの様に指定することができます。 PCBエディタで Design » Rules を選択し、これらのルールを設定しま
す。 回路図エディタでパラメータを使用してこれらのルールを設定することができ、それらは、PCBレイアウトへデザインを
移行した後に PCB Rules and Constraint Editorダイアログに表示されます。 

 
これらのルールには、2つの目的があります。 一つは、PCBで DRCチェックを実行した場合にボード全体を解析しルールに
違反した個所をチェックします。 二つ目は、Signal Integrityパネルを使用した時です。 これらのルールは、どのネットがど
のテストに通過できなかったかをグラフ式にパネルに表示する時に使われます。 
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SI設定オプションの設定 
Tools » Signal Integrityを選択し、すべての部品にモデルが割り当てられたとき、SI Setup Optionsダイアログは、開いてい
るプロジェクト上で実行するコマンドを最初に表示します。 

1. 必要であればトラックのインピーダンスと平均長を設定します。 これら配
線の特性は、PCBにまだネットが移行されていない、または未配線のネッ
トがある場合にのみ使用されます。 

Supply Nets と Stimulus タブは回路図のみの方法のときに表示されること
に注意してください。 

2.Analyze Design をクリックするとデフォルトの初期解析が実行され、反射、
クロストークを解析する為のネットを選択することができる Signal Integrity
パネルが表示されます。 

デザインが初めて解析される際には、4つのデフォルトの許容範囲および回
路図または PCBで設定されたシグナルインティグリティで使用するルール
がすべて有効になります。 これらの検査する内容と許容範囲の設定は、
Signal IntegrityパネルのMenuボタンをクリックして表示される Set 
Tolerancesで設定することができます。 

回路図のみの方法でのシグナルインティグリティ設定オプション 
1. プロジェクトに PCBが無い場合、Signal Integrity パネルの SI Setup オプションをいつでも変更することができます。

Menu ボタンをクリックするか、Setup Optionsを選択してください。 SI Setup Options ダイアログが表示されます。  

2. Track Setupタブではシミュレーションで使用するデフォルトの配線長を指定します。 デフォルトの配線長は、PCBが存
在し配線長が存在する場合には使用されません。例えば、Use Manhattan length（マンハッタン長）を確認することがで
きないときには PCBのトラックの代わりにこの値を使用します。 このタブの Track Impedanceの項目も同様に設定しま
す。 

3. Supply Netsと Stimulusタブをクリックすると、有効なネットおよびスティミュラスに関する情報が表示されます。 これ
らのタブでは、PCBまたは回路図でのルールの通常の設定方法以外に、他のインタフェースでもこれらの特性を定義する
ことができます。 

Signal Integrityパネルの使用 
初期設定を実行後、Signal 
Integrityパネルには解析結果の
データが表示されます。 この解
析結果や、様々なテストを通過
したネットは、パネルの左側の
リストに表示されます。   

システムで表示できるパネルは
一つだけです。 再度、Tools » 
Signal Integrityを実行しても、
表示しているパネルの内容はク
リアされ、新しい解析結果が上
書きされることに注意してくだ
さい。 これは、プロジェクトの
回路図または PCBに変更を加え
た後、または新しいプロジェク
トで解析を始める時に結果を新
たにする為に使用されます。 

スクリーニング結果の表示 
初期スクリーニング解析では、多数のネットを素早く解析し多くの情報を得ることができます。 そして、反射と（または）ク
ロストーク解析の様な、より精密な検査を行う為の評価ネットを識別します。 リストの左側に解析結果が表示されます。  

各ネットは、3つの部類（Passed; Failedまたは Not Analyzed）のうちのどれか 1つに割り当てられます。  

• Passedは、定義されたテスト内容にパスしたネットを表します。  
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• Failedは、定義されたテスト内容にパスできなかったネットです。 違反した値の欄は赤く表示されます。  

• Not Analyzedは、何らかの原因でテストできなかったネットを表します。 テストできなかった原因を表示するには、右ク
リック（またはMenuをクリック）して Show/Hide Columnsを選択し、Analysis Errors欄を有効にします。   

Failedネット 
解析に失敗する共通の原因の多くは、ネットに接続されたコネクタ、ダイオード、トランジスタがある場合や出力ピンが全く
無いあるいは複数の出力ピンがある場合です。 ネットが遮られる時（双方向ピンを含みネットに出力ピンが無い時）、各双方
向ピンは、出力ピンとして別個にシミュレーションが行われます。 これらのシミュレーションから最悪の場合の結果が表示さ
れます。 スクリーニングテストでネットを解析できない場合でも、反射やクロストークのシミュレーションを行なう際に確認
することができる可能性があることに注意してください。 

ネットは、スクリーニングと更なるシミュレーションで間違った解析結果に結びつく他のエラーを持つことが可能です。 これ
らのネットは赤くハイライトで表示されます。 更に解析されたネット（例えば、PCBでまだ配線されていないネット）は、グ
レーで表示されます。 

FailedまたはNot Analyzedネットの確認 
Failedまたは Not Analyzedネットの原因を表示するには: 

1. ネットが赤くハイライト表示されている場合は、ネットを選択してからマウス右クリックで Show Errorsを選択します。 
問題箇所を修正する為にクロスプローブさせることができるMessagesパネルに、メッセージが表示されます。  

2. 選択したネットのすべての情報を表示するには、右クリックして Detailsを選択します。 Full Details ダイアログが表示さ
れ、スクリーニング解析から計算された情報やその他の基本的な情報がすべて表示されます。  

 

3. 右クリックメニュー（またはMenuをクリック）から Cross Probeを選択すると回路図または PCBのどちらかの選択した
ネットにクロスプローブ（ジャンプ）します。 F4ショートカットキーを使用して、Signal Integrityパネルとデザイン間
の表示を交互に切り替えることもできます。 

4. どのネットが、単一のネットあるいはネットのグループに連結されているか、希望のネットを選択して表示させます。その
後、右クリックか Find Coupled Netsを選択してください。 この操作は、選択されたネットに連結されたすべてのネット
を選ぶことになります。 ネットの連結が考慮される基準は、Preferencesダイアログ（Signal IntegrityパネルのMenuボ
タンから Preferencesを選択して表示されます）で設定することができます。 

5. 過程またはレポート情報は、クリップボードにコピーし他のアプリケーションに貼り付けることができます。 要求したネ
ットを選択し、右クリックメニューから Copyを選択します。 更に、右クリックメニューから Show/Hide Columnsコマ
ンドを使用して各項目を選択し、表示させる情報をカスタマイズできます。 

6. ハイライト表示された解析結果のレポートは、Signal Integrityパネルで右クリックメニューから Display Reportを選択し
て利用することができます。 これは、テキストエディタでレポートファイル（Signal Integrity Tests Report.txt）として開
き、プロジェクトに追加されます。 

Preferencesの設定 
定義したすべての解析を適用する為のさまざまなプリファレンスを指定することができます。 これらは一般的な設定、統合方
法や正確なしきい値も含まれています。  
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プリファレンスでの変更は、すべてのプロジェクトに適用されます。 すべてのプリファレンスの設定は\Documents and 
Settings\User_name\Application Data\Altium Designerフォルダにファイル名称
SignalIntegrity.iniで保存されます。  

1. Signal IntegrityパネルのMenuボタンをクリックして Preferencesを選択す
ると Signal Integrity Preferencesダイアログが開きます。  

 

2. 関連するタブをクリックし、必要なプリファレンスを設定してから OKをク
リックします。 

3. Signal Integrity preferencesダイアログのすべての設定項目は Defaultsボタ
ンをクリックして、デフォルトの初期状態に戻すことができます。 

Generalタブ 
General タブでは、シグナルインティグリティ解析の実行に関係したエラーがデザインに存在する場合、ヒントあるいはワー
ニングを表示するなどのエラーの取り扱いについて設定します。 ヒントや警告はMessagesパネルにリスト表示されます。 
Show Warningsオプションが有効の場合、ワーニングが発生すると、Signal Integrityパネルにアクセスする際に warning 
confirmationダイアログが表示されます。 更に、波形表示の際には Signal Integrityパネルを隠しておく設定ができます。 ま
た、シグナルインティグリティ測定の際のデフォルト単位が定義でき、波形結果がWaveform Analysis画面に表示される際
に、プロットタイトルや FFTチャートを表示するかどうか設定できます。 

Configurationタブ 
Configuration タブでは、カップルネットとみなすネット間の最大距離や最小長さなどシミュレーションに関連する数々のし
きい値を設定できます。 

Integrationタブ 
Integrationタブでは、解析のために使用される数値積分の方式が設定できます。 Trapezoidal（台形法）は解析が比較的早く
正確ですが、ある条件下では積分境界が発散する傾向があります。 Gear法では解析により多くの時間を要しますが計算結果
はより安定している傾向があります。 更に、高次の Gear法を使えば高精度ですが、解析に要する時間も増えていきます。 
Trapezoidalを使用するのがデフォルトの設定です。 

Accuracyタブ 
Signal Integrity Preferencesダイアログの Accuracyタブでは、解析に関与する計算アルゴリズムが使用するさまざまなしきい
値や限度設定を行ないます。 

DC Analysisタブ 
DC Analysisタブでは、DC解析に関連したさまざまなパラメータ用のしきい値や限度設定を行ないます。 

許容範囲の設定 
デザインが初めて解析される際には、4つのデフォルトの許容範囲
および回路図または PCBで設定されたシグナルインティグリティ
で使用するルールがすべて有効になります。  

1. Signal IntegrityパネルのMenuボタンをクリックして Set 
Tolerancesを選択すると、Set Screening Analysis Tolerances
ダイアログが表示され、これらのルールを有効／無効に設定す
ることができます。 

2. デザインが解析される際に有効としたいルールタイプ右側の
Enabledチェックボックスをクリックしてチェックマークを入
れます。 

3. シグナルインティグリティで使用するルールを追加／変更するには、PCB Signal Integrity Rulesボタン（回路図のみの方
法で無い場合）をクリックし、PCB Rules and Constraints Editor ダイアログを開きます。 必要な修正が終わったらダイア
ログを閉じてから Signal Integrityパネルの OKをクリックします。 
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解析の準備 
解析を実行する前に、解析するネットを選択する必要があります。 もし必要があれば、Edit Buffersメニューを使用して、部品
の Part technologyやピンの属性の表示、変更やネットに終端を追加することができます。 

解析するネットの選択 
ネット上の解析（反射やクロストーク）を行うには、ネットが Signal Integrityパネルの右
側のリストで選択されている必要があります。  

1. パネル左側のリストで解析を行いたいネットをダブルクリックすると、ネット名はパネ
ル右側にリストされます。  

あるいは左側のリストで選択したネットを右側のリストに移動させるには矢印ボタンを
使用してください。 左側のリストで複数のネットを選択するには、Shiftまたは Ctrlキ
ーを押しながらマウスでネットをクリックします。 

2. ネットが選択された状態であれば、シミュレーション実行前に更に詳細な設定を行うこ
とが可能です。 

VictimとAggressorネットの設定 
クロストーク解析を行なう場合、ネットを Victim（観察）、Aggressor（ノイズ源）に分類する必要があります。 複数のネッ
トが選択（右側のリストに移動）された場合にのみこの機能が有効であることに注意してください。 

1. 右側のリストでネットを選択して右クリックし Set Aggressorまたは Set Victimを選択します。 ネット名左側のステータ
ス表示が更新されます。  

2. マウス右クリックメニューから Clear Statusを選択すると設定が解除されます。 

双方向ピンの方向設定 
与えられたネットに含まれる双方向ピンの Directionを設定することができます。 Directionを設定するには: 

1. 右上のリストから影響を与えたネットを選択すると、下の欄にそのネットに含まれるピンのリストが表示されます。  

2. ピンのリストから in/outステータスを変更したい双方向ピンを選択し、マウス右クリックメニューから Toggle In/Outを選
択するとステータスを変更できます。 これらの in/outの設定はプロジェクトに保存され次回使用する際も有効です。 

3. マウス右クリックのメニューから Cross Probeオプションを選択して、関連した回路図・PCBドキュメントのどちらにも
クロスプローブすることができます。 

バッファの編集 
入力と出力モデルやピン方向など、部品の Part Technologyやピン属性を表示、変更する
ことができます。 右側のリストで、選択したネットに接続されている部品を変更すること
ができます。 ピンのリストでマウス右クリックして Edit Bufferを選択すれば、部品の属
性を編集できます。  

コンポーネントのパートテクノロジーを変更しても、それはピン単体の特性の変更だけで、
部品全体の変更では無いことに注意してください。 Edit Bufferボタンを使用して行なう
すべての変更は、回路図に 含まれるシグナルインティグリティ・モデルから設定されたテ
クノロジー/ピンモデルの内容を上書きします。  

1. ダイアログやオプションは、ピンが属する部品のタイプ（例えば、resistor, IC, BJTな
ど）によって変わります。 Integrated Circuitダイアログは、IC部品用のダイアログで
す。 

2. Input Modelと Output Modelの欄は Part Technologyのタイプに依存して変化します。 
Component Part Technologyをドロップダウンから選択すれば、関連したデフォルト
のテクノロジーモデルがモデル欄に入力されます。  

3. ピンの Technologyと Directionをプルダウンから選択すれば、適切な Inputと/または
Outputモデルがそれぞれの欄に表示されます。 Technologyや Directionの変更は、解析実行時のみに有効です。 これらは
ローカルな修正で、パネルを閉じるとリセットされ保存されません。 必要な変更を行って、OKをクリックします。 

終端 
信号波形の乱れは、伝送線路における複数の反射波によるものです。 これらの反射や� ’リンギング’は PCB設計においてドラ
イバー／レシーバーのインピーダンス不整合により発生します。 通常、ドライバーが低いインピーダンス、レシーバーが高い
インピーダンスです。 
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ドライブ側での理想的な信号の質を得るには、反射を 0にする（リンギングがない）ことです。 リンギングのレベルは、終端
を使用することで、デザインが許容できるレベルに下げることができます。 

Signal Integrityパネルは、ネットの指定した位置に ’仮想的な終端’を挿入して評価できる
ターミネーションアドバイザーを装備しています。 この方法で、物理的にボードを作成し
なくても、自由にターミネーションの方法をシミュレーションすることができます。 

シミュレーションできる終端の種類は: 

• シリーズ抵抗 
• プルアップ抵抗（VCCへ） 
• プルダウン抵抗（GNDへ） 
• プルアップ・ダウン抵抗（VCCと GNDへ） 
• コンデンサ付きプルダウン（GNDへ） 
• パラレルコンデンサ（GNDへ） 

• ショットキーダイオード  

各終端の種類は、リストから有効／無効を設定することができます。 反射またはクロスト
ーク解析を実行した際に、有効となった終端の種類ごとにシミュレーション波形を出力しま
す。 シリーズ抵抗の終端を使用した場合、それは選択したネットのすべての出力ピンに配
置されます。 他の終端はネットのすべての入力ピンに配置されます。 

更に、終端の最良の結果を得るには、ネットの特性に応じた最適な定数を設定することが必要です。  

1. 終端の種類を選択する時、下部にその種類に応じた終端の図が表示されています。 この図では、終端に使用する抵抗やコ
ンデンサの最小値と最大値の定数を設定することができます。  

2. 定数の最小値と最大値は、スイープ数（終端のリストに表示されます）が 1以上の数値に設定される時に使用されます。  

3. 終端の種類についての詳細な情報は、Help ?  ボタンをクリックすれば表示されます。 Suggestオプションが有効になって
いる場合は、推奨の定数が計算され（各終端の種類の情報ポップアップに記載された公式によります）ライトグレーで表示
されています。 この値を採用するか、必要ならば Suggestオプションを無効にし、他の定数を入力することもできます。 

4. もし、スイープを設定したい場合は、Perform Sweepが有効で、解析が実行される時に必要な Sweep Stepsの数が設定
されていることを確認します。 定数の比較検証のため、スイープごとに波形が生成されることに注意してください。 

回路図に終端を配置 
一度、波形が作成され最適な終端が見つかれば、回路図シートに直接、終端を配置することができます。 それは、
Termination リストでマウス右クリックすることで可能です。 回路図への終端の配置は、現在、選択されたネットにのみ適用
されることに注意してください。 

’仮想の終端 �’  としてではなく、選択した終端回路を実際に回路図に配置したい場合: 

1. Signal Integrityパネルの Terminationの項目内でマウス右クリックし Place on 
Schematicを選択します。  

終端用に使用するライブラリコンポーネントのようなさまざまな属性の設定、部品配
置を自動あるいはマニュアルで行なうかの設定、選択したピンにのみ終端を配置
する設定、部品に使用する正確な定数などの設定項目を持った Place Termination
ダイアログが表示されます。 OK をクリックして続けます。 

3. シグナルインティグリティ・アナライザは、目的のピンを含んだソース回路図を
検索し、そしてドキュメントの空いている個所に正しい定数を持った必要な素子
（抵抗、コンデンサまたは必要なものは何でも）やパワーオブジェクトを追加し
ます。 回路図の目的のピンに終端素子を接続します。 

この後に、追加した素子をピンに正確に配線することが必要になるかもしれない
ことに注意してください。 更に、PCBに、同様に追加した素子を含める場合、
同期させ PCBで配線する必要があります。 Design » Update PCBを選択して、
同様にこれらの部品を追加する為に PCBを回路図と同期させます。 
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解析の実行 
1. 必要なネットの設定（と終端オプションの選択）が完了したら、波形を生成するために、Signal Integrity パネルの

Reflection  または Crosstalk ボタンをクリックします。 

2. 解析が開始され、シミュレーション波形ファイル( PCBDesignName.sdf )が作成されます。 このファイルは、Projectsパ
ネルの Generated\Simulation documentsフォルダに表示され、分割されたタブで開きます。 そして、Simulation Dataエデ
ィタのWaveform Analysis ウィンドウに解析結果が表示されます。 

3. 選択した各ネットについて、チャートが生成されWaveform Analysis ウィンドウ に波形が表示されます。  

 

反射 
反射解析は、一つ、または複数のネットをシミュレーションすることが可能です。 しかし、解析するネットの数に応じて解析
に要する時間が必要になるので、ネットの数は現実的な数に留めるべきです。  

シグナルインティグリティ・アナライザは、PCBからの層の構成や配線の情報およびドライバーやレシーバーの I/Oバッファ
ーモデルを使用してネットの各ノードの電圧を計算します。 2次元解析ソルバーは、自動的に伝送線路の電気的特性を計算し
ます。 DC通過ロスは無視できるぐらい十分に小さいと仮定してモデリングされています。 

選択された各ネットについては、チャートが生成され、Waveform Analysis ウィンドウ内のネット名称のタブと共に解析結果
が表示されます。 チャートには、終端オプションの波形が含まれています。 

クロストーク 
クロストークの解析では、2つ以上のネットを必要とします。 通常、ノイズ発生源のネットとそのすぐ隣の 2つまたは 3つの
ネットが解析対象となります。 

クロストークのレベル（またはEMIの範囲）は、信号線の反射の大きさに比例します。 もし、正しい終端により信号の乱れを
少なくし反射の影響も無視できるレベルまで下ることができれば、信号はロスなく終端まで伝達されクロストークもまた最小
になるでしょう。 詳細は、 終端 を参照してください。 

クロストーク解析では、すべてのネットは Crosstalk Analysis と言う名称のチャートに表示されます。  
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波形解析画面の使用 
シミュレーションデータ・エディタのWaveform Analysis ウィンドウには、個々のシミュレーション解析実行毎に追加され
る一つ、または複数のタブがあります。 各タブは複数の波形プロットを表したチャートを含み、各波形プロットは複数のシミ
ュレーションデータの波形を表示することができます。 この画面には、4つまでの測定プロットを同時に表示することができ
ます。  

ソースデータの選択 
初期のソースデータは、シグナルインティグリティの設定に含まれていたすべてのネットか
ら構成され、Sim Data パネルのWaveforms の項目にリスト表示されます。 更に、アクティ
ブチャートで使用できるソースシミュレーション波形のリストを設定することができます。  

1. メニューから Chart » Source Data を選択するか、Sim Dataパネルの Source Dataボタ
ンをクリックすると Source Data ダイアログが表示されます。 このダイアログには、ア
クティブチャートで使用できるソースシミュレーション波形がリスト表示されていま
す。  

2. Createボタンをクリックすると Create Source Waveformダイアログが開き、新たに
表示を追加したい波形の一連のデータポイントに X、Yの値を登録するか、またはカス
タムのサイン波、パルス波の設定を行うことができます。 

3. 新たな信号波形の設定を行なってから Createボタンをクリックすると、SimDataパネ
ルの波形リストに波形名称が追加されます。 

4. Source Dataダイアログでは、波形データを ASCIIテキストファイル
(WaveformName.wdf)で保存することができます。 これらの波形ファイルは 、いつで
も再び読み込んでリストに加えることができます。  

5. Createボタンで作成したユーザ設定の波形は、Editボタンをクリックして編集するこ
とができます。 詳細な情報は、 ユーザ定義波形の編集の項目を参照してください。 

波形画面での作業 

アクティブチャートとプロットの選択 
Waveform Analysis ウィンドウの下部にあるタブ名称をクリックしてチャートを選択します。 波形プロットの範囲内をクリ
ックすることにより、個々のプロットをアクティブにすることができます。 

ドキュメント オプション 
Document Options ダイアログ（Tools » Document Options または、Waveform Analysis ウィンドウで右クリックして、
Document Optionsを選択）で、Number of Plots Visible オプションが All に設定されている場合、 アクティブな波形プロッ
トは、波形名称の周りが黒の実線で縁取られて識別されます。  

Number of Plots Visibleオプションが 1，2，3または 4に設定されている場合、アクティブな波形プロットは、その表示範囲
の左側に黒い矢印で識別されます。 

波形の選択 
Waveform Analysis ウィンドウで、波形名称をクリックするとその波形が選択されます。 選択された波形は太線になり、名
称の隣にドットが表示されます。 そして、選択されていない他の波形はマスク（薄く）表示されます。 Mask Level ボタンを
クリックしてマスクのコントラストを設定します。Clear ボタン [ショートカット SHIFT + C、または ESC] は、選択とマスク
を解除します。 

更に、矢印キーやマウスホイールを使用して、波形名を上下に移動することができます。 プロットの表示波形名称の数が多く
表示しきれない場合、スクロールアローが表示され、矢印をクリックすることで全リストを見ることができます。 

Document Optionsダイアログの Highlight Similar Wavesオプションを有効にすると、同じスイープでのすべての波形をハイ
ライト表示することができます。 

波形の拡大 
波形表示の拡大したいエリアをマウスでドラ
ッグして選択するとズーム表示します。 波形
全体を再度表示するにはマウス右クリックで
Fit Documentを選択します。 
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波形の移動 
波形プロットから別のプロットへ波形を移動したい場合、移動したい波形の名称部分をクリックして、移動したいプロットの
場所までドラッグします。  

波形プロットの波形を表示 
新たな波形プロットで波形を表示したい場合: 

1. まず Number of Plots Visible(Tools » Document Options)が Allに設定されていることを確認します。 

2. 波形の名称部分をクリックし、ブランクの波形プロットかチャートの最後の波形プロットの更に下までドラッグします。 
新しい波形プロットが作成されます。 

プロットへ波形を追加 
チャートのアクティブな波形プロットに新たな波形を追加するには 

1. 波形プロットの領域内をクリックし、Waveform Analysis ウィンドウ内で新
規の波形を追加したいプロットをアクティブにします。  

2. メニューからWave » Add Wave を選択し、Add Wave to Plotダイアログを
表示させます。 

3. シミュレーション波形のリストから波形を選択します。 もし必要があれば、
functions欄に用意された演算子を Expressionに追加して数学的手法で言語式
を作成し、波形を加工して表示することもできます。 

4. Createをクリックして、新たな波形が波形プロットに追加されます。 

ユーザ定義波形の編集 
Create Source Waveformダイアログを使用して手動で作成したユーザー定義の
波形を編集することはできますが、シミュレーションの結果として生成された波
形を編集することはできません。 これらの波形を変更するには、回路図、または PCBを修正するか、シグナルインティグリ
ティ解析に戻り、設定を変更する必要があります。 

Edit Waveコマンドでは、既存の波形から新規の言語式を作成することもできます。 

1. Waveform Analysis ウィンドウで波形名をクリックし、編集したい波形が選択されていることを確認します。 

2. メニューからWave » Edit Waveを選択し、Edit Waveformダイアログを表示させます。 

3. このダイアログを使用して、選択された波形に関連する数学的手法の言語式を使用して波形を新たに作成するか、または
Waveformリストに表示されている波形リストから新しい波形を選択して波形を変更します。 

波形の保存と再読込み 
Tools » Store Waveformを選択して、WaveformName.wdf と言うファイル名で ASCIIテキストファイル形式として波形を保
存することができます。 .wdf ファイルは X Y値ペアによって表される一連のデータポイントで波形を表現しています。 一旦、
ユーザー定義した波形が保存され、再度読み込まれた場合、読み込まれたその波形は編集できない点に注意してください。 

保存された波形を再度、読み込むには、Tools » Recall Waveformを選択し、表示された Recall Stored Waveformダイアログ
で.wdfファイルを選択します。 波形名称が、アクティブチャートの Source Data欄のリストに再度、読み込まれます。  

新しいチャートの作成 
現在の.sdfファイルに追加する新しいチャートを作成することができます。 

メニューから Chart » New Chartを選択し、Create New Chart ダイアログを表示します。 

2. 追加する波形の名称とタイトルを記入し、X軸のラベルと単位を設定します。 更に、複雑
なデータをチャートに表示するかどうか指定することができます。 

3. OKをクリックすると、新しいブランクチャートが波形解析画面に表示され、このチャート
のタブがドキュメントの最後に追加されます。 
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FFTチャートの作成 
アクティブなチャートで高速フーリエ変換（FFT）を実行し、結果を新しいチャートで表示することができます。 

1. 高速フーリエ変換を実行したいチャートを波形解析画面の下部のタブでクリックして選択します。  

2. Chart » Create FFT Chartを選択します。 FFTが実行され、結果は新しいチャートに表示されます。 それは新しいタブ
(<netname>_FFT)として追加され、画面上でアクティブチャートとして作成されます。  

 

新しいプロットの作成 
Plot Wizard を使用して、既存か新しいチャートに新しいプロットを追加することができます。 

1. メニューから Plot » New Plotを選択すると、Plot Wizardの最初のページが表示されます。 追加するプロットの名称を入
力して Nextをクリックします。 

 

2. プロットに表示する項目を設定して Nextをクリックします。  

3. Addボタンをクリックして、Add Wave to Plotダイアログで追加する波形を選択し（または、言語式を追加）、Createを
クリックします。  

4. Nextをクリックして波形の追加を続けるか、Finishをクリックしてウイザードを終了させます。 新しいプロットが
Waveform Analysis ウィンドウに表示されます。 
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SimDataパネルの使用 
SimDataパネルでは、利用可能なソースデータからアクティブ波形プロットへ波形を追加し
たり、測定用カーソルを使用して選択された波形の各ポイントを測定するなど、その情報を表
示することができます。 

パネルの上部の Souce Data セクションには、シミュレーションで生成されたすべての利用可
能なソースデータ信号波形のリストが表示されています。 このリストは、Source Dataダイア
ログ (Chart » Source Data)で表示されるリストと同じ内容です。 Source Dataボタンをクリ
ックして、Source Dataダイアログを開きます。 

SimDataパネルからプロットに波形を追加 
Waveform Analysis ウィンドウで選択したプロットへ波形を追加するには、Sim Data パネル
で追加したい波形を選択してから Add Wave to Plotボタンをクリックします。 

測定カーソル 
パネルのMeasurement Cursorsの項目では、1つあるいは両方の測定カーソルを使用して測
定値を表示します。 

1. 2種類の測定カーソル(A と B)は、Waveform Analysis ウィンドウ内の選択した波形名称
の部分でマウス右クリックして利用できます。 カーソルをドラッグすることで目的の位置
まで移動できます。 

 

2. 両方のカーソルについて、カーソルが現在割り当てられている波形の名称と X軸、Y軸デ
ータの値（カーソル位置での波形の座標）が表示されています。 

3. 計算された X と Y の値は、SimDataパネルのMeasurement Cursorsの項目に表示され
ます。 

波形の測定 
ダイアログのWaveform Measurementsの項目では、波形解析画面で選択した波形の立ち上が
り、立下り時間といったさまざまな基本的な測定結果を表示します。 

結果の分析後 
解析結果を分析することで、例えば、選択したネットのリンギングを押さえるためのさまざまな終端を使用して実験すること
ができます。 更に、回路図や PCBを変更して希望の結果に到達するまで、シグナルインティグリティを繰り返す必要があり
ます。 
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更新履歴 
 

Date Version No. Revision 

9-Dec-2003 1.0 New product release 

08-Jul-05 1.1 Update for Altium Designer SP4 

12-Dec-2005 1.2 Path references updated for Altium Designer 6 

11-Mar-2008 1.3 Converted to A4. 
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