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このドキュメントでは、デザイン上の複数オブジェクトの編集を行う際のテクニック
を紹介します。 Find Similar Objectsダイアログと Inspectorパネルを組み合わせての
使用方法やパラメータマネージャとモデルマネージャについてもカバーしています。 
最後にデザインオブジェクトの検索と編集を行うためのクエリと Listパネルを紹介し
ます。 

 

 
電子設計とは、回路図上で論理的な設計を行い、その後 PCBのワークスペースで、実際のオブジェクトの集まりを表すプロセ
スです。 小規模な回路であっても、PCBワークスペースにはデザインを構成するデザインオブジェクトが数多く使用されてい
ます。 デザインプロセスでは、こうしたオブジェクトの属性を変更する必要が生じます。 それは、設計者がデザインや PCB
製造、組立てで、それぞれ要求される項目のバランスを取ろうとするためです。 

多くのオブジェクトの編集作業をサポートするために、以前のアルティウムのデザインツールには、グローバル編集と呼ばれ
る機能が用意されていました。 この機能の基本的な考えは、ひとつのオブジェクトを編集し、それを他のオブジェクトに適用
させるというアプローチでした。  

DXPプラットフォームのリリースに伴い、グローバル編集の手法が変更されました。 基本的なアプローチとして、編集するオ
ブジェクトを ”選択”し、その属性を”確認”し、”編集” を行います。 

この ”選択 – 確認 – 編集” の手順を頭に入れ、各ステップを詳しく見ていきましょう。 

複数オブジェクトの選択 
実際にオブジェクトを選択するには、いくつもの方法があります。 例えば、ウィンドウズの基本的
なショートカットであるマウスのクリックも使用可能です。 この方法は、選択するオブジェクトの
数が少ない場合や、異なる種類のオブジェクトを同時に編集する場合には理想的です。 

図 2 Find Similar Objects ダイアログに読み込まれたオブジェ
クトの属性 

複数の回路図シートに渡って、多くのオブジェクトを選択するには、Find Similar Objectsダイアロ
グを使用します。 このダイアログをオープンするには、編集したいオブジェクトのどれかひとつの
上で右クリックを行い、ポップアップメニューから Find Similar Objectsを選択します。  

サンプルを使って、実際に手順を確認して
みましょう。 ここでは回路図のパワーネ
ットの名称を VCCから 3V3に変更します。 
これは全シート上の VCCパワーポートの
ネット属性を変更することになります。 
最初に回路図上の VCCパワーポートを見
つけ、その上で右クリックを行い、Find 
Similar Objectsをポップアップメニュー
から選択します。 

図 1 右クリックで Find 
Similar Objectsを選択

図 2 は、回路図上のパワーポートで、右クリックを行った後に表示
されるポップアップメニューです。 この Find Similar Objectsコマ
ンドを実行するとダイアログが表示されます。 ダイアログには、ク
リックしたオブジェクトの属性が表示されます。 このダイログの内
容は、クリックしたオブジェクトによって異なりますので注意して
ください。 

ダイアログには、2つのカラムが確認できます。図 2 でハイライト
表示されているのは、クリックしたオブジェクトの属性で、下側に
ネット名を示す Text が VCCとなっています。 
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複複オオオオオオの編編 

Find Similar Objectsダイアログの 2番目のカラムは、その他のオ
ブジェクトと何を一致させるかを指定します。 オブジェクトの各
属性の値を Same（同じ）、Different（異なる）、Any（条件な
し）と指定することで、対象となるオブジェクトが指定できます。 

図 3では、Object Kind は Sameで、ネット名を示す Text も 
Same に設定します。 これによって、一致するオブジェクトは、
ネット名 VCCのパワーオブジェクトになります。 

図 3 どの属性を使用して一致させるか 

 

次のステップでは、検索実行の範囲（スコープ）を設定します。 
Current Document（現在編集中のドキュメント）だけか、あるい
は、Open Documents（オープンしている全ドキュメント）かを選
びます。 ここではプロジェクト全体に適用するよう、図 4に示す

通り、Open Documents に設定します。 この編集作業が
全シートに適用されるように、ドキュメントを先にオープ
ンしておく必要があります。 

最後のステップでは、オープンしているすべてのドキュメ
ントでネット名 VCCのパワーオブジェクトを検索した後、
どのようにするかを設定します。  

図 5では、この編集操作の重要な設定を示しています。 ハ
イライトされているオプションは、（すべての VCCパワー
ポートを選択するため）Select Matching と選択されたオ
ブジェクトを読込むための Run Inspectorです。  

選択された PCB オブジェクトや回路図オブジェクトのグループの位
置は、矢印キーでそれぞれに再調整できます。 これらの選択された
オブジェクトは、PCB エディタ、回路図エディタのスナップグリッ
ドに設定されている値に応じて、全体として移動します。 

複数の回路図オブジェクト、PCB オブジェクトを選択でき、それぞ
れ別個に（選んだ順番で）再配置できます。Reposition Selected 
Components コマンドを使用してください（Tools » Component 
Placement » Reposition Selected Components または、ショート
カット T、O、C）。 

Ctrl キーを押しながら矢印キーを押すと、選択されたオブジェクト
は、現在のスナップグリッド値に応じて少し移動します。 

かなり大きな値（スナップグリッドの値がファクタ 10など）で、選
択したオブジェクトを、'ひと突きする' こともできます。 CTRL と 
SHIFT キーを同時に押しながら、矢印キーを使います。 

回路図オブジェクトでは、 Document Options ダイアログ (Design » 
Document Options あるいは、ショートカット D、O)で、現在の 
Snap Grid が設定されています。 

PCB オブジェクトでは、 Board Options ダイアログ (Design » 
Board Options あるいは、ショートカット D、O)で、現在の Snap 
Grid が設定されています。 

回路図、PCBの両オブジェクトに対して、 G のショートカットで異
なるスナップグリッド値が適用されます。 View » Grids submenu 
サブメニュー、または Grids の右クリックメニューでも、新しいグ
リッド値が選べます。 

図 4 どのドキュメントにこの編集を適用するか 

 

一致するパワーポートを選択するには、OKボタンをクリ
ックします。  

Applyボタンでも一致するパワーポートがセレクトされ、

図 5 検索したオブジェクトに対して何を行うか 
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Editing Multiple Objects 

Inspectorが開きます。 ただし、この Find Similar Objectsダイアログがオープンしたままになります。 条件の設定が確実でな
い場合は、こちらを使用します。 
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オブジェクトの確認 
回路図と PCBエディタには、共に Inspector というパネルが用意されています。 
Inspector の基本的な動作は、現在、選択されているすべてのオブジェクトについて、そ
の全属性を表示することです。 選択されているオブジェクトが同じ種類のオブジェクト
であれば、例えば、 図 6 のように 10個のパワーポートの属性が表示されます。  

選択されたオブジェクトの属性がすべて同じであれば、その値が表示されます。 例では
10個のパワーポートの Orientation（角度）がすべて 90度になっています。  

各パワーポートの属性（例えば、位置 X1）が異なる値の場合は、<…> と表示されます。 
10個のオブジェクトの X1は、同じでない、すなわち別の場所にあることを示していま
す。 

図 6 の Inspector の上側に 2つのオプションがあります。 これら 2つの設定は重要で、
どこからオブジェクトを検索したのか – カレントドキュメント（current document）か、
オープンされている全ドキュメント（open documents）か、同じプロジェクトのオープ
ンされている全ドキュメント（open documents of the same project）か、を設定します。 
選択した全パワーポートをインスペクタに読み込むには、open documentsか open 
documents of the same projectに設定する必要があります。 

図 6 インスペクタに選択されたオブジ
ェクトの属性が表示された状態 

 

SCH インスペクタとは？ 

SCH インスペクタは、今、選択されているオブジェクトの属性を表示するパネルです。 選択されているオブジェクトは、1つでも複数でもかまいませ
ん。 複数のオブジェクトが選択されている場合は、選択オブジェクトに共通の属性だけが表示されます。 共通の属性が同じ値であればその値が表示さ
れ、同じでない場合は、<…>と表示されます。SCH インスペクタに値を入力し、Enter キーを押すと、選択されているすべてのオブジェクトの属性がた
だちに変更されます。 

SCH インスペクタには、たいへん便利に使える特性があります。  

第一に、これはパネルなので、常に表示しておくことができます。ダイアログをオープンするようにダブルクリックする必要はありません。 ワークスペ
ース上でオブジェクトをクリックし、選択すれば属性がすぐに表示されます。 デザインの設定を確認する場合など、これはより効果的です。 例えば、
PCB 上のいくつかのコンポーネントについて、デジグネータの文字の高さを確認したい場合などです。 SCH インスペクタが表示されていれば、単にデジ
グネータをクリックするだけで値が確認できます。次々とクリックし、値を確認していくことができます。 これはデジグネータをダブルクリックし、値
を確認し、ダイアログを閉じる、次のデジグネータをダブルクリックし…、を繰り返すよりずっと速くなります。  

第二に、SCH インスペクタは、異なるオブジェクトの共通の属性を表示し、編集ができます。  方法は後ほど、このチュートリアルで紹介します。   

SCH インスペクタの下側に、選択されているオブジェクトの数が表示されるので、予期した動作をするか、ここで常にチェックしてください。 
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Editing Multiple Objects 

オブジェクトの編集 
編集したいオブジェクトを”選択”し、インスペクタで属性を”確認”できました。次は”編集”
を行います。 

ネット名を編集するために Text をクリックすると、 … という表示ボタンが、Text フィ
ールドの終わりに表示されます。 部分的な文字列の編集を行いたい場合に、このボタン
をクリックすることができます。 ここでは、文字全体を変更しますので、セルの全体の
内容を新しいテキスト、3V3 に置き換えます。 

Text値に対して行った変更を選択した全オブジェクトに適用するには、Enter キーを押す
か、SCH インスペクタ内の別のセルをクリックします。 

編集中に気が変わった場合、Esc キーを押せば、編集は中断します。 編集のやり直し
（アンドゥ）を行うには、メニューから Edit » Undoを実行します。 複数の回路図シー
トに対して編集を適用させた場合は、各シート事にアンドゥの操作を行ってください。 

図 7 ネット名に該当する Textの編集 

図 8 は、文字を変更し、Enter キーを押した状態のSCH Inspectorパネルを示しています。
その横は、編集されたパワーポートの 1つです。 

 

この方法を使って、回路図エディタや PCB エディタで、あらゆる種類のオブジェクトの
一括編集が可能です。 

編集を実行した後は、回路図上のその他のオブジェクトが消えているか、あるいはマスクされているはずです。 マスクされて
いる場合は、編集することができません。 マスク状態を解除するには、ワークスペース右下にある Clear ボタンをクリック
（ショートカット Shift + C ）します。 

 

図 8 更新された 10個のパワーポートのうちの１つ 
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グループオブジェクトの編集 
先に行った編集は、プリミティブオブジェクトに対して行われました。 プ
リミティブオブジェクトは、回路図上で使用されている基本的なオブジェ
クトのひとつです。 コンポーネントなど、より複雑なオブジェクトはグル
ープオブジェクトと呼ばれ、これらは基本的にプリミティブなオブジェク
トの集まりです。 例えば、回路図上のコンポーネントは、ドローイングオ
ブジェクト、文字、パラメータ、ピン及び参照するモデルの集まりです。 
グループオブジェクトに属するプリミティブオブジェクトは”子”オブジェク
ト、グループオブジェクトは、それらの”親”オブジェクトと呼ばれます。 

一般的なグループオブジェクトの編集例を見ていきましょう。 デザインに、
いくつかの 470uF 16Vのコンデンサがあり、フットプリントにMCCT-Bが
使用されている場合を考えます。 現在、電圧値はコンポーネントのコメン
トの一部として指定されています。 この電圧値をコンポーネントのパラメ
ータとして定義し直し、回路図上にこのパラメータを表示させてみます。  

図 10 ind Similar Objectsの操作を実行した後の表示 。 シート上で 3つのコンデンサが
検索されました。 

これから実行する手順は次のとおりです。  

1. コンデンサを選択します。値は 470uF 16V 、フットプリントは MCCT-
B です。 

2. コメントを 470uF に変更します（16Vの文字は削除）。 

3. 新しいパラメータをこれらのコンポーネントに追加します。Voltage 
という名前で、値は 16V です。 

4. 回路図にこのパラメータが表示されるように設定を変更します。 

編集内容は複雑かもしれませんが、実際に手順に沿って操作してみましょ
う。  

Step 1. コンデンサの選択 
470uF 16V のコンデンサを選択するには、コンポーネントシンボルのいず
れかひとつの上で右クリックして、Find Similar Objects をポップアップ
メニューから選びます。  

以前の例と同じ手順で操作を行いますが、今回は、図  に示すように、同
じ Part Comment 、同じ Current Footprint をコンポーネントに設定しま
す。  

9

9

図 10

図 9 470uF 16V のコンデンサを検索 

また、デジグネータの文字列が Cで始まるコンポーネントを一致条件にできることに注意してください。 これは、コンポーネ
ントのデジグネータの値を Find Similar Objects ダイアログで変更することで実行されます。値は C* にしてください（図
）。 OK ボタンをクリックして、一致するコンデンサを選びます。 

Step 2. コメント文字の変更 
Find Similar Objects ダイアログを実行した後、
SCH Inspector パネルが開きます（Find 
Similar Objects ダイアログ内の Run 
Inspector オプションを有効にしておいてく
ださい）。 その背後には、回路図シート上で
一致するオブジェクトが選択されて表示され
ます。 Find Similar Objectダイアログで
Zoom MatchingとMask Matchingオプショ
ンが有効になっていれば、ズーム表示され、
その他の一致しないオブジェクトは、消えて
いるか、マスクされています。 

 にその結果が表示されています。 この
ページでは、3つのコンデンサが検索されて
います。  

SCH Inspector パネルの下側のステータスラ
インを確認すると、同じコンデンサが他のシ
ート上にあることが確認できます。 
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コメント文字を変更するには、文字列から 16V を単に削除するだけです。図 12

図 11 ユーザ定義のパラメータを追加する 

 をご覧ください。変更を確定させるには、
Enterキーを押します。 

 
図 12 コンデンサの値が変更されました 

Step 3. コンポーネントへ新規パラメータを追加 
次に行う変更では、これら 4つのコンポーネントに Voltage という新
しいパラメータを追加し、その値を 16V に設定します。 これを行う
には、SCH Inspector パネルの下側にある Add User Parameter機能
を使用します（図 ）。 先に値を追加し、それからパラメータ名を
入力することに注意してください。  

12

1.   1.   まず、新しいパラメータの値 16V を Add User Parameter の
欄に入力します。 

2.   2.   変更を適用するには、Enterキーを押します。 キーを押すと
Add new parameter to XX objects ダイアログが表示されます。 

3.   3.   新しいパラメータ名を入力し、OKボタンをクリックします。 

注記 : 各パラメータの横にある赤い十字（X）の上でクリックすると、
削除になります。 

これでSCH Inspectorパネルには、値が 16Vの新しい Voltage パラメ
ータがリストの下側に追加されます。図 参照してください。 こ
の方法で、必要なパラメータをいくつでも追加していくことが可能で
す。 

14 を

 

 
図 14 ユーザ定義のパラメータ 

Step 4. Voltageパラメータを表示するための設定 
最後のステップは、新しい Voltageパラメータを表示するように 4つのコンデン
サに設定します。 パラメータの表示は、コンポーネントではなく、パラメータ
自身の属性になります。 このため、この変更はコンポーネントの属性が表示さ
れている SCH Inspector からは、変更できません。 

 

図 15 親のコンポーネント属性へ戻るに
は 

パラメータの属性にアクセスするには、SCH Inspector パネルの下側にある
Parametersのリストで、ハイパーリンクが設定されているパラメータ名 
Voltage をクリックします。 これを実行すると、選択されているコンポーネント

の Voltageパラメータの属性が SCH 
Inspector パネルに読み込まれ、編集可
能になります。 これは、SCH 
Inspector パネルの上側の Object Kind 
が、� ‘Parameter’となることで確認でき
ます。 

これで回路図に Voltageパラメータを表
示させることができます。 表示するに
は、図 14に示すように Hide チェック
ボックスをオフにしてください。 

図 13 新しいパラメータの表示設定を変更 
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他の属性を編集するなどで、親オブジェクトであるコンポーネントに戻りたい場合は、 図 15 に示すようにリンクが設定され
ている Owner をクリックします。 

これでフットプリントが MCCT-B のコンデンサのコメントを 470uF に更新されました。 また、Voltage という新しいパラメ
ータが追加され、値を 16V に設定し、更にパラメータが表示されるようにしました。 
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Editing Multiple Objects 

異なる種類のオブジェクトに対する一括編集 
PCB Inspectorパネルは、複数の同じ種類のオブジェクトだけではなく、同じ属性を持った異なる種類のオブジェクトに対し
ても使用できます。  

既存配線のネット名変更 
最初の例として回路図で、あるネットから 1つのピンを削除し、それを別のネットへ追
加する変更があった場合を考えます。 PCBを更新する際、そのネットが PCB上で既に
配線が終了した場合は、違うネット名が接続されていることになります。 配線には、
トラックやビアなどその他のオブジェクトも含まれます。 

この状態を解消するのにいくつかの方法が考えられます。 一番簡単な方法として、
PCB Inspector パネルを使用します。 その手順を見てみましょう。 

1. PCBで、ネット名を変更する必要がある配線の全プリミティブを Edit » Select » 
Connected Copperコマンド（ショートカット Ctrl + H）で選択します。  

2. PCB Inspectorパネルが表示されていなければ、表示します［ショートカット
F11］。 

3. PCB Inspectorでは、選択されたオブジェクトの共通の属性だけが表示されます。 
正しく選択されていれば、これらの属性のひとつに Net があるはずです。 これを変更するには、単にドロップダウンリス
トから新しいネット名を選択し、変更を適用するために Enterキーを押すだけです。 これで配線済みの異なる全オブジェ
クトのネット属性は変更されます。 

図 16 選択したトラックとビアのネット
名変更 

図 17 選択したオブジェクトのレイヤ変更

異なるオブジェクトのレイヤ属性変更 
別の例として、あるメカニカルレイヤから別のメカニカルレイヤへ全オブジェクトを移
動する場合を考えてみます。 これを行うには： 

1. PCBエディタウィンドウの下側にある Layer タブをクリックして、カレントのメカ
ニカルレイヤをアクティブにします。 

2. Select » All on Layerコマンド［ショートカット S, Y ］で、そのレイヤの全オブジ
ェクトをセレクトします。 

3. PCB Inspectorパネルが表示されていなければ、表示します［ショートカット
F11］。 

4.Layer のリストから新しいレイヤ名を選び、Enter キーを押して変更を適用します。  
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設計オブジェクトのロック 
設計オブジェクトには、ロックをかけて回路図ドキュメントや PCB ドキュメントでの移動や編集をできなくすることができま
す。 ロックをかけるには、Locked を有効にします。 たとえば、特定オブジェクトの位置やサイズがとても重要な場合にロッ
クをかけます。 この Locked 属性は、設計オブジェクトのダイアログで有効になります。これらの Locked 属性は、SCH List 
や PCB List パネルでもまとめて設定できます。 

回路図シートやPCBドキュメント上の設計オブジェクトをロックする 
1. 回路図オブジェクトのグループをロ
ックするには、SCH List パネルを使
って、Locked オプションを切り替え
ます。図 （左）を参照してくださ
い。 PCBオブジェクトのグループに
ついても同じように操作できます。
やはり、PCB List パネルを使います。 

18

18

19

2. それぞれのオブジェクトをロックす
るには、オブジェクトをダブルクリ
ックします。属性ダイアログが表示
されるので、Locked オプションを有
効にします。図  （左）を参照して
ください。 図 18 ワイヤ属性のロックを有効にする 

Locked 属性が有効になっているオブジェクトを移動させたり、回転させたりしようとすると、ダイアログが表示され、編集
を続けるかどうか尋ねてきます（図 ）。 

図 19 ロックされた設計オブジェク
トをグラフィカルに編集しようと

Preferences ダイアログ（回路図エディタやPCB エディタで、それぞれ、Tools » 
Schematic Preferences または Tools » Preferences ）のSchematic – Graphical Editing 
ページ（図 20）、またはPCB Editor – General ページにおいて、Protect Locked Objects 
オプションが有効で、設計オプションが locked に指定されているときは、このオブジェクト
は選択したり、グラフィカルに編集したりすることはできません。 Locked オブジェクトを
ダブルクリックして、Locked 属性を無効にします。または、Preferences ダイアログの中に
あるSchematic フォルダの下側、Graphical Editing ページでProtect Locked Objects オプ
ションを無効にして、グラフィカルに編集できるようにします。 

その他のオブジェクトと一緒に、ロックされたオブジェクトを選んだ場合、Protect Locked Objectsが有効なら、ロックされ
ていないオブジェクトだけが選択でき、グループとして移動させることができるようになります。 
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図 20 回路図内でロックされたオブジェクトの保護 - Preferences ダイアログの Graphical Editing ページ 
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パラメータマネージャでの複数パラメータの編集 
ユーザが定義したデザイン属性をパラメータとしてデザインに追加することができます。 コンポーネントパラメータは、コン
ポーンネトのレートから在庫情報、PCBのコンポーネントクラスのメンバーシップまで、あらゆる情報を定義するために使用
できます。 コンポーネントのデータシートへのリンクなどにも使えます。 
パラメータは、PCBデザインの要求を定義するためにネットに追加すること
もできます。 また、ネットを PCBのネットクラスへ追加することもできま
す。ドキュメントパラメータは、シートのタイトル、設計者の名前などを定
義して使用することができます。   

パラメータは、個別に追加／編集が可能です。 また、Parameter Table 
Editorダイアログを使用して、デザイン全体やライブラリ全体に追加するこ
とができます。 エディタをオープンすると、デザイン全体からパラメータの
全情報を集め、テーブル形式で表示します。 この Parameter Table Editor を
起動するには、 Tools » Parameter Managerを実行します。 

メニューから Parameter Manager を実行すると、まず、Parameter Editor 
Options ダイアログが最初に表示されます（図 ）。 ここで、どの種類の
パラメータを Parameter Table Editor ダイアログに読み込むか決定します。 

図 21 編集したいパラメータの種類を選択。 

 
図 22 Parameter Table Editorを使って、既存のパラメータ名を変更 

21

21

22

23

図 22

コンポーネントパラメータを編集したい場合、Include Parameters Owned 
Byセクションの Parts 以外のチェックボックスは、すべてオフにします。 
ドキュメントパラメータについて作業を行う場合は、Documents チェック
ボックスだけをオンにしてください。 また、Exclude System Parameters チェックボックスは注意してください。 これはコ
ンポーネントモデルの設定や、テンプレートで設定されているドキュメントパラメータなどのシステムパラメータを除外する
オプションです。 このオプションは、パラメータ管理に関する操作に詳しくなってから使用してください。  

ここでいくつかのパラメータの編集を行ってみましょう。 次の記述とイメージは、 4 Port Serial Interface リファレンスデザ
インの例に基づいています。 Parameter Editor Options ダイアログを 図  に示すように設定してください。 

パラメータ名の変更 
下記の 図  において、� ‘Text Field1’という既存のパラメータが確認できます。 これを変更します。 � ‘Component Type’ が
より適した名称です。  

パラメータの名称を変更
するには、カラムのセル
上で右クリックを行い、
ポップアップメニューか
ら Rename を実行します。 
Renameダイアログが表
示されますので、 新しい
名称を入力し、OKボタ
ンをクリックします。 名
称が変更され、（図  に
示すように）カラム右上
に小さな青の三角形の印
が表示されます。 このア
イコンは、このセルの値
が変更されたことを示し
ています。 ここで使用さ
れるアイコンの詳細は、
カーソルをダイアログ上
に移動し、F1を押すと確
認できます。 

ま
た、

 でいくつかのコンポーネントでは、この Component Typeパラメータが無く、斜線になっている
ことが判ります。 次にその他のすべてのコンポーネントに Component Type パラメータを追加してみ
ます。 

図 23 名称が変更された
パラメータ 
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パラメータの追加 
パラメータが無いコンポーネ
ントにパラメータを追加する
には、それらのセルをエディ
タで選択します。Shift + クリ
ック、または Ctrl + クリック
してください。 その後、右ク
リックを実行し、ポップアッ
プメニューから Add を実行し
ます。 

          
図 25 選択したコンポーネントにこのパラメータを追加 - 左が追加前、右が追加後 

                   

Addを実行した後は、各セル
に緑色の+マークが表示されま
す。 これは、新しいパラメー
タが追加されたことを示して
います。  

図 25 セルを選択し、右クリック、Edit を実行（左）、新しい値を入力し（中央）、 Enter キーを押す
（右）

 
図 26 システムへの変更は、常に Engineering Change Orderダイアログを通じて適用

これで各コンポーネントに
Component Typeパラメータ
が追加され、定義ができます。 
Parameter Table Editorダイア
ログでは、標準的な編集のシ
ョートカットがサポートされ
ています。 カーソルをグリッ
ド周りの� walk’の上に移動し、
F2キーを押すと編集ができま
す。 編集後、Enterキーを押
すと、適用されます。 また、
一度に複数のセルも編集でき
ます。 複数のセルを選択し、
その上で右クリックを実行し、
ポップアップメニューから
Editを選択します。 新しい値
を入力し、Enterキーを押す

とセレクトしていたすべてのセルに編集が適用されます。 

変更したパラメータを適用するには 
現時点でパラメータの編集
は、Parameter Table Editor
上で行っていますが、まだ、
回路図シート上のコンポー
ネントに対して適用されて
いません。 コンポーネント
にこれらの変更を適用する
には、ECO （Engineering 
Change Order：変更指示）
を実行し、この ECOをデザ
インに適用する必要があり
ます。 

パラメータの編集が終了し
たら、Accept Changes 
(Create ECO) ボタンをクリ
ックします。 Parameter 
Editor Tableを閉じると、
Engineering Change Order
ダイアログが表示されます。  

Validate Changesボタンを
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クリックして変更箇所を確認し、Execute Changes ボタンをクリックし、 コンポーネントにパラメータの変更を適用します。 
変更が済めば、Engineering Change Orderダイアログを閉じます。 

複数のコンポーネントモデルの管理 
回路図シンボルは、回路図上におけるコ
ンポーネントを現しています。 ワイヤ
は、コンポーネントのピンを接続し、接
続情報を生成します。 これは回路図で
生成されたもの、あるいはデザイン内部
的な接続構造で、最終的には実際の
PCBへ展開する必要があります。  

図 27 モデル編集の領域が表示された回路図ライブラリエディタ 

元の回路図を PCBレイアウトや回路シ
ミュレーションなどの別の形式へ変換す
るには、各コンポーネントに供給されて
いるモデルの情報が必要になります。  

PCBフットプリントや Spiceシミュレ
ーション、シグナルインテグリティ解析、
3Dモデルなど、異なるモデルの種類が
サポートされています。 これらは通常、
コンポーネントライブラリとして定義し
ますが、回路図シート上でも定義可能で
す。 個別のコンポーネントにモデルを
追加するのは簡単です。 図 に示すよ
うに、ライブラリ編集ウィンドウの下側
にモデル編集の領域が用意され、そこか
ら追加ができます。 

27

 

 
ライブラリ・コンポーネントの作成とモデルのリンク方法についての詳細は、TU0103 ライブラリコンポーネントの作成 を
参照してください。 

コンポーネントモデルについてより詳しく知りたい場合は、AR0104 コンポーネント、モデル、ライブラリの概要を参照し
てください。 

複数コンポーネントに対してモデルの設定を追加／削除す
るには、ライブラリエディタのモデルマネージャを使用し
ます。  ライブラリエディタからモデルマネージャをオー
プンするには、メニューから Tools » Model Managerを
実行します。 Model Managerダイアログがオープンし、
左側にライブラリに含まれているコンポーネントのリスト
が表示されます。 クリックしてコンポーネントをセレク
トすると、現在設定されているモデルの情報が確認できま
す。  

図 28 複数のコンポーネントにわたってモデルを管理するには、モデルマ
ネージャを使用します

モデルマネージャで可能な作業は以下のとおりです。 

• コンポーネントに対する新規モデルの追加 

• あるコンポーネントからモデルをコピーし、別のコン
ポーネントへの貼り付け 

• コンポーネントからモデルの削除 

• コンポーネントに割り当てているモデルの編集 

これらのコマンドはすべてダイアログのモデルリストのエ
リアから右クリックを実行し、ポップアップメニューから
選択します。 また、モデルリストの下にあるボタンからも、いくつかのコマンドが実行できます。 

図 28に示すようにモデルマネージャで PCBフットプリントがセレクトされ、これがコピーされています。 コピーされると、
複数のコンポーネントに対して、貼り付けを行うことができます。 実行するには、SHIFT + クリック、または CTRL + クリッ
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クで複数尾コンポーネントをリストから選んでください。 必要なコンポーネントを選択したらModel のエリアで右クリックを
実行し、ポップアップメニューから Pasteを実行します。 

重要なポイントとして、複数のコンポーネントをセレクトする場合、セレクトされたコンポーネントに共通なモデルだけが
表示されます。 したがって、フットプリントの貼り付けを行う際、モデルリストの表示がブランクになっても驚かないで
ください。 ひとつのコンポーネントだけをセレクトすれば、すぐにリストにそのコンポーネントのモデルが表示されます。 

デザイン全体にわたるフットプリント管理 

 
図 29 フットプリントマネージャを使っての PCB全体のフットプリントの確認と管理 

 

Altium Designerの回路図エ
ディタには、強力な
Footprint Managerが用意さ
れています。 Toolsメニュ
ーから起動（Tools » 
Footprint Manager）する
と、フットプリントマネー
ジャによって、プロジェク
ト全体の各コンポーネント
の全フットプリントが確認
できます。 複数のセレクト
をサポートしていることで、
複数のコンポーネントのフ
ットプリントがどのように
リンクされているか、ある
いはコンポーネントが保持
している複数のフットプリ
ント情報のうち、現在どれ
が割り当てられているかが
確認でき、フットプリント
の割り当てが容易に編集で
きます。 デザインの変更は、
Altium Designerの標準的な
ECOシステムを介して適用

され、必要に応じて回路図と PCBの両方を更新できます。 

クエリを使用して複数オブジェクトの検索と編集 
Altium Designer には、対象となるデザインオブジェクトを正確に特定するための強力なクエリエンジンが内蔵されています。 
クエリは、基本的にデザインデータ内で何かを検索するための記述です。  

オブジェクト検索のためのフィルタリング 
デザインデータに対してクエリを実行するには、いくつかの方法が用意されています。 これらのひとつとして、Filter パネル
にクエリを入力する方法があります。 デザインデータベースに対して、クエリを適用し、フィルタをかける場合、 各オブジェ
クトは適用されるかどうかクエリによってテストされます。  

図 30

30

 は回路図ライブラリの SCHLIB Filter パネルを示しています。クエリに IsPin が入力されています。 このクエリが適
用されると、（Whole Library オプションが有効になっているので、）すべてのライブラリの各オブジェクトがチェックされ、
ピンオブジェクトが集められて結果セットに追加されます。 それ以外のオブジェクトにはフィルタがかかります。  

SCHLIB Filter パネル右側にあるオプションで結果の表示が
変わります。 図  から、（このケースでは）ピンがフィル
タを通り、セレクト、ズームされます。 それ以外の全オブ
ジェクトはフィルタを通過せず、選択されず、マスクがかけ
らます（フェードアウトされ、編集不可になります）。 

図 30 SCHLIB Filterパネルを使用し、Library Editor内のライブラリ全
体をピンをクエリとして検索 

Selectオプションが有効になっているので、ピンは SCH 
Inspectorに読み込まれます。 Inspector は選択されたオブ
ジェクトの共通の属性を表示することができ� ますが、コン
ポーネントのピンを編集するには、（長さを編集する以外）
役に立ちません。  

TU0115 (v2.6) March 10, 2008 15 



複複オオオオオオの編編 

また、ピンは SCH List パネルにも表示されます。 これはデザインデータをリスト表示し、複数のオブジェクトが簡単に比較、
編集できます。 

Mask outオプションを有効にしてフィルタを適用すると、フィルタアウトされたオブジェクトは、フェードアウトし、
編集ができない状態になります。 フィルタを解除するには、ワークスペース右下にある Clear ボタンをクリックします

[ショートカット SHIFT + C]。 

Listパネルでの設計オブジェクトの編集 - 回路図ライブラリ 
図 31

32 か

図 31 Schematic Library Editorの SCHLIB List パネルに表示されたピンコンポーネント 

 は、回路図ライブラリエディタ
の SCHLIB Listパネルにピン情報が
読み込まれた状態を示しています。 
パネルのトップにある from  のオプ
ションが今は、 current component 
に設定されていることに注意してく
ださい。フィルタの場合は、これは
すべてのライブラリから選択できる
ように設定されていました。 スコー
プのコントロールは、SCHLIB Filter
パネルと SCHLIB Listパネルの両方
にあります。これはフィルタリング
と結果表示を別にコントロールする
ためです。 これでライブラリ内のすべてのピンを検索し、すべてのピンを見たり、編集中のコンポーネントだけを見たりする
ことができます。 

SCHLIB List パネルは表形式になっており、オブジェクトの確認と編集には理想的です。 SCHLIB Listパネル（左上にあるオ
プション）で Edit モード に設定すれば、キーボードのキーを使った � walk’ around や編集が行えます。 例えば、矢印キーで
グリッド値に応じた移動ができ、F2 または Spacebarで選択しているセルを編集できます。 Enterキーで変更が適用され、セ
ルがアクティブになっていれば、Spacebar でチェックボックスの切り替えができます。 

SCHLIB Listパネルはカスタマイズが可能です。 カラム上で右クリックを実行し、ポップアップメニューから Choose 
Columnsを実行するとカラムの追加や削除、順序の変更ができます。 

デザインデータ編集のためにスプレッドシートを利用 

SCHLIB List パネルを
View モードではなく、
Edit モードに設定する必
要があります。そうする
ことで、データを編集
し、パネルにペーストで

SCHLIB Listパネルでデータを直接編集できるだけではなく、複数のセルを選択して SCHLIB List パ
ネルから任意のスプレッドシートエディタにコピーし、スプレッドシートから SCHLIB List パネルに
編集したものを戻すことができます。 例えば、新しいコンポーネントを作成する場合、メーカーが供
給している PDFのデータシートからすべてのピン情報をスプレッドシートにコピーします。 このデー
タを 1ピンずつライブラリエディタに入力するのではなく、次のような作業が行えます： 

1. 新しく作成したコンポーネントでひとつピンを配置し、それをコピーし、Paste Array コマンドを使
用し、必要な数だけ貼り付けます。 

2. Filter パネルでクエリ IsPin を使用し、Listパネルにこれらのピン情報を読み込みます。 

3. ピンデータのカラムが、スプレッドシートエディタのカラムと一致するように適切な設定を行います。 

4. スプレッドシートエディタに切り替え、ピンデータに必要なブロックを選
択し、コピーします。 

図 32 クリップボードにコピーされたスプレッドシ
ートエディタでのピンデータ 

5. SCHLIB Listパネルに戻り、同じセルのブロックをセレクトし、右クリッ
クを行い、ポップアップメニューから Pasteを実行します。 

データがスプレッドシートでどのように表示されるか見るために、データのブ
ロックを先にSCHLIB Listからスプレッドシートにコピーをしたいかもしれま
せん。 この手法を使うと、ピン数が多いコンポーネントの新規作成が、素早
くできます。 図 ら 図 では、この手順を示しています。 
 

34 ま
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図 33 SCHLIB List パネル上でセルのブロックを選択し、右クリックから Pasteを実行 

 
図 34 ピンデータが貼り付けられた後の SCHLIB Listパネル 

スプレッドシートやテーブルからペーストしたデータの作成と編集 
Smart Grid Paste ツールを使用すると、設計オブジェクトの属性を迅速に更新したり、プリミティブのグループをすばやく簡
単に作成したりできます。 このツールは、回路図エディタや、PCBエディタの List パネルの右クリックメニューで有効にな
ります。  

Smart Grid Paste ツールの詳細は、TR0104 Altium Designer パネルリファレンス の Editing Attributes with Smart Grid 
Paste Tools のセクションを参照してください。 

ワークスペースでフィルタリングされたオブジェクトの - 動作について 

Display dataFiltering Engine

Filter
panel

Navigator
panel

FSO
dialog

Highlighting Engine
(Mask, Select, Zoom)

Query Engine

Design data

 

図 35 フィルタリング／ハイライトのプロセス図 

図 35は、デザインデータがどのようにしてフィルタリングされ、ハイライトされるかを示しています。 Filterパネルでクエリ
を記述したり、Find Similar Objects (FSO)ダイアログ（実際には、背後でクエリが動作）の設定によって、あるいは、
Navigatorパネルでオブジェクトを選択することによって、フィルタリングのプロセスがコントロールできることに注意してく
ださい。 上図にPCBパネルは示されていませんが、NavigatorパネルのようにPCBワークスペースで、データをフィルタする
ことが可能です。  
ハイライトエンジンは、フィルタされたデータをどのようにして表示するかを決定します。 
メインのグラフィカルな編集ウィンドウでフィルタされた表示データ（Display data）に対して（ハイライトエンジンにそれを
セレクトするように指示すれば）Inspectorから、あるいは Listパネルからアクセスすることができます。 
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クエリ作成のヒント 
• クエリのキーワードに慣れるまでは Query Helperを使用してください。 ヘルパーを表示するには、Filter パネルにある

Helperボタンをクリックします。 
• キーワード上で F1 キーを押すと、そのキーワードのオンラインヘルプが表示されます。 
• Query Helperダイアログ下側にあるMaskフィールド を使って検索するキーワードの絞込みができます。 * （ワイルドカ

ード）を文字列の先頭に入力すると、すべてのキーワードが表示されます。 
• Query Helperダイアログを閉じる前に Check Syntaxボタンをクリックし、チェックを行ってください。 
• 例えば、� ‘DIP14’ のように、変数はクオーテーションで囲んでください。 
• クエリが適用される優先順位の問題を解消するために、括弧（）を使用し、正しい順序になるようにしてください。 
クエリについての概要は、AR0109 クエリ言語入門を、クエリの記述方法についての詳細は、AR0129 クエリ言語の詳細ガ
イドを参照してください。 
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更新履歴 
 

Date Version No. Revision 

9-Dec-2003 1.0 New product release 

1-Dec-2004 2.0 Rewritten to suit updated Inspector, List and Filter panels 

13-Apr-2005 2.1 Updated for Altium Designer Service Pack 4 

29-Nov-2005 2.2 Reviewed and updated for Altium Designer 6 

15-Nov-2006 2.3 Reviewed and updated for Altium Designer 6.6 

8-Feb-2007 2.4 Inserted a section on use of Smart Grid paste tools for Altium Designer 6.7 

18-Jan-2008 2.5 Updated for Altium Designer 6.8. Moving of selected objects in PCB/Schematic with arrow keys added. 
Locking design objects. Revised information on directives. 

10-Mar-2008 2.6 Converted to A4. 
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