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このチュートリアルでは、回路図を作成するための方法、PCBドキュメントにデザ
イン情報を更新する方法、PCB配線の製造用出力ファイルを作成する方法について
概要を説明します。 また、プロジェクトや統合ライブラリの概念についても説明
し、３D PCB環境を概観します。 

 

 
統一エレクトロニクス製品開発環境 Altium Designerの世界へようこそ。 このチュートリアルでは、非安定マルチバイブレー
タのデザインを例に PCBプロジェクトを作成してみます。  

Altium Designerを使い始めたばかりでしたら、GU0112 ようこそAltium Designer の開発環境へ を参照してください。イン
ターフェースの説明、パネルの使用方法やデザインドキュメントの管理方法について記載されています。 

新規PCBプロジェクトの作成 
Altium Designerのプロジェクトは、デザインに関連するすべてのドキュメントと設定へのリンクで構成されています。 プロジ
ェクトファイル(例えば、xxx.PrjPCB は、ASCIIテキストファイルで、プロジェクト内の、どのドキュメントが関連する出力
設定、印刷や CAMなのか、をリスト表示しています。 プロジェクトに関連付けられていないドキュメントは � ‘フリードキュ
メント’ と呼びます。 PCB、FPGA、組込み (VHDL) パッケージやライブラリパッケージなど、回路図シートや対象とするアウ
トプットへのリンクは、プロジェクトに追加されます。 プロジェクトをコンパイルするとデザインを検証し、ファイル間の同
期を取り、比較を行うことができます。 例えば、オリジナルの回路図や PCBなどを変更すると、プロジェクトのコンパイル
時に更新されます。 

プロジェクトの新規作成プロセスは、すべてのプロジェクトタイプで同じです。 ここでは PCBプロジェクトの例で説明しま
す。 まずプロジェクトファイルを作成し、次に空の回路図シートを作成して空のプロジェクトを新しく追加します。 このチュ
ートリアルの後半では空の PCBを作成し、同様にプロジェクトに追加します。 

チュートリアルを開始するには、新規 PCBプロジェクトを作成します: 

1. メニューから File » New » Project » PCB Project  を選択するか、Filesパネルの
Newの項目で Blank Project (PCB)をクリックします。 このパネルが表示されない
場合、Files を、メインデザインウィンドウのの右下にある System ボタンから選
びます。 

あるいは、Altium Designer Home Page (View » Home) の Pick a Task の項目の
Printed Circuit Board Designを選択してから New Blank PCB Projectをクリッ
クします。 

2. Projectsパネルが表示されます（）。 パネルには新しいプロジェクトファイルである PCB Project1.PrjPCB が表示さ
れますが、ドキュメントは追加されません。  

3. File » Save Project Asを選択して、新規のプロジェクトファイル（拡張子.PrjEmb）の名称を変更します。 プロジェクト
を保存するハードディスク上のディレクトリに移動し、File Nameフィールドでファイル名 Multivibrator.PrjPCBを
入力して Saveをクリックします。 

次に、空のプロジェクトファイルに追加する回路図を作成します。 ここでは、非安定マルチバイブレータの回路図を作成しま
す。 
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新規回路図シートの作成 
新規の回路図シートを作成するには、次のステップを実行します:  

1. File » New » Schematicを選択するか、Filesパネルの Newセクションで Schematic Sheetをクリックします。 デザイン
ウィンドウに、Sheet1.SchDoc というブランクの回路図シートが表示され、回路図ドキュメントは自動でプロジェクトに
追加（リンク）されます。 回路図シートは、Projectsタブ内でプロジェクト名の下の Source Documentsフォルダ内にリ
ストされます。 

 

2. File » Save As を選択して、新規の回路図ファイル（拡張子.SchDoc）の名称を変更します。 プロジェクトを保存するハ
ードディスク上のディレクトリに移動し、File Nameフィールドでファイル名 Multivibrator.PrjPCB を入力して Save
をクリックします。 

空の回路図シートを開くと、ワークスペースが切り替わったことがわかります。 メインツールバーには新しいボタンが追加さ
れ、新しいツールバーが表示されてメニューバーに新しいアイテムが加わり、Sheet パネルが表示されます。 これが回路図エ
ディタです。 

このワークスペースはさまざまにカスタマイズすることができます。 例えば、パネルやツールバーの位置を変更したり、メニ
ューやツールバーのコマンドをカスタマイズしたりすることができます。  

これでプロジェクトに空の回路図を追加できたので、回路の作成に移ります。 

プロジェクトへ回路図シートを追加  
プロジェクトファイルに追加したい回路図シートがフリードキュメントとして開いている場合は、Projectsパネルでプロジェ
クト名を右クリックし、Add Existing to Projectを選択します。 フリードキュメント名を選択し、Openをクリックします。 
あるいは、Projects パネルのプロジェクトドキュメントリストの中に、フリードキュメントをドラッグ&ドロップします。 回
路図シートは、Projects タブでプロジェクト名の下の Source Documentsの下にリストされ、プロジェクトファイルにリン
クされます。 
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回路図オプションの設定 
回路を作図する前に、適切なドキュメントオプションを設定します。 以下の手順で設定します。 

Altium Designerでは
Undo (元に戻す)機能が
複数回使えるので、直前
の操作を何度でもやり直
せます。 Undoの最大回
数は、お使いの PCのメ
モリが許す限り、ユーザ
が自由に設定できます。

1. メニューから Design » Document Optionsを選択すると、Document Optionsダイアログが表示さ
れます。 このチュートリアルのこの場面で必要な変更は、シートサイズを標準の A4の大きさに設定
することだけです。 Sheet Optionsタブの Standard Stylesフィールドで設定します。 エントリの
隣にある矢印をクリックすると、シートスタイルが表示されます。 

2. A4を選択、OKボタンをクリックすると、ダイアログが閉じてシートサイズが更新されます。 

3. ドキュメント全体を再表示するために View » Fit Document を選択します。  

Altium Designerでは、メニューホットキー（メニュー名の下線が引かれた文字）を押すとそのメニュー
が表示されます。 また、いくつかのサブメニューにも、項目をすぐに実行できるホットキーが割り当て
られています。 例えば、View » Fit Documentを選択するショートカットは、Vキーを押し、続いて Dキーを押します。 多く
の場合、Edit » DeSelectのようなサブメニューは直接呼び出すことができます。 Edit » DeSelect » All on Current 
Documentメニューを実行するには、Xキーを押して DeSelectメニューを直接呼び出し、続いて Sキーを押します。 

次に、回路図の環境設定を行います。 
回路図シートはドキュメ
ントのテンプレート
(.schdot) として保存で
きるので、会社のタイト
ルブロックやロゴなど、
固有の情報を含めること
ができます。 

1. Tools » Schematic Preferences［ショートカット T, P］を選択し、 回路図 Preferencesダイアログ
を開きます このダイアログでは、作業する回路図シートすべてに適用するグローバル環境を設定し
ます。 

2. セレクションツリー（ダイアログの左側）の Schematic – Default Primitivesをクリックしてペー
ジをアクティブにし、Permanentオプションを有効にします。 OKボタンをクリックし、ダイアロ
グを閉じます。 

3. 回路の作成を始める前に、File » Save [ショートカット F, S]を選択して、この回路図シートを保存します。 
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回路図の作成 

図 1 非安定マルチバイブレータ 

これで回路図を作成する準備ができました。 このチュートリアルで
は以下（ ）の回路を使用します。 ここでは、2個の 2N3904ト
ランジスタを使用した自動起動型の非安定マルチバイブレータ回路
を作成します。 

図 1

図 1

 

コンポーネント（部品）の検索とライブラリの読
出し 
Altium Designerに数多く用意されている回路図シンボルを管理する
ため、回路図エディタは高度なライブラリ検索機能を提供していま
す。 必要とするコンポーネントは、デフォルトで登録されているラ
イブラリ内にありますが、コンポーネントを見つけるためにライブラリを検索する方法を知ることは重要です。 以下の手順を
実行して、このチュートリアルの回路を作成するために必要なライブラリの検索と登録を行います。  

まずトランジスタを検索します。使用するトランジスタはどちらも
2N3904です。  

1. Libraries タブをクリックすると、Librariesパネルが表示されま
す。 

2. Librariesパネルの Searchボタンを押すか、Tools » Find 
Componenを選択すると、 Libraries Searchダイアログが表示さ
れます。 

3. Optionsにある Search in ドロップダウンが Componentsになっ
ていることを確認してください。 ライブラリの検索には、別の規
範を使う他のオプションもあります。 

4. Scopeが Libraries on Pathに設定されていること、そして Path
フィールドには使用するライブラリへのパスが正しく入力されて
いることを確認します。 Altium Designerのインストール時ににデ
フォルトディレクトリを指定した場合、ライブラリへのパスは、Library になります。 
必要なら、フォルダアイコンをクリックし、ライブラリフォルダを確認します。 Include 
Subdirectoriesボックスが選択されていない（チェックが入っていない）ことを確認しま
す。 

5. 部品の名前に 3904という文字がある部品をすべて検索してみます。 まず、Libraries 
Search ダイアログの上部のクエリ入力欄に*3904* と入力します。 *（アスタリスク）は、
メーカーごとに異なる接頭辞や接尾辞が挿入されていることを考慮して使用するワイルド
カードです。 

6. Searchボタンをクリックして、検索を開始します。 検索が始まると、結果が Librariesパ
ネルに表示されます。  

7. Miscellaneous Devices.IntLib ライブラリで見つかったコンポーネント名 2N3904

をクリックして選択します このライブラリは、シミュレーションで使用可能なすべての
BJTトランジスタ用のシンボルがあります。 

8. まだインストールされていないライブラリに属するコンポーネントを選んだ場合は、コン
ポーネントを回路図に配置する前にライブラリを確認するように求められます。 ここで必
要なMiscellaneous Devices.IntLibライブラリはデフォルトで既にインストールされている
ので、コンポーネントは直ぐに配置することができます。 

追加したライブラリは、Librariesパネルのドロップダウンリストの中に表示されるようにな
ります。 上側のリスト内のライブラリ名をクリックすると、ライブラリ中のコンポーネントが
下側に表示されます。 パネルのコンポーネントフィルターは、ライブラリ内のコンポーネント
を素早く探すのに使えます。 

回路図へのコンポーネントの配置 
最初に回路図へ配置するコンポーネントは、2個のトランジスタ、Q1と Q2です。 回路の一
般的なレイアウトに関しては、図 1に示した回路図を参照してください（ ）。  

1. View » Fit Document [ショートカット: V, D]を選択し、回路図シートをウィンドウいっぱいに広げます。 

2. Librariesタブをクリックして、Librariesパネルを表示させます。 
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3. Q1と Q2は BJTトランジスタです。Miscellaneous Devices.IntLib ライブラリをアクティブにするため、Libraries
パネル上部のドロップダウンリストから選択してください。 

4. 必要に応じてフィルタを使うと、コンポーネントが素早く探せます。 デフォルトのワイルドカード(*) は、ライブラリ内で
見つかるすべてのコンポーネントを表示します。 ライブラリ名の下のフィルタフィールドに *3904* と入力して、フィル
タを設定します。 Component Nameフィールドの一部にテキスト “3904” を含むコンポーネントのリストが表示されます。 

5. リストの 2N3904をクリックで選択し、Placeボタンをクリックします。 あるいは、コンポーネント名をダブルクリック
します。 カーソルが十字形に変わり、配置のため自由に動かせるトランジスタのシルエットがカーソルの上に浮かびます。 
今は、部品の配置モードになっています。 カーソルを動かすにつれてトランジスタのシルエットも一緒に動きます。 

6. 回路図に部品を配置する前に、まず、その属性を編集します。 トランジスタがカーソルの上に浮いている状態で、TAB キ
ーを押します。 この操作で Component Propertiesダイアログ が開きます。 下記のようなダイアログでオプションを設定
します。 

 

回路図コンポーネントと
PCBコンポーネントの
リンクがフットプリント
です。 回路図用のフッ
トプリントは、ネットリ
ストを読込んだときに
PCBライブラリから読
込まれます。 回路図コ
ンポーネントをダブルク
リックすると、フットプ
リントが指定されます。

7. ダイアログの Propertiesで、最初のコンポーネント識別子の値を Designatorフィールドに Q1と入力して設定します。 

8. 次に、フットプリントを確認します。フットプリントは、PCB上のコンポーネントを表すために使われます。 このチュー
トリアルでは、フットプリント用と回路シミュレーション用の推奨モデルが既に含まれている統合ライブラリを使用します。 
フットプリントの名前を確認してください。 
�TO-92A -92Aが Models リストに含まれています。  すべてのフィールドをデフォルトのままに残して OK をクリックし、
ダイアログを閉じます。 

これで部品を配置する準備ができました。 
編集モードや配置モードのとき（十字カーソルのと
き）は、ドキュメントウィンドウの端にカーソルを
移動させて、シートを自動的にスライドさせること
ができます。  

スライドさせすぎたときは、ショートカット V, F
（View » Fit All Objects ） を選択すると、回路図の
全体表示に戻ります。 この操作はオブジェクトの配
置中にも行えます。 

1. カーソルを動かして（トランジスタのシンボルと一緒に）、トランジスタをシ
ートの中央からやや左に配置します。 トランジスタを配置する場所を決めた
ら、ENTERをクリックして回路図にトランジスタを配置してください。 

以下のキーを使って、部品のシル
エットを操作できます。 

- Y 垂直方向に反転します 

- X 水平方向に反転します 

- スペースバー 90度刻みで反時計
回りに回転します 

2. カーソルを動かすと、トランジスタのコピーが回路図に配置されていることが
分かります。まだ、部品の配置モードが続いていて、カーソルの横には部品の
シルエットが浮かんでいます。 この Altium Designerの機能により、同じタイ
プの部品を何個でも配置することができます。 さて、二つ目のトランジスタ
を配置してみましょう。 このトランジスタは一つ目のものと同じものなので、配置の前に属性を編集する必要はありませ
ん Altium Designerは一連の部品を配置する際、自動的にコンポーネントの識別子を増分さ
せています。 このケースでは、二つ目のトランジスタに自動的に Q2が指定されます。 

3. 回路図ダイアグラム（ ）参照すると、Q2は Q1に対して鏡面反転になっていることが
分かります。 トランジスタの方向を反転させるため、カーソルの上に浮いている状態で X 
キーを押します。 この操作はコンポーネントを水平方向に反転させます。 

図 1

4. カーソルを Q1の右のほうへ移動させます。 コンポーネントをより正確に配置するには、
PAGE UP キーを 2回押して、2段階ズームさせてください。 グリッドラインが見えるはず
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です。 

5.部品の位置を決めたら、クリックするか、ENTER を押して、Q2 を配置します。 保持されているトランジスタのコピーは、
再び回路図に配置できます。次のトランジスタがカーソルの上に浮かんでいて、配置されるのを待っています。 

6. 必要なトランジスタはすべて配置したので、マウスの右クリックか、ESCキーを押して部品の配置モードを抜けます。 カ
ーソルは元の矢印に戻ります。 

次に 2つの抵抗を配置します。 

1. Librariesパネルで、Miscellaneous Devices.IntLib ライブラリがアクティブになってい
ることを確認します。 

回路図上に配置されたオブジ
ェクトの属性を編集するに
は、オブジェクトをダブルク
リックして、Component 
Propertiesダイアログを開き

2. ライブラリ名の下のフィルタの項目に res1 と入力しフィルタを設定します。 

3. コンポーネントリストの Res1をクリックして選択し、Placeボタンをクリックします。 カーソ
ル上に抵抗のシンボルが表示されます。 

4. TABキーを押して、抵抗の属性を編集します。 ダイアログの Propertiesで、最初のコンポーネント識別子の値を
Designatorフィールドに R1 と入力して設定します。 

5. フットプリントの名前を確認してください。AXIAL-0.3 が Models リストに含まれています。 

6. 回路図コンポーネントの Comment フィールドの内容は、PCBコンポーネントの Comment フィールドにマッピングされ
ます。通常は、抵抗値をここで入力しておく方がよいでしょう。 R1の Comment フィールドに R1100K の値を入力します。 

 
シミュレートされたコンポーネントには、定義可能なシミュレーション特性の番号が付けられています(例：抵抗なら 1、BJTには 5、MOSFET に
3、など)。これらの特性は、パラメータで定義されています。 この回路をシミュレートしたい場合は、名が値を示し、値が抵抗であることを示すよ
うなパラメータで抵抗値を定義しなくてはなりません。  

シミュレーションと PCBレイアウトの両方のためにキャプチャされた回路には、2種類以上の値（Valueと呼ばれる値、および Commentフィール
ド）を入力します。 �Altium Designer 間接的’にパラメータの文字を Commentフィールドにマッピングする機能をサポートしています。 クリックで
Commentフィールドのドロップダウンリストを表示させると、ソフトウェアが自動的にすべての既存パラメータのリストを生成します。中のひとつ
の値を Commentフィールドにマッピングしてください。 

 
7. ここでは、シミュレーションを実行しないので、Value パラメータ用の Visibleオプションを無効にしてください。 

8. SPACEBAR を押して、抵抗を 90度刻みで回転させ、正しい方向に向けます。 

9. 抵抗の位置を Q1の上に決めて（ の回路図参照）、クリックまたは ENTERを押し、部品を配置します。 まだ、抵抗が
トランジスタに接続していなくても構いません。 すべての部品は後で配線します。 

図 1

図 1

10. 次に、別の 100K抵抗 R2を Q2の上に配置します。 二番目の抵抗を配置すると、識別子が自動的に増分されます。 

11. さらに残りの 1K抵抗、R3と R4が残っています。TAB キーを押し、Component Propertiesダイアログを表示させます。
Commentに 1Kを入力し、Value パラメータ用の Visibleオプションを無効にしてください。 OKボタンをクリックし、
ダイアログを閉じます。 

12. 位置を決めて、R3と R4を の回路図ダイアグラムのとおりに配置します。 右クリックか ESCを押して、部品の配置モ
ードを抜けます。  

次に 2つのコンデンサを配置します。 

1. コンデンサの部品は、Librariesパネルで既に選択されている Miscellaneous 

Devices.IntLibライブラリにあります。 オブジェクトの再配置
は、カーソルを直接オブ
ジェクトの上に置き、左
マウスボタンでクリッ
ク、そのまま新しいポジ

2. Librariesパネル内のコンポーネントのフィルタ欄に capと入力します。 

3. コンポーネントリストの CAPをクリックして選択し、Placeボタンをクリックします。 カーソ
ル上にコンデンサのシンボルが表示されます。 

4. TABキーを押して、コンデンサの属性を編集します。 Component Propertiesダイアログで、
Designatorを C1に、Commentを 20n に設定します。Value パラメータ用の Visibleオプションを無効にして、Models
リストの PCBフットプリントのモデルに RAD-0.3 が選択されていることを確認します。 OKをクリックします。 

 抵抗と一緒に、この回路をシミュレーションしたい場合は、Value パラメータに 20nの値が必要です。この場合、容量を
Value パラメータに定義し、間接機能を使って、値の内容を Commentフィールドにマッピングしてください。 ここでは、
シミュレーションを実行しないので、Value パラメータ用の Visibleオプションを無効にしてください。 

5. 1つ目と同じようにして、2つ目のコンデンサの位置を決め、配置してください。 

6. 右クリックか ESCを押して、配置モードを抜けます。 

配置を要する最後のコンポーネントはコネクタです。Miscellaneous Connectors.IntLib にあります。  

6 TU0117 (v2.3) May 21, 2008 



設設設設PCB  

1. Libraries パネルのライブラリリストから Miscellaneous Connectors.IntLib を選択します。 欲しいコネクタは、2
ピンソケットなので、フィルタに*2*を設定します。 

2. パーツリストから Header 2を選択し、Place ボタンをクリックします。 TABキーを押して、属性を編集し、Designator
に Y1を設定、PCBフットプリントモデルが HDR1X2 であることを確認します。 回路シミュレーション時にこのコンポー
ネントを電源と置き換えたい場合は、Value パラメータは不要です。 OKボタンをクリックし、ダイアログを閉じます。 

3. コネクタを配置する前に、Xを押して水平方向に反転させ、正しい方向に向けます。 回路図上でコネクタをクリックして
配置します。 

4. 右クリックか ESCを押して、部品の配置モードを抜けます。 

5. メニューから File » Save [ショートカット F, S]を選択して、回路図を保存します。 

回路図上の選択されたオブジェクトのグループは、矢印キーで再配
置できます。 選択したオブジェクトの移動は、Document Options 
ダイアログ（Design » Board Options  [ショートカット D, O]）の現
在の Snap Grid 設定に応じて設定されます。 このダイアログでスナ
ップグリッド値を変更します。 このグリッド値は、Altium Designer 
のステータスバーにも表示されます。  

 Preferences ダイアログ (Tools » Schematic Preferencesを選択、
または [ショートカット T, P])の回路図 - グリッドのページは、イン
チまたはセンチ単位でも設定できます。 スナップグリッド設定値を
切り替えるには、ショートカット G を使用します。 あるいは、
View » Gridsのサブメニューや右クリックメニューから Grids を選
択します。 

Ctrl キーを押しながら矢印キーを押すと、選択されたオブジェクト
は、現在のスナップグリッド値に応じて少し移動します。 

かなり大きな値（スナップグリッドの値がファクタ 10など）で、
選択したオブジェクトを、'ひと突きする' こともできます。 CTRL 
と SHIFT キーを同時に押しながら、矢印キーを使います。 

これですべてのコンポーネントを配置しました。 図 2 のコンポーネント間は余裕があり、各コンポーネントのピンを配線する
には間隔が広く開いていることに注意してください。 これは実は重
要なことです。なぜなら、ピンからピンへ、コンポーネントを横切
って配線することはできないからです。 部品の両側のピンを配線に
接続します。  

コンポーネントを動かしたい場合は、コンポーネント本体をクリッ
ク、そのまま新しい位置へドラッグしてください。 

 
図 2 すべての部品が配置された回路図 

回路の配線 
配線は、回路の様々なコンポーネント間の接続を作成する作業です。 回路の配線は のダイアグラムのとおり、以下のよう
なステップで行います。 

図 1

1. 回路図シートがちゃんと見えるように、PAGE UPキーでズーム、または PAGE 
DOWN キーでズームダウンさせます。  CTRLキーを押しながら、マウスホイー
ルを動かしてみる、あるいは、マウスホイールを押したまま、マウスを上下に動
かすと、ズームイン、ズームアウトの操作ができます。試してみてください。 

配線や、その他の図形オブジェクトの形状をグ
ラフィカルに編集するには、いったん配置した
後、矢印カーソルでその図形を再度クリックし
ます。 

配線がコンポーネントの接続ポイントに到達し
たり、別の配線上で終了したりする場合、
Altium Designerは自動的に接点を作成します。

配線の引き回しでは、以下の点に注意してくだ
さい。 

- クリックするか、 ENTERキーを押して、カー
ソル位置に配線を固定します。  

- BACKSPACEを押すと、最後の固定ポイント
が削除されます。  

- 配線の最後のセグメントを配置した後は、右
クリックか、ESCキーを押すと、配線の引き
回しが終了します。 - カーソルが十字形のま
まのときは、別の配線の引き回しを開始でき
ます。 

- 再度右クリックするか、ESCを押すと、配線
の引き回しモードを抜けます。 

2. 最初に、抵抗 R1をトランジスタ Q1のベースに、次のようにして配線します。 
Place » Line [ショートカット P, W]をメニュー から選択するか、Wire ツールを 
Wiring  ツールバーからクリックして、ワイヤ配置モードに入ります。 カーソル
が十字形に変わります。 

3. カーソルを R1の下端の上に置きます。 正しく置くと、赤い接続マーカ(大きなア
スタリスク)がカーソル位置に表示されます。 これは、カーソルがそのコンポー

ネントの信号接続ポイントの上にあることを示しています。 

4. クリックするか、ENTERキーを押して、最初の配線ポイントを固定し
ます。 カーソルを動かすと、カーソルの位置から固定したポイントへ、配線が伸
びていきます。 

5.R1の下側へカーソルを動かし、Q1のベースレベルに置きます。 クリックするか、
ENTERキーを押して、このポイントに配線を固定します。 1つ目と 2つ目の固
定(アンカー)ポイント間に配線が引かれました。 

6. Q1のベースの上にカーソルを置き、カーソルが赤い接続マーカに変わるように
します。 クリックするか、ENTERキーを押して、Q1のベースに配線を接続しま
す。 
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7. カーソルは十字形のままなので、このまま、別の配線を引くことができます。 配置モードを完全に抜け、矢印カーソルに
戻るには、右クリックか、ENTERキーを押しますが、今はやめておきましょう。 

8. 次に、C1を Q1と R1に配線します。 カーソルを C1の左側の接続ポイントの上に置いて、クリックするか、ENTERキー
を押し、新しい配線を開始します。 カーソルを水平に動かして、Q1のベースと R1を接続する配線の真上に来るようにし
ます。 接続マーカが表示されます。 クリックするか、ENTERキーを押して配線セグメントを配置します。次に右クリッ
クするか、ESCキーを押して配線の引き回しを終わらせます。 2つの配線が自動的に接続される様子をご覧ください。 

9. 残りの回路を配線します。図 3をご覧ください。 

 

ピンの終端で交差する配線は、
接点を削除しても、そのピンに
接続されています。 先に進む前
に、実際に作成した回路が、図
3のようになっていることを確
認してください。

図 3 すべて配線された回路図 

10. すべての配線の配置が終了したら、右クリックするか ESCキーを押して、配置モードを抜けます。 カーソルが矢印に戻り
ます。  

11. 配置されたコンポーネントを動かして、接続された配線を一緒に引き直したい場合は、CTRLキーを押したまま、コンポー
ネントを動かしてください。あるいは、Move » Drag.を選択してください。  

ネットとネットラベル 
それぞれ他のコンポーネントに接続されたコンポーネントピンの各セットは、”ネット”と呼ばれるものを構成することになりま
す。 たとえば、あるネットは、Q1のベース、R1のピンを 1つ、C1のピンを 1つ含んでいます。 

設計図内にある重要なネットを容易に識別できるようにするため、”ネットラベル”を貼っておくことができます。  2つの電源
ネットにネットラベルを貼るには、次のようにします。 

1. Place » NetLabel [ショートカット P, N]を選択します。 点線ボックスがカーソルの上に浮かびます。 

2.配置する前にネットラベルを編集するには、TAB キーを押して Net Label ダイアログを表示してください。 

3. Netフィールドに 12V を入力し、OKをクリックしてダイアログを閉じます。 

4. ネットラベルの左下が回路図の配線の少し上に触れるように、ネットラベルを動かします。 ネットラベル
が配線に触れるところで、カーソルが赤い十字に変わります。 交差する線が明るい灰色になった場合は、
ネットではなく、ピンにラベルが付きます。 

5. 最初のネットラベルを配置した直後は、まだネットラベルの配置モードのままです。もう一度 TABキーを押すと、二つ目
のネットラベルを配置前に編集できます。 

6. Netフィールドに GND を入力、OKをクリックしてダイアログを閉じ、ネットラベルを配置します。 

7.ネットラベルの左下が回路図の配線の少し下に触れるように、ネットラベルを動かします。 右クリックか、ESC を押すと、
ネットラベルの配置モードを抜けます。 

8. File » Save [ショートカット F, S]を選択して回路を保存してください。 プロジェクトも同様にして保存します。 

お疲れ様でした。 これで、Altium Designerを使った最初の回路図の作成が完了しました  

回路図を基板に変換する前に、プロジェクトのオプションを設定しましょう。 
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プロジェクトオプションの設定 
プロジェクトオプションには、エラーチェックのパラメータ、接続マトリクス、クラスジェネレータ、コンパレータ設定、
ECO生成、出力パスとネットリストのオプション、Multi-Channelの命名フォーマット、Default Printの設定、Search Paths、
その他のプロジェクトパラメータが含まれています。 Altium Designerはこれらの設定をユーザがプロジェクトをコンパイルす
る際に使用します。 

プロジェクトがコンパイルされると、エレクトロニクス設計上の包括的なルールがデザインの検証に使用されます。 すべての
エラーが解決すると、再コンパイルされた回路図の設計がターゲットとなるドキュメント（たとえば、PCBドキュメントな
ど）にロードされます。 プロジェクトコンパレータによって、ソースとターゲットのファイル間の差異や双方で更新された差
分を発見することができます。 

プロジェクトに関するすべての操作、たとえ
ば、エラーチェック、ドキュメントの比較、
ECO生成などは、Options for Project ダイア
ログで設定されます （Project » Project 
Options）。  

プロジェクトの出力、たとえば、アセンブリ
や製造用の出力やレポートは、Fileメニュー
のオプションから設定できます。 ジョブオプ
ションについても、ジョブオプションファイ
ルで設定できます(File » New » Output Job 
File).。 詳細は、出力ドキュメントをご覧く
ださい 

1.Project » Project Options を選択します。 
Options for … Project ダイアログが開きま
す。 

2. プロジェクトに関するオプションはこの
ダイアログで設定します。 ここでは、
Error Reporting、Connection Matrix、
Comparatorタブでいくつか変更してみま
しょう。 

回路図の電気的特性のチェック 
Altium Designerにおける回路図ダイアグラムには、単純な描画以上の能力があります。つまり、回路についての電気的な接続
情報が含まれています。 この接続情報を使うと、設計を検証することができます。 プロジェクトのコンパイル時に、Altium 
Designerは、Error Reporting や Connection Matrix タブに設定されたルールに従って、エラーチェックを行います。また、
違反事項はすべて Messages パネルに表示されます。 

Error Reportingの設定 
Options for … Projecダイアログの Error 
Reporting タブは、デザイン作図のチェックに使
用されます。  Report Mode の設定は、違反の深
刻さのレベルを表しています。 設定を変える場合
は、変更したい違反事項の隣で Report Modeをク
リックし、深刻さのレベルをドロップダウンリス
トから選んでください。 このチュートリアルでは、
デフォルトの設定を使用します。 

接続マトリクスの設定 
 Connection Matrix タブ (Options for … Project ダ
イアログ)は、ピン間、ポート間、シートエントリ
など、デザイン内の電気的接続をチェックするエ
ラーレポータが生成したエラータイプの深刻さを
表示します。 マトリクスは、回路図上の接続ポイ
ントと許容できるかどうかの異なるタイプをグラ
フィカルに表わしたものです。  
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たとえば、マトリクスダイアグラムの右側にあるエントリを下へたどって、Output Pinを見つけてください。 マトリクスのこ
の行をたどって、Open Collector Pinの列まで進みます。 交差したところの四角形はオレンジ色なので、回路図上で Open 
Collector Pinに接続している Output Pinが、プロジェクトをコンパイルした際に Errorの状態になったことを示しています。 

それぞれのエラータイプには、No Report（問題無し)から、Fatal Error（致命的エラー)まで、別々のエラーレベルが設定でき
ます。 右クリックで、全マトリクスを制御するメニューオプションを見ることができます。 

接続マトリクスの変更は次のとおりです。 

1. Options for … Projectダイアログの Connection Matrix タブをクリックします。  

2. Output Sheet Entryと Open Collector Pinなど、二つの接続タイプが交差しているボックスをクリックします  

3. “オレンジ色のボックスは、この接続についてエラーが生成されたことを表します”など、説明にあるとおりのエラーの色に
変わるまで、ボックスをクリックします。 

このチュートリアルで使用する回路には、Passive Pins（抵抗、コンデンサ、コネクタ）と Input Pins（トランジスタ）しかあ
りません。 接続マトリクスが未接続のパッシブピンを検出したかどうか、見てみましょう。 

1. 行のラベルを下へたどって、Passive Pinを見つけます 列のラベルをたどって、Unconnectedを見つけます passive pin 
の unconnected（未接続）が検出された場合、二つのエントリが交差した四角形がエラー状態を表示します。 デフォルト
は緑色の四角形で、レポートが生成されなかったこと（問題無し）を表します。  

2. この交差ボックスを黄色に変わるまでクリックして、プロジェクトのコンパイル時、未接続のパッシブピンに対して警告が
生成されるようにします。 ここで、わざとこのエラーを生成するインスタンスを作ってみましょう。後ほど、このチュー
トリアルで確認します。 

コンパレータの設定 
Options for … Project ダイアログの
Comparatorタブは、プロジェクトのコンパイ
ル時に、ファイル間のどの相違をレポートし、
あるいは無視するかを設定します。 このチュー
トリアルでは、階層的な回路図設計を参照する
ためだけに、機能間の相違を表示する必要はあ
りません。 コンポーネントクラスを無視しなく
てはならないときに、うっかりコンポーネント
を無視したりしなうようにしてください。 

1. Comparatorタブをクリックします。
Changed Room Definitions、Extra Room 
Definitions、Extra Component Classesが、
Differences Associated with Components
のセクションにあります。  

2. 上記の各オプションの右側にあるMode の
列のドロップダウンのリストから、Ignore 
Differencesを選択します。 

これで、プロジェクトをコンパイルし、エラーを確認する準備ができました。 
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プロジェクトのコンパイル 
プロジェクトのコンパイルでは、デザインドキュメントの描画や電気的なルールのエラーを確認し、デバッグ環境に切り替え
ます。 Options for Projectダイアログの Error Checkingや Connection Matrixタブには、既にルールを設定しました。 

1. 作成中のMultivibratorプロジェクトをコンパイルするには、Project » CompileCompile PCB Project...を選択します。 

2. プロジェクトがコンパイルされると、警告やエラーがMessagesパネルに表示されます。 パネルをクリックして、エラー
をチェックします（View » Workspace Panels » System » Messages）。 コンパイルされたドキュメントは、平坦化され
た階層、コンポーネント、ネットリスト、接続モデルと一緒に Navigatorパネルに表示されます。 

回路が正しく描かれていれば、Messages パネルにエラーは表示されません。 エラーがある場合は、回路を見直し、すべての
配線や接続が正しいか確認してください。 

今から、わざとエラーを回路に紛れ込ませ、プロジェクトをコンパイルしてみましょう。 

1. デザインウィンドウのトップにある Multivibrator.SchDoc タブをクリックして、回路図シートをアクティブにします 

2. R1と Q1のベースの配線の真中をクリックします。 小さな、四角形の編集ハンドルが配線の両端に表示され、対象が選択
されたことを表す選択色が配線の周りに点線で表示されます。  DELETE キーを押して、配線を削除してください。  

3. プロジェクトをコンパイル（Project » Compile PCB Project）して、エラーを確認してみましょう。 

Messagesパネルが警告メッセージを表示し、接続されていないピンが回路中にあることを示します。 Messagesパネル
が表示されない場合は、 View » Workspace Panels » System » Messagesを選択します。 

4. Messagesパネルのエラーや警告をダブルクリックすると、Compile Errorウィンドウが違反の詳細を表示します。 このウ
ィンドウでエラーをクリックすると、回路図内の違反のあるオブジェクトにジャンプし、エラーを確認、訂正することがで
きます。 

次のセクションへ進む前に、回路図のエラーを訂正しておきましょう。 
Messagesパネルのメッ
セージをクリアにしてお
きたい場合は、右クリッ
クして、Clear All を選択
してください。 

1. 回路図シートのタブをクリックして、シートをアクティブにします。 

2. メニューからを Edit » Undo [ショートカット CTRL + Z]を選択します。 先に削除した配線が元通り
になりました。 

3.元に戻ったことを確認し、プロジェクトを再コンパイル（Project » Compile PCB Project）します。 
Messages パネルにはエラーが表示されません。 

4. メニューから View » Fit All Objects [ショートカット: V, F]を選択して、表示を元通りにし、エラーのない回路図を保存し
ます。 

5. 回路図、プロジェクトも同様に保存します。 

これで、回路図は完成、チェックもしました。PCBを作成してみましょう。 
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新規PCBドキュメントの作成 
回路図エディタから PCBエディタにデザインを送る前に、最低でも、基板の外形だけがある空の PCBを一つ作っておく必要
があります。 Altium Designerでにおいて、最も簡単なやり方で PCBデザインを作るには、PCB Board Wizardを使用します。
独自のカスタムボードサイズを作成するのと、同じように、業界標準の基板の外形を選ぶことができます。 Wizardでは、
Backボタンでいつでも前頁のチェックや変更ができます。 

PCB Wizardで新規 PCBを生成するには、以下のステップに従ってください。 

1.新規 PCBを生成します。Filesパネルの下部にある New from Templateセクションの PCB Board Wizardをクリックして、 
このオプションが表示されていないときは、上向き矢印のアイコンをクリックして、上側にあるいくつかのセクションを閉
じてください。 

2. PCB Board Wizardが開き、紹介ページが表示されます。 Next をクリックして続けます。 

3.測定単位をインチ表示（ Imperial）またはミリメートルにします。なお、
1mil = 0.0254mmです。 

4. Wizardの三番目のページで、好きな基板の外形を選ぶことができます。 
このチュートリアルでは、ボードサイズを独自に指定することにします。 
基板外形のリストから、Customを選択し、Nextをクリックします。 

5. カスタムボードのオプションを入力します。 チュートリアル用の回路と
しては、2×2インチの基板で十分です。 Rectangularを選択し、 Width
と Heightのフィールドにそれぞれ 2000 を入力します。  Title Block & 
Scale, Legend Stringと Dimension Linesのチェックは外しておきま
す。 Next をクリックして続けます。  

6. ここでは、ボード上のレイヤの数が選べます。 二つの信号レイヤが必要
です。電力用のレイヤは不要です。 Next をクリックして続けます。 

7. デザイン中で使用するビアのスタイルを選びます。 Thruhole Vias onlyを選択し、Nextをクリックします。 

8. ここでは、コンポーネント/トラックのテクノロジ（配線）のオプションが選べます。 Through-hole componentsオプシ
ョンを選択し、One Trackで隣接するパッド間のトラックの数を設定します。 Next をクリックします。 

9. ここでは、基板に適用するトラックの幅とビアのサイズに関するデザインルールを設定します。 これらのオプションはデ
フォルトのままにしておいてください。 Next をクリックします。 

10.Finishをクリックします。 これで、新規ボードを生成するのに必要なすべての情報を PCB Board Wizardに設定しました。 
PCBエディタには、新しい PCB PCB1.PcbDoc が表示されています。  

11. PCBドキュメントには、デフォルトサイズの白いシートと空の基板外形（グリッドのある黒いエリア）が表示されていま
す。 これをオフにするには、Board Options .ダイアログの Design » Board Optionsを選択して、Display Sheetの選択を
外します。 

Altium Designerが提供している他の PCBテンプレートから、自分で境界、グリッド参照、タイトルブロックを追加するこ
ともできます。  

基板外形、シート、テンプレー
トについての詳細は、TU0110 デ
ザイン移行のための ボード準備
を参照してください。 

詳細なチュートリアルを
見るには、F1キーを押
して、Altium Designer
のドキュメントライブラ12. これで、シートはオフになりま

す。基板外形だけを表示するに
は、View » Fit Board [ショート
カット V、F]を選択します。 

13. PCBドキュメントがプロジェク
トに自動的に追加（リンク）さ
れ、Projectsタブのプロジェク
ト名の下にあるソースドキュメ
ントにリストアップされます。 
File » Save As を選択して、新
規の PCBファイル（拡張
子.PcbDoc）の名称を変更しま
す。 PCB の保存先を指定します。
Multivibrator.PcbDoc を
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File Name フィールドに入力して、Saveをクリックします。 

新しいPCBをプロジェクトに追加 
プロジェクトファイルに追加したい PCBがフリードキュメントとして開かれている場合は、 Projectsパネルの PCBプロジェ
クトファイルをクリックし、Add Existing to Projectを選択します。 新規 PCBのファイル名を選択し Openをクリックしま
す。 これで、Projectsパネルのプロジェクトの下にある Source Documentsに PCBがリストアップされます。ドキュメント
は自動的にプロジェクトファイルにリンクされました。 この操作は、フリードキュメントをプロジェクトファイルにドラッグ
&ドロップすることによっても行えます。 プロジェクトファイルを保存します。 

設計情報の転送 
回路図情報を新しい空の PCBに転送する前に、回路図と PCBの両方で、関連ライブラリが有効であることを確認してくださ
い。 デフォルトでインストールされている統合ライブラリだけをこのチュートリアルでは使用しますので、フットプリントは
既に含まれています。 プロジェクトがいったんコンパイルされ、エラーも修正されたら、Update PCBコマンドを使って
ECO（Engineering Change Orders）を生成。回路図情報をターゲット PCBに転送します。  

PCBの更新 
回路図情報をプロジェクト内のターゲット
PCBに転送します。 

1. 回路図ドキュメント
Multivibrator.SchDoc を開きます 

2. Design » Update PCB Documentで、
Multivibrator.PcbDoc を選択します。 
プロジェクトがコンパイルされ、
Engineering Change Orderダイアログが
表示されます。  

3. Validate Changesをクリックします。 
すべての変更が正当と確認されたら、緑
のマークがが Statusリストに表示され
ます。 変更が正しく確認されなかった場
合は、ダイアログを閉じてMessagesパ
ネルをチェック。エラーをクリアにしてください。 

4. Execute Changesをクリックして変更を PCBに送ります。 すべて完了したら、Done欄のエント
リがマークされます。  

ECOについてのレポー
トを作成、プリントアウ
トすることができます。
Report Changesボタン

5. Closeをクリックして、ボード上に配置準備の完了したコンポーネントが並んでいるターゲット
PCBを開きます。 カレントビューでコンポーネントが見えない場合、ショートカット V、D（View 

» Document）で見えるようになります。 

図 4 配置準備の完了したコンポーネント 
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PCBの設計 
これから、PCB上のコンポーネントの配置と基板の配線を始めます。 

PCBワークスペースの設定 
ボード上のコンポーネントを配置する前に、グリッド、レイヤ、デザインルールなど、PCBワークスペースを設定する必要が
あります。 PCBエディタでは、2Dまたは 3Dでワークスペースをレンダリングすることができます。 

2D モデルはマルチレイヤ環境であり、コンポーネントの配置、配線、接続など、通常の PCB デザイン作業に適しています。 
3D モデルは、デザインを内部および外部からフル 3D モデルとして調べ、部品の干渉や製造前の外観をチェックするのに便利
です。 2D モードと 3D モードを切り替えるには、File » Switch To 3D または File » Switch To 2D（ショートカット 2（2D）、
3（3D））を使用します。 

グリッド 
基板にコンポーネントを配置する前に、適切な配置グリッドが設定されているか確認してください。 PCBワークスペースにあ
るすべてのオブジェクトは、”スナップグリッド”に従って配置されます。 このグリッドは、使用する配線テクノロジに適した
値にする必要があります。  

PCBエディタはインチ
とメートルの両方の単位
をサポートしています。 
切り替えには、View » 
Toggle Unitsを選択して
ください。 多くのダイ
アログの機能が、トグル

スイッチ でコントロ
ールされており、使用中

このチュートリアルでは、標準のインチコンポーネントを使用します。最小ピンピッチは、100mil です。 
スナップグリッドはこれと同様な比率で設定します。つまり、50mil、25milなど、コンポーネントを配
置したとき、すべてのピンがグリッドポイントにうまくはまるようにします。 ボードのトラック幅とク
リアランスもそれぞれ、12mil、13mil（PCB Board Wizardのデフォルト値）にします。この設定で、
パラレルトラックの間のセンターに、最低 25milを確保できます。 したがって、最も適したスナップグ
リッドの設定は 25milということになります。  

スナップグリッドを設定するには、以下の手順に従ってください。  

1. Design » Board Options [ショートカットキー D, O] を選択すると、Board Options ダイアログが表
示されます。 

2.ドロップダウンリストか直接入力で、Snap Gridと Component Gridの値を 25mil に設定します。 このダイアログでは、
Electrical Gridの設定も行うことができます。 このグリッドは、電気的オブジェクトを配置するときに使用するもので、
スナップグリッドに優先して電気的オブジェクトをスナップします。 OKボタンをクリックし、ダイアログを閉じます。 

他にいくつかのオプションを設定して、コンポーネントを配置しやすくしましょう。 

1. Tools » Preferences［ショートカット T, 
P］を選択し、 Preferencesダイアログを
開きます ダイアログ中の選択ツリー（パ
ネルの左サイド）の PCB Editor – 
Generalをクリックして、PCB Editor – 
Generalのページを表示させます。 
Editing Optionsセクションでは、Snap 
To Centerオプションが選ばれています。 
このことはつまり、コンポーネントをつか
んで配置しようとすると、カーソルはコン
ポーネントの参照ポイントに設定されることを意味します。 

2. PCB Editor – Displayをクリックします。 
このページの DirectX Optionsセクション
では、Use DirectX if possibleオプション
をチェックしてください。 これで、最新の
3Dビューモデルが活用できます。 OK を
クリックして Preferences ダイアログを閉
じます。 

注 : Altium Designerの 3Dビューモデルに
は、最適なグラフィックカードに合わせて、
DirectX 9.0Cまたは Shader Model 3（それ
以上）が必要になります。 DirectXが動作しない場合は、旧版の 3Dビューアしか使えないことになります。 

ビュー設定におけるレイヤスタックとその他の非電気的レイヤの定義 
ビュー設定は、2D、3D環境用の多くの PCBワークスペースの表示オプションをコントロールし、PCBと PCBライブラリの
エディタを適用するために設定します。 PCBドキュメントが保存されたとき、最後に使用していたビュー設定がファイルと共
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に保存されます。 これにより、関連するビュー設定を使った Altium Designerの他のインスタンスを見ることができます。 ビ
ュー設定は、ローカルに保存して、どんな PCBドキュメントに対しても、いつでも使用、適用することができます。 関連す
るビュー設定のないどんな PCBファイルでも、システムデフォルトで表示されます。 

注 : View Configurations ダイアログは、レイヤ用 2Dカラー設定へのアクセスを提供しています。その他のシステムベースの
カラー設定 - system settingsは、すべての PCBドキュメントに適用される、ビュー設定の一部です。 2Dワークスペース用の
カラープロファイルは、ビュー設定と同じく、作成、保存が可能です。また、いつでも適用できます。 

Design » Board Layers & Colors [ショートカット L] をメインメニューから選択して、View Configurations ダイアログを開き
ます。 このダイアログで、ビュー設定の定義、編集、ロード、保存ができます。 ここでは、どのレイヤを表示するか、ポリゴ
ン、パッド、トラック、ストリングなどの一般オブジェクトをどのように表示するか、ネット名や参照マーカ、透過レイヤの
表示、シングルレイヤのモード表示、3D表面の不透過度、3D本体の表示、等々を設定します。  

ビューの設定は、View Configurationsダイアログを使って、あるいは、PCB Standardツー
ルバーのドロップダウンリストから直接選ぶことで、適用することができます。 

PCB ワークスペースの下部には一連のレイヤタブがあります。編集作業のほとんどは特定のレイヤに対して実行されます。  

 

PCBエディタには、3種類のレイヤがあります： 

• エレクトリカルレイヤ - ここには 32の信号層と 16の内部プレーン層が含まれます。 エレクトリカルレイヤは、Layer 
Stack Manager ダイアログで、Design » Layer Stack Managerを選択すると、デザインからの追加と削除ができます。 

• メカニカルレイヤ - 基板外形の定義や寸法線、組立て図の作成など、デザインの必要に応じて、汎用のレイヤとして 16の
メカニカルレイヤが用意されています。 これらのレイヤは、ガーバー出力生成時に含めることができます。 View 
Configurations ダイアログで、メカニカルレイヤの追加、削除、名前の設定を行うことができます。 

• 特別レイヤ - ここにはトップ、ボトムのシルクスクリーンレイヤ、ソルダ及び、ペーストマスクレイヤ、ドリルレイヤ、キ
ープアウトレイヤ（電気的な境界を定義するのに使用）、マルチレイヤ（マルチレイヤパッドやビアに使用）、コネクショ
ンレイヤ、DRCエラーレイヤ、グリッドレイヤ、ホールレイヤが含まれます。  

ここで、簡単な 2Dのビュー設定を作成してみましょう。 

1. Design » Board Layers & Colors [ショートカット L]を選択して、View Configurationsダイアログを開いてください。 ダ
イアログは、Select PCB View Configurationの下で選択されているアクティブな設定で開きます。 3Dモードになってい
るときは、2Dをクリックしてください。 

2. Board Layers And Colorsページで、Only show layers in layer stackと Only show enabled mechanical layers のオプ
ションを有効にします。 これらの設定はスタックしているレイヤだけに表示されます。 

3.ページ下部の Used Layers Onのコントロールをクリックします。 これは、使用中のレイヤにだけ表示されます。 つまり、
デザイン要素を持っています。 

4. Top Layerの隣の色をクリックして、2D System Colorsダイアログを表示させます。#7 (yellow)を Basicカラーリストか
ら選択します。 OKをクリックして、View Configurationsに戻ります。 
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5. Bottom Layerの隣の色をクリックして、2D System Colorsダイアログを表示させます。#228 (bright green)を Basicカラ
ーリストから選択します。 OKをクリックして、View Configurationsに戻ります。 

6. Top Overlayの隣の色をクリックして、2D System Colorsダイアログを表示させます。#233 (white)を Basicカラーリス
トから選択します。 OKをクリックして、View Configurationsに戻ります。 

7. 各レイヤの Show オプションが無効になっているので、4つのMaskレイヤと Drill Drawingレイヤは表示されていないこ
とを確認してください。  

8. Actionsセクションで、Save As view configurationをクリックしてファイルを tutorial.config_2dsimple として保
存してください。 

9. OKをクリックして、View Configurationsに戻り、変更を適用して閉じます。  

注 : 2Dレイヤのカラー設定は、システムベースであり、すべての PCBドキュメントに影響を及ぼします。個別のビュー設定
に関連した一項目ではありません。 2D System Colorsダイアログからは、2Dカラープロファイルの生成、編集、保存ができ
ます。 

レイヤスタックマネージャ 
チュートリアルで使用する PCBは
簡単なデザインで、片面や両面基
板で配線が行えます。 デザインが
より複雑な場合は、Layer Stack 
Manager ダイアログでレイヤを追
加することができます。  

1. Design » Layer Stack 
Manager [ショートカットキー 
D, K]を実行し、Layer Stack 
Manager ダイアログを表示しま
す。 

2. 新しいレイヤやプレーンは、現在選択しているレイヤの下に追加されます。 レイヤの属性、銅箔の厚みや絶縁体の属性な
どは、シグナルインティグリティで使用されます。 OKボタンをクリックし、ダイアログを閉じます。  

新しいデザインルールの設定 
PCBエディタはルールドリブンな環境です。つまり、ユーザが何かアクションを起こして - トラックの配置とか、コンポーネ
ントの移動とか、ボードの自動配線とか - デザインを変えると Altium Designerはそれぞれのアクションをモニタしていて、デ
ザインルールの範囲内でデザインをコンパイルできるかどうかチェックしています。 異常な操作に対しては、ルール違反とし
て、エラーが直ちにハイライトされます。 デザインルールの設定をボードの作業の前に行っておくことで、デザインのタスク
そのものに集中することができ、エラーはすぐに報告されて、デザイナの指示を待つのだということを当てにできます。 

デザインルールは 10のカテゴリに分けられ、ルールのタイプごとに、さらに分類されます。 デザインルールは電気、配線、
製造、配置、シグナルインテグリティの要求をカバーしています。 

今から、新しいデザインルールを設定して、電力ネットの配線に必要な幅を規定してみましょう。 これらのルールを設定する
には、以下の手順に従って
ください。 

1. メニューから Design » 
Rulesを選択し、PCB
ドキュメントをアクテ
ィブにします。 

2. PCB Rules and 
Constraints Editor ダイ
アログが表示されます。 
各ルールのカテゴリが、
ダイアログの（左サイ
ドの）Design Rulesフ
ォルダの下に表示され
ます。 Routingカテゴ
リをダブルクリックし
て広げ、関連する配線ルールを見ます。 Widthをダブルクリックすると、幅についてのルールが参照できます。 
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3. それぞれのルールをクリックして選択します。 それぞれのルールをクリックすると、ダイアログの右サイド、トップセク
ションにルールのスコープ（このルールを適用する対象）が表示されます。ボトムセクションには、ルールの制約事項が表
示されます。 これらのルールはデフォルトか、あるいは、新しい PCBドキュメントが生成されたときに PCB Board 
Wizardで設定されているはずです。 

4. Width ルールをクリックしてスコープと制限事項を見てみましょう。 このルールは、ボード全体に適用されます（Scope
は Allに設定されています）。 

 

Altium Designerのデザインルールシステムの強力な機能の一つは、同タイプの複数のルールを、別々のオブジェクトを対象に
して定義できることです。 各ルールが対象とするオブジェクトの正確なセットは、ルールの scopeで定義されます。 ルール
システムは、プレ定義階層を使って、どのルールがどのオブジェクトに適用されるのかをきちんと決めます。 

たとえば、幅についての制限事項をボード全体に適応（すべてのトラック幅を統一、など）した上で、グランドネット幅につ
いての 2番目の制限ルール（これは最初のルールより優先）を設定し、最後に、特定のグランドネット接続の幅についてだけ
適用されるルールを導入できます（このルールは他の二つに優先）。 ルールは、優先度の高い順に表示されます。 

今のところ、このデザインには幅についての制限ルールが一つだけあり、ボードの全体に適用されています。 今から、幅につ
いての新しい制限ルールを追加してみましょう。12Vと GNDのネットで、幅を 25milにします。 これらの制限ルールを設定
するには、以下の手順に従ってください。 

1. Design Rulesフォルダで選択されたWidth カテゴリで、右クリックで New Ruleを選択し、12Vネットだけをターゲット
にして、幅についての新しい制限ルールを追加します。  

新規ルールの名前 Width_1 appears が表示されます。 Design Rulesフォルダ内の新規ルールをクリックして、スコー
プと制限事項を書き換えます。 

2. 12V or GND を Name フィールドに入力します。 この名前は、Design Rules の領域をクリックすると確定します。 

3. 次に、Query Builderを使用して、ルールスコープを設定します。直接入力することもできます。 設定が複雑になりそう
な場合は、Advancedオプションを選択、Query Helperボタンをクリックして Query Helperダイアログを使ってください。 

4. Query Builderボタンをクリックして、Building Query from Board ダイアログを開きます。 

5. Add first conditionをクリックし、ドロップダウンリストから Belongs 
to Netを選択します。 Condition Valueのフィールドで、リストから 12V
を選択します。 Query Previewに �InNet( ‘12V’)が表示されました。 

6. Add another conditionをクリックしてスコープを広げ、GNDネットを
追加します。 Belongs to Netと GNDを Condition Valueとして選択し
ます。 

7. 検索ロジックを変更します。� ANDの検索ロジックをクリックして、ド
ロップダウンリストから ORを選択します。 プレビューが 

� �InNet( 12V’) OR InNet( GND’) になっていることを確認します。 

8. OK をクリックして Building Query from Boardダイアログを閉じます。 これで、Full Queryセクションのスコープは新し
い設定にアップデートされました。  
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9. PCB Rules and Constraints Editor ダイアログの下部セクションで、以前の制限テキスト（10mil）をクリック、数値を入力
して、Min Width, Preferred WidthとMax Widthのフィールドを 25mil に変更してください。 これで新しいルールが設
定されました。別のルールを選んだり、ダイアログを閉じたりする前に、保存してください。 

10. 最後に、オリジナルルール Width（Scope は Allにセット）をクリックして、編集します。Min Width、Max Width、
Preferred Widthフィールドがすべて 12mil に設定されていることを確認します。 OKボタンをクリックし、ダイアログ
を閉じます。 

 

 

 
図5 ボボボ上のコココボコココ  

コンポーネントを動かす
と、接続ラインは自動的に
再度、最適化されます。 こ
れにより、接続ラインをコ
ンポーネントの最適配置と
向きのガイドとして使うこ
とができます。 

ボードをマニュアルで、あるいは自動で配線するときは、25milに設定されている 
GNDと 12Vのトラックを除いて、全トラックが 12milの幅になります。 

PCB上へのコンポーネント配置 
これで、正しい位置へのコンポーネント配置を始めることができます。  

1. ショートカット V、D で、ボードとコンポーネントにズームインし
てください。 

2. コネクタ Y1を配置するには、カーソルをコネクタの外観の真中に
おいて、左マウスボタンでクリック&ホールドしてください。 カー
ソルは十字形に変わり、部品の参照ポイントにジャンプします。 
マウスボタンでホールドしたまま、コンポーネントをドラッグしま
す。 

3. フットプリントをボードの左サイドへもって行きます。なお、全部
のコンポーネントが、ボードの境界内にそろっていることはあらか
じめ確認してください。  図 5

図 5

図 5

4. コンポーネントの位置を決めたら、マウスボタンを離し、その場に
ドロップします。 接続ラインはコンポーネントと一緒にドラッグ
されます。 

5. をガイドにして、残っているコンポーネントの位置を決めま
す。 ドラッグしながら SPACEBARキーを使うと、コンポーネン
トが回転（反時計回りに 90度刻み）します。接続ラインは、
のようになります。 それぞれのコンポーネントを配置するたびに、
接続ラインは最適化されます。 

コンポーネントテキストも、同様のやり方で再配置することができます。テキストのクリック&ドラッグ、SPACEBARで
回転です。  
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Altium Designerには、強力な対話式配置ツールが装備されています。 4つのレジスタ
が正しく整列、等間隔で配置されていることを確認してみましょう。 

1. SHIFTキーを押しながら、4つのレジスタそれぞれをクリックするか、または、4
つまとめてクリック&ドラッグします。 選択されたコンポーネントの周りに、
Selectionsと呼ばれるシステム色で影が付いた選択ボックスが表示されます。 選
択色を変えるには、Design » Board Layers & Colors [ショートカット L ]を選択し
てください。 

2. 右クリックで、Align » Align [ショートカット A、A ]を選択します。  Align Objects
ダイアログで、Horizontalセクションの Space Equallyをクリック、Verticalセク
ションで Topをクリックします。 4つのレジスタは、これできちんと、等間隔で整
列しました。 

3. デザインウィンドウの適当な場所をクリックして、レジスタの選択を解除します。  

フットプリントの変更 

 
図 6 新しいフットプリントとともにボード上
に配置されたコンポーネント 

図 6

ここでは、フットプリントの位置を決めます。コンデンサのフットプリントは大きす
ぎて、要求仕様に合わないようです。 コンデンサのフットプリントをもっと小さなも
のに変更しましょう。 

1. 最初に、新しいフットプリントを見てみましょう。 Librariesパネルをクリックし
て、ライブラリのリストから Miscellaneous Devices.IntLib を選びます。 
ラジアルタイプの小さなフットプリントが欲しいので、Filterフィールドに radを
入力します。 ライブラリ名の隣にある…  buttonをクリックして、Footprintsオ
プションを選択、アクティブライブラリ内で有効なフットプリントを表示させま
す。 フットプリント名をクリックして、関連するフットプリントを見ます。 フッ
トプリント RAD-0.1ならうまく合いそうです。  

2. コンデンサをダブルクリックし、Componentダイアログで、Footprint フィール
ドを RAD-0.1 に変更します。 フットプリント名を入力します。あるいは、…  
buttonを押して、Browse Librariesダイアログからフットプリントを選びます。 
OKをクリックすると、新しいフットプリントがボード上に現れます。 必要に応
じて識別子を再配置します。 ボードは のようになるはずです。  

すべて配置し終えたら、配線に取りかかりましょう。 

PCBドキュメント上で選択したオブジェクトは移動することができます。Ctrl キーと矢印キーの組み合わせを使用するか（垂直または水平）、Ctrl キーと 
Shift キーと矢印キーの組み合わせを使用します。 選択したオブジェクトの移動は、Board Options ダイアログ（Design » Board Options  [ショートカット 
D, O]）の Snap Grid に設定されている値に応じて設定されます。 このダイアログでスナップグリッド値を変更できます。 スナップグリッド設定値を切り
替えるには、ショートカット G を使用します。 View » Gridsのサブメニューや右クリックメニューの Snap Grid を選択することもできます。 

Ctrl キーを押しながら矢印キーを押すと、選択したオブジェクトは、現在のスナップグリッド値に応じて少しづつ移動します。 Ctrl キーと Shift キーを押
したまま矢印キーを押すと、選択したオブジェクトは、スナップグリッド値に 10 を掛けた分だけ大きく移動します。 

 

 

 

 

 

 

 

ボードのマニュアル配線 
配線は、トラックやビアをボード上に置いて、コンポーネントをつないで行くプロセスです。 Altium Designerは、ボード上の
全部または一部の配線をボタンタッチで最適化する Situsオートルータ以上に洗練された対話型配線ツールによって、この作業
を簡単にしました。  

オートルータ（自動配線機能）が簡単で強力なボードの配線手法を提供する一方で、配置やトラックに正確なコントロールが
必要な箇所があったり、どうしても手動で引いてみたい場合があったりします。 このようなシチュエーションでは、ボードの
一部または全部を手動で配線することもできます。 チュートリアルのこのセクションでは、全部のボード（片面）について、
ボトムレイヤのすべてのトラックを手動で配線してみましょう。 トラック配置のためのカーソルガイダンス、シングルクリッ
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図 8 Pushモード、
Hug  & Pushモード
で、目標のパッドに
配線できないとき、
ブロックマークが現
れます。 

クによる接続、障害物のプッシュ&ウォークアラウンド、既存の接続への自動追従、など。効率
的で柔軟な直感的手法により、対話型配線ツールは、デザインルールに一致した配線作業を最大
限に支援します。 

今から、ボードのボトムレイヤにトラックを配置してみましょう。ガイドに使用するのは、
“ratsnest“ 接続線です。 

PCB上のトラックは、一連の直線セグメントで構成されています。 各段階で、方向が変わり、
新しいトラックセグメントが始まります。 デフォルトで Altium Designerは、トラックの角度を
垂直、水平、斜め 45度に限定することで、本格的な配線を容易に提供することができます。 ツ
ールの動作はカスタマイズして、ユーザの要求に合わせることができます。このチュートリアル
ではこのまま使います。 

1. ボトムレイヤを有効にします。ショートカットキー L を押して、View Configurationsダイア
ログを表示させてください。 Signal Layers 領域にあるボトムレイヤの隣の Showオプショ
ンを有効にします。 OKをクリックすると、デザインウィンドウの下部にボムレイヤタブが
表示されます。 

2. Place » Interactive Routing [ショートカット P, T]をメニューから選択します。または、
Interactive Routingボタン ( ) をクリックします。 カーソルが十字形に変わり、トラック
配置モードであることを示しています。 

3. ドキュメントワークスペースの下部に並んでいるレイヤタブのいくつかを調べてみてくださ
い。 Top Layerタブが現在アクティブになっているはずです。 トラック配置モードを抜ける
ことなく、ボトムレイヤを切り替えるには、数値キーパッドの上で * キーを押してください。 このキーで信号レイヤと交
互に切り替わります。 Bottom Layerタブが現在アクティブになっているはずです。 

図 7 手動プロセスではカーソ
ルが追従します 

4. コネクタ Y1上の下側のパッドにカーソルを合わせます。 クリックするか、ENTERキーを押して、最初のトラックポイン
トを固定します。  

5. カーソルをレジスタ R1の下側のパッドに移動させます。 トラックセグメントがチェックパターンの中で表示される様子に
注意してください。カーソルパスに追従します（ ）。 チェックパターンは、まだ、定まって（配置されて）いないこと
を示しています。 パスに沿ってカーソルを戻すと、定まっていない配線も崩れます。 ここでは、配線に二つの選択肢があ
ります。 

図 7

- CTRL + クリックで、Auto-Complete機能を使用し、ただちに接続（このテクニックはパッドや接続ライン上で直接使え
ます）。 接続元と接続先のパッドは同じレイヤにある必要があります。また、Auto-Complete機能が動作するためには、
ボード上に障害物があっても、配線可能である必要があります。 大きなボードでは、配線パスがセクションごとにマップ
されるので、この Auto-Completeパスが常に有効であるとは限りません。また、接続元と接続先パッドのマッピングを完
了できない場合もあります。 

- ENTER または、対象となるトラックセグメントのクリックで、トラックがターゲットの R1パッドへ直接つながります。 
この方法は、配線のコントロールを提供し、必要なアクションを最小限にします。 

目的外のトラックは斜線で、目的のトラックは無地で表されます。  

6. 上記の方法のどちらかを使って、ボード上の他のコンポーネント間を配線します。 はマニュアルで配線されたボードで
す。 

図 9

7. デザインを保存します[ショートカット F, S、または CTRL + S]。 

Altium Designerの対話型配線ツールは、既存のトラックなど、ボード上の障害物との衝突を解決できるモードに特長がありま
す。 これらの対話的な配線モードは、SHIFT + R でを切り替えられます。 有効なモードは以下のとおりです。 

Push（押しのけ） - このモードは、干渉無しに再配置できそうなオブジェクト（トラックやビア）の移
動を試みることで、新しい配線に対応します。 

Walkaround（迂回） - このモードは、既存の障害物を動かすことなく、その周りに配線の引き回しを試
みます。 

Hug & Push（ハグ&プッシュ） - このモードは、上記二つの機能の組み合わせです。 障害物を迂回する
一方で、固定の障害物を押しのけようとします。 

Ignore（無視） - このモードでは、違反を無視して、どこにでもトラックを配線できます。 

対話型配線の実行中、Pushまたは Hug & Pushモードで解決できないエリア内に配線しようとすると、
トラックの端に表示が現れ、ブロックされていることが示されます（ ）。 図 8

トラック配置のヒント 
トラックを配置するときは、以下のポイントを覚えておいてください。 
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• クリックまたは ENTERで、カーソルの現在位置にトラックセグメントが固定されます。 対象外の配線を表すパターンセ
グメントをチェックしてください。 対象トラックはレイヤ内で無地になっています。 

• CTRL + クリックで、いつでも Auto-Complete接続が使用できます 接続元と接続先のパッドは同じレイヤにある必要があ
ります。また、回避不能な障害物があってはいけません。 

• SHIFT + Rで衝突解決のモード、Push、Walkaround、Hug & Push 、Ignoreが切り替えられます。 

• SHIFT + SPACEBAR で各種トラックコーナーのモードが切り替わります。 スタイルは、 自由アングル、45°、アークつき
45°、90°アークつき 90°です。 SPACEBARを押して、コーナーの向きを変えてください。 

• END を押すと、いつでも、スクリーンが再描画されます。 

図 9 手動で配線したボードでは、トラックはトップと
ボトムのレイヤに配置されます。

• V, Fで、いつでも、全オブジェクトがフィットするようにスクリーンが
再描画されます。 

• PAGE UPまたは、PAGE DOWNキーで、いつでも、カーソル位置を中
心にしてズームイン、ズームアウトができます。 マウスホイールで、左
移動、右移動します。 CTRLキーを押したまま、マウスホイールでズー
ムイン、ズームアウトができます。 

• BACKSPACE で直前に配置したトラックセグメントをやり直しできます。 

• トラックの配置を終了して、別な作業を始めるには、右クリックまたは、
ESCを押します。 

• お互いにつなぐべきでないパッドをうっかり接続してしまうことはあり
えません。 Altium Designerはボードをモニタしており、接続ミスやトラ
ックの交差が起こらないようにしています。 

• トラックセグメントを削除するには、クリックで選択します。 セグメン
トの編集ハンドルが現れます（トラックの残りの部分はハイライトされ
ます）。 DELETE キーを押して、選択されたトラックセグメントを削除
してください。 

• 新しいトラックセグメントの再配線も容易です。右クリックで終了したら、余分なトラックセグメントは自動的に削除され
ます。 

• PCB上のすべてのトラックの配置が終了したら、右クリックするか ESCキーを押して、配置モードを抜けます。 

各種の対話型配線ツールについての詳細は、AP0135 Interactive and Differential Pair Routing を参照してください。 

ボードの自動配線 
Altium Designerの自動配線がいかに簡単かわかります。以下の手順に従ってください。 

1. 最初に、メニューから Tools » Un-Route » All [ショートカット U, A] を選択し、ボードの配線を除去します。 

2. Auto Route » Allを選択します。 Situs Routing Strategiesダイアログが表示されます。 Route Allをクリックします。 
Messagesパネルには自動配線の様子が表示されます。 

図 10 フル自動配線されたボード 

Situsオートルータは、経験のあるボード設計者に比肩する成果を提供します。PCB編集ウィンドウ内のボードに直接、配
線するので、配線ファイルのエクスポート、インポート作業で格闘する
必要はありません。 

3.File » Save [ショートカット F, S]を選択してボードを保存してください。 

注 : オートルータで配置されたトラックは 2種類の色で表されています。赤
色は、トラックがボードのトップの信号レイヤにあることを示し、青色はボ
トムの信号レイヤにあることを示します。 オートルータが使用するレイヤは、
Routing Layersのデザインルールで特定されており、PCB Board Wizard
で設定できます。 また、コネクタからの二つの電力ネットトラックが幅広く
なっています。これは、チュートリアルで既に設定されたデザインルールに
基づいています。 

図 10とまったく同じデザインになるとは限りません。 コンポーネントの配
置、配線の配置もまったく同じになるわけではありません。 

なぜなら、このチュートリアルでは、PCB Board Wizardで独自に両面ボー
ドを定義しましたが、手動でトップとボトムのレイヤを使用し、「両面」ボ
ードの配線を行うこともできるからです。 最初に、メニューから Tools » 
Un-Route » All [ショートカット U, A] を選択し、ボードの配線を除去します。 
これまでどおり、対話型配線を始めます。* キーで配置トラックのレイヤを
切り替えます。 レイヤを切り替えると、Altium Designerは必要に応じて自
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動的にビアを挿入します。 

 

3Dモードでボードデザインを確認する 
以上で、ボードデザインは基本的に完成しました。3Dモードで見てみましょう。 3Dモードでは、あらゆる角度からフル 3D
モデルのボードを眺めることができます。 3D に切り替えるには、PCB Editorで View » 
Switch To 3D [shortcut: 3] を選ぶか、PCB Standard ツールバーのリストから 3D ビュー構成
を選択します。 

Altium Designer の 3D 環境には、DirectX とその関連テクノロジ、グラフィックカードが必要です。 お使いのシステムを調べ
て、Altium Designerから DirectXを使用できるようにしてください。 Preferences ダイアログ（Tools » Preferences）の 
PCB Editor – Display ページを開きます。. 

ビューは滑らかにズームさせたり、回転させたりすることができます。ボードの内部に入り込むことさえできます。以下のコ
ントロールを使用してください。 

Zooming（ズーム） - CTRL + 右クリック、あるいは、CTRL + マウスホイール、あるいは、PAGE UP / PAGE DOWN キ
ー。 

Panning（パン） - マウスホイールでアップ/ダウン、SHIFT + マウスホイールで左/右、右ドラッグであらゆる方向へパン。 

Rotation（回転） - SHIFT を押しながら、3D 回転モードに入る。 図には、カーソルポジションにおけるダイレクションス
フィア（方向指示する球体）がスクリーンに表示されています（図 11）。 モデルの回転運動は、スフィアを中心にして行
われます。以下のコントロールを使用してください。 

スフィアの Center Dot（中心点）を右ドラッグすると、フルフローティングビュー – あらゆる方向に回転できます。 

スフィアの Horizontal Arrow（水平方向の矢印）を右ドラッグすると、Y軸を中心として回転します。 

スフィアの Vertical Arrow（垂直方向の矢印）を右ドラッグすると、X軸を中心として回転します。 

スフィアの Circle Segment（円環部分）を右ドラッグすると、Y平面で回転します。 

 

Altium Designerの 3Dモード
には、DirectX 9.0c以降、
Shader Model 3以降、適切な
グラフィックカードが必要に
なります。 

PCBエディタのオプションが
有効なら、Use DirectX で、
DirectXを使うように設定で
きます。Preferences ダイア

図11 ビビボの回回スススス 3D  

3Dワークスペース表示オプションを、View Configurations ダイアログ [ショートカット L] で設定します。 さまざまな表層と
ワークスペースのカラーを選択できるオプション、頂点のスケーリングを選択できるオプションがあり、PCBの内部を手軽に
調べることができます。 いくつかの表層には、不透明– 不透明さが増すにつれて、� 表層を透過する明るさが減少し、オブジ
ェクトの背後が見えなくなる - が設定されています。 3Dボディやレンダリング 3Dオブジェクトは、2Dのレイヤカラーで表
示させることもできます。 

3D STEPフォーマットのモデルをコンポーネントフットプリントや PCBデザインにインポートして、カスタムの 3Dボディオ
ブジェクトを作成することができます。 また、PCBドキュメントを STEP や DWG/DXF のフォーマットで出力して、ほかの
プログラムで使用することもできます。 今までの 3Dビューア（Tools » Legacy Tools » Legacy 3D View）は、3Dオブジェ
クトを VRML 1.0/IGES/STEP フォーマットでインポートすることができ、IGES や STEP でエクスポートできました。 

注 : 3D モードでは、いつでも、現在のビューをクリップボードにさまざまな解像度で”貼り付ける”ことができます。CTRL + C
を使用してください。 イメージは、Windowsのクリップボードに、ビットマップフォーマットで保存され、他のアプリケーシ
ョンで使用することができます。 
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コンポーネントフットプリント用の 3Dボディの作成とインポート 
これで、ようやく、PCBの最終検証と出力の段階に到達しました。 Altium Designer の 3D 環境は優れたビューア機能を提供
し、PCBアセンブリの視覚的でリアルな環境での検証が行えます。 

コンポーネントフットプリントは、3D 環境でコンポーネントをレンダリングするための 3D ボディを保存することができます。 
さらに、正確なコンポーネントクリアランスのチェックができ、PCBとその外部、あるいはフリーフロート 3Dオブジェクト
との全体的な組み立てさえも可能です。 これらの機能によって、正に Altium Designerだけで、メカニカル CADパッケージと
新しいレベルで設計の統合を図ることができます。 

コンポーネントの 3D ボディの作成についての詳細は、TU0103 ライブラリコンポーネントの 作成 の 3次元コンポーネン
トの詳細 のセクションを参照してください。 

MCADアプリケーションとの統合のために 3D ボディを使用することについての詳細は、TU0132 MCADオブジェクトと
PCBデザインの統合  を参照してください。 

TU0132 MCADオブジェクトとPCBデザインの統合  のチュートリアルでは、このチュートリアルで作成してきたボードを使用
して、コンポーネントの 3D ボディを完成させます。 (図 12). チュートリアルは、ボードとハウジング機構の組み立てに進みま
す（図 13）。 ボードとコンポーネントは、Altium Designerをインストールしたディレクトリの 
Examples/Tutorials/multivibrator_step フォルダの中にあります。 

 
図 12 3D 
 ボディコンポーネントで表示されたマルチバイブレータ PCB 

 
図 13 2つの部品 
ハウジングにフルアセンブリされたマルチバイブレータ PCB 

Altium Designerは、階層デザ
インのルールをサポートして
います。 同様のルールについ
ては、そのいくつかを、それ
ぞれの定義スコープで設定で
きます。 ルールの優先順位
は、定義の順序で決まりま
す。 

ボードデザインの確認  
Altium Designerは PCBをデザインできるルールドリブンの設計環境であり、ボードを完全なもの
にするために多くのデザインルールのタイプを定義することができます。 一般的には、デザインプ
ロセスの開始時にデザインルールを設定し、設計終了時にルールに従ってデザインが作成されてい
るか確認します。 

このチュートリアルの前半で、配線デザインルールをテストし、トラック幅に関するルールを追加
しました。 その他の多くのルールはすでに PCB Board Wizardによって作成されています。  

配線が終了した PCBに対して、デザインル
ールに合致しているか確認するためデザイ
ンルールチェック(DRC)を実行します: 

1. Design » Board Layers & Colors [ショ
ートカット L]を選択して、System 
Colors セクションの DRC Error 
Markers オプションの隣にある、Show 
ボタンが有効になっている（チェックさ
れている）ことを確認して、DRC エラ
ーがマーカが表示されるようにしてくだ
さい。 

2. Tools » Design Rule Check [ショート
カット T, D]を選択します。 オンライン
とバッチ DRCの両方が Design Rule 
Checker  ダイアログで構成されています。 
カテゴリ、たとえば、Electrical をクリ
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ックすると、カテゴリに属する全ルールを参照できます。  

3. すべてのオプションをデフォルトのままにして、Run Design Rule Check ボタンをクリックします。 DRC が実行され、
レポートファイル Multivibrator.DRC が開きます。 結果は、Messagesパネルにも表示されます。 PCBドキュメント
をクリックします。トランジスタのパッドが緑色にハイライト表示されて、デザインルール違反を示しているのがわかりま
す。 

4. エラーリストを Messages パネルで調べます。 リストには PCBデザインで発生した違反が表示されています。 4つの違
反箇所が Clearance Constraint ルールの下に記載されている点に注目してください。 トランジスタ Q1と Q2のパッドが、
13 milのクリアランスルールに違反していることがわかります。  

5. Messagesパネルでエラーをダブルクリックすると、PCB上の配置場所にジャンプします。 

通常は、クリアランスの制限ルールを設定してから、ボードをレイアウトし、ルーティングテクノロジやデバイスの物理属性
を確認します。 エラーを解析し、現在のクリアランスデザインのルールを再検討して、対策を決定します。  

トランジスタのパッド間の実際のクリアランスを調べるには、次の操作を実行します:  

1. PCBドキュメントをアクティブな状態にします。カーソルをトランジスタの 1つに合わせ、PAGE UPキーを押して拡大表
示します。 

2. Reports » Measure Primitives [ショートカット R, P]を選択します。 カーソルが十
字形に変わります。 

3. カーソルをトランジスタの左側のパッドの中心に移動した後、クリックするか、
ENTERキーを押します。 カーソルは、接続されているパッドとトラックの上に移
動します。ポップアップメニューが表示され、目的のオブジェクトが選択できるよ
うになります。 トランジスタのパッドをポップアップメニューから選択します。 

4. カーソルをトランジスタの中間のパッドの中心に移動した後、クリックするか、ENTERキーを押します。 もう一度、パッ
ドをポップアップメニューから選択します。 情報ボックスが表示され、パッド間の最短距離は 10.63milと表示されます。 

5. 情報ボックスを閉じて、右クリック、または ESC を押し、計測モードを抜けます。V、 F のショートカットで、ドキュメ
ントを再ズームさせます。 

現在のクリアランスルールを見てみましょう。 

1. Design » Rules [ショートカット D, R] をメニューから選び、PCB Rules and Constraints Editor ダイアログ を開きます。 
Electrical カテゴリをダブルクリックすると、すべての電気的ルールがダイアログの右側に表示されます。 Clearance タイ
プをダブルクリックして、Clearance ルールをクリックすると、ルールが表示されます。 ダイアログの下側にルールが 1
つ表示されていて、ボード全体の最小クリアランスが 13 milに設定してあることがわかります。 トランジスタのパッド間
のクリアランスはこの幅よりも小さく、これが DRCを実行したときに違反が発生した原因です。 

トランジスタのパッド間は 10 milよりやや大きいことがわかっているので、デザインルールを設定して、トランジスタだ
けのクリアランス制限を 10 milにします。 

2. Design Rulesフォルダで Clearanceタイプを選び、右クリックして New Ruleを選択して、新しいクリアランス制限ルー
ルを追加します。 

3. 新しいクリアランスルール、Clearance_1 をクリックします。 結果ページの Constraints セクションで、Minimum 
Clearance を 10mil にします。 

4. Advanced (Query) をクリックし、次に Query Helper  をクリック。Memberships Checks からクエリを作成します。 あ
るいは、以下のクエリを Query フィールドに入力して、最初のオブジェクトにします（図 14）。: 

�  HasFootprintPad( TO-92A’,’*’) 
* （アスタリスク）は、フットプリント TO-92A の � '任意のパッド' を示します。   

5. 2番目のオブジェクトのスコープは ALL のままにして、OK をクリックします。Apply 、 OK の順にクリックして、PCB 
Rules and Constraints Editor ダイアログを閉じます。  

6. 再び、DRC を Design Rules Checker ダイアログ（Tools » Design Rule Check）から走らせます。Run Design Rule 
Check ボタンをクリックしてください。 今度は、違反が起きません。 

7. 完成した PCBとプロジェクトを保存します。 
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図14 ルボルを作作すすすすの ダダスダダで ルボルを使使 Constraints Editor PCB  

以上で終わりです。 PCBレイアウトは終了し、ドキュメントを出力する準備ができました。 
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出力ドキュメント 
PCBのデザインとレイアウトは完成しました。出力ドキュメントを作成して、ボードレビュー、製造、組み立てに進んでみま
しょう。 これらのドキュメントは一般的に、ボード製造工程のために企画されています。さまざまなテクノロジと手法が PCB
の製造に関連しているので、Altium Designerでは以下のような出力を行うことができます。 
アセンブリ出力 
• アセンブリ描画 - ボードの各面におけるコンポーネントの位置と向き 

• ピック&プレース ファイル - ロボティック配置機構を使用して、ボードにコンポーネントを配置 

ドキュメント出力 
• コンポーネント描画 - 完成後のボードアセンブリ。コンポーネントとトラックを含む。 

• PCB 3D プリント - 3次元パースからのボードビュー 

• 回路図プリント - デザインに使用された回路図のプリント  

製造出力 
• コンポーネントドリル描画 - ドリル穴の位置とサイズ（シンボルを使用）。単一描画されたボード用。  

• ドリル描画/ガイド - ドリル穴の位置とサイズ（シンボルを使用）。分割描画されたボード用 

• 最終アートワークプリント - さまざまな製造出力を組み合わせ、単一プリント可能な形で出力 

• ガーバーファイル - ガーバーフォーマットで製造情報を作成 

• NC ドリルファイル - NCマシンで使用可能な製造情報を作成 

• ODB++ - ODB++ データベースフォーマットで製造情報を作成 

• パワープレーン プリント - インターナルプレーンとスプリットプレーンの描画を作成 

• ソルダ/ペーストマスク プリント - ソルダマスク、ペーストマスクの描画を作成 

• テストポイント レポート - さまざまなフォーマットで、テストポイント出力を作成 

ネットリスト出力 

ネットリストには、デザイン中のコンポーネント間の論理的な接続が記述されていて、他のエレクトロニクス設計アプリケー
ションへにデータを移送するのに便利です。  

レポート出力 
• 部品表（BOM） - ボード製造にもとめられるさまざまなフォーマットで、部品と数量のリスト（BOM）を作成 

• コンポーネントのクロス参照レポート - デザイン中の回路図に基づいて、コンポーネントのリストを作成 

• プロジェクト階層レポート - プロジェクト内で使用されるドキュメントのソースのリストを作成 

• シングルピンネット レポート - ただひとつの接続だけがあるネットを集めたリストを作成 

• シンプル BOM - テキストとコンマで区切られた変数（CSV）のファイルを BOMから作成 

ほとんどのドキュメントは、編集/構成可能で、必要に応じてカスタマイズできます。 設計を数多くこなしていくうちに、同じ、
または似たような出力ドキュメントを作成することが多くなります。 Altium Designerは出力ジョブファイル（Output Job 
Files）と呼ばれる仕組みを提供しています。その専用インターフェースである出力ジョブエディタ（Output Job Editor）では、
さまざまな出力ドキュメントをまとめ、さまざまなメディア（直接プリント、PDF、ファイル生成）で出力することができま
す。 
出力ジョブエディタ（Output Job Editor）についての詳細は、TR0127 出力ジョブエディタのリファレンスを参照してくだ
さい。 

PDF出力についての詳細は、OG0109 PDFに出力を参照してください。 

製造用出力ファイル 
このチュートリアルでカバーする PCB設計プロセスの最終段階は、ガーバーファイル、NCドリルファイル、部品情報
（BOM）など、製造用ファイルの作成です。 ここでは、出力ジョブエディタは使いません。個々のメニューコマンドを使用し
ます。すべての出力ドキュメントはメニューシステムがらも直接作成することができます。 出力ドキュメントの構成は、プロ
ジェクトファイルの一部として保存できることに注意してください。 

ガーバーファイルの生成 
各ガーバーファイルは、コンポーネントオーバーレイ、トップシグナルレイヤ、ボトムシグナルレイヤ、ソルダマスクレイヤ
など、物理的ボードのそれぞれひとつのレイヤに対応しています。 ガーバーファイルや NCドリルファイルを生成する前に、
基板製造業者へ必要なデータの形式について問い合わせておくことをお勧めします。 
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このチュートリアルの PCBで製造ファイルを作成するには、次の操作
を実行します:  

1. File » Fabrication Outputs » Gerber Filesを選択します。 Gerber 
Setupダイアログが表示されます。 

2. Layers タブ、Plot Layers ボタンをクリックし、Used Onを選択
します。 OK をクリックしてデフォルト設定を適用します。  

3. ガーバーファイルが生成され、CAM エディタが開いてファイルを表
示します。 ガーバーファイルは、Project Outputs フォルダに
保存されます。このフォルダは、プロジェクトファイルが保存され
ているフォルダに自動的に作成されます。 各ファイルには、レイヤ
名に関係のある拡張子がつけられます。たとえば、
Multivibrator.GTO はガーバートップオーバーレイに対応してい
ます。 これらは Generated CAM Documents フォルダの Projects 
パネルに追加されます。. 

同様に、File » Fabrication Outputs » NC Drill Files コマンドで、NC Drill Setup ダイアログを開いて（デフォルト設定はその
ままで）、NC ドリルデータを出力してください。 

作成中に自動的に出力ファイルが開くのを望まない意場合は、
Project » Project Optionsを選び、 Options タブをクリック。
Open outputs after compile optionを無効にしてください。 

部品表（BOM）の作成 
このチュートリアルの PCB用の部品表（BOM: Bill of Materials）を作
成します。 

1. Reports » Bill of Materialsを選択します。 Bill of Materials for PCB Document ダイアログが表示されます。 

 

2. このダイアログで、BOMを作成します。 レポートに含めたい各欄の Show オプションを有効にします。 

3. All Columns リストから部品を選んで、Grouped Columns リスト にドラッグすると、コンポーネントが BOMのデータ
タイプごとにグループ分けされます。 たとえば、Footprintでグループ分けしたい場合は、Footprint を All Columns リス
トで選んで、Grouped Columns リストにドラッグします。. レポートはそれにしたがって、ソートされます 

4. Open Exported オプションを有効にして、CSV を File Format として選びます。Export ボタンをクリックすると、BOM 
ファイルが生成され、すぐに CSV ビューア（たとえば、Microsoft Excel）に表示されます。 BOM には多くのオプション、
その他のレポートがあり、非常に高度な柔軟性で、レポートの定義、組織化を可能にしています。 ダイアログを閉じます。 

お疲れ様でした。 これで、PCB設計プロセスは完成です。 
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より詳細な調査のために 
このチュートリアルでは、Altium Designerの強力な機能のいくつかを紹介しました。 回路図をキャプチャし、PCBのデザイ
ンと配線を行いました。しかし、これらは Altium Designerが提供している強力なデザイン機能のほんの一部に過ぎません。 
一度、Altium Designer について調べ始めると、より「ラク」な設計を可能にする豊富な機能群を見出すでしょう。 Altium 
Designer の可能性を確認できるように、多くのサンプルファイルも添付されています。 それらのファイルは、通常、メニュー
から File » Open を選択し、Altium Designerがインストールされているディレクトリの\Examples のフォルダを開いて参照す
ることができます。 このフォルダ内には、ボードデザインのサンプルファイルの他に、Altium Designerの特別な機能を備えた
サンプルファイルが保存されている多くのサブフォルダも含まれています。 

Circuit Simulation サブフォルダを確認して、Altium Designerのアナログ、デジタルシミュレーションの可能性を確かめてくだ
さい。 アンプや電源などのアナログのサンプルファイルによる回路設計のさまざまなデモとだけでなく、混在モードのサンプ
ル、関数のサンプル、ソース依存型線形/非線形のサンプル、真空管などサンプルがあります。 

ロジックのスイッチング、デザインクロックスピードの更なる高速化に伴い、デジタル信号の質も、ますます重要になってい
きます。 Altium Designerには、洗練された伝送線路解析ツールが含まれていて、ボードレイアウトを正確にモデル化し、分析
することができます。 伝送線路解析に必要な設定、インピーダンス、オーバーシュート、アンダーシュート、スロープなどは、
PCB デザインルールで定義され、標準のデザインルールチェックで検査されます。 

より詳細な解析が必要なネットがある場合は、Tools » Signal Integrity を選択し、デザインに伝送線路解析（Signal Integrity 
Analyzer）を実行し、そこで反射やクロストークシミュレーションを確認することができます。 結果は、オシロスコープのよ
うな波形アナライザに表示されますので、実行内容の検証や、波形からの直接測定ができます。 

この入門チュートリアルをご覧いただき、ありがとうございました。 
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更新履歴 
 

Date Version No. Revision 

22-Jan-2004 1.0 New product release 

24-Nov-2004 1.1 Updated for DXP 2004 SP2 

13-Apr-2005 1.2 Updated for Altium Designer 

25-Jul-2005 1.3 Reference to Board Shape & Sheets tutorial renamed to Preparing the Board for Design Transfer. 
Updates for SP4. 

28-Nov-2005 1.4 Updated for Altium Designer 6 

31-Oct-2006 1.5 Updated for Altium Designer 6.6 

17-Oct-2007 1.6 Updated with new dialog box and 3D references for Altium Designer 6.8 

21-Dec-2007 1.7 Updated with 3D component body tutorial for 6.9 

22-Jan-2008 1.8 Updated view configuration info, removed STEP model import info to TU0103 document (beyond scope 
of this tutorial) for 6.9. 

1-Feb-2008 1.9 Minor typos fixed. 

12-Feb-2008 2.0 Changed component body references to 3D body. 

22-Feb-2008 2.1 Converted to A4. 

9-Apr-2008 2.2 Updated with interactive routing and 3D body dialog box for "Summer 08". 

21-May-2008 2.3 Removed component 3D body building section. Added references to TU0103 (library components 
tutorial) and TU0132 (MCAD integration tutorial). Amended routing and project outputs section for S08. 
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