Altium Wiki

Information and resources for electronic product designers

Skip to end of metadata
Go to start of metadata
最新情報

メンター・グラフィックス PADS からの移行

他社製 CAD の PADS データを Altium Designer へインポートする方法をご紹介しています。
以下をご参照ください。

https://jp.resources.altium.com/%E3%83%A1%E3%83%B3%E3%82%BF%E3%83%BC-%E3%82%B0%E3%83%A9%E3%83%95%E3%82%A3%E3%83%83%E3%82%AF%E3%82%B9-pads%E3%81%8B%E3%82%89%E3%81%AE%E7%A7%BB%E8%A1%8C

Related Training Videos

以下のリンクは、他の設計ツールのデータを Altium Designer へ移行するための方法が記載されています:

 

 

このアーティクルでは、他の設計ツールから Altium Designer へ移行する時の鍵となる概念を説明します。それは、Altium Designer の機能をどのように導入して、柔軟なエレクトロニクス製品開発環境を使用して生産性を向上させるか確認します。 

設計ファイルのインポート

Main article: Importing and Exporting Design Files

エレクトロニクス製品設計をある設計環境から他へ移行できます。設計ツールを変更、または他の会社からデザインを入手した場合、回路図、または PCB デザインを Altium Designer へインポートする必要があります。 

Altium Designer では、様々な異なる設計ツールからデザインをインポートするためにインポートプロセスを統一します。Importer Wizard は、プロジェクトの回路図と PCB 間の関連を管理するのと同様に、それらの両方を扱いインポートします。 

Importing Wizard では、新しいインポーターを容易に追加できます。 

Altium Designer の環境

Main articles: The Altium Designer Environment, Altium Designer Panels

Altium Designer の環境は、FPGA デザイン、開発やオンチップデバッギングと同様に、回路設計から PCB 出力の生成までデザインの全ての領域についてエレクトロニクス製品開発環境を提供します。その環境はカスタマイズでき、作業に適したワークスペースを設定できます。Altium Designer の環境内で別のエディタを介してセレクションを保持したり編集して、様々な設計タスクを容易に切り換えできます。  

Altium Designer で作業し始める時に注意する最も大きな違いの1つは、ファイルのタイプ(回路図、PCB、ライブラリ、テキスト等)に関わらず、全ての設計ファイルを作成、編集するために使用したアプリケーションは1つだけであると言うことです。回路図を表示している状態から PCB へ移行したい時、異なるアプリケーション間を切り換える必要はありません。ファイル(ドキュメントとも言います)は同じアプリケーション上で開くことができ、Altium Designer 内で独立したドキュメントタブで表示されます。あるタイプのドキュメントから他へ移動する時、そのドキュメントを編集するための環境になるようにメニューやツールバーは自動で切り換わります。

ヘルプの参照

Main article: Documentation and Help

Altium Designer の操作方法を理解するためのベストな方法として、以下のようなヘルプを参照する方法があります:

  • 簡単な内容説明が記載されている Knowledge Center パネルを表示するには、オブジェクト、エディタ、パネル、メニュー、ボタン上で F1 を押します。
  • コマンドで実行できるショートカットのリストを表示するには、コマンドを実行している時に Shift+F1 を押します。 
  • Knowledge Center パネル、または Altium Wiki Website で Altium Wiki を検索します。 
  • タスクを完了するために必要な正確なステップの詳細について短いトレーニングビデオを見るには、TRAININGcenter へアクセスしてください。 
  • 仲間と一緒に考えを共有するには、フォーラムへ参加してください。 

プロジェクトベースのデザイン

Main article: Project Management

Altium Designer で作成した各デザインの開始点はプロジェクトファイルです。多くのプロジェクトタイプがあります(例えば、PCB プロジェクト、Library プロジェクト、FPGA プロジェクト、Embedded プロジェクト、Core プロジェクト、Script プロジェクト)。特定のプロジェクト設定と同様に、プロジェクトファイルは設計ドキュメントへのリンクを保存します。 

マルチチャンネルデザイン

Main articles: Multi-Channel Design Concepts, Creating a Multi-channel Design

インストール時に含まれているマルチチャンネルデザインがあります。これらには、Multi-Channel Mixer、Peak Detector、PortSwitcher が含まれており、インストールフォルダ(\Examples\Reference Designs フォルダ)に保存されています。コンパイルするサンプルを開いたら、回路図エディタの下部でコンパイルしたドキュメントタブを探します。

複雑な階層は、回路図の階層で複数の同じシートを使用するプロセスを描写するために産業で使用する一般的な表現です。複雑な階層を含むデザインでは、コンポーネントやネットを固有にするために階層を 'フラット'、または '拡張' するプロセスを行う必要がありました。Altium Designer ではこれを行う必要はありません。そのため、この機能は複雑な階層ではなくマルチチャンネルデザインと呼ばれます。 

親シートシンボルからパラメータを渡すことで異なる各チャンネルを作成できる機能をサポートします。これはパラメータ階層と呼ばれます。 

各チャンネルで同じ値を持たないコンポーネントになるように、パラメータ階層を使用してコンポーネントの値を定義できます。パラメータコンポーネントは、上階層のシートシンボルのパラメータとして値を宣言して定義します。これによりターゲットコンポーネント上のパラメータを参照します。 

プリファレンス

Main article: Altium Designer Environment Preferences

全体的なプリファレンスは、メニューから DXP»Preferences を選択してアクセスします。ここで設定したプリファレンスは、インストールの一部として保存されます。これは設計ファイルと同期しません。各エディタの Design メニューを介してアクセスする回路図のドキュメントオプションや PCB のオプションはファイル特定の設定です。  

PCB レイアウトとデザイン

ボードレイアウトは、物理的なレイアウトと配線と共にデザインの定義を統一するデザインシステムに頼ります。Altium Designer では、容易にボードを配置、配線できる機能を含む PCB システムを利用できます。PCB エディタがアクティブである(例えば、PCB ドキュメント (*.PcbDoc) が開いてアクティブである状態)時、メインアプリケーションウィンドウは以下を含みます:

  • 2D、3D で設計できるメインデザインウィンドウ 
  • PCB エディタ用のメニューとツールバー
  • 全般的な、エディタ特定のワークスペースパネル 

ビュー設定とレイヤスタックマネージャ

ビュー設定は、2D、3D 環境の PCB ワークスペース画面のオプションをコントロールするための設定で PCB や PCB ライブラリエディタへ適用します。最後に使用したビュー設定は、PCB ドキュメントを保存する時に保存されます。 

メインメニューから Design»Board Layers & Colors (ショートカット: L) を選択して、View Configurations ダイアログを表示します。または、下図のようにメインツールバーのドロップダウンを使用して設定を切り換えます。  

Layer Stack Manager を開くには、メニューから Design»Layer Stack Manager (ショートカット D, K) を選択します。Layer Stack Manager ダイアログに現在のボードのレイヤスタックが表示されます。信号層とプレーン層は追加、削除、順番を変更できます。厚さ、ネット(プレーン層)、比誘電率のようなレイヤ属性を設定するには、電気的な、または絶縁体のレイヤをダブルクリックします。  

PCB ボードオプション - ドキュメント設定

配置グリッド、単位、シート位置、デジグネータの表示モードに関するオプションは、Board Options ダイアログで設定します。Board Options ダイアログを開くには、メインデザインウィンドウで PCB ドキュメントがアクティブである時にメニューから Design»Board Options (ショートカット D, O) を選択します。 

マルチチャンネルデザインのために、PCB で論理的、または物理的なデジグネータのどちらを表示するか Board Options ダイアログで選択できます。

PCB ボードウィザード

回路図エディタから PCB エディタへデザインを移行する前に、少なくともボード外形があるブランクの PCB ファイルを作成する必要があります。PCB ボードウィザードでは、カスタムボードのサイズで作成するのと同様に、業界の標準のボード外形を使用して基本的な PCB デザインを容易に作成できます。PCB ボードウィザードは、Files パネルの New from template の項目から実行します。どの段階でもウィザードの前のページを確認、または修正するために Back ボタンを使用できます。 

インタラクティブ配線

Main article: PCB 配線

Altium Designer ではインタラクティブ配線モードがあります。インタラクティブ配線モードはライセンスオプションに依存せず、PCB エディタで利用できます。

デザインルール

Main articles: デザインルール, Creating Design Rules, デザインルールチェック, Scoping Design Rules

Altium Designer の PCB エディタは、ルールで実行する設計環境です。また、他のボードからデザインルールを移行できます。デザイルールは、下図のように PCB Rules and Constraints Editor ダイアログを介してエクスポート、インポートできます。 

インポートするには右クリックメニューから Import Rules を選択します。Choose Design Rule Type ダイアログが開きます。

シグナルインテグリティ

Main articles: Performing Signal Integrity Analyses, Signal Integrity Analysis, Signal Integrity Rules, Signal Integrity Panel

DRC のための標準のデザインルールに加えて、Altium Designer では PCB エディタ(Tools»Signal Integrity)へ統合されたシグナルインテグリティ解析をサポートします。これは、回路図、または PCB エディタから実行できる配線前、配線後のシグナルインテグリティ解析機能を含みます。また、事前に定義したテストに対してネットスクリーニング結果を評価し、選択したネットの反射やクロストーク解析を実行して波形を表示します。また、termination advisor を使用して適切な終端値を計算します。 

回路シミュレーション

Main article: Circuit Simulation

回路シミュレーションは回路設計の一部で、回路図編集環境と一緒に統合されています。回路シミュレーションを実行する前に、プロジェクト内の回路図シートが開いていることを確認します。Design » Simulate » Mixed Sim コマンドからシミュレーションを実行する前に、シミュレーションモデルは回路図ドキュメントの各コンポーネントと関連している必要があります。シミュレーションはプロジェクト全体で実行されます。  

PCB 設計の詳細について

Compilation - Altium Designer の基礎

Compilation は Altium Designer 環境の基本概念です。Compilation は、多くの設計機能を利用できるプロセスです。 
Project » Compile Project を選択する時、compilation プロセスはプロジェクトのソース回路図(または、HDL)ドキュメント間の構造を構築します。それから、各シート内でネットレベルの接続を決め、最後にシート間の接続を決めます。回路図のコンポーネントや接続は、回路図間の相違の比較、表示、パラメータ管理、デザインのナビゲーション、回路図と PCB 間やその他のクロスプローブのような内部データ構造に書かれます。

デザインのネットやコンポーネントはどこ? 

接続情報は、デザイン上で明確に存在するのではなく compilation プロセスを使用してデザインから抽出する必要があります。これは、Projects パネルで右クリックして表示されるメニューから、または Project » Compile Project メニューコマンドを使用して利用できます。 

デザインをコンパイルすると、コンポーネント、ネット、バスと同様にシートレベル階層が Navigator Panel に表示されます。ここから、全体のデザインを通して容易にコンポーネント、バス、ネット、ピンの位置を見つけることができます。Navigator Panel で Alt キーを押しながらオブジェクトをクリックした場合、それに相当するオブジェクトが PCB 上でハイライトされます。そのため、デザインの接続を確認するためにネットリストを調べる必要はありません。  

デザイン接続の設定

Main article: Connectivity and Multi-Sheet Design

Altium Designer は異なるタイプの接続をサポートします。これは、デザインの構造に合う設定にする必要があります。シート同士の接続のタイプは *Net Identifier Scope と呼ばれます。これは、Options for Project ダイアログの Options タブで定義し、プロジェクトと一緒に保存されます。Project メニューから Project Options メニューコマンドを選択し、Options タブをクリックします。  

Net Identifier スコ-プは Project Options の Options タブで設定します。

Net Identifier Scope のドロップダウンで以下の接続オプションを選択できます:

  • Automatic (Based on project contents)
  • Flat (Only ports global)
  • Hierarchical (Sheet entry <-> port connections)
  • Global (Net labels and ports global)

Import Wizard は移行プロセスを通して自動で接続を処理し、デフォルトで Automatic (Based on project contents) に設定されます。階層ブロックはシートシンボルとしてマップされます。Automatic モードでは、デザインコンパイラはトップシート上にシートシンボルで表示します。もし、その中にシート全体(階層のピン)がある場合、それは縦の接続と仮定されます。そして、内部で Hierarchical オプションを使用します。シートシンボルがトップシート上に無い場合、またはシートシンボルはあるがシートエントリが含まれていない場合、横の接続と仮定されます。Altium Designer はこれをサポートする Flat と Global の2つの方法があります。これらの2つのオプションのどちらかを決めるために、デザインコンパイラはサブシート上でポート、またはオフシートコネクタを探します。もし、それらがある場合、Flat オプションを使用し、ポートが無い場合、Global オプションを使用します。 

変換後、Projects メニューから Project Options ダイアログを通して設定を容易に変更できます。  

デザインの確認 - 拡張されたエラーチェック 

Main articles: Project Compiler Error Reference, Compile Errors Panel

Altium Designer でプロジェクトをコンパイルするその他の利点は、エラーをレポートする機能が内蔵されていることです。これは、プロジェクトをコンパイルする前に設定できます。プロジェクトファイルを右クリックして Project Options コマンドを選択、または Project メニューを使用します。 

デザインの同期

Main article: Finding Differences and Synchronizing Designs

Altium Designer では、デザインを同期するためにネットリストを渡す必要が無く、統合されています。Altium Designer での同期は双方向で、1つの操作で回路図、PCB 間のアノテーション変更やコンポーネント属性の更新を行えます。 

コンポーネントとライブラリ

Main article: Component, Model and Library Concepts

回路図と PCB を別の組織で設計している時、Altium Designer では理想的にソースシンボル、またはモデルライブラリから直接、作業できます。 

論理シンボルは、本質的なコンポーネントの開始点と仮定されます。これは、ピン、グラフィカルシンボル、選択表示オプションを追加するものへ、回路図ライブラリの名称として最低限、最初に定義できます。これは、設計中、コンポーネントを異なる方法で表現できます。これは、回路図の論理シンボルだけでなく、PCB のフットプリント、またはシミュレーションの SPICE 定義にもなります。 

ライブラリはどこ? ライブラリ管理の基本 

Projects パネルを通して移行後、ソース回路図や PCB ライブラリファイルを表示できます。移行したライブラリは自動で1つの PCB プロジェクトへまとめられます。 

開いている全てのプロジェクトでコンポーネントを利用できるようにするには、ライブラリを Altium Designer 環境へ導入(追加)します。Libraries パネルからライブラリを導入、削除できます。また、ライブラリはどんなプロジェクトにもリンクでき、シミュレーションモデルを参照するために役立つプロジェクト検索パスも定義できます。 

データベースリンクの注意点

Main articles: Linking Existing Components to Your Company Database, Using Components Directly from Your Company Database

多くの設計者は、エレクトロニクスデザイン ソフトウェアのコンポーネントから会社のデータベースへリンクすることを求めます。Altium Designer では設計プロセスを通して部品表含めデータベースのデータをリンク、移行できます。 

2つの方法をサポートします。1つは、Altium Designer のライブラリシンボルはモデルリファレンスを保有し外部データベースへリンクできます。2つ目は、データベースがモデルリファレンスや他の会社の情報を保有できます。Altium Designer のデータベース接続がデフォルトの MS Access データベース (*.mdb ファイル) の場合、ODBC 準拠のデータベースへアクセスできます。  

複数のモニターをサポート

Altium Designer は複数モニターをサポートします。もし、複数のモニターを持っている場合、Altium Designer から容易にドキュメントをドラッグし、2番目のモニターへドロップできます。複数モニターを使用するかどうか設定は Windows で設定します。 

プロジェクト出力

Altium Designer Viewer

Main article: Welcome to Altium Designer Viewer

Altium Designer Viewer は、Altium Designer を使用して作成した設計プロジェクトやドキュメントを素早く、容易に、安全に read-only で扱えます。ユーザーは、Altium Designer で作成したデザインの全ての面を表示、印刷、確認できます。そして、全体の設計チェーンを通して設計データをアクセスできるようにします。Viewer は組織内で共同化を強化するだけでなく、設計チームと外部の人との間の設計作業フローやプロジェクトの生産性を改善させます。 

Altium Designer Viewer は 無償ダウンロード で、ライセンスは必要ありません。 

参照

Labels
  • None